О программе
Возврат в начало

TherCyc v2.1 является программным интерфейсом для работы с амплификатором ТП4-ПЦР-01 - "Терцик" и позволяет:

создавать и редактировать программы амплификации: Редактор программ

проверять состояние запущенных программ в приборе: Состояние прибора

непрерывно сканировать ход выполнения программы амплификации для конкретно выбранного
термоблока прибора (диагностика прибора): Сканирование программ

С помощью TherCyc v2.1 стало возможным:

запускать и останавливать программы амплификации
считывать из прибора и записывтаь в прибор программы амплификации
удалять программы из прибора
распечатать текстовый код и графический образ программы амплификации
провести поиск подключенных приборов и определить их состояние (запущенные программы)
и др. (см. Инструментальная панель приложения)


Амплификатор

ТП4-ПЦР-01 - "Терцик" представляет собой многоканальный (4 канала) программируемый терморегулятор и предназначен для проведения полимеразной цепной реакции (ПЦР) в клинико-диагностических и научных лабораториях.
В настоящее время выпускается две версии прибора: Терцик-МС2 [image] и Терцик [image].


Терцик-МС2
Прибор версии 3.0 и ниже. Не позволяет создавать и редактировать программы амплификации без помощи компьютера.


Терцик
Прибор версии 4.0 и выше. Позволяет создавать и редактировать программы амплификации без помощи компьютера.


Инструментальная панель приложения

Ниже представлена инструментальная панель, которая служит для непосредственного доступа к основным функциям приложения TherCyc v2.1:

- создание новой программы амплификации
- открыть существующую программу с диска компьютера
- сохранить программу амплификации на диск компьютера
- вывести на печать текст и графический образ программы амплификации

- открыть программу амплификации из прибора
- записать программу амплификации в прибор

- запустить программу амплификации из редактора программ
- запустить программу амплификации с компьютера
- остановить запущенную программу с компьютера
- непрерывное сканирование программы амплификации

- считать группу программ из прибора в компьютер
- записать группу программ в прибор с компьютера

- удалить группу программ из прибора

- статус приборов

- выход из приложения


Создание новой программы

- Очищает поле Редактора программ от предыдущей программы амплификации и позволяет ввести другую программу.


Открыть программу

- Выбирает существующую программу амплификации (* .apm *.APM) с диска компьютера и открывает ее в поле Редактора программ.


Сохранить программу

- Выбирает директорию на диске компьютера, имя файла и сохраняет текущую программу амплификации, находящуюся в Редакторе программ.


Печать программы

- Выводит на печать полную информацию о программе амплификации (включая графический образ программы)


Открыть программу из прибора

- В диалоговом окне интерфейса с прибором выберете интересующий прибор, программу амплификации и клавишей [image] откройте ее в Редактор программ:


Записать программу в прибор

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и клавишей [image] запишите программу амплификации из Редактора программ в прибор:

Замечание: Для записи программы амплификации в прибор Терцик-МС2 [image] появляется индикатор для выбора номера программы, под котором программа и будет располагаться в дальнейшем:


Запустить программу из редактора

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и клавишей [image] запишите программу амплификации из Редактора программ в прибор:

затем выберете номер термоблока и запускайте программу:


Запустить программу в приборе

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и программу амплификации:

затем выберете номер термоблока и запускайте программу:


Остановить программу в приборе

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и работающую программу амплификации:

затем выберете номер термоблока (возможно, что одна программа запущена в несольких термоблоках) и запускайте программу:


Сканировать программу в приборе

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и программу амплификации, которую собираетесь диагностировать:

затем выберете номер термоблока:

и в соответствующем окне сканирования предстанет графический образ исследуемой программы:

Далее см. Сканирование программы амплификациии.


Считать группу программ из прибора

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и интересующую группу программ амплификации:

для выделения группы программ пользуйтесь комбинацией (Shift + лев.клавиша мыши) и (Ctrl + лев.клавиша мыши)

затем необходимо выбрать директорию, в которой хотите сохранить эту группу программ:


Записать группу программ в прибор

- из стандартного диалога выбора файлов на диске компьютера выберете интересующую группу программ для записи в прибор:

для выделения группы программ пользуйтесь комбинацией (Shift + лев.клавиша мыши) и (Ctrl + лев.клавиша мыши)

затем в диалоговом окне интерфейса с прибором выберете нужный прибор:

при этом появляется каталог программ для записи в прибор.

Замечание: Для прибора Терцик [image] максимально возможное число программ ограничивается 28, а для Терцик-МС2 [image] это ограничение составляет 16 программ.

Замечание: (только для Терцик-МС2 [image] ) В случае копирования группы программ с одного прибора в другой (другие), когда порядок следования программ в приборе важен, необходимо сделать следующие шаги:

считать интересующую группу программ из прибора в отдельную директорию на диске компьютера, а затем
записать эту группу программ в нужные приборы.


Статус приборов

- производит опрос состояния подключенных приборов:


Удалить группу программ из прибора

- В диалоговом окне интерфейса с прибором выберете интересующий прибор и интересующую группу программ для удаления из прибора:

для выделения группы программ пользуйтесь комбинацией (Shift + лев.клавиша мыши) и (Ctrl + лев.клавиша мыши)

Замечание: Удаление программ с компьютера возможно только для прибора Терцик [image] .


Меню приложения

Ниже представлено меню приложения TherCyc v2.1:

Разделы меню Файл полностью дублируют Инструментальную Панель приложения.

Разделы меню Настройки содержат следующие пункты:

- Показать текстовый код программы, которая находится в текущий момент в редакторе программ амплификации.
- Провести измерения выносного термодатчика в одном из термоблоков.
- Провести поиск новых подключенных приборов.

Разделы меню Help содержат справочную информацию о TherCyc v2.1


Текстовый код программы

- Позволяет просмотреть текстовый код программы, которая находится в текущий момент в редакторе программ амплификации:


Выносной термодатчик

- выберете номер термоблока, в котором необходимо провести измерения выносного термодатчика (см. Сканирование программы амплификации)


Поиск новых подключенных приборов

- производит поиск приборов для определения конфигурации подключенных приборов;

эту процедуру необходимо производить всякий раз после подключения нового прибора к компьютеру (в том числе и при подключению существующего прибора к другому Com порту);
у пользователя есть возможность присвоить прибору свой личный псевдоним для большей наглядности в распознавании приборов

Эта процедура запускается автоматически после установки приложения!!!


Диалоговое окно интерфейса с прибором

Ниже представлено стандартное диалоговое окно интерфейса с прибором в случае операций чтения, записи, удаления и запуска программ амплификации в приборе.

Замечание: Для приборов Терцик-МС2 [image] нумерация в списке программ выглядит несколько иначе: только программы с номерами 1-1,1-2 и т.д. находятся в энергонезависимой памяти прибора и соответствуют режиму "4/16" ручного запуска программ (см. Паспорт на ТП4-ПЦР-01-"Терцик"):


Редактор программы амплификации

Редактор программ амплификации предоставляет пользователю возможность создавать новые и редактировать существующие программы.

Ниже приведены основные пункты создания/редактирования программы амплификации (порядок следования этих пунктов не обязательный):

Введите необходимую информацию об имени программы и кол-ве рабочей смеси в пробирке:

Выберете нужный тип регулирования:

Создание программы амплификациии:

Последовательно заполните поля температур и времен (минуты, секунды). Ввод каждого нового значения заканчивается нажатием клавиши <Enter>.

После определения всех параметров (температура, минут и секунд) текущего шага в блоке автоматически появляется новая строка с пустыми полями для ввода следующего шага.

Для завершения блока необходимо нажать <Enter> не определяя температуру и время нового шага. При этом мы переходим к редактированию значения кол-ва повторов в блоке. Нажатие клавиши <Enter> заканчивает ввод нового значения "Числа циклов" и осуществляется переход для ввода нового блока.

Для ввода блока "пауза" либо "хранение" необходимо выбрать соответствующее значение в поле "Тип блока". Режим "хранение" может находится только в конце программы.

Для более гибкого создания и редактирования уже созданных программ амплификации предусмотрены функциональные клавиши, позволяющие добавлять/удалять строки и блоки программы:

Не допускайте в программе пустых полей ввода значений температур и времен!!!

В ходе создания/редактирования программы, при вводе каждого нового значения температуры или времени появляется графический образ программы амплификации:

Для просмотра/редактирования, сохранения, печати программ амплификации пользуйтесь соответствующими кнопками Инструментальной панели.


Состояние прибора

Диагностика состояния прибора прозволяет визуально оценить текущий момент выполнения программ амплификации в каждом из 4-х термоблоках:
Для диагностики состояния прибора необходимо выбрать интересующий прибор из предлагаемого списка приборов:


Сканирование программы амплификации

Сканирование программы амплификации позволяет детально исследовать ход выполнения программы в каждом из 4-х термоблоков прибора:

Сканирование программы амплификации предпологает, что программа уже находится в памяти прибора. Поэтому, если вы хотите запустить вновь созданную программу, то ее необходимо сначало записать память прибора (см. Инструментальная панель приложения).

Для сканирования программы амплификации необходимо:

запустить процедуру запуска программ:

в диалоговом окне интерфейса с прибором выбрать необходимую программу;

выбрать номер термоблока (1 из 4-х) :

в соответствующем окне появится графический образ запускаемой программы: программа готова к запуску;

Подобным способом можно подготовить к запуску все 4 термоблока...

Если данная программа уже запущена на выполнение в данном термоблоке, то сканирование начинается с текущего (выполняемого в данный момент) блока.

сканирование процесса амплификации в ходе выполнения программы:

Cканируемую программу можно остановить и вручную(традиционным способом): используя управляющие кнопки на передней панели прибора.

Замечание: Не рекомендуется проводить какие-либо операции с прибором (чтение, запись, удаление программ) с прибором в котором запущены программы амплификации!