- DataGraf -
Самая компактная в мире
картографическая система

Короткий вводный практикум для тех, кто впервые запустил DG

Итак, вы только что запустили программу и увидели небольшую панель с несколькими незнакомыми кнопочками. Поместите курсор мыши на каждую из них и вы увидите выскакивающую текстовую подсказку о ее назначении. Это реализовано во всех режимах и если вам непонятно назначение конкретной кнопки, почитайте текстовую подсказку. В самом левом окошке вы видите надпись TEST - это тестовый проект, в котором есть несколько небольших баз данных, позволяющих вам сходу "пощупать" DG.

Сразу к интересному

Нажмите кнопку [image] - "Картография" и вы увидите, что открылось основное картографическое окно. Из левого верхнего меню (синий шрифт) выберите базу данных "Россия по алфавиту", из окошка рядом (красный шрифт) - показатель (ряд даннных) "Числ.населения - 2001". Обратите внимание, что на самой нижней панели картографического окна печатается развернутое описание выбранного показателя. Нажмите расположенную рядом кнопку "Карта" с уже знакомым значком [image] и вы увидите, что на экран будет выведена карта с распределением численности населения по регионам страны. Однако картинка будет не очень красивой - часть ее не будет видна, а легенда закроет часть карты...

Изменим стиль

Из правого нижнего меню "Стиль" (голубой фон) выберите название "Россия" - вы заметите, что окно программы изменило свои размеры и теперь карта видна полностью. Еще раз выведите карту, повторно нажав кнопку "Карта" - теперь вы видите картинку в том виде, который определен стилем "Россия". Для любой серии карт вы можете сформировать и сохранить собственный стиль, который простым выбором из меню изменяет много параметров для вывода карты.

Пробуем основные функции

Последовательно нажмите расположенные рядом кнопки [image] [image] [image] [image] - вы увидите различные этапы построения комбинированного изображения - эти 4 функции последовательно выполняются при нажатии кнопки "Карта". Зачем это нужно? Выберите базу данных "Экосистемы-Бассейны" и показатель "Флора общая в России". Нажмите [image] и [image] - вы получите карту природного деления страны, отличающегося от административного, но без нарисованных границ. Далее обратно выберите базу данных "Россия по алфавиту" и нажмите кнопку "Сетка" - [image]. На карте природного деления отрисуются административные границы, что позволит более комфортно и осмысленно анализировать полученный образ.

Меняем палитру

Выберите показатель "Числ.населения - 2001" и нажмите кнопку "Карта" [image]. Теперь из меню "Палитра" выбирайте любое название и перерисовывайте картинку кнопкой "Карта". Вы видите как при этом меняется цветовое решение всего изображения.

Пробуем дополнительные функции

Из меню "Стиль" выберите пункт "Россия большой" - вы заметите, карта того же самого показателя будет выглядеть абсолютно по другому - это увеличенное ее изображение в другой палитре. Протяните движками изображение до конца вправо-вниз, чтобы была видна только дальневосточная часть страны и нажмите кнопку "Карта", чтобы появилась легенда. Теперь можно работать только с видимым фрагментом этой карты.
Нажмите на панели кнопку с буквой "И" (информация). Теперь по любому двойному щелчку мыши на карте в нижней (информационной) панели окна будет выводиться информация о значении показателя в данном регионе - попробуйте на нескольких регионах.
Нажмите на панели кнопку с буквой "Т" (текст). Точно так же попробуйте два раза щелкнуть мышью на разных регионах - на карту выводятся их названия. Этим способом можно за считанные секунды надписать названия нужных вам регионов.
Нажмите на панели кнопку с буквой "Д" (данные). По двойному щелчку мыши на карту выводятся значения выбранного показателя в данном регионе.

Экспортируем изображение

Откройте чистый документ в Microsoft Word. Перейдите в DG и нажмите кнопку "Копировать" [image], затем вернитесь в Word и нажмите кнопку "Вставка" - вы увидите изображение всей карты, вставленное в ваш документ. Теперь в DG нажмите кнопку "Копировать фрагмент" [image] и вставьте в документ - сравните полученный результат. Этим способом вы можете работать не только со всей картой, но и с любым ее фрагментом, видимым в картографическом окне. Закройте Word, он нам больше не нужен.

Работаем с точечными объектами

Из меню стилей выберите стиль "Москва", затем базу данных "Москва-мал", а в ней показатель "Максимально". Выведите карту - вы увидите уже не Россию, а картосхему Москвы по административным округам. Теперь сразу же выберите базу данных "Москва-точки", а там показатель "Половинка-1" - мы начинаем работу с другим типом объектов - точечным. Нажмите кнопку "Точечные объекты" [image] и в появившемся окне выберите из меню пункт "Молния", а также отожмите нажатую кнопку "Цвет". Закройте эту панель крестиком - сейчас мы определили вид точечных объектов. Теперь нажмите знакомую кнопку "Карта" и вы увидите, что поверх существующего изображения нанесены пиктограммы с изображением молнии - тем самым мы на одной карте совместили площадные и точечные объекты. Вновь нажмите кнопку "Точечные объекты" [image], в меню выберите пункт "Мухомор" и закройте панель крестиком. После этого выберите другой показатель - "Половинка-2" и нажмите кнопку "Карта". Тем самым мы дополнили нашу иллюстрацию еще одним показателем, отображенным другой пиктограммой. Этим способом можно комбинировать на одной карте площадные и точечные объекты - каждый со своей легендой.
Теперь очистите окно [image], выведите сетку [image] и карту [image] - так производится работа с индивидуальными точечными объектами.

Пишем текст

Нажмите кнопку "Писать текст" [image] - чуть ниже этой кнопки прямо на карте в белом прямоугольнике замигает текстовый курсор - введите несколько слов с клавиатуры. Теперь кнопкой [image] выберите шрифт - например курсив, размер 9. Вы заметите, что написанный вами текст изменил начертание и размер. Напишите еще что-нибудь и вы заметите, что вводимый текст автоматически переносится и форматируется по центру. Поместите курсор мыши прямо на ваш текст и нажмите правую кнопку мыши - вокруг текстового окна появится рамка, размеры которой можно стандартным способом изменять, "зацепив" за ее края. Изменяя размеры рамки, отформатируйте ваш текст, чтобы он смотрелся красиво. После этого при нажатой левой кнопке мыши внутри рамки "оттащите" ее на нужное (свободное) место и завершите редактирование, надав клавишу Enter - курсор в рамке перестанет мигать, ваша надпись в неизменном виде останется на карте. Вы имеете очень простое и удобное в обращении средство нанесения надписей на ваши на карты в WYSIWYG-режиме (что вижу, то и получаю). Теперь можете нажать на кнопку "Записать" [image] и сохранить ваши труды у себя на диске в одном из форматов, поддерживаемых вашей операционной системой.

Мы попробовали основные приемы работы в картографическом режиме, более подробно о работе каждого из них см. в документации на систему. Теперь закройте картографическое окно крестиком и вернитсь к основному модулю-меню.

Что мы видели?

Просмотр данных

В картографическом режиме мы видели лишь результат работы программы, теперь посмотрим на основании чего строятся увиденные нами картинки. Нажмите кнопку "Редактор данных" [image] - появится окно, по внешнему виду напоминающее Microsoft Excel - это собственный табличный процессор DG, позволяющий просматривать и редактировать исходные данные. Из меню слева выберите базу "Россия по алфавиту" - таблица заполнится значениями всех показателей, имеющихся в вашей базе данных. Их можно как просматривать, так и редактировать любую цифру, название или описание. Обратите внимание, что размеры окна можно изменять и расширить его, например, на весь экран для вашего удобства. Закройте окно редактора - нам пока достаточно было просто посмотреть на данные.

Ввод новых данных

Новый показатель можно ввести вручную в табличном редакторе, который мы только что видели, однако давайте посмотрим иной, более быстрый и удобный способ, который к тому же обеспечивает взаимодействие с привычными всем программами - например Excel. В директории (папке) с программой есть тестовый файл Test.xls. Откройте его, а в нем выберите закладку Russia - там увидите 2 колонки с данными - B и C, выделите обе эти колонки и скопируйте в буфер обмена (копируйте только колонки с данными, а не названия регионов).
Теперь в DG нажмите кнопку "Операции с данными" [image], а там в левом меню (синего цвета) выберите базу данных "Россия по алфавиту" - нижний список заполнится названиями имеющихся показателей. Теперь просто нажмите кнопку "Вставить из буфера" [image] - всё, в вашей базе данных появились 2 новых показателя (вставленных после первого), которые вы передали в DG из другой программы. Проще не бывает, не правда ли?... Далее вы можете посмотреть только что вставленные данные в табличном редакторе или сразу построить по ним картограммы.

Пересчет - научно-прикладная задача

В картографическом режиме вы уже видели карту России не административного, а природного деления - она существенно сложнее и имеет не 89, а 461 пространственный выдел, соответственно и один ряд данных там содержит 461 цифру. На практике первичные данные собираются и систематизируются по наиболее удобной классификации - например, запасы гумуса в почвах собираются в разрезе естественных природных выделов. А если стоит вопрос оценки этой величины в разрезе административных регионов (например для принятия решений), то это уже становится сложной научно-прикладной задачей, над которой работают серьезные коллективы ученых. Давайте решим эту задачу за несколько секунд.
Итак, нам нужно пересчитать запасы гумуса с природной сетки (461) на административную(89). В окне "Операции с данными" выберите в левом меню (синий цвет) базу данных "Экосистемы-Бассейны", а в правом (красный) - "Россия по алфавиту". Найдите в левом окне (последний) показатель "Гумус в 1 м слое т/га", "зацепите" его мышкой и "перетащите" в правый список, поставив, например вторым по порядку. Теперь нажмите кнопку "Пересчет" [image] - вы увидите счетчик, отсчитывающий число регионов с 89 до 1 - это производится решение нашей научно-прикладной задачи, которое на самом деле очень сложное и может занять до нескольких десятков секунд. Однако по завершении операции вы будете иметь в базе данных "Россия по алфавиту" очень точно посчитанный показатель запасов гумуса (уже в административном разрезе), который можете посмотреть в "Картографии", там же визуально сравнить с "родным" и убедиться в адекватности пересчета.
Закройте окно операций с данными, там есть еще много возможностей, но этим мы для первого знакомства ограничимся

Если хочется большего...

Расчеты и проверка гипотез

Помимо только что с успехом решенной научно-прикладной задачи, DG позволяет вам ставить и решать свои собственные, экспериментировать с проверкой гипотез и моделей, попутно пополняя базы данных новыми - рассчитанными показателями. Покажем технологию на небольшом примере. Нажмите на главной панели кнопку "Вычислитель" [image], из появившегося меню выберите базу данных "Россия по алфавиту", а в появившемся списке показатели:
a - Площади тыс.кв.км
b - Числ.населения-2001
c - Занятых в экономике
Отмечать их нужно просто нажатием мышки - при этом они выделяются синим. Отметив эти 3 показателя, нажмите на кнокпку "Завершить выбор" - вид окна изменится, слева вы увидите список только что выбранных показателей, а справа окошко для ввода выражения. В это окошко можно вводить формулы, используя в качестве обозначений показателей буквы, которыми они отмечены в списке (a, b, c) и любые операторы, список которых приведен выше.
Давайте прикинем в каких регионах страны наибольший процент занятого в экомике населения - то есть посмотрим отношение занятого населения к общей численности. Для этого в окошке напечатаем простую формулу - c/b и нажмем клавишу Enter (или кнопку "Расчет"). На экране сразу появится карта - результат наших расчетов - из которой следует, что этот процент больше всего в северо-восточных регионах страны (красный цвет). Действительно, там меньше всего пенсионеров, много "вахтовиков" и тех, кто едет подзаработать. Картографический образ сразу навеял мысли, идеи, гипотезы... Попробуйте сами с другими показателями - наверняка окажется полезным.
Однако вывод, который мы сделали, кажется нам тривиальным, поэтому просто нажмем на кнопку с крестиком или клавишу Esc и вернемся обратно к окну ввода формул. Дальнейшие эксперименты оставим на ваше усмотрение, а сейчас сделаем полезное дополнение нашей базы данных еще одним показателем, который может быть часто востребован - Плотность населения. Для ее расчета введите в окошко формулу b/a и нажмите клавишу Enter или кнопку "Расчет". Обратите, кстати, внимание, что картина получилась обратной предыдущей - во всех северо-восточных регионах плотность минимальна (но это к слову...). Нам этот показатель нужен в базе данных, поэтому введите его название, а затем более подробное описание. Никогда не экономьте десяток секунд на ввод описания - оно вам же через полгода поможет разобраться в том, что вы успели к этому времени подзабыть! Нажмите кнопку "Запись" [image] и ваша база данных пополнена новым показателем "Плотность населения", который наверняка пригодится в дальнейшей работе.
Теперь можете закрыть окно вычислителя, войти в "Картографию" и посмотреть, как выглядят все новые показатели, которыми мы дополнили нашу базу данных в ходе этого небольшого ознакомительного практикума.

Здесь мы рассмотрели лишь наиболее общие особенности работы с DG, многие дополнительные возможности и особенности работы в разных режимах смотрите в подробной документации на систему.

Создание вашей собственной карты

Этот раздел практикума относится только к официальным
пользователям DG, имеющим картографический редактор

Процедура создания вашей собственной векторной карты для работы в DG проста - вы готовите список регионов будущей карты, картинку с их границами в формате BMP, а затем просто указываете мышкой какой регион где расположен, всю остальную оцифровку программа делает автоматически. Для начального практикума в директории (папке) TEST находятся два предварительно подготовленных файла: Mos-Test.txt и Mos-Test.bmp, используя которые вы меньше, чем за минуту создадите полностью работоспособную карту и привязанную к ней базу данных.
Загрузите картографический редактор, нажав на главной панели кнопку "Редактор карт" [image]. В нем нажмите кнопку с тем же изображением - "Новая карта" и из папки TEST выберите файл Mos-Test.bmp - на экране появится контурная карта Москвы с административными округами. Далее по кнопке "Новый список" [image] выберите файл Mos-Test.txt со списком названий округов. Обратите внимание, что в окошке (синим цветом) появилось первое название - "Восточный округ". Теперь вам нужно указать программе, где на карте находится этот округ (думается, что вы без труда определите, что он самый правый). Поместите курсор ближе к его центру и нажмите левую кнопку мыши - контур закрасится красным. Убедившись, что закрашено именно то, что вам нужно, нажмите кнопку "Записать координаты" [image] - контур перекрасится в зеленый цвет, значит он уже оцифрован, а в окошке появится название следующего округа - "Юго-Восточный"...
Повторите всю процедуру для оставшихся 9-ти округов. После того, как все контура будут закрашены зеленым, а список исчерпан, программа выдаст сообщение о начале векторизации, а затем о полной готовности карты - все делается автоматически, вам остается только наблюдать. По окончании оцифровки готовая векторная карта будет отображена красным цветом, теперь можно закрывать редактор карт, войти в картографию и посмотреть результат - для новой карты программа всегда делает новую базу данных с тем же названием, куда пишет один тестовый показатель.
Новая карта и база данных всегда называется так же, как и текстовый файл со списком регионов - в нашем примере Mos-Test.
Теперь вы можете попробовать ввести в новую базу данных свои показатели вручную или дополнить ее из файла Test.xls, выбрав там закладку Moscow с тремя пробными показателями. Созданная вами карта Mos-Test полностью идентична уже существующей в проекте TEST карте "Москва-мал", так что после нескольких пробных экспериментов вы можете в режиме "Проекты-базы данных" [image] без сожаления ее удалить. Вам важен лишь опыт, который вы почерпнули из ее создания и который наверняка пригодится при оцифровке ваших собственных картографических проектов.

Приятной и успешной работы!

Владимир Артюхов, vart@aha.ru 2006 ©