- DataGraf -
Самая компактная в мире
картографическая система

ЧТО ТАКОЕ DG - НАЗНАЧЕНИЕ И ПРИНЦИПЫ РАБОТЫ

Зачем нужен DG? Карты и диаграммы неспроста являются основным средством для выражения количественных закономерностей - в отличие от таблиц с цифрами, они дают нам образ явления и позволяют буквально с одного взгляда оценить общую картину, отметить различия и почувствовать закономерности. Именно этой особенностью человеческого восприятия объясняется широкое использование графических пакетов и картографических систем в иллюстративных и аналитических целях. DataGraf (DG) - это чрезвычайно простая, компактная и быстрая программа, позволяющая с минимальными усилиями превратить ряд числовых данных по каким-либо пространственным выделам в емкий картографический образ.

DG - это ГИС? Обычно для создания картографических иллюстраций на основе числовых рядов используют ГИС - Географические Информационные Системы (ArcView, MapInfo и т.д.). Однако это очень сложные, объемные и дорогие программы, поскольку предназначены для решения специальных географических задач, а не для создания иллюстраций широким кругом пользователей. Модуль Misrosoft Map, встроенный в Excel, также не решает этой задачи, поскольку является разновидностью одной из известных ГИС, наследует основные принципы ее реализации и ориентирован на использование только готовых цифровых карт (если вам нужна карта своего региона, то подразумевается, что вы ее купите или закажете оцифровку у фирмы). При этом для иллюстративных и даже аналитических целей полноценная цифровая карта и не нужна - если вас интересует образ, общие закономерности явления или просто картинка в отчет, то точные географические координаты, по которым строится карта, вряд ли заинтересуют. Именно эту нишу в ряду картографические программ и занимает DG - это не ГИС, он создает не географические карты, а картограммы (по принятой у географов классификации) и не использует при их построении понятия географических координат. Поэтому везде далее под более привычным словом "карта" будет иметься в виду "картограмма". DG - не ГИС, а средство для простроения картограмм. Сколь-нибудь известных программ этого класса сегодня на рынке нет.

Кому нужен DG? Программу по достоинству оценят те, кто занимается аналитической картографией - это очень удобный и гибкий инструмент для визуализации данных, моделирования ситуаций, построения синтетических показателей. Программа наверняка пригодится и тем, у кого есть потребность просто подготовить картографическую иллюстрацию к курсовой, диплому, отчету и т.д. И, наконец, исключительная простота, компактность и неприхотливость делают DG непревзойденным средством для изучения основ компьютерной картографии - в школах, колледжах и ВУЗ-ах. Не исключено, что программа покажется полезной и профессиональным географам для решения отдельных прикладных задач (социальных, экономических и т.д.).

Что умеет DG? DataGraf - не просто программа, а полностью самодостаточная картографическая система, включающая в себя все необходимое для создания полноценных баз данных и карт буквально "с нуля - и под ключ". Система позволяет:
- создавать ваши собственные векторные карты (площадные и точечные), используя в качестве заготовки любую подходящую картинку
- содавать для каждой карты неограниченное число привязанных к ней тематических баз данных с числовой информацией
- заносить и редактировать числовые данные вручную, из буфера обмена, внешнего файла
- производить копирование, удаление, перестановку данных, обмен между базами, а также автоматический пересчет показателей между двумя базами разной структуры
- экспортировать данные в другие приложения через буфер обмена и файлы
- любой ряд числовых данных представлять в виде карты
- карта может произвольно масштабироваться без потери качества
- любая карта может иметь произвольное цветовое решение, для чего есть встроенный редактор палитр
- параметры легенды и карты можно произвольно изменять, для чего есть встроенный редактор стилей
- на карту может быть выведен заголовок и произвольное число других подписей - любым шрифтом и размером, с прозрачным или сплошным фоном
- по щелчку мыши на карте можно получить информацию в данной точке, вывести на карту название региона, а также значение текущего показателя любыми шрифтами
- возможна работа с двумя и более картами одной территории, но разных принципов деления
- полученное изображение можно записать на диск в любых форматах, поддерживаемых вашей операционной системой
- изображение карты целиком или ее фрагмента можно записать в буфер обмена для передачи в другие программы
- помимо площадных объектов (регион) можно работать и с точечными (населенный пункт) объектами
- точечные объекты могут быть представлены геометрическими фигурами или любыми вашими пиктограммами (с прозрачным и непрозрачным фоном), способы их графического представления можно менять
- для точечных объектов предусмотрена собственная независимая легенда, параметры которой также могут произвольно изменяться.
- для карт одной территории возможна одновременная работа с площадными и точечными объектами (как картографическое наложение, так и пересчет значений показателей)
- уникальной особенностью системы является встроенный формульный вычислитель, позволяющий по задаваемой вами формуле производить операции с рядами данных и записывать полученный результат в виде нового показателя
- вычислитель имеет собственное картографическое окно, в котором вы сразу видите результат расчета в виде карты, что позволяет очень быстро и удобно проверять различные соотношения и моделировать ситуации.

Вся эта "начинка" располагается в двух файлах, суммарный объем которых около 350 Кбайт (заметье - не Мегабайт, а Килобайт!). Иными словами, на одну обычную дискетку свободно запишутся четыре копии полностью работоспособной системы (сравните с любыми другими картографичесими программами). Насколько известно автору, по соотношению функциональность/размер DG является самой компактной картографической системой в мире! (С удовольствием сниму это утверждение, если кто-то напишет еще более компактную).

Как такое получилось? На самом деле DG не был придуман в один прекрасный день, а имеет за собой 15-тилетнюю историю. Начиная с 1990 года постепенно, по кирпичику, придумывались и оттачивались идеи, алгоритмы и в конце концов появился DataGraf для DOS, который в свое время был достаточно популярен. Эта программа - просто реализация тех же идей под Windows, причем, в минимально необходимом наборе. Для простоты работы с системой целый ряд чисто аналитических функций было решено не встраивать в программу - не исключено, что они будут добавлены в будущих версиях. Так что добро пожаловать в старый новый DataGraf !

ОСНОВНЫЕ ПОНЯТИЯ И СПЕЦИФИКА ДАННЫХ

Исходя из главных принципов работы, основными типами данных в DG являются числовые массивы и карты. При описании операций с первичной числовой информацией будут использоваться следующие базовые понятия.

Показатель - базовый элемент данных DG. Это ряд числовых данных, в котором каждое число описывает значение показателя в отдельном регионе. Тем самым показатель - это числовой вектор, длина которого соответствует числу регионов на карте. Обращение к показателю в системе для различного рода операций производится по его имени (названию). К примеру, если мы в вычислителе показатель "Численность населения" делим на показатель "Площади", то получаем показатель "Плотность населения" - ряд данных, в котором представлена плотность населения для всех регионов страны. Каждый показатель в DG помимо названия (до 20 знаков) может иметь более подробное описание, которое хранится в базах данных вместе с ним и выводится там, где это необходимо.

База данных (или просто База) - набор показателей, относящихся к одной карте и (как правило) к одной тематической области. Для одной и той же карты в DG может существовать любое число баз данных (для разных тематических областей или просто решаемых задач).

Проект - совокупность Баз данных, обычно объединенных тематикой решаемых задач. При этом базы данных могут быть привязаны к картам с различными принципами деления, но объединенными общей территорией - например Россия с административным, природным, бассейновым делением и т.д. Проект представляет собой директорию (папку) на диске, внутри которой находятся все базы и карты. Настоятельно рекомендуется для разных территорий заводить разные проекты, а не "валить в кучу" например, карты России, Московской области, Петушков и Рязани. Число проектов в DG может быть любым.

Отсутствие данных и "ноль".

DG предназначени для иллюстративных и аналитических целей, когда более важен смысл показателя, нежели конкретный числовой результат. Поэтому при работе с числовыми данными выделяются в самостоятельные категории следующие смысловые понятия:

"Ноль" как самостоятельная смысловая величина. Например производство автомобилей или самолетов в большинстве регионов страны будет нулевым и только в нескольких из них будет отличным от нуля. "Ноль" в данном случае является абсолютным минимумом для данного типа показателей. Все нулевые значения в этом случае остаются на карте белыми (не закрашиваются). В базу данных вводятся как число "0".

"Ноль" как промежуточное значение числового ряда. Например диапазон зимних температур по стране колеблется от -20 до +5оС, где значение 0оС не имеет самостоятельного значения и нет смысла выделять его из прочих данных. На карте выводится обычным образом - то есть цветом, соответствующим месту в диапазоне шкалы градаций. В базу данных также вводятся обычно - как число "0". Отличие от предыдущего случая в том, что "ноль" не является здесь абсолютным минимумом. Все различия первого и второго случаев в DG определяются автоматически и вданном случае "ноль" отображается на карте соответственно его положению в ряду остальных данных.

"Ноль" как отсутствие данных. Если ряд данных по стране неполный (есть информационные пробелы в отдельных регионах), то в условиях неопределенности (не знаем какие же там значения), графические и вычислителные операции теряют корректность. А если вместо отсутствующих данных ввести "ноль", как это делается в большинстве программ, то можно потерять даже смысл конечного результата. Поэтому в DG существует как отдельная категория метка "нет данных", которая вводится в базу данных как пустая клетка, а на карту выводится специальным цветом (по умолчанию светло-голубой), для которого зарезервирована последняя ячейка в палитре . Регионы, для которых введена метка "нет данных" не участвуют во всех расчетных и графических операциях с данным показателем и, соответственно, не влияют на окончательный результат.
Имейте в виду эти особенности работы с "нулем", так как они специфичны только для DG и позволяют сделать полученные результаты в смысловом отношении более корректными.

ОСНОВНЫЕ ОГРАНИЧЕНИЯ

Несмотря на свой более, чем скромный размер, DG является достаточно мощной программой и не накладывает практически никаких ограничений на размер и объемы данных, с которыми работает. Количество проектов, баз данных, показателей в базе и чисел в одном показателе может быть любым. Однако всему есть предел и вы сами устанете искать нужный показатель в списке из 10 000, поэтому разумные количественные ограничения на все эти величины накладываете вы сами и они диктуются прежде всего соображениями удобства работы. Именно с этими соображениями и связаны основные ограничения, которые накладывает DG на форматы первичных данных. Связано это с тем, что при работе все списки (проектов, баз, показателей) представлены в виде выпадающих меню. Понятно, что если длина строки в таких меню будет большой, то работать с ними станет неудобно, да и полезного места на панели они отнимут немало. Поэтому в DG приняты следующие объективные ограничения для текстовых атрибутов:

  • Название проекта - до 20 знаков
  • Название базы данных - до 20 знаков
  • Название показателя - до 20 знаков
  • Описание показателя - до 80 знаков.

Это компромисс между смыслом и эргономикой, отнеситесь к нему с пониманием и не удивляйтесь, если программа не дает вам ввести более длинную строку, а лучше придумайте разумное сокращение. Как правило это удается без особого труда.
Кроме того, при оцифровке ваших карт имейте в виду, что есть объективное ограничение - в одном векторе (отдельном регионе на вашей карте) может быть до 1024 точек (узлов, на которых отрезок линии меняет направление). Как правило, вектора среднего размера и сложности имеют размер в 100-200 точек, поэтому на практике вы навряд ли столкнетесь с этим ограничением, однако имейте в виду, что оно существует и программа его отслеживает.

ФАЙЛЫ, НЕОБХОДИМЫЕ ДЛЯ РАБОТЫ

Для нормальной работы системы необходимо наличие на диске следующих файлов, стирать или изменять которые нельзя:
DG.exe - картографическая система
DGMEd.exe - картографический редактор
DG.chm - этот файл справки
index.dg - список проектов (создается в ходе работы)
palette.dg - ваши палитры (создается в ходе работы)
Кроме этого в рабочей директории в процессе работы создаются поддиректории (папки), в которых расположены все данные для ваших проектов. Никакие файлы программой непосредственно в директории проектов для вашего удобства не пишутся - используйте их для хранения своих данных, изображений и т.д. Для размещения собственных рабочих файлов внутри каждого проекта DG автоматически создает свою поддиректорию с названием MAP. Типичная файловая структура ваших проектов следующая:
ПРОЕКТ-1 ( директория)
файлы с вашими данными
. . . . . . . . . . . . . . . . . . . . . . .
MAP ( поддиректория)
имя_карты.dgm - файлы с векторными картами
имя_карты.bak - резервная копия файла карты
название_базы.dg - файлы с базами данных
название_базы.$$ - резервная копия файла базы данных
dg.sty - файл с вашими стилями для данного проекта
пиктограммы.bmp - любое число ваших файлов с пиктограммами для точечных объектов
ПРОЕКТ-2
ПРОЕКТ-3
. . . . . . . . . . .
ПРОЕКТ-N

Не изменяйте файлы, расположенные в директориях MAP, иначе нормальная работа программы не гарантируется. Единственное, что допускается делать здесь вручную - это переписывать или удалять bmp-файлы с вашими пиктограммами.

ФУНКЦИИ СИСТЕМЫ

Работа с данными
Проекты и базы данных
Редактор данных
Операции с данными
Картография
Основные режимы работы
Работа с палитрами
Работа с текстом
Работа со стилями
Точечные объекты
Расчеты
Вычислитель
Создание карт
Картографический редактор

Приятной и успешной работы!

Владимир Артюхов, vart@aha.ru 2005 ©


DataGraf

В этом режиме производится работа с крупными блоками данных - Проектами и Базами данных, которые могут содержать сотни, тысячи, десятки тысяч первичных цифр, поэтому будьте особо внимательны!

ПРОЕКТЫ

Проект - это отдельная директория (папка) на диске, где расположены базы данных (БД), карты и данные, относящиеся к одной определенной тематике. Понятие проекта структурирует и существенно облегчает работу в DG. К примеру, не имеет смысла держать вместе БД и карты, относящиеся в Росси в целом, Московской области или Подольскому району - для каждого из этих объектов лучше завести самостоятельную директорию (папку) на диске, что позволит избежать серьезной путаницы. Планируя какое-либо серьезное тематическое исследование (даже с копиями существующих карт и БД), заведите для него новый проект.
Количество проектов, с которыми работает DG, не ограничено.
Список имеющихся проектов выводится в левом выпадающем меню основного модуля DG. Для перехода к желаемому проекту, выберите его название из списка. С этого момента все режимы DG настроены на работу с картами и данными этого проекта.

Создание нового проекта

В окошко под надписью ПРОЕКТЫ - "Создать новый" введите уникальное название для вашего нового проекта и нажмите расположенную рядом кнопку. Проект создан, можно начинать работу.
Внимание! Так как проект - это директория на диске, при задании его имени не используйте спецсимволы операционнной системы, такие, как ? . * . Во избежание дальнейших ошибок, программа их автоматически заменяет на подчеркивание. Название проекта не должно превышать 20 символов в дину.

Проект по умолчанию

При запуске DG по умолчанию текущим выбирается самый первый проект в списке, что не всегда удобно, так как Вы можете работать с другим проектом и его придется каждый раз выбирать из списка. Для того, чтобы назначить проект по умолчанию, с которого всегда будет начинать работа DG, в окошке ПРОЕКТЫ - "По умолчанию" выберите название нужного и нажмите расположенную рядом кнопку. С этого момента при запуске DG этот проект всегда будет текущим.

Удаление проекта

В программе не предусмотрено возможности автоматически удалить проект, так как при этом по неосторожности можно потерять огромные массивы важной информации. Однако, если какой-либо проект Вам стал более не нужным и Вы в этом полностью уверены, то можете сделать это вручную. Для этого:

  • удалите вручную одноименную директорию (папку)
  • откройте файл index.dg, расположенный рядом с программой, в любом текстовом редакторе, найдите название проекта, поставьте курсор на первую букву названия и удалите ровно 20 символов. Если этот проект был не последним, то курсор после этого должен стоять на первой букве следующего названия.

При удалении будьте внимательны - если стерты больше или меньше 20-ти символов, то меню проектов "разъедется" и выбирать их станет затруднительно. Пользуйтесь этой возможностью только в случае крайней необходимости.

Внимание! При создании проекта внутри той директории (папки), имя которой вы задали, автоматически создается поддиректория с фиксированным названием MAP. Программа пишет в нее только свои служебные данные - не удаляйте там никаких файлов! Для вашей информации используйте основную директорию проекта или создайте внутри нее любое число других.

БАЗЫ ДАННЫХ

База данных (БД) - вторая по иерерхии операционная единица DG после проекта. Она представляет собой совокупность показателей (рядов числовых данных), относящихся к карте с определенным типом деления. На диске БД представляет собой один файл, в котором компактно записана вся необходимая для работы информация. Все файлы баз данных имеют название заданное_вами_имя.dg.
Количество БД в одном проекте не ограничено.
Создание структуры новых БД производится в режиме картографического редактора, а для остальных операций с БД целиком предназначены следующие режимы DG.

Копия базы данных

Рано или поздно в БД накапливается столько показателей, что не только найти нужный, но и просто листать ее становится делом затруднительным. Не доводите ваши БД до такого состояния и не обрекайте себя на бесконечное листание длинных списков - просто сделайте пустую копию и перенесите туда нужные показатели. После этого сами заметите, насколько легче и быстрее стало работать.
Для создания копии БД в окошке БАЗЫ ДАННЫХ - "Создать копию, удалить" выберите название базы, копию которой Вы собираетесь делать. После выбора в окошке "Новое название" появится название исходной базы - измените его - это будет название вашей копии. Нажмите кнопку со значком копирования и в текущем проекте под новым именем будет создана точная копия выбранной БД, в которую будет перенесен один показатель. В пустой копии он нужен для удобства - чтобы хоть что-то можно было посмотреть в картографии или редакторе данных - не стирайте его сразу, а лучше удалите позже, заполнив базу несколькими своими показателями.
Внимание! Копия БД ничем не отличается от оригинала, она остается привязанной к той же самой карте и обладает той же самой функциональностью. Копия занимает на диске только то место, которое нужно для имеющихся в ней данных, при копировании не создается никаких дополнительных файлов. Поэтому свободно создавайте копии БД для решения, например, отдельных тематических задач, тем более, что по их завершении ненужные базы можно будет просто стереть.

Удаление базы данных

Ставшие ненужными БД можно удалить, чтобы освободить место на диске и облегчить листание списков. Для этого в окошке БАЗЫ ДАННЫХ - "Создать копию, удалить" выберите название базы и нажмите кнопку с изображением корзины. Программа дважды запросит у Вас подтверждения на удаление, чтобы дать возможность подумать, после чего удалит выбранную базу.
Внимание! Удаление производится физически, поэтому будьте особо внимательны, чтобы потом не жалеть о тех усилиях, которые были затрачены на ввод данных в случайно стертую базу.
Если все же неприятная случайность произошла, то поищите директории MAP вашего проекта файл с названием Имя_Стертой_Базы.$$ - это ее резервная копия. Переименуйте расширение этого файла в Имя_Стертой_Базы.dg и постарайтесь в дальнейшем быть повнимательнее.

Переименование базы данных

При необходимости переименовать имеющуюся базу данных в списке БАЗЫ ДАННЫХ - "Переименовать" выберите нужную БД, после чего ее название появится в расположенном рядом окошке. Отредактируйте это название и нажмите кнопку с изображением текста. С этого момента во всех списках ваша БД будет фигурировать под новым названием.

Копирование БД в другой проект

Новый проект Вы можете создавать не только "с нуля", но и для решения каких-то задач с уже имеющимися БД и картами. Для заполнения пустого проекта имеющимися данными в списке БАЗЫ ДАННЫХ - "Скопировать" выберите базу данных из текущего проекта, затем в списке "в проект" выберите название нужного и нажмите расположенную рядом кнопку. Выбранная БД будет скопирована целиком, причем, не только данные, но и соответствующая карта, что позволит сразу начать работу. Если карта той же самой структуры уже существует в проекте, то она не переносится, а копируется только БД, в которую автоматически заносится ссылка на имеющуюся карту. То есть последний случай по смыслу аналогичен созданию в новом проекте копии базы, но с переносом всех данных.
Перенос БД осуществляется только из текущего проекта (выбранного из списка в главном модуле DG). При необходимости копирования из другого проекта, вернитесь в главный модуль, смените проект и повторите процедуру.

Внимание! В соответствии с основными ограничениями DG, длина названий проектов и баз данных не должна превышать 20 символов. Поэтому все текстовые окошки в описанных выше режимах, не дадут Вам ввести название длинее 20-ти знаков. Имейте это в виду заранее, придумывая название для нового проекта или базы данных.
После выхода из режима "Проекты - Базы данных" в основном модуле DG производится полное обновление списка проектов и текущим становится первый, поэтому если до этого был выбран какой-то другой проект кроме первого, для продолжения работы с ним выберите этот проект еще раз.


РЕДАКТОР ДАННЫХ

Редактор данных - единственный режим в DG, где основным элементом является одно число, это самый нижний уровень иерархии данных. В этом режиме Вы можете ввести вручную один или несколько рядов данных, а также исправить любую цифру.

Приемы работы

Тот, кто хоть однажды работал в MS Excel, найдет работу в редакторе данных DG столь же простой и интуитивно понятной. Ряд данных здесь - это столбец, в котором цифры расположены в порядке следования регионов, список которых печатается слева. Выбор базы данных для редактирования производится в выпадающем меню, раположенном слева вверху. После выбора БД на редактирование выводятся все показатели, имеющиеся в базе, в виде одной большой таблицы, которая может стандартным образом протягиваться вверх-вниз и вправо-влево. В ячейке на пересечении названий показателей и регионов представлены две цифры - текущее число показателей в базе и количество регионов. Это может быть полезным для ведения статистики Ваших баз данных.
Количество показателей (рядов данных) в DG не ограничено, в отличие от MS Excel, допускающего до 255 столбцов.

Перед началом работы Вы можете увеличить размер поля для редактирования (таблицы), для чего достаточно "потянув" за правый нижний угол окна, задать его новые размеры. Если у Вас хорошее разрешение экрана, то таблицу можно сделать достаточно большой, что облегчит восприятие, хотя прокручиваться она при этом будет немного медленнее.

Текущая ячейка, в которой производится редактирование в данный момент, выделена желтым цветом. Перемещать ее можно в видимой части таблицы просто щелкнув мышью по нужной ячейке или при помощи следующих клавиш:

  • стрелка вверх - перемещение на 1 строку вверх
  • стрелка вниз - перемещение на 1 строку вниз
  • клавиша TAB - перемещение на 1 колонку вправо
  • SHIFT+TAB - перемещение на 1 колонку влево
  • PageUP - на 1 страницу вверх
  • PageDOWN - на 1 страницу вниз

Все остальные клавиши предназначены для редактирования текста внутри ячейки. Отредактировав текст, не обязательно нажимать Enter, он автоматически запоминается при любом перемещении курсора.

Название и описание текущего показателя (столбца данных, на котором расположен курсор) печатаются в двух текстовых окошках, расположенных сверху. Обратите внимание, что текст в них меняется при перемещении ячейки редактирования между рядами данных. Текст в этих двух окошках может быть произвольно отредактирован в любое время и запишется в измененном виде при сохранении базы данных.
Внимание!. Согласно основным ограничениям DG, длина названия показателя не должна превышать 20 символов, а его описания - 80 символов. Поэтому не удивляйтесь, когда программа не дает Вам ввести в соответствующие поля более длинную строку, а подумайте о ее сокращении.
Кроме того, обратите внимание, что при увеличении размеров окна редактора пропорционально увеличивается и поле для редактирования (более длинного) описания. Тем самым, увеличив размер окна редактора, Вы можете избежать необходимости "протягивать" 80 символов описания в более коротком окошке.

Сохранение произведенных изменений производится при нажатии кнопки с изображением дискетки. Настоятельно рекомендуется при редактировании больших объемов данных периодически нажимать на эту кнопку во избежание досадных недоразумений (например со сбоями в электричестве).

Ввод нового показателя

При любой загрузке данных на редактирование (выборе БД) редактор в конце таблицы выделяет 20 пустых столбцов для ввода новых показателей. Переместитесь в конец таблицы и поставьте курсор на любое место в самом первом пустом столбце - при этом название и описание показателя должны быть пустыми. Начните ввод именно с названия и описания - переместитесь мышью в эти поля и введите туда соответствующий текст. Теперь поставьте курсор на первую строчку пустого столбца и введите числовые значения для всех регионов. Аналогично поступайте для ввода второго и всех следующих показателей, обращая внимание на то, чтобы новый показатель всегда вводился в первый пустой столбец таблицы и у него всегда имелось название и описание. Дело в том, что при записи данных DG не пишет в базу данных пустые столбцы, а останавливает запись, когда находит первый пустой столбец без названия. Поэтому если между введенными Вами данными и остальной таблицей остался пустой столбец, то все данные после него просто не будут записаны и труд пропадет даром.
Если Вам требуется единовременно ввести больше 20-ти показателей поступите следующим образом. Введите первые 20, запишите их, выберите любую другую базу, а затем вновь ту, в которую вводите данные - редактор даст Вам еще 20 пустых столбцов и можете продолжать ввод.

Внимание! В DG имеется понятие "нет данных" - их отсутствие, которое по смыслу отличается от понятия "ноль". В базах данных и на картах эти величины отличаются от "нуля" и отображаются особенным цветом или меткой. В редакторе данных такой меткой является пустая ячейка (обратите внимание на примеры). Иными словами, если Вы желаете различать понятия ноля и отсутствия данных, то при вводе чисел нулевые значения обозначайте "0", а там, где "нет данных" просто оставляйте ячейку пустой. Позже Вы заметите, что на карте регионы с отсутствующими данными выводятся особенным цветом, а во всех вычислениях эти значения игнорируются, что намного корректнее, нежели заменять их нулем.

Редактор данных DG - не табличный процессор, поэтому он выполняет сугубо специальную функцию - просмотра, ввода и редактирования чисел. Выполнение операций вырезания, копирования, вставки (как это делается например в Excel) здесь не очень удобно, так как сопряжено с листанием вперед-назад длинных таблиц. Все эти манипуляции в DG выполняются более удобными средствами в режиме операций с данными, где работа ведется не с числами, а с показателями - рядами данных, как единым объектом. Оперируете Вы там только с названиями, что делает работу очень быстрой и удобной.


Этот модуль DG предназначен для работы с показателями - рядами данных по всем выделам карты. При помощи несложной панели из двух окошек и нескольких кнопок вы сможете проделать практически все необходимые операции при работе с рядами данных, как целостным объектом. Имейте в виду, что все, описываемые дальше процедуры относятся к базам данных, карты для которых площадные, а работа с базами, привязанными к точечным объектам описывается в специальном разделе. Обратите внимание на основные принципы устройства этой панели, что позволит быстрее понять и освоить работу в этом режиме, после чего она окажется очень простой, быстрой и удобной:

  • Левое окно - основное. В нем выводится список показателей той базы, с которой вы работаете - основной. Выбор базы осуществляется из списка, расположенного над этим окном.
  • Правое окно - рабочее. Оно может быть или пустым или содержать список показателей второй - вспомогательной - базы. Выбор ее также производится из списка, расположенного над окном. При выборе как той, так и другой базы над списком выводится число выделов в каждой базе, что сразу позволяет определить совместимость этих баз и пригодится в дальнейшем.
  • Принцип работы прост - при нажатой левой кнопке, вы мышью перетаскиваете нужные позатели из левого (основного) окна в правое - пустое или со списком.

В зависимости от того, что выбрано в правом (вспомогательном) окне, вам становятся доступны следующие основные 8 режимов работы с данными.

Правое окно | Режим работы
Пустое, база не выбрана | Вставка данных в основную базу из файла или буфера обмена (Clipboard)
Перетащили несколько показателей, база не выбрана | Экспорт выбранных показателей в файл или копирование их в Clipboard (буфер обмена). Удаление выбранных показателей из основной базы
Выбрана та же самая база, что и в левом окне (основная) | Перестановка местами показателей в основной базе
Выбрана копия основной базы - то же самое число выделов, но не сама основная база | Копирование показателей из основной базы в выбранную копию
Выбрана база другой структуры, чем основная | Пересчет значений выбранных показателей на карту другой структуры и запись результата в эту базу.

В зависимости от перечисленных выше сочетаний, часть кнопок для выполнений той или иной функции дезактивируются (становятся серыми и недоступными), а активными остаются только те, которые предназначены для выполнения соответствующий функций. Кроме того, над кнопками выводится текстовая подсказка с перечнем доступных режимов, что может (особенно поначалу) помочь в выборе нужной функции. Хотя, на самом деле, описание этого режима работы намного сложнее, чем собственно работа - стоит вам несколько раз попробовать и все эти на первый взгляд запутанные сочетания окажутся простыми, логичными и удобными, а сама работа быстрой и приятной.
Следует также отметить, что при перетаскивании показателя в другое окно, он всегда исчезает из исходного. Это делается для того, чтобы вам не запутаться и не перенести один показатель дважды или трижды, а потом не удалять лишнее. Однако исчезновение показателя не означает, что он будет удален из этой базы! Удаление происходит только если вы выберете режим "Удалить", во всех остальных случаях исходная база данных остается нетронутой - происходит только копирование выбранных показателей.

Обратите внимание на специфику работы с пустым окном, что позволит избежать многих вопросов! При перетаскивании объекта в пустое окно, Windows позволяет вставить его только в самую первую позицию (списка еще нет). Поэтому "зацепив" показатель в основном окне и "перетащив" в пустое, не пытайтесь "бросить" его где-то в середине пустого списка - это бесполезно. "Бросайте" его на самой верхней границе пустого окна, тогда результат вам гарантирован. Впрочем, после непродолжительной "тренировки", это у вас будет получаться автоматически.
Стоит попутно заметить, что второй показатель вы сможете вставить только перед первым, а вот уже для всех последующих можно будет выбирать произвольное место внутри списка - обратите внимание, что на левой границе окна будет появляться стрелка, указывающая место между элементами списка, куда можно вставить новый показатель. Тем самым, если вы планируете записать в файл или передать в Clipboard список в определенной последовательности, то первым "перетаскивать" следует самый последний показатель, т.к. ниже него вы ничего уже вставить не сможете. А вот вторым вполне может быть и первый показатель, ниже которого вы сможете уже вставить третий, четвертый и т.д.

Вставить данные в базу из файла

В левом окне основная рабочая база, правое пустое. Протянув при необходимости список, щелкните мышью в то место, куда вы собираетесь вставлять данные. Данные будут вставлены после выбранного показателя, если ничего не выбрано, то данные будут вставлены в начало списка, после первого показателя. Нажмите кнопку с иконкой "Открыть" и выберите имя файла с данными, после чего они будут автоматически вставлены в указанное место, в чем можно убедиться сразу же. Для импорта-экспорта данных DG использует текстовые файлы, что очень удобно, т.к. вы можете передать данные коллегам, даже вставив их в текст E-mail. Формат файлов будет описан ниже, стандартное расширение файлов с данными *.dgf.

Вставить данные в базу из буфера обмена (Clipboard)

В левом окне основная рабочая база, правое пустое. Выделите данные в другом приложении, которым вы пользуетесь (например Excel) и скопируйте их в буфер (Ctrl+Ins, Ctrl+C). Затем перейдите в DG и, протянув при необходимости список, щелкните мышью в то место, куда вы собираетесь вставлятьданные. Нажмите кнопку "Вставить" и если данные в буфере соответствуют по структуре выбранной базе , они будут вставлены в выбранное место. Если программа "не узнает" свой формат данных, она выдаст сообщение об ошибке - это происходит: a) если в буфере находится не текст, b) текст, но не в формате DG, c) текст в формате DG, но из базы другой структуры. При подготовке или обработке данных во внешних программах во избежание проблем с переносом в DG соблюдайте структуру данных, образец которой вы будете иметь перед глазами каждый раз, вставляя (например в Excel) скопированные в DG данные.
Замечание. Если общая структура импортируемых данных может быть отслежена автоматически, то последовательность переносимых чисел полностью лежит на вашей ответственности. Для нормальной работы DG числа должны быть расположены в строгом соответствии с последовательностью регионов в базе данных. Если количество цифр совпадает, а последовательность не соблюдена, программа без проблем вставит данные в базу, но с точки зрения логики они не будут иметь для вас никакого смысла. Что делать, если нужно вставить в базу данные другой структуры, смотрите в Приложении.
Внимание! Копировать данные можно не только во внешнем приложении, но и в другой базе DG. Если вы наберете и скопируете в буфер список показателей в одной базе, а затем перейдете к другой базе той же структуры (например ее копии), то они без проблем вставятся в указанное вами место. Это способ обмена блоками данных между базами DG в дополнение к имеющемуся режиму непосредственного переноса в нужное место, который будет описан ниже.

Удалить выбранные показатели

В левом окне основная рабочая база, в правое перенесли один или несколько показателей. Перенесите ставшие ненужными показатели в пустое окно и нажмите кнопку "Удалить". После предупреждения, дающего возможность подумать над своими действиями, выбранные показатели будут навсегда удалены из базы данных.
Замечание. Удаление показателей производится физически, с уплотнением базы данных. Их восстановление невозможно. Поэтому не спешите нажимать красную корзинку, а лишний раз проверьте - те ли показатели вы собираетесь удалить.
Внимание! Если все же вы нажали на корзинку, а чуть позже вас прошиб холодный пот от содеянного... Конечно же лучше этого не допускать, но уж коли случилось, то придется немного поработать руками. В директории (папке) с именем проекта расположена поддиректория MAP. Найдите в ней файл с названием вашей пострадавшей базы, но расширением .$$ - это резервная копия. Удалите основной файл с расширением .dg (или лучше перенесите в другую директорию), а затем переименуйте расширение файла .$$ в .dg. Все - вы имеете базу в состоянии, предшествующем удалению. Следует отметить, что эту операцию лучше делать сразу после обнаружения ошибки, если после этого делались какие-то операции с показателями или редактировались данные в "Редакторе", то все описанные операции бесполезны - копия базы уже изменена и в ней нет ваших стертых данных.

Скопировать данные в буфер обмена (Clipboard)

В левом окне основная рабочая база, в правое перенесли один или несколько показателей. Перенесите в нужном порядке данные в пустое окно и нажмите кнопку "Копировать" - они будут скопированы в Clipboard, откуда их можно будет вставить в другое приложение. Эта функция пригодится, если вы собираетесь формировать базу и производить обработку данных во внешних программах, например Excel.
Замечание. Если при вставке данных в Excel.русский шрифт не читается, то не пользуйтесь стандартной иконкой вставки, а в меню "Правка" выберите пункт "Специальная вставка" и там пункт "Текст", после чего данные вставятся на лист в нормальном читаемом виде.
Внимание! Если нажать мышью на число, напечатанное синим цветом над списком основных баз, то в Clipboard будет скопирован список регионов в выбранной (текущей) базе данных и появится соответствующее сообщение. Если вы собираетесь формировать базу данных из своих показателей например в MS Excel, то этот список вам будет просто необходим, как "боковик" таблицы данных, которую вы затем будете наполнять из DG через Clipboard. Начните работу с того, что на чистый лист в первую колонку вставьте скопированный таким способом список регионов - структура базы готова, далее ее можно наполнять информацией. Именно в этой последовательности следует заносить вручную или формировать программно данные для того, чтобы их использование в DG имело практический смысл.

Запись данных в файл

В левом окне основная рабочая база, в правое перенесли один или несколько показателей. Перенесите в нужном порядке данные в пустое окно, нажмите кнопку "Записать" и задайте имя файла - данные записаны. Теперь этот файл можно переносить на машину с другой копией DG и вставлять данные в базу.
Полезно. Если вы хотите связать DG с какой-либо расчетной или моделируюшей программой для визуализации результатов, то программными средствами (или даже вручную) можете сформировать файл данных в обменном формате. Это обычный текстовый файл, структура которого следующая:

N - первая строка - число показателей, передаваемых в файле
M - вторая строка - число выделов на карте (размер числового ряда базе данных)
С третьей строки начинаются собственно данные - N раз повторенная структура:
Название (до 20 знаков)
Описание (до 80 знаков)
число1, число2, число3, .... числоM (через запятую)
Пример:
2
7
Название-1
Описание-1
1.12, 3.14, 1.03E-3, 2.456, 14.2, 12.35, 456
Название-2
Описание-2
8.16, 6.45, 1.08, 2.01E-05, 1.21, 2.15, 1.313E-12

Обратите внимание на самое последнее число, выделенное жирным шрифтом. Так в DG обозначается метка нет данных (см. основные понятия). Так что если есть потребность передать данные, где помимо смыслового нуля есть отсутствие, обозначайте в файле отсутствующий показатель цифрой 1.313E-12.

Передача данных в другую базу

В левом окне основная рабочая база, в правом выбрана другая база, но с тем же числом показателей (копия). Перетащите нужные показатели из основной базы в правое окно и вставьте их в нужное место списка. Любой показатель можно вставить в любое место, формируя тем самым тематические группы. Когда все показатели перенесены, нажмите кнопку "Обмен" и данные будут автоматически перенесены во вторую базу и вставлены на предназначенные вами места.
Стоит еще раз напомнить, что при этом производится только копирование - все показатели в той базе, из которой вы их переносите, остаются неизменными, поэтому не стоит переживать, что они исчезают из списка - делается это исключительно для удобства.

Перестановка показателей

В левом окне основная рабочая база, в правом выбрана та же самая база. Перетаскивайте показатели из левого в правое окно и вставляйте их в желаемое место (списки при этом можно протягивать). При этом после каждой операции содержимое окон обновляется и они остаются абсолютно идентичными по структуре. После того, как вы "навели порядок" и удовлетворены полученной структурой, нажмите кнопку "Обмен" и произведенные изменения сохранятся.

Пересчет показателей

В левом окне основная рабочая база, в правом выбрана база другой структуры. Последовательность действий точно такая же, как и при передаче данных в копию базы - перетаскиваете в нужные места правого списка выбранные показатели и нажимаете кнопку "Обмен". Однако сам процесс передачи данных при этом происходит существенно медленнее и может в зависимости от структуры баз и скорости вашего процессора занимать до одной минуты! Дело в том, что в данном случае не просто переписываются цифры, а решается сложнейшая задача по расчету среднего взвешенного значения вашего показателя для всех пресекающихся областей кадого из контуров первой и второй карты. Это уникальная процедура, решающая по сути научно-прикладную задачу - например пересчета продуктивности растительности на административные регионы. Прикиньте сколько времени и сил отняло бы у вас решение подобной задачи иными средствами и поймете, что есть смысл подождать десяток-другой секунд... В ходе процесса там, где выводится текстовая подсказка о доступных режимах, вы увидите счетчик, ведущий обратный отсчет до нуля. Не нажимайте никаких кнопок, дождитесь, пока DG закончит работу и получите в своей базе данных уникальные показатели, которые подчас почти невозможно получить иными средствами.
Точность алгоритма пересчета (при тестировании пересчета на ту же самую карту) составляет 99.99%, так что если обе карты у вас создавались на одной и той же основе и не имеют дефектов элементарных полигонов, можете рассчитывать процентов на 99.
Внимание! Операции пересчета имеют смысл лишь в том случае, если обе карты у вас относятся к одной и той же территории (Административная и Природная карты России в тестовых примерах). Автоматический пересчет, например, с карты страны на карту района является бессмысленной задачей, поэтому в DG встроена проверка на соответствие базового размера (который вы задаете, приступая к созданию новой карты в редакторе) для первой и второй карт. Если размеры не совпадают, никакого пересчета не производится. Поэтому, создавая свои собственные карты, имейте в виду возможность пересчета и всегда карты одной и той же территории делайте на общей основе. Если же совпало так, что и карта страны, и карта какого-то района у вас имеют один и тот же базовый размер, то пересчет, безусловно, будет произведен, однако, что делать с полученным результатом - решать исключительно вам...

Особенности работы с базами данных для точечных объектов

По структуре базы данных для площадных и точечных картографических объектов идентичны, однако, в силу принципиальной смысловой разницы между этими двумя типами объектов, работа с ними имеет свою специфику. Эта специфика связана исключительно с взаимодействием двух баз данных (выбранных в левом и правом окне), а все режимы работы с одной базой (копирование, вставка, запись в файл и т.д.) абсолютно идентичны.
Специфика работы с двумя базами следующая:

1. Если в одном окне выбрана площадная база, а в другом - точечная, то независимо от количества регионов (точек) производится пересчет выбранных (перенесенных из левого в правое окно) показателей.
2. Пересчет показателей производится по следующему принципу:
- С площадной базы на точечную: всем точкам, лежащим внутри контура (региона) присваивается значение для контура. Например 3-м городам, расположенным в Московской области, присваивается одно и то же значение - для области.
- С точечной базы на площадную: каждому контуру (региону) присваивается значение, равное среднему арифметическому из значений для всех попавших в этот регион точек. Например Московской области присваивается значение, равное сумме значений для 3-х имеющихся городов, деленное на 3.
При пересчете между площадными и точечными базами точно так же, как было описано выше, производится проверка на соответствие у выбранных баз (карт) базового размера - если их величины разные, то вы увидите соответствующее сообщение об ошибке.
3. Пересчет с точечной базы на точечную не производится по вполне понятным смысловым причинам. Поэтому если в левом и правом окне выбраны разные точечные базы, кнопка для пересчета становится неактивной. Однако, если в обоих окнах выбрана одна и та же точечная база, то в ней обычным образом можно произвести перестановку показателей.

Полезный совет - что делать с данными другой структуры?

Очень часто последовательность одних и тех же регионов в разных источниках данных не совпадает (даже в Госкомстате есть несколько разных стандартных классификаций регионов России). Если Вы имеете (например в Excel) таблицу, в которой последовательность регионов не та, что в базе DG, а есть нужда перенести данные, то нет смысла вбивать их вручную - поступите следующим образом.
Для начала нужно создать индексный файл, устанавливающий соответствие номеров регионов в первом и втором списках. Проще всего для этой цели использовать возможность обмена данными DG с Excel. Процедура здесь следующая.

1. Как описано выше, скопируйте и вставьте на чистый лист Excel список регионов нужной базы данных.
2. Скопируйте и вставьте в колонку рядом второй список регионов, не совпадающий с первым.
3. В третьей колонке введите подряд числа от 1 до номера последнего региона в списке (т.е. пронумеруйте второй список).
4. Теперь по порядку первого списка ищите во втором соответствующий регион и в следующие две колонки (4 и 5) просто выделяйте и копируйте название вместе с номером, размещая их так, чтобы названия регионов в 1 и 4 колонке совпадали (то есть название из 2-ой колонки помещается в одной строке с тем же названием из первой). Перенос номера вместе с названием обеспечивает в 5-ой колонке искомое индексирование, устанавливающее соответствие номеров регионов в первом и втором списках.
5. После того, как установлено соответствие для всех регионов, первые 4 колонки можно удалить, а сохранить лишь 5-ю колонку - номера, расположенные в порядке парекрестного соответствия 1-го и 2-го списков.
6. Сдвиньте всю колонку вниз на 2 ячейки и введите в 1-ю и 2-ю клетки значение "ноль" - это место для названия и описания.
7. Запишите этот список на диск с тем, чтобы его можно было использовать в дальнейшем. Индексация вручную делается всего один раз, а затем может многократно использоваться. Теперь можно переносить данные из 2-ой базы в первую, для чего:
8. Загрузите на один лист Excel вторую базу, на другой лист - созданный на предыдущих шагах индексный список.
9. Выделите колонку со списком и скопируйте ее на лист с данными
10. По этой колонке произведите сортировку всего листа в возрастающем порядке (для чего есть специальная кнопка).
11. Теперь все данные расположены в той последовательности, что необходима и их можно через Clipboard переносить в DG как это описано выше.

Следует заметить, что несмотря на внешнюю громозкость описанной процедуры, собственно этап переноса данных - это пункты 8-11, которые по времени займут от силы минуту. Остальное - подготовительный этап, который делается всего лишь раз, да и то может занять времени от силы 5-10 минут. Имеет смысл затратить это время на создание индексного файла, чем тратить гораздо больше на ввод даных вручную.


Общая информация

Базовые приемы работы в картографическом режиме достаточно просты. Из левого меню (синего цвета) вы выбираете нужную базу данных (по сути картооснову), при этом правый список (красного цвета) заполняется названиями имеющихся в этой базе показателей. Выберите интересующий показатель и нажмите расположенную рядом кнопку "Карта" - результат перед вами. Это простейший способ получения картографического изображения, на самом деле вы можете построить намного более сложные и эффектные конструкции, воспользовавшись выводом полигонов, сетки, точечных объектов, изменив палитру, стиль, надписи, но все эти режимы будут описаны ниже. Простейший же (и наиболее распространенный) способ получить карту с легендой - просто нажать кнопку "Карта". Имейте в виду, что выбранный в меню показатель остается текущим вплоть до выбора следующего, то есть его не нужно выбирать в меню еще раз, если вы изменили какие-то настройки и хотите построить карту заново - просто нажимайте кнопку нужного режима.
Внимание! Не выходя из картографического режима, вы можете переключиться в главное окно программы и там произвести какие-либо операции с данными (например редактирование, импорт, вычисления). При этом может измениться содержимое выбранной для картографии базы данных. Для обновления содержащихся в ней данных достаточно будет выбрать из списка название этой базы еще раз.

DataGraf использует векторный формат карт, что позволяет практически произвольно масштабировать получаемые картографические изображения и создавать иллюстрации самого высокого полиграфического качества. В связи с этим в видимую часть окна программы помет помещаться не вся карта, а только ее часть. Обратите внимание, что у вас есть возможность в любое время произвольно изменять размеры видимого окна, а также стандартным способом протягивать в окне изображение, если оно превышает заданные размеры. При этом все операции (в том числе сохранение) производятся не с видимой частью, а со всем изображением. Обратите внимание на возможность создания собственных стилей, в которых однажды определенные размеры можно сохранить на диск, а затем использовать для создания единообразно оформленных серий карт.
При выборе базы данных (картоосновы) размер карты автоматически устанавливается по базовому размеру (коэффициент масштабирования = 1), в дальнейшем этот размер вы можете произвольшо изменять, используя режимы увеличения-уменьшения. Базовый размер для каждой карты вы определяете сами при ее создании - это размер исходной картинки, которая используется для оцифровки карты. При создании серии разных карт на одну и ту же территорию старайтесь использовать в качестве заготовки разные копии одной и той же картинки - это гарантирует совпадение базовых размеров и открывает ряд дополнительных возможностей (автоматический пересчет показателей, наложение точечных объектов и т.д.). Подробнее об этом см. в описании картографического редактора.
Программа поддерживает два типа картографических объектов - площадные и точечные. Площадные объекты являются основным операциональным типом и представляют собой набор полигонов (произвольных замкнутых кривых), которым в зависимости от значения присваивается соответствующая закраска. Пример - административные регионы страны. Точечные объекты являются вспомогательным типом (с ними не производится часть операций) и представляют собой координаты отдельных географических объектов (например крупные города). Выводиться на карту точечные объекты могут разными способами - закрашенными/незакрашенными, а также масштабируемыми/немасштабируемыми геометрическими объектами (окружность, прямоугольник, ромб) или любыми пиктограммами из создаваемой вами собственной библиотеки.
Внимание! Если базовые размеры площадной и точечной карт совпадают (то есть это карта одной территории), то точечные объекты могут накладываться на площадные, что дает возможность создавать достаточно сложные, информативные и привлекательные картограммы. Программа автоматически проверяет совпадение базовых размеров и не даст вам вывести, к примеру, на карту России города с (другой, более крупной) карты Московской области.

Далее дается подробное описание назначения каждой кнопки и отдельных приемов работы, связанных с выполняемой функцией.

Карта

Эта кнопка реализует универсальную функцию по построению карты на основе выбранного из базы данных показателя. При ее нажатии последовательно осуществляются операции, для каждой из которых предназначены следующие 4 кнопки - очищается окно, выводятся полигоны, сетка и легенда. Если эта кнопка используется для вывода точечных объектов, вокруг геометрических фигур (окружность и т.д.) рисуется контур черного цвета. Легенда при нажатии этой кнопки выводится всегда, поэтому если она не нужна, используйте для построения карты следующие три кнопки.

Очистить окно

Нажатие этой кнопки приводит к стиранию изображения в графическом окне программы. Используйте ее для удаления изображения перед использованием следующих трех кнопок.

Области

Выводятся неоконтуренные полигоны (цветные области), в которых отсутствуют черные границы между регионами. Используйте в том случае, если хотите на карту с одним принципом деления нанести контурную сетку (границы бластей) карты с другим принципом деления. Если эта кнопка используется для вывода точечных объектов, вокруг геометрических фигур (окружность и т.д.) не рисуется контур черного цвета и не выводится легенда.

Сетка

Выводится контурная сетка (границы областей), соответствующая выбранной базе данных. При этом имеющееся изображение не стирается, что дает возможность сначала вывести полигоны (области) для показателя из одной базы данных, затем выбрать базу данных с другим принципом деления и нанести на имеющееся изображение ее контурную сетку.
Внимание! Для точечных объектов отсутствует понятие сетки (границ областей), однако сами эти объекты обретают смысл лишь "в связке" с соответствующей площадной картой, по которой производилась их оцифровка. Для вывода сетки на точечные объекты используйте именно эту карту, для чего в программе предусмотрен следующий механизм.
- сначала выбирается подходящая площадная база данных (ее сетка запоминается)
- затем выбирается точечная база и нужный показатель
- очищается окно и выводятся точечные объекты
- после этого нажимается кнопка Сетка и на карту выводятся контуры ранее выбранной площадной базы (карты).
Последние два действия можно производить и в обратном порядке - в этом случае контурная карта не будет пересекать точечные объекты, а будет располагаться "под ними".

Легенда

При нажатии этой кнопки на карту выводится легенда, формат которой соответствует выбранному стилю. Если стиль не выбран (при входе в картографический режим), легенда выводится в левом верхнем углу. Вы можете изменить расположение, формат легенды и шрифтов, выбрав соответствующий стиль или воспользовавшись редактором стилей. Числовые значения в легенде рассчитываются для текущего (выбранного на данный момент) показателя, поэтому вы можете сначала построить некоторую комбинированную карту по описанной выше технологии, затем выбрать соответствующие базу данных - показатель и вывести на карту легенду для этого показателя как независимый объект. Значения чисел для легенды рассчитываются и округляются автоматически с целью обеспечить наиболее компактный формат записи - например 32.01675406 будет выглядеть как 32.02, однако если вас не устраивает "автоматический" формат, то вы можете всегда воспользоваться режимом редактирования текста легенды, чтобы произвести желаемые изменения.
Внимание! DG предусматривает отдельные независимые как по расположению, так и по оформлению легенды для площадных и для точечных объектов.

Информация/текст

Данные три кнопки предназначены для получения информации по двойному щелчку в любом месте карты и/или выводу в этом месте текста. Каждая из них работает как "выключатель" - при первом нажатии выбранный режим становится текущим, кнопка "нажимается" и становится активной вплоть до "отключения" или выбора другой кнопки. При активизации любой из этих кнопок двойной щелчок мыши в любом месте карты приводит к следующему:
И (нформация) - в нижней части окна программы на специальной информационной панели печатаются название показателя, название региона, на котором расположен курсор мыши, и числовое значение показателя в данном регионе.
Т (екст) - в том месте, где стоит курсор мыши, на карте печатается название соответствующего региона. Используйте эту возможность для быстрого и удобного подписывания отдельных регионов. Обратите внимание, что надпись выводится тем шрифтом, который был выбран ранее в режиме выбора шрифта. Шрифт можно менять непосредственно в ходе работы, в этом случае разные регионы можно будет подписать различными шрифтами.
Д (анные) - Принцип работы тот же самый, что и в предыдущем случае, но на карте печатаются числовые значения текущего показателя в выбранном регионе. При выводе на печать форматирования чисел не производится, они печатаются в том же виде, как вы их видите в базе данных. В случае автоматически рассчитанных показателей они могут выглядеть не очень хорошо читаемыми (например 23.9876545), исправить положение можно войдя в редактор данных и убрав лишние значащие цифры.
Обратите внимание, что для точечных объектов, где отсутствует понятие замкнутого контура, поиск производится до первой ближайшей точки - именно для нее и будет выведено название/значение. Это позволяет выводить текст не непосредственно на объекте, а рядом с ним, что выглядит намного эстетичней. Однако при этом имейте в виду, что для программы ближайшей точкой может оказаться не та, которую вы запланировали, а соседняя, поэтому "прицеливайтесь" поточнее.

Увеличить

Нажатие этой кнопки позволяет изменить коэффициент масштабирования и увеличить размер карты. При этом размер окна программы не увеличивается и часть изображения останется "скрытым", однако картинку всегда можно стандартным образом "протянуть" по вертикали-горизонтали или (если позволяет разрешение экрана) увеличить само окно. Даже если фрагмент изображения скрыт, графические операции производятся со всей картой. Повторное нажатие этой кнопки приводит к дальнейшему увеличению изображения без потери его качества - в этом преимущество векторного представления картографических данных в DG. В принципе изображение можно увеличивать до тех пор, пока это позволяют ресурсы памяти вашего компьютера. Если ресурсов для дальнейшего увеличения не хватает (чаще всего на Windows - 98), изображение станет серым. В этом случае восстановить его можно нажатием кнопки уменьшения - это будет максимально возможный масштаб на вашем компьютере.

Уменьшить

Эта кнопка предназначена для изменения масштаба изображения в сторону уменьшения. Работает она точно так же, как и кнопка увеличения, но для уменьшенного изображения существует объективный предел - 0.1 от исходного размера карты, меньше которого кнопка не работает. Обратите внимание, что на масштабах меньше единицы функции распознавания регионов работают неуверенно, поэтому режимом Информация/Текст, описанным выше, лучше не пользоваться.
Внимание! Кнопки увеличения/уменьшения предназначены для масштабирования всей карты и не влияют на размер точечных объектов. Устанавливайте их размер при помощи редактора стилей.

Копировать

Нажатие этой кнопки копирует изображение, находящееся в картографическом окне, в буфер обмена (Clipboard), откуда вы его можете стандартным приемом вставить в любое приложение Windows, поддерживающее графику. Изображение копируется целиком, даже если часть его не помещается в установленные вами размеры окна программы.

Копировать фрагмент

Данной кнопкой также производится копирование в буфер обмена, но копируется не все изображение, а только его видимая часть. Это дает вам возможность, подобрав размер окна и увеличение, работать только с фрагментом карты. Если карта меньше размеров окна (уменьшена), то в буфер копируется целиком, но по краям возможно появление черных полос, поэтому пользуйтесь для копирования уменьшенных изображений предыдущей функцией.

Записать

Для записи изображения в файл, нажмите эту кнопку и задайте его имя. Обратите внимание, что DG записывает на диск изображения только в форматах, которые поддерживаются вашей операционной системой. Программа автоматически определяет доступные форматы и выдает их в меню для имени файла, поэтому если у вас на компьютере Windows-98, то вы сможете сохранить файл только в формате BMP. Это очень "расточительный" формат и в нем файлы лучше на диске не держать, поэтому последуйте нехитрому совету - скопируйте изображение в буфер, затем вставьте его в какой-нибудь графический редактор, а уже из него запишите на диск в более компактном формате. Тем же, у кого на компьютере развернуты Windows-2000/XP для записи доступны много разных форматов, из которых лучше выбрать GIF или PNG, дающие наиболее компактные файлы для карт.

Сменить палитру

Палитра - это набор цветов, определяющий цветовое решение вашей карты. Стандартная палитра DG - зелено - желто - красная, в которой минимальные значения отображаются зеленым цветом, а максимальные - красным. Вы можете использовать готовые палитры, произвольно их редактировать, а также создавать свои собственные. В данном окошке представлен список имеющихся палитр, из которого вы можете выбрать любую, после чего все карты будут выводиться именно в этом цветовом решении. Набор палитр является общим для всех проектов и записывается в файл palette.dg, расположенный на диске рядом с программой. Не стирайте этот файл, в противном случае возможны сбои в работе программы.
Создать, отредактировать, переименовать палитру вы можете в специальном режиме редактора палитр.

Сменить стиль

DG позволяет придать серии карт (например из одной базы данных) единый уникальный стиль при минимальных затратах времени с вашей стороны. Один раз сформируйте и сохраните стиль, после чего все карты будут выводиться именно так, как вы это определили. Стиль включает в себя:
- расположение и размер видимого окна основной программы на экране
- размер (масштаб) самого картографического окна
- выбранную цветовую палитру
- количество цветовых градаций на карте и в легенде
- тип шкалы, по которой рассчитывается легенда
- размер, расположение и рамку легенды
- формат легенды и подписей
- шрифт подписей в легенде
- размер, форму, параметры легенды для вывода точечных объектов.
Изменить весь этот набор можно одним щелчком мыши, просто выбрав нужное название из списка имеющихся стилей. Для создания, редактирования, переименования ваших стилей служит специальный режим редактора стилей. Набор стилей для каждого проекта свой собственный и записывается внутри проекта в файл dg.sty - не стирайте эти файлы, иначе возможны сбои в работе программы.

Работа с текстом

Редактор палитр

Редактор стилей

Точечные объекты


DataGraf предоставляет простейшие, но достаточно развитые возможности для размещения на вашей карте заголовков, подписей и прочей текстовой информации, а также произвольного изменения текста, выводимого в легенде. Для реализации этих возможностей предназначены следующие кнопки.

Писать текст

Эта кнопка позволяет делать в любом месте карты произвольные надписи. При ее нажатии на экране появляется окошко текстового редактора, в котором по умолчанию присутствует текст из 2-ой строки вашего столбца данных - описания показателя. Тем самым вы имеете практически готовый заголовок к карте (если не поленились дать подробное описание при подготовке данных). Изначально окошко для редактирования выводится без границ - просто текст на белом фоне, однако, если щелкнуть на тексте правой кнопкой мыши, вокруг окошка появится пунктирная рамка. Она же появляется и после перемещения окошка, которое осуществляется мышью при нажатой левой кнопке. Размеры окошка можно менять стандартным образом - "потянув" за любую границу при нажатой левой кнопке. При этом находящийся в окошке текст автоматически выравнивается по центру и переносится исходя из заданных размеров шрифта. Таким образом вы имеете возможность поместить текст в любое место карты, произвольно изменить размер окна и сформировать тем самым общий вид текста, каким бы вы его хотели видеть на карте. Обратите внимание, что правая кнопка мыши работает как переключатель для рамки, поэтому если не хотите, чтобы ваш текст был в рамке, нажмите ее еще раз, чтобы удалить. Более того, рамка может стать не пунктирной, а сплошной - поэкспериментируйте и сами увидите при каких условиях.
Во время всех описанных манипуляций с окошком редактора в нем мигает курсор - по сути это свободно перемещаемый по карте текстовый редактор с изменяющимися размерами, в котором вы видите ваш текст точно таким же, как он будет выглядеть на карте. Если курсор в окошке не мигает, то переместиться в него можно вторично нажав кнопку текста на панели или дважды шелкув мышью в окне редактирования. После того, как все готово - текст написан, красиво рамещен и отформатирован, вы можете закончить редактирование, нажав следующие клавиши:
Enter- завершает редактирование, ваш текст превращается в изображение и его уже нельзя редактировать. При нажатии Enter фон под текстом по умолчанию делается "прозрачным" и надпись выводится поверх картинки, не затираяя ее.
SHIFT+Enter - также заканчиват редактирование, но фон под текстом в границах рамки остается белым. Используйте это сочетание клавиш, если хотите на карте сделать контрастную "врезку", на которой рамка текста затирает часть изображения.
Esc - завершает редактирование, но текст не выводится на карту, а просто исчезает. Используйте эту клавишу если передумали писать текст или что-то не получилось как надо и проще начать с самого начала.
Количество надписей на одной карте не ограничено - закончив одну, можете сделать сколько угодно других - другим типом и размером шрифта, в другом месте, с другим форматированием. Обратите внимание, что в окно для редактирования можно не только вносить текст вручную, но и вставлять из буфера обмена стандартным сочетанием клавиш (Ctrl+V, Shift+Ins). Это особенно удобно, если у вас уже есть готовый текст или вы хотите иметь больше одного абзаца.

Выбрать шрифт

Нажав эту кнопку, вы можете выбрать для своего текста любой шрифт, установленный на вашем компьютере. Имейте в виду, что шрифт выбирать следует только при открытом окошке редактирования с текстом. В этом случае выбрав шрифт, вы мгновенно увидите изменения. Выбранный ранее шрифт для вновь созданного окошка не действует.
Внимание! Выбор шрифта работает не только с окошком для ввода текста, но и распространяется на:
- названия регионов, выводимые на карту (кнопка T)
- значения показателей, выводимые на карту (кнопка Д)
- начертание шрифтов в легенде (размер определяется стилем).
Выберите шрифт перед выполнением каждой из этих операций и все надписи будут выводиться выбранным шрифтом вплоть до выхода из картографии или выбора другого шрифта.

Текст легенды

При построении легенды DG автоматически форматирует числа, стараясь сделать их максимально компактными (например 5.016869 записывается как 5.02), но иногда возникает нужда подправить цифры, а то и вовсе заменить их на надписи (например: максимальное - среднее - минимальное). Для этого предназнана кнопка редактирования текста легенды, при нажатии на которую появляется таблица с автоматически посчитанными значениями, которые можно произвольно изменять. При изменении текста для перехода между строками используйте стрелки вверх-вниз, клавиша Enter тоже осуществляет переход на строчку ниже, однако ее нажатие в самой последней строке означает конец редактирования, исчезновение таблицы и выдачу на экран изменений. Если вы передумали редактировать текст легенды, просто нажмите Esc - таблица исчезнет, но легенда останется прежней.
Имейте в виду, что подписи к легенде могут содержать не только цифры - это обычный текст, который вы можете произвольно изменять и даже полностью стирать. Единственное, на что следует обратить внимание - это длина текстовой строки, которую не стоит делать слишком длинной, чтобы надписи в легенде не выходили за край карты.


Редактор палитр

Нажатие этой кнопки приводит к появлению на экране встроенного редактора палитр, с помощью которого вы можете редактировать любой цвет в любой палитре, а также создавать свои собственные. Выбор палитры для редактирования производится из левого выпадающего меню. В нижней части панели расположены цвета выбранной палитры, текущий (редактируемый) цвет отмечен рамкой вокруг соответствующего квадрата (первый слева на рисунке). Для выбора цвета просто щелкните мышью по соответствующему квадрату.

Редактирование производится тремя движками, позволяющими смешивать красный, зеленый и синий компоненты композитного цвета. При изменении положения движков цвет в соответствующем квадрате моментально изменяется, что позволяет видеть на глаз произведенные изменения. Подбирая цвет, имейте в виду, что левая часть спектра отражает минимальные числовые значения ваших показателей, а правая - максимальные. Освоив это несложное устройство, вы сможете создавать для своих карт уникальные и неповторимые цветовые решения.
Обратите внимание, что помимо "линейки" основных цветов, которыми окрашивается карта, в правой части панели есть два поля для дополнительных, которыми в данном цветовом решении выводятся контурная сетка и метка Нет данных. Эти цвета редактируются точно так же, как и все остальные, а в результате вы можете создать цветовое решение, в котором сетка не обязательно будет черной (по умолчанию), а метка Нет данных будет иметь произвольный цвет.
Для того, чтобы сохранить сделанные в ходе работы изменения, перед выходом из редактора нажмите на кнопку с изображением дискетки. Редактировать можно не только собственно цвета, но и название палитры (в текстовом окошке). Пользуйтесь этим для того, чтобы не заводить новую палитру, если у вас есть та, которой вы давно не пользуетесь - назовите ее по новому, измените цвета и сохраните - ваш список палитр останется компактным и легко обозримым.
Завести новую палитру можно нажав кнопку с изображением чистого листа - при этом в текстовом окошке появится название "Новая", которое следует заменить на любое удобное вам название. Удаления палитр не предусмотрено, поэтому старайтесь не создавать много новых палитр, чтобы не путаться в длинном списке, а лучше изменяйте ставшие уже ненужными. Не удивляйтесь, если при вводе названия палитры, программа не дает ввести больше 15 символов - это объективное ограничение, чтобы сделать выпадающий список палитр нормально читаемым.
Если произвенные изменения не записаны, то они будут действовать и после закрытия редактора палитр, но только влоть до выхода из картографического режима. Поэтому не забывайте сохранять проделанную работу, чтобы ваш труд не был напрасным. С другой стороны, это дает вам возможность создавать временные цветовые решения, которые нужны для решения отдельной задачи и не обязательно должны быть сохранены на будущее.


Редактор стилей

Перед тем, как приступать к созданию нового стиля, выберите любой стиль из существующих, выведите карту, для которой собираетесь его создавать, а после этого определите общие параметры для нового стиля:
- распложите окно программы наиболее удобным для вас образом
- установите желаемый размер окна
- кнопками увеличения-уменьшения задайте желаемый масштаб карты
- выберите палитру, в которой будет выводиться карта по умолчанию.
Все эти установки запишутся и будут воспроизводиться каждый раз, когда вы выберете новый стиль. Теперь можно нажать кнопку Редактора стилей для того, чтобы определить установки карты-легенды. При нажатии кнопки редактора появляется следующее окно:

а легенда, расположеннная на карте, теперь начинает вести себя точно так же, как и окошко для ввода текста - она перемещается в любое место карты, размер ее можно произвольно изменять стандартными приемами. Начните с того, что переместите ее в желаемое место.
Обратите внимание, что в верхнем текстовом окошке присутствует название стиля, который вы выбрали на самом первом шаге, но уже частично изменили. Если у вас задача только отредактировать этот стиль, можете при желании подправить его название и перейти к следующему шагу. Если же вы создаете на его основе новый стиль, то нажмите кнопку справа с изображением чистого листка и вместо стандартного названия "Новый" задайте удобное вам название (до 15 символов). Отныне в картографическом режиме ваш новый стиль будет фигурировать под этим именем.
Внимание! В DG предусмотрен собственный набор стилей для каждого проекта, поэтому если проект новый и стилей в нем еще нет, то просто измените название по умолчанию "Новый", который выдается программой, и можете продолжать работу - это будет ваш первый стиль в проекте. Если же в проекте уже созданы какие-то стили, а вы, заходя в редактор, предварительно никакой не выбрали, то при записи на диск, он запишется первым - взамен уже существующего. Имейте в виду эту особенность и если не хотите, чтобы вместо существующего стиля был записан новый, всегда выбирайте какой-то из имеющихся стилей перед тем, как приступить к созданию нового.
Теперь можно выбрать число цветовых градаций (в выпадающем меню "Легенда") - оно определяет количество кубиков в легенде и цветов на карте. Градация - это дипазон чисел в вашем ряду данных, соответствующий одному цвету на карте - чем меньшее число градаций, тем более широкой диапазон чисел охватывает каждая из них. Количество градаций вы можете изменять, выбирая из меню один из заданных фиксированных диапазонов - 3, 5, 7, 9, 13. Как правило этого вполне достаточно для решения практически всех возникающих задач. Градации в программе считаются тремя различными способами - по равнонаполненной, равномерной и логарифмической шкале, выбрать желаемую можно из соседнего выпадающего меню с соответствующим названием.
После выбора числа и шкалы градаций определите структуру легенды - расположение кубиков, для чего воспользуйтесь кнопкой "Несколько строк" и расположенным рядом выпадающим меню. Если кнопка не нажата, то все кубики вытягиваются подряд - в одну горизонтальную строку. Если кнопка нажата, то количество строк, по которому распределяются кубики, определяется числом, выбранным в меню - попробуйте сами и сразу поймете принцип. Перед экспериментом с наиболее удачным расположением кубиков, примите решение, будет ли у вас в легенде выводиться метка "Нет данных" - это еще один дополнительный кубик в легенде. Для установки-снятия его в легенде используйте кнопку "Нет данных", которая работает как выключатель.
После выбора структуры легенды часть кубиков и надписей наверняка вышли за границы легенды и не видны. Теперь самое время, потянув за края рамки, определить внешний размер поля легенды при новой ее структуре.
Увидев всю легенду, вы наверняка не будете удовлетворены размерами кубиков, текста и их взаимным расположением. Значит настала пора обратиться к до сих пор еще не упомянутому большому белому окошку справа. Это не что иное, как инструмент для изменения элементов легенды:
1. Попробуйте немного изменить размер красного прямоугольника (обычным способом) - отпустив кнопку мыши, вы увидите, что вслед автоматически изменяются размеры у всех кубиков легенды на карте
2. Попробуйте немного подвинуть красный прямоугольник (нажав на нем левую кнопку мыши) - при отпускании кнопки вы увидите, что в результате этой операции изменяется взаимное расположение кубиков легенды - легенда "сжимается - раздвигается"
3. Попробуйте немного подвинуть желтый текст по отношению к красному прямоугольнику - когда вы его отпустите, то увидите, что и в легенде все надписи адекватно передвинулись. Заметьте, что при этом вы можете расположить текст над и под кубиками, и даже внутри них.
Выбрав удачные размеры кубиков, вы можете изменить размер шрифта для подписей (окошко "Шрифт"), а затем подправить взаимное расположение, внешние размеры и место легенды на экране. Все эти действия лучше производить с нажатой кнопкой "Рамка", позволяющей видеть внешние границы поля легенды, однако, если она вам на карте не нужна, то в конце просто выключите эту кнопку. Использование интерактивного инструмента формирования легенды позволяет вам с минимальной затратой сил и времени сконструировать желаемый вид и формат легенды прямо на карте в том же виде, в котором она будет выводиться впоследствии.
После того, как вы удовлетворены достигнутым результатом, нажмите кнопку с изображением дискетки, чтобы записать произведенные изменения. Отныне при каждой загрузке проекта все ваши установки будут воспроизводиться, что позволяет вам автоматически придать уникальный стиль целой серии карт. Если для какой-то отдельной задачи заданный стиль вас не устраивает, то вы можете войти в редактор, изменить его и выйти не записывая - измененный стиль будет оставаться текущим вплоть до выхода из картографии или загрузки другого стиля. Это позволяет не меняя "любимых" установок решать целый спектр временных задач.

Точечные объекты

В DG предусмотрено два отдельных независимых типа легенды для площадных и для точечных объектов, которые вы можете определить в рамках одного заданного стиля, как правило относящегося к нескольким картам (базам) с одним и тем же принципом деления (базовым размером). При входе в режим редактора стилей, программа автоматически распознает тип текущей карты (базы) - площадная или точечная - и выдает на редактирование соответствующий тип легенды.
Приемы работы при редактировании (создании) стиля для точечных объектов те же самые, что и для площадных. Разница состоит лишь в следующем:
- в легенде, которую вы видите на карте, отображаются не прямоугольники, а соответствующие значки, которые были выбраны до этого в меню точечных объектов (геометрические фигуры или изображения из библиотеки)
- форма и размер красного прямоугольника в данном случае определяют размер выводимых значков - как в легенде, так и на карте. Если вы хотите сделать масштаб значков, выводимых на карту, крупнее или мельче, пользуйтесь этим режимом, а не кнопками (+) или (-) на главной панели
- легенда для точечных объектов самостоятельная, она может быть выдана на карту одновременно с площадной, поэтому ее стоит расположить в другом месте, чтобы две легенды не перекрывали друг друга. Если не одного стиля в проекте еще не создано, расположение этих легенд одно и то же - они находятся в левом верхнем углу и по сути накладываются. Имейте это в виду и при создании нового проекта разместите площадную и точечную легенды в разных местах.
- если при входе в данный режим в меню точечных объектов ничего не выбрано, по умолчанию текущим значком будет являться окружность. Вы можете работать только с ней и не выбирать ничего другого - в данном случае создается макет легенды и реально вместо окружности как на карте, так и в легенде будут подставляться любые выбранные вами значки.

Шкалы цветовых градаций

Есть много различных способов разделить числовой ряд на несколько диапазонов (градаций цветов), в DG реализованы три наиболее распространенных и дополняющих друг друга при решении самого широкого круга задач.

Равнонаполненная шкала. Прицип разбиения - чтобы во все регионы на карте попало примерно равное количество цифр из числового ряда. Преимущество этой шкалы в том, что карта всегда получается контрастной и сбалансированной, без преобладания каких-либо цветов, недостаток - при преобладании одинаковых чисел легенда получается малоинформативной, содержащей одни и те же диапазоны чисел в нескольких градациях. Равнонаполненная шкала используется программой по умолчанию, т.е. градации всегда считаются по этой шкале, если при определении стиля не выбрано иное.

Равномерная шкала. Принцип - числовой ряд разбивается на равное число интервалов от минимума до максимума и реальные значения заносятся в соответствующий интервал. Преимущество в том, что эта шкала наиболее "реальная", недостаток в том, что в часть интервалов реальные данные могут просто не попасть и этих цветов на карте просто не будет. Если максимальное значение ряда сильно отличается от всех остальных, то карта вообще может оказаться двухцветной - максимум и все остальные, что абсолютно неинформативно. Равномерной шкалой лучше пользоваться для ровно распределенных рядов данных без экстремальных "выбросов" значений - например оценок по N-балльной шкале.

Логарифмическая шкала. Принцип разбиения тот же, что и равномерном случае, но диапазон градаций строится не на реальных значениях, а на их логарифмах, что позволяет "растянуть" интервал минимальных значений и "сжать" максимальных. Преимущество в том, что даже если в ряду есть экстремально высокие значения, карта получается все равно контрастной, недостаток - трудно воспринимаемая легенда, в которой возрастание значений от диапазона к диапазону не равномерно.

В большинстве реальных случаев, особенно при отсутствии в ряду данных большого числа одинаковых чисел, пользуйтесь равнонаполненной шкалой, что обеспечит вам всегда сбалансированную по цветам карту. Однако, если в смысловом отношении полученный результат вас не устраивает, попробуйте другие варианты разбиения с учетом описанных преимуществ и недостатков - в любом случае приемлемое решение найдется. Для наиболее полного представления о принципах графического отображения данных, помимо этого раздела обратите внимание на особенности работы с нулевыми значениями и отсутствием данных.


РАБОТА С ТОЧЕЧНЫМИ ОБЪЕКТАМИ

Точечные объекты в DG - это значки, привязанные к координатам заданной вами при оцифровке точке на карте, которые в зависимости от числового значения масштабируются/окрашиваются в соответствии с заданным стилем. Точечные объекты имеют смысл только в "связке" с площадной картой той же самой территории, т.к. не имеют собственной контурной сетки и предназначены для дополнения пространственно-распределенных объектов (например районов области) новой категорией информации - точечной (например районные центры). Если для площадных объектов значение показателя считается одним и тем же для всех точек в пределах контура, то для точечных объектов оно определено только для одной точки. Таких точек в пределах одного региона может быть несколько и каждая из них будет представлять собой самостоятельный точечный объект.
Числовая информация, которую вы заносите в базы данных , может быть автоматически пересчитана с площадных объектов на точечные и наоборот - подробнее см. режим операций с данными. В картографическом режиме возможно наложение точечной карты на площадную (каждая с собственной легендой), а также вывод точечных показателей на площадную контурную сетку. Все это возможно лишь в том случае, если на одну и ту же территорию помимо точечной существует и площадная карта, более того - обе они имеют один и тот же базовый размер. Иными словами, как карта населенных пунктов без административных границ - это просто точки на чистом листе бумаги, так и точечные объекты без площадных - просто значки на экране без всякой визуальной привязки. Поэтому на практике имеет смысл приступать к созданию точечных объектов лишь в том случае, если у вас на эту территорию уже есть площадная карта.

Значки, которыми отображаются точечные объекты, разделяются на два вида - геометрические (окружность, прямоугольник, ромб), которые фиксированно заданы в программе, и пиктограммы - произвольные картинки формата BMP, которые вы сами добавляете в библиотеку. Размер и пропорции значка (как на карте, так и в легенде) определяются при создании макета легенды, кнопки увеличения-уменьшения изображения на главной панели на них не влияют, а масштабируют карту целиком.
Внимание! Добавить собственную пиктограмму в библиотеку точечных объектов данного проекта очень просто. Файл с нужной картинкой сохраните в формате BMP, назовите как вам удобно, а затем перепишите его в поддиректорию (папку) MAP, находящуюся внутри проекта. С этого момента он будет фигурировать под заданным вами именем в выпадающем меню значков. Для большинства задач лучше всего использовать небольшие пиктограммы стандартного размера 32х32 точки (см. примеры), однако если вы планируете сделать большую карту полиграфического качества, можете использовать рисунки 50х50 или даже 100х100 точек. Однако имейте в виду, что при уменьшении они очень серьезно теряют в качестве и будут плохо выглядеть на карте размером в экран. Теоретически ограничения на размер пиктограммы нет, но картинки занимают очень много памяти и ее может просто не хватить, если вы решите поэкспериментировать с большими изображениями. Если вы решили удалить значок из библиотеки, то просто сотрите соответствующий файл.

Вывод точечного объекта на карту осуществляется стандартным способом с использованием тех же самых кнопок, что и для площадных объектов. Однако при этом существует одна особенность - точечные объекты связаны с соответствующими площадными и если вы хотите вывести их не на чистый экран, а на соответствующую контурную карту, то:
- сначала выберите нужную площадную карту (базу) - она запомнится
- затем сразу свою точечную карту
- после этого можете выводить на карту любой точечный показатель
До тех пор, пока не будет сделан выбор следующей карты (базы), нажатие кнопки "Сетка" будет выводить контурную карту выбранной на первом шаге площадной базы. Типичная поцедура при этом: очистка экрана - вывод сетки - вывод точечного показателя. Если же вы хотите наложить точечный объект на площадной, то:
- выберите площадную базу
- постройте карту нужного показателя
- выберите точечную базу (экран при этом автоматически не очистится если базовые размеры совпадают)
- выведите точечный показатель.
Эта процедура хотя и более сложная, но занимает от силы несколько секунд. Как площадные, так и точечные объекты выводятся при этом в едином масштабе, заданном выбранным стилем.
Внимание! Точечные объекты, значения которых в базе данных нулевые или отсутствуют (метка "Нет данных") на карте не отображаются. Этим можно воспользоваться и на одну и ту же карту вывести несколько видов значков. Для этого, к примеру, в одном показателе часть чисел сделайте нулями, а в другом наоборот - нулями те, которые в первом были ненулевые. После этого выведите оба на карту, сменив перед выводом второго значок. Этим способом (редактируя данные) можно украсить карту одновременно большим количеством разных значков.

Точечные объекты

Эта кнопка на главной панели является своеобразным редактором стилей для точечных объектов и позволяет выбрать значок, а также задать параметры его отображения на карте. При ее нажатии появляется следующее небольшое окно:

Выбор значка производится из желтого выпадающего меню, в котором пиктограммы представлены названиями файлов, которые вы им присвоили перед тем, как переписать в проект.
Кнопка "Размер" определяет масштабирование значков. Если она включена, значки на карте выводятся разных размеров в зависимости от значения показателя. При этом наибольший размер определяется размером значка, заданным при формировании стиля, все остальные масштабируются в меньшую сторону. Если эта кнопка выключена, все значки выводятся одного размера (заданного в стиле).
Кнопка "Цвет" определяет режим закраски значков. Если выбран геометрический значок, то при включенной кнопке он заливается цветом, соответствующим значению показателя (аналог цветовой градации в площадных объектах). Если кнопка выключена, то внутренность его остается белой, а выводится только внешний контур. В сочетании с кнопкой "Размер" это позволяет один и тот же показатель отобразить несколькими разными способами: от одного размера незакрашенных до разных размеров с заливкой - используйте эту возможность для подчеркивания различных смысловых аспектов.

Если же при нажатии кнопки "Цвет" в меню значков выбрана пиктограмма, то она определяет состояние фона под картинкой:
- кнопка включена - пиктограмма выводится как прямоугольник вместе с фоном по краям изображения
- кнопка выключена - пиктограмма выводится прозрачной - фон по краям не затирает расположенное ниже изображение.
Внимание! При выводе пиктограммы фоновый цвет, который нужно сделать прозрачным определяется автоматически по левой-верхней точке картинки. Если этот же цвет присутствует и в нарисованном на пиктограмме изображении, то он тоже станет прозрачным и на картинке появится "грязь". Чтобы избежать этого, не пожалейте лишнюю минуту и в каком-нибудь графическом редакторе просто "залейте" те места, которые нужно сделать прозрачным фоном, каким-нибудь другим цветом, котого нет на изображении. В случаях, когда значок прямоугольный и фон имеет значение, просто включите кнопку "Цвет" и картинка будет выводиться как есть.

Выбрав нужный значок и изменив параметры, нажмите кнопку с крестиком - панель закроется и все сделанные установки будут действовать для любых точечных баз вплоть до следующего изменения или выхода из картографического режима.


ВЫЧИСЛИТЕЛЬ

Вычислитель является мощным и эффективным средством работы с числовыми данными. Этот режим реализован в виде очень простого для пользователя и достаточно полного формульного языка программирования со своим текстовым редактором, синтаксическим анализатором, обработчиком ошибок, арифметическим интерпретатором. Основное его отличие от стандартных средств программирования расчетов состоит в том, что в качестве переменной в языке вычислителя DG выступают не отдельные числовые величины, а вектора данных (значения одного показателя по всем регионам карты). К примеру, имея в базе данные по a-численности населения и b-площадям регионов, при помощи Вычислителя вы можете всего за несколько секунд пополнить свою базу новым показателем - плотностью населения, для чего достаточно будет просто посчитать его по формуле a/b и написать название.

При входе в Вычислитель первым шагом следует выбрать базу данных, с которой предполагается работать, а затем - до 20-ти показателей, каждый из которых будет являться отдельной переменной. Выбор данных осуществляется выделением мышью названия соответствующего показателя (при выборе следующего выделение остается). Вы можете пометить более 20-ти показателей - программа это позволяет, но использоваться при расчетах будет первая двадцатка из выделенного списка. Для окончания выбора используйте кнопку "Завершить выбор".
После выбора данных на экране появятся несколько окон, каждое из которых имеет свое функциональное предназначение. В левом окне располагается список названий выбранных вами показателей, каждому из которых будет соответствовать буква латинского алфавита: a, b, c, d... и т.д. В дальнейших расчетах для обозначения того или иного показателя в формуле пользуйтесь соответствующим буквенным обозначением. В правом верхнем окне расположен список доступных операций, которые можно выполнять с вашими данными. Эти операции следующие:

+ -сложение;
- -вычитание;
* -умножение;
/ -деление;
^ -возведение в степень;
"-" -унарный минус (обозначение отрицательного числа);
LOG -натуральный логарифм;
EXP -экспонента;
ABS -абсолютная величина;
SUM -сумма всех чисел по вектору (одному ряду данных);
MIN -нахождение минимального числа в данном векторе;
MAX -нахождение максимального числа в векторе;
( ) -скобки для определения приоритетов.

Все операторы являются стандартными для основных языков программирования за исключением SUM, который превращает вектор в число (суммирует значения данного показателя по всем выделам), а также MIN и MAX, использующихся для нахождения самого большого и самого маленького числа в векторе (полезно для нормировки и расчета отклонений). Стандартные операторы работают с векторами покомпонентно. Операции допустимы не только с переменными-векторами (обозначаемыми соответствующими буквами), но и с произвольными числами - как целыми, так и действительными. При написании действительных чисел употребляйте стандартную компьютерную форму их записи, при которой вместо разделяющей запятой используется точка (1.345, 3.1415). Интерпретатор не распознает экспоненциальную форму записи больших чисел, поэтому вместо 1.32Е+5 следует употреблять выражение 1.32*10^5 или 13200. Правила записи формул и приоритеты операций стандартные:

- сначала выполняются унарные операции (LOG, EXP, "-"...);
- затем возведение в степень (^);
- после умножение и деление (*, /);
- и наконец, сложение и вычитание (+, -).

Приоритеты операций могут быть изменены расстановкой скобок, при этом не забывайте правило "открыл скобку - закрой". Всего проверено 25 уровней вложенности скобок, что для практических целей оказывается более, чем достаточно, тем более, что при использовании унарных операций заключать операнд в скобки вовсе не обязательно: LOG(a) = LOGa = LOG a -эти записи эквивалентны.
Как переменные, так и операторы могут быть записаны и строчными и прописными буквами - восприняты они будут правильно, например: Exp(a) = EXP A = expA = eXp(A). Между операторами и переменными допускается один или несколько пробелов.

Несколько примеров написания формул :

a/((maxa- min a)/2)
a*exp b+c^0.54
(c*.05+Log(d))^3.14
(a+(b+(c+(d+ABS b)))^(a/b)+567.732)+(-a -8.9*e)

Для записи формул предназначено стандартное окно текстового редактора, расположенное ниже списка операторов. Нажатие клавиши Enter или кнопки "Расчет" после ввода текста формулы будет означать команду на счет.
Если при разборе введенной формулы выявлены синтаксические ошибки (непарные скобки, имя переменной состоит не из одной буквы и т.д.), то будет выдано соответствующее предупреждение и введенная формула будет возвращена вновь на редактирование. Внимательно просмотрите текст и попытайтесь устранить ошибку прежде, чем запускать формулу вновь на счет.
Если формула синтаксически правильна, но в результате работы выявлены нештатные ситуации типа деления на ноль, переполнения и т.д., то расчет все равно будет проведен до конца. В этом случае для переменных, при обработке которых выявлены некорректности, в качестве результата в базу будет записана метка "Нет данных", выводимая на карту голубым цветом. Эта же метка записывается и в том случае, если в исходных векторах для данного региона есть хотя бы одна метка отсутствия данных, то есть, по смыслу для данного региона не производится никаких операций с отсутствующими данными во избежание получения заведомо некорректных результатов.
Результатом успешного счета будет являться вывод на экран соответствущей карты. Это еще одна "изюминка" DataGraf, позволяющая существенно интенсифицировать аналитический процесс. Введя формулу, вы сразу получите на экране небольшую картограмму, отображающую пространственное распределение расчетного показателя - здесь практически воспроизводится то, что вы увидели бы, записав расчетное значение в базу данных, затем перешли из вычислителя в режим картографии и вывели бы на экран. Моментальное представление результатов расчета в виде картографического образа позволяет оценить полученный результат и, исходя из полученных впечатлений, либо сохранить его в базе данных, либо отвергнуть (например за очевидностью) и перейти к проверке другой гипотезы, не сохраняя результат. Для продолжения работы без записи показателя используйте кнопку "Выход" или просто нажмите клавишу Esc.
В случае, если полученные результаты вас удовлетворяют и вы решили сохранить их для последующих операций, в окно "Название" введите удобное вам имя будущего показателя (как обычно до 20-ти символов) и, при необходимости - подробное описание. После этого нажмите на дискетку (или просто клавишу Enter) - новый показатель готов ко всем последующим математическим и картографическим операциям. После записи нового показателя вы возвращаетесь в пенель вычислителя, где можете считать по новым формулам и продолжать эксперименты.
Если для расчетов вам необходм другой набор показателей или вообще другая база данных - нажмите на кнопку "Выбрать данные" с изображением чистого листа. На месте списка показателей вновь появится меню выбора данных, вы можете выбрать другой их набор и продолжить эксперименты не выходя из Вычислителя.

Внимание! Режим Вычислитель может быть использован, помимо своего основного назначения, также и для операций только с числами. Если Вы будете использовать в формулах исключительно числа, то результат счета по формуле будет представлен также числом. Например, в текстовом редакторе: 2*2 , результат: 4; в редакторе : (max a-min a)/2, результат: x, где x - будет медиана по вектору а. Тем самым, в режиме вычислителя вы всегда имеете под рукой удобный калькулятор, позволяющий быстро, не выходя из системы, произвести любой арифметический расчет.


DG Map Editor

DG Map Editor позволит вам легко и быстро превратить обычный графический файл BMP системы Windows в полноценно функционирующий векторный объект для картографии в системе DG. Эта операция называется оцифровкой и в профессиональной картографии осуществляется при помощи специальных устройств - дигитайзеров, а также сложных, объемных и дорогих программ. Данный редактор позволит вам сделать то же самое, но в кратчайшее время и с использованием только вашей компьютерной мышки. Скорость и удобство при этом не дежурные слова - прочтите эти инструкции, а затем попробуйте сами тестовый пример Moscow (карта 10-ти округов г. Москвы) - у меня лично на ее оцифровку ушло 30 секунд...
Векторные объекты, с которыми работает DG, подразделяются на 2 типа - площадные (например регионы) и точечные (например населенные пункты в регионе). Картографический редактор позволяет создавать и редактировать оба типа объектов.

Что нужно для начала оцифровки?

Для создания полноценной цифровой карты вам нужны две вещи - собственно карта в виде картинки любого компьютерного формата и список тех объектов, которые на ней изображены (области, районы, города и т.д.). Их предварительная подготовка потребует от вас некоторого времени и усилий, но на самом деле не столь больших.

Создание списка объектов (регионов, городов и т.д.). В любой таблице пространственно организованных данных обычно первым столбцом ("боковиком" таблицы) являются названия регионов. Именно этот список и необходим в качестве основного "смыслового" файла для процесса оцифровки - в процессе работы вы будете связывать названия регионов с их местоположением на карте. Создать этот список довольно просто в любом текстовом редакторе (например Блокнот). Просто введите названия нужных регионов в столбик - каждое на отдельной строке, убедитесь, что в файле нет пустых строк и запишите на диск .
Внимание! При задании имени файла имейте в виду, что в дальнейшем именно так и будет называться как векторная карта, так и основная, привязанная к ней база данных, поэтому выбирайте уникальное название, не повторяющее названия уже существующих в данном проекте баз и карт. Также для собственного удобства придумывайте такие названия, которые впоследствии позволяли бы вам легко отличить точечные карты от площадных. Не делайте название длиннее 20 символов, иначе оно может не поместиться в выпадающее меню программы и при записи будет автоматически укорочено. И последнее - расширение этого текстового файла должно быть обязательно стандартным - *.txt . В качестве образца правильной структуры файла можете посмотреть прилагаемый файл Moscow.txt.

Подготовка графического файла. Найдите подходящую картинку с изображением интересующей вас карты в любом графическом формате. Размер ее может быть любым - основной ориентир при этом - чтобы картинка полностью умещалась в ваше экранное разрешение, иначе оцифровать ее будет невозможно. Формат создаваемых карт векторный, допускающий произвольное масштабирование, поэтому в дальнейшем вы легко сможете получить не только уменьшенный, но и увеличенный вариант вашей карты того же самого качества, что и в исходном масштабе. Поэтому не стремитесь брать для оцифровки большие изображения, вполне достаточно будет картинки размером 500-700 пикселей (точек), которые без труда уместятся полностью на большинстве современных мониторов.
Внимание! Исходный размер вашей картинки в экранных пикселях называется базовым и в отдельных случаях играет немалую роль. Дело в том, что DG располагает уникальной возможностью распознавания и автоматического пересчета значений с одной контурной сетки на другую, а также одновременной работы с площадными и точечными объектами, если они относятся к той же самой территории. При оцифровке следует иметь в виду, что для таких карт (одна территория, но разные принципы деления) базовый размер должен быть одним и тем же, в противном случае пересчет и наложение будут невозможны. На практике это лучше всего реализуется если с самого начала вы имеете одну исходную картинку с внешней границей (например страны), которая используется как "заготовка" для изображения внутренних границ для всех принципов деления. Использование единой заготовки гарантирует совпадение не только базового размера, но и внешних границ, что существенно повышает точность пересчета.

Далее необходимо с использованием любого графического редактора (например стандартного Paint) сделать из вашей картинки черно-белую "сетку" с границами. Если области закрашены, залейте их белым, если есть надписи - удалите, они будут мешать. Если границы регионов у вас не черные, а фон картинки не белый - можете их оставить, программа это допускает. Важно, чтобы к окончанию предварительной работы у вас образовалась контурная карта с замкнутыми пространственными выделами, а фон карты (как снаружи, так и внутри выделов) был одним и тем же. Все эти операции очень просто осуществляются в любом графическом редакторе, с которым вы умеете работать (см. пример работы в обычном Paint, встроенном в Windows). Для нормальной работы Map Editor важно лишь соблюсти следующие условия:

  • все контура должны быть замкнутыми. Это легко проверяется заливкой контура каким-то цветом. Если цвет "утекает" за карту или в соседние контура, поищите разрыв границы (в режиме увеличения) - "дырка" могла образоваться при удалении надписей и т.д. Залатайте ее цветом границы и еще раз проверьте.
  • все границы должны быть изображены одним цветом. Это не обязательно должен быть черный цвет, но обязательно один для всех границ на контурной карте.
  • толщину линий рекомендуется делать в одну точку. В принципе она может быть любой, но от нее очень сильно зависит качество оцифровки. Окончательный формат карты - векторный, в котором границы каждого региона представлены совокупностью линий, поэтому если граница между двумя регионами будет например толщиной в 2 точки, то при увеличении две рядом идущих линии "разъедутся" и в этом месте между границами появится разрыв. Обращайте также внимание на "чистоту" точек пересечения линий, стараясь их делать минимально достаточными для того, чтобы цвет не "утекал" и убирая все лишние точки, которые образуют на картнинке "грязь", а после векторизации потребуют от вас дополнительных усилий по редактированию получившейся карты. Примеры "грязного" (красный) и "чистого" (зеленый) фрагментов карты приведены на иллюстрации:

    • Не пожалейте времени на "очистку" исходной картинки и вы немало сэкономите на последующей ее "доводке", т.к. на "чистой" картинке после векторизации практически нечего редактировать и она сразу готова к работе.
  • цвет фона может быть не белым, но должен быть одним и тем же для всей карты (как снаружи, так и внутри). Имейте в виду, что он определяется автоматически по самой левой-верхней точке картинки, поэтому если, например, вокруг картинки есть какая-то рамка, то сотрите ее или сделайте где-нибудь слева-вверху в ней разрыв хотя бы в одну точку (зачем - будет сказано ниже).

После того, как контурная карта "почищена", все контура замкнуты и вы довольны своей работой, запишите ее на диск в формате *.BMP (который поддерживается буквально всеми редакторами). При этом лучше всего сразу записывайте ее в формате BMP-16 цветов, что обеспечит минимально возможный размер файла и максимальную скорость работы программы.
Внимание! Точечные объекты имеют картографичский смысл только в привязке к каким-то регионам (например населенные пункты). Поэтому для их создания используйте те же самые BMP-изображения, что использовали для создания площадных объектов (регионов) и размещайте в том же самом проекте. Использование тех же самых картинок гарантирует вам идентичный базовый размер будущих карт и, соответственно, полную их совместимость как в пересчетных, так и в картографических процедурах.

Теперь вся необходимая работа проделана, перепишите оба только что сделанных файла в директорию (папку), нужного проекта и можно начинать собственно оцифровку.
Если вы создаете карту для нового проекта, то сначала нужно загрузить DG и создать этот проект, а затем переписать в него файлы. Переписывайте файлы именно в директорию (папку) с названием проекта, а не в расположенную там же поддиректорию MAP, которая является служебной! В этой поддиректории ничего вручную изменять нельзя.

Процедура оцифровки

Перед тем, как приступить к работе, решите какой тип объектов вы собираетесь создавать и выберите режим оцифровки, нажав одну из этих кнопок-переключателей: Р(егионы) - включает режим оцифровки площадных объектов, Т(очки) - включает оцифровку точечных объектов. Одновременно можно работать лишь с одним типом объектов, при загрузке программы по умолчанию всегда включен режим Р(егионы).

Нажмите кнопку с изображением контурной карты, а затем выберите название BMP-файла с ее изображением. Она будет выведена в окно программы и вы заметите, что фон вокруг карты станет светло-желтым, а контура внутри регионов останутся прежнего цвета, что делает изображение более контрастным и позволяет не "потерять" отдельные мелкие элементы карты (например острова). Именно для этого и нужен был разрыв в (возможной) рамке - заливка фона никак не влияет на оцифровку, но делает ее более удобной. Ваша исходная картинка при этом никак не изменяется.

Далее загрузите список названий регионов/точечных объектов - нажмите кнопку с изображением листа и выберите из директории с вашим проектом имя текстового файла со списком. Вы заметите, что в белом окошке справа появилось первое название из вашего списка. Это значит, что можно начинать собственно процедуру оцифровки - связывания названий выделов/точек и их местоположения на будущей карте.

Точечные объекты

Процедура оцифровки точечных объектов чрезвычайно удобна и проста - для объекта, название которого печатается программой в окошке, вы отмечаете его местоположение на картинке, нажав левую кнопку мыши. На этом все - данный объект оцифрован, на карте в указанном вами месте появляется красная точка, а в окошке выдается название следующего объекта. Повторяйте эти нехитрые действия до тех пор, пока не завершится весь список.

Площадные объекты

Последовательность действий при оцифровке площадных объектов столь же проста - для пространственного выдела, название которого печатается программой в окошке, вы отмечаете соответствующий контур(а) на картинке, нажимая левую кнопку мыши. При этом выбранный контур заливается красным цветом. Следует отметить, что одному названию могут соответствовать несколько контуров на карте - например к Ненецкому округу относится не только материковая часть, но и острова Новой Земли:

В подобных случаях отметьте все контура, относящиеся к региону с данным названием. Старайтесь помечать (особенно маленькие) контура, помещая курсор мыши ближе к его центру - это гарантирует, что вы отметите именно нужный регион. Однако, если вы ошиблись и залили не тот контур, нажмите на нем кнопку мыши еще раз - он перекрасится в цвет фона и вы сможете исправить допущенную оплошность.
Внимание! Сам процесс оцифровки чрезвычайно прост, однако есть один момент, который обязательно следует иметь в виду для достижения желаемого результата. Речь идет о проблеме "островов" - например Адыгея расположена полностью внутри Краснодарского края, являясь своеобразным "островом" (слева на рис.). Точно таким же "островом" является г.Москва по отношению к Московской области (справа). При оцифровке внешних регионов (в данном случае Краснодарский край и Московская область) курсор мыши следует помещать не снизу, а над "островом", руководствуясь правилом - чтобы при движении от вашей точки вверх нигде не пересекалась граница "острова". Соблюдайте это несложное правило и ваши объекты всегда будут оцифрованы верно.

После того, как контур(а), относящийся к текущему названию региона, закрашен, нажмите кнопку справа от списка. Оцифровка региона закончена - контура перекрасятся в зеленый цвет, а в текстовом окошке появится название следующего по списку региона. Далее процедура повторяется до тех пор, пока вы не оцифруете весь список и вся карта не будет закрашена зеленым.
Внимание! После того, как контур(а) для региона записаны и в списке появилось следующее название, отменить или исправить сделанное становится невозможно. Поэтому будьте внимательны и лучше лишний раз проверить соответствие контура названию, чем начинать всю работу заново.

Число контуров, с которыми работает DG Map Editor не ограничено. Поэтому ваша карта может быть сложной, содержать, например, тысячу контуров и оцифровать ее за один раз будет весьма проблематично. Для этого случая предусмотрен режим записи проделанной работы. Нажмите на дискетку - все оцифрованные регионы будут записаны на диск, вы можете выходить из программы и возвращаться к оцифровке в любое удобное время. Это относится как к площадным, так и к точечным объектам.

Для того, чтобы продолжить начатую ранее работу, нажмите на эту кнопку и выберите файл, с которым вы работали в прошлый раз. Состояние программы восстановится ровно в том месте, где вы ее оставили и вы можете продолжать прерванную работу. При этом программа распознает тип сохраненного объекта (площадной/точечный) и автоматически включает соответствующий режим оцифровки.
Внимание! Незаконченная работа записывается в директорию вашего проекта (рядом с двумя файлами, которые переписывались вами сюда вручную) во временный файл с названием вашей незаконченной карты, но расширением *.$$$. Не стирайте файлы с этим расширением, иначе ваш труд пропадет даром. Обратите внимание, что для продолжения оцифровки проекта нужно пользоваться именно этим режимом, а не начинать с открытия графического файла с картинкой. Если вы начнете работу с этой же картой/списком заново, то при записи на диск будут сохранены только свежие изменения, а вся проделанныя ранее работа пропадет.

Векторизация

После завершения оцифровки последего контура (точки), программа производит векторизацию карты - превращение помеченных вами замкнутых областей или точек в полноценную масштабируемую векторную карту. Эта операция производится автоматически и не требует от вас никаких действий. Для площадных объектов ход ее отображается на экране последовательным перекрашиванием регионов в красный цвет. Процедура занимает буквально секунды, после чего программа поздравляет вас с завершением оцифровки специальным сообщением и записывает в поддиректорию MAP текущего проекта файл с картой ваше_имя.dgm и новую базу данных для этой карты с одним пробным показателем ваше_имя.dg. Ничего не изменяйте в этой поддиректории, там находятся только рабочие файлы программы, а вот список регионов, который вы переписывали в основную директорию проекта, можете стереть, он больше не нужен. Оцифрованные файлы для площадных и точечных объектов имеют одно и то же расширение и внешне ничем друг от друга не отличаются, поэтому для собственного удобства в будущем придумывайте такие названия исходным файлам (со списком), которые позволяли бы вам легко их различать.
Обратите внимание, что модуль автоматической векторизации (для площадных объектов) стремится сделать окончательную карту максимально похожей на изображение на вашей исходной картинке. Поэтому если вы предварительно не "почистили" изображение, то оно останется таким же "грязным", а при увеличении все дефекты будут проявляться еще более отчетливо. Файл с картой при этом будет большего размера, а в отдельных случаях часть контуров может быть даже недооцифрована - это происходит, если программа попала в замкнутый "лабиринт" из лишних точек и не смогла "найти выход". Поэтому настоятельная рекомендация - перед оцифровкой "почистите" изображение, чтобы на нем все линии были толщиной в 1 точку и не было скоплений "лишних" точек. В этом случае векторизация происходит идеально, ваша карта имеет минимально возможный размер и практически не требует какого-либо редактирования. К точечным объектам это не относится, они не связаны с изображением и их можно цифровать на картинке любого качества.
Внимание! Существует объективное ограничение на размер одного вектора (региона на вашей карте) - он не должен превышать 1024 точек (узлов, в которых линии меняют направление). Если при автоматической векторизации программа находит, что это число превышает указанное значение, то она прекращает работу и рекомендует упростить данный вектор. Выйдите из программы и в графическом редакторе попробуйте убрать лишние "изгибы", аппроксимируя их прямыми линиями. Обычно вектор средней величины и сложности имеет размер 100-200 точек, поэтому на практике вы можете ни разу и не столкнуться с этим ограничением, однако имейте в виду, что оно существует. Для примера - такое количество точек может иметь один сложной формы контур размером примерно в 640*400 точек. Если вам для каких-то нужд нужно оцифровать карту в 2-3 таких больших контура, то лучше с самого начала сделайте размер картинки раза в два поменьше - это практически не ухудшит качество, зато вы никогда не столкнетесь с данным ограничением. В связи с этим практический совет: если вам нужна карта примерно в 10 контуров, то не берите большое изображение - уменьшите его до 200-300 точек и вы никогда не столкнетесь с описанным ограничением, файл карты будет до смешного маленьким, а качество изображения практически не пострадает - ведь вы всегда его сможете увеличить.

Редактирование векторных объектов

Если вы хотите что-то подправить на созданной векторной карте или просто посмотреть, как выглядят оцифрованные вами объекты, воспользуйтесь встроенным векторным редактором. Для этого нажмите кнопку "Открыть" - ту же самую, что использовалась для продолжения работы с недооцифрованными регионами - и выберите из поддиректории MAP нужного проекта файл с необходимым именем и расширением *.dgm - это и есть ваша оцифрованная карта. Редактор автоматически узнает тип оцифрованной карты и после ее выбора автоматически входит в нужный режим редактирования.

Точечные объекты

Если оцифрованная карта точечная, то сразу же после выбора карты вам будет предложено еще одно меню, откуда необходимо будет выбрать BMP-файл с картинкой, по которой вы производили оцифровку - она нужна в качестве "подложки", чтобы вам можно было ориентироваться, меняя местоположение точек. Процедура редактирования сводится именно к этому - вы помещаете курсор мыши на нужную точку, нажимаете левую кнопку и, не отпускяя ее, перемещаете курсор в требуемое место. Затем отпускаете кнопку - точка перемещена. Обратите внимание, что при нажатии кнопки на точке, в верхнем окошке для вашего удобства печатается соответствующее название. Переместив нужные точки в требуемые места, запишите изменения, нажав на дискетку - редактирование закончено.

Площадные объекты

Для редактирования любого площадного объекта (региона) на выведеной карте, дважды щелкните по нему мышью, после чего откроется окно векторного редактора и в него будет загружено ваше изображение.
Редактируемый вектор представляет собой набор точек, соединенных линиями. Каждую точку можно двигать, "зацепив" мышью при нажатой левой кнопке, при этом за ней в новое положение будут "тянуться" линии, соединяющие ее с соседними точками. Основной вектор (выбранный регион ) представлен точками и линиями красного цвета, кроме него в окне будут прорисованы зеленым цветом границы соседних регионов, что позволяет легко ориентироваться и без труда заметить существующие расхождения в координатах.
Основная идея редактирования - передвижением соответствующих точек добиться, чтобы все границы с соседними регионами в точности совпадали - при полном совпадении общая граница становится синей. Точки можно не только передвигать, но и удалять и добавлять новые. Этих возможностей вполне достаточно, чтобы даже "грязно" оцифрованную карту при должном старании превратить в полностью "чистый" красивый масштабируемый объект.

При загрузке окна редактора выбранный вектор автоматически масштабируется по размерам окна. Для больших регионов коэффициент масштабирования может быть не очень высоким и соседние точки будет трудно отличить друг от друга. Для увеличения изображения нажмите кнопку "Увеличить". Обратите внимание, что после увеличения вы будете видеть в окне только часть изображения, для просмотра и редактирования остального можно "прокрутить" его в окне или увеличить размер окна самого векторного редактора - вплоть до разворачивания на полный экран. Нажимайте эту кнопку несколько раз до тех пор, пока не добьетесь желаемого масштаба, после чего можете увеличить размер окна программы и приступать к редактированию.
Внимание! Верхнего ограничения на увеличение изображения не предусмотрено, поэтому если на вашем компьютере не очень много памяти, то может случиться так, что после очередного нажатия этой кнопки изображение исчезнет и окно останется серым. Это значит, что у вас просто не хватает памяти для размещения столь большого прокручиваемого изображения. Нажмите кнопку "Уменьшить" (следующая) и изображение восстановится таким, как было на предыдущем шаге. Как правило даже на не очень мощных компьютерах памяти вполне хватает для увеличения изображения до вполне приемлемого уровня, когда соседние точки хорошо различимы друг от друга.

Нажимайте эту кнопку при необходимости уменьшить масштаб редактируемого изображения. В отличие от предыдущего случая для уменьшения изображения есть объектиный порог - оно уменьшается до оригинального размера (как на первоначально оцифрованной карте), после чего эта кнопка уже не производит никаких действий.

Кнопки Т+ и Т- предназначены для удаления существующих точек и добавления новых. Они работают как выключатель - при нажатии кнопка остается "включенной", вы щелкаете мышью по нужной точке, она удаляется (или перед ней добавляется новая), после чего кнопка "выключается". Рядом с этими кнопками печатается общее число точек в векторе, а при нажатиии на точку - ее текущий номер.

После завершения редактирования вектора нажмите на кнопку "Завершить" (крестик), сделанные изменения останутся в памяти, окно векторного редактора закроется и вы можете выбрать для редактирования следующий регион, дважды щелкнув по нему мышью. После того, как все нужные вектора отредактированы, не забудьте нажать на дискетку, чтобы записать на диск произведенные изменения. Теперь можно завершать работу программы и возвращаться в DG, чтобы оценить проделанную работу.

Как видите, процедура превращения заранее подготовленных картинки и списка в оцифрованную карту чрезвычайно проста, равно, как и редактирование получившейся карты. В этом вы можете реально убедиться сами и попробовать себя на простейшем тестовом примере - файлы mosmap.bmp и Moscow.txt. Для тех, кто представляет, где на карте находятся север, юг, восток и запад не составит труда найти, например, Юго-западный округ и вся оцифровка займет максимум одну минуту, после чего можно сразу загрузить DG и насладиться проделанной работой.

Типичная процедура подготовки карты в редакторе Paint

1. Находим в Интернете интересующую карту - в данном примере это Архангельская область. Как правило найденные карты будут многоцветные (True color) и содержать дополнительные изображения и надписи.
2. Для того, чтобы в тысячи раз ускорить свою работу, сразу же пересохраните картинку в 16-тицветный формат BMP. При этом цвета картинки изменяются - из миллионов цветов остается только 16, с которыми теперь не так сложно работать.

3. На 16-тицветной карте (2) с использованием «Заливки» белым цветом снимаем основные фоны. Далее "подчищаем" рисунок, для чего используя "Ластик/Цветной ластик" и назначая фоновыми разные цвета, стираем ненужные для картосхемы рассеянные пиксели. При этом имейте в виду, что при нажатой правой клавише мыши ластик стирает только назначенные цвета.
4. Далее вычищаем все цифры и надписи, попадающие внутрь карты, чтобы они не мешали цифровке. После этого в увеличенном масштабе производим редактирование контуров, в т.ч. замыкание образовавшихся разрывов линий и замену цветов с темно-серого на черный (там где это нужно). Попиксельную прорисовку границ «Карандашом» удобнее всего производить назначив основной цвет (ставится при нажатии левой клавиши) черный, а фоновый (при нажатии правой клавиши) – белый.
5. Далее (на рис. не показано) проверяем "Заливкой" целостность всех контуров, которые собираемся цифровать. Если цвет "утекает" через границу, ищем и заделываем разрывы. В данном случае вокруг карты нарисована рамка. Последним действием делаем в ней слева-вверху разрыв в 1-2 точки (белым) или стираем часть - для оцифровки она не нужна.
На этом записываем изменения и можем приступать к оцифровке - вся подготовительная работа проделана.

Успехов!