QuickMap
- a powerful toy -

- Достойная замена ArcView, MapInfo и Microsoft Map для решения иллюстративных задач -
Непревзойденное по простоте средство для постижения основ компьютерной картографии

QuickMap программа очень маленькая, удобная и быстрая. Почему? Во-первых она написана не для Windows (как подавляющее большинство программ), а для людей. Посмотрите на размер файла - на одну обычную дискетку уместятся дюжина копий - такими могут быть все грамотно написанные виндовые программы. Во-вторых в ней нет абсолютно ничего лишнего, а только то, что требуется для решения поставленной задачи. И в самом деле - у нас де-факто стало стандартом наличие на любом компьютере MS Office, поэтому зачем нужно собственное хранилище данных, если есть Excel, в котором большинство строит и хранит свои таблицы? К чему конвертеры графических форматов, если есть обычный Paint, а изображения все-равно вставляются в документы Word? В этом отношении QuickMap - не самостоятельная программа, а скорее модуль для MS Office, представляющий для обычного пользователя достойную замену Microsoft Map.
Как работает программа? Чрезвычайно просто. Вы держите все ваши таблицы с цифровым материалом в Excel или даже в Word. При необходимости построить карту, выделяете и копируете столбец данных (несколько столбцов, всю таблицу) в буфер обмена, а затем нажимете соответствующую кнопку в QuickMap - карта готова, ее можно использовать. Минимально необходимая для этого процедура включает 7 (обещанных) щелчков мыши:
1. Выделяете столбец в Excel
2. Нажимаете иконку Копировать
3. Переходите в QuickMap
4. Нажимаете иконку Карта (строится карта)
5. Нажимаете иконку Копировать
6. Переходите в Word
7. Нажимаете кнопку Вставить.
Готово - картинка в документе, на всю бесхитростную процедуру затрачены буквально секунды. Вот, собственно, и все базовые приемы работы, а особенности подготовки данных и массу дополнительных возможностей, включая надписи, шрифты, палитры, легенду, стили, а также приемы создания ваших собственных цифровых карт, смотрите в подробных инструкциях по работе с программой.

Комплект и установка

Полный комплект системы включает в себя следующие файлы, наличие которых обязательно для нормальной работы:
- QMap.exe - картографический модуль
- QEd.exe - модуль оцифровки карт
- QMap.pal - создаваемые вами палитры
- QMap.chm - этот файл с инструкциями
- MAP/ - поддиректория внутри основной директории (папки) программы, в которой создаются служебные файлы данных в процессе работы. Изначально может быть пуста или содержать тестовые примеры. Не изменяйте файлы, находящиеся в этой директории, это может привести к потере работоспособности ваших картографических проектов. В стандартный пакет также входят дополнительные файлы - Test.xls, содержащий на листе Russia данные для тестовых примеров Россия-640.map, Россия-800.map, а на листе Moscow данные для проекта Moscow, карта для оцифровки которого находится в файле mosmap.bmp, а структура данных в файле Moscow.txt.
Установка системы чрезвычайно проста. Распакуйте архив в какую-нибудь удобную для вас директорию (вместе с поддиректорий MAP и содержащимися там файлами) - установка закончена, можно начинать работу. Если хотите установить на рабочем столе иконку QuickMap для быстрого запуска, щелкните на рабочем столе правой кнопкой мыши, выберите "Создать - Ярлык", а затем укажите местоположение программы - иконка создана.

Системные требования и контакты

QuickMap работает на любой 32-разрядной версии Windows (тестирован на 98/ME/XP), использует максимум 4 Мб оперативной памяти, не требует никаких внешних run-time модулей или библиотек. На самых ранних версиях Win-98 нормальная работа не гарантируется - в самой операционной системе здесь много ошибок, которые были исправлены в последующих версиях.
В процессе разработки каждый модуль тщательно тестировался и программа в целом является полностью работоспособной во всех режимах. Однако, если в процессе ее работы были замечены сбои, вызванные не вашими некорректными действиями, а самой программой - сообщите об этом по указанным ниже контактам. Официально зарегистрированные пользователи в кратчайшие сроки получат исправленную версию, они же будут уведомлены о появлении новых, расширенных версий системы с возможностью их бесплатного получения.

Приятной работы и всяческих успехов!

Артюхов Владимир
Mail: vart@aha.ru
Web: http://www.sci.aha.ru


QuickMap

QuickMap - картография

Принципы работы, назначение и краткое описание QuickMap смотрите в разделе "О программе" - если вы открыли этот документ впервые, то прочтите его, чтобы иметь общее представление о работе программы, прежде, чем приступать к подробным инструкциям по каждому режиму.

Подготовка данных

QuickMap по умолчанию работает с данными, организованными по принципу один регион - одна строка (см. прилагаемый пример Test.xls), поэтому если у вас другая организация данных, то их придется конвертировать в совместимую структуру, иначе работа не будет иметь практического смысла. Вы можете пользоваться абсолютно любой программой для подготовки и хранения ваших табличных данных (Excel, Access, Word, Lotus...), важно, чтобы структура одного столбца таблицы (или записи в базе данных) была следующей:
Название показателя
Описание показателя
# - число для 1-го региона
# - число для 2-го региона
# - число для 3-го региона
...
...
# - число для N-го региона
Иными словами блок данных - это 2 текстовых строки с названием и более подробным описанием показателя, а затем ряд чисел для каждого региона, расположенных каждый на отдельной строке. В качестве примера можно привести Excel-таблицу для 10-ти округов г.Москвы:

Дальнейшие комментарии, думается, будут излишними - принцип организации данных простой и естественный. Почему именно две текстовых строки - название (более короткое - выводится в меню) и описание (более длинное)? Это стандарт, идущий еще от DOS - версии картографической системы DataGraf и реализованный в он-лайновой картографии на http://www.biodat.ru и http://www.sci.aha.ru, он же будет поддерживаться всеми будущими версиями программы. Поэтому просто примите его как данность и вместо описания можете просто продублировать название показателя. Однако, сэкономив однажды, вы можете потерять в будущем, поэтому не пожалейте полминуты на развернутое описание показателя - именно оно выводится автоматически в качестве (редактируемого) заголовка к вашей карте, да и со временем вы сами себе скажете спасибо, прочтя, например, одновременно с "Числ.населения" еще и строку "Численность населения по переписи 1998 года (тыс.чел)"...
Внимание! На что действительно необходимо обратить внимание при подготовке данных, так это на последовательность названий ваших пространственных выделов и, соответственно, чисел. Вы оцифровали свою карту на основе некоторой последовательности регионов, поэтому если в какой-то таблице они расположены в ином порядке, то результат вы получите просто бессмысленный. Поэтому при подготовке данных всегда следите за тем, чтобы последовательность регионов/цифр всегда была той же самой, что и в самой первой таблице, на основе которой вы создавали карту. Если у вас уже имеются готовые таблицы, в которых структура данных не совпадает с исходной, их вовсе не обязательно перебивать вручную - воспользуйтесь рекомендациями по переиндексации таблиц в Excel и затратите на всю процедуру всего несколько минут.

Работа с программой

Перед началом работы выберите проект, с которым собираетесь работать - оцифрованную карту, фигурирующую под именем, которое вы определили в редакторе. Для этого служит выпадающее меню в крайнем левом окошке программы. После выбора проекта окно программы переместится в позицию, определенную заданным стилем и на экран будет выведена чистая контурная карта. Далее откройте Excel или любое другое приложение, где вы храните таблицы, выделите и скопируйте в буфер обмена данные, которые желаете выводить на карту - это может быть один столбец, несколько столбцов или вся таблица (лист Excel). Далее можно нажимать следующую кнопку "вывести карту".

Функции программы при нажатии этой кнопки засисят от того, что вы поместили в буфер обмена. Итак, если вы скопировали:
1. Один столбец таблицы. Если данные в буфере по структуре совпадают с загруженным проектом (оцифрованной картой), то на экране вы моментально увидите результат - карту, автоматически построенную по вашим данным. Если структура данных не совпадает с предусмотренной проектом, то карта построена не будет и программа выдаст сообщение об ошибке. Это происходит если в буфере обмена не текст, или текст, но не совпадающий с ожидаемым числом строк. Исправить ситуацию можно только скопировав в буфер блок данных нужной структуры.
2. Несколько столбцов таблицы (кроме первого). Если в буфере данные нужной структуры, то на экране, как и в предыдущем случае, будет моментально построена карта первого из вставленных показателей. Однако обратите внимание на то, что окошко, из которого вы выбирали проекты, при этом изменилось - в нем теперь находится список названий выбранных показателей. Теперь для построения следующей карты достаточно будет просто выбрать нужное название из этого меню - тем самым вы получаете возможность построить целую серию карт, не переключаясь каждый раз в Excel и обратно.. Кнопка [image] при этом служит для (повторного) построения карты, по показателю, название которого находится в меню. Самая первая строка в меню показателей "СПИСОК ПРОЕКТОВ" служит для завершения работы с выбранным списком - выберите этот пункт, затем вновь проект (из того же меню, которое изменится ), а дальше можете переносить в программу следующий ряд данных.
3. Вся таблица данных (или блок, включающий самый первый столбец с названиями). Для выбора всей таблицы (текущего листа) в Excel щелкните по левому верхнему углу поля - пустой клетке между А и 1. В этом случае в программу переносятся все данные, включая первый столбец, в котором расположены названия регионов. Здесь у программы появляется возможность проявить свои "интеллектуальные" возможности и она делает проверку (по первому слову) соответствия названий из импортируемой таблицы с теми, что вы задавали при оцифровке карты. Если в результате сравнения выявлены различия, то вам:
а) выдается предупреждение о несоответствии названий;
б) выдаются оба названия на проверку;
в) задается вопрос - продолжать ли работу дальше.
Если вы видите, что регион тот же, просто название написано немного по иному или есть опечатка, то отвечайте "Да" и смело продолжайте работу, если же названия разные, то значит таблица по структуре не совпадает с исходной и тот результат, что вы получите, не будет иметь смысла. Поэтому разумнее всего ответить "Нет" и затратить несколько минут на то, чтобы переиндексировать таблицу. Замеченные опечатки или разночтения в названиях лучше исправить с тем, чтобы программа в дальнейшем не заставляла отвечать на свои вопросы. Кстати, при проверке программой допускается наличие одной ошибки (опечатки) - это практически не влияет на результат, но делает ее менее "навязчивой".
Несмотря на некоторые неудобства, вы, думается, оцените по достоинству предварительную проверку импортируемых данных, ведь при этом вы имеете полную гарантию того, что построенные карты в смысловом отношении безупречны. Поэтому старайтесь максимально полно использовать эту возможность и всегда работать с целой таблицей - тогда вы никогда не столкнетесь с проблемой "перепутанных регионов".
Еще одна особенность работы с таблицей "целиком". Обратите внимание на вторую строчку в меню с названиями показателей - в тестовом примере из Test.xls это "Название" - первая строка первого столбца. При подготовке данных не оставляйте ее пустой - она тоже нужна для меню. Зачем? Выберите эту строчку из меню и увидите, что на экране появилась чистая "бланковка" вашей карты (без легенды). На ней можно надписать названия регионов и использовать в тех случаях, когда нужна просто контурная карта.
Примечание. Если таблица у вас большая, а нужные данные находятся в конце, то перед копированием всей таблицы вы можете скрыть лишние столбцы - тогда скопированы будут только оставшиеся и список показателей будет короче.
Внимание! Если вы производили в Excel какие-либо операции со столбцами данных (например суммирование), то при копировании этих столбцов можете получить ошибку "Неверная структура данных". В этом случае пролистайте текущую таблицу до самого конца (строка 65576) и увидите, что при суммировании Excel вставил туда результат по столбцам. Сотрите эти цифры и сохраните файл - дальше можно работать без проблем. К слову, QuickMap нормально распознает не только столбцы с первичными данными, но и результаты расчета по формулам.

После того, как карта построена и должным образом оформлена (см. далее) нажмите эту кнопку и она будет скопирована в буфер обмена Windows. Дальше с ней можно делать что угодно - она ушла из QuickMap и передается другим программам. Можете вставить ее в документ Word, а можете передать в любой графический редактор (Paint, ACD-See, Photoshop...), а из него записать на диск в любом графическом формате.
Примечание. Не задавайте вопросов, почему в Word картинка вставляется "размытой" - это он так ее интерпретирует на экране, а напечатана она будет нормально. Вставьте изображение например в Paint и убедитесь сами, что качество ее то же самое, что вы видите на экране QuickMap .

Таковы базовые функции QuickMap, далее описываются дополнительные возможности программы, позволяющие "оживить" вашу карту и сделать максимально приближенной к тому, какой бы вы хотели ее видеть.

Работа с текстом

Обратите внимание! На панели для этой возможности нет специальной кнопки, однако если вы дважды щелкнете левой кнопкой мыши на каком-нибудь из регионов, в этом месте на карте будет напечатано его название. Это позволяет в считанные секунды подписать интересующие вас регионы. Названия выводятся тем шрифтом, который был выбран до этого (см. ниже), в процессе "подписывания" вы в любое время можете изменить шрифт - пользуйтесь этим если нужно по смыслу выделить некоторые регионы из остальных.

Эта кнопка позволяет делать в любом месте карты любые надписи. При ее нажатии на экране появляется окошко текстового редактора, в котором по умолчанию присутствует текст из 2-ой строки вашего столбца данных - описания показателя. Тем самым вы имеете практически готовый заголовок к карте (если не поленились дать подробное описание при подготовке данных). Изначально окошко для редактирования выводится без границ - просто текст на белом фоне, однако, если щелкнуть на тексте правой кнопкой мыши, вокруг окошка появится пунктирная рамка. Она же появляется и после перемещения окошка, которое осуществляется мышью при нажатой левой кнопке. Размеры окошка можно менять стандартным образом - "потянув" за любую границу при нажатой левой кнопке. При этом находящийся в окошке текст автоматически выравнивается по центру и переносится исходя из заданных размеров. Таким образом вы имеете возможность поместить текст в любое место карты, произвольно изменить размер окна и сформировать тем самым общий вид текста, каким бы вы его хотели видеть на карте. Обратите внимание, что правая кнопка мыши работает как переключатель для рамки, поэтому если не хотите, чтобы ваш текст был в рамке, нажмите ее еще раз, чтобы удалить. Более того, рамка может стать не пунктирной, а сплошной - поэкспериментируйте и сами увидите при каких условиях.
Во время всех описанных манипуляций с окошком редактора в нем мигает курсор - вы можете в любое момент внести любые изменения в сам текст. Если курсор в окошке не мигает, то переместиться в него можно вторично нажав кнопку текста на панели или дважды шелкув мышью в окне редактирования. После того, как все готово - текст написан, красиво рамещен и отформатирован, вы можете закончить редактирование, нажав следующие клавиши:
Enter- завершает редактирование, ваш текст превращается в изображение и его уже нельзя редактировать. При нажатии Enter фон под текстом по умолчанию делается "прозрачным" и надпись выводится поверх картинки, не затираяя ее.
SHIFT+Enter - также заканчиват редактирование, но фон под текстом в границах рамки остается белым. Используйте это сочетание клавиш, если хотите на карте сделать контрастную "врезку", на которой рамка текста затирает часть изображения.
Esc - завершает редактирование, но текст не выводится на карту, а просто исчезает. Используйте эту клавишу если передумали писать текст или что-то не получилось как надо и проще начать с самого начала.
Количество надписей на одной карте не ограничено - закончив одну, можете сделать сколько угодно других - другим типом и размером шрифта, в другом месте, с другим форматированием.

Нажав эту кнопку, вы можете выбрать для своего текста любой шрифт, установленный на вашем компьютере. Имейте в виду, что шрифт выбирать следует только при открытом окошке редактирования с текстом. В этом случае выбрав шрифт, вы мгновенно увидите изменения. Выбранный ранее шрифт для вновь созданного окошка не действует.

Работа с палитрами

Палитра - это набор цветов, в которые окрашиваются контура в зависимости от числового значения - по сути это цветовое решение вашей карты. Выбор палитры производится выбором соответствующего названия из выпадающего списка, показанного на рисунке. Палитры вы создаете сами, назначая любой картографической градации любой цвет, число используемых палитр не ограничено. При смене цветовой палитры вся карта перерисовывается заново, поэтому сначала подберите палитру, а лишь затем пишите текст, иначе он пропадет. Набор палитр является общим для всех ваших картографических проектов, он хранится в маленьком файле QMap.pal, расположенном рядом с основной программой - не стирайте этот файл, иначе возможны проблемы в работе программы.

Нажатие этой кнопки приводит к появлению на экране встроенного редактора палитр, с помощью которого вы можете редактировать любой цвет в любой палитре, а также создавать свои собственные. В нижней части панели расположены цвета выбранной палитры, текущий (редактируемый) цвет отмечен рамкой вокруг соответствующего квадрата (первый на рисунке). Для выбора цвета просто щелкните мышью по соответствующему квадрату.

Редактирование производится тремя движками, позволяющими смешивать красный, зеленый и синий компоненты композитного цвета. При изменении положения движков цвет в соответствующем квадрате моментально изменяется, что позволяет видеть на глаз произведенные изменения. Подбирая цвет, имейте в виду, что левая часть спектра отражает минимальные числовые значения ваших показателей, а правая - максимальные. Освоив это несложное устройство, вы сможете создавать для своих карт уникальные и неповторимые цветовые решения.
Для того, чтобы сохранить сделанные в ходе работы изменения, перед выходом из редактора нажмите на кнопку с изображением дискетки. Редактировать можно не только собственно цвета, но и название палитры (в текстовом окошке). Пользуйтесь этим для того, чтобы не заводить новую палитру, если у вас есть та, которой вы давно не пользуетесь - назовите ее по новому, измените цвета и сохраните - ваш список палитр останется компактным и легко обозримым.
Завести новую палитру можно нажав кнопку с изображением чистого листа. Удаления палитр не предусмотрено, поэтому старайтесь не создавать много новых палитр, чтобы не путаться в длинном списке, а лучше изменяйте ставшие уже ненужными. Не удивляйтесь, если при вводе названия, программа не дает ввести больше 15 символов - это объективное ограничение, чтобы сделать выпадающий список палитр нормально читаемым. Если произвенные изменения не записаны, то они будут действовать и после закрытия редактора палитр, но только влоть до выхода из самой программы. Поэтому не забывайте сохранять проделанную работу, чтобы ваш труд не был напрасным

Работа со стилями

QuickMap позволяет придать всем картам вашего проекта единый уникальный стиль при минимальных затратах времени с вашей стороны. Один раз сформируйте и сохраните стиль, после чего все карты будут выводиться именно так, как вы это определили. Стиль включает в себя:

  • выбранную цветовую палитру
  • количество цветовых градаций на карте и в легенде
  • размер и расположение легенды
  • формат легенды и подписей
  • шрифт подписей в легенде
  • рамку вокруг легенды
  • расположение окна основной программы на экране

Сразу после создания проекта какой-либо стиль для него отсутствует, поэтому не удивляйтесь, что легенда при выводе расположена слева вверху. Просто нажмите кнопку редактора стилей и расположите все так, как вам того хочется. Однако, перед этим поместите окно всей программы на экране так, как вам удобно - это расположение тоже запишется и будет автоматически воспроизводиться при каждой загрузке проекта. Текущая на данный момент палитра также сохраняется, так что предварительно выберите необходимую. При нажатии кнопки редактора стилей появляется следующее окно:

а легенда, расположеннная на карте, теперь начинает вести себя точно так же, как и окошко для ввода текста, описанное выше - она перемещается в любое место карты, размер ее можно произвольно изменять стандартными приемами. Начните с того, что переместите ее в желаемое место.
Теперь можно выбрать число цветовых градаций (в выпадающем меню "Легенда") - оно определяет количество кубиков в легенде и цветов на карте. Градация - это дипазон чисел в вашем ряду данных, соответствующий одному цвету на карте - чем меньшее число градаций, тем более широкой диапазон чисел охватывает каждая из них. Градации в программе считаются по стандартной равнонаполненной шкале, что всегда обеспечивает вашей карте цветовую контрастность независимо от диапазона разброса числовых данных. Количество градаций вы можете изменять, выбирая из меню один из заданных фиксированных диапазонов - 3, 5, 7, 9, 13. Как правило этого вполне достаточно для решения практически всех возникающих задач.
После выбора числа градаций определите структуру легенды - расположение кубиков, для чего воспользуйтесь кнопкой "Несколько строк" и расположенным рядом выпадающим меню. Если кнопка не нажата, то все кубики вытягиваются подряд - в одну горизонтальную строку. Если кнопка нажата, то число строк, по которому распределяются кубики, зависит от числа, выбранного в меню - пояснять получится дольше, поэтому просто попробуйте и сразу поймете принцип.
После выбора структуры легенды часть кубиков и надписей наверняка выехали за границы легенды и не видны. Теперь самое время, потянув за края рамки, определить внешний размер поля легенды при новой ее структуре.
Увидев всю легенду, вы наверняка не будете удовлетворены размерами кубиков, текста и их взаимным расположением. Значит настала пора обратиться к до сих пор еще не упомянутому большому белому окошку в редакторе стилей. Это не что иное, как инструмент для изменения элементов легенды:
1. Попробуйте немного изменить размер красного прямоугольника (обычным способом) - отпустив кнопку мыши, вы увидите, что вслед автоматически изменяются размеры у всех кубиков легенды
2. Попробуйте немного подвинуть красный прямоугольник (нажав на нем левую кнопку мыши) - при отпускании кнопки вы увидите, что в результате этой операции изменяется взаимное расположение кубиков легенды - легенда "сжимается - раздвигается"
3. Попробуйте немного подвинуть желтый текст по отношению к красному прямоугольнику - когда вы его отпустите, то увидите, что и в легенде все надписи адекватно передвинулись. Заметьте, что при этом вы можете расположить текст над и под кубиками, и даже внутри них.
Выбрав удачные размеры кубиков, вы можете изменить размер шрифта для подписей (окошко "Шрифт"), а затем подправить взаимное расположение, внешние размеры и место легенды на экране. Все эти действия лучше производить с нажатой кнопкой "Рамка", позволяющей видеть внешние границы поля легенды, однако, если она вам на карте не нужна, то просто выключите эту кнопку.
После того, как вы удовлетворены достигнутым результатом, нажмите кнопку с изображением дискетки. Отныне при каждой загрузке проекта все ваши установки будут воспроизводиться, что позволяет вам автоматически придать уникальный стиль целой серии карт. Если для какой-то отдельной задачи заданный стиль вас не устраивает, то вы можете войти в редактор, изменить его и выйти не записывая - измененный стиль будет оставаться текущим вплоть до выхода их программы или загрузки другого проекта. Это позволяет не меняя "любимых" установок решать целый спектр смежных задач.

При построении легенды QuickMap автоматически форматирует числа, стараясь сделать их максимально компактными (например 5.016869 записывается как 5.02), но иногда возникает нужда подправить цифры, а то и вовсе заменить их на надписи (например: максимальное - среднее - минимальное). Для этого предназнана кнопка редактирования текста легенды, при нажатии на которую появляется таблица с автоматически посчитанными значениями, которые можно произвольно изменять. При изменении текста для перехода между строками используйте стрелки вверх-вниз, клавиша Enter тоже осуществляет переход на строчку ниже, однако ее нажатие в самой последней строке означает конец редактирования, исчезновение таблицы и выдачу на экран изменений. Если вы передумали редактировать текст легенды, просто нажмите Esc - таблица исчезнет, но легенда останется прежней.
Нулевые значения в градациях и легенде. При расчете градаций и формировании легенды QuickMap различает "смысловой" ноль от "несмыслового" и интерпретирует из по разному. К примеру всего в нескольких регионах страны производятся самолеты или автомобили, для всех остальных производство самолетов будет "смысловым" нулем - минимальной величиной, ниже которой оно быть просто не может. В этом случае все "нулевые" регионы программой закрашиваются просто белым фоном, на котором хорошо видны регионы, имеющие подобное производство. Те же случаи, когда ноль - это просто промежуточная величина (например среднегодовые температуры: от -15 до +20), никак не обрабатываются - ноль здесь выступает как обычное число из середины диапазона. Имейте в виду эту особенность для случаев, когда по каким-либо причинам вы предпочли бы "подавить" смысловой ноль и сделать фон "нулевых" регионов не белым - для этого достаточно вместо 0 ввести какое-нибудь очень маленькое число, например 0.000001, а затем вручную исправить легенду.

Приложение
Что делать с данными другой структуры?

Очень часто последовательность одних и тех же регионов в разных источниках данных не совпадает (даже в Госкомстате есть несколько разных стандартных классификаций регионов России). Если Вы имеете (например в Excel) таблицу, в которой последовательность регионов иная, чем в исходной, по которой оцифрована карта, - поступите следующим образом.

Для начала нужно создать индексный столбец (файл), устанавливающий соответствие номеров регионов в первом и втором списках. Идея проста - вы нумеруете второй список, а затем перемещаете из него название вместе с номером на ту строку, в которой расположено название этого же региона в исходном списке. После перемещения всех названий у вас образуется столбец чисел (номеров), устанавливающий искомое соответствие. Подробная процедура этого для Excel следующая:

1. Cкопируйте и вставьте на чистый лист Excel список регионов исходной базы данных, по которой оцифрована карта - первая колонка.
2. Скопируйте и вставьте в колонку рядом второй список регионов из таблицы, не совпадающей с исходной - вторая колонка.
3. В третьей колонке введите подряд числа от 1 до номера последнего региона в списке (т.е. пронумеруйте второй список).
4. Теперь по порядку первого списка ищите во втором соответствующий регион и в следующие две колонки (4 и 5) просто выделяйте и копируйте название вместе с номером (две ячейки), размещая их так, чтобы названия регионов в 1 и 4 колонке совпадали. Перенос номера вместе с названием обеспечивает в 5-ой колонке искомое индексирование, устанавливающее соответствие номеров регионов в первом и втором списках.
5. После того, как установлено соответствие для всех регионов, первые 4 колонки можно удалить, а сохранить лишь 5-ю колонку - номера, расположенные в порядке парекрестного соответствия 1-го и 2-го списков.
6. Сдвиньте всю колонку вниз на 2 ячейки и введите в 1-ю и 2-ю клетки значение "ноль" - это место для названия и описания.
7. Запишите этот список на диск с тем, чтобы его можно было использовать в дальнейшем. Индексация вручную делается всего один раз, а затем может многократно использоваться.

Теперь можно переструктурировать данные из второй таблицы, для чего:

1. Загрузите на один лист Excel вторую таблицу, на другой лист - созданный на предыдущих шагах список индексов.
2. Выделите колонку с индексами и скопируйте ее на лист с данными
3. Выделите всю таблицу и по этой колонке средствами Excel произведите сортировку всего листа в возрастающем порядке (для чего есть специальная кнопка).
4. Теперь все данные расположены в необходимой последовательности и их можно непосредственно использовать в QuickMap-картографии точно так же, как и исходную таблицу.

Следует заметить, что собственно процедура сортировки данных по времени займет от силы минуту. Остальное - подготовительный этап, который делается всего лишь раз, да и то может занять времени от силы 5-10 минут. Имеет смысл затратить это время на создание индексного файла, чем тратить гораздо больше на перенос даных вручную.

Приятной работы и всяческих успехов!

VArt 2005 ©


QuickMap Editor

Редактор QEd позволит вам легко и быстро превратить обычный графический файл BMP системы Windows в полноценно функционирующий объект для картографии в системе QuickMap. Эта операция называется оцифровкой и в профессиональной картографии осуществляется при помощи специальных устройств - дигитайзеров, а также сложных, объемных и дорогих программ. Данный редактор позволит вам сделать то же самое, но в кратчайшее время и с использованием только вашей компьютерной мышки. Скорость и удобство при этом не дежурные слова - прочтите эти инструкции, а затем попробуйте сами тестовый пример Moscow (карта 10-ти округов г. Москвы) - у меня лично на ее оцифровку ушло 30 секунд...

Что нужно для начала оцифровки?

Для создания полноценной цифровой карты вам нужны две вещи - собственно карта в виде картинки любого компьютерного формата и список тех объектов, которые на ней изображены (области, районы и т.д.). Их предварительная подготовка потребует от вас некоторого времени и усилий, на самом деле не столь больших.

Создание списка объектов (регионов). Если у вас возникла нужда в картографической визуализации, значит имеются какие-то цифровые данные по территориям, которые обычно хранятся в виде таблиц (например в Excel). QuickMap по умолчанию работает с данными организованными по принципу один регион - одна строка, подробнее об организации данных смотрите в описании картографического модуля. При этой организации данных обычно первым столбцом таблицы являются названия регионов. Именно этот список и необходим в качестве "смыслового" файла для процесса оцифровки - вы будете связывать названия регионов с их местоположением на карте. Создать этот список довольно просто - например в Excel выделите столбец с названиями, скопируйте в буфер, а затем вставьте в любой текстовый редактор (например Блокнот). Убедитесь, что в файле нет пустых строк, первое название стоит на первой же строке, а далее остается только записать файл на диск и подготовительный этап завершен. При задании имени файла имейте в виду, что в QuickMap именно так и будет называться ваш картографический проект, поэтому выбирайте уникальное название, говорящее само за себя. Не делайте его длиннее 15-20 символов, иначе оно может не поместиться в выпадающее меню программы. И последнее - расширение этого текстового файла должно быть обязательно стандартным - *.TXT. В качестве образца правильной структуры файла можете посмотреть прилагаемый файл Moscow.txt.

Подготовка графического файла. Найдите подходящую картинку с изображением интересующей вас карты в любом графическом формате. Размер ее может быть любым - при подборе размера ориентируйтесь на собственные нужды и планы по дальнейшему использованию будущик карт. Если вам необходимо будет хорошее качество при печати на бумаге во весь лист, подбирайте больший размер (например 1600 или 1000 точек), если достаточно будет скромных иллюстраций, вставленных в Word, то размер может быть и меньше (400-600 точек). Основной ориентир при этом - чтобы картинка умещалась в ваше экранное разрешение, иначе оцифровать ее будет невозможно.
Далее необходимо с использованием любого графического редактора (например стандартного Paint) сделать из вашей картинки черно-белую "сетку" с границами (см. прикладываемые примеры). Если области закрашены, залейте их белым, если есть надписи - удалите, они будут мешать. Если границы регионов у вас не черные, а фон картинки не белый - можете их оставить, программа это допускает, если за границами карты есть какое-то изображение - можете его также оставить (см. пример mosmap.bmp). Важно, чтобы к окончанию предварительной работы у вас образовалась контурная карта с замкнутыми пространственными выделами, а фон карты (как снаружи, так и внутри выделов) был одним и тем же. Все эти операции очень просто осуществляются в любом графическом редакторе, с которым вы умеете работать (см. пример работы с обычным Paint, встроенном в Windows). Для нормальной работы QuickMap важно лишь соблюсти следующие условия:

  • все контура должны быть замкнутыми. Это легко проверяется заливкой контура каким-то цветом. Если цвет "утекает" за карту или в соседние контура, поищите разрыв границы (в режиме увеличения) - "дырка" могла образоваться при удалении надписей и т.д. Залатайте ее цветом границы и еще раз проверьте. Толщина линий может быть любой, но наиболее эстетично смотрится граница толщиной в 1 точку (см. примеры).
  • цвет фона может быть не белым, но должен быть одним и тем же для всей карты (как снаружи, так и внутри). Имейте в виду, что он определяется автоматически по самой левой-верхней точке картинки, поэтому рисуя, например, рамку вокруг карты, оставьте небольшой отступ от края изображения, а для вашего удобства при оцифровке, сделайте где-нибудь слева-вверху в рамке разрыв хотя бы в одну точку (зачем - будет сказано ниже). После оцифровки, кстати, этот разрыв можете "заделать".

После того, как контурная карта "почищена", все контура замкнуты и вы довольны своей работой, запишите ее на диск в формате *.BMP (который поддерживается буквально всеми редакторами). При этом если на вашей карте нет какого-то цветного изображения, а только фон и контура, то лучше всего записывайте ее в формате BMP-16 цветов, а при наличии картинки - в BMP- 256 цветов. Это обеспечит минимально возможный размер файла и максимальную скорость работы программы.
Теперь вся необходимая работа проделана, перепишите оба только что сделанных файла в директорию (папку), в которой находится программа и можно начинать собственно оцифровку.

Процедура оцифровки

Нажмите кнопку с изображением контурной карты, а затем выберите название BMP-файла с ее изображением. Она будет выведена в окно программы и вы заметите, что фон вокруг карты станет светло-желтым ( как у этой страницы), а контура внутри регионов останутся прежнего цвета, что делает изображение более контрастным и позволяет не "потерять" отдельные мелкие элементы карты (например острова). Именно для этого и нужен был разрыв в (возможной) рамке - заливка фона никак не влияет на оцифровку, но делает ее более удобной. Ваша исходная картинка при этом никак не изменяется и будет выводиться в том же самом виде, как вы ее создавали.

Далее загрузите список выделов - нажмите кпопку с изображением листа и выберите имя вашего текстового файла со списком. Вы заметите, что в белом окошке справа появилось название первого региона из списка. Это значит, что можно начинать собственно процедуру оцифровки - связывания названий выделов и их местоположения на будущей карте.
Последовательность действий при этом чрезвычайно проста - для пространственного выдела, название которого печатается программой в окошке, вы отмечаете соответствующий контур(а) на картинке, нажимая левую кнопку мыши. При этом выбранный контур заливается красным цветом. Следует отметить, что одному названию могут соответствовать несколько контуров на карте - например к Ненецкому округу относится не только материковая часть, но и острова Новой Земли:

В подобных случаях отметьте все контура, относящиеся к региону с данным названием. Старайтесь помечать (особенно маленькие) контура, помещая курсор мыши ближе к его центру - это гарантирует, что вы отметите именно нужный регион. Однако, если вы ошиблись и залили не тот контур, нажмите на нем кнопку мыши еще раз - он перекрасится в цвет фона и вы сможете исправить допущенную оплошность.

После того, как контур(а), относящийся к текущему названию региона, закрашен, нажмите кнопку справа от списка. Оцифровка региона закончена - контура перекрасятся в зеленый цвет, а в текстовом окошке появится название следующего по списку региона. Если у вас не очень быстрый процессор, распознавание может занять несколько секунд - дожитесь, пока контура перекрасятся в зеленый и не нажимайте в это время никаких кнопок.
Далее процедура повторяется до тех пор, пока вы не оцифруете весь список и вся карта не будет закрашена зеленым. После завершения оцифровки последего контура, программа поздравляет вас с завершением оцифровки специальным сообщением и переписывает сделанные файлы в свою рабочую поддиректорию MAP. Ничего не изменяйте в этой директории, там находятся только рабочие файлы программы, а вот список регионов, который вы переписывали в основную директорию, можете стереть, он больше не нужен.
Внимание! После того, как контур(а) для региона записаны и в списке появилось следующее название, отменить или исправить сделанное становится невозможно. Поэтому будьте внимательны и лучше лишний раз проверить соответствие контура названию, чем начинать всю работу заново.

Число контуров, с которыми работает QuickMap не ограничено. Поэтому ваша карта может быть сложной, содержать, например, тысячу контуров и оцифровать ее за один раз будет весьма проблематично. Для этого случая предусмотрен режим записи проделанной работы. Нажмите на дискетку и все оцифрованные регионы будут записаны на диск, вы можете выходить из программы и возвращаться к оцифровке в любое удобное время.

Для того, чтобы продолжить начатую ранее работу, нажмите на эту кнопку и выберите файл, с которым вы работали в прошлый раз. Состояние программы восстановится ровно в том месте, где вы ее оставили и вы можете продолжать прерванную работу.
Внимание! Незаконченная работа записывается в текущую директорию во временный файл с названием вашего проекта, но расширением *.$$$. Не стирайте файлы с этим расширением, иначе ваш труд пропадет даром. Обратите внимание, что для продолжения оцифровки проекта нужно пользоваться именно этим режимом, а не начинать с открытия графического файла с картинкой. Если вы начнете работу с этим же проектом заново, то при записи на диск будут сохранены только свежие изменения, вся проделанныя ранее работа пропадет.

Как видите, процедура превращения заранее подготовленных картинки и списка в оцифрованную карту чрезвычайно проста и сводится исключительно к нажатию кнопки на мыши. На самом деле даже это описание намного сложнее, чем сама работа. В этом вы можете убедиться сами и попробовать QEd на простейшем тестовом примере - файлы mosmap.bmp и Moscow.txt. Для тех, кто представляет, где на карте находятся север, юг, восток и запад не составит труда найти, например, Юго-западный округ и вся оцифровка займет максимум одну минуту, после чего можно сразу загрузить QuickMap и на тестовых данных насладиться проделанной работой.

Типичная процедура подготовки карты в редакторе Paint

1. Находим в Интернет интересующую карту - в данном примере это Архангельская область. Как правило карты будут многоцветные (True color) и содержать дополнительные изображения и надписи.
2. Для того, чтобы в сотни тысяч раз ускорить свою работу, сразу же пересохраняем картинку в 16-тицветный формат BMP. При этом цвета картинки изменяются - из миллионов цветов остается только 16, с которыми теперь не так сложно работать.

3. На 16-тицветной карте (2) с использованием «Заливки» белым цветом снимаем основные фоны. Далее "подчищаем" рисунок, для чего используя "Ластик/Цветной ластик" и назначая фоновыми разные цвета, стираем ненужные для картосхемы рассеянные пиксели. При этом имейте в виду, что при нажатой правой клавише мыши ластик стирает только назначенные цвета.
4. Далее вычищаем все цифры и надписи, попадающие внутрь карты, чтобы они не мешали цифровке. После этого попиксельно производим редактирование контуров, в т.ч. замыкание образовавшихся разрывов линий и замену цветов с темно-серого на черный (там где это нужно). Попиксельную прорисовку границ «Карандашом» удобнее всего производить назначив основной цвет (ставится при нажатии левой клавиши) черный, а фоновый (при нажатии правой клавиши) – белый.
5. Далее (на рис. не показано) проверяем "Заливкой" целостность всех контуров, которые собираемся цифровать. Если цвет "утекает" через границу, ищем и заделываем разрывы. В данном случае вокруг карты нарисована рамка. Последним действием делаем в ней слева-вверху разрыв в 1-2 точки (белым), который после оцифровки можете заделать обратно.
На этом записываем изменения и можем приступать к оцифровке - вся подготовительная работа проделана.

Успехов!

VArt 2005 ©