О программе
"Конструктор тестов" это универсальная система проверки знаний. Данную программу можно использовать как в домашних условиях, так и для проведения тестирования в любых учебных заведениях. Программа позволяет использовать неограниченное количество тем, вопросов и ответов. Программа поддерживает пять типов вопросов, что позволяет проводить любые тесты. В тестах имеется возможность использовать музыку, звуки, изображения и видеоролики. Любые данные можно распечатать на принтере, экспортировать в файлы различных форматов (Word, Excel, Access, HTML, XML, Текстовый файл, Paradox, DBase и др.). На одном компьютере тестирование независимо могут проходить несколько человек, входя в программу под своими именами. Программа проста в использовании, имеет удобный и понятный русский интерфейс.

"Конструктор тестов" состоит из двух частей:
1. "Конструктор тестов. Редактор" - предназначен для заполнения и редактирования базы данных, а так же для различных настроек "Конструктора тестов".
2. "Конструктор тестов. Тренажер" - предназначен для проведения тестирования по тем темам и вопросам, которые были занесены в базу данных при помощи "Редактора".


Возможности программы
"Конструктор тестов" это универсальная система проверки знаний. В программе имеются следующие возможности:

Использование неограниченного числа тем, вопросов и ответов;

В опросы могут содержать музыку, звуки (файлы wav, mid. rmi);

В опросы могут содержать изображения (файлы jpg, bmp, ico, emf, wmf);

В опросы могут содержать видеоролики (файлы avi);

Поддержка пяти типов вопросов:

1. Выбор единственно правильного ответа;

2. Выбор нескольких возможных правильных ответов;

3. Установка последовательности правильных ответов;

4. Установка соответствий ответов;

5. Ввод ответа вручную с клавиатуры.

Печать на принтере и сохранение в файл тем, вопросов и ответов;

Печать на принтере и сохранение в файл результатов тестирования;

Экспорт тем, вопросов и ответов в файлы различных форматов (MS Excel, MS Word, MS Access, Paradox, DBase, Текстовый файл, HTML, XML, RTF (RichText format), PDF (Adobe Acrobat), буфер обмена MS Windows, Lotus 1-2-3 и др.);

Возможность проведения тестирования на одном компьютере несколькими пользователями. Для каждого пользователя заводится персональная карточка пользователя, поля в которой являются настраиваемыми.

Возможность установить разные права доступа к редактированию базы данных в "Редакторе" для разных пользователей;

Возможность задавать вопросы в произвольном порядке;

Возможность задавать цену каждому вопросу в баллах;

Возможность ограничить ответы по теме по времени;

Возможность прервать тестирование и продолжить его в другое время;

Возможность выставлять оценку по окончании тестирования. Система оценок настраивается в "Редакторе". Шкалу оценок можно настроить от 2-х бальной до 100-бальной системы;

Синхронизация базы данных. При помощи этой функции можно легко обмениваться данными с другими пользователями и переносить данные с компьютера на компьютер;

Проверка орфографии в "Редакторе";

Поиск по базе данных в "Редакторе";

Сжатие базы данных;

Функция проверки обновления через Интернет.


Конструктор тестов. Тренажер.
"Конструктор тестов. Тренажер" предназначен для проведения тестирования. База данных тем, вопросов и вариантов ответов, а также различные дополнительные настройки производятся в программе "Конструктор тестов. Редактор".


Вход в программу
В программе имеется возможность предоставить доступ к редактированию базы данных и изменению различных настроек, неограниченному числу пользователей. Каждого пользователя можно наделить различными правами доступа к редактированию базы данных. Права пользователя можно задать в администраторе пользователей.

После первой загрузки программы в списке пользователей есть только одно имя "Администратор". "Администратора" нельзя удалить из списка пользователей, а также изменить его права. Пользователь, вошедший в программу, как "Администратор", имеет полные права на редактирование любой информации. Если доступ к редактированию информации необходимо дать другим пользователям, то Вы можете добавить новых пользователей в администраторе пользователей, указав права для каждого конкретного пользователя. Для обеспечения конфиденциальности, любому пользователю, в том числе и "Администратору", можно задать пароль, который будет запрашиваться при входе в программу.


Администратор пользователей
Администратор пользователей предназначен для добавления, изменения и удаления пользователей из списка пользователей, а также для установки уровня прав пользователя на редактирование информации. Для обеспечения конфиденциальности, любому пользователю, в том числе и "Администратору", можно задать пароль, который будет запрашиваться при входе в программу.


Права пользователей
Для того чтобы ограничить возможности пользователя при работе с базой данных, существует система настройки прав пользователя, которые можно установить для каждого конкретного пользователя в администраторе пользователей.

Права пользователя можно ограничить по многим параметрам:

Управление администратором пользователей
  • Разрешить или запретить добавлять новых пользователей
  • Разрешить или запретить изменять существующих пользователей
  • Разрешить или запретить изменять пользователю свои имя и пароль
  • Разрешить или запретить удалять пользователей
  • Разрешить или запретить изменять права пользователей
Управление темами
  • Разрешить или запретить добавлять новые темы
  • Разрешить или запретить изменять существующие темы
  • Разрешить или запретить удалять темы
Управление вопросами
  • Разрешить или запретить добавлять новые вопросы
  • Разрешить или запретить изменять существующие вопросы
  • Разрешить или запретить удалять вопросы
Управление вариантами ответов
  • Разрешить или запретить добавлять новые варианты ответов
  • Разрешить или запретить изменять существующие варианты ответов
  • Разрешить или запретить удалять варианты ответов
Управление печатью
  • Разрешить или запретить использовать печать на принтере
Управление экспортом
  • Разрешить или запретить использовать экспорт


Окно тем и вопросов

В данном окне отображаются список тем и список вопросов, находящихся в базе данных. Также в этом окне есть главное меню, с помощью которого производятся различные настройки и управление программой.

Список тем.
Над списком тем расположен фильтр по категориям тем. Фильтр нужен для облегчения навигации по темам.

В списке тем отображаются темы, содержащиеся в базе данных. Управлять колонками таблицы тем можно при помощи редактора столбцов. В нижней части списка тем отображается информация о том, сколько в базе данных присутствует всего тем и вопросов во всех темах. Количество тем в базе данных не ограничено.

Под списком тем есть кнопки, с помощью которых можно добавлять новые темы, редактировать или удалять уже существующие. Добавление и редактирование тем осуществляется в редакторе тем. Каждая тема может иметь неограниченное количество вопросов.

Список вопросов.
В списке вопросов отображаются вопросы, содержащиеся в базе данных. Управлять колонками таблицы вопросов можно при помощи редактора столбцов. В нижней части списка вопросов отображается информация о том, сколько всего вопросов в текущей теме и суммарное количество баллов по всем вопросам данной темы.

Под списком вопросов есть кнопки, с помощью которых можно добавлять новые вопросы, редактировать или удалять уже существующие. Добавление и редактирование вопросов осуществляется в редакторе вопросов. Каждый вопрос может иметь неограниченное количество вариантов ответов.

Управление вариантами ответов по каждому конкретному вопросу осуществляется с помощью кнопки «Варианты ответов», которая находится в правом нижнем углу экрана, под списком вопросов.

Сортировка в списках тем и вопросов осуществляется путем нажатия на заголовок того столбца, по которому необходимо осуществить сортировку.


Главное меню окна тем и вопросов
Меню «Сервис»
  • Администратор пользователей (Вызов окна Администратор пользователей)
  • Войти в редактор под другим именем (Смена текущего пользователя)
  • Редактор категорий тем (Управление списком категорий тем)
  • Проверить орфографию (Проверка орфографии в редакторе)
  • Все темы
  • Текущая тема
  • Текущий вопрос
  • Поиск (Поиск по базе данных)
  • Экспорт (Экспорт базы данных в различные форматы)
  • Печать (Печать базы данных)
  • Синхронизация
  • Передать данные (Перенос базы данных с Вашего компьютера на другой)
  • Получить данные (Перенос базы данных с другого компьютера на Ваш)
  • Сжать базу данных (Сжатие базы данных для высвобождения дискового пространства)
  • Подтверждение перед выходом (Переключатель, который нужен для того, чтобы выдавать подтверждение при выходе из программы или не выдавать)
  • Выход из редактора (Закрыть программу)
Меню «Настройки»
  • Редактор Тренажера
  • Орфография (Настройки проверки орфографии)
  • Настройка столбцов (Настройка столбцов таблиц тем и вопросов)
  • Тренажер
  • Поля карточки пользователя тренажера (Настройка полей карточки Тренажера)
  • Язык интерфейса (Установки языка интерфейса)

Меню «Помощь»

  • Справка
  • О программе
  • Посетить сайт программы
  • Техническая поддержка по e-mail
  • Обновление через Интернет (Проверка на наличие новой версии программы через Интернет)
  • Регистрация (Вызов окна для ввода регистрационного ключа)


Редактор тем

Редактор тем предназначен для добавления новых тем в базу данных и для изменения уже существующих. Окно редактора тем содержит 5 закладок:

Основные данные

Номер темы
В данном поле указывается порядковый номер темы. Номер темы может быть только целым числом.

Название темы
В данном поле указывается название темы. В этом поле можно использовать до 255 символов.

Задавать вопросы по этой теме в случайном порядке
Если это поле отмечено, то при проведении тестирования с помощью Тренажера, вопросы по данной теме будут задаваться в случайном порядке.

Ограничить количество задаваемых вопросов по данной теме
Если необходимо ограничить число задаваемых вопросов по данной теме, то нужно отметить это поле и ввести количество вопросов, которое нужно задать в Тренажере.

Скрыть данную тему
Скрытые темы будут недоступны в Тренажере, но будут видны в Редакторе.

Дополнительные данные

Запретить прерывать тестирование по этой теме
Если это поле отмечено, то при проведении тестирования с помощью Тренажера, тестирование по данной теме прервать будет нельзя. В случае, если тестирование все же будет прервано, то все ответы, которые не были получены будут считаться неверными.

Скрывать индикатор результатов тестирования
Если это поле отмечено, то при проведении тестирования с помощью Тренажера, индикатор результатов тестирования отображаться не будет.

Скрывать правильные ответы в результатах тестирования
Если это поле отмечено, то при проведении тестирования с помощью Тренажера, пользователь не сможет увидеть правильные ответы к тем вопросам, на которые он дал неверные ответы.

Ограничить ответы по этой теме по времени
Если необходимо ограничить время, отведенное на ответы по данной теме, то укажите это время в данном поле.

После ответов на все вопросы данной темы
Подать звук
В данном поле можно добавить звук, который будет воспроизведен сразу после окончания ответов на вопросы по данной теме. Если поле «Подать звук» отмечено, то активизируется панель управления звуком.
На этой панели есть три кнопки для управления файлом звука:
- Загрузить звук в базу данных (Загрузка в базу данных звукового файла следующих форматов: WAV, MID, RMI)
- Сохранить звук в файл (Сохранение звука из базы данных в файл того формата, в котором звук находится в базе данных)
- Удалить звук из базы данных (Удаление звука из базы данных)

На панели управления звуком есть еще три кнопки, с помощью которых можно управлять звуком, который загружен в базу данных:
- Воспроизвести звук
- Сделать паузу в воспроизведении звука
- Остановить воспроизведение звука

Автоматически распечатать отчет
Если это поле отмечено, то сразу после окончания ответов на вопросы по данной теме на печать автоматически будет отправлен отчет с результатами тестирования по данной теме.

Приветствие

В данном поле можно ввести приветствие, которое будет показано пользователю перед тем как начать тестирование по данной теме в Тренажере.

Категории

Каждую тему можно классифицировать по четырем категориям. Управление списком категорий осуществляется при помощи редактора категорий. Классификация тем по категориям нужна для облегчения навигации по темам в главном окне Редактора и Тренажера при помощи фильтра по категориям.

Оценки

В «Конструкторе тестов» существует возможность выставлять оценку по окончании тестирования. Система оценок имеет гибкую настройку. Шкалу оценок можно настроить от 2-х бальной до 100-бальной системы. Для каждой темы можно настроить свою систему оценок.

Максимальное число баллов
В этом поле указывается максимальное число баллов в системе оценок тестирования.
Для того чтобы изменить число баллов системы оценок, необходимо ввести нужное число в это поле и нажать кнопку «Применить».

Таблица оценок
Таблица оценок содержит количество строк равное максимальному числу баллов. Редактирование таблицы оценок производится непосредственно в самой таблице. В поле «Оценка» можно указывать как числа, так и слова. В полях «от (%)» и «до (%)» указывается интервал баллов в процентах, которые наберет пользователь при тестировании в Тренажере. Сколько баллов в процентах наберет пользователь, такую оценку и получит. Пересечение интервалов в полях «от (%)» и «до (%)» для разных оценок недопустимо.

Ставить по данной теме оценку в окне результатов тренажера
Если данное поле отмечено, то в окне результатов тестирования Тренажера, пользователю будет выставлена оценка, в соответствии с тем, сколько баллов он набрал в процентах от суммарного количества баллов во всех вопросах текущей темы.

Скопировать оценки из другой темы
При помощи данной функции можно скопировать таблицу оценок из других тем в текущую тему.


Редактор вопросов

Редактор вопросов предназначен для добавления новых вопросов в базу данных и для изменения уже существующих. Окно редактора вопросов содержит 4 закладки:

Основные данные

Номер вопроса
В данном поле указывается порядковый номер вопроса. Номер вопроса может быть только целым числом.

Текст вопроса
В данном поле указывается текст вопроса. В этом поле можно использовать до 255 символов.

Тип вопроса
В данном поле указывается тип вопроса. Вопросы могут быть пяти типов:
1. Выбор единственно правильного ответа;
2. Выбор возможных правильных ответов;
3. Установить последовательность ответов;
4. Установить соответствия ответов;
5. Ввод ответа вручную с клавиатуры.

Баллы
В данном поле указывается цена данного вопроса в баллах, в зависимости от сложности вопроса. Баллом может быть любое целое число. По умолчанию цена вопроса равна одному баллу.

Показывать варианты ответов по данному вопросу в случайном порядке
Если это поле отмечено, то при проведении тестирования с помощью Тренажера, варианты ответов по текущему вопросу будут отображаться в случайном порядке.
У вопросов третьего типа данное поле отмечено всегда.
У вопросов пятого типа данное поле не может быть отмечено.

Скрыть данный вопрос
Скрытые вопросы будут недоступны в Тренажере, но будут видны в Редакторе.

Примечание

В данном поле можно ввести примечание, которое будет показываться пользователю в Тренажере при просмотре вопросов, на которые был дан неверный ответ.

Изображение

Каждый вопрос можно сопроводить изображением. В базу данных можно загрузить файлы изображений следующих типов: JPG, JPEG, BMP, ICO, EMF, WMF. В базу данных также можно загрузить видеоролик в формате AVI.
Панель управления изображением:
 - Загрузить (Загрузить в базу данных файл с изображением)
- Сохранить (Сохранение изображения из базы данных в файл того формата, в котором изображение находится в базе данных)
- Удалить (Удалить изображение из базы данных)

Если в базу данных загружен видеоролик, то появится панель управления воспроизведением видеоролика:
- Воспроизвести видеоролик
- Сделать паузу в воспроизведении видеоролика
- Остановить воспроизведение видеоролика

Звук

Каждый вопрос можно сопроводить звуком или музыкой. В базу данных можно загрузить файлы звуков следующих типов: WAV, MID, RMI.
Панель управления звуком:
На этой панели есть три кнопки для управления файлом звука:
- Загрузить звук в базу данных (Загрузка в базу данных звукового файла)
- Сохранить звук в файл (Сохранение звука из базы данных в файл того формата, в котором звук находится в базе данных)
- Удалить звук из базы данных (Удаление звука из базы данных)

Если в базу данных загружен звуковой файл, то появится панель управления звуковым файлом:
- Воспроизвести звук
- Сделать паузу в воспроизведении звука
- Остановить воспроизведение звука


Типы вопросов

Каждый вопрос может быть пяти типов:

1. Выбор единственно правильного ответа. Ответ на вопрос данного типа должен быть только один. После заполнения списка вариантов ответов на данный вопрос, в редакторе ответов нужно будет указать только один верный ответ.

2. Выбор нескольких возможных правильных ответов. У вопроса данного типа может быть несколько правильных ответов. После заполнения списка вариантов ответов на данный вопрос, в редакторе ответов нужно будет указать все верные ответы.

3. Установка последовательности правильных ответов. У вопроса данного типа все ответы являются правильными. Заполнять, в редакторе ответов , список вариантов ответов на данный вопрос следует строго в правильной последовательности. При тестировании Тренажером, верной последовательностью будет считаться именно та, в какой варианты ответов были введены в редакторе ответов . При тестировании, варианты ответов будут отображены в случайной последовательности.

4. Установка соответствий ответов. У вопроса данного типа есть несколько вариантов ответов и несколько соответствий вариантам ответов. В редакторе ответов необходимо заполнить два списка: список вариантов ответов и список соответствий вариантам ответов. После заполнения обоих списков нужно установить правильные соответствия.

5. Ввод ответа вручную с клавиатуры. При ответе на вопрос этого типа, пользователь должен будет ввести правильный ответ с клавиатуры, а не выбирать из списка предложенных вариантов ответов. В редакторе ответов необходимо заполнить список вариантов ответов всеми возможными правильными ответами. Как правило, верным ответов на вопрос пятого типа является только один, но бывают ситуации, когда верных ответов может быть несколько, например, при ответе на вопрос: Сколько будет 2 умножить на 2, правильными ответами могут быть и цифра 4 и слово «четыре».


Цена вопроса

Каждому вопросу можно назначить свою цену. Цена вопроса исчисляется в баллах. По умолчанию, каждому новому вопросу присваивается цена вопроса равная одному баллу. Однако, если сложность вопроса выше других вопросов по данной теме, то цену вопроса можно увеличить. Цена вопроса может быть любым положительным целым числом.

По окончания тестирования в Тренажере, пользователю выставляется оценка. Оценка рассчитывается не по соотношению количества верных и неверных ответов, а на основе количества набранных баллов.


Окно ответов

В данном окне отображаются название темы, название текущего вопроса, тип текущего вопроса и список вариантов ответов по текущему вопросу. Под списком вариантов ответов есть кнопки, с помощью которых можно добавлять новые варианты ответов, редактировать или удалять уже существующие. Добавление и редактирование вариантов ответов осуществляется в редакторе ответов.

Если тип текущего вопроса: «4. Установка соответствий ответов», то в окне ответов отображаются два списка: список вариантов ответов и список соответствий вариантам ответов, каждый из которых расположен на своей закладке, а рядом с кнопками добавления, изменения и удаления вариантов ответов есть кнопка «Выбор правильных соответствий». При нажатии на эту кнопку откроется окно, в котором для каждого варианта ответа, указываются правильные варианты соответствий.

В нижней части окна ответов расположена панель подсказок, которая поможет правильно заполнить список вариантов ответов, в зависимости от типа текущего вопроса.

Сортировка в списке ответов осуществляется путем нажатия на заголовок того столбца, по которому необходимо осуществить сортировку.


Редактор ответов

Редактор ответов предназначен для добавления в базу данных новых вариантов ответов и для изменения уже существующих, а также для указания правильных вариантов ответов.

Окно редактора ответов выглядит по-разному, в зависимости от типа текущего вопроса.

1 или 2 тип вопроса

Если текущий вопрос 1 или 2 типа, то окно редактора ответов выглядит следующим образом:

Номер ответа
В данном поле указывается порядковый номер варианта ответа. Номер варианта ответа может быть только целым числом.

Текст варианта ответа
В данном поле указывается текст варианта ответа. В этом поле можно использовать до 255 символов.

Под полем текста варианта ответа расположен переключатель, с помощью которого можно указать, является данный вариант ответа правильным или нет.

3 или 5 тип вопроса

Если текущий вопрос 3 или 5 типа, то окно редактора ответов выглядит следующим образом:

Номер ответа
В данном поле указывается порядковый номер варианта ответа. Номер варианта ответа может быть только целым числом.

Текст варианта ответа
В данном поле указывается текст варианта ответа. В этом поле можно использовать до 255 символов.

В отличие от вариантов ответов на вопросы 1 и 3 типов, переключатель правильных ответов отсутствует, так как у вопросов 3 и 5 типов все варианты ответов являются правильными.

4 тип вопроса

Если текущий вопрос 4 типа, то вид окна редактора ответов выглядит по-разному, в зависимости оттого, что Вы редактируете, варианты ответов или варианты соответствия ответов.

Если Вы редактируете варианты ответов, то окно редактора ответов выглядит следующим образом:

Номер ответа
В данном поле указывается порядковый номер варианта ответа. Номер варианта ответа может быть только целым числом.

Текст варианта ответа
В данном поле указывается текст варианта ответа. В этом поле можно использовать до 255 символов.

Если Вы редактируете варианты соответствий ответов, то окно редактора ответов выглядит следующим образом:

Обозначение ответа
В данном поле указывается порядковый номер варианта ответа буквой. Рядом с этим полем расположен переключатель-индикатор раскладки клавиатуры, который выполняет те же функции, что и стандартный индикатор Windows.

Текст варианта ответа
В данном поле указывается текст варианта ответа. В этом поле можно использовать до 255 символов.


Проверка орфографии в редакторе

Система проверка орфографии работает только в том случае, если на Вашем компьютере установлен MS Word с установленным компонентом проверки орфографии.

Проверить орфографию можно тремя способами:
1. У всех тем. Проверка орфографии будет произведена по всем названиям тем базы данных, текстам вопросов и текстам вариантов ответов.
2. У текущей темы. Проверка орфографии будет произведена только в названии текущей темы, в текстах вопросов и текстах вариантов ответов, относящихся к текущей теме.
3. У текущего вопроса. Проверка орфографии будет произведена в тексте текущего вопроса и по всем текстам вариантов ответов на текущий вопрос.

Существует возможность проверять орфографию автоматически. При включенной системе автоматической проверки орфографии, орфография будет проверяться при добавлении или изменении информации в темах, вопросах и вариантах ответов.
Включить автоматическую систему проверки орфографии можно в настройках программы.


Поиск по базе данных

С помощью функции поиска по базе данных можно искать темы, вопросы, ответы и соответствия ответов.

Возможен поиск в:
- названиях тем;
- приветствиях тем;
- тексте вопросов;
- примечаниях к вопросам;
- вариантах ответов;
- вариантах соответствий ответов.

Если поиск дал положительный результат, то найденные записи можно увидеть в окне "Результаты поиска". Из окна результатов поиска, при помощи кнопки "Перейти", можно переместиться на интересующую Вас запись в базе данных.


Экспорт базы данных

В программе имеется мощная и гибкая система экспорта базы данных, которая позволяет экспортировать любые данные из базы данных на выбор пользователя.

Выбор тем
Существует возможность выбрать все темы для экспорта, только текущую тему или выбрать темы произвольно.

Поля тем для экспорта
Существует возможность выбрать только те поля тем, которые необходимо экспортировать.

Поля вопросов для экспорта
Существует возможность выбрать только те поля вопросов, которые необходимо экспортировать.

Поля ответов для экспорта
Существует возможность выбрать только те поля вариантов ответов, которые необходимо экспортировать.

Форматы экспорта

При помощи системы экспорта базы данных, можно экспортировать данные в файлы следующих форматов:
  • Paradox файл (*.db)
  • DBase файл (*.dbf)
  • Текстовый файл (*.txt)
  • HTML-файл (*.htm)
  • Excel-файл (*.xls)
  • Word-файл (*.doc)
  • RichText format (*.rtf)
  • Adobe Acrobat документ (*.pdf)
  • XML файл (*.xml)
  • MS Access база (*.mdb)
  • Буфер обмена MS Windows
  • Lotus 1-2-3 файл (*.wk1)
  • QuattroPro файл (*.wq1)
  • SYLK (Symbolic Link) (*.slk)
  • DIF (Data Interchange Format) (*.dif)
  • LDAP Data Interchange Format (*.ldif)
  • SPSS формат (*.sav)
Разделитель столбцов
При экспорте в текстовый файл или в буфер обмена, Вы можете указать символ, который будет являться разделителем столбцов. Разделителем можно выбрать:
  • символ табуляции;
  • точку с запятой;
  • запятую;
  • пробел;
  • любой другой символ.

Таблица символов
Это поле позволяет указать, в какой кодировке необходимо произвести экспорт. Доступны две кодировки: ANSI (Windows) и ASCII (MS_DOS).

По окончанию экспорта
Это поле позволяет указать действие, которое необходимо выполнить по окончанию экспорта:
Ничего не делать (По окончанию экспорта никаких действий произведено не будет)
Открыть файл (По окончанию экспорта файл, полученный в результате экспорта, будет открыт в своем приложении)
Отправить файл по E-Mail (По окончанию экспорта файл, полученный в результате экспорта, будет отправлен по E-Mail, который Вы сами укажите)

Если необходимо обменяться базами данных между двумя компьютерами, то используйте систему синхронизации.


Печать базы данных

В программе имеется мощная и гибкая система вывода информации из базы данных на печать. При помощи этой системы можно вывести данные на принтер, сохранить в файл или вывести информацию на экран (предварительный просмотр).

Выбор тем
Существует возможность выбрать все темы для печати, только текущую тему или выбрать темы произвольно.

Печатать каждую тему с новой страницы
Эта опция позволяет указать надо или нет начинать печать каждой новой темы с новой страницы.

Включить в отчет темы, у которых нет вопросов
Если это поле отмечено, то на печать будут выведены все темы, даже если у некоторых из них нет вопросов.

Включить в отчет вопросы, у которых нет ответов
Если это поле отмечено, то на печать будут выведены все вопросы, даже если у некоторых из них нет вариантов ответов.

Отображать в отчете номера правильных ответов
Если это поле отмечено, то на печать будет выведена информация о правильных вариантах ответов.

Отображать в отчете типы вопросов
Если это поле отмечено, то на печать будут выведены типы вопросов.

Отображать в отчете цены вопросов
Если это поле отмечено, то на печать будут выведены цены вопросов.

Отображать в отчете примечания к вопросам
Если это поле отмечено, то на печать будут выведены примечания к вопросам, на которые был дан неверный ответ.

Печатать изображения
Если это поле отмечено, то на печать будут выведены изображения. Здесь же можно указать, надо ли печатать рамки изображений, а также указать масштаб изображений при печати.


Синхронизация базы данных

Система синхронизации базы данных предназначена для обмена базами данным между разными компьютерами. Система синхронизации базы данных состоит из двух частей: передача данных и получение данных.

Передача данных

Система передачи данных служит для экспорта данных с данного компьютера на другой компьютер.

Выбор тем и вопросов
Существует возможность выбора тем и вопросов, которые необходимо передать.

Результирующий файл
В этом поле указывается путь, где результирующий файл будет сохранен и имя результирующего файла.

Описание
В этом поле можно ввести описание для результирующего файла. Это описание поможет понять, что находится в этом файле, когда данные будут переноситься на другой компьютер при помощи системы «Получение данных».

Защита паролем
При необходимости, результирующий файл можно защитить паролем.

Получение данных

Система получения данных служит для импорта данных с другого компьютера на данный компьютер.

Укажите файл, в котором находятся данные

В данном поле следует указать файл, из которого необходимо получить данные. Создать такой файл можно с помощью системы «Передача данных». После того, как Вы укажите файл, из которого нужно получить данные и, если этот файл является файлом синхронизации «Конструктор тестов», то ниже будет отображена информация об этом файле:
- Имя файла
- Дата создания файла
- Количество тем, находящихся в файле
- Количество вопросов, находящихся в файле
- Защищен или не защищен этот файл паролем
- Описание файла.

Выбор тем и вопросов
Существует возможность выбора тем и вопросов, которые необходимо получить.


Сжатие базы данных

Функция сжатия базы данных служит для того, чтобы очистить базу данных от тех записей, которые были ранее удалены. Структура базы данных устроена так, что при удалении записи, физически из базы данных запись не удаляется, а лишь помечается, как удаленная. Такие записи в работе программы уже не участвуют и к ним вернуться уже нельзя, но при этом такие записи занимают место на винчестере и в них нет смысла. Функция сжатия базы данных очищает базу данных от ранее удаленных записей.

Функцию сжатия базы данных рекомендуется периодически использовать.


Настройки программы
Орфография

В программе существует возможность проверки орфографии тем, вопросов и вариантов ответов.

Язык
В этом поле необходимо выбрать язык для проверки орфографии.

Автоматически проверять орфографию
При включенной системе автоматической проверки орфографии, орфография будет проверяться при добавлении или изменении информации в темах, вопросах и вариантах ответов.

Карточка пользователя Тренажера
Карточка пользователя Тренажера служит для регистрации пользователей при прохождении тестирования в Тренажере. Те поля, которые будут выбраны при настройке карточки пользователя, будут обязательны для заполнения в Тренажере. Поля карточки пользователя имеют гибкую настройку. Имеется возможность использовать 10 полей в карточке. Все названия полей карточки пользователя, кроме поля «Пароль» можно изменить. Любые поля карточки пользователя можно либо задействовать, либо не задействовать. Исключением является только поле «Имя», которое должно быть задействовано обязательно, но его название можно изменить.
Язык интерфейса
Смена языка интерфейса Редактора и Тренажера.

Столбцы
Настройка столбцов таблиц тем и вопросов. Можно изменить порядок следования столбцов, а так же указать какие столбцы отображать, а какие нет.


Ограничения в незарегистрированной версии

Незарегистрированная копия «Конструктора тестов» отличается от зарегистрированной тем, что:

1. Незарегистрированная копия работает в ознакомительном режиме в течение 30 дней. По истечении 30 дней программу надо зарегистрировать или отказаться от ее дальнейшего использования;
2. В незарегистрированной копии Вы можете использовать не более 5 тем и не более 10 вопросов в каждой теме;
3. В незарегистрированной копии Вы можете экспортировать, распечатывать, сохранять в файл и синхронизировать не более 5 тем и не более 10 вопросов в каждой теме.

После регистрации, все ограничения снимаются. Зарегистрированная копия программы работает без ограничения по времени и может содержать любое число тем, вопросов и вариантов ответов.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Условия распространения программы

«Конструктор тестов» не является бесплатным. Вам предоставляется право использования данной программы бесплатно в течение 30 дней для оценки пригодности ее для Ваших целей. Если Вы решили использовать «Конструктор тестов» более 30 дней, то от Вас требуется регистрационная оплата. При получении оплаты Вам будет выслан персональный регистрационный ключ, который позволит Вам использовать «Конструктор тестов» без ограничений.

Использование незарегистрированной копии «Конструктора тестов» после 30-дневного оценочного периода является нарушением авторских прав.

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Регистрация для жителей России и стран СНГ

Для жителей России и стран СНГ, регистрация «Конструктора тестов» осуществляется со скидкой. Перед тем, как оплатить регистрацию программы Вы должны выбрать тип лицензии, в соответствии с которым Вы будете регистрироваться.

Цены на регистрацию «Конструктора тестов», в зависимости от выбранной лицензии:

Студенческая лицензия | 200 руб.
Стандартная лицензия | 300 руб.
Корпоративная лицензия на 10 компьютеров | 1000 руб.
Корпоративная лицензия на 20 компьютеров | 1500 руб.
Корпоративная лицензия на неограниченное число компьютеров | 3000 руб.

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

Подробней о ценах, способах и вариантах оплаты регистрации «Конструктора тестов» читайте на сайте в Интернете по адресу: http://www.keepsoft.ru/simulator.htm

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Регистрация для людей, живущих за пределами России и стран СНГ

Для людей живущих за пределами России и стран СНГ цена регистрации «Конструктора тестов» зависимости от типа выбранной Вами лицензии.

Цены на регистрацию «Конструктора тестов», в зависимости от выбранной лицензии:

Студенческая лицензия | $19,95
Стандартная лицензия | $29,95
Корпоративная лицензия на 10 компьютеров | $149,95
Корпоративная лицензия на 20 компьютеров | $249,95
Корпоративная лицензия на неограниченное число компьютеров | $599,95

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

Подробней о ценах, способах и вариантах оплаты регистрации «Конструктора тестов» читайте на сайте в Интернете по адресу: http://www.keepsoft.ru/simulator.htm

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Типы лицензий

Существует три типа лицензий:

1. Студенческая лицензия
Студенческая лицензия дает право использовать «Конструктор тестов» только на одном компьютере. В данном случае регистрационный ключ будет «привязан» к одному конкретному компьютеру. При заполнении бланка заказа на оплату студенческой лицензии, Вы должны указать свой персональный идентификационный номер, который можно найти в «Конструкторе тестов» в окне «Регистрация».

В том случае, если Вам понадобится сменить компьютер и зарегистрировать «Конструктор тестов» снова, то старый регистрационный ключ уже не подойдет, так как изменится Ваш уникальный идентификационный номер. В этом случае, новый регистрационный ключ будет Вам выдан бесплатно, а старый регистрационный ключ будет аннулирован.

2. Стандартная лицензия
Стандартная лицензия дает право использовать «Конструктор тестов» одним лицом на неограниченном количестве компьютеров. В данном случае, регистрационный ключ не «привязывается» к конкретному компьютеру. Вам будет выдан Ваш персональный регистрационный ключ, зарегистрированный на Ваше имя. Этот ключ может быть использован только Вами лично и не может быть передан другим лицам.

3. Корпоративная лицензия
Корпоративная лицензия дает право использовать «Конструктор тестов» на нескольких компьютерах разными лицами. Этот тип лицензии служит для регистрации «Конструктора тестов» в компьютерных классах, на предприятиях, в учебных заведениях и т.д., где установлено несколько компьютеров и на этих компьютерах работают разные пользователи. Существует три вида корпоративных лицензий:
- Корпоративная лицензия на 10 компьютеров;
- Корпоративная лицензия на 20 компьютеров;
- Корпоративная лицензия на неограниченное число компьютеров.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Ввод регистрационного ключа

Для того чтобы зарегистрировать программу надо войти в меню «Помощь» и выбрать пункт «Регистрация». В появившемся окне необходимо ввести регистрационный ключ. Ввести ключ можно тремя способами:

1. Нажать кнопку «Из файла» и указать файл, в котором находится регистрационный ключ;
2. Открыть файл с регистрационным ключом в любом текстовом редакторе, скопировать все содержимое файла в буфер обмена и в окне регистрации нажать кнопку «Вставить»;
3. Набрать вручную.

Ваш персональный регистрационный ключ вы получите по электронной почте сразу после оплаты.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Обратная связь

Адрес сайта «Конструктора тестов» в Интернете: http://www.keepsoft.ru/simulator.htm

E-Mail адрес технической поддержки: support@keepsoft.ru