О программе
"Конструктор тестов" это универсальная система проверки знаний. Данную программу можно использовать как в домашних условиях, так и для проведения тестирования в любых учебных заведениях. Программа позволяет использовать неограниченное количество тем, вопросов и ответов. Программа поддерживает пять типов вопросов, что позволяет проводить любые тесты. В тестах имеется возможность использовать музыку, звуки, изображения и видеоролики. Любые данные можно распечатать на принтере, экспортировать в файлы различных форматов (Word, Excel, Access, HTML, XML, Текстовый файл, Paradox, DBase и др.). На одном компьютере тестирование независимо могут проходить несколько человек, входя в программу под своими именами. Программа проста в использовании, имеет удобный и понятный русский интерфейс.

"Конструктор тестов" состоит из двух частей:
1. "Конструктор тестов. Редактор" - предназначен для заполнения и редактирования базы данных, а так же для различных настроек "Конструктора тестов".
2. "Конструктор тестов. Тренажер" - предназначен для проведения тестирования по тем темам и вопросам, которые были занесены в базу данных при помощи "Редактора".


Возможности программы
"Конструктор тестов" это универсальная система проверки знаний. В программе имеются следующие возможности:

Использование неограниченного числа тем, вопросов и ответов;

В опросы могут содержать музыку, звуки (файлы wav, mid. rmi);

В опросы могут содержать изображения (файлы jpg, bmp, ico, emf, wmf);

В опросы могут содержать видеоролики (файлы avi);

Поддержка пяти типов вопросов:

1. Выбор единственно правильного ответа;

2. Выбор нескольких возможных правильных ответов;

3. Установка последовательности правильных ответов;

4. Установка соответствий ответов;

5. Ввод ответа вручную с клавиатуры.

Печать на принтере и сохранение в файл тем, вопросов и ответов;

Печать на принтере и сохранение в файл результатов тестирования;

Экспорт тем, вопросов и ответов в файлы различных форматов (MS Excel, MS Word, MS Access, Paradox, DBase, Текстовый файл, HTML, XML, RTF (RichText format), PDF (Adobe Acrobat), буфер обмена MS Windows, Lotus 1-2-3 и др.);

Возможность проведения тестирования на одном компьютере несколькими пользователями. Для каждого пользователя заводится персональная карточка пользователя, поля в которой можно настроить в "Редакторе";

Возможность установить разные права доступа к редактированию базы данных в "Редакторе" для разных пользователей;

Возможность задавать вопросы в произвольном порядке;

Возможность задавать цену каждому вопросу в баллах;

Возможность ограничить ответы по теме по времени;

Возможность прервать тестирование и продолжить его в другое время;

Возможность выставлять оценку по окончании тестирования. Система оценок настраивается в "Редакторе". Шкалу оценок можно настроить от 2-х бальной до 100-бальной системы;

Синхронизация базы данных. При помощи этой функции можно легко обмениваться данными с другими пользователями и переносить данные с компьютера на компьютер;

Проверка орфографии в "Редакторе";

Поиск по базе данных в "Редакторе";

Сжатие базы данных;

Функция проверки обновления через Интернет.


Начало работы
Прежде, чем начать работать с "Тренажером" необходимо заполнить базу данных темами, вопросами и ответами при помощи программы "Конструктор тестов. Редактор", которая поставляется вместе с "Тренажером". С помощью "Редактора" Вы так же можете настроить карточку пользователей и систему оценок.


Конструктор тестов. Редактор.
"Конструктор тестов. Редактор" предназначен для заполнения и редактирования базы данных, а так же для различных настроек "Конструктора тестов". "Конструктор тестов. Редактор" поставляется вместе с программой "Конструктор тестов. Тренажер" и имеет свою собственную справочную систему.


Вход в программу

В программе имеется возможность проведения тестирования на одном компьютере несколькими пользователями. При входе в программу Вы можете выбрать имя, под которым Вы будете проходить тестирование. Список пользователей можно дополнять и изменять при помощи администратора пользователей. Поля в администраторе пользователей настраиваемые. Настройка полей карточки пользователя производится в «Редакторе» в меню Настройка карточки пользователя.


Администратор пользователей

Администратор пользователей предназначен для добавления, изменения и удаления пользователей из списка пользователей. Все поля в карточке пользователя обязательны для заполнения. Поля в карточке пользователя настраиваемые. Настройка полей карточки пользователя производится в «Редакторе» в меню Настройка карточки пользователя.

Удаление пользователя из списка приводит к удалению всей истории его тестирования.


Окно выбора темы

В окне выбора темы есть две закладки: все темы и ранее начатые темы.

На первой закладке «Все темы» находится список всех тем, которые присутствую в базе данных и количество вопросов, которые присутствуют в каждой теме. Для начала тестирования, нужно выбрать интересующую Вас тему и нажать кнопку «Начать тест». Если тестирование по выбранной теме еще не проводилось, то тест будет начат сначала.

На второй закладке «Ранее начатые темы», приведен список тех тем, тестирование по которым ранее уже проводилось. На этой закладке Вы можете продолжить тестирование, которое было ранее прервано или начать тестирование заново. На этой же закладке есть кнопка «Удалить». При нажатии на эту кнопку выбранная тема будет удалена только из списка ранее начатых тем. При нажатии на кнопку «Результаты», будет открыто окно с результатами по текущей теме.

Список всех результатов тестирования можно увидеть в окне «Таблица результатов».


Окно тестирования

Окно тестирования это основное окно «Тренажера». В этом окне Вам задается вопрос и приводится список вариантов ответов, среди которых необходимо выбрать верные. В этом же окне указывается тип заданного вопроса и его цена в баллах.

После того, как Вы отметили все правильные варианты ответов, нажмите на кнопку «OK» и Вам будет задан следующий вопрос.

Кнопка «Прервать» служит для того, чтобы Вы могли прервать текущий тест. К прерванному тесту Вы сможете вернуться в окне «Выбор темы» с закладки «Список ранее начатых тем».

Внизу окна тестирования расположен индикатор результатов тестирования, с помощью которого можно следить за промежуточными результатами текущего теста.


Типы вопросов

Вам могут быть заданы пять типов вопросов:

1. Выбор единственно правильного ответа. Ответ на вопрос данного типа должен быть только один. Задача состоит в том, чтобы выбрать из предложенного списка вариантов ответов только один верный.

2. Выбор нескольких возможных правильных ответов. У вопроса данного типа может быть несколько правильных ответов. Задача состоит в том, чтобы выбрать из предложенного списка вариантов ответов один или несколько верных.

3. Установка последовательности правильных ответов. У вопроса данного типа все ответы являются правильными. Задача состоит в том, чтобы пронумеровать предложенные варианты ответов в правильном порядке.

4. Установка соответствий ответов. У вопроса данного типа есть несколько вариантов ответов и несколько соответствий вариантам ответов. Задача состоит в том, чтобы для каждого варианта ответа выбрать из предложенного списка соответствий вариантам ответов один или несколько верных.

5. Ввод ответа вручную с клавиатуры. У вопроса данного типа нет списка вариантов ответов. Задача состоит в том, чтобы набрать правильный ответ вручную с клавиатуры. Высота регистра букв ответа значения не имеет.


Индикатор результатов тестирования

Индикатор результатов тестирования расположен внизу окна тестирования и предназначен для того, чтобы следить за промежуточными результатами текущего теста.

Индикатор состоит из номеров вопросов текущей темы. Текущий вопрос, на который Вы в данный момент должны дать ответ, на индикаторе, подсвечивается зеленым цветом. После того, как Вы дадите ответ на заданный вопрос, индикатор отобразит, какой ответ Вы дали, правильный или нет. Если ответ был дан правильно, то под номером вопроса на индикаторе появится зеленый свет, а если ответ дан неверно, то свет будет красный. Пока тестирование по текущей теме не окончено, Вы можете посмотреть результат ответа на каждый заданный вопрос отдельно. Для этого щелкните левой кнопкой мыши на индикаторе по интересующему Вас вопросу. Окончательные результаты теста можно увидеть в окне «Результаты» по окончанию тестирования по текущей теме.


Окно результатов теста

В окне результатов теста отображается вся информация по текущему тесту:

- Название текущей темы;
- Общее число вопросов в текущей теме;
- Число заданных вопросов;
- Число пропущенных вопросов;
- Число вопросов, на которые были даны правильные ответы и процент правильных ответов от числа заданных вопросов;
- Число вопросов, на которые были даны неверные ответы и процент неверных ответов от числа заданных вопросов;
- Общее количество баллов по всем вопросам данной темы;
- Количество набранных баллов и их процент от общего числа баллов;
- Оценка;
- Дата проведения тестирования;
- Затраченное время.

Если в процессе тестирования были допущены ошибки, то список допущенных ошибок можно увидеть, нажав на кнопку «Просмотр допущенных ошибок».

Результаты теста можно вывести на печать или сохранить в файл, нажав на кнопку «Печать».


Ограничения в незарегистрированной версии

Незарегистрированная копия «Конструктора тестов» отличается от зарегистрированной тем, что:

1. Незарегистрированная копия работает в ознакомительном режиме в течение 30 дней. По истечении 30 дней программу надо зарегистрировать или отказаться от ее дальнейшего использования;
2. В незарегистрированной копии Вы можете использовать не более 5 тем и не более 10 вопросов в каждой теме;
3. В незарегистрированной копии Вы можете экспортировать, распечатывать, сохранять в файл и синхронизировать не более 5 тем и не более 10 вопросов в каждой теме.

После регистрации, все ограничения снимаются. Зарегистрированная копия программы работает без ограничения по времени и может содержать любое число тем, вопросов и вариантов ответов.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Условия распространения программы

«Конструктор тестов» не является бесплатным. Вам предоставляется право использования данной программы бесплатно в течение 30 дней для оценки пригодности ее для Ваших целей. Если Вы решили использовать «Конструктор тестов» более 30 дней, то от Вас требуется регистрационная оплата. При получении оплаты Вам будет выслан персональный регистрационный ключ, который позволит Вам использовать «Конструктор тестов» без ограничений.

Использование незарегистрированной копии «Конструктора тестов» после 30-дневного оценочного периода является нарушением авторских прав.

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Регистрация для жителей России и стран СНГ

Для жителей России и стран СНГ, регистрация «Конструктора тестов» осуществляется со скидкой. Перед тем, как оплатить регистрацию программы Вы должны выбрать тип лицензии, в соответствии с которым Вы будете регистрироваться.

Цены на регистрацию «Конструктора тестов», в зависимости от выбранной лицензии:

Студенческая лицензия | 200 руб.
Стандартная лицензия | 300 руб.
Корпоративная лицензия на 10 компьютеров | 1000 руб.
Корпоративная лицензия на 20 компьютеров | 1500 руб.
Корпоративная лицензия на неограниченное число компьютеров | 3000 руб.

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

Подробней о ценах, способах и вариантах оплаты регистрации «Конструктора тестов» читайте на сайте в Интернете по адресу: http://www.keepsoft.ru/simulator.htm

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Регистрация для людей, живущих за пределами России и стран СНГ

Для людей живущих за пределами России и стран СНГ цена регистрации «Конструктора тестов» зависимости от типа выбранной Вами лицензии.

Цены на регистрацию «Конструктора тестов», в зависимости от выбранной лицензии:

Студенческая лицензия | $19,95
Стандартная лицензия | $29,95
Корпоративная лицензия на 10 компьютеров | $149,95
Корпоративная лицензия на 20 компьютеров | $249,95
Корпоративная лицензия на неограниченное число компьютеров | $599,95

Став зарегистрированным пользователем, Вы получите:
- персональный регистрационный ключ зарегистрированного пользователя;
- бесплатную техническую поддержку программы по e-mail;
- Вы не пропустите ни одной новости, касающейся «Конструктора тестов», и будете получать всю информацию по e-mail.

Подробней о ценах, способах и вариантах оплаты регистрации «Конструктора тестов» читайте на сайте в Интернете по адресу: http://www.keepsoft.ru/simulator.htm

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Типы лицензий

Существует три типа лицензий:

1. Студенческая лицензия
Студенческая лицензия дает право использовать «Конструктор тестов» только на одном компьютере. В данном случае регистрационный ключ будет «привязан» к одному конкретному компьютеру. При заполнении бланка заказа на оплату студенческой лицензии, Вы должны указать свой персональный идентификационный номер, который можно найти в «Конструкторе тестов» в окне «Регистрация».

В том случае, если Вам понадобится сменить компьютер и зарегистрировать «Конструктор тестов» снова, то старый регистрационный ключ уже не подойдет, так как изменится Ваш уникальный идентификационный номер. В этом случае, новый регистрационный ключ будет Вам выдан бесплатно, а старый регистрационный ключ будет аннулирован.

2. Стандартная лицензия
Стандартная лицензия дает право использовать «Конструктор тестов» одним лицом на неограниченном количестве компьютеров. В данном случае, регистрационный ключ не «привязывается» к конкретному компьютеру. Вам будет выдан Ваш персональный регистрационный ключ, зарегистрированный на Ваше имя. Этот ключ может быть использован только Вами лично и не может быть передан другим лицам.

3. Корпоративная лицензия
Корпоративная лицензия дает право использовать «Конструктор тестов» на нескольких компьютерах разными лицами. Этот тип лицензии служит для регистрации «Конструктора тестов» в компьютерных классах, на предприятиях, в учебных заведениях и т.д., где установлено несколько компьютеров и на этих компьютерах работают разные пользователи. Существует три вида корпоративных лицензий:
- Корпоративная лицензия на 10 компьютеров;
- Корпоративная лицензия на 20 компьютеров;
- Корпоративная лицензия на неограниченное число компьютеров.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Ввод регистрационного ключа

Для того чтобы зарегистрировать программу надо войти в меню «Помощь» и выбрать пункт «Регистрация». В появившемся окне необходимо ввести регистрационный ключ. Ввести ключ можно тремя способами:

1. Нажать кнопку «Из файла» и указать файл, в котором находится регистрационный ключ;
2. Открыть файл с регистрационным ключом в любом текстовом редакторе, скопировать все содержимое файла в буфер обмена и в окне регистрации нажать кнопку «Вставить»;
3. Набрать вручную.

Ваш персональный регистрационный ключ вы получите по электронной почте сразу после оплаты.

О том, как получить регистрационный ключ читайте в разделах:
- Регистрация для жителей России и стран СНГ
- Регистрация для людей живущих за пределами России и стран СНГ

По всем вопросам, связанным с регистрацией «Конструктора тестов», обращайтесь в службу технической поддержки.


Обратная связь

Адрес сайта «Конструктора тестов» в Интернете: http://www.keepsoft.ru/simulator.htm

E-Mail адрес технической поддержки: support@keepsoft.ru