
COMPONENT User's Guide

Chapter 1
Getting started

This chapter tells you how to install COMPONENT, how to start the program, and
introduces the basics of using the software.

Installing COMPONENT

Installing COMPONENT is straightforward and should be undertaken in Windows.
The installation procedure copies all necessary files onto your hard disk, sets up a
Program Manager group displaying the program's icon, and creates an initialisation
file (CPW.INI) in your Windows directory.

Hardware and Software Requirements

COMPONENT runs on IBM PCs and compatibles with an Intel 80286 (or higher)
processor, 2Mb of RAM, and a hard disk. The program requires Microsoft Windows
3.0 or later. The program requires about 1 Mb of disk space.

Installation

You must install COMPONENT onto your hard disk. This can be done from within
Windows.

n Insert the distribution disk into your floppy disk drive.

n From Windows Program Manager's File menu choose Run.

n Windows will display the following dialog box:

n Type in A:SETUP (or B:SETUP if you are installing COMPONENT
from the B: drive).

Figure 1.1
The Program Manager

Run dialog box
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The program Setup will start by asking you for a drive and directory in
which to install COMPONENT. It will display the default directory, \CPW.

name of that directory.

n rom the floppy disk onto the hard
disk. You will be prompted for further disks as necessary.

Once Setup has copied all the files it will create a Program Manager group
called COMPONENT. This group will display icons for COMPONENT

The COMPONENT group

The COMPONENT group contains icons for several of the distribution files. The

Any other  icons are for various documents created for the standard Windows
applications such as Write and Win Help, and can be opened by clicking on the

sensitive help. You can access this help from within COMPONENT (see the section
"Getting help" below) or by clicking on the help file's icon:

Windows Write editor:

Figure 1.2
The COMPONENT icon

Figure 1.3
The COMPONENT help

file icon

Figure 1.4
The Windows Write icon
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Starting COMPONENT

To start COMPONENT click on the COMPONENT icon with the mouse. When
COMPONENT starts your screen should look like this:

Log window (a child window)

Status bar

Menu bar

Desktop

Control menu

Scroll bars

Title bar Maximize button
Minimize button

If this is the first time you have run COMPONENT you will be presented with a
dialog box requesting your name and institution. This personalises your copy of the
program.

The interface

COMPONENT features a standard Windows user interface. This manual assumes
that you have some knowledge about using Windows; if this is not the case please
take the time to read through your Windows documentation.

There are three main parts to the COMPONENT interface: the title and menu bar at
the top, the desktop, and the status bar at the bottom. When the program starts a
single child window titled Log is open on the desktop. This window is used by
COMPONENT to display output, and is described further below in the section
"Viewing output" below. Other child windows may be opened to edit files and
display trees.

Menu bar

The menu bar is used to access the menus. To choose a menu item either click on
the item desired, or press Alt plus the underlined letter of the menu item. Some
menu items have keyboard shortcuts, such as Shift+F5 , to enable quick access to a
command.

Depending on which child window is active some menu items may appear dim, and
when you choose them nothing happens. This indicates that the command doesn't
make sense in the current context (for example, computing a consensus tree for only
one tree). Some child windows may place their own menu on the menu bar.

Figure 1.5
The COMPONENT

interface
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Child windows

COMPONENT uses a variety of child windows to display output, trees, and files.
Only one of these windows is active at any time. The active window is the one
you're currently working in, and can be recognised by having its title bar
highlighted with the same colour as the program's title bar. Child windows can be
maximised or minimised; a maximised child window occupies the whole desktop, a
minimised child window is shrunk to an icon on the desktop. You can move a
window on the desktop by dragging on its title bar.

You can activate a different child window by clicking anywhere on it, by pressing
Ctrl+F6 or Ctrl+Tab until the window you want is selected, or by selecting the
window's name from the Window menu:

To close a child window press , or double click on the window's Control
menu button.

Status bar

The status bar at the bottom of the desktop provides information on the status of the
program. If you have opened an Edit window, the status bar displays the location of
the cursor. Error messages are displayed here, as are hints about what a menu
command does when that command is highlighted.

Dialog Boxes

COMPONENT uses dialog boxes to either request information from you, or to
provide information to you. Whenever you see an ellipsis (...) after a menu
command a dialog box follows. For example, when you choose Show from the
Trees menu, COMPONENT displays the Trees Show dialog box asking what trees
you want to show:

Figure 1.6
The Window menu

Figure 1.7
The Trees Show dialog

box



Getting Started 1-5

COMPONENT User's Guide

COMPONENT also uses dialog boxes to inform you of the progress of an operation.
For example, after selecting the trees you want to show with the Show command,
COMPONENT displays a dialog box showing what percentage of the trees the
program has processed so far:

This dialog box allows you to interrupt the program by clicking on the Cancel
button.

Viewing output

COMPONENT sends all its output to a 32K circular text buffer. The contents of this
buffer are displayed in the Log window. This window is the first window you see
when you start COMPONENT. The Log window can be moved, resized and
iconized, but not closed.

To view output

To view your output first make the Log window the active window. The window
will automatically updated with the most recent output. You can scroll through the
output by using clicking on the scroll bars and buttons, or by using the  ↑, ↓, ←, →,
PgDn, or PgUp keys.

F Once the display buffer is full it starts to overwrite itself, so that output from
previous analyses can be lost. To avoid this happening you can either open an
output file to send the output to, or save the current contents of the buffer to a file.

Opening an output file

n From the File menu choose Output file. If the file you specify already
exists the program will give you the option of either appending your output
to that file, or replacing the file.

n From the File menu choose Echo output to disk. A check mark will
appear to the left of the Echo output to disk menu item. From now on any
output sent to the display buffer will also be written to the output file. You
can switch this feature on and off.

Figure 1.8
The Showing Trees
progress dialog box
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Saving the display buffer

To save the contents of the display buffer choose Save display buffer from the File
menu. You will be prompted for the name of a file to save the output to. Note that
this command only saves what is still in the display buffer. Any output that has been
overwritten is lost for good.

Editing the display buffer

You can edit the display buffer by choosing the Edit display buffer command from
the Edit menu. COMPONENT will open an external editor (currently Windows
Notepad) and copy the current contents of the display buffer to that editor. This
command is useful if you just want to save just a part of the output.

Printing the display buffer

From the File menu choose Print display buffer. The contents of the buffer will be
printed on the currently selected printer.

Clearing the display buffer

From the Edit menu choose Clear display buffer. Before clearing the buffer
COMPONENT will ask you to confirm that this is want you want to do.

F By default, COMPONENT uses characters from the IBM PC extended character set
(referred to in the Windows documentation as the "OEM character set") to draw
trees in the Log window. These characters are not part of the ANSI character set
used by Windows. If you edit or print the display buffer COMPONENT will replace
the OEM characters by their ANSI equivalents.

Creating and editing files

Input files can be created and edited in an Edit window:

Figure 1.9
An Edit window
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The file being edited can be saved, renamed, printed, and processed using
commands on the File menu. COMPONENT Edit windows support the Undo, Cut,
Copy, Paste, and Delete functions found in most Windows editors. However
COMPONENT can only edit small (less than 8K) files. If you try and open a file
larger than this COMPONENT will start an external editor (such as Windows
Notepad) and load the file into that editor.

Creating a new file

Choose New from the File menu. COMPONENT will open an edit window and give
it a temporary name.

Opening an existing file

Choose Open from the File menu. A standard File Open dialog box will appear
asking for the name of the file you wish to open. After you have entered the file
name and clicked on the OK button COMPONENT will display a dialog box asking
whether you want to edit the file or view the trees:

Click on the Edit button. If the file is too large to be edited in an Edit window
COMPONENT will attempt to load the file into an external editor (currently
Windows Notepad).

Saving a file

Choose Save from the File menu. If you have not changed the default name
("Untitled") COMPONENT displays the File Save As dialog box so that you can
name the file.

Saving to a file with a new name

Choose Save as from the File menu.

Printing a file

Choose the Print command from the File menu. The contents of the active edit
window will be printed on the system printer. If you want to print just part of the
file, select that part of the file by either:

Figure 1.10
The File Open Mode

dialog box
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n holding the left mouse button down and dragging the mouse pointer over
the desired text, or

n holding the Shift key down and using the cursor control keys to highlight
the text.

n choose Print selection from the File menu.

Processing a file

If the file being edited in the active Edit window is a NEXUS file (i.e., it starts with
the #NEXUS directive, see Chapter 3) and has been saved to disk then you can
process that file by choosing Execute from the File menu. If COMPONENT
encounters an error while processing a file it will highlight the location of the error
in the edit window and display an error message on the status bar. You can correct
errors by editing the file, saving it, then choosing Execute again, until
COMPONENT accepts the file.

Tree windows

COMPONENT displays trees in a Tree window:

You can open more than one Tree window at a time. The COMPONENT
commands that open tree windows are Open, and Execute from the File menu (see
above),  and the Random trees and All trees from the Generate menu (see Chapter
6).

The commands in the Trees menu manipulate the trees in the currently active tree
window. These commands are described in Chapters 2, 4, 5, 6, and 7.

Figure 1.11
The Tree window
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Viewing trees

A Tree window displays one tree from the set of trees held in memory. If there is
more than one tree you can view the other trees either by typing the number of the
tree in the tree input box, or by clicking on the tree spin button:

Input box Spin button

Viewing blocks of trees

If you are using COMPONENT to compare host and parasite, gene and organism,
or taxon and area cladograms then your input file will contain one or more
DISTRIBUTION blocks (see Chapter 3). The Tree window will then display a drop
down list box listing all the DISTRIBUTION blocks in your file. The TREES (if
present) block is also listed. If the DISTRIBUTION block contains a TITLE
command, such as

TITLE = 'Geomydoecus';

then the list box will display that title, otherwise it will display a number
corresponding to the order in which the block occurs in the file.

In the example above the input file contains a DISTRIBUTION block called
"Geomydoecus" which contains information on the distribution and relationships of
some parasitic lice,  and a TREES block containing a cladogram for the pocket
gopher hosts of the lice.

Some commands in the Trees menu are only available if a distribution block has
been selected.

Figure 1.12
The Tree window input
box and its spin button

Figure 1.13
The block drop down list

box
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Histogram dialog boxes

COMPONENT uses a Histogram dialog box to display histograms:

At present the program's charting facilities are rudimentarythe chart can be
printed but you have no control over the appearance of the histogram. You will get
much nicer graphics if you use a program such as Microsoft Excel, Borland's
Quattro Pro for Windows, or the Graph applet that comes with Microsoft Word for
Windows. You can copy the data displayed by the histogram into the Windows
Clipboard as tab-delimited text. The data can then be pasted into another program
such as a spreadsheet. To paste data to the Clipboard click on the Copy button.

Printing

Within COMPONENT you can print the contents of the display buffer, input files,
and trees. Each of these printing operations has its own command, but the printer
itself is controlled by the Printer setup command in the File menu.

Changing the printer

By default COMPONENT uses the current system printer. You can select another
printer by choosing Printer setup from the File menu. When you choose this
command COMPONENT displays a dialog box listing the currently active printers:

Figure 1.14
A Histogram dialog box
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If you click on the Set Up button, another dialog box appears allowing you to select
the paper size, orientation, fonts, and so forth. The options available to you will
depend on the capabilities of your printer. Here, for example, is the dialog box for
the Hewlett Packard LaserJet 4/4M printer:

Getting on-line help

COMPONENT provides context sensitive on-line help using Windows Help. If you
are unfamiliar with Windows Help please see your Windows documentation.

Figure 1.15
The File Printer Setup

dialog box

Figure 1.16
The printer setup dialog
box for the HP LaserJet

4/4M
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F The on-line help is not as extensive as the documentation in this manual.

Getting on-line help

To get help on:

n a specific topic use the Help menu.

n the currently highlighted menu item press the F1 key.

n a dialog box click on the dialog box's Help button.

Figure 1.17
The COMPONENT on-

line help


