0x0000000A: IRQL_NOT_LESS_OR_EQUAL

Была сделана попытка затронуть виртуальную память на внутреннем процессе IRQ уровня высокого уровня. Если доступен kernel debugger, вы можете проследить, где именно система зациклилась.

Наиболее частая причина возникновения - драйвер устройства использует неверный адрес.

Параметры:

1 - адрес, по которому выполнено ошибочное обращение
2 - IRQL, который использовался для обращения к памяти
3 - тип доступа к памяти: 0 = операция чтения, 1 = операция записи
4 - адрес инструкции, которая затребовала доступ к памяти по адресу

Примечание: Имейте ввиду, что эта ошибка возникает в 99% из-за плохих драйверов. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) -> Run (Выполнить) -> verifier.exe

· Windows NT:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Advanced Server 3.5
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft BackOffice Small Business Server 4.0

Одна из самых часто возникающих ошибок Windows NT - STOP 0x0000000A. Этот STOP может быть вызван как Программным Обеспечением, так и проблемой с оборудованием. Для выявления при 1000 чин вы должны исследовать эту STOP-ошибку, используя отладчик. Тем не менее, некоторые выводы можно сделать, рассмотрев параметры STOP сообщения и сообщения сопутствующего этому STOP.

Дополнительная информация:

STOP 0x0000000A показывает, что процесс ядра или драйвер пытались обратиться к памяти, к которому у них нет разрешения обращаться. Самая обычная причина - это плохой или повреждённый указатель (pointer), который указывает на неправильный участок в памяти. Указатель (pointer) - это переменная, которая используется программой, для указания на блок в памяти. Если переменная имеет неправильное значение, тогда программа пытается обратиться к памяти, к которой не должна обращаться. Когда это происходит в программе пользователя, она генерирует нарушение доступа. Когда это происходит в режиме ядра, она генерирует STOP 0x0000000A сообщение.

Чтобы выявить какой процесс или драйвер пытался обратиться к памяти, к которой не должен был, посмотрите на параметры, указанные на STOP экране. Например, в этом STOP сообщении:

STOP 0x0000000A(0xWWWWWWWW, 0xXXXXXXXX, 0xYYYYYYYY, 0xZZZZZZZZ)
IRQL_NOT_LESS_OR_EQUAL
** Адрес 0xZZZZZZZZ основывается на <адрес> - <драйвер>

Четыре параметра имеют следующие значения:

0xWWWWWWWW адрес, который был указан некорректно
0xXXXXXXXX IRQL, который требуется, чтобы иметь доступ к памяти
0xYYYYYYYY Тип доступа, 0=Читать, 1=Писать
0xZZZZZZZZ адрес инструкции, которая пыталась обратиться к памяти 0xWWWWWWWW

Если последний параметр (0xZZZZZZZZ) указывает на область адресов системных устройств, вы будите знать, драйвер какого устройства был запущен во время ошибки. Этот драйвер обычно указан на третьей линии STOP экрана:

** Адрес 0xZZZZZZZZ основывается на <адрес> - <драйвер>

Если <имя драйвера> специфический драйвер, сделайте поиск в Microsoft Knowledge Base на слово "0x0000000A" и имя драйвера. Если вы не найдёте никаких подходящих статей, свяжитесь с Microsoft Product Support.

· Windows 2000:

Microsoft - "Stop 0x000000D1" Error Message in Tcpip.sys

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

Когда TCP/IP связь программно разъединилась или была удалена, в то время как операция получения была в прогрессе, ваш компьютер может "зависнуть" и появиться следующее сообщение:

STOP: 0x000000D1 (0xFF8BA000, 0x00000002, 0x00000001, 0xF3AAA40E)
DRIVER_IRQL_NOT_LESS_OR_EQUAL

Решение:

Для решения этой проблемы установите последний SP для Windows 2000. Для дополнительной информации обратитесь к следующей статье:

260910 How to Obtain the Latest Windows 2000 Service Pack

Microsoft подтверждает, что это их ошибка и сообщает, что впервые она была разрешена в SP1.

· Windows XP:

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q314063

Возникновение ошибки при "Быстром переключении пользователей" (Fast Switch Between Users):

IRQL_NOT_LESS_OR_EQUAL
Stop 0x0000000A (0x0227001d, 0x00000002, 0x00000000, 0x804eba3a)

первый параметр может меняться в зависимости от компьютера.

Проблема может появиться, если вы используете софт и драйвера Netropa Corporation для клавиатуры, чтобы добавить ей дополнительные функции.

Решение: обновите драйвера клавиатуры. Драйвера Netropa Corporation можно найти по адресу: http://www.netropa.com/download/mmkbd/download.html

Вы можете выяснить, почему соответствующая программа не завершилась корректно.

Для этого:

Старт (Start) => Выполнить (Run) => msinfo32.exe => Среда Программного Обеспечения (Software Environment) => Системная Информация (System Information) => просмотрите список программ, выясните, которая относиться к клавиатуре. Обычно эта программа загружается со следующей ветки реестра:

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Run

После того, как вы обнаружили программу, которая не завершилась корректно, используйте Autodump + утилиту, чтобы сгенерировать код ошибки.

Возникновение ошибки при переходе (Upgrade) на Windows XP:

При апгрейде с 98 или МЕ на ХР может возникнуть эта ошибка.

Ошибка чаще возникает из-за несовместимого оборудования или драйвера.

Решение:

1. Перезагрузите компьютер и посмотрите - предложит ли вам вернуться на предыдущую операционн c66 ую систему. Если да, то выбирайте эту опцию. Если нет, то пропустите пункт 2 и переходите на пункт 3.

2. Когда компьютер загрузиться в 98 или МЕ, удалите любые антивирусы и сторонние загрузчики (такие, как Roxio GoBack и др.), после этого "вычистите загрузчик", используя информацию следующих статей:

267288 чистка загрузчика в Windows Millennium Edition

192926 чистка загрузчика в Troubleshooting for Windows 98

Потом перезагрузите компьютер и попытайтесь сделать апгрейд снова. Если и после этого не удастся это сделать, то скорее всего проблема в оборудовании.

3. Уберите (т.е. совсем вытащите) из компьютера всё ненужное оборудование (звуковую карту, USB оборудование, принтеры, модемы и сетевые карты и т.д.), оставьте минимум (монитор, видео карта, клавиатура и мышь, флоппи и CD-ROM)

4. Если и после этого Вы продолжаете получать эту ошибку, возможно, Вам необходимо обновить BIOS. Свяжитесь с производителем материнской платы и выясните, если есть какие-либо обновления для BIOS.

0


0x000000BE

Драйвер попытался записать данные в постоянное запоминающее устройство (ПЗУ), что невозможно. Проблема в основном связана с установкой плохого драйвера устройства, службы или програмно-аппаратного обеспечения. Попробуйте отключить данный сбойный компонент.

· Windows 2000

Применяется к следующим системам:

  • Windows 2000 Datacenter Server

ATTEMPTED_WRITE_TO_READONLY_MEMORY

Обычная причина: плохой или повреждённый драйвер или неправильно функционирует.

Решение:

1. Отключите драйвер, указанный на стоп-экране или все, только что установленные драйвера. Если вы не можете загрузить компьютер, попробуйте воспользоваться Last Known Good Configuration или загрузиться в безопасном режиме (safe mode). И после этого отключите или удалить все новоустановленные драйвера и программное обеспечение.

Для большей информации смотрите статью Safe mode startup options. Если ваш компьютер не запускается в безопасном режиме, воспользуйтесь Recover a system that will not start.

Важно:

Когда вы используете Last Known Good Configuration, системные установки с последнего раза, когда компьютер загрузился успешно, будут утеряны.

2. Попытайтесь заменить драйвер хорошей копией с инсталляционного диска или скачать новую версию с сайта производителя.

Для дополнительной информацией используйте поиск на Microsoft Web site


0x000000C1: SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION

Драйвер записал данные в недопустимую секцию памяти.

Примечание: Эта ошибка возникает в 99% из-за "кривых" драйверов. Некоторые из них в Windows XP вы можете обнаружить, используя утилиту verifier.exe: Start (Пуск) => Run (Выполнить) => verifier.exe

· Windows NT/2000/XP:

Эта ошибка схожа с ошибками:

  • 0x0A IRQL_NOT_LESS_OR_EQUAL, указывает, что драйвер затронул память на DISPATCH_LEVEL уровне или выше.
  • 0xBE ATTEMPTED_WRITE_TO_READONLY_MEMORY, драйвер пытался записать в память "только чтение".
  • 0xC1 SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION, драйвер попытался записать в неверный адресс памяти.
  • 0xC4 DRIVER_VERIFIER_DETECTED_VIOLATION, обычно фатальная ошибка.
  • 0xC5 DRIVER_CORRUPTED_EXPOOL, указывает на то, что драйвер попытался обратиться к неверной памяти на процессе IRQL, который слишком высок.
  • 0xC6 DRIVER_CAUGHT_MODIFYING_FREED_POOL, драйвер пытался получить доступ к высвобожденному сектору памяти.
  • 0xC7 TIMER_OR_DPC_INVALID, which is defined as 0xC7, indicates that a kernel timer or DPC was found somewhere in memory where the kernel timer or DPC is not permitted. This condition is usually caused by a driver's not canceling the timer or the Delayed Procedure Call (DPC) before freeing the memory in which the timer or DPC resides.
  • 0xC9 DRIVER_VERIFIER_IOMANAGER_VIOLATION, I/O Driver Verifier violations.
  • 0x50 PAGE_FAULT_IN_NONPAGED_AREA, указание на неверную системную память.

Решение:

Используйте Driver Verifier для выявления ошибок и повреждённых драйверов. Переустановите свежие драйвера.


0x000000C5

STOP 0x000000C5 DRIVER_CORRUPTED_EXPOOL

Произошла попытка обращения из недопустимой области памяти в процесс IRQL высокого уровня. Эта ошибка возникает почти всегда из-за драйв 1000 еров, которые разрушили системный пул. Если Вы недавно установили новое программное обеспечение, выясните, правильно ли Вы его установили. Проверьте также наличие новых драйверов на узле веб-изготовителя.

· Windows 2000

Применяется к следующим системам:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional

Причина: эта ошибка возникает при попытке затронуть недействительную память на процессе IRQL, который слишком высок.

Примечание: ошибка схожа с ошибкой IRQL_NOT_LESS_OR_EQUAL

Решение:

Для решения этой проблемы воспользуйтесь Driver Verifier против любых новых (или подозреваемых) драйверов, если это не решит проблемы, используйте gflags для включения Special Pool feature.

Для дополнительной информации, как использовать Driver Verifier, прочитайте статью 244617

Для дополнительной информации, как включ 1000 ить Special Pool feature, прочитайте статью 188831

"Stop 0x1E" or "Stop 0xc5" After You Install Service Pack 2 and You Use Logitech Mouse Drivers

Применяется к следующим системам:

  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP2

Причина: ошибка появляется, потому что вы используете USB Logitech мышь и Logitech Mouseware версии 9.29.2 или раньше.

Решение:

Для решения проблемы скачайте MouseWare с http://www.logitech.com.

Чтобы правильно запустить компьютер, воспользуйтесь одним из следующих способов:

Метод 1:

Если вы выберите создать Service Pack 2 uninstall папку, следуйте следующим шагам:

1. Загрузитесь в Windows 2000 Recovery Console.
2. Зарегистрируйтесь с администраторским паролем.
3. Напечатайте следующие и нажимайте ENTER после каждой строки:

cd $Ntservicepackuninstall$
copy i8042prt.sys c:\winnt\system32\drivers (нажмите Y чтобы переписать файл)

4. По вызову, напечатайте exit, нажмите ENTER чтобы перезагрузить компьютер.

Метод 2:

Если вы не хотите создавать Service Pack 2 uninstall папку, следуйте следующим шагам:

1. Загрузитесь в Windows 2000 Recovery Console.
2. Зарегистрируйтесь с администраторским паролем.
3. Напечатайте следующие и нажимайте ENTER после каждой строки:

cd system32\drivers
ren L8042pr2.sys L8042pr2.old
copy i8042prt.sys L8042pr2.sys

4. По вызову, напечатайте exit, нажмите ENTER чтобы перезагрузить компьютер.


0x000000E3: RESOURCE_NOT_OWNED

Различные сбои, связанные с файловой системой, выдают данную STOP-ошибку.

· Windows 2000

Применяется к следующим системам:

  • Microsoft Windows 2000 Server SP1
  • Microsoft Windows 2000 Server SP2
  • Microsoft Windows 2000 Advanced Server SP1
  • Microsoft Windows 2000 Advanced Server SP2
  • Microsoft Windows 2000 Professional SP1
  • Microsoft Windows 2000 Professional SP2

"Stop 0x000000E3" Error Message in Windows 2000

Причина: эта ошибка возникает, когда ресурсы были высвобождены дважды в Ntfs.sys.

Решение:

Для решения этой проблемы получите последний Сервис Пак для Windows 2000.

В английской версии этого патча должны присутствовать файлы со следующими атрибутами или позже:

Date Time Version Size File name
-------------------------------------------------------------------------
30-Nov-2001 01:13 5.0.2195.4712 513,072 Ntfs.sys

Microsoft подтверждает, что проблема в продукте Microsoft. Впервые эта проблема была решена в Service Pack 3 для Windows 2000.


0x000000ED: UNMOUNTABLE_BOOT_VOLUME

Подсистема ввода - вывода привилегированного режима попыталась подключить загрузочный том, и потерпела неудачу. Эта ошибка также может произойти в процессе обновления, когда система начала использовать более производительные ATA диски или контроллеры с неправильным конфигурированием. Часто это ошибка появляется после некорректного завершения работы Windows. Для ее устранения воспользуйтесь EMRD или ERCD и в меню выберите третий режим (коррекция NTFS).

· Windows XP

Применяется:

  • Microsoft Windows XP Profesional
  • Microsoft Windows XP Home Edition

"STOP 0x000000ED UNMOUNTABLE_BOOT_VOLUME" Error Message When You Restart Your Computer or Upgrade to Windows XP

C имптомы:

После первой перезагрузки во время апгрейда на ХР или когда вы просто загружаете компьютер, вы получаете этот стоп:

STOP 0x000000ED (0xaaaaaaaa,0xbbbbbbbb,0xcccccccc,0xdddddddd) UNMOUNTABLE_BOOT_VOLUME

где 0xaaaaaaaa,0xbbbbbbbb,0xcccccccc,0xdddddddd - восьмеричные значения и могут быть разными.

Примечание:

Если вы получили этот стоп после первой перезагрузки во время апгрейда на Windows XP, ваша изначальная ОС всё ещё работает. В некоторых случаях, во время загрузки компьютера на посте BIOS может вывести сообщение о использовании неподходящего кабеля, но вы можете не увидеть это сообщение, если BIOS использует быструю загрузку.

Причина:

Это может случиться по нескольким причинам:
Ваш компьютер использует контроллер жёсткого диска Ultra Direct Memory< 1000 /span> Access (UDMA), и следующие утверждения верны:

  • Вы используете стандартный 40-wire кабель для подключения UDMA жёсткого диска к контроллеру в место 80-wire, 40-pin кабеля.
  • Основные установки BIOS (basic input/output system) сконфигурированы на самый быстрый метод UDMA.
  • Файловая система на жёстком диске повреждена.

Решение:

Контроллер UDMA:

Смените 40-wire кабель на 80-wire UDMA кабель.

В BIOS загрузите 'Fail-Safe' установки по умолчанию и потом сконфигурируйте самые важные его компоненты.

Повреждённая файловая система:

Если второй параметр (0xbbbbbbbb) стопа - 0xC0000032, значит у вас повреждена файловая система.

В этом случае загрузитесь в Консоль восстановления (Recovery Console), используя команду chkdsk /r восстановите диск. После восстановления, проверьте ваше оборудование, чтобы изолировать причину повреждения файловой системы.

Чтобы осуществить это, следуйте следующим шагам:

1. Перезагрузите ваш компьютер с установочных дискет или CD-ROMа.

2. На первом экране нажмите R, чтобы попасть в Консоль Восстановления.

3. Если у вас несколько ОС, выберите установку Windows.

4. Ввудите пароль администратора, если потребуется (если вы не устанавливали пароль, просто нажмите Ввод).

5. В командной строке, когда вы находитесь на том логическом диске, куда устанавливался ХР, напечатайте chkdsk /r и нажмите ENTER.

6. В командной строке нажмите ENTER, чтобы перезагрузить компьютер.

7.Если это не поможет, проделайте тоже самое, но в 5 пункте вместо chkdsk /r используйте команду fixboot.

Дополнительная информация:

314058 Description of the Windows XP Recovery Console


0x0000001E: KMODE_EXCEPTION_NOT_HANDLED

· Windows NT:

Это очень часто встречающаяся ошибка. Обычно исключённый адрес указывает на драйвер или функцию, которая вызвала стоп-экран. Всегда обращайте внимание не только на указанный драйвер, но и на сам адрес или имидж, содержащий эту ошибку. Обычно это код исключения 0x80000003. Эта ошибка означает, что точка прерывания или обработчик инициализировался при обращении к памяти, но система загрузилась с /NODEBUG ключа. Это ошибка не должна появляться слишком часто. Е 1000 сли ошибка появляется постоянно, убедитесь, что отладчик (debugger) подключён и система загружается с /DEBUG ключа.

На не-Intel системах, если адрес исключения - 0XBFC0304, ошибка возникает вследствие кэширования процессора. Если ошибка появляется постоянно, свяжитесь с производителем.

Как правило, требуется анализ второго параметра этого сообщения, который указывает на адрес драйвера/функции, которая была причиной проблемы.

Параметры:

1 - код исключительной ситуации
2 - адрес, при обработке которого произошел сбой
3 - Параметр 0 - исключение
4 - Параметр 1 - исключение

Решение:

Решение данной STOP-ошибки Вы можете найти по этой ссылке - http://www.orc.ru/~zalex/0x1e.htm

BSOD 0x0000001E при использовании Bookman Old Style шрифта

Если вы используете Bookman Old Style шрифт, и ваш видео драйвер пытается вывести на экран отрицательный "x", вы можете получить:

STOP 0x0000001E (0xc0000005, 0xfccc6add, 0x00000001, 0x013b8020)

Примечание: 4-ый параметр может меняться, но 2-ой всегда в пределах Vga.dll.

Это ошибка могла быть исправлена в SP6, но не документирована. Если это не так, не используйте Bookman Old Style font.

Так же плохо написанные программы могут вызвать BSOD 0x0000001E или 0x00000024 на вашем Windows NT. Потому что программа открывает много обработчиков, но никогда не закрывает их, и когда вы закрываете программу, то NT пытается закрыть все обработчики, но исчерпывает все ресурсы. Программы должны сами их за собой закрывать.

Решения по этому поводу пока у NT нет. Вы можете попробовать закрывать программы почаще, чтобы снизить количество открытых обработчиков.

Проявляется в:

  • Windows NT Terminal Server
  • Windows 2000 running Terminal Services

Вы получили STOP 0x0000001E, во время распечатки на Hewlett-Packard DesignJet принтере.

Проблема может появиться, если вы используете драйвер Hewlett-Packard DesignJet (HPGL2/RTL) версии 4.4 для Windows NT 4.0 и Windows 2000, потому что драйвер не способен благополучно посылать всплывающие сообщения на рабочий стол компьютера.

Решение:

1. Вы можете избавиться от проблемы, используя драйвер Microsoft.

2. так же вы можете запретить UMPD функцию (User Mode Print Driver) в драйвере:

1. Используйте Regedt32 - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\print\Printers\<Your Printer Driver>\PrinterDriverData.

2. Удалите значение SPLUserModePrinterDriver.

3. Переименуйте следующие файлы в .OLD расширение:

%SystemRoot%\System32\Spool\Drivers\W32x86\Ppltumpd.dll
%SystemRoot%\System32\Spool\Drivers\W32x86\2\Hpltumpd.dll
%SystemRoot%\System32\Spool\Drivers\W32x86\3\Hpltumpd.dll
4. Откройте CMD и напечатайте:
net stop spooler
net start spooler

1000 ;

· Windows XP:

Сообщение указывает на то, что ядро (kernel) Windows XP Professional обнаружило запрещённую операцию или неизвестную инструкцию процессора. Проблема, которая вызывает сбой такого рода, схожа с той, которая вызывает ошибку 0x0000000A. Так же причиной может быть повреждённая память или нарушенный доступ. Windows XP Professional умеет сам справляться с этой проблемой, если только проблема не захватила и саму "поддержку системы в аварийной ситуации".

Решение:

0х01Е STOP-сообщения обычно появляются после установления неисправных драйверов или системных сервисов, или они могут указывать на проблемы оборудования, такие как память и IRQ конфликты. Если в стоп сообщении указывается список драйверов, удалите/ликвидируйте их. Если удаление программного обеспечения или драйверов решат проблему, то свяжитесь с производителем и выясните на счёт обновлений. Обновлённое ПО особенно важно при использовании мультимедийного ПО, антивирусных программ и СД-записывающих мастеров.

Если в STOP-ошибке упомянается Win32k.sys, проблемой может быть программы "удалённого доступа" третьей стороны. Если такая программа установлена, Вы можете удалить её загрузившись в Безопасном режиме. Если нет, то используя консоль восстановления (Recovery Console) удалите неисправный системный файл. Для большей информации о Безопасном режиме и консоль восстановления, смотрите "Tools for Troubleshooting".

Проблема может возникнуть из-за несовместимости микропрограммного обеспечения. Многие Advanced Configuration and Power Interface (ACPI) проблемы могут решиться с обновлением микропрограммного обеспечения (BIOS).

Также может помочь чистка диска от ненужных временных файлов (temporary files) 1000 и т.п., так как проблема может возникнуть из-за недостаточного места на диске (для виртуальной памяти в том числе). Для этого вы можете использовать утилиту Очистки Диска (Disk Cleanup).

· Windows 2000:

Возникновение ошибки в процессе печати клиента Терминального Сервера

Terminal Services Сервер может допустить "Stop 0x1E" или "Stop 0x50" ошибку в процессе печати клиента Terminal Services сервера. Это может быть вызвано использованием некоторых шрифтов в документе, который распечатывался, например:

+ Type 1 multiple master fonts (legacy fonts)
+ Far East fonts containing both English and a localized name

Проблема может появиться, если такой шрифт установлен на компьютере или добавлен, как шрифт принтера.

Решение:

Установите последние Сервис Паки для 2000-ого. При установке СП, следующие (или более поздние) версии файлов должны присутствовать:

Date | Time | Version | Size | File name
--------------------------------------------------------
11/11/2000 | 12:01a | 5.0.2195.2291 | 222,480 | Gdi32.dll
11/11/2000 | 12:01a | 5.0.2195.2303 | 379,152 | User32.dll
11/10/2000 | 11:45p | 5.0.2195.2715 | 1,639,760 | Win32k.sys
11/11/2000 | 12:01a | 5.0.2195.2228 | 243,472 | Winsrv.dll

Так же можете попытаться решить проблему путём обновления драйверов для принтера.

Возникновение ошибки в Usbhub.sys Surprise Removal Plug-and-Play'я USB Hub'а

Когда вы часто вытаскиваете Plug-and-Play Universal Serial Bus (USB) hub (a surprise removal), то может появиться следующая ошибка :

STOP: 0x0000001E (0xC0000005, 0xF8CF75D0, 0x00000000, 0x00000044)
KMODE_EXCEPTION_NOT_HANDLED address 0xF8CF75D0 in USBHUB.sys
Ошибка возникает из-за USB драйвера.

Решение:

Для решения проблемы установите последний Service Pack. Впервые эта проблема была решена в Windows 2000 Service Pack 1.

< 6ae span style='font-family:Verdana;color:#302B43'>

BSOD: STOP 0x0000001e в Ntoskrnl.exe

Если во время загрузки вы получили такой стоп:

STOP 0x0000001e (0xc0000005, 0x801a8a83, 0x00000000, 0x005c0069)
KMODE_EXCEPTION_NOT_HANDLED

адрес 801a8a83 основывается на 80100000 - ntoskrnl.exe

Возможно, ваш SOFTWARE реестр повреждён.

Решение:

Лучший способ восстановить реестр – из резервной копии.

Примечание: в последнем случае все регистрационные ключи установленные после последней RDISK.EXE проверки будут утеряны.


0x0000004E: PFN_LIST_CORRUPT

Причина - повреждённая/неисправная структура ввода-вывода драйвера.

Параметры:

1. значение 1

2. значение ListHead, которое повреждено

3. число доступных страниц

4. 0

1. значение 2

2. данные, которые удаляются

3. наивысшее число физических страниц

4. итог удаляемых данных

· Windows 2000

Применяется к следующим системам:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server

How to Troubleshoot a "STOP 0x0000004E PFN_LIST_CORRUPT" Error Message

Симптомы:

STOP 0x0000004E PFN_LIST_CORRUPT (Parameter1, Parameter2, Parameter3, Parameter4

Параметры:

1. значение 1

2. значение ListHead, которое повреждено

3. число доступных страниц

4. ноль

1. значение 2

2. данные, которые удаляются

3. максимальное число физических страниц

4. итог удаляемых данных

Причина:

Ошибка возникает вследствие повреждения input/output структуры драйверов драйвером или любой другой проблемой.

Решение:

Сделайте диагностику системы (обычно, соответствующие программы предоставляются производителями).

Отключите все фильтр-драйвера файловой системы (file system filter drivers), такие, как бекапные утилиты (backup utilities), вирус-сканеры (virus scanners), или фаервол (firewall software).

Просмотрите Microsoft сайт, чтобы проверить совместимость оборудования и драйверов оборудования с Windows 2000:

http://www.microsoft.com/hcl/default.asp

Для информации о оборудовании вашего компьютера, свяжитесь с производителем.

Если эта ошибка появляется незакономерно или когда вы пытаетесь запустить какую-нибудь программу, удалите дополнительную память или протестируйте ваш random access memory (RAM). Эта ошибка так же может проявляться, если у вас повреждённый RAM.


0x0000007A

Не может быть прочтена запрашиваемая ядром страница. Ошибка вызвана плохим блоком в памяти или ошибкой контроллера диска. См. так же KERNEL_STACK_INPAGE_ERROR.

Параметры:

1. тип зависшей блокировки

2. статус ошибки (обычно код ввода-вывода)

3. текущий процесс (виртуальный адрес для блокировки типа 3 или PTE)

4. адрес виртуальной памяти, который не может быть перемещен в файл подкачки

· Windows NT 2000 XP

Решение STOP 0x00000077 и 0x0000007A сообщений.

Эти STOP сообщения относятся к невозможности Windows NT загрузить информацию о Виртуальной памяти в память или из-за проблем с оборудованием или ПО.

Возможные причины:

- Повреждённый блок на жёстком диске.
- Некорректное завершение оборудования SCSI.
- Плохое соединение жёсткого диска с контроллером.
- Ошибка контроллера жёсткого диска.
- Исчерпывание свободного места.

Применяется к следующим системам:

  • Windows XP
  • Windows 2000
  • Windows NT

Stop 0x0000007A or KERNEL_DATA_INPAGE_ERROR

Причина:

Stop 0x7A сообщение указывает, что страница виртуальной памяти не была найдена и не может быть загружена в память. Это может быть из-за несовместимых дисков, контроллеров, firmware (BIOS) или оборудования.

Параметры:
1. Lock type value (0x00000001, 0x00000002, 0x00000003, or page table entry (PTE) address).
2. I/O код статуса
3. Если тип лока 0x00000001, этот параметр указывает на текущий процесс. Если тип лока 0x00000003, этот параметр указывает на адрес виртуальной памяти.
4. Адрес виртуальной памяти, который не может быть загружен в память.

Причина может быть выявлена через второй параметр (I/O код статуса), используя следующую информацию, которая указана в "значении второго параметра" следуя за "основной причиной" формате:

0xC000009A, или STATUS_INSUFFICIENT_RESOURCES: нехватка nonpaged pool ресурсов.

0xC000009C 1000 , или STATUS_DEVICE_DATA_ERROR: плохой кластер на жёстком диске.

0xC000009D, или STATUS_DEVICE_NOT_CONNECTED: неисправный кабель, зависание, или контроллер не смог получить доступ на жёсткий диск.

0xC000016A, или STATUS_DISK_OPERATION_FAILED: плохой кластер на жёстком диске.

0xC0000185, или STATUS_IO_DEVICE_ERROR: неправильное завершение процесса или неисправный кабель SCSI оборудования, или два устройства пытались использовать одно и то же IRQ.

Для большей информации о других возможных кодов статусов, смотрите Ntstatus.h файл Windows XP Professional Driver Development Kit (DDK).

Решение:

Используйте один из предложенных методов для решения этой проблемы:

Просканируйте жёсткий диск антивирусной программой.

Просмотрите Журнал событий (Event Viewer) для получения дополнительной информации, какое оборудование стало причиной ошибки.

Такое может произойти, когда запрошенная страница информации ядра не может быть прочитана из виртуальной памяти, или master boot record заражён вирусом, или из-за несовместимых дисков, контроллеров, firmware (BIOS), оборудования.

Плохой кластер на жёстком диске. Ошибка номера 0x7А зачастую является причиной плохого кластера в месте виртуальной памяти, или ошибка контроллера диска, или в ОЧЕНЬ редких случаях, когда не хватает свободного места на диске.

Если первый и второй параметры равны нулю, то причиной является неисправное оборудование. Если I/O статус равен C0000185 и виртуальная память на SCSI жёстком диске, вы должны проверить рабочее состояние кабелей и завершение SCS.

I/O код статуса 0xC000009C или 0xC000016A обычно указывает, что информация не может быть считана с жёсткого диска из-за плохого кластера.

Если возможно перезагрузите компьютер, Autochk автоматический запуститься и попытается выявить плохие кластеры. Если по какой либо причине Autochk не просканирует диск, запустите Autochk вручную. Если диск отформатирован на NTFS, запустите Chkdsk /f /r на системной партиции. Вы должны перезагрузить компьютер до того, как сканирование начнётся. Если вы не можете загрузить компьютер из-за этой ошибки, используйте Консоль (Command Console) и запустите Chkdsk /r .

Повреждённая память - random access memory (RAM), Level 1000 2 (L2) SRAM cache, или RAM видео адаптера - ещё одна причина этой ошибки.

Проверьте, если все карты адаптеров хорошо закреплены в слотах. Что контакты нигде не отходят.

Отключите caching в BIOS и проверьте, решит ли это проблему.

Если вы недавно установили новое оборудование, отключите и отсоедините его.

Если это не решит проблему, то повреждена материнская плата.

Проверьте обновления на сайте поставщика вашего оборудования. Проверьте, используют ли ваш диск и его контроллер одинаковые дополнительные установки. Если необходимо, установите медленней скорость передачи данных.

Так же вы можете установить драйвера для контроллеров, которые не присутствуют на Windows XP Professional установочном диске. Для этого в начале установки нужно нажать F6, когда установка просит:

Press F6 if you need to install a third party SCSI or RAID driver

Примечание:

Эта ошибка схожа с STOP: 0x00000077

Stop 0x0000007A во время установки на ATA66 компьютере

Во время установки Windows 2000 на IDE или UltraDMA66/ATA66 компьютер, вы получаете:

STOP 0x0000007A (0xc03f33fc, 0xc000000e, 0xfccffcba, ox0696b860)
KERNEL_DATA_INPAGE_ERROR ***Address xxxxxxxx has base at xxxxyyyy -
atapi.sys

Если у вас UlraDMA66/ATA66 (80 wire/40 pin) IDE кабель, подсоединенный к диску, на который вы устанавливаете Windows 2000, это может случиться, т.к. Windows 2000 не полностью поддерживает UltraDMA66 контроллер.

Решение:

Используйте подходящий способ, чтобы решить проблему:

1. Используйте стандартный ATA (40 wire/40 pin) IDE кабель и проверьте у производителя вашей мат. платы обновления драйверов ATA66 для Windows 2000.

2. Когда во время установки вас просят нажать F6, если вам необходимо установить SCSI и RAID драйвера (if you need to install a third party SCSI or RAID driver), установите обновлённый драйвер Windows 2000 UltraDMA66.

Примечание: Некоторые UltraDMA66/ATA66 firmware дисков установлены на UltraDMA66/ATA66. Некоторые старые мат.платы не поддерживают UltraDMA66/ATA66. Спросите вашего производителя ж.диска о установке джамперов или программе, которую вы могли бы использовать, чтобы включить поддержку протокола ATA33 на ATA66 протоколе на диске или мат.плате, которая имеет встроенный UltraDMA66/ATA66 контроллер, неподдерживаемый Windows 2000.


0x0000007B: INACCESSIBLE_BOOT_DEVICE

В процессе инсталляции I/O системы, драйвер загрузочного устройства, возможно, не смог инициализировать устройство, с которого система пыталась загрузиться, или файловая система, которая должна была прочитать это устройство, либо не смогла инициализироваться, либо просто не распознала информацию на устройстве, как структуру файловой системы. В вышеупомянутом случае, первый аргумент - это адрес уникодовой структуры информации, которая является ARC именем устройства, с которого была попытка загрузиться. Во втором случае, первый аргумент - это адрес объекта устройства, которое не может быть смонтировано.

Если эта ошибка возникла при начальной инсталляции системы, возможно система была установлена на диск или SCSI контроллер, которые ею не поддерживается. Имейте в виду, что некоторые контроллеры поддерживаются только драйверами из Windows-библиотек (WDL), которые должны быть установлены в режиме выборочной установкой.

Эта ошибка так же может произойти после установки нового SCSI адаптера или контроллера или после изменения системных разделов. В этом случае, на x86 системах, нужно отредактировать BOOT.INI; на ARC системах, нужно запустить Setup.

Если аргумент указывает на строковый параметр ARC, формат первых двух (это только в этом случае) длинных слов будет:

USHORT Length;
USHORT MaximumLength;
PVOID Buffer;

Например, если первое длинное слово содержит что-то типа 00800020, где 20 длина Уникодового стринга (Unicode string), следующее длинное слово будет содержать адрес буфера.

Если аргумент указывает на объект устройства, формат первого слова будет:

USHORT Type;

Значит, первое сло 1000 во содержит 0003, где тип всегда будет 0003.

Примечание:

Вы сразу сможете опознать, указывает ли аргумент на ARC имя или на объект устройства, так как уникодовая строка (Unicode string) никогда не содержит нечётное число байтов, а объект устройства всегда будет содержать тип кода - 3.

Параметры:

1. указатель на объект устройства или уникодовая строка (Unicode string), или ARC имя.

· Windows 2000

При первом рестарте после установки новой материнской платы, вы можете получить эту ошибку.

Если в новой материнской плате есть встроенный IDE-контроллер, который использует отличный чипсет чем предыдущая материнской плата, вы получите такой стоп.

Решение:

1. Загрузитесь с установочного диска или дискет Windows 2000

2. На первом экране нажмите Ентер

3. Нажмите F8, когда попросят подтвердить

4. Выберите Windows 2000 и нажмите R

5. Придерживайтесь инструкций на экране, чтобы выполнить ремонт Windows 2000

· Windows NT 2000, BackOffice

Microsoft статья - http://support.microsoft.com/?kbid=122926:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a

После рестарта компьютера, вы получили стоп:

STOP: 0x0000007B Inaccessible Boot Device

Это ошибка может появиться, если какая-либо из приведённых причин применяется:

1. Ваш компьютер заражён вирусом, который может повредить boot сектор

2. Драйвер устройства, который требуется загрузочным контроллером на момент загрузки, не сконфигурирован или повреждён.

3. Конфликт ресурсов имеет место между загрузочным контроллером и другим контроллером или между SCSI устройствами в системе.

4. Загрузочная информация повреждена и не может быть смонтирована системой.

5. Информация в реестре Windows NT, которая определяет драйвер какого устройства должен быть загружен на старте, повреждена.

6. Если эта ошибка появилась во время установки, когда читается вторая установочная дискета, возможно у вас разрешена функция Drive Swapping в BIOS.

7. Использование winnt /b, как метод инсталляции, могут вызвать причины тайминга для контроллера диска. Контроллеру дано не достаточно времени, чтобы ответить и определится и поэтому определён не корректно или совсем не найден.

8. Если инсталляция происходит с загрузочного SCSI CD-ROM, вы получили ошибку потому, что установка не разрешила вам добавить SCSI драйвера третьей стороны, когда вы загружаетесь с SCSI CD-ROM.

Решение:

Для решения этой проблемы, используйте подходящий метод:

Метод 1:

Проверьте на вирусы дискеты, которые могли быть использованы с последнего раза, когда система перезагружалась успешно.

Вам, возможно, понадобятся самые новые программы для выявления вируса.

Если вы обнаружили вирус и антивирусная программа не может его удалить и репейр системе не помог, вам необходимо переустановить всю систему.

ARTICLE-ID: 122221
TITLE : How to Protect Boot Sector from Viruses in Windows NT (Как защитить от вирусов Бут Сектор в Windows NT)

Метод 2:

Windows NT требует мини-порт драйвер, чтобы связываться с контроллером загрузки. Если драйвер устройства повреждён или несовместим с вашим контроллером, вы можете заменить его, скопировав новый драйвер в папку %systemroot%\system32\drivers или через Emergency Repair процесс. На компьютерах, работающих на SCSI контроллере или ATAPI enabled системе, SCSIPORT.SYS и DISK.SYS (только Windows NT 4.0) драйвера тоже обязаны грузиться успешно.

Если вы пытаетесь сделать "WINNT /B" установку, вы можете получить этот стоп до того, как массовое определение оборудования начнётся. Чтобы решить эту проблему, когда компьютер перезагружается после начального копирования файлов, нажмите F6, как только увидите надпись - "Setup is inspecting your computers hardware configuration". Это даст вам возможность добавить накопительное устройство в самом начале установки текстового вида.

ARTICLE-ID: 125933
TITLE : STOP 0x0000007B: Inaccessible Boot Device After Removing CD-ROM

ARTICLE-ID: 164471
TITLE : Replacing System Files Using a Modified Emergency Repair Disk

Метод 3:

Если существует конфликт порт адресов IRQ или I/O между загрузочным контроллером и другими контроллерами в вашей системе, Windows NT либо зависнет при загрузке, либо появится Stop 0x0000007B сообщение. Если как 1000 раз до этого вы установили новое оборудование, удалите его или переконфигурируйте так, чтобы не вызывать конфликта с ресурсами любых других контроллеров.

Проверьте цепь SCSI на корректное завершение. Удалите всякое необязательное SCSI оборудование или убедитесь, что SCSI ID для каждого устройства уникально.

ARTICLE-ID: 102651
TITLE : Required Settings for Adaptec 1510 SCSI Host Adapter

Метод 4:

Загрузочная партиция Windows NT должна быть не дальше 1024 цилиндра загрузочного устройства. Это из-за ограничения INT-13 BIOS зова, используемого, чтобы загрузить систему. Проверьте настройки вашего CMOS на поддержку LBA на системе, основанной на IDE, или ваши SCSI контроллер BIOS установки на разрешение поддержки винчестера больше 2Г.

ARTICLE-ID: 114841
TITLE : Windows NT Boot Process and Hard Disk Constraints

Метод 5:

Если повреждена файловая система и Windows NT не может смонтировать загрузочную информацию во время загрузки, поставьте винчестер на машину с Windows NT и запустите CHKDSK на повреждённом харде. Или попробуйте параллельно установить Windows NT на отдельной директории. Установка Windows NT проверяет целостность прежде чем начать установку и может решить некоторые проблемы.

Метод 6:

Если повреждён файл SYSTEM в реестре Windows NT, это может помешать Windows NT загрузить Mini-port (мини-порт) драйвер, требуемый загрузочным контроллером. Для решения этой проблемы, воспользуйтесь одном из следующих способов:

Загрузитесь с 3-ёх загрузочных дискет Windows NT и используйте Repair utility. Когда потребуется, выберите проверку файлов реестра и только тогда замените System Configuration Registry hive. Этот файл содержит информацию о том, какие драйвера и сервисы должны быть запущены во время загрузки.

Заинсталируйте параллельную копию Windows NT 700 в другую директорию и потом используйте Registry Editor, чтобы редактировать SYSTEM файл и исправить неправильную или отсутствующую информацию.

ARTICLE-ID: 165748
TITLE : How to Disable a Service or Device that Prevents NT from Booting

Метод 7:

Многие компьютеры снабжены 5.25-inch и 3.5-inch флоппи дисководом. При инсталляции Windows NT может появиться ошибка STOP 0x7B во время чтения второй загрузочной дискеты. Чтобы решить эту проблему, отключите в BIOS Drive Swapping для флоппи дисковода. Для большей информации, пожалуйста, обратитесь к следующей статье:

ARTICLE-ID: 126423
TITLE : STOP: 0x0000007B "Inaccessible_Boot_Device" During Setup Disk2


0x0000007E

· Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

"STOP 0x0000007E" Error Message After You Upgrade to Windows XP

После обновления на Windows XP, вы можете получить следующий стоп:

STOP: 0x0000007E (0xC0000005, 0x804E518E, 0xFC938104, 0xFC937E04)
SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Примечание: четыре параметра в этом сообщении могут меняться, в зависимости от конфигурации системы.

Причина:

Это может случиться, когда системная нить генерирует исключение, которое поддержка ошибок (error handler) не может уловить.

Это может случиться, когда одно из следующих высказываний верно:

  • Не хватает дискового пространства. Если ошибка появилась после первого рестарта во время установки Windows или сразу после того, как установка завершилась, на жёстком диске может быть не достаточно места, чтобы запустить Windows.
  • Несовместимость BIOS. Если ошибка появилась после первого рестарта во время установки Windows или сразу после того, как установка завершилась, BIOS может быть несовместим с Windows.
    Несовместимые драйвера видео адаптера.
  • Повреждённый Random Access Memory (RAM).
  • Повреждённый драйвер оборудования или системный сервис.
  • Несовместимая программа третьей стороны удалённого управления. Если ошибка ассоциируется с Win32k.sys файлом, это может быть из-за программы третьей стороны удалённого управления.

Решение:

Используйте один из предложенных методов для решения этой проблемы:

Метод 1:

Убедитесь, что на диске достаточно свободного мета. Удалите ненужные файла с жёсткого: temporary files, Internet cache files, бэкапы от программ, .chk файлы, которые содержут врагменты файлов с скана диска. Так же вы можете воспользоваться другим HDD с большей ёмкостью.

Метод 2:

Обновите BIOS. Свяжитесь с производителем материнской платы и выясните обновления для BIOS. Вы можете временно отключить такие функции в BIOS, как caching или shadowing.

65416 Hardware and Software Third-Party Vendor Contact List, A-K

60781 Hardware and Software Third-Party Vendor Contact List, L-P

60782 Hardware and Software Third-Party Vendor Contact List, Q-Z

Метод 3:

Посмотрите Microsoft Hardware Compatibility List (HCL) список, чтобы выяснить, является ли ваше PCI оборудование совместимым с Windows XP.

314062 The Latest Windows XP Hardware Compatibility List

Обновите последние драйвера видео адаптера. Если драйвер указан на стоп-экране, отключите или удалите этот драйвер. Отключите или удалите все драйвера или сервисы, которые вы добавили последними. Если ошибка появляется во время загрузки Windows, партиция, на которой стоит система, использует NTFS, возможно использование Безопасного режима (Safe mode), чтобы переименовать или удалить неисправный драйвер. Если драйвер используется, как часть системы во время загрузки, то необходимо загрузиться в Recovery Console, чтобы получить доступ к файлу.

Если проблема ассоциируется с Win32k.sys файлом, причина проблемы может быть в программе удалённого доступа третьей стороны. Если такая программа установлена, вы можете удалить сервис загрузившись в Recovery Console и удалить специфический файл системного сервиса.

Метод 4:

Если у вас есть возможность загрузиться в Безопасном режиме (Safe mode), удалите все драйвера, которые не имеют digital signeture. Для дополнительной информации, как это сделать, обратитесь к статье:

316434 HOW TO: Perform Advanced Clean-Boot Troubleshooting in Windows XP

Метод 5:

В редких случаях вы можете выявить неисправный драйвер третьей стороны. Вы можете попутаться решить эту проблему, переместив все драйвера третьей стороны из Windows\System32\Drivers в другую директорию. Чтобы это осуществить, загрузитесь в Recovery Console или в другую установку Windows, если таковая имеется. Только убедитесь, что папка, в которую вы перемещаете эти файлы, не имеет дату создания - 8/13/2001. Если компьютер под управлением драйвера контроллера IDE или SCSI третьей стороны, необходимо установите эти драйвера и оставить их в Windows\System32\Drivers. Перезагрузите компьютер и продолжайте установку. Для дополнительной информации, как отключить сервис, который предотвращает загрузку Windows, обратитесь к следующей статье:

310602 How to Disable a Service or Device that Prevents Windows from Starting

Дополнительная информация

Если вы получили стоп 0x0000007E, когда вы первый раз загружаете компьютер после установки и вы не устанавливали никаких драйверов 3-ей стороны, во время установки Windows, проблема может быть в неподдерживаемом оборудовании Windows XP. И это из-за того, что все драйвера - Windows XP драйвера.

Тем не менее, если вы получили этот стоп после апгрейда с Windows 2000 или вы только, что подключили новое оборудование, проблемой может быть несовместимый драйвер или само оборудование. Для дополнительной информации:

315222 A Description of the Safe Boot Mode Options in Windows XP

314058 Description of the Windows XP Recovery Console

308041 Resources for Troubleshooting Startup Problems in Windows XP

Так же для дополнительной информации вы можете обратиться к статье 0x0000000A


0x0000007F: UNEXPECTED_KERNEL_MODE_TRAP

Эта ошибка означает, что произошло непредвиденное исключение в режиме ядра, или прерывания, при котором ядро не срабатывает. Также причиной ошибки может стать прерывание, которое повлекло за собой немедленную смерть в виде двойной ошибки - double fault. Первое число в коде ошибки - число прерывания (8 = double fault). Чтобы узнать больше, что это за прерывание, обратитесь к мануалу семейства Intel x86.

Короче говоря, ошибка появляется, когда процессор допускает ошибку, с которой ядро не может справиться. Чаще всего ошибка возникает из-за плохих блоков ОЗУ, а иногда из-за разгона процессора.

Попробуйте отменить в BIOS функцию синхронной передачи данных.

· Windows XP

Применяется в системам:

  • Windows XP Professional

Stop 0x0000007F or UNEXPECTED_KERNEL_MODE_TRAP

Причина:

Stop 0x7F сообщение указывает на то, что одна из 3-ёх проблем появилась в режиме ядра (kernel-mode):

  • Ситуация, которую ядро не допускает, или intercept (так же называется - bound trap).
  • Проблема программного обеспечения.
  • Ошибки устройств.

Параметры:

1. Исключительный код процессора.
2. Это значение 0x00000000 (ноль).
3. Это значение 0x00000000 (ноль).
4. Это значение 0x00000000 (ноль).

Первый параметр самый важный и он может принять насколько различных значений, указывающих на разные причины этой ошибки. Вы можете найти условия возникновения Stop 0x7F на всех x86 микропроцессорах в их мануале, т.к они специфичны для x86 платформ. Вот несколько часто встречающихся:

  • 0x00000000, или разделённая на 0 ошибка, возникает когда "разделить" (DIV) инструкция делит на 0. Битая память, другие проблемы с оборудованием или проблемы с ПО могут привести к этой ошибке.
  • 0x00000004, или Переполнение, в результате предыдущих операций был взведён флаг переполнения (OF), а процессор обращается к модулю прерывания.
  • 0x00000005, or Bounds Check Fault, указывет, что процессор, во время выполнения операции BOUND, обнаружил, что операнд превысил указанный лимит. Инструкция BOUND используется, чтобы проверять, что числа массива находятся в определённом промежутке.
  • 0x00000006, or Invalid Opcode, возникает, когда процессор пытается выполнить недопустимую операцию. Обычно такое случается, когда указатель инструкций (instruction pointer) повреждён из-за повреждённой памяти и указывает на неверную позицию.
  • 0x00000008, или Двойная Ошибка (Double Fault), указывает на исключ 1000 ение во время попытки вызвать модуль (the handler) для предыдущего исключения. Обычно, два исключения могут быть выдержанны в очереди, но есть несколько исключений (почти всегда вызванных проблемами с устройствами), из-за которых процессор вызывает двойную ошибку.

Реже встречающиеся ошибки:

  • 0x00000001: A system-debugger call.
  • 0x00000003: A debugger breakpoint.
  • 0x0000000A: A corrupted Task State Segment.
  • 0x0000000B: An access to a memory segment that was not present.
  • 0x0000000C: An access to memory beyond the limits of a stack.
  • 0x0000000D: An exception not covered by some other exception; a protection fault that pertains to access violations for applications.

Решение:

Следующие решения специфичны к Stop 0x7F ошибкам. для дополнительной информации обратитесь к статье M$ "Stop Message Checklist".

1. Stop 0x7F ошибки обычно возникают из-за испорченной, плохо работающей памяти (RAM). Если вы только что подключили новое устройство - отключите его и посмотрите, если это решит проблему. Запустите диагностическое ПО, которое пришло к вам от производителя системы, чтобы выявить если какой-нибудь компонент не рабочий/ плохо работает.

2. Разгон процессора (overclocking) может стать причиной Stop 0x7F или другие ошибки из-за перегрева. Когда диагностируете разогнанную систему, сначала снимите все разгоны до тех, которые рекомендованы производителем.

3. Проблема может быть из-за поцарапанных, испорченных компонентов на материнской плате. В этом случае вам необходимо отнести мат. плату на диагностику.

4. Stop 0x7F сообщение может появиться после установки несовместимого ПО, драйверов или системных сервисов. Свяжитесь с производителем ПО и выясните о каких-либо дополнительных обновлений для Windows XP Professional. Использование совместимых программ особенно важно в случае с Бэкапными программами (backup programs), мультимедийным ПО, антивирусными и CD-записывающими программами.

5. Для дополнительной информации обратитесь к статье http://www.microsoft.com/windows/reskits/webresources. Используйте в поиске ключевые слова winnt, 0x0000007F и 0x7F.


0x0000008E

Несовместимость или неисправность блоков памяти RAM.

· Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

"STOP 0x0000008e" Error Message During Windows XP Setup

Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

Во время установки, вы можете получить следующую ошибку:

STOP 0x0000008e
или
STOP 0x00000050 PAGE_FAULT_IN_NON_PAGED_AREA

А так же, если вы удалите всё не необходимое оборудование из компьютера и после этого начнёте установку, можете получить следующую ошибку:

Setup cannot copy the file Setupdd.sys.

Это может случиться, если один из приведённых ниже вариантов применяется:

  • Один или несколько RAM модулей установленных на вашем компьютере неисправны.
  • Конфигурация RAM не совместима с Windows XP.

Решение:

1. Удалите некоторые модули RAM памяти и оставьте хотя бы столько, чтобы можно было запустить Windows XP.

Рекомендовано - 128, минимум - 64, максимум - 4Г.

2. Перезагрузите компьютер и запустите установку.

3. Если вы опять получаете этот же стоп, то переходите к пункту 4.

4. Попробуйте другой модуль или поставьте этот модуль в другой слот.

5. Перезагрузите компьютер и запустите установку снова.

Примечание: эта и ошибка 0x0000008E в большинстве случаев указывают на плохую RAM память.

STOP 0x0000008E Error Message on a Blue Screen and Your Computer Does Not Enter Hibernation or Standby After You Remove an IEEE 1394 Storage Device

Применяется к следующим системам:

  • Microsoft Windows XP Professional SP1
  • Microsoft Windows XP Home Edition SP1

Вы могли получить такую ошибку, после того как удалили IEEE 1394 накопительное устройство, такое как CD-ROM или внешний винчестер с компьютера под Windows XP Service Pack 1 (SP1):

1. Когда вы погружаете ваш компьютер в сон (hibernation):

*** STOP: 0x0000008E (0xC00000005, 0x804EF844, 0xF89463FC,0x00000000)

2. Когда вы погружаете ваш компьютер в standby, монитор выключается, как нужно, но индикатор показывает, что компьютер не в standby.

Это может случиться, если приведённые ниже варианты применяются:

1. Апдейт - 329909 IEEE 1394 Storage Device Detection Does Not Work When the System Resumes from Standby or Hibernation - установлен на ваш компьютер.

И

2. Вы удалили IEEE 1394 накопительное устройство, пользуясь Safely Remove Hardware, и потом погрузили ваш компьютер в сон (hibernation) или standby

Примечание: IEEE 1394 накопительное устройство удалено из Windows XP, но физический ещё подключено к компьютеру .

Решение:

Уже есть решение этой проблемы, но оно поможет только в ситуации описанной вверху. Применяйте его только к компьютеру с такой проблемой. Поэтому, если вы не сильно обременены этой проблемой, Microsoft рекомендует подождать до выхода следующего SP, который решит эту проблему.

Чтобы решить эту проблему немедленно, свяжитесь с Microsoft Product Support Services, для выяснения номеров телефонов и стоимости звонков и услуг, посетите сайт Microsoft:

http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS

Примечание: В некоторых случаях, стоимость звонка может быть отменена, если Microsoft выяснит, что конкретный патч поможет решить эту проблему. В остальных случаях, когда обсуждаются вопросы, не относящиеся к конкретному случаю, плата будет взыскана.

В патч должны быть включены файлы со следующими атрибутами:

Date Time Version Size File name SP
----------------------------------------------------------------------------------
20-Feb-2003 17:04 5.1.2600.111 38,656 sbp2port.sys
20-Feb-2003 17:04 5.1.2600.1172 38,656 sbp2port.sys SP1

Microsoft подтверждает, что проблема в продукте Microsoft.


0x0000009C: MACHINE_CHECK_EXCEPTION

Фатальная ошибка Machine Check Exception (проверка машины).

KeBugCheckEx параметры:

Если процессор имеет ТОЛЬКО MCE функции доступными (например: Intel Pentium), то параметры будут:

1 - Low 32 bits of P5_MC_TYPE MSR
2 -
3 - High 32 bits of P5_MC_ADDR MSR
4 - Low 32 bits of P5_MC_ADDR MSR

Если процессор имеет так же MCA функции доступными (например: Intel Pentium Pro), то параметры будут:

1 - Пустой номер
2 - Адрес поля MCi_ADDR MSR MCA, где ошибка случилась
3 - High 32 bits MCi_STATUS MSR, где ошибк 1000 а случилась
4 - Low 32 bits MCi_STATUS MSR, где ошибка случилась

· WindowsXP:

http://support.microsoft.com/?kbid=329284

Вы получили стоп: STOP: 0x0000009C (0x00000004, 0x00000000, 0xb2000000, 0x00020151)
"MACHINE_CHECK_EXCEPTION"

(четыре параметра в скобках могут быть разными)

Причина:

Это происходит из-за того, что процессор вашего компьютера обнаруживает ошибку и сообщает об этом Windows XP. Чтобы сделать это он использует Machine Check Exception (MCE) для процессоров Pentium или Machine Check Architecture (MCA) для некоторых процессоров Pentium Pro. Ошибка может вызываться следующим:

  • Ошибки системной шины
  • Ошибки памяти, которые могут включ ать четность или Код исправления ошибок (код с исправлением ошибок) проблемы
  • Ошибки кэша в процессоре или аппаратных частях системы
  • Ошибки процессора в TLB
  • Причина ошибки, другой вендор (производитель) процессора
  • Специ фичные обнаруженные аппаратные проблемы.

Статус:

Такое поведение специально спланировано М$

Решение:

Ошибка может возникнуть если вы:

1. Сделали оверклокинг процессора или шины. В этом случае, установите параметры работы рекомендуемые производителем.

2. Не стабильный блок питания. Удостоверьтесь, что ваш БП работает корректно.

3. Перегрев. Перегрев каких либо компонентов может привести к этой ошибке. Убедитесь, что все куллеры работают исправно.

4. Повреждённая память или память не подходящая для вашего компьютера. Убедитесь, что память работает исправно и модель совместима с вашей конфигурацией.

Добавление:

Такая ошибка так же может возникнуть если:

1. Вы изменили параметры в биос, которые влияют на конфигурацию ядра системы

2. Вы установили ХР с образа чужой системы

3. У вас не правильно подключено какое-то оборудование

Происходит это из-за того что проверка машины не соответствует уже установленной конфигурации ядра.


0x0000009F

Драйвер находится в противоречивом или недопустимом состоянии потребления энергии. Обычно это происходит из за сбоев в питании, при перезагрузке, выходе из спящего режима и т.д.

· Windows 2000

Применяется к следующим системам:

  • Microsoft Windows 2000

DRIVER_POWER_STATE_FAILURE

Причина:

Причиной этого стопа является драйвер устройства, который не выдержал вызова на переход в другое состояние электропитания.

Решение:

Вы должны обновить или удалить неработоспособный драйвер устройства или фильтр драйвер файловой системы (file system filter driver), который, возможно, был установлен антивирусом, программой удалённого доступа или ПО CDW/CDRW.

Дл 6eb я обнаружения драйвера примените следующие:

1. Используйте %SystemRoot%\System32\Sigverif.exe чтобы проверить на драйвера, которые не проходили тесты Microsoft (unsigned drivers).

2. Проверьте обновления драйверов у поставщика вашей системы.

3. Обновите ПО, которое может иметь фильтр драйвера файловой системы (file system filter drivers).

4. Удалите компоненты оборудования, а так же ПО, которые не обязательны для выявления драйвера.

5. Установите ещё один Windows 2000 на другую партицию. И устанавливаете, тут же проверяя, ПО пока не выявите программу с драйвером.


0x00000050: PAGE_FAULT_IN_NONPAGED_AREA

Возникает, когда запрошенная информация не была найдена в памяти. Система проверяет файл подкачки (page file), но отсутствующая информация была обозначена, как невозможная для записи в файл подкачки (page file).

Если это случилось на Terminal Server, проверьте драйвера третьей стороны для принтера.

Параметры:

1. указывает на адрес в памяти, который допустил ошибку

· Windows NT:

Применяется к следующим системам:

  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

Replacing TCP/IP After SP2 Causes STOP 0x00000050

На компьютере с Windows NT 4.0, где до этого был установлен Service Pack 2 (SP2), если вы удаляете TCP/IP протокол, а потом снова добавляете, при загрузке компьютера вы получаете следующие STOP ошибки:

STOP 0x00000050 (0xFF10c004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA
или

STOP 0x00000050 (0xFF404004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA
или

STOP 0x00000050 (0xA0133004, 0x0, 0x0, 0x0) PAGE_FAULT_IN_NONPAGED_AREA

Примечание: первый аргумент может меняться, но сам стоп (0x00000050) всегда одинаков.

Причина:

Это происходит из-за того, что в системе установлен сервис удалённого доступа (Remote Access Service) и сконфигурирован использовать TCP/IP протокол или на dial-in или на dial-out протоколе.

Решение:

Чтобы избежать проблемы - после того, как вы добавили TCP/IP протокол опять, используйте следующие методы:
Установите SP2 после того, как вы добавили TCP/IP протокол, но перед перезагрузкой компьютера. Нажмите "No", когда вам предложат рестарт после того, как вы добавили TCP/IP.

или
После того, как вы добавили TCP/IP протокол, запретите TCP/IP в RAS конфигурации и разрешите Windows NT перезагрузиться. После перезагрузки, установите SP2 и разрешите TCP/IP через RAS.

Чтобы решить проблему, используйте подходящий метод:

Method 1: Windows NT на FAT партиции

Загрузите компьютер с другой ОС (MS-DOS, Windows 95, Windows 3.x) 1000 и замените файл Tcpip.sys из \Winnt\System32\Drivers папки на файл из папки Service Pack 2.

Method 2: Windows NT на NTFS партиции

Установите параллельную установку Windows NT в новую директорию и замените файл Tcpip.sys из \Winnt\System32\Drivers папки на файл из папки Service Pack 2. Перезагрузитесь в начальный Windows NT и переустановите Service Pack 2. После удалите параллельную установку Windows NT.

Microsoft подтверждает, что это их глюк. =)

Stop 0x00000050 во время перехода с Windows NT 4.0 на Windows 2000

Во время апгрейда с Windows NT 4.0 до Windows 2000, вы получаете следующий BSOD:

STOP 0x00000050 (любое значение, 0x00000001, любое значение, 0x00000000).

Одна из возможных причин этого BSOD, что слишком много портов обозначено на HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{Interface ID}\TcpAllowedPorts значение.

Решение:

1. Удалите большинство значений портов или само значение TcpAllowedPorts.

2. Обновитесь.

· Windows 2000:

Применяется к следующим системам:

  • Microsoft Windows 2000 Professional

Когда вы устанавливаете PC карточку на ваш Windows 2000 Professional лаптоп, ваша система вылетает в BSOD:

Stop: 0x00000050 (0xfffffff0 ,0x00000000, 0x8044d0da, 0x00000000) PAGE_FAULT_IN_NONPAGED_AREA.

Если у вас установлен Roxio Inc.'s Easy CD Creator Platinum 5.0 вместе с Take Two backup ПО, эта проблема будет появляться пока вы не обновите или не пропатчите Roxio ПО:

http://www.roxio.com/en/support/roxio_support/ecdc/ecdc_software_updatesv5.jhtml.

STOP 0x00000050 in Sentinel.sys во время загрузки Windows 2000

Во время загрузки Windows 2000, вы получаете BSOD:

STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4) PAGE_FAULT_IN_NON_PAGED_AREA Sentinel.sys.

Причина:

Проблема возникает из-за повреждённой или несовместимой программы Rainbow Technologies 'Sentinel'.

Решение:

1. Перезагрузите компьютер.

2. Нажмите F8 во время бут-экрана.

3. Выберите Safe Mode и нажмите Enter.

4. Если необходимо, выберите Windows 2000.

5. Обратитесь к http://www.rainbow.com/support/index.html, чтобы узнать, как удалить системный драйвер Sentinel.

STOP 0x00000050 в Sentinel.sys во время загрузки Windows 2000

Во время загрузки Windows 2000 получаете:

STOP: 0x00000050 (parameter1, parameter2, parameter3, parameter4) PAGE_FAULT_IN_NON_PAGED_AREA Sentinel.sys.

Эта проблема возникает из-за повреждённой или несовместимой версии программы Rainbow Technologies 'Sentinel'.

Решение:

1. Перезагрузите компьютер.

2. Нажмите F8 на загрузке.

3. Выберите Safe Mode и нажмите Enter.

4. Если необходимо, выберите Windows 2000.

5. Посетите http://www.rainbow.com/support/index.html чтобы узнать, как удалить системный драйвер Sentinel.

· Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

Следующее может произойти с вами:

1. Компьютер автоматический перезагружается

2. После перезагрузки вы получаете следующие сообщение:

Microsoft Windows
The system has recovered from a serious error.
A log of this error has been created.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.

Если вы хотите посмотреть детали стоп-ошибки нажмите на "click here":

BCCode : 00000050 BCP1 : 0xffffffe0 BCP2 : 0x00000001 BCP3 : 0xf30da010 BCP4 : 0x00000000 OSVer : 5_1_2600 SP : 0_0 Product : 256_1

3. Вы получаете синий экран с сообщением:

A problem has been detected and Windows has been shut down to prevent damage to your computer
Technical information:

*** STOP: 0x00000050 (0xffffffe0, 0x0x00000001, 0xf30da010, 0x00000000)
PAGE_FAULT_IN_NONPAGED_AREA

4. При просмотре системных логов в Event Viewer, вы обнаруживаете ошибку:

Date: date
Source: System
Error Time: time
Category: (102)
Type: Error
Event ID: 1003
User: N/A
Computer: computer
Description: Error code 00000050, parameter1 0xffffffe0, parameter2 0x00000001, parameter3 0xf30da010, parameter4 0x00000000.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 00000MN 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c

Примечание:

Симптомы ошибки могут изменяться в зависимости от того, что именно повредилось.

307973 HOW TO: Configure System Failure and Recovery Options in Windows

Четыре параметра в стоп-ошибке могут меняться в зависимости от конфигурации системы.

Не все стоп-ошибки возникают по причинам перечисл 3c9 енным ниже.

Причина:

Проблема появляется из-за некорректной работы драйвера USB Universal Reader от Lexar Media, он не совместим с ХР

Решение:

Обновите драйвера для USB


0x00000071: SESSION5_INITIALIZATION_FAILED

Это коды кодов (SESSION1 - SESSION5) указывают место в NTOS\INIT\INIT.C, где была допущена ошибка.

Параметры:

1. указывает код статуса, который решил, что инициализация NT не прошла успешно.

· Windows NT 2000 XP

Применяется к следующим системам:

  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Server
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows XP 64-Bit Edition
  • Microsoft Windows XP Professional

MS03-007: Unchecked Buffer in Windows Component May Cause Web Server Compromise

Относится стопу SESSION5_INITIALIZATION_FAILED

Microsoft впервые выпустил эту статью 17, 2003. В то время Microsoft был информирован о дыре в безопасности Windows 2000 Servers на IIS 5.0. Для атак использовался WebDAV, но в корне, уязвимым компонентом был Ntdll.dll. Microsoft выпустил патч для Windows 2000 и продолжил работу над главной проблемой. Windows NT 4.0 так же имеет основную уязвимость в Ntdll.dll, но он не поддерживает WebDAV, поэтому эта дыра не может быть использована для атак Windows NT 4.0. Microsoft всё равно выпустил патч для Windows NT 4.0. К тому же Microsoft изучает уязвимости в Windows XP. Тем не менее, как и Windows NT 4.0, Windows XP не устанавливает Internet Information Services (IIS) по умолчанию. 28 мая 2003 Microsoft выпустил патч для Windows XP и Windows XP Service Pack 1.

Предупреждение:

Если вы используете Windows 2000 Service Pack 2 (SP2), вы должны проверить версию Ntoskrnl.exe до установки патча. Сделайте это так:
1. Откройте %Windir%\System32 folder.
2. Правой кнопкой мыши на Ntoskrnl.exe - Свойства (Properties) - Закладка Версия (Version tab).
Версии Ntoskrnl.exe с 5.0.2195.4797 до 5.0.2195.4928 несовместимы с этим патчем. Эти версии были разработаны только для Microsoft Product Support Services hotfixes. Если вы установите этот патч на компьютер с такими версиями Ntoskrnl.exe, копм зависнет и появиться "Stop 0x00000071" сообщение после перезагрузки. Если такое случиться, вам необходимо восстановить Windows, используя Windows 2000 Recovery Console и бекапную копию Ntdll.dll, которая находиться в папке Winnt\$NTUninstallQ815021$.

Чтобы обновить такой Ntoskrnl.exe вы должны связаться с Microsoft Product Support Services до установки патча. Номера телефонов и тарифы оплат вы найдёте на http://support.microsoft.com/default.aspx?scid=sz;en-us;top

Или вы можете установить Windows 2000 Service Pack 3 (SP3) до установки патча.

Симптомы:

Windows 2000 поддерживает World Wide Web Distributed Authoring and Versioning (WebDAV) протокол. WebDAV, как это описано в RFC 2518, это набор расширений для Hypertext Transfer Protocol (HTTP), который обеспечивает стандарты для правки и управление файлами между компьютерами в Internet. Просмотреть RFC 2518 можно по адресу:
ftp://ftp.rfc-editor.org/in-notes/rfc2518.txt
Эта уязвимость существует в Windows компонентах, которыми пользуется WebDAV. Эта уязвимость появляется потому, что компоненты содержат непроверенный буфер (unchecked buffer).

Взломщики могут воспользоваться уязвимостью, посылая специально сформированные HTTP запросы на компьютер с Microsoft Internet Information Services (IIS). Запрос может спровоцировать падение сервера или запустить коды взломщиков по их выбору. Код будет выполняться в контексте безопасности IIS сервиса. (По умолчанию, IIS запускается в LocalSystem контексте).

Microsoft рекомендует установить патч немедленно. Для дополнительной информации смотрите Microsoft Knowledge Base:
816930 MS03-007: How to Work Around the Vulnerability That Is Discussed in Microsoft Knowledge Base Article 815021

Смягчающие факторы
В конфигурации по умолчанию URLScan предупреждает использование уязвимости. URLScan - это часть IIS Lockdown инструмента. Для дополнительной информации о URLScan смотрите:

http://www.microsoft.com/technet/security/URLScan.asp

Для дополнительной информации о IIS Lockdown tool смотрите:

http://www.microsoft.com/technet/security/tools/tools/locktool.asp

Уязвимость может использоваться только удалённо, через установленную связь по Web.

Решение:

Информация по Service Pack:

Windows 2000
Для решения проблемы, установите последний СП для Microsoft 1000 Windows 2000.

Информация по патчу безопасности:

Windows XP
Следующие файлы доступны для скачивания с Microsoft Download Center:

Windows XP (все языки)

Download the 815021 package now.

Windows XP 64-Bit Edition
Download the 815021 package now.

Дата Выпуска: May 28, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.

Предпосылки:

Этот патч должен быть установлен на Windows XP или Windows XP Service Pack 1 (SP1). Для дополнительной информации:
322389 How to Obtain the Latest Windows XP Service Pack

Информация по установлению:

Следующие команды могут использоваться:

  • /?: Показать все команды.
  • /u: Использовать несопровождаемый способ.
  • /f: Закрыть другие программы, когда компьютер выключается.
  • /n: Не сохранять текущую конфигурацию (удаление патча впоследствии невозможно).
  • /o: Переписывает OEM файлы без запросов.
  • /z: Не перезагружать после того, как установка закончится.
  • /q: Использовать "Тихий способ" (без вмешательства пользователя).
  • /l: Вывести список установленных хотфиксов.
  • /x: Распаковать файлы, не запуская установку.

Например, чтобы установить патч без вмешательства пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021_wxp_sp2_x86_enu /u /q /z

Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel).

Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в %Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:

  • /?: Показать все команды.
  • /u: Использовать несопровождаемый способ.
  • /f: Закрыть другие программы, когда компьютер выключается.
  • /z: Не перезагружать после того, как установка закончится.
  • /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Вы обязаны перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется на загрузке.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы, даты будут представлены в локальном времени. Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.

Windows XP

Дата Время Версия Размер Путь Имя файла
---------------------------------------------------------------------------------
02-May-2003 15:03 5.1.2600.114 651,264 %Windir%\System32\Ntdll.dll pre-SP1
01-May-2003 20:56 5.1.2600.1217 654,336 %Windir%\System32\Ntdll.dll with SP1

Windows XP 64-Bit Edition

Дата Время Версия Размер Путь Имя файла
------------------------ 1000 ------------------------------------------------------------
02-May-2003 15:03 5.1.2600.114 1,498,112 %WinDir%\System32\Ntdll.dll pre-SP1
01-May-2003 14:57 5.1.2600.114 654,336 %WinDir%\System32\Wntdll.dll pre-SP1
01-May-2003 20:56 5.1.2600.1217 1,508,864 %WinDir%\System32\Ntdll.dll with SP1
30-Apr-2003 21:43 5.1.2600.1217 657,408 %WinDir%\System32\Wntdll.dll with SP1

Вы так же можете посмотреть файлы, которые этот патч устанавливает, проверив ключ реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows XP\SP2\Q815021\Filelist

Windows 2000
Информация по установлению:

Следующие файлы доступны для скачивания с Microsoft Download Center:

Все языки, за исключением Japanese NEC
Download the 815021 package now.

Japanese NEC
Download the 815021 package now.

Дата выпуска: March 17, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.

Предпосылки:

Патч должен быть установлен на Windows 2000 Service Pack 2 (SP2) или Windows 2000 Service Pack 3 (SP3). Для дополнительной информации смотрите Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

Примечание: Если вы используете Windows 2000 Service Pack 2 (SP2), посмотрите предупреждение в начале этой статьи перед установкой патча.

Информация по установлению:

Следующие команды могут использоваться:

  • /?: Показать все команды.
  • /u: Использовать несопровождаемый способ.
  • /f: Закрыть другие программы, когда компьютер выключается.
  • /n: Не сохранять текущую конфигурацию (удаление патча впоследствии невозможно).
  • /o: Переписывает OEM файлы без запросов.
  • /z: Не перезагружать после того, как установка закончится.
  • /q: Использовать "Тихий способ" (без вмешательства пользователя).
  • /l: Вывести список установленных хотфиксов.
  • /x: Распаковать файлы, не запуская установку.

Наприм 1000 ер, чтобы установить патч без вмешательства пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021_w2k_sp4_x86_en /u /q /z

Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\SP4\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel) - "Windows 2000 Hotfix (SP4) Q815021."

Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в %Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:

  • /?: Показать все команды.
  • /u: Использовать несопровождаемый способ.
  • /f: Закрыть другие программы, когда компьютер выключается.
  • /z: Не перезагружать после того, как установка закончится.
  • /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Вы обязаны перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется на загрузке.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы даты, будут представлены в локальном времени. Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.

Дата Время Версия Размер Путь Имя файла
----------------------------------- 1000 ------------------------------------
15-Mar-2003 01:23 5.0.2195.6685 476,944 %Windir%\System32\Ntdll.dll

Вы так же можете посмотреть файлы, которые этот патч устанавливает, проверив ключ реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\Windows 2000\SP4\Q815021\Filelist

Windows NT 4.0 (All Versions)
Microsoft Internet Information Server (IIS) не предназначен для использования на Windows NT Server 4.0, Terminal Server Edition, и поэтому ими не поддерживается. Microsoft рекомендует пользователям использующим IIS 4.0 на Windows NT Server 4.0, Terminal Server Edition защитить свою систему, удалив IIS 4.0.

Информация по установлению:

Следующие файлы доступны для скачивания с Microsoft Download Center:

Windows NT 4.0:
Все языки, исключая Japanese NEC и Chinese - Hong Kong:

Download the 815021 package now.
Japanese NEC:

Download the 815021 package now.
Chinese - Hong Kong:

Download the 815021 package now.

Windows NT Server 4.0, Terminal Server Edition:

Все языки:

Download the 815021 package now.
Дата выпуска: April 23, 2003

Для дополнительной информации:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft проскандировал эти файлы на вирусы, используя самые обновлённые базы.

Предпосылки:

Этот патч должен быть установлен на Windows NT 4.0 Service Pack 6a (SP6a) или Windows NT Server 4.0, Terminal Server Edition Service Pack 6 (SP6). Для дополнительной информации смотрите Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack

Информация по установлению:

Следующие команды могут использоваться:

  • /y : Удалить (только с /m или /q ).
  • /f : Закрыть другие программы, когда компьютер выключается.
  • /n : Не создавать папку Uninstall.
  • /z : Не перезагружать после того, как установка закончится.
  • /q : Использовать "Тихий" или несопровождаемый способ с вмешательством пользователя. (Это команда является расширенной командой - /m)
  • /m : Использовать несопровождаемый способ с вмешательством пользователя.
  • /l: Вывести список установленных хотфиксов.
  • /x: Распаковать файлы, не запуская установку.

Например, чтобы установить патч c вмешательством пользователя и не перезагружать компьютер после установки, используйте следующие команды:
q815021i /q /z

Чтобы убедится, что установка патча прошла успешно, проверьте наличие ключа реестра:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Hotfix\Q815021

Информация по удалению:

Чтобы удалить патч воспользуйтесь Установкой/Удалением Программ (Add/Remove Programs tool) в Контрольной Панели (Control Panel).

Системный администратор может использовать Spunist.exe утилиту для удаления патча. Spuninst.exe находится в

%Windir%\$NTUninstallQ815021$\Spuninst папке и поддерживает следующие команды:

  • /?: Показать все команды.
  • /u: Использовать несопровождаемый способ.
  • /f: Закрыть другие программы, когда компьютер выключается.
  • /z: Не перезагружать после того, как установка закончится.
  • /q: Использовать "Тихий способ" (без вмешательства пользователя).

Требование по перезагрузке:

Вы обязаны перезагрузить компьютер после установки или удаления патча, так как он применяется к ядру системы, которое конфигурируется на загрузке.

Файловая информация:

В английской версии этих фалов атрибуты должны быть, как указано в таблице или позже. Даты и время указаны в универсальном времени (UTC). Когда вы просматриваете файлы даты, будут представлены в локальном времени. Чтобы определить различие во времени, воспользуйтесь утилитами системы Дата и Время.

Дата Время Версия Размер Путь Имя файла
----------------------------------------------------------------------------------------
24-Mar-2003 10:38 4.0.1381.7212 367,376 %WinDir%\System32\Ntdll.dll Windows NT 4.0
24-Mar-2003 07:12 4.0.1381.33546 369,936 %WinDir%\System32\Ntdll.dll TSE

Дополнительная информация:

http://www.microsoft.com/technet/security/bulletin/MS03-007.asp

Если на вашем компьютере несколько процессоров (multiple processors), вы должны запустить Microsoft Baseline Security Analyzer (MBSA) с /nosum командой, чтобы запретить проверку checksum. Для дополнительной информации обратитесь к Microsoft Knowledge Base:

320454 Microsoft Baseline Security Analyzer (MBSA) Version 1.1 Is Available


0x00000077

Запрошенная страница ядра не может быть считана. Причина ошибки может крыться в сбойном блоке файла виртуальной памяти или ошибки контролера диска (очень редко, причиной может стать нехватка системных ресурсов, а точнее, может закончится резерв невиртуальной памяти со статусом c0000009a [STATUS_INSUFFICIENT_RESOURCES]).

Если первый и второй параметры кода ошибки равны 0, то это означает, что местоположение ошибки в ядре не найдено. А это значит, что ошибка вызвана плохим оборудованием.

Статус ввода-вывода c000009c (STATUS_DEVICE_DATA_ERROR) или C000016AL (STATUS_DISK_OPERATION_FAILED) обычно означает, что информация не может быть прочитана из-за плохого блока в памяти. После перезагрузки автоматическая проверка диска попытается определить адрес плохого блока в памяти. Если статус равен C0000185 (STATUS_IO_DEVICE_ERROR) и виртуальная память находиться на SCSI диске, то проверьте подключение и работу SCSI устройства.

Параметры:

1. ноль

2. ноль

3. значение PTE на момент ошибки

4. адрес ошибки ядра

1. код статуса

2. код статуса ввода-вывода

3. номер страницы виртуальной памяти

4. Смещение в файле подкачки

· Windows NT 2000

Решение STOP 0x00000077 и 0x0000007A сообщений.

Эти STOP сообщения относятся к невозможности Windows NT загрузить информацию о Виртуальной памяти в память или из-за проблем с оборудованием или ПО.

Возможные причины:

- Повреждённый блок на жёстком диске.
- Некорректное завершение оборудования SCSI.
- Плохое соединение жёсткого диска с контроллером.
- Ошибка контроллера жёсткого диска.
- Исчерпывание свободного места.

Значение второго восьмеричного параметра, может помочь вам выявить проблему:

Значения параметра:
0xC000009A STATUS_INSUFFICIENT_RESOURCES - исчерпание свободного места.
0xC000009C STATUS_DEVICE_DATA_ERROR - плохой блок на диске.
0xC000009D STATUS_DEVICE_NOT_CONNECTED - плохое подсоединение, некорректное завершение работы или контроллер не находит диск.
0xC000016A STATUS_DISK_OPERATION_FAILED - плохой блок на диске.
0xC0000185 STATUS_IO_DEVICE_ERROR - некорректное завершение или плохое подсоединение оборудования SCSI.

В MSDN DDK файле NTSTATUS.H есть дополнительные коды статусов.

Применяется к следующим системам:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows NT Server 3.1
  • Microsoft Windows NT Server 3.5
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 3.1
  • Microsoft Windows NT Workstation 3.5
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Advanced Server

"Stop 0x00000077" or "KERNEL_STACK_INPAGE_ERROR"

Во время работы вы можете получить следующую ошибку:

Stop 0x00000077
KERNEL_STACK_INPAGE_ERROR

Причина:

Такое может произойти, когда запрошенная страница информации ядра не может быть прочитана из виртуальной памяти, или boot record заражён вирусом. Для выявления причины стопа вы должна тщательно изучить сообщение ошибки.

Если первый и третий параметры равны нулю, тогда четыре параметра выявляются как:
1. 0 (zero)
2. Page Table Entry (PTE) значение на момент ошибки
3. 0 (zero)
4. Адрес signature ядра

Если первый или третий параметры не равны нулю, тогда четыре параметра выявляются как:
1. Код статуса
2. I/O код статуса
3. Номер страницы виртуальной памяти
4. Offset into page file

В этом случае причина может быть выявлена через второй параметр (I/O код статуса), используя следующую информацию, которая указана в "значении второго параметра" следуя за "основной причиной" формате:

0xC000009A, или STATUS_INSUFFICIENT_RESOURCES: нехватка nonpaged pool ресурсов.

0xC000009C, или STATUS_DEVICE_DATA_ERROR: плохой кластер на жёстком диске.

0xC000009D, или STATUS_DEVICE_NOT_CONNECTED: неисправный кабель, зависание, или контроллер не смог получить доступ на жёсткий диск.

0xC000016A, или STATUS_DISK_OPERATION_FAILED: плохой кластер на жёстком диске.

0xC0000185, или STATUS_IO_DEVICE_ERROR: неправильное окончание процесса или неисправный кабель SCSI-основанного оборудования, или два устройства пытались использовать одно и то же IRQ.

Решение:

Используйте один из предложенных методов для решения этой проблемы:

Вирус загрузочного сектора:

Просканируйте жёсткий диск антивирусной программой.

Не вирус:

Просмотрите Журнал событий (Event Viewer) для получения дополнительной информации, какое оборудование стало причиной ошибки.

Плохой кластер на жёстком диске. Ошибка номера 0x77 зачастую является причиной плохого кластера в месте виртуальной памяти, или ошибка контроллера диска, или в ОЧЕНЬ редких случаях, когда не хватает свободного места на диске.

Если первый и второй параметры равны нулю, то причиной является неисправное оборудование. Если I/O статус равен C0000185 и виртуальная память на SCSI жёстком диске, вы должны проверить рабочее состояние кабелей и завершение SCS.

Если I/O код статуса 0xC000009C или 0xC000016A, это обычно указывает, что информация не может быть считана с жёсткого диска из-за плохого кластера.

Если возможно перезагрузите компьютер, Autochk автоматический запуститься и попытается выявить плохие кластеры. Если по какой либо причине Autochk не просканирует диск, запустите Autochk вручную. Если диск отформатирован на NTFS, запустите Chkdsk /f /r на системной партиции. Вы должны перезагрузить компьютер до того, как сканирование начнётся. Если вы не можете загрузить компьютер из-за этой ошибки, используйте Консоль (Command Console) и запустите Chkdsk /r .

Повреждённая память - random access memory (RAM), Level 2 (L2) SRAM cache, или RAM видео адаптера - ещё одна причина этой ошибки.

Проверьте, если все карты адаптеров хорошо закреплены в слотах. Что контакты нигде не отходят.

Отключите caching в BIOS и проверьте, решит ли это проблему.

Если это не решит проблему, то повреждена материнская плата.

Примечание:

Эта ошибка схожа с STOP: 0x0000007A


0x00000218

Необходимый файл системного реестра не может загрузиться. Файл может быть поврежден или отсутствует (необходим спасательный диск или переустановка Windows). Файлы системного реестра, возможно, были разрушены из-за повреждения жесткого диска. Драйвер, возможно, разрушил данные системного реестра при загрузке в память, или память, куда системный реестр был загружен, имеет ошибку четности (выключите внешний кэш и проверьте ОЗУ).

1. Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP 64-Bit Edition

Симптомы:

Вы можете получить следующую ошибку:

Stop 0xc0000218 (0xe11a30e8, 0x00000000, 0x000000000, 0x00000000)
UNKNOWN_HARD_ERROR

или

Stop: 0xc0000218 {Registry File Failure}
The registry cannot load the hive (file):
\SystemRoot\System32\Config\SYSTEM or its log or alternate.
It is corrupt, absent, or not writable.

Параметры могут изменяться в зависимости от конфигурации системы.

Причина: поведение может наблюдаться, когда необходимая библиотека реестра повреждена или не найдена. Файлы реестра могут быть повреждены из-за повреждённого жёсткого диска или других проблем с оборудованием.

Также проблема может появиться, если драйвер повредил информацию реестра во время загрузки её в память, или когда память, в которую загружается информация реестра, повреждена (в этом случае отключите внешнюю память и проверьте чипы памяти на ошибки).

Решение:

Для решения выполните следующие шаги до тех пор, пока ошибка перестанет появляться:

1. Попытайтесь запустить компьютер в режиме Load Last Known Good Сonfiguration. Чтобы сделать это нажмите и держите пробел во время загрузки Windows до тех пор пока не появится сообщение - Load Last Known Good.

2. Восстановите файлы реестра, используя Recovery Console:

307545 How to Recover from a Corrupted Registry

Возможно, для этого вам придётся загрузиться с установочного CD Windows XP.

3. Возможно, для этого вам придётся загрузиться с установочного CD Windows XP. Выполните полную параллельную установку Windows и восстановите файл реестра, взяв его из бэкапа.

а. Переустановите Windows в отдельную папку.
б. Восстановите файл реестра, который можно найти в %SystemRoot%\System32\Config папке.
в. Если у вас нет бэкапа, свяжитесь с администратором системы. Бэкап это необходимая часть серверов, чтобы быть уверенным в их стабильности.

Примечание: если система стоит на FAT файловой системе, вы можете восстановить повреждённый файл реестра, скопировав такой же с работающей машины.

4. Возможно, для этого вам придётся загрузиться с установочного CD Windows XP. Если стоп-экран появляется из-за плохого оборудования (например, жёсткого диска, покрытого бэдами), диск, возможно, нуждается в низкоуровневом форматировании, переразбитии партиций и восстановлении системы с бэкапа.

Если причиной являются физически плохие кластеры, то используйте низкоуровневое форматирование, чтобы передвинуть их в другое место. Хотя это и радикальный метод.


0xC000021A

Это происходит, когда Windows переключился в привилегированный режим, а подсистемы непривилегированного режима, типа Winlogon или Подсистемы Времени выполнения Клиент-сервера (CSRSS), вызвали какой-либо сбой, и защиту нельзя гарантировать. Поскольку Windows XP не может работать без Winlogon или CSRSS, это - одна из немногих ситуаций, где отказ обслуживания непривилегированного режима может заставить систему прекращать отвечать. Эта также может произойти, когда компьютер перезапущен после того, как администратор системы изменил разрешения так, чтобы СИСТЕМНАЯ учетная запись больше не имела адекватные разрешения обратиться к системным файлам и папкам.

· Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

A Stop: 0xc000026C or Stop: 0xc0000221 "Unable to Load Device Driver" Error Occurs When You Start Windows XP

При загрузке вы можете получить следующие сообщения:

STOP: 0xc000026C [Unable to load device driver] DriverName

или

STOP: 0xc0000221 [Unable to load device driver] DriverName

или

STOP: 0xc0000221. Bad image check sum, the image user32.dll is possibly corrupt. The header check sum does not match the computed check sum.

Причина:

Это может случиться, когда одно из следующих высказываний верно:

  • Драйвер оборудования (.sys) не найден или повреждён.
    Пропавший или повреждённый файл скорее всего тот, который упомянут в стоп-сообщени.
  • User32.dll не найден или повреждён.

Решение:

Используйте один из предложенных методов для решения этой проблемы:

Потерянный или повреждённый драйвер.

1. Используйте Консоль Восстановления (Recovery Console)

2. Перейдите в директорию:
windows\system32\drivers (используйте команду cd)

3. Чтобы переименовать повреждённый файл напечатайте следующее и нажмите ENTER:
ren drivername.sys drivername.bak

где drivername - имя повреждённого файла.
4. Чтобы скопировать файл с Windows XP CD-ROM в папку Drivers, напечатайте следующее и нажмите ENTER:
copy cd-rom:\i386 drivername

где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Потерянный или повреждённый User32.dll файл.

Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:

1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл

2. Перейдите в директорию:
windows\system32 (используйте команду cd)

3. Переименуйте повреждённый файл (напечатайте следующее и нажмите ENTER):
ren user32.dll user32.bak

4. Распакуйте user32.dll с диска в директорию (команда expand):

expand cd-rom:\i386\user32.dl_ c:\windows\system32\user32.dll

где cd-rom - это буква диска, содержащая Windows XP CD.

5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Microsoft подтверждает, что это их проблемы =)


0xC000026C

Обычно указывает на проблемы драйвера устройства.

1. Windows XP

Применяется к следующим системам:

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition

A Stop: 0xc000026C or Stop: 0xc0000221 "Unable to Load Device Driver" Error Occurs When You Start Windows XP

При загрузке вы можете получить следующие сообщения:

STOP: 0xc000026C [Unable to load device driver] DriverName

или

STOP: 0xc0000221 [Unable to load device driver] DriverName

или

STOP: 0xc0000221. Bad image check sum, the image user32.dll is possibly corrupt. The header check sum does not match the computed check sum.

Причина:

Это может случиться, когда одно из следующих высказываний верно:

  • Драйвер оборудования (.sys) не найден или повреждён.
    Пропавший или повреждённый файл скорее всего тот, который упомянут в стоп-сообщени.
  • User32.dll не найден или повреждён.

Решение:

Используйте один из предложенных методов для решения этой проблемы:

Потерянный или повреждённый драйвер.

1.< 1000 span style='font-family:Verdana;color:#302B43'> Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл

2. Перейдите в директорию:
windows\system32\drivers (используйте команду cd)

3. Чтобы переименовать повреждённый файл напечатайте следующее и нажмите ENTER:
ren drivername.sys drivername.bak

где drivername - имя повреждённого файла.
4. Чтобы скопировать файл с Windows XP CD-ROM в папку Drivers, напечатайте следующее и нажмите ENTER:
copy cd-rom:\i386 drivername

где cd-rom - это буква диска, содержащая Windows XP CD.
5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Потерянный или повреждённый User32.dll файл.

Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл:

1. Используйте Консоль Восстановления (Recovery Console), чтобы заменить файл

2. Перейдите в директорию:
windows\system32 (используйте команду cd)

3. Переименуйте повреждённый файл (напечатайте следующее и нажмите ENTER):
ren user32.dll user32.bak

4. Распакуйте user32.dll с диска в директорию (команда expand):

expand cd-rom:\i386\user32.dl_ c:\windows\system32\user32.dll

где cd-rom - это буква диска, содержащая Windows XP CD.

5. Напечатайте exit, нажмите ENTER, перезагрузите компьютер.

Microsoft подтверждает, что это их проблемы =)


Синий экран XP

1000 Синий экран XP

Ремонт компьютеров, восстановление данных на профессиональном уровне, программное обеспечение по самостоятельному восстановлению данных.

Дата последнего обновления: 25 марта 2005 г.

Проверить аттестат

Наши партнеры:

Синий экран XP

Текст описания от автора:

"Синий экран XP (по терминологии Blue Screen of Death - "синий экран смерти", он же BSoD)- это метод генерации сообщения о фатальной ошибке в операционной системе Windows NT 4.0, Windows 2000, Windows 2003 или Windows XP, вызванной нарушениями в работе некоторых программ, чаще из-за аппаратных сбоев компьютера. Синий экран XP или по другому STOP-ошибка (от слова STOP - "останов") приводит к останову всех процессов в системе и замиранию компьютера после вывода синего экрана. Это необходимо для предотвращения возможного разрушения ядра операционной системы (самый важный компонент операционной системы, повреждение которого приводит к краху системы) и дальнейшего возможного разрушения данных на дисках. При выводе STOP-ошибки, 1000 на экране отображается код ошибки и метод ее решения, а также происходит сохранение дампа (фрагмента содержимого оперативной памяти). При этом дальнейшая работа системы полностью останавливается (или система сама собой перезагружается). Для возобновления работы системы достаточно нажать RESET на системной панели компьютера, и тем самым, перезагрузить систему. Если ошибка вызвана случайностью (например искажение пакетов данных, передаваемых по локальной сети), то об этой ошибке можно забыть. Если же ошибка постоянна и тем более если она появляется каждый раз при запуске системы, то возможной проблемой является какая-то аппаратная часть компьютера (например повреждение драйверов, файловой системы, жесткого диска, блоков памяти RAM) и необходимо разобраться с ошибкой. А именно записать на листочек бумаги первые две выводимые строки STOP-ошибки. Например:

STOP 0x000000ED(0xWWWWWWWW, 0xXXXXXXXX, 0xYYYYYYYY, 0xZZZZZZZZ)
UNMOUNTABLE_DISK_VOLUME

,где 0xWWWWWWWW, 0xXXXXXXXX, 0xYYYYYYYY, 0xZZZZZZZZ - параметры, раскрывающие смысл данной BSoD

Стандартный вид синего экрана смерти BSoD в Windows NT (слева) и Windows 2003 (справа)

Моя личная рекомендация: в системе Windows XP необходимо отключить автоматическую перезагрузку при возникновении STOP-ошибки. Иначе Вы просто не сможете прочитать текст и код STOP-ошибки. Для этого перейдите в свойства "Мой компьютер", выберите вкладку "Дополнительно". В поле "Загрузка и восстановление" нажмите кнопочку "Параметры". В появившемся окне снимите галочку напротив "Выполнить автоматическую перезагрузку"

... далее с другого рабочего компьютера выйдите в Интернет, зайдите на сайт: www.remont-pc.ru и воспользуйтесь указанной ниже таблицей узнать причину ошибки и методы ее устранения (описание STOP ошибок присутствует также в спасательных системах EMRD и ERCD - тогда Вам не понадобится даже выходить в интернет, вся информация есть уже в них). Например приведенная выше ошибка чаще говорит о том, что повреждена файловая таблица MFT или сам жесткий диск. Всегда с выводом STOP-ошибки в тексте сообщения приводится и метод ее решения на английском языке (с выпуском Windows XP произошел вообще анекдотический случай, программисты перевели все сообщения STOP-ошибок на русский язык, но забыли о руссификации видеоадаптера в момент вывода этих сообщений, из-за чего в русской Windows XP вместо текста STOP-ошибки вылетают "крякозяблики" - в Windows XP SP2 данную ошибку благополучно исправили). Некоторые STOP-ошибки, являются на самом деле ошибками самой операцион 1000 ной системы, как это ни странно. Особенно много их было в Windows NT 4.0. Система с тех пор постоянно совершенствовалась. Ошибки убирались. Но даже в современной Windows XP они не редкость. Некоторые STOP-ошибки генерируются самой Windows, чтобы, например, сообщить пользователю об окончании лицензии на систему. Но как говорилось выше, большинство STOP-ошибок возникает из-за аппаратных проблем с железом компьютера или из-за программной его части, а иногда из-за нестыковки одного с другим. Тем не менее если указанное ниже подробное описание STOP-ошибок Вам не поможет или Вам нужна эффективная помощь для устранения сбоев, обратитесь ко мне и я Вам обязательно помогу. Мой телефон в Москве (095) 741-19-41.

С уважением, Елисеев Сергей Александрович."

Код ошибки | Сообщение об ошибке | О писание
 |  | общее | по дробное
0x00000001 | APC_INDEX_MISMATCH | >> |
0x0000000A | IRQL_NOT_LESS_OR_EQUAL | >> | >>
0x0000000D | MUTEX_LEVEL_NUMBER_VIOLATION | >> |
0x0000001E | KMODE_EXCEPTION_NOT_HANDLED | >> | >>
0x00000020 | KERNEL_APC_PENDING_DURING_EXIT | >> |
0x0000002A | INCONSISTENT_IRP | >> |
0x0000002B | PANIC_STACK_SWITCH | >> |
0x0000002E | DATA_BUS_ERROR | >> |
0x00000031 | PHASE0_INITIALIZATION_FAILED | >> |
0x00000032 | PHASE1_INITIALIZATION_FAILED | >> |
0x00000035 | NO_MORE_IRP_STACK_LOCATIONS | >> |
0x00000036 | DEVICE_REFERENCE_COUNT_NOT_ZERO | >> |
0x0000003E | MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED | >> |
0x0000003F | NO_MORE_SYSTEM_PTES | >> |
0x00000040 | TARGET_MDL_TOO_SMALL | >> |
0x00000041 | MUST_SUCCEED_POOL_EMPTY | >> |
0x00000044 | MULTIPLE_IRP_COMPLETE_REQUESTS | >> |
0x00000048 | CANCEL_STATE_IN_COMPLETED_IRP | >> |
0x00000049 | PAGE_FAULT_WITH_INTERRUPTS_OFF | >> |
0x0000004C | FATAL_UNHANDLED_HARD_ERROR | >> |
0x0000004D | NO_PAGES_AVAILABLE | >> |
0x0000004E | PFN_LIST_CORRUPT | >> | >>
0x00000050 | PAGE_FAULT_IN_NONPAGED_AREA | >> | >>
0x00000051 | REGISTRY_ERROR | >> |
0x00000058 | FTDISK_INTERNAL_ERROR | >> |
0x00000067 | CONFIG_INITIALIZATION_FAILED | >> |
0x00000069 | IO1_INITIALIZATION_FAILED | >> |
0x0000006B | ROCESS1_INITIALIZATION_FAILED | >> |
0x00000071 | SESSION5_INITIALIZATION_FAILED | >> | >>
0x00000073 | CONFIG_LIST_FAILED | >> |
0x00000074 | BAD_SYSTEM_CONFIG_INFO | >> |
0x00000075 | CANNOT_WRITE_CONFIGURATION | >> |
0x00000076 | PROCESS_HAS_LOCKED_PAGES | >> |
0x00000077 | KERNEL_STACK_INPAGE_ERROR | >> | >>
0x00000079 | MISMATCHED_HAL | >> |
0x0000007A | KER 1000 NEL_DATA_INPAGE_ERROR | >> | >>
0x0000007B | INACCESSIBLE_BOOT_DEVICE | >> | >>
0x0000007D | INSTALL_MORE_MEMORY | >> |
0x0000007E | SYSTEM_THREAD_EXCEPTION_NOT_HANDLED | >> | >>
0x0000007F | UNEXPECTED_KERNEL_MODE_TRAP | >> | >>
0x0000008B | MBR_CHECKSUM_MISMATCH | >> |
0x0000008E |  | >> | >>
0x0000008F | PP0_INITIALIZATION_FAILED | >> |
0x00000090 | PP1_INITIALIZATION_FAILED | >> |
0x00000092 | UP_DRIVER_ON_MP_SYSTEM | >> |
0x00000093 | INVALID_KERNEL_HANDLE | >> |
0x00000094 | KERNEL_STACK_LOCKED_AT_EXIT | >> |
0x00000096 | INVALID_WORK_QUEUE_ITEM | >> |
0x00000097 | BOUND_IMAGE_UNSUPPORTED | >> |
0x00000098 | END_OF_NT_EVALUATION_PERIOD | >> |
0x00000099 | INVALID_REGION_OR_SEGMENT | >> |
0x0000009A | SYSTEM_LICENSE_VIOLATION | >> |
0x0000009B | UDFS_FILE_SYSTEM | >> |
0x0000009C | MACHINE_CHECK_EXCEPTION | >> | >>
0x0000009F | DRIVER_POWER_STATE_FAILURE | >> | >>
0x000000BE | ATTEMPTED_WRITE_TO_READONLY_MEMORY | >> | >>
0x000000C1 | SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION | >> | >>
0x000000C5 | DRIVER_CORRUPTED_EXPOOL | >> | >>
0x000000E3 | RESOURCE_NOT_OWNED | >> | >>
0x000000ED | UNMOUNTABLE_DISK_VOLUME | >> | >>
0xC0000218 | UNKNOWN_HARD_ERROR | >> | >>
0xC000021A | STATUS_SYSTEM_PROCESS_TERMINATED | >> | >>
0xC000026C |  | >> | >>

Краткое описание всех STOP-ошибок Вы также найдете здесь

[ Содержание ] [ Описание ошибок ]
Copyright © 1999-2005 Ambulance PC © 2003-2005 Remont-PC.ru. Все права защищены. (Автор: Елисеев Сергей Александрович). Дата последнего обновления: 25 марта 2005 г.

be number one


Описание ошибок

1000 Описание ошибок

Ремонт компьютеров, восстановление данных на профессиональном уровне, программное обеспечение по самостоятельному восстановлению данных.

Дата последнего обновления: 25 марта 2005 г.

Проверить аттестат

Наши партнеры:

APC_INDEX_MISMATCH -------------------------------- (0x00000001)

В нутренняя ошибка ядра (kernel). Ошибка может возникнуть вследствии несовпадения меток KeEnterCricticalRegion и KeLeaveCriticalRegion в файловой системе.

к общему списку ошибок "синей смерти" >>

DEVICE_QUEUE_NOT_BUSY ------------------------------- (0x00000002)

INVALID_AFFINITY_SET ------------------------------------ (0x00000003)

INVALID_DATA_ACCESS_TRAP --------------------------- (0x00000004)

INVALID_PROCESS_ATTACH_ATTEMPT ------------------ (0x00000005)

INVALID_PROCESS_DETACH_ATTEMPT ------------------ (0x00000006)

INVALID_SOFTWARE_INTERRUPT ------------------------- (0x00000007)

IRQL_NOT_DISPATCH_LEVEL ------------------------------ (0x00000008)

IRQL_NOT_ 1000 GREATER_OR_EQUAL ------------------------- (0x00000009)

IRQL_NOT_LESS_OR_EQUAL --------------------------- (0x0000000A)

Была сделана попытка затронуть виртуальную память на внутреннем процессе IRQ уровня высокого уровня. Если доступен kernel debugger, вы можете проследить, где именно система зациклилась.

Наиболее частая причина возникновения - драйвер устройства использует неверный адрес.

Параметры:

1 - адрес, по которому выполнено ошибочное обращение
2 - IRQL, который использовался для обращения к памяти
3 - тип доступа к памяти: 0 = операция чтения, 1 = операция записи
4 - адрес инструкции, которая затребовала доступ к памяти по адресу

Прим: Имейте ввиду, что эта ошибка возникает в 99% из-за плохих драйверов. Некоторые из них в Windows XP вы можете обнаружить используя утилиту verifier.exe: Start (Пуск) -> Run (Выполнить) -> verifier.exe

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

NO_EXCEPTION_HANDLING_SUPPORT -------------------- (0x0000000B)

MAXIMUM_WAIT_OBJECTS_EXCEEDED ------------------- (0x0000000C)

MUTEX_LEVEL_NUMBER_VIOLATION ------------------- (0x0000000D)

Попробуйте установить взаимоисключения используя библиотеку NTOS\EX\EXLEVELS.H файла заголовков. Попробуйте найти точки взаимодействия и определить, какие из них пытаются получить доступ к этому уровню в неверной последовательности.

Параметры:

1 - настоящая нить уровня взаимодействия
2 - уровень взаимодействия пытающаяся получить доступ

к общему списку ошибок "синей смерти" >>

NO_USER_MODE_CONTEXT -------------------------------- (0x0000000E)

SPIN_LOCK_ALREADY_OWNED ---------------------------- (0x0000000F)

SPIN_LOCK_NOT_OWNED ---------------------------------- (0x00000010)

THREAD_NOT_MUTEX_OWNER ----------------------------- (0x00000011)

TRAP_CAUSE_UNKNOWN ----------------------------------- (0x00000012)

EMPTY_THREAD_REAPER_LIST ----------------------------- (0x00000013)

CREATE_DELETE_LOCK_NOT_LOCKED -------------------- (0x00000014)

LAST_CHANCE_CALLED_FROM_KMODE ------------------- (0x00000015)

CID_HANDLE_CREATION ----------------------------------- (0x00000016)

CID_HANDLE_DELETION ------------------------------------ (0x00000017)

REFERENCE_BY_POINTER ----------------------------------- (0x00000018)

BAD_POOL_HEADER ----------------------------------------- (0x00000019)

MEMORY_MANAGEMENT ----------------------------- 1000 -------- (0x0000001A)

PFN_SHARE_COUNT ------------------------------------------ (0x0000001B)

PFN_REFERENCE_COUNT ------------------------------------ (0x0000001C)

NO_SPIN_LOCK_AVAILABLE -------------------------------- (0x0000001D)

KMODE_EXCEPTION_NOT_HANDLED ------------------- (0x0000001E)

Это очень часто встречающаяся ошибка. Обычно исключённый адрес указывает на драйвер или функцию, которая вызвала стоп-экран. Всегда обращайте внимание не только на указанный драйвер, но и на сам адрес или имидж, содержащий эту ошибку. Обычно это код исключения 0x80000003. Эта ошибка означает, что точка прерывания или обработчик инициализировался при обращении к памяти, но система загрузилась с /NODEBUG ключа. Это ошибка не должна появляться слишком часто. Если ошибка появляется постоянно, убедитесь, что отладчик (debugger) подключён и система загружается с /DEBUG ключа.

На не-Intel системах, если адрес исключения - 0XBFC0304, ошибка возникает вследствие кэширования процессора. Если ошибка появляется постоянно, свяжитесь с производителем.

Как правило, требуется анализ второго параметра этого сообщения, который указывает на адрес драйвера/функции, которая была причиной проблемы.

Параметры:

1 - код исключительной ситуации
2 - адрес, при обработке которого произошел сбой
3 - Параметр 0 - исключение
4 - Параметр 1 - исключение

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

SHARED_RESOURCE_CONV_ERROR ----------------------- (0x0000001F)

KERNEL_APC_PENDING_DURING_EXIT ----------------- (0x00000020)

Название ошибки указывает на повреждённый/отключённый APC счётчик. Если счётчик показывает значение не равное нулю, то он и есть источник проблемы. Отрицательное значение указывает на то, что файловая система вызывала FsRtlEnterFileSystem большее количество раз чем FsRtlExitFileSystem. Положительное значение указывает наоборот FsRtlExitFileSystem было вызвано большее количество раз чем FsRtlEnterFileSystem. Если у вас такая ситуация, проверьте все файловые системы установленные на машине, используя спасательные комплекты EMRD или ERCD (используя команду "3").

Текущий IRQL должен быть равен нулю. Если IRQ не равен нулю, то определённый порядок выгрузки драйверов, при возвращении на более высокий уровень IRQ, может стать причиной возникновения ошибки. Попытайтесь запомнить, что вы делали или какие приложения закрывали, какие драйвера были установлены на момент возникновения синего экран 1000 а. Этот симптом указывает на серьёзную проблему в драйверах сторонних разработчиков.

Параметры:

1 - адрес APC, на момент сбоя.
2 - Сбойная нить APC
3 - текущий IRQ уровень

к общему списку ошибок "синей смерти" >>

QUOTA_UNDERFLOW ---------------------------------------- (0x00000021)

FILE_SYSTEM ------------------------------------------------- (0x00000022)

FAT_FILE_SYSTEM ------------------------------------------- (0x00000023)

NTFS_FILE_SYSTEM ------------------------------------------ (0x00000024)

NPFS_FILE_SYSTEM ------------------------------------------ (0x00000025)

CDFS_FILE_SYSTEM ----------------------------------------- (0x00000026)

RDR_FILE_SYSTEM ------------------------------------------- (0x00000027)

CORRUPT_ACCESS_TOKEN --------------------------------- (0x00000028)

SECURITY_SYSTEM ------------------------------------------ (0x00000029)

INCONSISTENT_IRP -------------------------------------- (0x0000002A)

IRP неожиданно был обнаружен в нерабочем режиме; возникает, когда поле или несколько полей неверны по сравнению с сохранившемся состоянием IRP. Например, IRP был уже отключен, когда драйвера какого-либо устройства ждал команды.

Параметры:

1 - адрес по которому IRP был найден в нерабочем режиме

к общему списку ошибок "синей смерти" >>

PANIC_STACK_SWITCH ---------------------------------- (0x0000002B)

Эта ошибка возникает, когда область стека ядра переполнена. Ошибка происходит, когда драйвер ядра использует слишком много места в области стека. Возможной причиной ошибки также может быть повреждение самого ядра.

к общему списку ошибок "синей смерти" >>

PORT_DRIVER_INTERNAL ----------------------------------- (0x0000002C)

SCSI_DISK_DRIVER_INTERNAL ---------------------------- (0x0000002D)

DATA_BUS_ERROR ---------------------------------------- (0x0000002E)

Данная STOP-ошибка чаще всего возникает из-за сбоя в области ОЗУ. Такое может случиться, когда драйвер пытается обратиться к адресу памяти, которого не существует.

Параметры:

1 - адрес виртуальной памяти, который стал причиной ошибки

2 - физический адрес причины ошибки

3 - регистрация статуса процессора (PSR)

4 - регистрация инструкции ошибки (FIR)

к общему списку ошибок "синей смерти" >>

INSTRUCTION_BUS_ERROR ---------------------------------- (0x0000002F)

SET_OF_INVALID_CONTEXT ---------------------------------- (0x00000030)

PHASE0_INITIALIZATION_FAILED ------------------------ (0x00000031)

Инициализацию системы не удалось завершить на ранней стадии (фаза 0). Нужно более детально изучить ошибку, так как данный код ошибки не говорит практический ни о чём.

к общему списку ошибок "синей смерти" >>

UNEXPECTED_INITIALIZATION_CALL ------------------------ (0x00000033)

CACHE_MANAGER ---------------------------------------------- (0x00000034)

PHASE1_INITIALIZATION_FAILED ------------------------ (0x00000032)

Инициализацию системы не удалось завершить на поздней стадии (фаза 1). Нужно более детально изучить ошибку, так как данный код ошибки не говорит практический ни о чём.

Параметры:

1 - код уровня системы, который описывает, по какой причине система считает, что инициализация не завершена

2 - указывает место внутри INIT.C, где произошла ошибка инициализации фазы 1

к общему списку ошибок "синей смерти" >>

NO_MORE_IRP_STACK_LOCATIONS ---------------------- (0x00000035)

Драйвер высокого уровня пытался вызвать драйвер низкого уровня через интерфейс IoCallDriver(), но у системы не было свободного места в области стека, по этой причине драйвер низкого уровня не достигнет нужных параметров, так как для него вообще нет никаких параметров. Это фатальная ситуация, так как драйвер высокого уровня считает, что заполнил параметры для драйвера низкого уровня (что-то он должен был сделать, чтобы вызвать драйвер низкого уровня). Тем не менее, так как для драйвера низкого уровня нет свободного места в области стека, был затерт конец пакета. Это часто возникает из-за повреждения блоков памяти стека.

Параметры:

1 - адрес IRP

к общему списку ошибок "синей смерти" >>

DEVICE_REFERENCE_COUNT_NOT_ZERO --------------- (0x00000036)

Драйвер устройства пытался удалить из системы один из компонентов своего устройства, но счётчик обращений этого компонента не был равен нулю - это означает, что за данным компонентом находятся какие-то невыполненные задачи (счётчик указывает код ошибки, из-за чего данный компонент не может быть выгружен). Это ошибка вызова драйвера.

Параметры:

1 - адрес объекта

к общему списку ошибок "синей смерти" >>

FLOPPY_INTERNAL_ERROR ------------------------------------ (0x00000037)

SERIAL_DRIVER_INTERNAL ----------------------------------- (0x00000038)

SYSTEM_EXIT_OWNED_MUTEX ------------------------------- (0x00000039)

SYSTEM_UNWIND_PREVIOUS_USER ------------------------- (0x0000003A)

SYSTEM_SERVICE_EXCEPTION ------------------------------- (0x0000003B)

INTERRUPT_UNWIND_ATTEMPTED --------------------------- (0x0000003C)

INTERRUPT_EXCEPTION_NOT_HANDLED -------------------- (0x0000003D)

MULTIPROCESSOR_CONFIGURATION_NOT_SUPPORTED (0x0000003E)

Мультипроцессорная система не симметрична по отношению друг к другу. Для правильной симметричности, процессоры должны быть одного типа и уровня. Например, попытка использовать процессор уровня Pentium и 80486 одновременно, вызовет ошибку. Кроме того, на х86 системах, возможность вычислений с плавающей точкой должны быть либо на всех процессорах, либо ни на одном.

к общему списку ошибок "синей смерти" >>

NO_MORE_SYSTEM_PTES ---------------------------------- (0x0000003F)

Не хватает РТЕ (page file entries - точек доступа к файлу подкачки). Обычно причиной является драйвер, который плохо очищает файл подкачки (swap) и он переполняется. Если отладчик ядра (kernel debugger) Вам доступен, проследите, где система зациклилась и введите следующую команду:

!sysptes 3

к общему списку ошибок "синей смерти" >>

TARGET_MDL_TOO_SMALL -------------------------------- (0x00000040)

Драйвер вызвал функцию IoBuildPartialMdl() и передал ему MDL, чтобы выявить часть источника MDL, но область получателя MDL не достаточно большая, для того, чтобы отобразить пределы требуемых адресов. Это ошибка драйвера.

к общему списку ошибок "синей смерти" >>

MUST_SUCCEED_POOL_EMPTY --------------------------- (0x00000041)

Если отладчик ядра (kernel debugger) доступен, команда Виртуальной Машины (VM) показывает различные величины:

Параметры:

1 - величина запроса к файлу подкачки, котор ую невозможно было выполнить

2 - номера страниц, которые были использованы из виртуальной памяти

3 - номера слишком больших страниц, запрашиваемых из виртуальной памяти

4 - номера доступных страниц

к общему списку ошибок "синей смерти" >>

ATDISK_DRIVER_INTERNAL ------------------------------------ (0x00000042)

NO_SUCH_PARTITION ------------------------------------------- (0x00000043)

MULTIPLE_IRP_COMPLETE_REQUESTS --------------------- (0x00000044)

Драйвер запросил завершение IRP [IoCompleteRequest()], но пакет был уже завершён. Эту ошибку сложно выявить. Возможная причина - драйвер пытается завершить одну и ту же операцию дважды. Редкая причина - 2 различных драйвера пытаются завладеть пакетом и завершить его. Первый как правило срабатывает, а второй нет. Отследить, какой именно драйвер это сделал, трудно, так как следы первого драйвера были переписаны вторым. Тем не менее, конфликт может быть выявлен, при рассмотрении DeviceObject поля, в каждой секции стека.

Параметры:

1 - адрес IRP

к общему списку ошибок "синей смерти" >>

INSUFFICIENT_SYSTEM_MAP_REGS ----------------------------- (0x00000045)

DEREF_UNKNOWN_LOGON_SESSION ---------------------------- (0x00000046)

REF_UNKNOWN_LOGON_SESSION ------------------------------- (0x00000047)

CANCEL_STATE_IN_COMPLETED_IRP ------------------------ (0x00000048)

Эта ошибка указывает, что I/O Request Packet (IRP), который должен быть завершён, имеет 1000 порядок отмены определённый в нём же, т.е. это означает, что пакет в таком режиме, может быть отменен. Тем не менее, пакет не относиться более к драйверу, так как он уже вошёл в стадию завершения.

к общему списку ошибок "синей смерти" >>

PAGE_FAULT_WITH_INTERRUPTS_OFF ------------------------ (0x00000049)

Ошибка буквально означает: страничная ошибка при обращении к памяти, при выключенных прерываниях IRQ. Описание ошибки такое же, как и у 0x0000000A.

к общему списку ошибок "синей смерти" >>

IRQL_GT_ZERO_AT_SYSTEM_SERVICE --------------------------- (0x0000004A)

STREAMS_INTERNAL_ERROR -------------------------------------- (0x0000004B)

FATAL_UNHANDLED_HARD_ERROR ---------------------------- (0x0000004C)

Если данное исключение появится во время загрузки системы, загрузка прервётся синим экраном.

Наиболее частые причины:

x218 - необходимая библиотека реестра не может быть загружена. Этот файл может отсутствовать или повреждён. Чтобы решить эту проблему, вам понадобится спасательная дискета EMRD или диск ERCD , с помощью которого необходимо восстановить реестр и провести диагностику жесткого диска.

У д райвера мог быть повреждён ключ реестра в момент его загрузки в память, или память, в которую происходила загрузка данного ключа. Но бывают и исключения, касаемые особенно AST EISA машин с 16М ОЗУ и выше, там необходимо включить доступ к памяти выше 16М, т.е. в утилите конфигурации EISA параметр доступа к памяти должен быть ENABLED (разрешён). Иначе файл, который загрузится в память, при чтении покажет - 0xffffffff

x21A - или Winlogon или CSRSS (Windows) внезапно отказали. Код возврата может сказать больше об ошибке. Обычно это - c0000005, который говорит о том, что неподдерживаемое исключение отказало в том или ином процессе. Требуется детальный анализ ситуации.

x221 - означает, что драйвер повреждён или системная библиотека была распознана, как повреждённая. Система делает всё для того, чтобы проверить целостность важных системных файлов. Синий экран показыва 1000 ет имя повреждённого файла. Если такое случилось, загрузитесь в любую другую систему или, если таковых нет, переустановите систему... Убедитесь, что версия файла, который был выявлен, как повреждённый, совпадает с версией файла в дистрибутиве системы и если так, то замените его с диска. Постоянные ошибки с разными именами файлов, говорят о том, что есть проблемы с носителями информации или с контроллером диска, где располагаются эти файлы.

к общему списку ошибок "синей смерти" >>

NO_PAGES_AVAILABLE ---------------------------------------- (0x0000004D)

Нет больше свободных страниц, чтобы закончить операцию. Если отладчик (kernel debugger) доступен, печатайте следующие команды:

!process 0 7
!vm
dd mmpagingfiles
dd @$p

Параметры:

1 - количество использованных страниц
2 - количество физических страниц на машине
3 - расширенное значение величины страниц
4 - Общее значение величины страниц

к общему списку ошибок "синей смерти" >>

PFN_LIST_CORRUPT ------------------------------------------- (0x0000004E)

Причина - повреждённая/неисправная структура ввода-вывода драйвера.

Параметры:

1. значение 1

2. значение ListHead, которое повреждено

3. число доступных страниц

4. ноль

1. значение 2

2. данные, которые удаляются

3. максимальное число физических страниц

4. итог удаляемых данных

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

NDIS_INTERNAL_ERROR ------------------------------------------ (0x0000004F)

PAGE_FAULT_IN_NONPAGED_AREA -------------------------- (0x00000050)

Возникает, когда запрошенная информация не была найдена в памяти. Система проверяет файл подкачки (page file), но отсутствующая информация была обозначена, как невозможная для записи в файл подкачки (page file).

Если это случилось на Terminal Server, проверьте драйвера третьей стороны для принтера.

Параметры:

1. указывает на адрес в памяти, который допустил ошибку

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

REGISTRY_ERROR --------------------------------------------- (0x00000051)

Что-то случилось с реестром. Если отладчик (kernel debugger) доступен, отследите ошибку. Если он вам покажет, что вы в ветке системы (CmpWorker будет присутствовать в перечне), введите следующие команды:

dd CmpRegistryMutex+18 L1
!thread <whatever value the above command printed out>

Эти команды покажут Вам ветвь и место ошибки, куда именно шло последнее обращение в реестр.

Эта ошибка так же может означать, что произошла ошибка ввода-вывода с реестром, когда система попыталась прочитать один из его файлов, отсюда следует, что ошибка могла быть вызвана проблемой с оборудованием или что сама система повреждена. Это так же может означать, что ошибка вызвана операцией обновления, которую использует только система безопасности и эта ошибка возникает, когда ресурсы на исходе. Если такая ошибка возникла, проверьте, является ли машина PDC или BDC и сколько аккаунтов в базе данных SAM (Менеджер Безопасности Аккаунтов), не заполнены ли соответствующие библиотеки почти до конца.

Параметры:

1. значение 1 (указывает, где появилась ошибка)

2. значение 2 (указывает, где появилась ошибка)

3. может указывать на библиотеку

4. может быть возвратным кодом HvCheckHive'а, если какая-либо библиотека повреждена

к общему списку ошибок "синей смерти" >>

MAILSLOT_FILE_SYSTEM ----------------------------------------- (0x00000052)

NO_BOOT_DEVICE ------------------------------------------------ (0x00000053)

LM_SERVER_INTERNAL_ERROR ---------------------------------- (0x00000054)

DATA_COHERENCY_EXCEPTION --------------------------------- (0x00000055)

INSTRUCTION_COHERENCY_EXCEPTION ----------------------- (0x00000056)

XNS_INTERNAL_ERROR ------------------------------------------- (0x00000057)

FTDISK_INTERNAL_ERROR ------------------------------------ (0x00000058)

Система загрузилась с восстановленного первичного раздела, в следствии чего библиотеки сообщают, что зеркало в порядке, но на самом деле это не так. Настоящие образы библиотек оттенены. Вам нужно загрузиться именно с них.

к общему списку ошибок "синей смерти" >>

PINBALL_FILE_SYSTEM ------------------------------------------- (0x00000059)

CRITICAL_SERVICE_FAILED ------------------------------------- (0x0000005A)

SET_ENV_VAR_FAILED ------------------------------------------- (0x0000005B)

HAL_INITIALIZATION_FAILED ----------------------------------- (0x0000005C)

HEAP_INITIALIZATION_FAILED ---------------------------------- (0x0000005D)

OBJECT_INITIALIZATION_FAILED ------------------------------- (0x0000005E)

SECURITY_INITIALIZATION_FAILED ---------------------------- (0x0000005F)

PROCESS_INITIALIZATION_FAILED ----------------------------- (0x00000060)

HAL1_INITIALIZATION_FAILED ---------------------------------- (0x00000061)

OBJECT1_INITIALIZATION_FAILED ------------------------------ (0x00000062)

SECURITY1_INITIALIZATION_FAILED --------------------------- (0x00000063)

SYMBOLIC_INITIALIZATION_FAILED ---------------------------- (0x00000064)

MEMORY1_INITIALIZATION_FAILED ----------------------------- (0x00000065)

CACHE_INITIALIZATION_FAILED -------------------------------- (0x00000066)

CONFIG_INITIALIZATION_FAILED --------------------------- (0x00000067)

Ошибка о значает, что реестр не может выделить место, необходимое для работы файлов реестра. Эта ошибка никогда не может появиться, так как процесс резервирования такого места происходит на ранней стадии загрузки системы и для реестра выделяется достаточно места.

Параметры:

1. пять

2. Указывает на NTOS\CONFIG\CMSYSINI, который потерпел неудачу.

к общему списку ошибок "синей смерти" >>

FILE_INITIALIZATION_FAILED ----------------------------------- (0x00000068)

IO1_INITIALIZATION_FAILED -------------------------------- (0x00000069)

Не удалось инициализировать устройство ввода-вывода по неизвестной причине. Такое могло случиться, если установка приняла неправильное решение в процессе инсталляции системы, или пользователь неверно переконфигурировал систему.

к общему списку ошибок "синей смерти" >>

LPC_INITIALIZATION_FAILED ------------------------------------ (0x0000006A)

PROCESS1_INITIALIZATION_FAILED ------------------------ (0x0000006B)

Параметры:

1. сообщает на код процесса, который решил, что инициализация системы не прошла успешно.

2. сообщает на место в NTOS\PS\PSINIT.C, где ошибка была обнаружена.

к общему списку ошибок "синей смерти" >>

REFMON_INITIALIZATION_FAILED ------------------------------- (0x0000006C)

SESSION1_INITIALIZATION_FAILED ---------------------------- (0x0000006D)

SESSION2_INITIALIZATION_FAILED ---------------------------- (0x0000006E)

SESSION3_INITIALIZATION_FAILED ---------------------------- (0x0000006F)

SESSION4_INITIALIZATION_FAILED ---------------------------- (0x00000070)

SESSION5_INITIALIZATION_FAILED ------------------------ (0x00000071)

Это коды кодов (SESSION1 - SESSION5) указывают место в NTOS\INIT\INIT.C, где была допущена ошибка.

Параметры:

1. сообщает код сессии, которая решила, что инициализация системы не прошла успешно.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

ASSIGN_DRIVE_LETTERS_FAILED ------------------------------- (0x00000072)

CONFIG_LIST_FAILED ----------------------------------------- (0x00000073)

Указывает, что одна из системных библиотек повреждена или не читаема. Эта библиотека может быть следующих типов: SOFTWARE, SECURITY, SAM (Менеджер Безопасности Аккаунтов).

Параметры:

1. пять

2. два

3. список библиотек

4. указывает UNICODE_STRING, содержащее имя библиотеки

к общему списку ошибок "синей смерти" >>

BAD_SYSTEM_CONFIG_INFO --------------------------------- (0x00000074)

Эта ошибка может возникнуть в результате того, что библиотека SYSTEM, загружаемая OSLOADER/NTLDR, повреждена. Тем не менее, это практически невозможно, так как OSLOADER всегда проверяет библиотеки после загрузки и убеждается, что они не повреждены.

Эта ошибка так же может означать, что некоторые требуемые ключи реестра и их параметры отсутствуют. Загрузка в LastKnownGood (Последней удачной конфигурации) возможно решит эту проблему. Но не исключено, что вам придётся переустанавливать систему, или использовать спасательный диск.

к общему списку ошибок "синей смерти" >>

CANNOT_WRITE_CONFIG 1000 URATION -------------------------- (0x00000075)

Эта ошибка может возникнуть, когда файлы системной библиотеки (SYSTEM и SYSTEM.ALT) не могут разместить дополнительные данные в момент инициализациями реестра и первой фазы (когда файловые системы становятся доступными). Эта ошибка обычно означает, что на диске нет свободного места, так же это может произойти при попытке сохранить реестр на устройстве "только чтение".

к общему списку ошибок "синей смерти" >>

PROCESS_HAS_LOCKED_PAGES ----------------------------- (0x00000076)

Э та ошибка может возникнуть по причине драйвера, который не полностью выгрузился после операции ввода-вывода.

Параметры:

1. адрес процесса

2. число закрытых страниц

3. число зарезервированных страниц

4. ноль

к общему списку ошибок "синей смерти" >>

KERNEL_STACK_INPAGE_ERROR ----------------------------- (0x00000077)

Запрошенная страница ядра не может быть считана. Причина ошибки может крыться в сбойном блоке файла виртуальной памяти или ошибки контролера диска (очень редко, причиной может стать нехватка системных ресурсов, а точнее, может закончится резерв невиртуальной памяти со статусом c0000009a [STATUS_INSUFFICIENT_RESOURCES]).

Если первый и второй параметры кода ошибки равны 0, то это означает, что местоположение ошибки в ядре не найдено. А это значит, что ошибка вызвана плохим оборудованием.

С татус ввода-вывода c000009c (STATUS_DEVICE_DATA_ERROR) или C000016AL (STATUS_DISK_OPERATION_FAILED) обычно означает, что информация не может быть прочитана из-за плохого блока в памяти. После перезагрузки автоматическая проверка диска попытается определить адрес плохого блока в памяти. Если статус равен C0000185 (STATUS_IO_DEVICE_ERROR) и виртуальная память находиться на SCSI диске, то проверьте подключение и работу SCSI устройства.

Параметры:

1. ноль

2. ноль

3. значение PTE на момент ошибки

4. адрес ошибки ядра

1. код статуса

2. код статуса ввода-вывода

3. номер страницы виртуальной памяти

4. Смещение в файле подкачки

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

PHASE0_EXCEPTION --------------------------------------------- (0x00000078)

MISMATCHED_HAL -------------------------------------------- (0x00000079)

Уровень проверки HAL и тип конфигурации HAL не подходят ядру системы или типу машины. Такая ошибка, скорее всего, вызвана тем, что пользователь вручную обновил либо NTOSKRNL.EXE либо HAL.DLL. Или на машине мультипроцессорный HAL (MP) и юнипроцессорное ядро (UP), или наоборот.

Параметры:

1. тип несовпадения (1, 2 или 3):

1. несовпадение уровней выпуска PRCB (несовпадение дат). Если дело в этом, то параметры 2 и 3:

2 - больший уровень NTOSKRNL.EXE

3 - больший уровень HAL.DLL

2. несовпадение типов бильдов, в этом случае параметры 2 и 3:

2 - тип сборки NTOSKRNL.EXE

3 - тип сборки HAL.DLL

типы сборки:

0 - свободный мультипроцессорный режим компоновки

1 - отмеченная, как допускаемая мультипроцессорный режим компоновка

2 - свободная однопроцессорная компоновка

3. Компьютерам с микроканальной архитектурой (MCA) требуется поддержка MCA-спецификации HAL, в этом случае параметры 2 и 3:

2 - тип машины, определённый NTDETECT.COM

значение 2 означает, что компьютер - MCA

3 - тип машин, которые этот HAL поддерживает

значение 2 означает, что этот HAL сделан для MCA

к общему списку ошибок "синей смерти" >>

KERNEL_DATA_INPAGE_ERROR ------------------------------ (0x0000007A)

Не может быть прочтена запрашиваемая ядром страница. Ошибка вызвана плохим блоком в памяти или ошибкой контроллера диска. См. так же KERNEL_STACK_INPAGE_ERROR.

Параметры:

1. тип зависшей блокировки

2. статус ошибки (обычно код ввода-вывода)

3. текущий процесс (виртуальный адрес для блокировки типа 3 или PTE)

4. адрес виртуальной памяти, который не может быть перемещен в файл подкачки

Больше информации о данной ошибке >>

< 1000 a href="blue_screen_xp.htm">к общему списку ошибок "синей смерти" >>

INACCESSIBLE_BOOT_DEVICE ------------------------------ (0x0000007B)

В процессе инсталляции I/O системы, драйвер загрузочного устройства, возможно, не смог инициализировать устройство, с которого система пыталась загрузиться, или файловая система, которая должна была прочитать это устройство, либо не смогла инициализироваться, либо просто не распознала информацию на устройстве, как структуру файловой системы. В вышеупомянутом случае, первый аргумент - это адрес уникодовой структуры информации, которая является ARC именем устройства, с которого была попытка загрузиться. Во втором случае, первый аргумент - это адрес объекта устройства, которое не может быть смонтировано.

Если эта ошибка возникла при начальной инсталляции системы, возможно система была установлена на диск или SCSI контроллер, которые ею не поддерживается. Имейте в виду, что некоторые контроллеры поддерживаются только драйверами из Windows-библиотек (WDL), которые должны быть установлены в режиме выборочной установкой.

Эта ошибка так же может произойти после установки нового SCSI адаптера или контроллера или после изменения системных разделов. В этом случае, на x86 системах, нужно отредактировать BOOT.INI; на ARC системах, нужно запустить Setup.

Если аргумент указывает на строковый параметр ARC, формат первых двух (это только в этом случае) длинных слов будет:

USHORT Length;
USHORT MaximumLength;
PVOID Buffer;

Например, если первое длинное слово содержит что-то типа 00800020, где 20 длина Уникодового стринга (Unicode string), следующее длинное слово будет содержать адрес буфера.

Если аргумент указывает на объект устройства, формат первого слова будет:

USHORT Type;

Значит, первое слово содержит 0003, где тип всегда будет 0003.

Примечание:

Вы сразу сможете опознать, указывает ли аргумент на ARC имя или на объект устройства, так как уникодовая строка (Unicode string) никогда не содержит нечётное число байтов, а объект устройства всегда будет содержать тип кода - 3.

Параметры:

1. указатель на объект устройства или уникодовая строка (Unicode string), или ARC имя.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

BUGCODE_PSS_MESSAGE ---------------------------------------- (0x0000007C)

INSTALL_MORE_MEMORY -------------------------------------- (0x0000007D)

Не хватает памяти, чтобы загрузить Windows NT (необходимо 5 MB)

Параметры:

1. номер найденных физических страниц

2. нижняя физическа 1000 я страница

3. верхняя физическая страница

4. ноль

к общему списку ошибок "синей смерти" >>

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED ---------------------------(0x4000007E)

Проблема с оборудованием или обнаружена нехватка свободного места на диске.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

UNEXPECTED_KERNEL_MODE_TRAP ------------------------- (0x0000007F)

Эта ошибка означает, что произошло непредвиденное исключение в режиме ядра, или прерывания, при котором ядро не срабатывает. Также причиной ошибки может стать прерывание, которое повлекло за собой немедленную смерть в виде двойной ошибки - double fault. Первое число в коде ошибки - число прерывания (8 = double fault). Чтобы узнать больше, что это за прерывание, обратитесь к мануалу семейства Intel x86.

Короче говоря, ошибка появляется, когда процессор допускает ошибку, с которой ядро не может справиться. Чаще всего ошибка возникает из-за плохих блоков ОЗУ, а иногда из-за разгона процессора.

Попробуйте отменить в BIOS функцию синхронной передачи данных.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

NMI_HARDWARE_FAILURE ------------------------------------ (0x00000080)

HAL должен сообщить всю конкретную информацию, которую имеет, и предложить пользователю обратиться к поставщику оборудования за техподдержкой.

к общему списку ошибок "синей смерти" >>

SPIN_LOCK_INIT_FAILURE --------------------------------------- (0x00000081)

SETUP_FAILURE ------------------------------------------------ (0x00000085)

Ошибка возникает при загрузке установщика системы (Примеча 1000 ние: текстовая форма setup'a больше не использует процедуру поиска ошибок (bugcheck), для того чтобы не создавать серьезных помех при установке. Поэтому вы никогда не столкнётесь с данной ошибкой. Все проверки ошибок были заменены на более дружелюбные и (где возможно) более информативные сообщения об ошибках. Тем не менее я хочу Вам рассказать, при каких обстоятельствах в ранних версиях Windows генерировалась данная STOP-ошибкой и как теперь она отображается.

1-

0: Недействительный формат файла *.fon, из-за чего установщик не смог отобразить текст. Это означает, что файл vgaxxx.fon на компакт-диске или дискете повреждён.

1: Не произошла инициализация видео. Эта ошибка имеет собственный экран и пользователю предоставляется на выбор 2 варианта.

Это означает, что файл vga.sys (или другой драйвер, в зависимости от машины) повреждён, или то, что не поддерживается данное оборудование.

2 - что разрушено:
0: NtCreateFile of \device\video0
1: IOCTL_VIDEO_QUERY_NUM_AVAIL_MODES
2: IOCTL_VIDEO_QUERY_AVAIL_MODES
3: Желаемый режим видео не поддерживается. Внутренняя ошибка установщика.
4: IOCTL_VIDEO_SET_CURRENT_MODE (невозможно установить режим видео)
5: IOCTL_VIDEO_MAP_VIDEO_MEMORY
6: IOCTL_VIDEO_LOAD_AND_SET_FONT

3 - код состояния NT вызова API, если есть подходящий

2: Нехватка памяти. Теперь эта ошибка использует более дружественный экран, в зависимости от того, как далеко прошла установка.

3: Инициализация клавиатуры не удалась. Теперь используются 2 разных экрана в зависимости от ошибок, которые тут могли появиться. Это может означать, что диск, содержащий драйвера для клавиатуры (i8042prt.sys или kbdclass.sys) повреждён или машина имеет не поддерживаемую клавиатуру.

Так же это может означать, что динамическая библиотека для переключения раскладок клавиатуры не может быть загружена.

2 - что разрушено:
0: NtCreateFile of \device\KeyboardClass0 .
"Установщик не обнаружил клавиатуру, подключённую к вашему компьютеру."
1: Unable to load keyboard layout dll.
"Установщик не может загрузить динамическую библиотеку для переключения раскладок клавиатуры <имя файла>."
Это значит, что компакт-диск или дискета не имеют файла библиотеки (kbdus.dll для us или других dll).

4: Установщик не смог выявить компонент ARC: путь устройства, с которого он был запущен. Это внутренняя ошибка установщика.

5: Система не прошла проверку на наличие и корректность разделов диска (MBR). Ошибка находится в драйвере диска.

к общему списку ошибок "синей смерти" >>

MBR_CHECKSUM_MISMATCH --------------------------------- (0x0000008B)

Эта ошибка возникает в процессе загрузки, когда контрольная сумма MBR, которую посчитала система, не совпадает с контрольной суммой загрузчика. Обычно это означает вирус. Некоторые вирусы не могут быть определены/найдены. Загрузитесь с дискеты с вирус-сканером (убедитесь, что дискета защищена от записи!)

KerBugCheckEx параметры:

1 - Сигнатура диска в MBR
2 - Контрольная сумма MBR, записанная в osloader
3 - Контрольная сумма MBR, записанная в системе

к общему списку ошибок "синей смерти" >>

0x0000008E

Несовместимость или неисправность блоков памяти RAM.

Ошибка возможна в следующих системах:

  1. Microsoft Windows XP Professional
  2. Microsoft Windows XP Home Edition
  3. Microsoft Windows XP Professional SP1
  4. Microsoft Windows XP Home Edition SP1

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

---------------------------------------------------------------------------------------

Следующие STOP-ошибки были добавлены производителем в Windows NT версий 3.51 и 4.x:

---------------------------------------------------------------------------------------

PP0_INITIALIZATION_FAILED -------------------------------- (0x0000008F)

Это сообщение появляется, если инициализация фазы 0 менеджера Plug and Play не прошла на стадии инициализации ядра (kernel-mode Plug and Play Manager failed). Нет ничего такого, что могло спровоцировать эту ошибку.

к общему списку ошибок "синей смерти" >>

PP1_INITIALIZATION_FAILED --------------------------------- (0x00000090)

Это сообщение появляется, если инициализация фазы 1 менеджера Plug and Play не прошла на стадии инициализации ядра (kernel-mode Plug and Play Manager failed). Вот здесь происходят практически все процессы инициализации, включая конфигурацию среды (реестр и т.д.), драйверов устройств вв 1000 ода-вывода и т.д. Нет ничего такого, что могло спровоцировать эту ошибку.

к общему списку ошибок "синей смерти" >>

---------------------------------------------------------------------------------------

Следующие STOP-ошибки были добавлены производителем в Windows NT 4.0:

---------------------------------------------------------------------------------------

UP_DRIVER_ON_MP_SYSTEM ---------------------------------- (0x00000092)

Эта ошибка возникает только тогда, когда однопроцессорный драйвер загружается в системе, где присутствует более чем один активный процессор.

KeBugCheckEx параметры:

1 - Базовый адрес однопроцессорного драйвера

к общему списку ошибок "синей смерти" >>

INVALID_KERNEL_HANDLE ------------------------------------- (0x00000093)

Эта ошибка появляется, когда код ядра (kernel code) или другие критические компоненты ОС пытаются закрыть дескриптор, который не является действительным.

Параметры:

1 - Вызванный дескриптор NtClose

2 - 0 означает, что был закрыт защищенный дескриптор
1 означает, что был закрыт неправильный дескриптор

к общему списку ошибок "синей смерти" >>

KERNEL_STACK_LOCKED_AT_EXIT --------------------------- (0x00000094)

Это сообщение появляется, когда нить существует, в то время как её стек помечен, как блокированный.

к общему списку ошибок "синей смерти" >>

INVALID_WORK_QUEUE_ITEM -------------------------------- (0x00000096)

Это сообщение появляется, когда KeRemoveQueue удаляет очередь данных, в то время, как flink или blink поле равно 0. Это практически всегда происходит из за неправильного применения кода работающей нити текущего объекта, но неправильное применение любой очереди также может привести к этой ошибки. Правило - ввод данных в очередь может быть произведено только однажды. Когда нить удаляется из очереди, его flink поле равно 0. Эта ошибка возникает, когда происходит попытка удалить данные, flink или blink поля которых равны 0. Для того, чтобы разрешить эту ошибку, вам необходимо выяснить очередь, на которую он ссылается. Если эта очередь одна из ЕХ работающих очередей (ExWorkerQueue), тогда объект, который удаляется - WORK_QUEUE_ITEM. Эта ошибка подразумевает, что это и есть причина. Параметры ошибки помогают выявить драйвер, который неправильно использует очередь.

к общему списку ошибок "синей смерти" >>

BOUND_IMAGE_UNSUPPORTED ------------------------------- (0x00000097)

MmLoadSystemImage была вызван для того, чтобы загрузить связанное изображение. Эта функция не поддерживается ядром.

KeBugCheckEx параметры:

1 - Адрес данных в очереди, flink/blink поле которых ноль.
2 - Адрес на ссылающуюся очередь. Обычно это одна из ExWorkerQueues очередей.
3 - Начальный адрес ExWorkerQueue массива. Это поможет определить, является ли рассматриваемая очередь ExWorkerQueue и если так, то смещение от этого параметра изолирует очередь.
4 - Если это ExWorkerQueue очередь (как это бывает обычно), это адрес работающей процедуры, которая бы вызывалась, если работающий элемент был бы действительным. Это может быть использовано, чтобы выявить драйвер, который неправильно использует рабочую очередь.

к общему списку ошибок "синей смерти" >>

END_OF_NT_EVALUATION_PERIOD -------------------------- (0x00000098)

Ваша Windows система - триальная версия с ограниченной датой, которая подошла к концу.

KeBugCheckEx параметры:

1 - Дата инсталляции (нижние 32-бита)
2 - Дата инсталляции (верхние 32-бита)
3 - Триал период в минутах.

к общему списку ошибок "синей смерти" >>

INVALID_REGION_OR_SEGMENT ----------------------------- (0x00000099)

ExInitializeRegion или ExInterlockedExtendRegion были вызваны с неправильным набором параметров.

к общему списку ошибок "синей смерти" >>

SYSTEM_LICENSE_VIOLATION -------------------------------- (x0000009A)

Произошло н арушение программного лицензионного соглашения. Э 1000 то может быть или из-за попытки изменить тип продукта системы, или попытки изменить срок триального периода ОС.

UDFS_FILE_SYSTEM -------------------------------------------- (0x0000009B)

Смотрите комментарии к FAT_FILE_SYSTEM

к общему списку ошибок "синей смерти" >>

MACHINE_CHECK_EXCEPTION ------------------------------- (0x0000009C)

Фатальная ошибка Machine Check Exception (проверка машины).

KeBugCheckEx параметры:

Если процессор имеет ТОЛЬКО MCE функции доступными (например: Intel Pentium), то параметры будут:

1 - Low 32 bits of P5_MC_TYPE MSR
2 -
3 - High 32 bits of P5_MC_ADDR MSR
4 - Low 32 bits of P5_MC_ADDR MSR

Если процессор имеет также MCA функции доступными (например: Intel Pentium Pro), то параметры будут:

1 - Bank number
2 - Address field of MCi_ADDR MSR for the MCA bank that had the error
3 - High 32 bits of MCi_STATUS MSR for the MCA bank that had the error
4 - Low 32 bits of MCi_STATUS MSR for the MCA bank that had the error

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

---------------------------------------------------------------------------------------

Следующие STOP-ошибки были добавлены производителем в Windows 2000 и Winows XP (за исключением трехзначных кодов ошибок) :

---------------------------------------------------------------------------------------

0x0000009F: DRIVER_POWER_STATE_FAILURE

Драйвер находится в противоречивом или недопустимом состоянии потребления энергии. Обычно это происходит из за сбоев в питании, при перезагрузке, выходе из спящего режима и т.д.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0x000000A0: INTERNAL_POWER_ERROR
0x000000A1: PCI_BUS_DRIVER_INTERNAL
0x000000A2: MEMORY_IMAGE_CURRUPT
0x000000A3: ACPI_DRIVER_INTERNAL
0x000000A4: CNSS_FILE_SYSTEM_FILTER

0x000000A5: ACPI_BIOS_ERROR

Причиной данного сообщения являются постоянные сбои в ACPI BIOS. На уровне операционной системы данную проблему решить нельзя. Необходим детальный анализ.

к общему списку ошибок "синей смерти" >>

0x000000A7: BAD_EXHANDLE
0x000000AB: SESSION_HAS_VALID_POOL_ON_EXIT
0x000000AC: HAL_MEMORY_ALLOCATION

0x000000B4: VIDEO_DRIVER_INIT_FAILURE

Windows не смог загрузить драйвер видеокарты. Проблема в основном связана с драйверами видео, либо произошел аппаратный конфлика с платой видео. Перезагрузитесь в безопасном режиме и смените драйвер видео на стандартный.

к общему списку ошибок "синей смерти" >>

0x000000B8: ATTEMPTED_SWITCH_FROM_DPC
0x000000B9: CHIPSET_DETECTED_ERROR
0x000000BA: SESSION_HAS_VALID_VIEWS_ON_EXIT
0x000000BB: NETWORK_BOOT_INITIALIZATION_FAILED
0x000000BC: NETWORK_BOOT_DUPLICATE_ADDRESS

0x000000BE: ATTEMPTED_WRITE_TO_READONLY_MEMORY

Драйвер попытался записать данные в постоянное запоминающее устройство (ПЗУ), что невозможно. Проблема в основном связана с установкой плохого драйвера устройства, службы или програмно-аппаратного обеспечения. Попробуйте отключить данный сбойный компонент.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0x000000BF: MUTEX_ALREADY_OWNED

0x000000C1: SPECIAL_POOL_DETECTED_MEMORY_CORRUPTION

Драйвер записал данные в недопустимую секцию памяти. Смените драйвер!

Больше информации ->

к общему списку ошибок "синей смерти" >>

0x000000C2: BAD_POOL_CALLER

Ядро системы или драйвер дали неправильную команду обращения к памяти. Как правило, плохой драйвер или программное обеспечение вызвало эту ошибку.

к общему списку ошибок "синей смерти" >>

0x000000C4: DRIVER_VERIFIER_DETECTED_VIOLATION

Программа проверки драйвера обнаружила фатальную ошибку в модуле генерации STOP-ошибки. Сопр 1000 оводительные параметры - параметры, которые передаются в KeBugCheckEx и отображается на синем экране.

к общему списку ошибок "синей смерти" >>

0x000000C5: DRIVER_CORRUPTED_EXPOOL

П роизошла попытка обращения из недопустимой области памяти в процесс IRQL высокого уровня. Эта ошибка возникает почти всегда из-за драйверов, которые разрушили системный пул. Если Вы недавно установили новое программное обеспечение, выясните, правильно ли Вы его установили. Проверьте также наличие новых драйверов на узле веб-изготовителя.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0x000000C6: DRIVER_CAUGHT_MODIFYING_FREED_POOL

Драйвер попытался обратиться к освобожденному пулу памяти. Замените драйвер.

к общему списку ошибок "синей смерти" >>

0x000000C7: TIMER_OR_DPC_INVALID

Таймер ядра или Delayed Procedure Call (DPC) присутствует в запрещенном участке памяти. Данная ошибка возникает, когда драйвер не смог завершить работу таймера ядра или Delayed Procedure Call (DPC) перед отгрузкой его из памяти.

к общему списку ошибок "синей смерти" >>

0x000000C8: IRQL_UNEXPECTED_VALUE

0x000000C9: DRIVER_VERIFIER_IOMANAGER_VIOLATION

Это сообщение от одного из менеджеров проверки драйвера. Смените драйвер!

к общему списку ошибок "синей смерти" >>

0x000000CA: PNP_DETECTED_FATAL_ERROR

0x000000CB: DRIVER_LEFT_LOCKED_PAGES_IN_PROCESS

Ошибка, сходная со STOP-ошибкой 0x00000076. Отличается от последней только тем, что в данном случае ошибка выявлена при трассировке ядра. Ошибка указывает на то, что драйвер или менеджер ввода - вывода не могут открыть 1000 блокированные страницы после операции ввода - вывода. Обратите внимание на название прикладного драйвера в окне STOP-ошибке.

к общему списку ошибок "синей смерти" >>

0x000000CC: PAGE_FAULT_IN_FREED_SPECIAL_POOL
0x000000CD: PAGE_FAULT_BEYOND_END_OF_ALLOCATION

0x000000CE: DRIVER_UNLOADED_WITHOUT_CANCELLING_PENDING_OPERATIONS

Драйвер не может отменить зависшее состояние компонентов системы. Ошибка обычно происходит после установки плохих драйверов или компонентов сервиса.

к общему списку ошибок "синей смерти" >>

0x000000CF: TERMINAL_SERVER_DRIVER_MADE_INCORRECT_MEMORY_REFERENCE
0x000000D0: DRIVER_CORRUPTED_MMPOOL

0x000000D1: DRIVER_IRQL_NOT_LESS_OR_EQUAL

Система попыталась обратиться к страничной памяти, используя процесс ядра через IRQL высокого уровня. Самая типичная причина - плохой драйвер устройства. Это может также быть вызвано поврежденной оперативной памятью, или поврежденным файлом подкачки.

к общему списку ошибок "синей смерти" >>

0x000000D2: BUGCODE_ID_DRIVER
0x000000D3: DRIVER_PORTION_MUST_BE_NONPAGED
0x000000D4: SYSTEM_SCAN_AT_RAISED_IRQL_CAUGHT_IMPROPER_DRIVER_UNLOAD
0x000000D5: DRIVER_PAGE_FAULT_IN_FREED_SPECIAL_POOL
0x000000D6: DRIVER_PAGE_FAULT_BEYOND_END_OF_ALLOCATION
0x000000D7: DRIVER_UNMAPPING_INVALID_VIEW

0x000000D8: DRIVER_USED_EXCESSIVE_PTES
Ошибка происходит, когда драйвер запрашивает большое количество памяти ядра.

к общему списку ошибок "синей смерти" >>

0x000000D9: MUTEX_ALREADY_OWNED
0x000000DA: SYSTEM_PTE_MISUSE
0x000000DB: DRIVER_CORRUPTED_SYSPTES
0x000000DC: DRIVER_INVALID_STACK_ACCESS
0x000000DE: POOL_CORRUPTION_IN_FILE_AREA
0x000000DF: IMPERSONATING_WORKER_THREAD
0x000000E0: ACPI_BIOS_FATAL_ERROR
0x000000E1: WORKER_THREAD_RETURNED_AT_BAD_IRQL
0x000000E2: MANUALLY_INITIATED_CRASH

0x000000E3: RESOURCE_NOT_OWNED
Различные сбои, связанные с файловой системой, выдают данную STOP-ошибку.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0x000000E4: WORKER_INVALID
0x000000E6: DRIVER_VERIFIER_DMA_VIOLATION
0x000000E7: INVALID_FLOATING_POINT_STATE
0x000000E8: INVALID_CANCEL_OF_FILE_OPEN
0x000000E9: ACTIVE_EX_WORKER_THREAD_TERMINATION

0x000000EA: THREAD_STUCK_IN_DEVICE_DRIVER

Проблемный драйвер устройства ввел систему в состояние зависания. Как правило, это вызвано драйвером дисплея, при попытке перехода компьютера в ждущий режим. Данная проблема связана с видеоадаптером, или плохим видео драйвером.

к общему списку ошибок "синей смерти" >>

0x000000EB: DIRTY_MAPPED_PAGES_CONGESTION
0x000000EB: SESSION_HAS_VALID_SPECIAL_POOL_ON_EXIT

0x000000ED: UNMOUNTABLE_BOOT_VOLUME
Подсистема ввода - вывода привилегированного режима попыталась подключить загрузочный том, и потерпела неудачу. Эта ошибка также может произойти в процессе обновления, когда система начала использовать более производительные ATA диски или контроллеры с неправильным конфигурированием. Часто это ошибка появляется после некорректного завершения работы Windows. Для ее устранения воспользуйтесь EMRD или ERCD и в меню выберите третий режим (коррекция NTFS).

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0x000000EF: CRITICAL_PROCESS_DIED
0x000000F1: SCSI_VERIFIER_DETECTED_VIOLATION

0x000000F2: HARDWARE_INTERRUPT_STORM

Это сообщение появляется, если ядро обнаруживает шторм прерывания, то есть, когда вызванное уровнем-прерыванием устройство не в состоянии выдавать запрос на прерывание. Обычно, это вызвано плохим драйвером устройства.

к общему списку ошибок "синей смерти" >>

0x000000F3: DISORDERLY_SHUTDOWN

Завершение Windows потерпело крах из-за недостатка памяти. Определите, какая программа попала "за пределы памяти", попробуйте обнаружить, почему виртуальная память не обеспечивает нужными системными ресурсами, и исследуйте, отказывается ли программа (или, иногда, драйвер) завершать свою работу, без освобождения открытых страниц в памяти.

к общему списку ошибок "синей смерти" >>

0x000000F4: CRITICAL_OBJECT_TERMINATION
0x000000F6: PCI_VERIFIER_DETECTED_VIOLATION
0x000000F7: DRIVER_OVERRAN_STACK_BUFFER
0x000000F8: RAMDISK_BOOT_INITIALIZATION_FAILED
0x000000F9: DRIVER_RETURNED_STATUS_REPARSE_FOR_VOLUME_OPEN

0x1000007E: SYSTEM_THREAD_EXCEPTION_NOT_HANDLED_M

См. 0x000000 7E

к общему 1000 списку ошибок "синей смерти" >>

0x1000007F: UNEXPECTED_KERNEL_MODE_TRAP_M

0x1000008E: KERNEL_MODE_EXCEPTION_NOT_HANDLED_M

См. 0x0000008 E

к общему списку ошибок "синей смерти" >>

0x100000EA: THREAD_STUCK_IN_DEVICE_DRIVER_M

0xC000009A: STATUS_INSUFFICIENT_RESOURCES

Системное ядро операционной системы исчерпало все системные ресурсы для своей работы, в том числе и файл подкачки. Проверьте диск на наличие ошибок. Увеличьте объем жесткого диска и объем оперативной памяти.

к общему списку ошибок "синей смерти" >>

0xC0000135: UNABLE TO LOCATE DLL

Windows попытался загрузить DLL библиотеку и получил код ошибки. Возможная причина - файл отсутствует или поврежден. Возможно также поврежден системный реестр.

к общему списку ошибок "синей смерти" >>

0xC0000142: DLL Initialization Failure

Данная ошибка была вызвана повреждением системной DLL библиотеки.

к общему списку ошибок "синей смерти" >>

0xC0000218: UNKNOWN_HARD_ERROR

Необходимый файл системного реестра не может загрузиться. Файл может быть поврежден или отсутствует (необходим спасательный диск или переустановка Windows). Файлы системного реестра, возможно, были разрушены из-за повреждения жесткого диска. Драйвер, возможно, разрушил данные системного реестра при загрузке в память, или память, куда системный реестр был загружен, имеет ошибку четности (выключите внешний кэш и проверьте ОЗУ).

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0xC000021A: STATUS_SYSTEM_PROCESS_TERMINATED

Это происходит, когда Windows переключился в привилегированный режим, а подсистемы непривилегированного режима, типа Winlogon или Подсистемы Времени выполнения Клиент-сервера (CSRSS), вызвали какой-либо сбой, и защиту нельзя гар 1000 антировать. Поскольку Windows XP не может работать без Winlogon или CSRSS, это - одна из немногих ситуаций, где отказ обслуживания непривилегированного режима может заставить систему прекращать отвечать. Эта также может произойти, когда компьютер перезапущен после того, как администратор системы изменил разрешения так, чтобы СИСТЕМНАЯ учетная запись больше не имела адекватные разрешения обратиться к системным файлам и папкам.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0xC0000221: STATUS_IMAGE_CHECKSUM_MISMATCH

Указывает на проблемы драйвера, проблемы системного файла, дисковые проблемы, искаженние (например поврежденный файл подкачки), или повреждение ОЗУ или диска.

к общему списку ошибок "синей смерти" >>

0xC0000244

STOP-ошибка происходит, когда Ваша политика аудита активирует параметр CrashOnAuditFail (действительно для Windows XP)

к общему списку ошибок "синей смерти" >>

0xC000026C

Обычно указывает на проблемы драйвера устройства.

Больше информации о данной ошибке >>

к общему списку ошибок "синей смерти" >>

0xDEADDEAD: MANUALLY_INITIATED_CRASH1

"It’s dead, Jim!” (Это мертвый, Джим!) Эта STOP-ошибка указывает на то, что пользователь преднамеренно инициализировал аварийный отказ, либо от отладчика ядра, либо от клавиатуры.

к общему списку ошибок "синей смерти" >>

[ Содержание ] [ Наверх ]
Copyright © 1999-2005 Ambulance PC © 2003-2005 Remont-PC.ru. Все права защищены. (Автор: Елисеев Сергей Александрович). Дата последнего обновления: 25 марта 2005 г.

be number one


Компьютерная помощь

1000 Компьютерная помощь

Ремонт компьютеров, восстановление данных на профессиональном уровне, программное обеспечение по самостоятельному восстановлению данных.

Дата последнего обновления: 25 марта 2005 г.

Синий экран XP

Проверить аттестат

Наши партнеры:

Remont-PC.ru уже более пяти лет работает на рынке услуг, сопутствующих компьютеру и Интернет. На сайте Вы сможете найти всю необходимую информацию, касательно выявления ошибок и ремонта компьютеров. Здесь Вы найдете информацию и программное обеспечение как по самостоятельному восстановлению данных, так и возможность связаться с мастером по горячей линии для выявления и устранения проблем. На сайте имеется следующая информация:

  • Информативная часть
    • Файловые системы (полное описание всех ныне существующих файловых систем)
    • Синий экран XP (описание и методы устранения фатальных ошибок в ОС Windows XP, а также в NT и 2000)
  • Ремонт компьютеров и восстановление данных (программное обеспечение)
    • Комплект спасательных дискет EMRD 2005 - версия 1.03 от 16 марта 2005 года
    • Спасательный компакт диск ERCD 1.1 - версия 1.1 от 20 марта 2005 года
    • Сайт поддержки зарегистрированных пользователей
  • Лаборатория и скорая компьютерная помощь Remont-PC.ru (служба ремонта и сервиса)
    • Лаборатория восстановления данных
    • Скорая компьютерная помощь

Важная информация. С 25 марта возобновлена работа почтовой системы remont-pc.ru. Те письма, которые отсылались в течении марта на любой из ящиков ...@remont-pc.ru, просьба заново отослать. Проблема возникла по вине провайдера и сейчас полностью устранена. Хочу заметить, что теперь функционируют только три почтовых ящика. Их адреса остались прежние, подробнее здесь >> .

Важная информация. Версия 1.03, вышедшая в свет 16 марта является законченной версией EMRD 2005. Предыдущая версия 1.02 от 10 января 2005 года была предварительной версией, имеющая ряд недоработок, использовалась только для тестирования новой среды FreeDos с компонентами EMRD и широкого распространения не получила. Всем зарегистрированным пользователям, которые приобрели EMRD версии 1.02 в период с января по март 2005 года, новая версия 1.03 передается бесплатно. Остальные зарегистрированные пользователи оплачивают регистрацию за EMRD как обычно с 50% скидкой.

[ Содержание ] [ Файловые системы ] [ Синий экран XP ] [ Спасат. 5fe дискеты ] [ Спасательный CD ] [ Поддержка ] [ Услуги мастера ] [ Лаборатория ] [ Связь ]
Copyright © 1999-2005 Ambulance PC © 2003-2005 Remont-PC.ru. Все права защищены. (Автор: Елисеев Сергей Александрович). Дата последнего обновления: 25 марта 2005 г.

be number one