InsidePro - Passwords recovery and encryption

[Russian]

PasswordsPro

Important! This program may be used for recovery of your own forgotten passwords and is only to work with your own passwords!

  • Introduction
    1. Program description
    2. System requirements

  • Working with the program
    1. Password generator
    2. Dictionary generator
    3. MD4 hashes password recovery
    4. MD5 hashes password recovery
    5. MySQL hashes password recovery
    6. SHA-1 hashes password recovery
    7. Hidden password recovery
    8. General information

  • Use of the program
    1. Status of the program
    2. License agreement

  • About the program
    1. Download the latest version
    2. Technical support

Program description

The program PasswordsPro is to work with the passwords of the user and has a row of tools to recover and generate passwords.

System requirements

To work correctly the program requires:

  • OS Windows 95/98/ME/NT4/2000/XP/2003.
  • Any processor of the x86 line not less than Intel Pentium (or AMD K6-II), the MMX support is necessary.

Password generator

Description:

Password generator is to generate random passwords of requested length and will be useful for the administrators of the local nets or for other specialists who maintain large amount of computers.

Features:

  • Simultaneous generating of several different passwords.
  • Exporting gained passwords to the file to work with in the future.
  • Copying of any generated password to clipboard.
  • Editing of any generated password.

Limitations:

  • Maximal length of the password to generate is 128 characters.
  • Maximal quantity of the passwords to be simultaneously generated is 128.
Dictionary generator

Description:

Dictionary generator is to generate files (dictionaries) which contain passwords with set characters and parameters. This tool will be useful for work with brute-forcers and will let to use "Dictionary attack" more effectively.

Features:

  • Choice of characters to generate passwords for the dictionary.
  • Set minimal and maximal length of passwords.
  • Set initial character combination to generate similar passwords.

Limitations:

  • Maximal length of password to generate is 128 symbols.
  • Maximal dictionary size is 1 Terabyte.
MD4 hashes password recovery

Description:

This tool is to recover passwords for hashes encoded by the MD4 algorithm.
(Full description of the MD4 algorithm you can find in the document RFC1320).
Speed of attack of passwords encrypted by MD4 with different processors:

Processor | Attack speed
Intel Pentium-III 1000 MHz | ~3,4 millions passwords/sec
AMD AthlonXP 1700+ (1466 MHz) | ~5,3 millions passwords/sec
Intel Pentium-4 2500 MHz | ~5,4 millions passwords/sec

Initial data format:

To import hashes program uses the following universal format of lines in the textual file:

User name (or hash name):Hash:

But user name (hash name) isn't necessary. Hashes' lines examples:

Hash1:8BE1EC697B14AD3A53B371436120641D:
Hash2:114C5A33B8D4127FBE492BD6583AEB4D:
:8BE1EC697B14AD3A53B371436120641D:
Hash number one:8BE1EC697B14AD3A53B371436120641D:
In the program archive you may find test file with hashes MD4_Hashes.txt to analyze the work of the program.

Features:

  • Recovery of passwords, encrypted by MD4 algorithm, using the following methods:
    1. Brute-force attack.
    2. Mask attack.
    3. Dictionary attack (including hybrid attack).
    4. Distributed attack.
  • Checking of the password on all imported hashes.
  • Generation of the MD4 hash using known password.
  • Import of hashes not only from the textual file but also from the dialogue window.
  • Data export.

Limitations:

  • Maximal length of password to recover using brute-force attack and mask attack is 32 characters.
  • Maximal length of password to recover using dictionary attack is 128 characters.
  • Maximal length of password in the textual field "Password:" is 255 characters.
  • Maximal quantity of hashes to work with is 8192.
MD5 hashes password recovery

Description:

This tool is to recover passwords for hashes encoded by the MD5 algorithm.
(Full description of the MD5 algorithm you can find in the document RFC1321).
Speed of attack of passwords encrypted by MD5 with different processors:

Processor | Attack speed
Intel Pentium-III 1000 MHz | ~2,2 millions passwords/sec
AMD AthlonXP 1700+ (1466 MHz) | ~3,6 millions passwords/sec
Intel Pentium-4 2400 MHz | ~4,0 millions passwords/sec

Initial data format:

To import hashes program uses the following universal format of lines in the textual file:

User name (or hash name):Hash:

But user name (hash name) isn't necessary. Hashes' lines examples:

Hash1:C4CA4238A0B923820DCC509A6F75849B:
Hash2:C20AD4D76FE97759AA27A0C99BFF6710:
:202CB962AC59075B964B07152D234B70:
Hash number one:202CB962AC59075B964B07152D234B70:

The program also supports import of hashes of OS Unix format, i.e. MD5-hashes of the following kind:

Hash1:$1$12345678$XM4P3PrKBgKNnTaqG9P0T/:
Hash2:$1$12345678$eamrTZEOkK4vufehLXOhK0:
:$1$12345678$XM4P3PrKBgKNnTaqG9P0T/:
Hash number one:$1$12345678$eamrTZEOkK4vufehLXOhK0:

The program also supports import of hashes of APR (Apache Portable Runtime) format, i.e. MD5-hashes of the following kind:

Hash1::$apr1$12345678$auQSX8Mvzt.tdBi4y6Xgj.:
:$apr1$12345678$fOL3K5IECyUkOyDNiStbI0:

To analyze work you may find test file with standard MD5-hashes (MD5_Hashes.txt), textual file with MD5-hashes of Unix format (MD5-Unix_Hashes.txt) and textual file with MD5-hashes in APR format (MD5-APR_Hashes.txt) in the program archive.

The program also lets to recover passwords for RAdmin v2.x program encoded by MD5 algorithm. The encryption method is the following: if we have "123" password (for instance), it is to be extended by nulls up to certain length (100 symbols in RAdmin program), so MD5 algorithm processes not the 3-byte password "123", but 100-byte one started by "123" line.
For that purpose this tool has additional settings for recovery of such passwords, and there's also MD5-RAdmin_v2.x_Hashes.txt file in the archive to analyze program working on such MD5 hashes.

Features:

  • Recovery of passwords, encrypted by MD5 algorithm, using the following methods:
    1. Brute-force attack.
    2. Mask attack.
    3. Dictionary attack (including hybrid attack).
    4. Distributed attack.
  • Checking of the password on all imported hashes.
  • Generation of the MD5 hash using known password.
  • Adding of hashes not only from the textual file but also from the dialogue window.
  • Data export.

Limitations:

  • Maximal length of password to recover using brute-force attack and mask attack is 32 characters.
  • Maximal length of password to recover using dictionary attack is 128 characters.
  • Maximal length of password in the textual field "Password:" is 255 characters.
  • Maximal quantity of hashes to work with is 8192.
MySQL hashes password recovery

Description:

This tool is for the password recovery for hashes got during the encryption of the passwords in the MySQL databases.
Speed of attack of passwords encrypted by MD5 with different processors:

Processor | Attack speed
AMD AthlonXP 1700+ (1466 MHz) | ~8,3 millions passwords/sec
Intel Pentium-4 2400 MHz | ~10,0 millions passwords/sec

Initial data format:

To import hashes program uses the following universal format of lines in the textual file:

User name (or hash name):Hash:

But user name (hash name) isn't necessary. Hashes' lines examples:

Hash1:606717496665BCBA:
Hash2:077042FB4932B5B5:
:773359240EB9A1D9:
Hash number one:446A12100C856CE9:
In the program archive you may find test file with hashes MySQL_Hashes.txt to analyze the work of the program.

Features:

  • Recovery of passwords, encrypted by MySQL algorithm, using the following methods:
    1. Brute-force attack.
    2. Mask attack.
    3. Dictionary attack (including hybrid attack).
    4. Distributed attack.
  • Checking of the password on all imported hashes.
  • Generation of the MySQL hash using known password.
  • Adding of hashes not only from the textual file but also from the dialogue window.
  • Data export.

Limitations:

  • Maximal length of password to recover using brute-force attack and mask attack is 32 characters.
  • Maximal length of password to recover using dictionary attack is 128 characters.
  • Maximal length of password in the textual field "Password:" is 255 characters.
  • Maximal quantity of hashes to work with is 8192.

Note:

To increase attack speed this tool uses different password increment than other tools have. So password increment goes the next way:
AAAAAAA
AAAAAAB
AAAAAAC
...

Note, other tools use another way of password increment:
AAAAAAA
BAAAAAA
CAAAAAA
...

SHA-1 hashes password recovery

Description:

This tool is to recover passwords for hashes encoded by the SHA-1 algorithm.

Initial data format:

To import hashes program uses the following universal format of lines in the textual file:

User name (or hash name):Hash:

But user name (hash name) isn't necessary. Hashes' lines examples:

Hash1:356A192B7913B04C54574D18C28D46E6395428AB:
:356A192B7913B04C54574D18C28D46E6395428AB:
Hash number one:356A192B7913B04C54574D18C28D46E6395428AB:
In the program archive you may find test file with hashes SHA-1_Hashes.txt to analyze the work of the program.

Features:

  • Recovery of passwords, encrypted by SHA-1 algorithm, using the following methods:
    1. Brute-force attack.
    2. Mask attack.
    3. Dictionary attack (including hybrid attack).
    4. Distributed attack.
  • Checking of the password on all imported hashes.
  • Generation of the SHA-1 hash using known password.
  • Adding of hashes not only from the textual file but also from the dialogue window.
  • Data export.

Limitations:

  • Maximal length of password to recover using brute-force attack and mask attack is 32 characters.
  • Maximal length of password to recover using dictionary attack is 128 characters.
  • Maximal length of password in the textual field "Password:" is 255 characters.
  • Maximal quantity of hashes to work with is 8192.
Hidden password recovery

Description:

This tool is to recover the passwords hidden by asterisks in the following objects: standard Windows textual field to enter the passwords (EditBox), TEdit, TDBEdit and TMaskEdit, and works under all Windows operational systems from Windows 95 up to Windows 2003.

Features:

  • Replacing display of the asterisks by the password display, and additional displaying of this password in the program.
  • Displaying of the class of the window where the text had been recovered.
General information
  • The program supports "hidden mode" (key combination Ctrl+Alt+H), when it disappears from the display and from the Taskbar. To get back from the hidden mode use the same key combination.

  • The program supports multilingual interface due to Language-files use. PasswordsPro includes to menu the list of all Language-files found in the work directory. After choose of different language of the program interface quit the program and run it again.

  • All program password attack tools display the speed of the password' attack as: N * X p/s, where N is quantity of users (or hashes) being worked on at the moment, and X is speed of attack for each user (or hash).

  • Brute-force attack settings (common for all tools) let to choose character sets for the attack and to set maximal and minimal length of the passwords to recover.

  • Mask attack settings (common for all tools) let to shape mask for the passwords being recovered and to set maximal length of the password to recover. Mask setting carries the following: if you don't know the N-character in the password, set N-flag of the mask and in the textual field accordingly set the mask for this character.
    The program uses the following masks:
    ? - Any printable symbol (symbols codes: 32...255).
    A - Any Latin capital (A...Z).
    a - Any Latin small (a...z).
    N - Any digit (0...9).
    S - Any special symbol (!@#...).
    X - Any symbol from the user's character set.
    If you already know one of the characters in the password, type it in the N-field and remove the mask flag.

  • In the passwords recovery tools in the program all found passwords are recorded in the file PasswordsPro.dic which is being automatically created in the program folder.

  • There's also ability to set priority of password checking procedures. Use menu "Options" -> "Priority" to choose on of three types of priority - normal, low, or lowest.
Status of the program

Current version of the program PasswordsPro is distributed as Freeware so no pay for use is requested.

License Agreement
  1. All rights for the program PasswordsPro and its' components are reserved by its author - InsidePro.

  2. The unchanged copy of the program may be distributed with no limits. You may place the original distributive on your site or any disks (CD-ROM, etc.) without any notification of the developers.

  3. You may not modify, disassembly and decompile this software. The breach of any of these clauses automatically makes this license invalid.

  4. PasswordsPro is supplied "AS IS". No guaranties provided or implied. You use this program on your own risk. Author isn't liable for any data damages, or lost profit, or any else harm, caused by your use or non-use of this program. Author guarantees that the program doesn't contain harmful codes or any other code for performing actions but ones said in the program description.

  5. PasswordsPro use means this agreement accept.

  6. If you don't accept this agreement, please, remove files of PasswordsPro from your computer and stop the program use.
Technical support

Feel free to ask a question about the program, inform us about an error in it or suggest you ideas about the program development and improvement, using one of the following ways:

  • E-mail the support service: Support@InsidePro.com.
  • Contact the author of the program by ICQ: 285429551.
  • Leave your message in the Guestbook of the program site.


InsidePro - Passwords recovery and encryption

[English]

PasswordsPro

Внимание! Данная программа может использоваться исключительно для восстановления своих собственных забытых паролей и предназначена для работы только со своими собственными паролями!

  • Введение
    1. Описание программы
    2. Системные требования

  • Работа с программой
    1. Генератор паролей
    2. Генератор словарей
    3. Восстановление паролей к MD4-хэшам
    4. Восстановление паролей к MD5-хэшам
    5. Восстановление паролей к MySQL-хэшам
    6. Восстановление паролей к SHA-1-хэшам
    7. Восстановление паролей под звездочками
    8. Общая информация

  • Использование программы
    1. Статус программы
    2. Лицензионное соглашение

  • О программе
    1. Скачать последнюю версию
    2. Техническая поддержка

Описание программы

Программа PasswordsPro предназначена для работы с паролями пользователей компьютера и содержит для этого ряд инструментов для восстановления паролей и их генерации.

Системные требования

Для работы программы требуются:

  • ОC Windows 95/98/ME/NT4/2000/XP/2003.
  • Любой процессор линейки x86 не ниже Intel Pentium (или AMD K6-II), обязательно с поддержкой MMX.

Генератор паролей

Описание:

Генератор паролей предназначен для генерации случайных паролей нужной длины и будет полезен администраторам локальных сетей или же иным специалистам, обслуживающим большое количество компьютеров.

Возможности:

  • Одновременная генерация нескольких различных паролей.
  • Сохранение полученных паролей в файл для последующей работы с ними.
  • Копирование любого сгенерированного пароля в Буфер обмена.
  • Редактирование любого сгенерированного пароля.

Ограничения:

  • Максимальная длина генерируемого пароля - 128 символов.
  • Максимальное количество одновременно генерируемых паролей - 128.
Генератор словарей

Описание:

Генератор словарей предназначен для генерации файлов (словарей), содержащих пароли из заданных символов и с заданными параметрами. Данный инструмент будет полезен при работе с программами для перебора паролей и позволит более производительно использовать такой вид атаки как "Атака по словарю".

Возможности:

  • Выбор символов для генерируемых паролей в словаре.
  • Установка минимальной и максимальной длины генерируемых паролей в словаре.
  • Установка начальной комбинации символов, что позволит генерировать похожие пароли.

Ограничения:

  • Максимальная длина генерируемых паролей - 128 символов.
  • Максимальный объем словаря - 1 Терабайт.
Восстановление паролей к MD4-хэшам

Описание:

Этот инструмент предназначен для восстановления паролей к хэшам, зашифрованным алгоритмом MD4.
(Полное описание алгоритма MD4 можно найти в документе RFC1320).
Скорость перебора паролей, зашифрованных алгоритмом MD4, на разных процессорах:

Процессор | Скорость перебора
Intel Pentium-III 1000 МГц | ~3,4 миллиона паролей/cек
AMD AthlonXP 1700+ (1466 МГц) | ~5,3 миллиона паролей/cек
Intel Pentium-4 2500 МГц | ~5,4 миллиона паролей/cек

Формат исходных данных:

Для загрузки хэшей в программу используется следующий общепризнанный формат строк в текстовом файле:

Имя пользователя (или название хэша):Хэш:

При этом имя пользователя (название хэша) не является обязательным. Пример строк с хэшами:

Hash1:8BE1EC697B14AD3A53B371436120641D:
Hash2:114C5A33B8D4127FBE492BD6583AEB4D:
:8BE1EC697B14AD3A53B371436120641D:
Hash number one:8BE1EC697B14AD3A53B371436120641D:
В архиве с программой вы можете найти тестовый файл с хэшами MD4_Hashes.txt для анализа работы программы.

Возможности:

  • Восстановление паролей к хэшам, зашифрованным алгоритмом MD4, следующими методами:
    1. Атака полным перебором.
    2. Атака по маске.
    3. Атака по словарю (включая гибридную атаку).
    4. Атака распределенным перебором.
  • Проверка пароля на всех хэшах, загруженных в программу.
  • Генерация MD4-хэша по известному паролю.
  • Добавление хэшей в программу не только из текстового файла, но и через диалоговое окно.
  • Экспорт данных.

Ограничения:

  • Максимальная длина восстанавливаемого пароля при атаке полным перебором и атаке по маске - 32 символа.
  • Максимальная длина восстанавливаемого пароля при атаке по словарю - 128 символов.
  • Максимальная длина пароля в текстовом поле "Password:" - 255 символов.
  • Максимальное количество хэшей, с которым работает программа - 8192.
Восстановление паролей к MD5-хэшам

Описание:

Этот инструмент предназначен для восстановления паролей к хэшам, зашифрованным алгоритмом MD5.
(Полное описание алгоритма MD5 можно найти в документе RFC1321).
Скорость перебора паролей, зашифрованных алгоритмом MD5, на разных процессорах:

Процессор | Скорость перебора
Intel Pentium-III 1000 МГц | ~2,2 миллиона паролей/cек
AMD AthlonXP 1700+ (1466 МГц) | ~3,6 миллиона паролей/cек
Intel Pentium-4 2400 МГц | ~4,0 миллиона паролей/cек

Формат исходных данных:

Для загрузки хэшей в программу используется следующий общепризнанный формат строк в текстовом файле:

Имя пользователя (или название хэша):Хэш:

При этом имя пользователя (название хэша) не является обязательным. Пример строк с хэшами:

Hash1:C4CA4238A0B923820DCC509A6F75849B:
Hash2:C20AD4D76FE97759AA27A0C99BFF6710:
:202CB962AC59075B964B07152D234B70:
Hash number one:202CB962AC59075B964B07152D234B70:

Дополнительно программа поддерживает импорт хэшей формата ОС Unix, т.е. MD5-хэши вида

Hash1:$1$12345678$XM4P3PrKBgKNnTaqG9P0T/:
Hash2:$1$12345678$eamrTZEOkK4vufehLXOhK0:
:$1$12345678$XM4P3PrKBgKNnTaqG9P0T/:
Hash number one:$1$12345678$eamrTZEOkK4vufehLXOhK0:

Также программа поддерживает импорт и хэшей формата APR (Apache Portable Runtime), т.е. MD5-хэши вида

Hash1::$apr1$12345678$auQSX8Mvzt.tdBi4y6Xgj.:
:$apr1$12345678$fOL3K5IECyUkOyDNiStbI0:

Для анализа работы в архиве с программой вы можете найти тестовый файл со стандартными MD5-хэшами (MD5_Hashes.txt), текстовый файл с MD5-хэшами в формате Unix (MD5-Unix_Hashes.txt) и текстовый файл с MD5-хэшами формата APR (MD5-APR_Hashes.txt).

Также программа позволяет восстанавливать зашифрованные пароли к программе RAdmin v2.x, которые шифруются с помощью алгоритма MD5 следующим способом - если есть пароль "123" (к примеру), то он расширяется нулями до определенной длины (в программе RAdmin - до 100 символов) и алгоритмом MD5 уже шифруется не 3-байтовый пароль "123", а 100-байтовый массив, начинающийся со строки "123".
Для этого данный инструмент содержит дополнительные настройки для восстановления подобных паролей, а также в архиве с программой находится файл MD5-RAdmin_v2.x_Hashes.txt для анализа работы программы с такими MD5-хэшами.

Возможности:

  • Восстановление паролей к хэшам, зашифрованным алгоритмом MD5, следующими методами:
    1. Атака полным перебором.
    2. Атака по маске.
    3. Атака по словарю (включая гибридную атаку).
    4. Атака распределенным перебором.
  • Проверка пароля на всех хэшах, загруженных в программу.
  • Генерация MD5-хэша по известному паролю.
  • Добавление хэшей в программу не только из текстового файла, но и через диалоговое окно.
  • Экспорт данных.

Ограничения:

  • Максимальная длина восстанавливаемого пароля при атаке полным перебором и атаке по маске - 32 символа.
  • Максимальная длина восстанавливаемого пароля при атаке по словарю - 128 символов.
  • Максимальная длина пароля в текстовом поле "Password:" - 255 символов.
  • Максимальное количество хэшей, с которым работает программа - 8192.
Восстановление паролей к MySQL-хэшам

Описание:

Этот инструмент предназначен для восстановления паролей к хэшам, получаемых при шифровании паролей в базах данных MySQL.
Скорость перебора паролей, зашифрованных алгоритмом MySQL, на разных процессорах:

Процессор | Скорость перебора
AMD AthlonXP 1700+ (1466 МГц) | ~8,5 миллиона паролей/cек
Intel Pentium-4 2800 МГц | ~10,0 миллиона паролей/cек

Формат исходных данных:

Для загрузки хэшей в программу используется следующий общепризнанный формат строк в текстовом файле:

Имя пользователя (или название хэша):Хэш:

При этом имя пользователя (название хэша) не является обязательным. Пример строк с хэшами:

Hash1:606717496665BCBA:
Hash2:077042FB4932B5B5:
:773359240EB9A1D9:
Hash number one:446A12100C856CE9:
В архиве с программой вы можете найти тестовый файл с хэшами MySQL_Hashes.txt для анализа работы программы.

Возможности:

  • Восстановление паролей к хэшам, зашифрованным алгоритмом MySQL, следующими методами:
    1. Атака полным перебором.
    2. Атака по маске.
    3. Атака по словарю (включая гибридную атаку).
    4. Атака распределенным перебором.
  • Проверка пароля на всех хэшах, загруженных в программу.
  • Генерация MySQL-хэша по известному паролю.
  • Добавление хэшей в программу не только из текстового файла, но и через диалоговое окно.
  • Экспорт данных.

Ограничения:

  • Максимальная длина восстанавливаемого пароля при атаке полным перебором и атаке по маске - 32 символа.
  • Максимальная длина восстанавливаемого пароля при атаке по словарю - 128 символов.
  • Максимальная длина пароля в текстовом поле "Password:" - 255 символов.
  • Максимальное количество хэшей, с которым работает программа - 8192.

Примечание:

Для увеличения скорости перебора в данном инструменте применен инкремент пароля, отличный от других инструментов для восстановления паролей к хэшам, и инкремент пароля происходит следующим образом:
AAAAAAA
AAAAAAB
AAAAAAC
...

Для сведения, в остальных инструментах инкремент пароля происходит так:
AAAAAAA
BAAAAAA
CAAAAAA
...

Восстановление паролей к SHA-1-хэшам

Описание:

Этот инструмент предназначен для восстановления паролей к хэшам, зашифрованных алгоритмом SHA-1.

Формат исходных данных:

Для загрузки хэшей в программу используется следующий общепризнанный формат строк в текстовом файле:

Имя пользователя (или название хэша):Хэш:

При этом имя пользователя (название хэша) не является обязательным. Пример строк с хэшами:

Hash1:356A192B7913B04C54574D18C28D46E6395428AB:
:356A192B7913B04C54574D18C28D46E6395428AB:
Hash number one:356A192B7913B04C54574D18C28D46E6395428AB:
В архиве с программой вы можете найти тестовый файл с хэшами SHA-1_Hashes.txt для анализа работы программы.

Возможности:

  • Восстановление паролей к хэшам, зашифрованным алгоритмом SHA-1, следующими методами:
    1. Атака полным перебором.
    2. Атака по маске.
    3. Атака по словарю (включая гибридную атаку).
    4. Атака распределенным перебором.
  • Проверка пароля на всех хэшах, загруженных в программу.
  • Генерация SHA-1-хэша по известному паролю.
  • Добавление хэшей в программу не только из текстового файла, но и через диалоговое окно.
  • Экспорт данных.

Ограничения:

  • Максимальная длина восстанавливаемого пароля при атаке полным перебором и атаке по маске - 32 символа.
  • Максимальная длина восстанавливаемого пароля при атаке по словарю - 128 символов.
  • Максимальная длина пароля в текстовом поле "Password:" - 255 символов.
  • Максимальное количество хэшей, с которым работает программа - 8192.
Восстановление паролей под звездочками

Описание:

Этот инструмент предназначен для восстановления паролей, скрытых звездочками, в следующих объектах - стандартное текстовое окно Windows для ввода паролей (EditBox), объекты TEdit, TDBEdit и TMaskEdit и функционирует под всеми операционными системами Windows - от Windows 95 до Windows 2003.

Возможности:

  • Отображение пароля вместо звездочек, а также дополнительное отображение этого пароля в программе.
  • Отображение класса окна, текст в котором был восстановлен.
Общая информация
  • Программа поддерживает "скрытый режим" работы (комбинация клавиш - Ctrl+Alt+H), при котором она исчезнет с экрана и с панели задач. Для возврата из скрытого режима нажмите эту же комбинацию клавиш.

  • Программа поддерживает многоязыковой интерфейс с помощью Language-файлов. При этом PasswordsPro включает в свое меню список всех Language-файлов, найденных программой в своей рабочей директории. После выбора другого языка интерфейса программы, необходимо выйти из программы и запустить ее снова.

  • Все инструменты в программе, предназначенные для восстановления паролей методами перебора, отображают скорость перебора паролей в виде: N * X p/s, где N - количество пользователей (или хэшей), к которым одновременно подбирается пароль, а X - скорость перебора для одного пользователя (или хэша).

  • Настройки для полного перебора паролей (общие для всех инструментов) позволяют выбрать наборы символов для перебора, а также установить минимальную и максимальную длину восстанавливаемых паролей.

  • Настройки для атаки по маске (общие для всех инструментов) позволяют сформировать маску для перебираемых паролей, а также установить максимальную длину перебираемых паролей. Установка маски заключается в следующем - если вы не знаете N-й символ пароля, то включите N-й флажок маски и в соответствующем текстовом поле укажите маску для этого символа.
    В программе используются следующие маски:
    ? - Любой печатаемый символ (коды символов: 32...255).
    A - Любая заглавная латинская буква (A...Z).
    a - Любая строчная латинская буква (a...z).
    S - Любой специальный символ (!@#...).
    N - Любая цифра (0...9).
    X - Любой символ из пользовательского набора символов.
    Если же вы заранее знаете определенный символ пароля, то впишите его в N-е текстовое поле и снимите флажок маски.

  • В тех инструментах программы, которые предназначены для восстановления паролей, все найденные пароли записываются в файл PasswordsPro.dic, который автоматически создается в каталоге с программой.

  • Также в программе предусмотрена возможность установки приоритета процессов перебора паролей. В меню "Options" -> "Priority" вы можете выбрать один из трех видов приоритета - нормальный, пониженный или низкий.
Статус программы

Текущая версия программы PasswordsPro распространяется по принципу Freeware и плата за ее использование не требуется.

Лицензионное соглашение
  1. Все права на программу PasswordsPro и ее компоненты принадлежат автору - InsidePro.

  2. Копия программы может свободно распространяться в неизмененном виде. Вы можете размещать оригинальный дистрибутив программы на своем сайте, носителях информации (CD-ROM и т.п.) без уведомления разработчика.

  3. Вы не можете модифицировать, дизассемблировать и декомпилировать данное программное обеспечение. Нарушение любого из этих пунктов ведет к автоматическому прекращению действия этой лицензии.

  4. PasswordsPro поставляется по принципу "как есть" ("AS IS"). Никакие гарантии не предусмотрены и не подразумеваются. Вы используете программу на собственный риск. Автор не несет ответственности за потерю данных, повреждения, упущенную прибыль или иной ущерб при использовании или неиспользовании Вами этой программы. При этом автор гарантирует, что программа не содержит в себе вредоносного кода или иного кода, предназначенного для выполнения других функций, кроме оговоренных в описании программы.

  5. Использование PasswordsPro означает принятие Вами лицензионного соглашения.

  6. Если Вы не согласны с условиями данной лицензии, удалите файлы программы PasswordsPro с Ваших носителей информации и прекратите использование программы.
Техническая поддержка

Вы всегда можете задать вопрос по программе, сообщить об ошибке в ней или же предложить какие-либо идеи по развитию и совершенствованию программы следующими способами:

  • Отправить письмо в службу поддержки по электронной почте: Support@InsidePro.com.
  • Связаться с автором программы по ICQ: 285429551.
  • Оставить свое сообщение в Гостевой книге сайта программы.