Новости-1

Microsoft выпускает "заплатки" на CD

Компания Secunia сообщила про очередную серию критических ошибок в IE6. Те же самые уязвимости присутствуют и в версиях браузера 5.01 и 5.5. Среди возникающих проблем – переадресация, кросс-скриптование и взлом ПК. Фактически существует пять проблем в одной, и, по мнению компании, её решение заключается в отключении функции Active Scripting или использовании другого продукта. Более подробно с проблемой можно ознакомиться здесь.

В это же время Microsoft собирается выпустить обновления защиты на отдельном СD для пользователей более старых версий своей ОС, у которых отсутствует надежная и качественная интернет-связь. Для бета-тестирования этого выпуска были приглашены тестеры, использующие Windows 98, Windows 98 Second Edition и Windows Millennium, а в подборку заплат вошли патчи, которые находятся на сайте Windows Update. Компания не сообщает точную дату выхода нового компакта, однако известно, что бета-версия будет доступна лишь до 5 декабря. Сам же диск был создан как реакция на многочисленную критику в адрес Microsoft по поводу большого размера файлов-заплат, которые игнорируются поэтому многими пользователями с коммутируемым доступом в Сеть.

AMD предоставит суперкомпьютер своим разработчикам

Корпорация AMD объявила о возможности использования кластера на базе процессора AMD Opteron модели 244 в Центре разработки AMD в Саннивейл, Калифорния. Кластер, занимающий 247 место в списке 500 мощнейших суперкомпьютеров, создан для того, чтобы дать разработчикам тестовую платформу и масштабируемое средство для совершенствования приложений, которые требуют высокопроизводительных вычислений. AMD осуществила этот проект в сотрудничестве с компаниями Arima, Myricom и Racksaver.

“Центр разработки AMD теперь может предложить партнерам и клиентам самый широкий спектр систем на базе процессоров AMD64. Наши клиенты могут рассчитывать на поддержку и доступ ко всем этим системам, от настольных моделей до суперкомпьютеров, 7 дней в неделю и 24 часа в сутки, - сказал Эд Гасиоровски (Ed Gasiorowski), директор подразделения микропроцессоров AMD по вопросам разработки. - Введение в строй кластера AMD отвечает запросам разработчиков в области высокопроизводительных вычислений и других приложений, требующих большого объема вычислений”.

Linux обновится в декабре

Версия 2.6 ядра ОС Linux должна появиться в декабре и будет гораздо более стабильной, чем её предшественник, если верить её разработчикам. Текущая тестовая версия - 2.6.0-test10 - должна стать последней, по словам главного идеолога разработки нового ядра Эндрю Мортона (Andrew Morton), перед появлением собственно 2.6. Ядро Linux 2.6 претерпело существенные изменения по сравнению с версией 2.4, поставляемой сейчас большинством дистрибьюторов этой ОС. Так, например, в новой версии появится возможность поддержки мощных многопроцессорных серверов, самой популярной ОС для которых сейчас является Unix. Кроме того, будет улучшена поддержка сетевых роутеров, видеомагнитофонов или мобильных телефонов и реакция на действия человека, вроде щелчка мыши или ввода команд с клавиатуры. Также подверглись переделке драйверы, обеспечивающие связь с такими устройствами, как жесткие диски и CD.

При этом г-н Мортон надеется, что тестирование ядра 2.6.0 будет более полным, чем получилось с 2.4.0. Впрочем, не все столь оптимистичны. Некоторые поставщики считают, что глубокие архитектурные изменения ядра высветят больше проблем в ПО. Нелишне отметить, что благодаря добавлению множества настроек поставщиков Linux в версию 2.6 эта редакция принесет меньше отличий между конечными продуктами на её основе и стандартом с Kernel.org. Уменьшение различий также означает возможность обратного портирования разработок из будущей версии 2.7 в версию 2.6. Но, прежде всего, это дает дополнительную уверенность в том, что ошибки в нововведениях для 2.6 не потребуют повторного исправления при переносе в версию 2.7.

Не стоит забывать, что между выходом очередной редакции самого ядра и продуктов на его базе обычно есть некоторый промежуток. Так, один из ведущих поставщиков Linux-решений, Red Hat, планирует выпустить Red Hat Enterprise Linux на базе 2.6 до 2005 года. Пока же Linux-дистрибьюторы портируют некоторые возможности из 2.6 в текущие продукты на базе ядра 2.4.

Источник: http://www.cnews.ru/, интернет-издание о высоких технологиях.
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся
***
Copyright © Internet Zone, info@izcity.com


Новости-2

Microsoft "Платформа 2004". Безопасность ПО: Новый завет

В этой статье приведены основные тезисы доклада Дэвида Лебланка, посвященного написанию безопасного программного кода. Лебланк занимается в Microsoft вопросами безопасности и является одним из авторов книги "Защищенный код", которая используется в процессе обучения программистов компании.

Главным тезисом доклада Лебланка стало доказательство необходимости создания программного обеспечения, изначально безопасного для использования. Это утверждение также является и частью стратегии Microsoft в рамках инициативы Trustworthy Computing ("Надежный компьютинг"), направленной на пересмотр кода существующего ПО компании и написание нового с упором на безопасность. По словам Лебланка, дыры в ПО зачастую появляются именно из-за ошибок на стадии проектирования и программирования. До 50% всех уязвимостей возникают именно на этой стадии.

Что необходимо сделать, чтобы обеспечить безопасность кода при его написании? Во-первых, считает Дэвид Лебланк, необходимо соответствующим образом обучать сотрудников. Если программисты не знают, где может скрываться уязвимость, они не смогут обеспечить безопасность продукта. Необходимо проверять работоспособность систем безопасности после написания программы - испытывать ПО на наличие наиболее распространенных уязвимостей. Кроме того, требуется то, что Лебланк назвал security push - придание импульса всей команде разработчиков в целях исследования кода на предмет безопасности.

Основные три правила безопасного ПО: оно должно разрабатываться с учетом вопросов безопасности, оно должно быть безопасным по умолчанию (неиспользуемые функции должны быть отключены в "заводских установках" ПО, что и было применено в Windows Server 2003 и сервис-паке для Windows XP), и оно должно внедряться с учетом вопросов безопасности. Последнее, опять-таки, означает обучение персонала клиентов Microsoft с целью недопущения злополучных ошибок при внедрении ПО, которые могут повлиять на уровень безопасности программного продукта.

Далее Лебланк перешел к конкретным вопросам "безопасного программирования", представив соответствущие тезисы, один из которых справедлив и сходен с вездесущими "законами Мерфи": "Все беды от неведомого". Далее последовали два уже не столь очевидных утверждения: "Увеличение числа тестировщиков ПО не гарантирует повышения безопасности" и "Наличие средств безопасности автоматически не повышает безопасность". Все три тезиса можно объединить в одно: попытка укрепить безопасность ПО простым увеличением объемов тестирования и средств контроля не сможет радикально снизить число уязвимостей, так как уязвимость может скрываться и в совершенно "невинном" фрагменте кода. Примеры подобных "невинных" фрагментов были приведены далее в ходе доклада Лебланка.

По мнению Лебланка, средства защиты от взлома должны быть многоступенчатыми, чтобы обеспечить защиту "на глубинном уровне". Программное обеспечение должно быть безопасным сразу после установки из-за того, что "никто и никогда не обращается к встроенной системе помощи" (это верно и для пользователей, и для администраторов систем). Меры по защите ПО должны опираться на уже существующий опыт. "Те, кто не знает истории, обречены на ее повторение", - говорит Лебланк.

При разработке безопасного ПО следует первоначально создать модель приложения для отработки на ней известных типов взлома. Нужно разделить угрозы на категории и создать "дерево угроз". Далее угрозы необходимо отсортировать по степени опасности, основываясь на следующих критериях: воспроизводимость (уязвимость можно использовать для взлома при любых условиях или только при определенном стечении обстоятельств), процент успешных использований уязвимости (опять-таки, уязвимость можно задействовать либо во всех случаях, либо в некоторых случаях можно потерпеть неудачу), затрагиваемые группы пользователей, легкость обнаружения уязвимости. На основе этой модели необходимо выстроить приоритеты работы по повышению безопасности программного продукта.

По словам Лебланка, врагом программистов номер один является ошибка переполнения буфера, то есть "попытка передачи большего объема данных, чем положено". По мнению Дэвида, те, кто считают, что некоторые ошибки переполнения буфера нельзя использовать, глубоко ошибаются. В этой, заключительной части доклада Лебланк привел примеры составления запроса на сайте, который приводит к выполнению команд пользователя, интегрированных в запрос. Простейшие примеры с соответствующим кодом демонстрировали, как можно с помощью модификации отправляемых на сервер данных получать над ним контроль. Кроме того, Дэвид продемонстрировал работу некоторых уязвимостей, которые ранее были обнаружены в браузере Internet Explorer. Например, раньше в этом браузере можно было загрузить сайт с "локальными" настройками безопасности, если точки в URL заменить на соответствующие шестнадцатеричные коды: программа отличала локальный ресурс от удаленного именно по наличию точек.

После доклада состоялась пресс-конференция с участием Дэвида Лебланка и представителей издательства "Русская редакция", которое выпустило русский вариант книги "Защищенный код", написанной Лебланком в соавторстве с Майклом Говардом. Стоит отметить, что тезисы доклада Лебланка на конференции "Платформа 2004" соответствуют содержанию книги, хотя в совместном труде Говарда и Лебланка проблема безопасности рассматривается намного глубже, с анализом реального кода на различных языках программирования.

В ходе пресс-конференции Лебланк ответил на некоторые вопросы корреспондента "Компьюленты". В частности, была затронута тема "пасхальных яиц" в программных продуктах, которым, кстати, в книге "Защищенный код" посвящена отдельная глава. Во время доклада Лебланк упомянул фразу Netscape engineers are weenies ("Разработчики Netscape - салаги"), которая использовалась как код шифрования в одном из модулей Internet Explorer. Отвечая на вопрос "Компьюленты" о наличии других подобных "бомбочек" в коде приложений Microsoft, в том числе "пасхальных яиц", Дэвид отметил, что теперь подобная самодеятельность программистов (известно, что в предыдуших версиях программ для Windows можно было отыскать то фото создателей, то трехмерную игрушку, как было в случае с Excel 97) строго запрещена и такие "шуточки" караются в Microsoft увольнением. В книге "Защищенный код" один из авторов пишет: "Должен сознаться, что в "предыдущей жизни" сам занимался этим, но только не в готовом приложении. Это была программа-прототип. Теперь я бы не стал писать "пасхальное яйцо", потому что знаю, что пользователям оно не нужно, да и откровенно говоря, у меня нет времени на это".

На вопрос о том, "ухудшились" ли условия работы программистов с началом воплощения в жизнь инициативы "Надежного компьютинга", Лебланк ответил, что, скорее, наоборот, улучшились. По словам Дэвида, одним из основных качеств программиста считается лень, и при работе с учетом вопросов безопасности он может это качество "реализовать", написав код один раз безопасным, не переписывая и дополняя всякий раз при обнаружении очередной дыры. Кроме того, Лебланк пояснил, что при обнаружении уязвимости в ПО Microsoft сторонними компаниями страдает, в первую очередь, не программист, который допустил ошибку в коде. Проводится расследование, с целью выяснить, почему ошибка не была обнаружена внутри компании, или если она была обнаружена, то почему ее не исправили. Впрочем, "если сотрудник постоянно допускает грубые ошибки в коде, это может послужить поводом расстаться с ним", - заметил Лебланк.

Высказал свое мнение Лебланк и по поводу модели разработки ПО в сообществе open source. Он привел в пример открытый проект, разработкой которого никто не интересуется, из-за чего идея остается нереализованной. В Microsoft, говорит Лебланк, программистам платят деньги, и не они решают, что им делать, а что - нет. Из-за этого модель разработки коммерческих программ эффективнее. Но в то же время, Лебланк отметил, что с точки зрения собственно разработки, а не организации, разница между коммерческим и свободным ПО не так уж и велика.

Разнософт: Программа для хранения ссылок

Утилита под названием Links Organizer, о которой далее пойдет речь, представляет собой своеобразную адресную книгу для хранения ссылок на онлайновые странички, какие-либо документы, программы главного меню, ярлыки "Рабочего стола" и т.п. Причем все эти элементы можно разбить на тематические категории, что облегчает выбор нужного приложения или файла. Таким образом, основной задачей Links Organizer является обеспечение быстрого поиска и запуска тех или иных объектов.

Плюс к тому, Links Organizer обладает и рядом дополнительных функций. Во-первых, для каждой категории и любой отдельной записи пользователь может активировать опцию автоматической проверки: тогда в указанное время утилита самостоятельно просканирует интернет-адреса на предмет обновлений. Во-вторых, в Links Organizer встроен мощный инструмент для поиска "мертвых ссылок", которые указывают на несуществующие сайты, папки или документы. В-третьих, программа умеет запоминать содержимое веб-форм, с тем чтобы впоследствии облегчить их заполнение. Наконец, в-четвертых, в органайзер встроена специальная система оповещения пользователя: о результатах проверки утилита может сообщить звуковым сигналом, электронным письмом или мгновенным сообщением через интернет-пейджер ICQ. Пакет имеет лишь англоязычный интерфейс, хотя разобраться с назначением того или иного пункта меню не составит особого труда.

Бесплатная версия Links Organizer будет работать в течение 30 дней, объем инсталляционного файла составляет чуть менее одного мегабайта. Поддерживаются операционные системы Windows 95/98/Mе/NT/2000/XP и все популярные браузеры - Microsoft Internet Explorer, Netscape Navigator 2.x-3.x, Netscape 6.x-7.x и Opera 3.x-7.x. Полнофункциональный вариант органайзера требует приобретения лицензии стоимостью в 25 долл. США. Дополнительную информацию можно найти на сайте разработчиков.

Нигерия обещает бороться с интернет-мошенниками

Правительство Нигерии решило всерьез взяться за борьбу с так называемыми "нигерийскими мошенниками". Для этого президент страны Олусегун Обасанджо создал специальный комитет из пятнадцати человек. Деятельность этого комитета будет направлена на борьбу с различными методами мошенничества с использованием современных средств связи и, прежде всего, интернета.

Словосочетание "нигерийские мошенники" успело стать нарицательным в связи с распространением определенных мошеннических схем. Чаще всего в таких случаях производится массовая рассылка электронных писем с предложением о проведении законной или незаконной банковской сделки, связанной с выплатой потенциальной жертвой определенной суммы в качестве предоплаты. Такие письма часто отправляются от лица опальных бизнесменов, политиков или их наследников, нуждающихся в помощи при переводе денег за рубеж.

Потенциальную жертву просят помочь в этом мероприятии, обещая солидные проценты от суммы сделки. Тех, кто откликнулся на это письмо, просят подтвердить кредитоспособность путем перевода определенной суммы на счет мошенников. Как правило, после этого следует сообщение о непредвиденных обстоятельствах и просьба перевести дополнительную сумму. В конце концов, мошенники исчезают. Такое мошенничество практиковалось и ранее, с использованием обычной почты или факсов. Однако настоящий расцвет "нигерийского мошенничества" начался с наступлением эры интернета.

Необходимо отметить, что проведением таких мошеннических схем занимаются не только нигерийцы. Мошенники зачастую проживают в развитых странах и не имеют никакого отношения к африканским государствам. Например, недавно "нигерийский мошенник" был осужден в Канаде. Тем не менее, особенно сильно данный вид мошенничества развит в Африке, и правительства ряда государств, в частности, Нигерии, начали испытывать давление со стороны США и других стран, недовольных сложившейся ситуацией. Однако, насколько результативными окажутся инициативы нигерийского президента, еще вопрос. Выследить онлайновых мошенников очень и очень непросто.

Источник: http://www.compulenta.ru/
***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Снова найдены критические дыры в Internet Explorer

На нынешней неделе появилась информация об обнаружении в браузере Internet Explorer пяти новых уязвимостей. Первым новые дыры в самом популярном в мире браузере обнаружил независимый китайский специалист по безопасности Лю Де Юй. В Microsoft пока не признают факт наличия уязвимостей официально, но изучают проблему. Несколько независимых фирм, например, датская Secunia, уже опубликовали свои комментарии и рекомендации по этим дырам. Эта компания охарактеризовала обнаруженные китайцем дыры как чрезвычайно опасные.

Первая из дыр связана с ошибкой в работе функции перенаправления с использованием mhtml. Эта ошибка позволяет обойти проверку безопасности и предоставить скрипту на открытой в зоне интернета странице доступ к локальным файлам. Еще одну дыру в работе функции перенаправления можно использовать для загрузки на атакуемый компьютер произвольного файла и его исполнения в зоне безопасности "Мой компьютер". Для запуска на атакуемом компьютере произвольного кода можно использовать и другую уязвимость. Она тоже позволяет выполнить произвольный скрипт в зоне безопасности, соответствующей другому окну браузера, в том числе в зоне "Мой компьютер".

Следующая дыра является вариацией уже ликвидированной уязвимости и позволяет хакеру отслеживать действия пользователя, и выполнять собственные задачи без ведома последнего.

Наконец, последняя из уязвимостей связана с системой загрузки файлов Internet Explorer. Подсунув браузеру файл с расширением .htm и неверным значением поля Content-Type, злоумышленник может просмотреть содержимое кэша браузера на атакуемом компьютере.

Все указанные дыры актуальны для Internet Explorer 6, но могут присутствовать и в более ранних версиях браузера. Ожидается, что обновления для Internet Explorer будут выпущены в составе ежемесячной порции патчей от Microsoft. Более ранний выпуск заплаток возможен только в случае широкого распространения вредоносных программ, использующих новые дыры.

Источник: http://www.compulenta.ru/
***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


TV-чипсы Philips

Автор: Степан КОВАЛЬ

У вас давно возникло желание приобрести TV-тюнер? Могу поспорить, что давно, но после прочтения очередного обзора или теста в периодических компьютерных изданиях оно почему-то сразу пропадало. Вот несколько «положительных» характеристик материалов, которые сразу отпугивают нашего брата.

Из 22-х каналов тюнер нашел только 7; качество изображения содержало большое количество артефактов, мешающих нормальному просмотру; выводимая тюнером картинка достаточно низкого качества; по всей плоскости экрана постоянно появлялись и исчезали полосы и т.д., и т.п. Одним словом, как сейчас модно говорить и писать, — плохая реализация программного обеспечения. Но тут вас сразу успокоят байкой о чипе Conexant Fusion 8x8 и альтернативном софте, дескать, последнего в Сети неимоверное количество. Потом, между прочим, вспомнят о каком-то Philips SAA 713x, у которого изображение лучше, но для которого альтернативного ПО не существует, поэтому покупать его не стоит. И после всего этого порекомендуют приобрести что-то вроде Aver Media, потом предложат скачать программу BorgTV и пообещают, что все у вас будет хорошо. В чем-то с ними можно согласиться, но я пошел другим путем, остановив свой выбор на тюнере с чипом Philips SAA 713x. При этом остался очень доволен. Не знаете, что это за зверь? Сейчас расскажу. И не только о нем, а о том, как сделать из компа с помощью TV-тюнера самый настоящий мультимедийный комбайн.

На данный момент существует большое количество моделей TV-тюнеров от разных производителей, и простому потребителю разобраться во всем этом изобилии не просто. По большому счету, все TV-тюнеры можно разделить на два семейства: это устройства на чипах Conexant и Philips. Модели одного семейства практически ничем не отличаются друг от друга — они выполнены на одних и тех же чипах. Различия могут распространяться разве что на програмное обеспечение и коробки, в которые устройства упакованы. Теперь о самих чипах.

Bt8x8 — сейчас известны как Conexant Fusion 8x8. Название поменялось после того, как компания Brooktree была куплена компанией Conexant. Чипы этой серии разрабатывались приблизительно 5 лет назад и до наших дней не претерпели существенных изменений (именно эта серия). Имеют 8-битный аналогово-цифровой преобразователь. Наиболее известные модели на этих чипах — Aver Media. Существует разнообразное программное обеспечение сторонних разработчиков.

Philips SAA 713x. Не знаю, когда точно разрабатывались, но имеют 9-битный аналогово-цифровой преобразователь, который декодирует все варианты сигналов PAL, NTSC и SECAM. Качество декодирования выше, чем у конкурента, особенно в формате SECAM. На сегодняшний день известны следующие модификации — SAA7130HL/SAA7133HL/SAA7134HL. Принципиальных отличий нет, это чипы одного типа. В Philips SAA7134HL реализована возможность приема телевизионных программ со стереозвуком (рекомендую тем, у кого кабельное телевидение или спутниковый ресивер). Также Philips SAA7134HL отличается от Philips SAA7130HL возможностью декодирования стереосигнала формата A2 — NICAM (NTSC). А вот основное отличие Philips SAA7133HL от Philips SAA7130HL — возможность декодирования стереосигнала формата NTSC для USA/Japan. Впрочем, для нас эти нюансы не актуальны. Тюнеры на этих чипах бывают двух типов: одни устройства выполнены на референс-дизайне LR138 от LifeView (LifeView FlyVideo 2000/2100/3000/3100, Genius Video Wonder PRO III), другие — на референс-дизайне Proteus Pro. Вторая разновидность является скорее экзотикой, и вряд ли вам удастся найти эти устройства. Существует ошибочное мнение, что нормального альтернативного софта для этого семейства TV-карт нет, но самом деле, это мнение ошибочно.

Итак, пора отправляться в поход за тюнером. Оказалось, что найти подобные устройства не так-то просто. Оббегав почти все «железячные» точки Ивано-Франковска, еле нашел то, что искал (везде одни Aver Media и K-World), и имя ему Genius Video Wonder PRO III. За что было отдано 75 у.е. Так что, ребята, ищите LifeView FlyVideo. По сути, тот же тюнер, но стоит 40–45 у.е. Открываем коробку... Ого-го! Кроме основного железа и инструкции на русском (всего два листа, но и на том спасибо), я нашел шнур для подключения к музыкальному центру, шнур для подсоединения к Line-In звуковой карты, FM-антенну длиной около 3-х метров (простой двухжильный кабель, раздвоенный на конце), пульт ДУ и кабель с ИК-приемником. Пульт оказался маленьким, размером с пачку сигарет и толщиной 5 мм. Сам тюнер выполнен на чипе Philips SAA1734HL.

Установка драйверов и софта прошла без проблем, но при запуске программы для просмотра непонятно почему и зачем происходит изменение частоты обновления экрана до 60 Гц. При сканировании были найдены все каналы, как на комнатной антенне, так и на внешней. С приемом радиостанций тоже все отлично. Качество изображения на высоте, почти ничем не отличается от телевизионного, но при увеличении размера окна появляется «гребенка», и способов устранения в стандартной программе нет. Кто не знает, что это за артефакт, советую прочесть статью Виталия Клецко «Как скрестить ПК с телевизором», МК №51–52 (170–171), 2002 г. «Ну разве это нормальное телевидение?» — подумает читатель. «Нет, ненормальное», — подумал и я и нырнул в дебри WWW. Через некоторое время у меня на винте лежало творение рук Андрея Золотарева — FLY 2000TV. После установки и ознакомления с программой я был приятно удивлен ее возможностями. Кроме просмотра телепрограмм и декодирования телетекста, прослушивания FM-радиостанций, непосредственной записи теле- и радиопрограмм, она к тому же позволяет делать захват аудио- и видеопотоков, как всех одновременно, так и раздельно с любого источника, который можно подключить к тюнеру. Также есть возможность делать захват отдельных кадров и сохранять их в формате BMP и JPEG. Вот вам радиоприемник, телевизор и видеомагнитофон в одном флаконе. А некоторые говорят, что для Philips нет хорошего софта. Программа работает не только с Philips, но и с моделями, построенными на других чипах (BT8x8). Русскоязычную версию можно взять здесь: http://www.fly2000.ru/files/last/fly2000_setupr.exe, 1.37 Мб, версия 2.26. Программа имеет статус shareware и полнофункциональна на протяжении 30 дней. После окончания срока полностью пригодна для просмотра телепрограмм и прослушивания радио, недоступны будут только функции захвата видео и аудио. А теперь обо всем порядку.

Просмотр

Проблем при установке не возникло. Во время инсталляции не забудьте поставить русские шрифты для телетекста, иначе придется читать латиницей. Программа тестировалась на Windows 98 SE и Windows XP Professional (build 2600), нареканий относительно ее работы не было. Процедуру сканирования TV- и FM-каналов, а также такие мелочи, как редактирование списка и т.д. описывать не стану (думаю, здесь трудностей не возникнет), а постараюсь отдать должное основным «фишкам» программы. Итак, на основной панели жмем кнопочку Setting.

1. Пункт Устройства. По умолчанию Fly2000TV рассчитана на работу с тюнерами референс-дизайна LR138 (полный список устройств смотрите в справке). Так что здесь мне менять ничего не пришлось, только включить поддержку пульта ДУ и в качестве источника воспроизведения и источника записи выбрать линейный вход (Line In). Желательно поставить галочку на пункте Отключать линейный вход при выходе.

2. Пункт TV каналы. Для каждого канала в отдельности доступна настройка яркости, контрастности, оттенков, насыщенности и резкости, уровня громкости, а также выбор системы вещания. Не верится? Да-да, именно для каждого. Бытовых телевизоров с такой функцией я не встречал, а вы?

3. Пункт FM-каналы. Здесь перед сканированием будет полезно включить опцию Очищать список, так как радио «Сибирь» и «Абакан» у нас не водится :-). Также можно задать диапазон сканирования от 66 до 199 МГц.

4. Пункт Настройки (рис. 5) самый интересный из всех, поэтому на некоторых опциях остановимся подробнее.

Формат потока — выбираем режим YUY2, так как он не несет в себе избыточной информации и обеспечивает наилучшее качество изображения. Если выбрать RGB, большинство настроек, описанных ниже, будут недоступны. В режиме YUY2 и использовании драйвера 20.50 из стандартной поставки тюнера LifeView FlyVideo 2000 изображение оказалось перевернутым вверх ногами. Хотя с драйвером 20.37, который шел с моим тюнером, все было нормально. Исправить это можно, выполнив файл Del_xfm.bat, находящийся в папке …\Fly2000TV\Misc.

Использовать пин Capture для просмотра — помогает получить изображение в YUY2-режиме для некоторых карт на чипе BT8x8.

Вывод через Video Mixing Renderer — включает новую технологию вывода изображения (только под Windows XP).

Размер видеопотока для оконного и полноэкранного режимов — чем больше размер кадра, тем лучше изображение.

Видеообработка — включает дополнительные опции улучшения изображения (доступна только в режиме YUY2), такие как:

SmartBob — режим удвоения частоты кадров. В телевизоре частота кадров составляет 25 кадров в секунду. Сначала выводятся все четные строки, а потом нечетные, в результате получаем развертку 50 Гц. А если удвоить? Телевизор с разверткой 100 Гц у кого-то есть? У меня уже есть :-);

четкость — тут, думаю, все ясно;

деинтерлейсинг — устраняет эффект «гребенки», или «расчески», кому как больше нравится. Наилучший результат дает режим Blended Clipping;

удаление шума — удаляет высокочастотный шум с изображения.

Но не надо забывать, что все эти эффекты существенно увеличивают загрузку процессора.

В Windows 2000/XP применяется программное охлаждение процессора, а это значит, что проц постоянно переводится в режим Idle с меньшим потреблением тока и обратно (при этом потребляемый ток возрастает), в результате чего не исключены импульсные скачки питания, которые могут влиять на изображение и звук, особенно на дециметровых каналах. Но в Fly2000TV устранима и эта проблема. Для этого воспользуйтесь комбинацией клавиш Ctrl + I. В таблице 1 приведены сочетания клавиш, которые будут полезны при работе с программой.

А теперь смотрим, что получилось. Отличная цветопередача, цвета яркие и насыщенные, никакого дрожания изображения и никакой «расчески». У меня была возможность сравнить качество картинки тюнера на Conexant’е с изображением, полученным на своем тюнере, причем на одном и том же компьютере, и поверьте мне — это разные миры :-). И еще. Если изображение на экране телевизора выглядит нормально, нет шумов и искажений, а на вашем мониторе присутствуют полосы и другие неприятные эффекты (имеется в виду, что телевизор и компьютер подключались к одной и той же антенне) — ищите источник наводок в своем системном блоке. Этим источником может стать все, что угодно, — от материнской платы до винчестера.

Вот несколько примеров из реальной жизни. Моим первым компьютером был К6-II 350 МГц. В целях экономии я использовал безымянную китайскую материнскую плату и такой же корпус, все остальное железо было нормальным. Телевизор и компьютер находились в одной комнате. При включении компа телевизор можно было сразу выключать, так как изображение пропадало вообще, а из звука оставался только один шум. Но это еще не все. В соседней комнате, отделенной от моей комнаты кирпичной стеной, отец на досуге любил послушать радио. После включения моего «монстра» шансов делать это у него уже не было. Похоже на анекдот, но все это правда.

Могу привести еще один случай из жизни. Со своим знакомым мы иногда обмениваемся фильмами, музыкой, а перенос информации осуществляется с помощью винчестера. У него Seagate 40 Гб 7200 об/мин. После подключения винта и некоторых манипуляций с файлами я решил показать товарищу, как работает мой тюнер, и ужаснулся. Все изображение было искромсано полосами, а при копировании файлов с винта на винт становилось похожим неизвестно на что. Такие вот дела.

Дистанционное управление

Теперь перейдем к пульту ДУ. Первым делом, надо установить инфракрасный приемник так, чтобы прохождению ИК-луча ничего не мешало. В принципе он хорошо отбивается от стен, шкафов, но при условии, что стены не увешаны коврами. Например, мой стол, на котором стоит компьютер, находится в углу комнаты, а сам датчик прикреплен сзади системного блока таким образом, что не нужно целиться прямо на него, а достаточно навести пульт на любую из угловых стен и даже потолок. Итак, все установлено, пришло время посмотреть, на что пульт ДУ способен. И тут приходиться вставать с дивана, вылезать из-под теплого одеяла, кликать на ярлычке Fly2000 TV и только тогда наслаждаться всеми прелестями отечественного телевидения. А так бы хотелось холодными осенними или зимними вечерами, не вставая с постели одним нажатием кнопки включить любимую передачу, другим нажатием запустить любимый фильм в любимом плеере, а насладившись фильмом, перед сном послушать любимый Pink Floyd в Winamp или Apollo. И когда глаза уже слипаются так, что нельзя найти кнопку Пуск, выключить пультом своего железного друга и погрузиться в сладкий сон. «Во парня понесло, наверное, бредит бедняга. Быть такого не может», — эта мысль уже наверняка посетила 90% из тех, кто сейчас держит в руках МК. Но хочу вас успокоить и обрадовать. Температура у меня ровно 36.6 по Цельсию, и все эти мечты можно воплотить в реальность. Так как пульт ДУ и ИК-приемник у нас есть, и все правильно работает, что нам нужно еще? Совершенно справедливо — правильный софт.

А теперь всех обладателей разных железок с пультом ДУ попрошу затаить дыхание и в адресную строку браузера ввести следующее: http://slydiman.narod.ru. Здесь находится программа Дмитрия Васильева — SlyControl 2.7.9 (4.08 Мб). Удивляюсь, как до сих пор никто во весь голос и на весь мир не заявил о существовании этого чудесного программного продукта. Тут не то, что заявлять, тут кричать надо :-)!

Вот список устройств, которые поддерживает программа:

Тюнеры, базирующиеся на чипах Bt8x8:

  • AverTV Model 203/103;
  • AverMedia TV Phone 98 wVCR;
  • AverMedia TV Phone/Capture 98 w/o VCR;
  • AverMedia TV Phone/Capture 95;
  • PixelView PlayTV Pro / PAK (PV-BT878P+ Rev. 4E);
  • FlyVideo 98 / II;
  • E-Line;
  • TV Live;
  • FastCom;
  • KWorld KW-TV878RF / KW-TV878-FBK;
  • Genius Video Wonder Pro II V2;
  • Leadtek WinFast TV2000.

Тюнеры, базирующиеся на чипах Philips SAA713x:

  • LifeView FlyVideo 2x00/3x00, DV2000/DV3000;
  • Chronos Video Shuttle II FM (saa7130HL);
  • Eline TV Master 2000(FM);
  • Elta 8681 LV/TV;
  • Manli HomeTV;
  • Genius Video Wonder PRO III.

А для тех, кто немного дружит с радиотехникой, существует простая схема, по которой можно самостоятельно сделать устройство, подключаемое к COM-порту, и с помощью SlyControl управлять компьютером.

Настала пора вернуться к нашему девайсу и проверить все на практике. Программа является платной, но регистрация для жителей бывшего СССР бесплатна. На самом деле никакой регистрации не надо. Просто вводим название текущего месяца на русском языке и нажимаем OK. После установки и запуска автоматически появляется окошко мастера настроек. Здесь в списке нужно выбрать наше устройство — RM-050. Подтверждаем свой выбор кнопочкой Apply и переходим на следующую вкладку. Сразу жмем Skip или Apply — тут нам делать нечего. Далее надо настроить громкость. У меня настройки почему-то были выставлены для микрофона. Устраняем это безобразие и выставляем для Mute: Master Volume — Master Mute. А в поле, где написано no action, выбираем Togle и ставим галочку напротив Master Mute (чтобы убрать микрофон из списка Control, надо все проделать наоборот). Аналогично для Volume Up и Volume Down. Только вместо no action выбираем шаг, с которым будем увеличивать и уменьшать громкость. Чем дальше, тем интересней. Выбор предлагаемых программ, которыми можно управлять с помощью пульта, просто бьет наповал. Это около десятка всевозможных плееров для просмотра видео, не считая Windows Media Player, который представлен от классической до 9-ой версии. То же самое для аудио. Все версии Winamp, а также Apollo, Sonique и JetAudio версий 4.8 и 5. Для просмотра графических изображений можно выбрать Irfan View или ACDSee 5.

В списке имеется даже программа ICE Book Reader Professional, предназначенная для чтения электронных книг. Также есть программа ProgDVB. С ее помощью и компьютерного спутникового тюнера Sky Star-1 можно просматривать открытые и закрытые каналы цифрового спутникового телевидения. Это моя мечта. Представьте себе, вы без всяких преобразований и потерь качества в чистой цифре записываете себе на винт фильм MPEG2 формата с DVD-качеством. Все прокаты вашего города отдыхают :-).

Присутствует в списке и наша Fly2000TV, но только в двух вариантах: fly2000 и fly2000_noplugin. Если выбрать второй вариант, SlyControl не установит плагин, и запустить программу с пульта будет невозможно. Значит, выбираем первый вариант.

Мультимедийные программы каждый для себя выберет сам. Тут как говорится, на вкус и цвет товарищей нет. Я остановился на Winamp и Apollo — для прослушивания фонограмм, и на Sasami2k — для просмотра видео.

Ну и напоследок отберем мултимедиа-программы, а если говорить проще, программы, которыми нам бы хотелось не просто управлять, но и включать их с пульта.

С основными настройками вроде все. Теперь посмотрим на результаты нашей работы. Для большей наглядности все результаты помещены в таблицу 2. Думаю, разобраться будет не сложно.

Окончание следует

Источник: http://www.mycomp.com.ua/
***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Бюджетный монитор от PHILIPS

Автор: Андрей Воронин

Введение

Компания PHILIPS хорошо известна на российском компьютерном рынке. Популярность марки заслужена высоким качеством продукции и хорошим сервисным обслуживаниям. Фабрики Philips выпускают огромное разнообразие электроники, однако в нашей стране компьютерщики знают этого производителя больше, как разработчика высококачественных оптических дисководов и мониторов. Кстати, популярностью пользуются не только оригинальная продукция компании, но и, например, товары с лэйблом: «В этот монитор установлен кинескоп от Philips».

Сегодня мы кратко расскажем вам о новом электроннолучевом мониторе от компании Philips – модели 107T5. Решение сравнительно недавно вышло на российский рынок и в данный момент уже представлено в ряде передовых компьютерных магазинов.

Прошел ли век ЭЛТ?

Закончился ли век электроннолучевых трубок (ЭЛТ) и решений на нем? Попробуем кратко ответить на этот вопрос. Безусловно, современные жидкокристаллические панели имеют множество плюсов, о которых вы не раз читали и в которых могли убедится сами. Однако тот факт, что эволюция поколений LCD идет так стремительно говорит в пользу того, что технология эта имеет огромные видимые перспективы. Разработчики буквально каждый день предлагают все более лучшие и лучшие решения. Купив сегодня панель на жидких кристаллах, вы должны понимать, что через 3-4 месяца ваше решение устареет со всеми вытекающими отсюда обстоятельствами. Нет, я не в коем случае не выступаю против LCD! Просто порой его применение не совсем экономически оправдано. Например, LCD панель стоит существенно дороже дисплея-аналога с электроннолучевой трубкой. Выбор должен строиться на основе взвешиваний всех «за» и «против».

Технология создания и доводки мониторов с электроннолучевой трубкой доведена практически до совершенства. Эти решения формируют отличное изображение, которое практически полностью удовлетворяет глаз человека (например, цвета ЭЛТ трубок, по мнению многих пользователей, намного сочнее, чем у панелей на жидких кристаллах). Если бы не их большие размеры, то они могли бы достойно конкурировать в современном мире, который неумолимо стремится к мобильности.

Итак, выбор между LCD и ЭЛТ не очевиден. В каждом отдельном случае вам придется взвешивать плюсы и минусы. Например, вы живете в небольшой квартире и у вас просто не хватает места для установки обыкновенного монитора. В этом случае, придется выложить деньги за жидкокристаллическое чудо. Если вы наполняете просторный офис хорошими мониторами с большой диагональю для комфортной работы, то за деньги, требуемые на один LCD дисплей, можно купить два электроннолучевых монитора.

Новинка перед вами - Philips 107T5!

Прежде всего, мне хочется рассказать вам о дизайне монитора Philips 107T5. Решение имеет практически классический внешний вид - светлый пластик и темный абсолютно плоский экран. Приятное обрамление 40 сантиметровой видимой части 17-дюймового дисплея сделано очень аккуратно. Пользователя не преследуют мысли о щелях, в которые будет забиваться грязь.

•

Бюджетный монитор Philips 107T5

Кстати, кинескоп не очень глубоко утоплен в корпус, что делает внешний вид достаточно строгим. Задняя часть монитора достаточно короткая, поэтому монитор без особых проблем может быть установлен на небольшой стол. Официальные размеры монитора составляют 424х383х397 мм, при массе 15,5 кг. Потребляемая мощность составляет 68 Ватт. Корпус монитора нагревается совсем не значительно, однако не стоит забывать о влажной уборке устройства.

На передней панели расположены кнопки управления монитором и включения питания. Упругий элемент под ними требуют от пользователя не просто прикоснуться к ним, а именно нажать на них. Меню организовано традиционно - многоуровневая система. Наиболее популярные возможности заботливо вынесены на первый план.

•

Бюджетный монитор Philips 107T5

Качество изображения, прежде всего, обусловливается теневой маской с высоким разрешением и апертурой решеткой. Можно с удовольствием отметить хорошую настройку монитора на производстве. Процент решений с плохим сведением или кривой геометрией ничтожен. Обычно выбор сводится к просматриванию 2-3 моделей. Строчный трансформатор позволяет рассчитывать на разрешение 1,280 x 1,024 при частоте 60Гц. Комфортная работа, на мой взгляд, доступна на 1024х76 при той же частоте смены кадров. Если драйвера вашей видеокарты позволяют поэкспериментировать в этом направлении, то рекомендую выбрать оптимальное разрешение на ваш вкус. Размер зерна составляет 0,25 мм, что является стандартом для таких устройств на сегодняшний день.

107T5 использует уникальную технологию Lightframe™3 от Philips, что обеспечивает яркое и четкое отображение интернет-страниц, видео и фотографий. Суть новинки в том, что нижняя строка изображения может передавать служебную информацию. Она не отображается, а обрабатывается специальным процессором. Площадь экрана делится на 16 прямоугольников, изображение в которых может быть независимо подстроено по яркости и контрастности. Сделать это можно кнопками управления на лицевой панели управления. Таким образом, при многооконной работе пользователь может добиться нужных рабочих параметров для каждого окна. Разумеется, постоянно подстраивать эти параметры утомительно, но если вы пользуетесь постоянными окнами приложения, то такая разовая настройка сводит напряжение глаз к минимуму и делает вашу работу комфортной.

Philips 107T5 отвечает всем спецификациям экологической безопасности MPRII. Опционально монитор комплектуется акустической системой, которая перекрывает все требования офисного компьютера и экономит место на вашем рабочем столе.

Заключение

Рекомендованная к продаже стоимость 185 долларов делает из Philips 107T5 лакомый кусочек для людей покупающих бюджетный, но хороший монитор. Устройство имеет ряд плюсов: сравнительно компактные размеры в этом классе, низкую цену, фирменную технологию Lightframe™3, отличное сведение лучей и хорошие заводские настройки. Из минусов могу отметить только легкую неточность в передаче цветов, которая впрочем быстро подстраивается с помощью системного меню. Монитор может быть рекомендован для офисной работы с текстами, таблицами и Интернетом, а также для игр.

Плюсы:

  • хорошая цена
  • высокое качество
  • спокойный дизайн

Минусы:

  • небольшая неточность воспроизведения цветов (очень субъективно)

Источник: http://4user.ru/
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Обзор видеокарты ASUS V9950 (NVIDIA GeForce FX 5900)

Автор: Бурдыко Алексей

В сегодняшнем обзоре речь пойдет о видеокарте ASUS V9950, которая построена на чипе NVIDIA GeForce FX 5900. Чип представляет собой что-то вроде "работы над ошибками" компании NVIDIA в плане доработки, откровенно говоря, неудачного чипа NVIDIA GeForce FX 5800. В этом обзоре мы не будем заострять внимание на архитектурных отличиях и особенностях чипа GeForce FX 5900, а более подробно остановимся непосредственно на самой плате ASUS V9950.

Компания ASUS в представлении не нуждается. Ее продукция всегда пользовалась заслуженной репутацией очень качественного брэнда. ASUS всегда была в числе первых компаний, представляющих продукцию на чипах NVIDIA. Будет ли так сейчас, когда ASUS объявила также о поставках линейки видеокарт на чипах ATI, неизвестно, но будем надеяться, что "работа на два фронта" пойдет ей только на пользу.

Комплект поставки
В очень красочной коробке, которая является де-факто стандартом в FX-линейке продуктов ASUS, уместились:
• непосредственно сама плата;
• переходник DVI-to-D-sub;
• кабель S-Video — RCA;
• руководство пользователя (на англ. языке);
• руководство по установке драйверов (на 14 языках включая русский);
• 3 CD с играми (Gunmetal, Delta Force: Black Hawk Down, Battle Engine);
• 1 CD с демо-версиями игр (WarcrAnisotropic Filteringt III, Splinter Cell, Big Mutha Truckers, BREED, Colin McRae Rally 3 и TOCA Race Driver);
• 2 CD с разнообразным фирменным софтом от ASUS.
Мы только в очередной раз можем отметить превосходный комплект поставки ASUS, чем эта компания славилась всегда.

Дизайн и компоновка платы
Дизайн PCB-платы от ASUS полностью аналогичен эталонному дизайну референс-платы от NVIDIA. Отличий нет ни в расположении основных элементов, ни даже в компоновке конденсаторов.

Сама плата получилось очень тяжелой. Скорее всего, дело в массивной системе охлаждения (более подробно о ней ниже) с медными радиаторами. Карта имеет классический темно-зеленый цвет PCB, несет на борту 128 Mb DDR-памяти с шиной передачи данных в 256 бит (8 чипов по 32 бита каждый, размещенных на лицевой стороне PCB). Как видим, карта имеет вдвое меньший объем памяти, нежели ее старшая сестра GeForce FX 5900 Ultra, что достигается путем недоукомплектации карты еще 8 микросхемами памяти, места под посадку которых с оборотной стороны платы остаются свободными. Карта имеет интерфейс AGP 2x/4x/8x и стандартный набор выходов: 1 DVI-I, 1 аналоговый и 1 TV-OUT. Формирование сигнала для цифровых мониторов осуществляется TMDS-трансмиттером Sil164CT64 от Silicon Image. На плате также разведено посадочное место под VIVO-чип, но сам чип не установлен (он будет устанавливаться на более дорогостоящую Ultra-версию платы). Также на лицевой стороне печатной платы можно увидеть разъем для дополнительного питания, которое необходимо "прожорливому" GeForce FX 5900. Дополнительное питание на плату можно и не подключать, но в этом случае карта будет работать на пониженных частотах (250 МГц у ядра и 500 МГц у памяти). Недостатком конструкции разъема дополнительного питания на ASUS V9950 можно считать его вертикальное положение. Во-первых, подключение питания при уже установленной в слот AGP видеокарте весьма затруднительно, а во-вторых, крепеж разъема оставляет желать лучшего.

Для чипов памяти, размещенных, как уже упоминалось выше, только с лицевой стороны печатной платы, предусмотрена прогрессивная BGA-упаковка. Время выборки чипов памяти — 2,2 нс, что соответствует частоте работы 454 MHz (908 MHz), но память работает на положенной по спецификациям NVIDIA частоте 425 MHz (850 MHz). Частота работы GPU — 400 MHz, что также соответствует рекомендованной NVIDIA частоте.
Охлаждение на ASUS V9950 организовано весьма грамотно, и в процессе тестирования нареканий по части перегрева не возникало, да и в разогнанном режиме с платой все было в порядке, несмотря на просто выдающиеся разгонные показатели. Система охлаждения представляет собой сплошную конструкцию, которая состоит из весьма массивного сплошного медного радиатора, прикрывающего как сам чип, так и чипы памяти (для которых предусмотрены небольшие углубления, что увеличивает плотность прилегания оных к радиатору), двух вентиляторов (лопасти которых, кстати говоря, светятся в ультрафиолете, так что ASUS V9950 — можно сказать, находка для любителей моддинга=)), обдувающих как сам графический чип, так и микросхемы памяти. В довершение ко всему хочется добавить, что, несмотря на достаточно внушительные размеры и кажущуюся в связи с этим громоздкость системы охлаждения, соседний PCI-слот не блокируется. Однако "терзать" какое-либо устройство, устанавливая его в первый слот, не стоит, так как вместе с ним будет "терзаться" и видеокарта, поскольку приток холодного воздуха будет затруднен. Также в плюсы данной системы охлаждения относим очень малый уровень шума (про Flow FX даже и не вспоминаем=)), который на фоне работы процессорного кулера едва различим.

Тестирование
Тестовый стенд:
• Материнская плата: JetWay S446 (SiS 645).
• Процессор P4 Northwood 1,6 A @ 2,13 A GHz (133x16).
• Память: 256 Mb Hynix PC2100 DDR SDRAM (CL=2).
• Винчестер: Maxtor Diamond Plus 8 40 Gb.
• Видеокарты:
— ASUS V9950 128 Mb (NVIDIA GeForce FX 5900).
— ASUS V9900/TD Video Suite 128 Mb (NVIDIA GeForce FX 5800).

Операционная система, тестовые программы, драйверы и настройки
• Microsoft Windows XP SP1 ENG.
• DirectX 9.0b.
• Драйвер для видеокарт NVIDIA — Detonator 52.16 WHQL.
Все "красивости" в операционной системе убирались, система настраивалась на максимальное быстродействие.
Vsync принудительно отключался через драйверы как в OpenGL, так и в Direct3D-приложениях. Технология сжатия текстур S3TC также отключалась.

Тестовые программы:
• Future Mark 3DMark2003 v330.
• MadOnion 3DMark2001SE.
• CodeCult Codecreatures v1.0.0 (DirectX 8.1 приложение, шейдеры, Hardware T&L).
• id Software/Activision Return to Castle Wolfenstein v1.0 (Open GL, мультитекстурирование. Настройка качества изображения на максимальном уровне. Использовалось Demo Checkpoint).
• Digital Extreme/Epic Games Unreal Tournament 2003 (Di-rect3D, Hardware T&L, вершинные шейдеры, Dot3, cube texturing).
• Yeti studious Gun Metal Benchmark 2 v1.20s (DirectX 9.0 бенчмарк, Vertex Shaders 2.0, Pixel Shaders 1.1, Hardware T&L).
• Novalogic Comanche 4 Demo v1.0.1.10 (Direct3D, мультитекстурирование, Hardware T&L, пиксельные и вершинные шейдеры).
• Croteam/GodGames Serious Sam: The second Encounter v1.07 (OpenGL, мультитекстурирование, настройки качества — пресет Quality (анизотропная фильтрация, предлагаемая по умолчанию, отключалась)).
• Egosoft X2: The Threat Demo (Direct3D, мультитекстурирование, Dot3, режим встроенного в демо-версию бенчмарка).
• Microsoft HALO: CoMbat Evo-lved (DirectX 9.0, Vertex Shaders 1.1/1.4/2.0, Pixel Shaders 1.1/ 1.4/2.0, Hardware T&L, качество максимально возможное).
• Massive Development AquaMark3 (DirectX 9.0, Vertex Shaders 1.1/1.4/2.0, Pixel Sha-ders 1.1/1.4/2.0, Hardware T&L, режим AquaMark3 Triscoretm).
• Legend Ent./Epic Games Un-real II: The Awakening (Direct3D, вершинные шейдеры, Hardwa-re T&L, Dot3, cube texturing, качество, предлагаемое программой BenchemAll).

Качество 2D
Прежде чем дать оценку качеству изображения, выдаваемого видеокартами, мы в стотысячный раз повторяем=), что на сегодняшний день более или менее объективно оценить данный параметр для серии видеокарт нельзя, т.к. качество 2D сильно зависит от конкретного экземпляра, а проверить все карты по понятным причинам невозможно. Качество 2D зависит также от монитора и соединительного кабеля, что, в свою очередь, привносит солидную долю субъективизма в методику его оценки.

Качество 2D, показываемое всеми платами, в разрешениях 1024x768x85 Hz и 1280х1024х60 Hz можно охарактеризовать как хорошее. Заметных отклонений в качестве картинки ни у одного из протестированных экземпляров замечено не было.

Разгон
Видеокарты разгонялись при помощи утилиты RivaTuner. Стабильность работы при разгоне проверялась при помощи бенчмарков Future Mark 3D Mark2003 v330 и MadOnion 3D Mark2001SE. В первом прокручивалась третья игровая сцена Trolls' Lair в зацикленном режиме для быстрого выявления разгонного потенциала плат. После нахождения критических частот три раза прокручивался тест 3DMark2001SE. Если на мониторе появлялись искажения (выбитые пиксели, полосы, линии и т.д.), то частоту памяти понижали на несколько мегагерц. Если же компьютер зависал, то понижали частоту графического чипа. Если тесты прокручивались успешно, то разгон считался успешным. В качестве дополнительного охлаждения использовался обычный 8х8 см вентилятор, обдувающий прежде всего чипы памяти видеокарты.

Результаты разгона для протестированных плат оказались следующими:
• Видеокарту ASUS V9900/ TD удалось разогнать до частот 490 MHz/1 GHz для ядра/памяти соответственно.
• Видеокарту ASUS V9950 удалось разогнать до частот 500 MHz/975 MHz для ядра/памяти соответственно.

Результаты разгона просто замечательные для обеих плат. Все же качественная 2,2 нс память от Samsung на ASUS V9950 смогла заработать на еще больших частотах, нежели это демонстрирует ее маркировка, что в очередной раз подкрепляет утверждение о том, что видеокарты ASUS входят в число самых разгоняемых.

Результаты тестирования
Комментировать здесь, собственно, практически нечего=). Налицо явная победа видеокарты ASUS V9950 на чипе NVIDIA GeForce FX 5900 во всех тестах и всех разрешениях. В связи с выходом новых драйверов ForceWare 52.16 (скажите Deto-nator'у гуд бай=)) не удалось снять показания в альфа-версии игры DooM III, так как на новой версии драйверов игра корректно не запускается (все же сырость альфы дает о себе знать).

Видеокарты | ASUS V9900/TD | ASUS V9950
Синтетические бенчмарки | 1024x768
3DMark`03 v 330 (scores) | 4374,0 | 5028,0
3DMark`01 SE (scores) | 10617,0 | 11395,0
Codecreatures | 38,1 | 42,2
Игровые тесты: | 1024x768
Quake 3: Arena | 211,1 | -
Return to Castle Wolfenstein | 95,2 | 122,6
DooM III | 18,4 | -
Serious Sam | 81,8 | 83,2
Unreal Tournament 2003 | 124,3 | 131,3
Gun Metal Benchmark 2 | 25,8 | 29,8
Comanche 4 Demo | 39,4 | 41,8
Синтетические бенчмарки | 1280x1024
3DMark`03 v 330 (scores) | 3358,0 | 3933,0
3DMark`01 SE (scores) | 9259,0 | 9962,0
Codecreatures | 30,8 | 34,3
Игровые тесты: | 1280x1024
Quake 3: Arena | 199,3 | -
Return to Castle Wolfenstein | 94,1 | 122,1
DooM III | 15,2 | -
Serious Sam | 78,1 | 84,2
Unreal Tournament 2003 | 111,7 | 120,8
Gun Metal Benchmark 2 | 22,7 | 26,9
Comanche 4 Demo | 39,1 | 41,4

Выводы
По чипу NVIDIA GeForce FX 5900 хочется высказать только удовлетворение тем, что все недоработки и недостатки чипа NVIDIA GeForce FX 5800 были устранены. Причем в качестве положительных моментов здесь выступают не только возросшие скоростные показатели нового чипа, но также и избавление от многострадальной системы охлаждения FlowFX (для ASUS V9900/TD неактуально). А вот сама карта ASUS V9950 нам однозначно понравилась во всех отношениях. Даже если не упоминать просто замечательный комплект поставки, качество изготовления платы и отменный разгонный потенциал видеокарты делают ее очень хорошей покупкой.

Источник: http://www.nestor.minsk.by/kg/
***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Пылесосим через интернет

Автор: Alex, editor@izcity.com

Microsoft и наручные часы - Пылесосим через интернет - USB светлячок

Компания Fossil совместно с корпорацией Microsoft произвели на свет интерактивные наручные часы с мультимедийными возможностями. В настоящий момент ряд новых интерактивных часов насчитывает три модели: Wrist Net Dick Tracy (FX3002), Fossil Wrist Net Round (FX3001), Wrist Net Square (FX3000).

Люди, обладающие такими часами, получают возможность пользоваться сервисом MSN. В зависимости от модели часов за 179 долларов: Wrist Net Square, Fossil Wrist Net Round или за 199 долларов: Wrist Net Dick Tracy можно получить в этом сервисе следующие услуги:

  • НОВОСТИ. Самые свежие новости из различных отраслей человеческой деятельности (мировые, национальные, деловые, спортивные, технологические, развлекательные и др.).
  • ВРЕМЯ. Эти часы автоматически корректируют перемещение между часовыми поясами.
  • ПОГОДА. Приём данных о погоде в месте нахождения пользователя. Часы отражают данные о текущих погодных условиях в реальном времени. Трёхдневные прогнозы погоды: ветер, влажность, давление.
  • ПЕРСОНАЛЬНЫЕ СООБЩЕНИЯ. Человек может получать различные сообщения.
  • КАЛЕНДАРЬ. Приём с помощью наручных часов информации о праздниках, знаменательных датах, важных событиях.
  • ДОПОЛНИТЕЛЬНЫЕ ФУНКЦИИ. Таймер, будильник, секундомер и др.

***

Инженеры компании Samsung разработали высокотехнологичный бытовой пылесос, способный производить уборку в помещении без присутствия человека.

Пылесос Samsung VC-RP30W автоматически определяет своё местонахождение по встроенной 3D карте, которую человек может загрузить в память пылесоса, через персональный компьютер. Это может быть, например, план 3-х комнатной квартиры. Пользователю нужно задать только место, которое должно быть вычищено. Также можно задать интервал времени, через который пылесос будет объезжать выбранные человеком места и убирать в них мусор.

Если кому захочется поиграться с таким пылесосом, то с помощью дистанционного управления можно поуправлять действиями интеллектуального чистильщика. Причём, находиться в непосредственной близости с пылесосом не нужно, т.к. пылесос Samsung VC-RP30W оснащён встроенной видеокамерой, с помощью которой пользователь может контролировать все действия.

Если и этого недостаточно, то можно, находясь в любой точке земного шара и имея доступ к интернету, убираться в своей квартире с помощью этого пылесоса. Кто-нибудь из читателей IZone пылесосил с помощью интернета?!

***

USB разъём, который можно увидеть на фотографии ниже, не может "светить всегда, светить везде!", а может он светить только тогда, когда по нему передаются данные и происходит работа какого-либо устройства, подключенного через этот разъём.

Разъём Galaxy Light-UP USB кабеля может светиться пятью различными цветами: красным, синим, зелёным, жёлтым, перламутровым. Свечение исходит от двух разъёмов USB кабеля. Такой кабель поможет пользователю без труда продиагностировать некоторые поломки в различных устройствах. Galaxy Light-UP USB кабель поддерживает стандарты USB 1.1 и USB 2.

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Разумная платформа для Intelлигентов

Автор: Владимир СИРОТА

Здравствуйте, уважаемые читатели. Что-то давно мы с вами не «ударяли» по платформам Intel. Ну что ж, давайте прямо сейчас и рассмотрим вопрос создания бюджетной, но высокопроизводительной платформы на процессорах этой компании.

Накрапанное вступление

Некоторые пользователи на протяжении многих лет сохраняют приверженность той или иной платформе. У продукции корпорации Intel почитателей множество, не секрет, что около 80% ПК, продаваемых в мире, базируются на процессорах именно этой именитой компании. Наверняка многие из приверженцев «платформы Intel», задумываясь в последнее время о проблеме смены старых персоналок, размышляли над вопросом оптимального выбора компонентов для будущей новой системы…

Вот и я предлагаю свое видение данной проблемы. В ходе нынешних ученых изысканий :-) мы с вами рассмотрим варианты выбора платы на недорогих и более-менее соответствующих понятию «современный» чипсетах и процессорах. А именно, на самом новом наборе системной логики i848P; более старом, но продвинутом наборе микросхем i865PE; и на единственном не совсем свежем, но все еще популярном в силу своих неплохих характеристик и дешевизны чипсете i845PE. Наборы микросхем-предшественников i845PE мы отвергнем как морально устаревшие. А вариант i865P пропустим из-за его подозрительных характеристик: это подвид i865PE, который «не держит» шину 800 МГц, а только 533 МГц, что очень смахивает на продажу под вывеской i865P отбракованных чипов i865PE. Вы же не так богаты, чтобы покупать совсем дешевые вещи, а затем тратить кучу денег на лечение покусанных локтей :-)? Ну вот и я того же мнения.

Чипсет i875P, безусловно, хорош, но его мы тоже оставим в стороне (далее я объясню почему), ведь мы же собрались строить бюджетную платформу.

Эксперименты с выбором платформы мы будем проводить, используя платы AOpen. Хотя бытует мнение, будто бы изделия этого производителя и не хватают звезд с неба в оверклокерском плане, но и не для астрономов они предназначены :-). А с точки зрения надежности и качества исполнения — это продукты весьма высокого класса. А что до разгона, то, как мы увидим далее, с этим у новых моделей плат AOpen дела обстоят самым что ни на есть наилучшим образом.

В ходе наших исследовательских работ мы рассмотрим как выбор оптимальной платы/чипсета, так и процессора, к которому нужно присмотреться, если вы собираетесь создать действительно серьезную машину. Чтобы обеспечит некоторый, так сказать, частотный паритет исследуемых бюджетных процессоров Intel, мы создадим варианты платформ на базе Celeron 2.6 ГГц, Pentium 4 2.66 ГГц (шина QPB 533 МГц) и Pentium 4 2.6С ГГц с НТ (шина QPB 800 МГц). Конечно, между этими процессорами есть разница в цене (хотя все эти CPU, безусловно, относятся к классу бюджетных), зато из этой статьи мы как раз и узнаем, имеются ли весомые причины доплачивать за каждый из них.

Итак, господа заседатели за компьютером, lets, как говорится, go.

Только один

Начнем мы наш обзор с i848P (рис. 1) — этот чипсет появился на рынке недавно, как и платы на нем. По сути своей данный набор системной логики, согласно неофициальному, но общепринятому мнению, не что иное, как вариация чипсета i865PE (о нем далее), которому «удалили» второй канал памяти. Следствием этого стало то, что одноканальный 64-битный контроллер памяти чипсета i848Р, по сравнению с i865PE, «обслуживает» вдвое меньший максимальный размер оперативной памяти — до 2 Гб. И вовсе не зря на рассматриваемой далее плате AOpen, базирующейся на i848Р-чипсете, из возможных 4-х присутсвуют всего два (не напаяны) слота под модули DIMM — они здесь по большому счету просто не нужны. Потому что плата все равно не в состоянии поддерживать более чем 2 двухбанковых модуля DIMM, так что отсутствие слотов вызвано вовсе не желанием AOpen сэкономить.

В остальном достоинства «предшественника» у i848P сохранились — этот набор микросхем поддерживает все процессоры Pentium 4 и Celeron, с шиной QPB 800, 533 и 400 МГц, включая чипы, оснащенные технологией Hyper-Threading (НТ). Заявлена и поддержка ожидаемых процессоров Prescott. В наличии остались также интерфейсы Communication Streaming Architecture и AGP 3.0 (8х).

Ну вот собственно и все, больше о чипсете i848P особо сказать нечего, поэтому перейдем к плате AOpen на основе этого набора микросхем — AX4SPB-UN (рис. 2). Модель выполнена на черном текстолите, располагает, как уже было сказано, 2 слотами под DDR DIMM, 2-мя EIDE и 2-мя SATA-разъемами для подключения жестких дисков и оптических приводов, имеет и коннектор для подсоединения FDD, 5 слотов шины PCI для установки карт расширения, один разъем AGP для видеокарточки. На «заднюю» кромку платы выведены разъемы 4-х USB-портов, PS/2-порты для клавиатуры и мыши, 2 СОМ, LPT и LAN (сетевой) порты и 3 аудиоразъема — линейного входа, выхода и микрофона. Но эти разъемы не так просты, как вы можете подумать. Впрочем, об этом далее. Есть на плате и множество дополнительных штекеров для подключения всевозможнейших периферийных устройств, дополнительные фичи, но о них тоже попозже.

В комплект поставки девайса входит по одному кабелю SATA, ATA-100, FDD, а также переходник питания с привычного для нас разъема, идущего от блока питания, на соответствующий стандарту для SATA-устройств. Прилагается и заглушка на заднюю стенку ПК, соответствующая разъемам платы. Приятно порадовала толстая книжица-мануал, для плат AOpen это редкость. В наличии и 2 CD-диска с ПО: один — с драйверами и софтом разной полезности к материнке, а второй — с утилитой Norton Antivirus 2003. В последней все бы хорошо, да уж больно несвежая она.

Но тему софта к AOpen’овским платам мы затронем далее :-), а пока еще пару слов о некоторых «вкусностях» рассматриваемой платы. На материнке можно «поиграться» частотами системной шины, меняя FSB в пределах 100–400 МГц с шагом в 1 МГц. (Для тех, кто читает наше издание нерегулярно и слегка отстал от жизни, напомню, что частотам QPB 400, 533 и 800 МГц соответствуют реальные физические частоты FSB 100, 133 и 200 МГц. Просто по шине QPB за такт передается 4 порции (отсюда и приставка quadro в названии шины — Quad Pumped Bus) информации (две по росту тактового сигнала и две — по его спаду). Так что шина у Pentium 4 вдвое эффективнее, чем, скажем, у Athlon XP. Ведь в последнем случае используется DDR-шина (100, 133, 166 и 200 физическим мегагерцам FSB соответствуют 200, 266, 333 и 400 МГц системные шины), где за каждый такт передается всего 2 порции данных — одна по нарастанию, вторая по спаду тактирующего сигнала.)

Память для процессоров с 533-МГц шиной может работать в режимах DDR266 и DDR333 (по умолчанию), но не DDR400 (впрочем, это типично для плат на этом чипсете, а также на i865PE, i875P). При установке процессора (Celeron) со 100 (400) МГц шиной память работает по умолчанию в режиме DDR266. И изменить это нельзя ни за какие коврижки (ну, если не вести речь о разгоне, естественно), даже на DDR200 :-). Для процессоров с 800-МГц шиной допустимы «отклонения» с понижением частоты памяти с нормальных 200 МГц (DDR400), но поверьте, на пользу делу такой подход не пойдет.

Имейте в виду, что большинство (если не все) из сказанного в отношении частотных характеристик работы при той или иной конфигурации системы справедливо и для подавляющего большинства плат других производителей на чипсете i848P.

Частоты AGP и PCI у платы повышаются синхронно с шиной (т.е. только при разгоне). Вольтаж CPU можно менять от 0.85 до 1.6В с шагом 0.025В, а вот напряжение на AGP не поддается плавной регулировке — доступны два дискретных значения: 1.5В (по умолчанию) и 1.6В. То же касается и DDR-памяти — ее можно питать либо 2.6 (стандартно), либо 2.7 вольтами.

РЕ’нсионер

Да, вы угадали, в этом разделе речь пойдет о чипсете i845PE и плате на его основе. Почему пенсионер? Потому что ему пора на заслуженный покой. А на что еще может рассчитывать на сегодняшнем рынке чипсет, который официально не поддерживает шину 800 МГц? То-то же. Несмотря на то, некоторые производители умудрись заявить, что им удалось создать «нечто, надежно работающее» на чипсете i845PE и поддерживающее FSB 200 МГц, такие высказывания не внушают оптимизма. Верить во все это почти так же нелепо, как и «вестись» на новости об очередном рекорде типа того, что дескать, японцы разогнали Pentium 4 2.4 ГГц до 4999 МГц, превысив свой предыдущий рекорд на 0.5 МГц :-). Однако если вы не поленитесь поискать «корни» таких рекордов, то выяснится, что совсем выпавшие из реальной действительности жители Страны восходящего солнца использовали для охлаждения чипа… жидкий азот. Поэтому относиться к подобным достижениям человеческой мысли всегда следует с изрядной долей скепсиса, ибо они так далеки от реальной действительности, как Япония от нас.

Впрочем, если для вас не критичны шина QPB 800 МГц и наличие на плате ненужных подавляющему большинству находящихся в здравом уме пользователей SATA-разъемов, то плата на i845PE все еще может оказаться неплохим выбором, особенно с учетом ее, как правило, невысокой цены. Ведь такой девайс будет поддерживать все процессоры Pentium 4 и Celeron с частотой шины 400 или 533 МГц, включая модели, обладающие технологией Hyper Threading (то есть максимально на сегодняшний день в плату на i845PE можно «воткнуть» Pentium 4 3.06 ГГц с НТ). С одним каналом DDR-памяти также вполне можно смириться, контроллером ОЗУ этого чипсета поддерживаются максимум два двухбанковых модуля DIMM. (Если у вас на плате с чипсетом i845PE или i848P «обнаружилось» три слота DIMM, то производитель девайса явно рассчитывал на использование вами однобанковых модулей памяти, и о возможных проблемах с заполнением разъемов ОЗУ двухбанковыми модулями был обязан предупредить вас в мануале!). Если вас интересуют еще какие-то сведения о наборе микросхем i845PE, то могу порекомендовать статью «Система «Intel-Intel» — логично?», МК, №43 (214), 2002 г.

Чипсет i845PE у нас официально представляет материнская плата AOpen AX4PER-GN (рис. 3). Ее комплектация типична для AOpen’овских изделий и в целом повторяет «прилагающийся набор» для ранее описанной платы, за исключением нескольких мелочей. В AX4PER-GN не нашлось места диску с Norton Antivirus (на моей памяти у плат AOpen это впервые, видно, данную модель собираются отдавать совсем уж задешево). Также за естественной ненадобностью отпала необходимость в наличии SATA-кабеля и переходника для SATA же питания. О толстой книжице-мануале речь, естественно, тоже не идет — только типичные для плат этого производителя цветастые листики-мануалы. Да, можно сослаться на то, что красочные мануалы прилагаются на диске в электронном виде (в pdf-формате), но как, простите, их читать, если пользователю потребуется какая-то информация по ходу сборки ПК? Собрать заранее второй компьютер :-)?

В остальном все нужное на месте. Хотя, конечно же, не помешал бы второй АТА-33-шлейф для подключения оптических накопителей, но его отсутствие — отличительная особенность всех системных плат от AOpen (за исключением, по-моему, идущих в супер-пуперной комплектации дорогих моделей МАХ). Ну а в общем, плата как плата: 6 слотов PCI, AGP, 2 DIMM’а под DDR-память, два EIDE и один FDD-разъем — ничего необычного :-). Коннекторы IrDA и игрового порта тоже на месте, но, как и в других случаях, косички к ним придется приобретать за отдельную плату. В «нужном месте» на материнке вся когорта наиболее важных разъемов для периферии: PS/2-порты для клавиатуры и мыши, 4 USB, 2 СОМ, LPT и LAN, 3 «дырочки» для аудио. На этой плате, единственной из рассмотренных, порт AGP был заклеен бумажкой, предупреждающей об опасности установки в этот слот старых AGP 2х 3.3 В карт, что чревато серьезным повреждением платы. Вообще-то, это предостережение актуально и для остальных, более новых моделей плат, но видно, его решили «похерить», надеясь на то, что пользователи уже выбросили все свои AGP 2х карты (и правильно сделали :-)), или смогут заметить свет сигнализирующего о «несоответствии» диода.

Что расстроило в плате, так это слишком близкое расположение элементов стабилизации напряжения CPU к процессорному гнезду. Неоднократно устанавливаемый/снимаемый мной кулер все время отгибал одной из удерживающих его ножек близлежащий дроссель (рис. 4), причем довольно ощутимо . Да и слоты под память «перпендикулярно» пристыкованы к разъему AGP, так что устанавливайте модули DIMM перед вставкой видеокарты.

С частотами шины и памяти у данного решения ситуация следующая. При 533-МГц шине (Pentium 4) можно заставить память работать как DDR333 (по умолчанию) или DDR266 (выбирать, если вы уж сильно лохонулись с памятью :-)). При 400-МГц шине (Celeron) память может работать как DDR266 (по умолчанию) и даже как DDR200 (если вы ее насильно заставите, ибо я сомневаюсь, чтобы кому-нибудь так «повезло», что он оказался счастливым обладателем такого антиквариата, как пара планочек DDR200). Эти же частотные характеристики справедливы и для любых других плат с чипсетом i845PE.

Сама FSB на плате AX4PER-GN поддается регулировке в пределах 100–255 МГц с шагом в 1 МГц. Можно ускорять, устанавливая делитель к FSB, шины AGP и PCI (вариантов здесь множество — как от «заторможенных» по отношению к стандартному варианту частот, так и разогнанных).

Один плюс один

Самым приемлемым для создания нашей Intel’лигентной, недорогой и производительной платформы является чипсет i865 PE. Почему? Все дело в волшебных кочанах :-). Что за такие, почему не знаете? Перечисляю:

поддержка самых современных процессоров Pentium 4, рассчитанных на системную шину с частотой передачи данных 800 МГц (ну, это Intel так думает, мы то знаем, что на самом деле куда больше :-)) и поддерживающих технологию Hyper Threading, которая обеспечивает дополнительные возможности интеллектуального управления и определения приоритетов для потоков команд, обрабатываемых процессором;

двухканальный 128-битный (64 бит х 2) интерфейс памяти с высокой пропускной способностью (заметим, что максимальная пропускная способность одноканального 64-бит интерфейса памяти в случае применения памяти DDR400 составляет 3200 Мб/с (8 байт (это те самые 64 бит) х 400 МГц = 3200 Мб/с, отсюда и обозначение РС3200); нетрудно догадаться, что для такого двухканального интерфейса пропускная способность интерфейса памяти поднимается до 6.4 Гб/с (3.2 Гб/с х 2 = 6.4 Гб/с));

графический интерфейс AGP 3.0 (8x) с пропускной способностью 2.1 Гб/с (66 МГц х 4 байта (это 32 бита — ширина шины AGP)) х 8 (количество передач за такт шины) = 2112 Мб/с);

архитектура Communication Streaming Architecture (о ней упоминалось ранее, когда речь шла о i848P) с интерфейсом на основе выделенной сетевой шины (Dedicated Network Bus, DNB), который поддерживает передачу данных по стандарту Gigabit Ethernet (GbE), 1000 Мб/с;

два независимых контроллера Serial ATA с пропускной способностью по 150 Мб/с, возможностью организации RAID-массивов уровня 0 или 1, никуда не делись и два канала Parallel АТА-100;

высокоскоростная последовательная шина USB 2.0 с пропускной способностью до 480 Мбит/с (60 Мб/с) для подключения быстрой периферии.

Все, кочаны закончились. Неужели вам этого мало? Что за дружный шепот я слышу: «а i875P сиравно круче». Детский сад никто высказываться не просил. Я беседую с интеллигентными людьми и сейчас расскажу им что к чему. За дополнительными подробностями по i865PE отсылаю к статье «Что Intel прячет за спиной?», МК №5 (228) 2003 г., а мы поговорим об отличиях i865PE от более дорогого i875P. Таких отличий целых два, если не принимать во внимание цену этих продуктов. i875P «превосходит» i865PE поддержкой технологии PAT и кода коррекции ошибок (ECC) для памяти. Начнем с технологии PAT. Использование Performance Acceleration Technology (PAT) делает систему на 2–5% быстрее. Достигается это за счет оптимизации работы с оперативной памятью. А именно благодаря отказу от использования дополнительных буферов синхронизации при обращении процессора к памяти, что сокращает время поступления данных из ОЗУ к процессору на несколько системных тактов. Все это хорошо, и было бы большим достоинством i875P, если бы… производители плат не научились реализовывать технологию PAT в чипсетах i865PE. Не исключение и платы AOpen (там функция носит название Performance Boosting Engine (PBE), но это чистой воды переименованный PAT :-)). А что вы хотели, ведь фактически северные мосты чипсетов i875P и i865PE — одни и те же микросхемы, просто первые проходят более тщательный отбор по критериям качества, устойчивости работы. IMHO, рассказы об использовании в i875P какого-то особого сорта кремния нужны для «прикрытия» :-).

Надо отметить, что i875P пакуют в корпуса с большим количеством ножек, но эти ножки — в ответе за ту самую «вторую» коррекцию ошибок (ЕСС). И здесь уже от i865PE мы ничего не добьемся. Ну не паять же в самом деле к микросхеме ножки вручную! Однако по этому поводу расстраиваться не стоит — дело в том, что домашнему/офисному персональному компьютеру ЕСС при работе с памятью не нужен (системы и без него функционируют с завидной надежностью) и даже вреден. Ведь использование ЕСС снижает быстродействие ПК почти на те же самые проценты, на которые его приращивает РАТ, ибо «бесплатных» ресурсов не бывает, и за коррекцию ошибок приходится расплачиваться снижением быстродействия компьютера. А теперь трезво поразмыслим (у вас выпивка тоже кончилась :-)?) — стоит ли платить больше за ненужную для домашнего/офисного ПК возможность ЕСС. Думаю, нет. А вам как кажется?

Нужно также иметь в виду, что если вас угораздит оснастить систему с процессором, рассчитанным на шину 800 МГц, памятью DDR333, то по умолчанию она будет работать на 320 МГц (это ограничение наложено Intel и, я так думаю, связано с вопросами синхронизации работы памяти и процессора). Заметьте также, что режим PAT, согласно утверждению Intel, может функционировать только при 800-МГц шине и установленной DDR400 памяти. В принципе, легко понять почему — ведь именно при таком соотношении частоты FSB (а значит, и внешней частоты процессора) и памяти соотносятся 1:1, то есть процессору легко черпать данные прямо из ОЗУ. Очевидно, что при несинхронном отношении частот системной шины и памяти, скажем, 4:5 (т.е. когда на 4 такта шины приходится 5 тактов памяти), без использования промежуточных буферов для хранения поступающих из памяти к CPU данных просто не обойтись.

Продолжение следует

Источник: http://www.mycomp.com.ua/
***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Самопал 2, или Baybus своими руками

Качественный и надежный хостинг
***

“Самопал” 2, или Baybus своими руками

Автор: SilentMan

Продолжение. Начало смотрите в IZone 545.

Вы уже собрали Fanbus? А как кулеры, не шумят? Думаю, очень даже.

Еще бы, уже только два кулера (процессорный и БП-шный) способны создать немало шума. А добавить к ним еще кулер видеокарты, да еще пару-тройку дополнительных — тех самых, для которых мы и делали наш Fanbus — вой может оказаться весьма впечатляющим. Для уменьшения шума умные моддеры в свое время придумали такую замечательную штуку, как Baybus, позволяющую включать и выключать вентиляторы по желанию, снижая или увеличивая тем самым уровень шума. Для индикации мы будем использовать суперъяркие синие светодиоды.

Итак, для работы нам понадобится: 4 однополюсных переключателя; 4 синих светодиода; 4 патрона для них; резисторы для понижения напряжения с 12 В до номинала светодиодов; изоляционные термоусадочные трубки; паяльник с принадлежностями; пружинные клеммы (такие же, как мы использовали для постройки Fanbus'а); пластмассовая коробочка; разноцветные провода; лицевая заглушка от пятидюймового отсека; хотя бы начальные знания радиотехники. В данном конкретном случае были использованы светодиоды со следующими характеристиками: напряжение = 1,5 В, сила тока = 0,015 A. Отсюда следует, что нам понадобятся резисторы (12 В — 1,5 В/0,015 A) сопротивлением в 700 Ом или около того (можно и 750 Ом).

Как размещать и сверлить отверстия, думаю, вы догадаетесь сами — не впервой… В идеале для большей аккуратности можно использовать соединительные обжимные разъемы, как в автомобильном электропакете. Так можно легко демонтировать гаджет, не прибегая к паяльнику или, чего доброго, к кусачкам. Используемые переключатели имеют только два вывода, в принципе, подойдут и трехвыводные, где вам пригодятся только два контакта — третий можно изолировать или вовсе "откусить".

Перед пайкой выключатели лучше заранее вставить в отверстия лицевой заглушки — так легче паять. Во избежание замыкания и для пущей аккуратности рекомендую надеть на контакт термоусадочную трубку. Провод со свободным концом будет присоединяться к разъему блока питания.

А теперь самое сложное. Нам понядобятся четыре провода длиной примерно по 10 см для каждого выходящего контакта. Когда переключатель будет во включенном положении, напряжение будет подаваться от входных контактов на выходные контакты и к вентиляторам. Это нужно для того, чтобы каждый переключатель контролировал свой кулер.

Для контроля каждого переключателя в качестве индикатора его включенного состояния можно использовать не только синие, но и разноцветные светодиоды. Только будьте внимательны к их номиналам: они могут отличаться, и сопротивление резисторов нужно будет пересчитать. Резисторы и провода нужно присоединить одновременно к выходящим контактам. Не подсоединяйте резисторы к входным контактам, иначе светодиод будет постоянно гореть независимо от того, включен переключатель или выключен. Теперь аккуратно разложите провода и, разобравшись, что к чему, обожмите их в соединительных коннекторах. Теперь о присоединяемом к Baybus'у Fanbus'е. Принцип его постройки более подробно вы можете найти в прошлом номере КГ. В данном конкретном случае расположение клемм было немного изменено, но технически все то же самое. Подпаяв провода к клеммам зажимов, так же, как и в случае с Baybus'ом, обжимаем их противоположные концы в соединительных зажимах. Вот и все! Соединяем Baybus с Fanbus'ом, подключаем все это к компьютеру и… осуществляем TOTAL CONTROL над нашими кулерами.

Источник: http://www.nestor.minsk.by/kg/
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Все мужчины делают это

Автор: Евгений Золотов

Помните Йона Йохансена? Норвежский паренёк, которого пресса сегодня величает не иначе как "DVD Jon", заслужил своё прозвище и мировую славу в 99-м, когда написал программку DeCSS. Воплотившая в своём несложном коде уже существовавшую идею, она позволяла извлекать видеоконтент с защищённых от несанкционированного воспроизведения дисков DVD. За что её автор настрадался в судах и чуть было не сел в тюрьму. Сегодня имя Йона опять на первых полосах: его руками взломана защита очередного цифрового бастиона - теперь уже музыкального. Вы наверняка слышали про iTunes Music Store (iTMS) - Интернет-магазин музыки, основанный компанией Apple. Снятию защиты с музыкальных композиций, продаваемых в этом магазине, и посвятил себя в последние пару месяцев Йон.

Главная проблема iTMS общеизвестна: купив здесь композицию, пользователь оказывается сильно ограничен в средствах для её воспроизведения. Он может прослушать покупку во встроенном в iTunes плейере на своём компьютере, либо переписать её на носимый iPod от Apple. И в том, и в другом случае покупатель остаётся связан кровными узами с продуктами "яблочного гиганта". Что делать тем, кто не приемлет ограничений? По всей видимости, именно ответом на этот вопрос и должна была стать програма QTFairUse, которую Йохансен без каких-либо комментариев разместил на своём сайте неделю назад. Единственным намёком на её функциональность было полное название: QuickTime for Windows AAC memory dumper.

По поводу выпуска DVD-Йоном новой поделки прессой была моментально поднята шумиха, которая, вкупе с неразберихой первых дней, и породила диковатые слухи о том, что QTFairUse, якобы, использует некую лазейку в сервере iTMS и позволяет скачивать композиции, не платя за них. Слух этот, конечно же, действительности не соответствует. QTFairUse - находящийся в самой ранней стадии разработки инструмент, демонстрирующий возможность снятия защиты с музыкальных файлов AAC, распространяемых магазином iTunes. В своём нынешнем виде программа непригодна для большинства пользователей: её применение требует наличия специфических знаний и опыта программиста, а результатом работы становится полуфабрикат, для преобразования которого в файл, пригодный для воспроизведения MP3-плейерами, необходимо проделать ещё несколько дополнительных операций. Превратить QTFairUse в утилиту, теоретически, можно, но на этом пути и Йону, и его единомышленникам, которые, вероятно, появятся, предстоит решить немало технических проблем. Дело в том, что программа представляет из себя патч - "заплатку" для исполняемого файла основной iTunes для Windows. Внедряясь в код iTunes, QTFairUse следит за оперативной памятью и извлекает из неё сырые данные: iTunes самостоятельно расшифровывает защищённые файлы, а детище Йохансена просто пользуется плодами её труда.

Выложив программку на сайт, Йон никак не прокомментировал, что именно подвигло на её создание. Но кое-что можно почерпнуть из его последующих заметок. Дело в том, что Йона буквально завалили гневными письмами фанаты Apple, кричащие о крутизне идеи iTunes и о том, что на сей раз хакер зашёл слишком далеко. В ответ на что норвежец обозначил свою стратегическую позицию, оставшуюся неизменной со времён написания DeCSS: по мнению Йохансена, никто не может ограничивать естественные права человека (т.н. fair use). Частным случаем реализации такого права может быть покупка музыкальной композиции в iTunes и прослушивание её в Linux (для которой версии iTunes нет) или перенос этой композиции на какой-то портативный плейер для прослушивания самим покупателем. И создатели DVD в конце 90-х, и Apple сегодня покушаются на права личности, а потому попытки исправить эту ошибку нужно только приветствовать.

Оптимизму Йона можно позавидовать, но вот ему самому позавидовать сложно. Ведь разбирательство по делу DeCSS в Норвегии по-прежнему длится, весной государственным обвинителем была подана апелляция на оправдательный приговор и в начале декабря Йохансену предстоит снова встретиться со своими противниками в суде. И кто знает как отразится нынешний благородный порыв Йона на ходе судебного процесса. Непосредственная жертва всего случившегося, компания Apple, пока хранит молчание. Впрочем, она вообще редко что-либо комментирует. Возможно, её реакция ограничится выпуском обновлённой iTunes, которая сделает QTFairUse бесполезной и об истории забудут до тех пор, пока кто-то действительно не взломает защиту файлов AAC. Возможно, на Йона заведут новое дело. Нам же остаётся только радоваться тому, что люди, готовые пожертвовать собой ради общего блага, ещё не перевелись. Удачи тебе, Йон!

Источник: http://www.computerra.ru/
***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


IZone улыбается

Хакер.

***

Дышит?!

***

Покупка

Анекдоты

Ваша методика при написании диплома?
- Ctrl C - Ctrl V.

***

Получать зарплату - хорошо, а назначать ее другим - еще лучше.

***

Беседуют два программиста:
- Блин, вчера мне жена позвонила, а модем трубку снял.
- И что?
- Да болтали полтора часа.

***

- Хорошо клюет в этом озере?
- Клюет? Блин, да я должен прятаться за дерево, чтобы рыбы меня не разорвали, когда я насаживаю червяка на крючок.

***

Жена мужу, томно:
- Вась - ты хочешь миллион или...
- Никаких или!!!

***

Мужик вечером приходит с работы, а ему жена говорит:
- Слышь, тебя завтра премию за хорошую работу выдадут!
- А ты откуда знаешь?
- Да бабы говорят.
На следующий день мужик приходит на работу, ему выдают премию, он дико удивляется... Домой приходит, а ему жена:
- Слушай, тебя, говорят, в должности скоро повысят!
- Кто говорит?
- Да бабы говорят.
И точно, мужика скоро повышают по службе. Ну он, естественно, радуется, приходит домой и...
- Муженек, бабы говорят, тебя за недостачу завтра посадят!
Приходит на работу, его под руки и в тюрьму. Сидит он себе в камере, скучает, приходит к нему жена:
- Слушай, какого я адвоката тебе нашла! Он говорит...
- Зачем мне твой адвокат! Что там бабы говорят!?

***

Зима, лес, падает снег. По лесу ходит раздраженный медведь. То сломает елку, то пнет дерево, то на волка наорет... короче, обуял его гнев. Ходит и бормочет:
- Блин! Зачем я пил в сентябре кофе?!

***

- Иногда приходится жалеть, что твой друг не был большой свиньей, - вздыхал голодный Винни-Пух, обжаривая Пятачка на костре.

***

Художник говорит натурщице:
- Сегодня мы не работаем. Не снимайте платье, мы сейчас выпьем шампанского!
Вдруг раздается звук открывающейся входной двери. Художник испуганно:
- Быстро раздевайтесь! Моя жена идет!!

***

Проснешься утром, только лишь
Хлебнешь прокисшего рассолу,
С лица щетину соскоблишь -
И собираешь ранец в школу.

***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Win-комфорт

Сегодня в выпуске: Wallpapers (обои на Рабочий Стол), скины для проигрывателя Windows Media, визуальные стили для Windows XP.

Wallpapers (обои на Рабочий Стол)

1024x768 Скачать | 1024x768 Скачать
1280x1024 Скачать | 1280x1024 Скачать
800x600 Скачать | 1024x768 Скачать
1600x1200 Скачать | 1024x768 Скачать
1152x864 Скачать | 1024x768 Скачать

Ниже приведена инструкция, как установить обои на рабочий стол:

  1. Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Выбираем Фон > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Применить
  2. В WinXp делаем так: Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Раскрывается окно Свойства: Экран > Выбираем вкладку Рабочий стол > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Открыть > Нажимаем кнопку Применить
  3. Если вы скачиваете обои в архиве, то нужно разархивировать рисунок в нужную вам директорию, и далее как написано выше.

Работайте с комфортом!

***

Скины для проигрывателя Windows Media

Сайт программы: http://windowsmedia.com/

Скачать (1110 KB) | Скачать (691 KB)
Скачать (1347 KB) | Скачать (3866 KB)

Чтобы установить скин для проигрывателя Windows Media нужно:

  1. Кликнуть мышкой по ссылке скина.
  2. Запустится проигрыватель Windows Media и произойдёт скачивание и установка скина.
  3. В настройках программы, в списке скинов, задать нужный вам скин.

***

Визуальные стили для Windows XP

Визуальные стили (темы) включают в себя полный комплект для изменения внешнего вида Windows XP: shellstyle, desktop icons, user icon and wallpaper. Инструкцию по установке см. ниже.

Скачать (1124 Kb)

Для применения визуальных стилей, т.е. установки их, разработчики стилей рекомендуют использовать программу Style XP (или же TGT Soft's Style XP).
Данные программы "разрешают" Windows XP использовать неподписанные (без цифровой подписи) визуальные стили.

Инструкция для установки стиля:

  1. Загрузите визуальные стили .zip в ваш компьютер
  2. Извлеките .zip файл в эту директорию: %windir%\resources\themes\ (вероятно c:\windows\resources\themes\)
  3. Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Затем Темы > Выбираем из списка доступных тем нужную и нажимаем кнопку Применить
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Пароль - иллюзия или защита

Автор: Shadow (www.Goblin-home.narod.ru)

В данной статье предлагается рассмотреть один из наиболее известных и старых методов обеспечения безопасности - пароль, и попытаться сделать так, чтобы пароль в вашей компьютерной системе был реальной, а не иллюзорной защитой и мог на самом деле защитить ваши секреты от злоумышленника.

В настоящее время проблема защиты информации в компьютере от несанкционированного доступа (НСД) приобретает все более серьезное значение, особенно когда информация в компьютерах становится важной для организации. Причем, не стоят на месте ни разработчики систем защиты, ни взломщики. О проникновении в компьютерные системы банков, страховых компаний и даже в закрытые военные сети сегодня можно узнать из регулярных газетных сообщений. Количество компьютерных преступлений, не смотря на принимаемые специалистами меры, отнюдь не уменьшается год от года, а даже напротив растет.

При этом практически во всех вскрытых системах один из применяемых элементов защиты - пароль (а в некоторых он единственный), который многие пользователи и руководители считают непреодолимым препятствием.

В данной статье не будут рассматриваться программные способы "вычисления" и вскрытия пароля. Мы попытаемся рассмотреть этот вопрос с позиции организации работы пользователя с паролем, уточнить некоторые аспекты работы парольной системы, а так же дадим некоторые рекомендации для разработчиков и пользователей компьютерных систем, как сделать пароль не просто иллюзией защиты, а действительно серьезным препятствием на пути злоумышленников.

Прежде всего, напомним, что защиту информации в компьютерах обязательно следует рассматривать как комплекс мер, включающих организационные, технические, юридические, программные, оперативные, страховые и даже морально-этические меры.

Что же такое пароль? Военные говорят: "пароль - это секретное слово, позволяющее определить кто 'свой', а кто нет". С точки зрения компьютерной безопасности это определение можно немного добавить и расширить: "пароль - это секретный набор различных символов, позволяющий определить законного пользователя и его права на работу в компьютерной системе".Что же такое пароль? Военные говорят: "пароль - это секретное слово, позволяющее определить кто 'свой', а кто нет". С точки зрения компьютерной безопасности это определение можно немного добавить и расширить: "пароль - это секретный набор различных символов, позволяющий определить законного пользователя и его права на работу в компьютерной системе".

Пароль - только один из элементов системы разграничения доступа. По оценкам экспертов по компьютерной безопасности он используется практически в любой компьютерной системе, а во многих системах как единственное средство защиты, и, в связи с этим, в большинстве компьютерных систем именно стойкость пароля к вскрытию определяет безопасность всей системы. Но любой, даже самый надежный элемент, не обеспечит защиты, если он один, а не в системе. Значит, и пароль должен быть в системе в парольной системе, которая является составной частью системы разграничения доступа, а в итоге - в общей системе безопасности.

Подбор пароля

Вначале пароль надо придумать. И это один из самых важных и сложных вопросов. Какие слова в качестве пароля возьмет обычный пользователь? Скорее всего, те, какие не сразу забываются. Но ведь чем легче пароль для запоминания, тем легче его подобрать!

Небезызвестный вирус "Мориса" использовал чуть меньше 400 слов в качестве пароля и поразил около 6000 компьютерных систем. И, конечно, не бедность английского языка, а слабое воображение пользователей открыло двери вирусу. Вдумайтесь в эти цифры: 6000 и 400, то есть, в среднем каждые 15 систем имели одинаковые пароли!

На сегодняшний момент существует масса специальных программ для автоматизированного подбора пароля, которые используют свои огромные словари для его подбора. Например, программа Claymore, бесплатная программа NETCRACK, использует метод перебора для угадывания любого пароля пользователя в сетях NetWare. Это касается не только сетей. Существует так же программа CRACK, методом перебора ищущая пароль, используемый в программе архивации данных PKZIP. Весь вопрос в скорости перебора. Однако, если времени достаточно много и применяемый компьютер достаточно быстродействующий, то никакой пароль не сможет защитить систему от взлома. Именно поэтому надежда многих пользователей только на пароль наивна.

Какие правила можно рекомендовать при выборе пароля?

1. Запрещается использовать:

  • имена, фамилии, даты рождения детей, близких, знакомых, их комбинации, номера телефонов и любую другую личную информацию (типа ОЛЯ070576 или ИВАНОРЛОВ) и т.п. Как показывает практика любимые женские пароли это имена свои и своих детей и их производные (Таня – Танюшечка, Танюшенька и т.п.);
  • названия городов, стран, фирм, организаций, учреждений, специфических компьютерных слов, термины из своей предметной области;
  • слова из заставок задач или названия самих компьютерных систем (например, netware, windows, msdos);
  • широко распространенные слова, названия фильмов, книг, имена любимых литературных героев и пр.;
  • повторяющиеся символы (например, пароль типа "аббббб" раскрыть значительно легче, чем "алугыс");
  • набор символов, расположенных на клавиатуре рядом (“знаменитые” пароли: 111111, 12345, йцукен, qwerty и т.д.) или по простому закону (например, через клавишу - йуегщх; по две в ряду - йцфыяч и т.п.);
  • нельзя использовать один и тот же пароль одновременно в разных системах. Это прекрасная возможность для хакера проникнуть в систему.

2. Рекомендуется использовать:

  • Переключения различных регистров (рус., англ.). Попробуйте набрать русское слово на английском регистре или наоборот, получите бессмысленный набор, вполне подходящий для пароля. Можно, например, взять слово из любого (желательно не английского) языка и его звучание на русском языке набрать на английском регистре. Например, если грузинское слово "камарджоба" набрать русскими буквами на английском регистре, то получится "rfvfhl;j,f" - попробуйте такой пароль подобрать.
  • Использовать при формировании пароля как можно большее количество символов, конечно, если это допускает система (ведь компьютер позволяет использовать 256 символов). Например, сочетания букв и цифр, а также больших и маленьких букв в одном пароле (например, "ащночс" и "АщНоЧс" для компьютера - две большие разницы) значительно усложняет его подбор;
  • Если с фантазией «напряженка» попробуйте просто связать два слова вместе, например: «ЯГений», «МояЖенаУмница», «ЛюблюВасю»

Общая идея такая: самый лучший пароль - случайный и бессмысленный набор символов. Например: A18DtH52YreTXpDx

Предвижу возражения типа: "Бессмысленный набор символов очень трудно запомнить!". Что ж, это действительно так, но в этом случае можно рекомендовать еще одну маленькую хитрость. Составляйте пароль из первых (вторых и т.п.) букв запомнившейся фразы, четверостишья, песни, поговорки. Например, возьмем знакомое всем (или почти всем) стихотворение Некрасова:

Однажды, в студеную, зимнюю пору,
Я из лесу вышел, был сильный мороз.

Составляем пароли: "осзпяилвбсм" (из первых букв слов), "дтиозеыыио" (из вторых букв слов, хотя это и сложнее при наборе – сообразить какая буква вторая) и т.п. Получились бессмысленные наборы символов, которые, однако, очень просто запомнить.

И еще одно небольшое, но существенное замечание: какой длины должен быть пароль? Правило: чем больше, тем лучше, в данном случае, не совсем оправдано. Пароль, содержащий два-три десятка бессмысленных символов, трудно ввести в машину без ошибок. Ответ на этот вопрос существенно зависит от того набора символов, которые парольная система позволяет применять при формировании пароля (одно дело, только русские буквы или цифры, и другое - все 256 символов ASCII). В общем случае (опыт работы это подтверждает) можно рекомендовать использовать для пароля от 6 до 10 символов, и как наиболее оптимальный вариант - 7-8 символов. Опросы хакеров, проведенные американскими компьютерными журналами, говорят о том, что если в системе защиты используется длина пароля 7 и более символов, то заниматься простым его подбором бессмысленно. В этом случае для "вскрытия" пароля применяют другие способы: использование специальных программ (контроль нажатия клавиш, имитаторы входа в систему и т.п.), оперативное наблюдение, подкуп, шантаж и другие действия по отношению к человеку, который его знает. Да и запомнить 7 случайных символов все-таки возможно.

Озадаченный читатель может возразить: "То нельзя, это не рекомендуется - так и комбинаций не хватит!" Вот тут-то как раз и нечего бояться чего-чего, а их хватит на всех.

Посмотрите внимательно на клавиатуру: 33 русских буквы, 26 английских (да все это еще и на 2-х регистрах), цифры от 0 до 9, специальные символы (.,*!"#;' и т.д.). Всего около 160 символов, из которых можно составить пароль.

Чем больше длина пароля и шире набор используемых символов, тем сложнее его подобрать. Даже если предположить, что пароль будет найден после перебора только одного процента всех комбинаций, то пароль из 8 символов (если при его формировании можно было использовать 160 символов) дает стойкость в 100 лет, что для сохранности большинства коммерческих и банковских секретов вполне достаточно.

Однако следует предостеречь и от излишнего усложнения пароля. При выборе пароля не забудьте, что вам его еще нужно будет набирать его на клавиатуре. Когда в одном пароле присутствуют и английские и русские символы, набираемые на обоих регистрах, да еще и какие-либо специальные символы, вводить его с клавиатуры будет затруднительно. "Знай меру!" – говорили древние.

Хранение пароля пользователем

В мировой практике считается, что пароль, как единственное и самостоятельное средство защиты, применяется при низких требованиях к системе безопасности. Одна из причин такого подхода в том, что пользователи, не надеясь на свою память, будут записывать его в различных, не предназначенных для этого местах (перекидной календарь, записная книжка, пропуск и т.п.). Посмотрите внимательно за сотрудником, включающим компьютер. Куда он посмотрит, перед тем как ввести пароль. Нередко его взгляд падает на угол дисплея, где среди нескольких прилепленных клочков бумажек есть и клочок с паролем. Отсюда возникает новая проблема безопасности - где и как хранить пароль?

Список наиболее часто используемых паролей на английском языке:

aaa | boy | flover | light | pivo | square
abc | can | force | little | police | standard
academia | castle | friend | long | prince | star
advanture | cat | fun | lord | protect | station
advanture | center | george | love | quest | street
aerobics | chance | girl | mad | rain | success
afgan | chaos | golf | magic | ranger | summer
albert | cherry | gray | major | real | super
alex | club | great | mark | red | sweet
alexander | coctall | green | market | remote | system
alexey | computer | haliava | master | risk | target
algebra | cretin | hand | mega | river | team
aliases | cross | handra | metal | robot | tiger
alien | data | havimetal | michael | roman | time
alpha | death | hell | mike | room | toy
alphabet | december | hello | mister | rose | trade
ama | delta | help | mister | rubl | true
amorphous | debil | hero | moscow | ruslan | ukrain
analog | denis | hockey | mouse | russia | unknown
anchor | dima | horse | music | sasha | valentin
andrei | dmitriy | idiot | natalia | scott | victor
andrey | dog | igor | netware | scotina | visit
andromache | dollar | ilya | network | school | vlad
animals | doichmarkа | info | nice | secret | vladimir
ann | doom | irene | night | sensey | water
answer | door | iron | normal | serge | west
anton | dos | jazz | north | sergei | white
apple | dragon | job | old | sergey | wild
band | dream | jorik | oleg | service | wind
bank | durak | julia | omega | sex | windows
baron | eagle | jury | panel | shadow | wolf
bear | east | karate | paradise | shark | yorik
beat | easy | killer | password | shit | yurist
beatles | elena | kirill | pavel | shop | yurik
best | eugene | knight | persona | simple | zap
beta | eye | kostya | peter | sky | zone
black | field | land | philip | slava | zoloto
blue | filter | larri | phone | smile | zoo
board | filer | last | pilot | sound | znachek
boris | finish | legal | pitsa | south | zad
boss | float | lenin | pizza | Spi | zadnica
***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Как наложить на AVI-файл две или более аудиодорожки

Автор: Shadow (www.GOBLIN-HOME.narod.ru)

Иногда возникает необходимость наложить на имеющийся фильм еще одну или несколько звуковых дорожек, например, перевод, с тем, чтобы потом наслаждаться любимым фильмом в оригинальном звучании или на любом другом языке. Проигрывать такие многодорожечные фильмы можно в BSplayer или Media Player Classic .

Где взять переводы?
Достать их можно несколькими способами. Например, посетить Glanz или DVD Special - на этих серверах можно найти много качественных переводов от разных переводчиков; в этом случае нам придется микшировать скачанный перевод с оригиналом. Достать качественный перевод можно также из другого фильма: часта ситуация, когда есть два (или более) фильма, один с качественным дубляжом, но плохой картинкой, а другой - с качественной картинкой, но никуда не годным переводом. В таком случае вынимаем качественную звуковую дорожку из фильма и склеиваем ее с качественной картинкой.

Итак, мы имеем готовый фильм и несколько аудиотреков, которые хочется приклеить к фильму. Запасаемся необходимым программным обеспечением:

  • Любой звуковой редактор, имеющий простейшие функции - микширование, регуляция уровня громкости и т.д. (я пользуюсь GoldWave 5, shareware)
  • NanDub (но лучше VirtualDubMod).

Самое неприятное, что нас может ожидать – это рассинхронизация звука.

Что это такое?
Это расхождение звука и видео по времени, когда звук может отставать (чаще всего), либо забегать вперед. Рассинхронизация бывает постоянная (т.е. звук отстает/спешит на пару секунд в течении всего фильма) или прогрессирующая (когда временной разрыв звука и видео постоянно увеличивается). Постоянная рассинхронизация часто встречается при попытке выдрать звук из одного фильма и вставить его в другой; прогрессирующую рассинхронизацию. можно часто встретить в переводах от Glanz.

Для начала проверяем, совпадают ли звуковые потоки в нашем фильме и в переводе. Простейший способ: открываем любым видеоплейером наш фильм, убавляем громкость примерно на треть и ставим на паузу. Открываем любым аудиоплейером присоединяемый аудиотрек и также ставим на паузу. Смотрим, совпадают ли треки по времени звучания, выписываем время на отдельный листочек – пригодится. Затем быстро нажимаем на кнопки воспроизведения в обоих плеерах и смотрим, совпадает ли звучание в оригинале и накладываемом треке. Если обнаружилась рассинхронизация – определяем ее тип: постоянная или прогрессирующая?

Рассинхронизация постоянная, что делать?

Ничего страшного, засекаем в плеере на сколько секунд отстает/спешит звук и открываем накладываемую аудиодорожку в звуковом редакторе. Здесь я покажу все на примере GoldWave, но можно воспользоваться любым другим редактором – принцип работы одинаков.

  • Итак, запускаем редактор и кромсаем перевод.
  • Идея проста: если звук отстает на пару секунд, то отрезаем в начале аудиодорожки эти недостающие пару секунд (режем только тишину!), если же звук спешит – дописываем в начало пару секунд тишины. Главное следить, чтобы время звучания кромсаемой аудиодорожки совпадало с оригинальным фильмом. Если в процессе правки мы подогнали звук, но время при этом сократили/увеличили – идем в конец трека и дописываем/отрезаем лишние секунды.
  • Если накладываемый перевод был выдран из другого фильма, то часто встречается несовпадение в начале фильма: в одном варианте фильм может быть записан с логотипом кинокомпании, а в другом без. Не беда, стандартный логотип длится 15-20 секунд, засекаем точнее и правим аудиодорожку. В GoldWave правка проста: кликом правой кнопкой мыши отмечаем начальную позицию, затем вторым кликом конечную. На этом этапе можно ограничиться командами Cut, Copy, Paste; для упрощения навигации можно воспользоваться кнопками масштабирования (Sel – увеличивает выбранный участок, All – показывает всю дорожку).
  • После правки сохраняем результат в MP3 с любым желаемым битрейтом. К сожалению, GoldWave не всегда корректно пишет MP3-файлы такого объема, поэтому в нем сохраняем WAV 16 бит стерео, а потом любым способом конвертируем в MP3 (как это сделать с помощью Неро. Следует однако помнить, что слишком высокий битрейт может сильно отразиться на размере конечного видеофайла. Так что, если мы собираемся накладывать три и даже более аудиотрека, то особо высоким битрейтом лучше не увлекаться. Рассчитываем на то, что двухчасовая MP3 48 kHz 96 Kbit дорожка занимает 50-70 МБ, следовательно, на столько же увеличится размер конечного видеофайла

Рассинхронизация прогрессирующая, как быть?

Тут сложнее, т.е. придется править весь накладываемый аудиотрек, а это может занять много времени. Для начала, семейством Дубовых вынимаем из нашего фильма оригинальную звуковую дорожку. В VirtualDub и NanDub это делается так: File->Open video file… (открываем наш фильм), затем File->Save WAV… Несмотря на то, что Дубы пишут WAV, дорожка сохраняется в MP3. В VirtualDubMod: File->Open video file…, затем Streams->Stream list->Save WAV. Открываем обе аудиодорожки (оригинальный и накладываемый треки) в звуковом редакторе и начинаем правку (только накладываемого трека, оригинал не трогаем!).

Если к точности накладываемого перевода не особо придираться (такое можно заметить в переводах одним голосом – голос переводчика зачастую не совпадает с голосом актера, обычно немного запаздывает), то достаточно править аудиодорожку каждые 10-15 минут фильма, просто подгонять под голос оригинального трека, для чего периодически нажимать кнопку воспроизведения и сверяться.

Если же постараться добиться полного совпадения перевода с артикуляцией губ актеров, то придется попотеть: правка двухчасового фильма занимает в среднем 2-3 часа. Могу добавить, что с каждым новым фильмом этот процесс ускоряется :) Правим точно так же, как и при постоянной рассинхронизации, только всю дорожку: вырезать/вставлять тишину нужно между речью переводчика. Сверяем время звучания с оригиналом и сохраняем результат.

Если перевод был скачан от Glanz или Goblin, то нам понадобится смикшировать его с оригиналом. Для начала проверьте уровень громкости оригинала и перевода. Звучание оригинального трека должно быть четким, хорошо слышимым и, в то же время, не забивать перевод. Если оригинал забивает перевод – уменьшаем оригиналу громкость. В GoldWave для этого выделяем всю оригинальную дорожку и кликаем на кнопку Change volume. В открывшемся окне уменьшаем громкость либо на 6, либо на 12 dB зависит от конкретного фильма, лучше поэкспериментировать Затем, выделяем весь вставляемый трек, жмем кнопку Copy, кликаем на заголовок оригинального трека и жмем Mix. Выставляем позицию для микширования на 00:00:00.00000 и кликаем ОК. Получаем микшированную аудиодорожку и сохраняем ее в MP3 (в GoldWave в WAV 16 bit stereo, затем любой программой в MP3).

Клеим треки

Итак мы собрали весь необходимый материал: наш фильм с оригинальной звуковой дорожкой и перевод(ы). Теперь нам нужно собрать все это в единый файл.

Если дополнительный трек всего один, достаточно воспользоваться NanDub. Открываем наш фильм File->Open video file…, идем в Audio->Secondary stream и в (VBR) MP3 audio... выбираем наш перевод.Следим, чтобы в Audio, Audio->Secondary stream и Video стояло Direct stream copy, затем идем в File->Save as AVI… даем имя конечному файлу и ждем пару минут, пока не получим готовый фильм с двумя звуковыми дорожками.

Если необходимо присоединить более двух дорожек, нам поможет VirtualDubMod. Им же, в случае чего, можно отрезать лишние аудиодорожки. Открываем наш фильм File->Open video file…, идем в Streams->Stream list. Теперь, кнопкой Add мы можем добавлять любое количество аудиодорожек (я пробовал до восьми), кнопками Move up/down выставляем порядок, в котором будут идти дорожки, кнопкой Disable убираем лишние дорожки.

Не забываем выставить в Video Direct Stream Copy и записываем наш полностью собранный фильм в File->Save as…

Готово!
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Командуем файлами

Автор: Alex, editor@izcity.com

Наш сегодняшний герой, файловый менеджер JExplore, может поспорить с самыми популярными подобными программами в вопросах функциональности. Однако, перед всеми распространёнными файловыми менеджерами такого типа, например, Windows (Total) Commander и подобными, у JExplore есть существенное преимущество: разработчики распространяют этот продукт совершенно бесплатно.

JExplore представляет собой файловый менеджер панельного типа. Для комфортного и наглядного управления файлами возможностей JExplore более чем достаточно. Вот основные и наиболее востребованные функции этой программы: работа с архивами многих форматов (ZIP, RAR, ARJ, LHA, CAB, TAR, ACE), встроенный браузер на движке Internet Explorer, FTP клиент, монитор отправки/получения почты со встроенным фильтром спама, соединение с интернетом (дозвон может осуществляться прямо из окна программы).

Файловый менеджер JExplore не требователен к ресурсам компьютера. Минимальные системные требования для нормальной работы таковы:

  • Microsoft Internet Explorer 4.0 и более поздние версии
  • 8 мб свободного места на жёстком диске
  • Pentium 100-MHz
  • Windows 95/98/ME/NT4/2K/XP

Окно интерфейса JExplore:

Давайте зададим основные вопросы, касающиеся файлового менеджера JExplore, и ответим на них.

Как управлять файлами с помощью JExplore?

  • JExplore использует интерфейс, похожий на проводник Windows, поэтому освоение этого файлового менеджера не вызовет больших трудностей.
  • Двойной клик мышью на файле, в одной из панелей JExplore, приведёт к запуску данного файла.
  • Для открытия папки (директории) нужно дважды кликнуть на ней.
  • Правый клик мыши вызывает контекстное меню файла или папки.
  • В программе поддерживается функция Drag-and-Drop (перетаскивание файлов и папок мышью).

Как пользоваться браузером, встроенным в JExplore?

  • Наберите адрес сайта в командной строке и нажмите клавишу Enter. Начнется загрузка выбранного сайта прямо в одной из панелей файлового менеджера (загрузка начнётся в той панели, в которой набирался адрес).
  • По клику мыши, по пиктограмме в панели инструментов, вызывается Избранное браузера Internet Explorer. Двойной клик мыши, по одному из пунктов Избранного, позволит начать загрузку выбранного адреса.
  • В JExplore предусмотрены функции добавления, удаления, организации Избранного.

Как пользоваться FTP клиентом?

  • В настройках программы задайте данные FTP сервера.
  • Для записи/чтения файлов на FTP сервере, используйте функцию Drag-and-Drop (перетаскивание файлов мышью).

Как работать с архивами?

  • Для сжатия файлов используйте диалог вызываемый по кнопке Pack на панели инструментов файлового менеджера.
  • Для извлечения файла дважды кликните на нём мышью и укажите директории, куда извлечь файл, или используйте диалог меню Unpack, вызываемый на панели инструментов.

Файловый менеджер JExplore поддерживает различные плагины. Более подробно об установке и настройке плагинов читайте в файле справки или на сайте программы.

На момент написания статьи, на сайте разработчика, доступная версия программы: 1.7.0.4.

Скачать JExplorer 1.7.0.4 можно отсюда (2419 кб)

***
Рекомендуем
Хотите сыграть в пейнтбол?
Отличительная черта этой игры - ее полная демократичность. Маркер (оружие для игры в пейнтбол) уравнивает в правах всех - от банкиров и дипломатов до студентов и инженеров. Когда все облачены в камуфляж и маски, то разница в социальном статусе практически незаметна.
Подробнее >>


Полезная софтинка. Выпуск 1

Автор: Сергей УВАРОВ

Приветствую всех почитателей полезного софта! Хороший софт всегда высоко ценился, а полезный софт тем более. Поэтому предлагаю вам обратить свое внимание на цикл статей, посвященных исключительно интересным и полезным программам, которые, уверен, займут почетные места на ваших винчестерах. Приступим?

Startup Extractor 1.25

Скачать: http://supex.by.ru/supex125.zip

Startup Extractor — менеджер автозагрузки от харьковского разработчика Сергея Тарасенко. Назначение утилиты стандартно — облегчение управлением системными программами, запускающимися при старте Windows. В число подконтрольных объектов программы входят системный реестр, папка автозагрузки и файл win.ini, также возможны поддержка до 11 групп автозагрузки и отображение полной информации о выбранных программах. Утилита имеет интуитивный интерфейс, позволяющий легко разобраться во всей возможностях утилиты всем пользователям, уже имеющим опыт работы с подобным типом утилит. К числу основных функций программы относятся:

  • добавление и удаление новых программ в автозагрузку (доступен режим drag'n'drop);
  • редактирование параметров запускаемых программ;
  • сохранение и восстановление списка автозагрузки;
  • временное отключение программ;
  • мониторинг добавления новых программ в автозагрузку.

Кроме того, программа позволяет получить быстрый доступ к таким инструментам системы как редактор реестра, редактор файлов настройки, планировщик заданий, а также к основным системным папкам.

Утилита может работать в Windows 9x-XP, имеет русский интерфейс и незначительный размер дистрибутива (80 Кб), не требует установки. Единственная замеченная мною неприятная особенность работы утилиты — слишком много для своего размера она занимает места в памяти (более 7 Мб).

WinBar 1.2.95

Домашняя страница: http://www.winbar.nl

Скачать: http://home.concepts-ict.nl/~lunenburg/winbar/WinBar 1.2.95 Setup.exe

Довольно часто на страницах нашего еженедельника упоминались программы, позволяющие изменить интерфейс Windows: это и различные tweaker'ы, и оболочки для рабочего стола, и дополнительные стили интерфейса. Однако эти программы как правило обходят вниманием различные элементы управления, что вызывает чувство незавершенности разработки. Одним из таких обделенных участием элементов является панель Быстрого запуска (Quick Launch), что в итоге и привело в появлению большого количества альтернативных разработок. Не так давно мне на глаза попалась утилита WinBar, которая, несмотря на довольно-таки молодой свой возраст, уже признается одним из лучших представителей своего класса. По умолчанию панель располагается в верхней части экрана и предназначена для полного информирования пользователя о различных процессах, происходящих в системе. Все процессы представлены в виде отдельных модулей, коих насчитывается 19 видов: загрузка процессора, полный объем дискового пространства и объем свободного места, объем общей и свободной оперативной памяти, изменение громкости, модуль управления Winamp'ом, текущее разрешение экрана, мониторинг поступления электронной почты, синхронизация времени, поиск в Интернете с помощью Google, просчет входящего и исходящего трафика и т.д. Для выбора необходимого модуля предназначен Winbar Configuration, причем конфигурацию модулей можно менять по своему желанию, сохраняя необходимые параметры в виде соответствующего профиля. Из дополнительных возможностей необходимо отметить возможность смены цветового и графического оформления программы,

WinBar распространяется бесплатно, размер дистрибутива всего 325 Кб, работает под Windows 9x-XP, наличие английского языка интерфейса не должно поставить в тупик пользователя — все просто и прозрачно, только успевай пользоваться :-).

DocRepair v.2.10

Скачать: http://download.jufsoft.com/download/docrepair2.exe, http://active.jufsoft.com/download/docrepair2.exe

Можно сказать, что времена, когда у пользователя «летела» лишь система, давно прошли. Сегодня «благодаря» ошибкам различных программ и вирусам можно потерять самое главное — информацию. И если крах системы успешно лечится переустановкой, то ошибка доступа к документным файлам (например, тех же .doc и .rtf) может привести к значительно более печальным последствиям. Одной из множества программ, позволяющих восстанавливать текстовые файлы, является программа DocRepair. Текущая версия работает с .doc-файлами, созданными в MS Word 95, 97, 2000, XP, включая версию Word для MacOS. Позволяет восстанавливать файлы, скопированные с дискет/CD с ошибками, после вирусных атак, при резком завершении работы MS Word с последующей невозможностью открытия файла. Интерфейс выполнен в виде мастера, в полностью автоматическом режиме предлагающего на каждом этапе дополнительные опции для более корректного и успешного восстановления документа. Например:

  • восстановление документа, содержащего текст на языке, отличном от английского;
  • возможность восстановления графических элементов;
  • просмотр документа в собственном окне программы после операции восстановления.

Насколько я могу судить, программа выполняет свои прямые обязанности очень качественно. С ее помощью после большого промежутка времени мне удалось восстановить почти 200-Мб документ с большим количеством графики, который в один далеко не прекрасный день просто не открылся. DocRepair исправил эту проблему — при том, что документ содержал текст исключительно на украинском языке.

Программа работает под Windows 9x-XP, shareware, имеет английский интерфейс, размер дистрибутива 654 Кб.

На сегодня все.

Источник: http://www.mycomp.com.ua/
***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Файлы в кусках

Автор: Наталья ЛИТВИНЕНКО

Ох уж эти мне дискеты! Ну понятно, еще в ХХ веке, но в XXI-м! Маленькие, быстро портящиеся… Но все же ничего у нас без них не получится. А потому — приходится с охом и вздохом продолжать пользование оными. Ничто, однако, не мешает нам различными методами компенсировать неудобство самого распространенного носителя. Самый большой недостаток дискеты — ее малая емкость. Увеличить объем носителя нам поможет программа fformat. Но поскольку размеченную на 1.7 Мб дискету тот же Windows 2000 не понимает (интересно, кстати, не понимает: свободное место видит, а файлы — нет), то, вместо увеличения объема, будем уменьшать файлы, разрезая их на части. Замечу, что все программки-«резалки», описываемые в этом обзоре, бесплатны. Итак, начнем!

FCutter 1.17.22

  • Размер дистрибутива: 28 Кб
  • Местожительство: http://www.fsoft.tk, http://fsoft.h10.ru
  • Местокачательство: http://www.geocities.com/fsoftdev/fcutter.zip

Прежде всего перетаскиваем нуждающийся в разрезании файл из «Проводника» на желтую «посадочную площадку» вверху окна софтины. Резать можно только на куски трех указанных размеров, произвольные части не дозволяются. Умная софтина подскажет вам, сколько дискет понадобится. Указываем, куда складывать куски, и если на дискету, то чистить ли ее перед тем. Опасный пункт — как бы не удалить чего нужного. По нажатии кнопки Сut FCutter начинает трудиться. В результате мы получаем куски заданного размера и BAT-файл, по запуску которого все склеивается обратно. Кстати, куски соединяются с помощью обычного метода copy/b, то есть, например, если нужно объединить file.001 и file.002 в file.zip побайтно, пишем:

сору/b file.001 + file.002 file.zip.

После соединения кусков собственно куски и сам «батник» удаляются. Насчет немедленного удаления кусков — это зря: чуть что не так пойдет, сшить заново не получится — части уже удалены. Итак, «батник» был запущен, полученный архив разархивирован, картинка из него просмотрелась — жить и работать можно. Хелпа нет, да он и не особо нужен.

AutoCutIt!, версия 1.5

  • Размер дистрибутива: 196 Кб
  • Местожительство: http://www.s-melnikov.nm.ru
  • Местокачательство: http://kingmidas.hypermart.net/autocut.zip, http://www.s-melnikov.nm.ru/files/autocut.zip

Для выбора файла, а также места, где будет размещен результат, используется стандартный диалог. Размер частей представлен более длинным списком, также можно указать произвольный метраж, просто вписав его в закрытый выпадающий список. Под списком программа пишет, сколько частей получится. Процесс начинается по нажатию кнопки Старт. Можно поставить птичку Спрашивать дополнительно о каждой части, и тогда после начала работы кнопка «Старт» превратится в кнопку Далее — пока не нажмешь, продолжения не будет. И «птицу» ставила, и размер указывала нестандартный — все отработало. После окончания «резки» все поля на форме очищаются, что не совсем удобно, может, я бы повторила процедуру, но уже в другую папку и разрезав на другие части. В результате у нас будет несколько файлов, один из которых экзешник — сборщик. Нужно отметить, что части получаются больше заявленного размера (у меня на 15–17 Кб), потому при нарезке указывайте соответственно меньшие габариты. Итак, запускаем «сборщик». По нажатию кнопки Старт утилита спрашивает, куда класть результат. Части и самого себя «сборщик» не удаляет.

Я издевалась над программой, как только могла. Например, когда оная отработала, запустила ее еще раз, с тем же файлом, с той же папкой результата. Интересно было, что она предпримет, когда встретит файл с таким же именем, как тот, который она хочет записать. Программа не растерялась: столкнувшись с проблемой, вывела вопрос: «найден файл, накрыть ли, да/нет/отмена». В общем, все на пятерку.

PieceCopy, версия 1.2

  • Размер дистрибутива: 243 Кб
  • Местожительство: http://www.inner-smile.com/dl_piece.htm
  • Местокачательство: http://www.inner-smile.com/PieceCopy.EXE

Эта программа несколько отличается от двух предыдущих — она предлагает вырезать из файла кусок от такого-то и по такой-то байт. Можно, конечно, с ее помощью вручную «нарезать» файл на кусочки, а потом собрать по copy/b. Но мне кажется, что утилита предназначена не только и не сколько для этих целей.

Cutter 2.2

  • Размер дистрибутива: 202 Кб
  • Местожительство: http://cutter22.chat.ru
  • Местокачательство: http://cutter22.chat.ru/cutter22setup.exe

Позволяет выбрать несколько методов нарезки и последующего соединения. Можно собирать куски «батником», а можно, «добавив к первой части исполняемый модуль» (из пояснения программы), получить собирающую экзешку. Размер частей выбирается из списка или прописывается самостоятельно. Когда идет процесс «резьбы», программа чуть ли не со вздохом сообщает в заголовке информационного окна Работаю… По завершении столь тяжкого труда появляется соответствующее сообщение и на нас вылетает проводниковое окошко, в котором имеются папочка с кусочками и «сборщиком». Куда складывать части, не спрашивает, сама знает.

«Батники» соединили куски успешно. Второй должен был еще и архив запустить, чтобы его подобрал дежурный архиватор, но у меня не сработало. Сборщик-экзешник вывел окошко, по нажатии кнопки отработал и исчез. Интерфейс «отечественный».

KFK

  • Размер дистрибутива: 799 Кб
  • Местожительство: http://www.katarncorp.com, http://www.katarncorp.com/index.php?download
  • Местокачательство: ftp://ftp2.katarncorp.com/katarnco/files/kfk.exe, http://www.tucows.com/preview/196049.html

Программа отличается дизайном в стиле XP, интерфейс многоязычный и легко настраивается. Устанавливать язык не пришлось — утилита разобралась сама, что я есть немножко говорить по-русски. Перевод качественный. С помощью стандартного диалога указываем разбиваемый файл, а также куда помещать полученные части. Вариантов, как «разбить» файл, множество. Можно указать, на сколько частей «резать», а также размер части — то ли из заранее предусмотренного списка, то ли выставить свой собственный (в байтах, килобайтах или мегабайтах). Есть специальный режим записи прямо на дискеты (кнопка Дискеты в боковом меню).

Как собирать? Можно или создать файл для автовосстановления (как это называется в программе), или собирать программой же (кнопка Восстановить). Причем в последнем случае, когда указываешь программе, где лежат куски, она в диалоге показывает не части, а как бы уже собранный файл. Есть опция, позволяющая после сбора удалять части. Все проверила — программа со сборкой справилась. Провокации с записью следующего разбиения на то же место программа выдержала. Но все равно, впечатление самое благоприятное.

WinSplit

  • Размер дистрибутива: 394 Кб
  • Местожительство: http://www.everlong.co.uk
  • Местокачательство: http://myweb.tiscali.co.uk/cullis/everlong/winsplit/WinSplitSetup.exe

Эффектный дизайн, но функциональности маловато. Размер частей указывается в меню View > Options. Куда части класть, не спрашивает. Команда Split — и сразу начинает делить. Можно собирать «батником», а можно и программой (тогда создает дополнительный (мелкий) файл с расширением .spl). Меню File > Build спрашивает, где лежат части, а потом собирает. Оба метода сборки отработали успешно.

JoneSoft

  • Размер дистрибутива: 911 Кб
  • Местожительство: http://members.ozemail.com.au/~jaesenj/software/software.html
  • Местокачательство: http://members.ozemail.com.au/~jaesenj/downloads/jsfs.exe

При первой загрузке программа сурово предупредила меня, что бесплатно работать с ней могут только home-пользователи или люди, не преследующие коммерческих целей. Конторам просьба заплатить. Попугав таким образом, программа милостиво загрузились и предложила поработать. Две вкладки — слом и сборка, начнем с деления. Выбираем диалогом, что ломаем и куда крушим, причем пусть вас не смущает серая строка в последнем случае, где программа по умолчанию указывает ту же директорию, откуда берется ломимый файл. Указав, что нужно «резать», определяемся с размерами частей — и тут программа вновь пугает. Дескать, пока мы не определимся, будем делить файл по размеру или по количеству частей, дополнительный выпадающий список с параметрами она не отрисует. Если «резать» по размеру, то можно выбрать значение из списка или вписать его самому, причем части получаются несколько больше указанного. Если по количеству, то указываем число. При «разрезке» создается еще два дополнительных файла: один «батник», другой со специфическим расширением .split (его при последующей сборке и указываем программе). Этот .split весит буквально граммы, так что не страшно. В нем хранится информация о числе файлов, размере и дата. При сборке, найдя в диалоге .split и сказав, куда собирать, можем еще приказать убрать части после сборки и даже восстановить исходное время создания (вот для чего оно запоминалось в файле). Такого ни у одной программы раньше я не видела. Как ломает, так и собирает успешно. Вещь, во такая! — придраться не к чему.

KW_Split’Em

  • Размер дистрибутива: 2.09 Мб
  • Местожительство: http://www.knowware-soft.com
  • Местокачательство http://www.knowware-soft.com/freeware/kw_splitem.exe

Эта программа — настоящий мастер. Вначале указываем, что будем делать — собирать или разбирать. В нашем случае будем резать. Далее думаем, что режем и на какие части. Для этого можно воспользоваться ползунком, что оригинально, но неудобно, или же ручками вписать соответствующие значения. Определяемся, делать ли «батник» для сборки. И наконец, сообщаем программе, куда складывать части. Все — кнопка Finish. После отработки демонстрируются логи. Можно, «по просьбам трудящихся», открыть окно «Проводника», зато само окно, где мы выбирали, куда складывать результаты труда, не исчезает, и гадай, что жать дальше. В итоге имеем файлы точно указанного размера и «батничек». Замечу, если вы разбивали файл, думая собирать его «батником», и отметили соответствующий чекбокс, то с помощью программы вы его уже не соберете. Если хотите воспользоваться программой KW_Split’Em, то вместо «батника» создайте махонький файл HDR. Что ж, наконец-то переходим к сборке. Находим в диалоге этот самый HDR. Потом говорим, куда класть результат и Finish. У меня файл склеился корректно и с помощью программы и «батником».

Резка — Сборка файлов

  • Размер дистрибутива: 374 Кб
  • Местожительство: http://victorch.chat.ru
  • Местокачательство: http://victorch.chat.ru/filefunc.exe

В этой программе мне сразу понравилось, что речь идет не о файле, который надо «резать», а о файлах. Указав стандартным образом программе каталог, который «резать», и каталог, куда класть, вписываем размер ручками и нажимаем Делить. В итоге, получаем куски от двух файлов, бывших у меня в каталоге. «Батничек» не работает, сборка идет только программкой. Можно приказать убирать за собой тома. Весь процесс пошел успешно. Просто и со вкусом.

Chainsaw

  • Размер дистрибутива: 104 Кб
  • Местожительство: http://www.schmeusser.siw.de/software/chainsaw.html
  • Местокачательство: http://www.frankenwandern.de/chainsaw.zip

Перетаскиваем в верхний левый угол из «Проводника» нуждающийся в делении файл. Но делать это нужно после того, как выставлены параметры — размеры частей (из списка или свои), а также указано, куда класть куски. Быстренько порезала, сбор «батником», собирает успешно.

Split Fire

  • Размер дистрибутива: 1.04 Мб
  • Местожительство: http://users.win.be/W0117312/other/other.html
  • Местокачательство: http://users.win.be/W0117312/files/sf105.zip

Меню программы состоит из четырех вкладок. Указываем, что будем делить, вписываем размер частей, режим по кнопочке в верхнем углу — это первая вкладка. Никаких «батников», сбор осуществляется самой программой с помощью файла SPL, который она создает при разбивке. Собирает на второй вкладке. На третьей вкладке — лицензия, на четвертой — about.

Splice It

  • Размер дистрибутива: 50 Кб
  • Местожительство: http://www.splice-it.org/display.asp?page=dev
  • Местокачательство: http://www.splice-it.org/post/SpliceItInstall.exe

Чудо дизайна. По функциональности — разумный минимум. Кнопка Splice спрашивает файл, режет подискетно, добавляет «батник». Assemble собирает из кусочков, местонахождение которых надо указать, причем кусков в диалоге не видно, сразу виден архив, как если бы он был уже собран. Но дизайн опять же! И вроде понятно, как такие окошки делаются, но меня впечатлило. Еще это окошко не видно в списке по Alt + Tab, потому при нагромождении открытых приложений на экране его приходится искать методом «прямого перебора».

Справедливости ради отмечу, что «резать» умеют и многие архиваторы, как платные, так и freeware.

Источник: http://www.mycomp.com.ua/
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Mandrake Linux 9.2. Море удовольствия

Автор: Юрий Меркулов

Наконец-то мы получили дистрибутив, с которым практически не надо возиться, настройки просты до неприличия. И если на серверный дистрибутив Mandrake Linux 9.2 явно не тянет по многим причинам, то в качестве массового декстопа он смотрится весьма достойно.

Больше года я провел с верным товарищем Mandrake Linux 9.0. За это время я пережил немало бессонных ночей, отыскивая решения возникающих проблем, устраняя ошибки, оптимизируя систему (о Windows XP не забывая; мое увлечение D&D играми можно удовлетворять пока только там...). Когда я только начинал использовать Mandrake 9.0, у меня было много старого программного обеспечения, которое уже не шло в новой, по тем временам, версии Linux. Но довольно быстро стал выходить софт, который не работал на моем 9.0 по обратной причине – требовал новые версии библиотек. Около 5 часов я потратил на установку и настройку MPlayer 0.91, которому вечно чего-то не хватало. Не менее 2 часов я угробил на настройку TV-OUT своей старенькой (но очень любимой) SUMA GF2 PRO. Настройка дисков с помощью hdparm (9.0 по умолчанию выставил какие-то идиотские параметры), настройка кириллицы в программах для записи CD, возня кириллических шрифтов в OpenOffice.org 1.0.1, танцы вокруг десктоп-менеджеров (gdm, kdm, xdm) – все это осталось веселым воспоминанием о работе с Mandrake Linux 9.0. 9.2 весьма скучный дистрибутив в этом плане. Написали, что 9.2 сжигает cd-накопители LG. Ну и что? Кто-то пострадал? Я видел только 1 (одно!) сообщение в интернете о том, что у человека сгорел LG привод. Причем, он совершенно об этом не жалел. Написали, что в 9.2 нет исходников ядра. Это правда. Без них не ставятся, например, фирменные дрова NVidia (с нормальной поддержкой 3D). Чтобы скачать rpm-ку много ума не требуется (а вот времени потребуется много, ибо 39.9Мб). И, пожалуй, все. Фактически единственное, что я сделал – дописал в etc/fstab параметры noexec, showexec, чтобы файлы на монтируемых файловых системах не отображались все как исполняемые. Впрочем, обо всем по порядку.

Инсталляция. За создание инсталляторов в Mandrake Linux 9.х программистам надо ставить памятник при жизни. Более простого и одновременно гибкого инсталлятора я не видел не то, что среди других дистрибутивов Linux, а вообще, среди всех ОС Red Hat 9.0. Там до сих пор нельзя ставить загрузчик на второй диск, он всегда втыкается в hda. Выбор пакетов сделан примитивно, очень обобщенно. Процесс инсталляции идет дольше (субъективно, не засекал) Windows XP. Не смешите мои костыли - эти переписывания туда-сюда файлов, 3 перезагрузки, десяток минут “настройки самонастраивающегося оборудования” (зачем его настраивать, оно же само, по словам Microsoft, это делать умеет...), отсутствие менеджера дисков в начале инсталляции делают его жалким убожеством рядом с нормальными инсталляторами. Сам процесс, в общем-то, стандартный – выбрали раздел (если надо, создали его сначала) под Linux, затем под swap, выбрали пакеты и пошло-поехало. Переписали – ставим загрузчик (выбор: “какой” и “куда”), заводим пользователей и вперед с песней.

"День первый". В этот день обычно систему приводят в более-менее рабочее состояние, начинают копаться и разбираться. К моему легкому разочарованию, после редактирования fstab и подкрутки картинки монитора немного влево (стандартный “nv” драйвер у всех почему-то сдвигает изображение на 3-4 мм вправо) оказалось, что фактически можно начинать работать. Но я себе нашел развлечение - мне очень нравятся птицы (Firebird и Thunderbird), и я полез в интернет их выкачивать (сборки с поддержкой xft). Все остальные программы уже были в дистрибутиве. MPlayer? Милости просим, он уже есть, с кучей скинов и кодеков. K3B? Тоже есть, добро пожаловать, записывайте свои CD. И так далее. Почти все программы, что мне нужны, есть в 9.2.

Итак, первое, что бросилось в глаза – как фантастически красиво смотрятся шрифты, сглаженные xft2. Кирпичный Fixed в KDE (9.0) сменился на милый и уютный Nimbus Sans (очень похож на Arial), который со сглаживанием смотрится, словно аккуратно введенный графитовым карандашом на мелованной бумаге. К другим шрифтам эта метафора применима также (Courier – 3T карандаш, Impact – рейсфедер), но с Nimbus Sans она уж очень ярко бросилась в глаза. Я так проникся любовью к этой красоте, что решил воссоздать ее в WindowsXP. Включил ClearType. Тут же зерно моего монитора увеличилось с 0.25 до 0.39, как у первых 14-дюймовых моделей. Вместо сглаживая я получил дикое размытие текста. Почему-то сразу вспомнилась старушка VooDoo1. Зато не было тех ужасных (о, как быстро мы привыкаем к хорошему!) лесенок на шрифтах и эффекта внезапного ожирения. “Внезапное ожирение”? Откройте Word, наберите что-нибудь шрифтом Times New Roman. Размер 12, шрифт тоненький, 1 пиксел. 13, ничего не изменилось. 14, и вдруг шрифт резко толстеет, чернеет. Ай-ай, мы стали толще на 1 пискел. Это очень некрасиво и порой сбивает с толку. Неужели у меня и на принтере также распечатается? Так вот, через пол часа работы со включенным ClearType (занимался web-серфингом) я почувствовал, что меня элементарно тошнит. В прямом смысле этого слова. Голова стала кружиться и вообще стало как-то не по себе. Я быстро выключил ClearTypе и вернулся в Linux. И вот снова чья-то невидимая рука каллиграфическим почерком выводит мне текст своим карандашиком. Полегчало.

Лампочка “Scroll Lock” теперь мигала по умолчанию, не надо было прописывать ее мигание в x86config-4. Левые переключатели раскладок я не трогаю и никому не рекомендую – только проблемы, отдача нулевая. В Konqueror появились вкладки (KDE 3.1 и выше)! Теперь он на фоне Mozilla и Opera смотрится весьма неплохо – не то, что каменный IE в Windows. Все иконки и в KDE и в GNOME изменились по сравнению с mdk9.0. Очень красиво. Собственные иконки от Mandrake также перерисованы. Собственные средства настройки от Mandrake, в общем-то мало изменились, но косметическая работа проделана огромная. Опять же – все работает. Например, менеджер пакетов теперь не просит вставить второй диск, хотя именно он и стоит в накопителе. Сколько я не ставил пакеты в первый вечер – ни разу не было неурядиц, все прошло гладко. Документации на русском в дистрибутиве нет, есть на английском. Большой разницы не вижу, но русский – родной, да и не все английский знают хорошо, так что не всем это удобно. Но Mandrake – французская фирма, а за полностью русскими дистрибутивами добро пожаловать к ASP и AltLinux.

Любопытно, что в Mandrake 9.2 по умолчанию встал “фирменный” оконный менеджер MdkKDM. Не знаю, чем он отличается от стандартного kdm, но факт, что фирма сама дорабатывает оконный менеджер говорит в ее пользу. Ручное редактирование стартового меню из menudrake в mdk9.0 портило все меню целиком. Он него оставались “рожки да ножки”. Фактически, там нельзя было редактировать меню вручную (это не относится к IceWM, где настройки меню хранятся в одном текстовом файле). В mdk9.2 этой проблемы больше нет, menudrake заработал, как ему и следует.

С mdk9.0 у меня был связан еще один неприятный глюк. У меня 2 жестких диска. На первом (60Гб) WindowsXP, на втором (80Gb) Windows 98SE. Я ставил в прошлом году Mandrake Linux 9.0 на второй диск, загрузчик (пробовал и lilo и grub) втыкал на hdb (“второй”). Что должно получиться по идее? Если загрузка в биосе ставится с hdd1, тогда загружается lilo (grub), из которого можно выбрать все оси. А если загрузка идет с hdd0, тогда должна молча загрузиться Windows XP. Так ведь (может, я чего-то не понимаю)? Так вот, у меня XP переставала грузится. Не сразу(!!!), а через 1-2 недели. Из lilo – пожалуйста, а сама по себе – нет. Ко мне приходили друзья с жесткими дисками, и мы не могли ничего сделать, так как в mobil rack у меня стоит именно 80Гб, тот, на котором стоял lilo. Так вот, к чему я все это пишу. Сейчас я поставил mdk9.2 на тот же диск, что и XP (он 7200 оборотов, а 80Гб – 5400), lilo воткнул на второй. Затем dd if=/загрузчик of=/файл bs=512 count=1, прописал его в XP, а со второго диска его убил (fdisk /mbr). С утра сегодня попробовал загрузить Windows 98. Работает. Надо же.

Загружается, а главное, выключается, mdk 9.2 намного быстрей своего старшего брата 9.0 (сказывается также, что раньше он стоял у меня на диске с 5400 оборотов). Теперь, когда XP и Linux у меня на одном физическом hdd, я могу сказать, что загружаются они приблизительно одинаково (и это притом, что я загружаю мега-тяжелый KDE!), а вот выключается Linux быстрей. Наконец-то в 9.2 Mandrake сделали фоновые рисунки при загрузке и выключении компьютера а-ля облака Win9x или синий экран XP (не экран смерти, а приветствие и прощание). Раньше-то мы лицезрели каждый раз множество системных сообщений, которые не подобает показывать массовому пользователю.

"День второй". А что за софт входит в дистрибутив? OpenOffice.org 1.1.0. И здесь та же история. В mdk9.0 мне пришлось потратить не один вечер на приведение OO 1.0.1 в удобоваримый вид. Пришлось скачивать русский словарь проверки орфографии, читать документацию и искать как его подключить. Затем доставали проблемы с наползанием букв друг на друга, которые так до конца и не вылечились. Прилично смотрелось лишь 3-4 шрифта (все из семейства Sans), остальное было откровенно кривым и некрасивым. И что же мы видим в mdk9.2? Ничего ставить и настраивать не надо – проверка русской орфографии работает сразу по умолчанию, а шрифты отображаются, как у элитного писаря королевства. Красиво! OpenOffice.org 1.1.0 очень гармонично вписывается во всю концепцию Linux – максимум эффективности при минимуме лишних функций. Равно как, например, Microsoft Office 2003 очень удачно вписался в мир Windows XP – программа должна иметь как можно больше возможностей! Странно, что в MS Office 2003 нет какого-нибудь софта для монтажа видео. Вспомните слова чайников: “У меня Windows 97!” - а оказывается, что у него просто стоит Word 97. Просто, он 99% всех операций производит в нем, вот ему и кажется, что это и есть ОС (он в “Матрице”). OpenOffice.org 1.1.0 не ставил перед собой такую цель, поэтому скажу прямо – возможностей у него намного меньше, чем у вышедшего в это же время брата от Microsoft, но работать не менее удобно. Русификация меню в OO 1.1.0 не идеальная – изредка натыкаешься то на непереведенные участки, а местами вообще появляются нечетабельные строчки. Но это и понятно – официально русская ОО 1.1.0 от AltLinux вышла намного позже выхода mdk9.2, так что здесь мы видим “бета-версию русификации”. В принципе, можно сделать английское меню, тогда проблемы решаются сами-собой. Помощь в OO 1.1.0 по прежнему на английском языке.

Программы для интернета. Mozilla 1.4 – прекрасный набор программ, зачастую большего и не надо. Но я – эстет в этой области, люблю именно Firebird и Thunderbird. Оказалось, они (0.7 и 0.3 соответственно) дают гораздо больший выигрыш в скорости по сравнению с Mozilla 1.4, чем это было в свое время в Windows. Такое впечатление, что птицы хорошо оптимизированы под Linux, чего не скажешь о стандартной Mozilla. Странно, что их до сих пор не включили ни в один известный мне дистрибутив (“четвертый диск” с русификацией Red Hat 8.0 и 9.0 не принимаем всерьез; там есть Phoenix a.k.a. Firebird). В mdk9.0 я так и не смог “осознать” процедуру установки расширения Tab_extensions на Mozilla 1.1(1.3) и Phoenix 0.4. Расширение упорно не хотело появляться в меню, хотя я пробовал его ставить и от пользователя и от root-а. И обычно в тот момент, когда я уже хотел забить на все и поставить Opera, расширение вдруг начинало работать. Закономерность всего этого я так и не понял. Так вот, в mdk9.2 у меня все запустилось с первого раза. И хорошо встала вся русификация (в Windows русификация от AltLinux Firebird 0.7 глючная, а русификация Thunderbird нормально работает только с исправлениями Unghost). Кроме того, в mdk9.2, как и в предыдущие версии, входит Galeon. Текущая версия 1.3.8. Это браузер из состава GNOME на движке от Mozilla. А вот и новинка - Epiphany 1.0. Если Firebird – это облегченная и турбированная версия Mozilla, то Epiphany – разгон Galeon. Он теперь стандартный браузер в GNOME, начиная с версии 2.4. Любителям Opera, как прежде, придется скачивать ее.

Файловые менеджеры. Нового тут ничего не появились, но вот Midnight Commander 4.60 похорошел. Во-первых, у него теперь русская помощь, а во-вторых (как я ждал этого!) он теперь имеет выбор кодировки при показе содержимого файлов. Ctrl+T. Теперь мои cp1251 текстовые файлы, набранные в Windows (и cp866 досовая древность) отображается нормально. Это серьезный шаг вперед в плане совместимости. Krusader-а нет (не жалко), зато появилась цифровая мумия из прошлого века – FileRunner 2.5.1 (1999 год). Если его включили в дистрибутив, чтобы показать насколько за последние 4 года развился софт в Linux, то это им удалось на славу. В FileRunner даже нельзя управлять курсором навигацией (только клик мышкой), что говорить о более сложных функциях?

Проигрыватели. Наконец-то в дистрибутиве появился чудесный проигрыватель MPlayer 0.90 со всеми кодеками и скинами! После того, как он был мной замечен, все остальные проигрыватели были отмечены лишь беглым вниманием. В mdk9.2 появился Totem (раньше его не было), а также остались все те же XINE, XMMS и всякая мелочевка, типа Kmidi.

Остального софта меньше точно не стало. CD теперь записывать стало также просто, как в Easy CD Creator для Windows, так как теперь есть “k3b CD-ROM дизайнер”, программа, которой я записал диск сразу же после ее запуска. GIMP 1.2.5 никуда не делся, все также работает намного быстрей фотошопообразных редакторов при более удобном подходе к организации интерфейса. Wine все также помогает запускать приложения для Windows. После установки исходников ядра и драйверов NVidia пошли 3D игры для Linux. В Windows игры я не играю в Linux – за ухом предпочитаю чесать рукой (загрузить Windows), а не ногой. Пока лезть в интернет за каким-то новым софтом у меня не возникает (а в mdk9.0 возникло сразу почему-то).

Итак, мы имеем отличный дистрибутив Linux, в котором, как уже стало традицией для Mandrake, есть некоторые глюки. Но они сполна перевешиваются простотой и удобством настроек. Мне только один раз за время использования mdk9.2 пришлось править текстовый конфиг (fstab), остальное или работает как надо или есть удобные графические утилиты. Mandrake Linux 9.2 – море удовольствий при минимуме ковыряния.

***
Рекомендуем
Хотите сыграть в пейнтбол?
Отличительная черта этой игры - ее полная демократичность. Маркер (оружие для игры в пейнтбол) уравнивает в правах всех - от банкиров и дипломатов до студентов и инженеров. Когда все облачены в камуфляж и маски, то разница в социальном статусе практически незаметна.
Подробнее >>


Занимательное пингвиностроение. Фундамент

Автор: Сергей ГУЛЕНОК aka Gray

Скоро я буду справлять годовщину своей миграции на Linux. Надо сказать, программирование было одним из первоочередных пунктов, с которыми мне предстояло разобраться при переходе. В разговорах о Linux мне часто попадалась фраза «Linux написан программистами для программистов». Так ли это?

Первое, что заставляет обратить на себя внимание в Linux, — это поддержка разнообразных языков программирования. Парад открывают признанные гранды — C и C++ (реализованные GNU C Compiler'ом или просто gcc), на которых держится практически весь Linux. За ними следуют скриптовые языки — Perl (просто ас обработки текстов :-)) и стремительно набирающий популярность в сисадминских кругах Python. Не забыты и другие известные языки: Pascal (в образе Free Pascal Compiler и GNU Pascal), Java, Fortran, Ada, Lisp, Assembler. А еще не очень известные, к сожалению, Eiffel да Objective C и многие другие. Но главная прелесть всего этого разнообразия в том, что подавляющее большинство компиляторов и интерпретаторов бесплатны!

Библиотеки. Их очень много. Я не могу утверждать точно, но уверен, что процентов эдак 90 (а то и больше) того, что вам нужно, вы найдете. Имеются библиотеки для работы с архивами и базами данных, звуком и графикой, XML и PGP, сетями (без них-то и UNIX — не UNIX :-)) и еще много чего. Есть библиотеки для работы с трехмерной графикой (OpenGL) и создания игр (SDL — аналог DirectX). Понятно, не обошлось и без средств создания графических интерфейсов — можно выбрать из Gtk+, Qt, FOX, wxWindows и FLTK. Кроме того, в комплект поставки практически любого дистрибутива входит куча утилит, которые могут значительно облегчить процесс написания программ и их сопровождение. Таковыми я бы назвал, например, систему управления версиями CVS (в дистрибутивы также часто включают Cervisa — удобный фронт-энд для нее), утилиты lex (для автоматического создания лексикографических анализаторов), yacc (для создания парсеров), diff (для сравнения файлов), gprof (для статистического анализа функций и анализа их быстродействия), make, autoconf, automake (незаменимые при сборке больших программ) и многие другие.

Немного о средах разработки. Для консоли таковой является, например, Emacs. Но наиболее популярной среди продвинутых UNIX-программистов является vim. Несмотря на внешнее убожество и неудобство редактирования (те, кто хоть раз запускал старенький vi, меня поймут), за ней скрывается небывалая мощь, которую, причем, наращивать можно практически бес конца. Есть хороший текстовый редактор с подсветкой синтаксиса FTE, XEmacs. Чем-то они похожи, но FTE не хватает функциональности (например, нет возможности отлаживать программу), а XEmacs — удобства. Xwpe (есть и консольный вариант) и Motor для любителей сред разработки в стиле Borland C 3.x или Pascal 7.x. Среди чисто графических средств я бы отметил связки из сред разработки и визуальных строителей форм: Kdevelop+Qt Designer (можно найти в большинстве последних дистрибутивов), KDE Studio Gold+Qt Designer (правда, влетит это в копеечку — стандартная версия для закачки KDESG стоит $24.95; хотя возможность ее попробовать есть — зайдите на http://www.thekompany.com/products/ksg/ и скачайте демо-версию) и Anjuta+Glade для C/C++. «Паскалисты» могут опробовать компилятор FPC со средой Lazarus (я бы назвал это попыткой сделать бесплатный аналог Delphi). Так как из «графики» я больше знаком с Gtk+, мне лично по душе именно Anjuta и Glade. Остановимся немного на них.

Anjuta — удобная среда разработки. Она имеет весьма симпатичный редактор кода с некоторыми наворотами (например, есть возможность сворачивать комментарии и функции на манер дерева, также радуют всплывающие подсказки по параметрам функций — правда, пока не по всем). Кроме того, она генерирует множество дополнительных файлов, например makefile.am (для automake), configure.in (для autoconf), autogen.sh и т.д. Они хорошо знакомы тем, кто хоть раз собирал пакеты из исходников. В общем, среда определенно должна понравиться начинающим программистам. Кстати, один мой знакомый, краем глаза увидев Anjut’у, принял приложение за Visual C++ :-). К сожалению, есть у нее один маленький недостаток — после инсталляции нет поддержки кириллических шрифтов. Однако это дело легко поправимое. Достаточно заглянуть в файлы ~/.anjuta/user.properties и ~/.anjuta/session.properties и в первом раскомментировать строку:

Затем, если во втором тоже существует такой параметр, присвоить и ему значение 204. Вот и все сложности. При желании шрифты редактора потом можно настроить по своему вкусу.

Glade — это инструмент для создания графических интерфейсов на основе Gtk. Хочу дать один совет: начинайте создавать графические приложения, написав код вручную, чтобы понять, что и как делается, вникнуть в саму организацию, а потом уже используйте визуальные построители форм, чтобы ускорить работу. Это, кстати, относится не только к интерфейсу.

Этим коротким вступлением я собираюсь начать небольшой цикл статей, посвященный некоторым аспектам написания программ в Linux. Сразу хочу предупредить, что я не буду рассказывать, что такое указатели, динамические структуры данных, толковать о работе с файлами, и т.д. — подразумевается, что все это вы уже знаете (если же нет — Кернигана и Ритчи в руки, и вперед :-)!) В этом цикле будут рассмотрены некоторые из механизмов взаимодействия процессов UNIX, создание многопоточных приложений и оконных приложений на базе Gtk+, работа с сетью. Если же вы хотите разобраться в чем-нибудь, что не было затронуто, — пишите, подумаем над этим вместе. Основной язык программирования — C, но я постараюсь уделить немного внимания shell’у и perl’у, поскольку иногда использование всей мощи C, мягко говоря, не оправдано.

За сим прощаюсь. Следующая тема — системные вызовы fork() и exec().

Продолжение следует.

Источник: http://www.mycomp.com.ua/
***
Рекомендуем
Хотите сыграть в пейнтбол?
Отличительная черта этой игры - ее полная демократичность. Маркер (оружие для игры в пейнтбол) уравнивает в правах всех - от банкиров и дипломатов до студентов и инженеров. Когда все облачены в камуфляж и маски, то разница в социальном статусе практически незаметна.
Подробнее >>


Информация

Свежие номера здесь! Служебная информация
  • Реклама в журнале
  • Для авторов, желающих публиковаться
  • Условия использования материалов
  • Подписка на рассылку

Реклама в журнале

Версия от 15.09.2003г.

Информация о журнале:
От обычных рассылок, рассылаемых по почте, журнал отличается тем, что это не одинарный листок с информацией, а действительно полноценный электронный журнал (содержащий внутри себя массу страниц с информацией и графикой, систематизированными по рубрикам).
Большинство пользователей, скачивающих журналы - создают у себя на компьютере электронную библиотеку, т.е. хранят у себя на компьютере архивы журналов.
Соответственно, рекламная информация размещенная в журнале - имеет гораздо более длительный "срок жизни", чем реклама в обычных рассылках.

Количество загрузок каждого номера вы можете посмотреть здесь: http://www.izcity.com/down/doc0.html
В среднем порядка не менее 15-20 тыс. человек скачивают и читают каждый номер. Количество постоянных читателей (как минимум раз в месяц загружающих и просматривающих какой-либо выпуск журнала): не менее 50 тыс. человек
Периодичность выхода журнала: 8-10 выпусков в месяц.

Расценки:

Где размещено | Тип рекламы | 1 выпуск | 3 выпуска | 10 выпусков
Главная страница журнала | баннер 468х60 вверху | $5 | $10 | $20
 | Статья до 5000 знаков | $5 | $10 | $20
Внутри журнала баннер (сквозной по журналу, на всех страницах со статьями, кроме главной и нескольких служебных) | баннер 468х60 вверху | нет | нет | $20
 | баннер 468х60 внизу | нет | нет | $15
Статья рекламная внутри журнала | Статья до 7000 знаков | $2 | $5 | $12

Примечание:

  • Текст вместо баннера: вместо баннера вверху или внизу можно размещать текстовый блок до 300 знаков или текстово-графический блок (помимо текста может присутствовать небольшая картинка)
  • Бесплатно: в вашей статье или материале могут также присутствовать одно или несколько графических изображений общим "весом" не более 30 кб.
  • При подсчете знаков html-тэги не учитываются, а пробелы учитываются.
    Для того, чтобы правильно подсчитать знаки в вашем рекламном объявлении - используйте, например текстовый редактор Word. Скопируйте в него ваш текст, а затем в меню Word найдите пункт Статистика. Все сразу и увидите.
  • Форматы присылаемых текстовых блоков, материалов и статей:
    HTML, HTM, Word (doc) или RTF. Если статья с графикой, то можете все это дело упаковать в zip-архив и в таком виде прислать нам. Обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам.

Как платить?
Все расчеты производятся при помощи платежной системы WebMoney.
Наши кошельки:
Z906510760241
R211650054260
Если вы не знакомы с этой платежной системой, то зайдите к ним на сайт, почитайте. Все на русском языке, просто и понятно. Денежные переводы и расчеты производятся моментально, в режиме реального времени через Интернет.

Порядок оформления рекламного заказа:
- Переводите нужную сумму денег на наш кошелек в системе Webmoney
- В примечании к переводу оставьте какой-нибудь комментарий, в котором укажите ваш емейл или адрес сайта, или фамилию, или название организации. Чтоб мы могли понять, от кого пришли деньги...
- Затем присылаете письмо с сообщением о переводе денег и вашим рекламным текстом (статьей) или баннером.
- Ваша реклама выходит в ближайшем свободном выпуске журнала (в течении 2-4 дней).

По вопросам размещения рекламы обращаться: reklama@izcity.com
Дополнительно смотрите другие наши рекламные услуги

Вверх | На главную

Для авторов

Версия текста от 19.10.2003г.

Хотите публиковаться?
Стать нашим автором несложно... Если вы пишете статьи, если вы считаете, что они интересно, талантливо написаны, то у нас с вами есть повод для сотрудничества.
Нас интересуют статьи, описания, руководства... Тематика: компьютеры, Интернет, программы; описания утилит; обзоры железа, периферии, софта; примеры решения каких-либо компьютерных проблем и т.д. В общем интересно все, что относится к компьютерной тематике и Интернету.

Требования к материалам:

  • Статьи принимаются к публикации у нас только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Актуальность, ясность и простота изложения, последовательность и логичность, четкость формулировок и аккуратное использование терминов, точность в научных и технических сведениях. В статье могут быть указаны реквизиты автора: емейл, ссылка на сайт и т.д. Дополнительно: в двух-трех предложениях автор может написать о себе. Также может выразить благодарность компаниям или лицам, оказавшим помощь при подготовке материала. Соответственно могут быть указаны реквизиты организаций, предоставивших продукты или программы для тестирования или обзора.
  • Форматы присылаемых материалов: DOC (Microsoft Word), RTF, HTML (HTM).
    Если вы используете в статье графику (логотипы, скриншоты и т.д.), то сразу вставляйте графику в HTML. Графика не должна быть громоздкой и иметь большие размеры. Желательно не более 30 кб. графики (общий "вес") на одну статью... Кроме того, изображения (картинка, скриншот) в статье не должны превышать 370 пикселей в длину по горизонтали.
    Проверьте правильность ссылок. Статью и графику к ней будет логичным объединить в один каталог, упаковать архиватором и в таком виде переслать нам.
    Если ваша статья без графики и состоит из одной страницы, то этот документ можно просто прислать вместе с письмом.
  • Отсутствие ошибок: грамматических и орфографических (проверяйте тексты в Word, плюс сами читайте, перед тем как нам отправлять...)
    Обратите внимание: обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам... Статьи, содержащие много ошибок - не публикуются!
  • Статьи о спонсорах и заработке - грамотные содержательные статьи общего плана публикуются бесплатно. Статьи рекламного характера, с реферральными ссылками публикуются на правах рекламы
  • Рекламные статьи любой тематики (явно рекламирующие компанию, платные продукты или услуги) публикуются на правах рекламы.

Взаимоотношения с авторами:
Денег мы не платим, однако мы предлагаем альтернативные варианты поощрений для авторов. Для начала скажем, что понятное дело - вы в статье можете указать свои авторские реквизиты: емейл, ссылку на свой сайт и т.д. Таким образом, вы получите дополнительный приток людей на свой сайт. Ведь, не секрет, что хорошая статья о каком-либо продукте или услуге, со ссылкой на сайт - неизбежно вызовет приток посетителей на этот сайт.
Если вы достаточно часто будете публиковать статьи, то за вами вполне может закрепиться имидж эксперта в той или иной области.

А теперь о поощрениях за опубликованные у нас статьи:
За каждую статью, опубликованную в нашем журнале вы получаете бесплатно рекламный блок в нашей рассылке IZone Web (это правило действует с 14.08.2002г.; о рассылке IZone Web: на 19.10.2003 г. более 150 тыс. подписчиков, статистику на сегодняшний день можно посмотреть с этой страницы: http://www.izcity.com/info/reklama2.htm).
Рекламные блоки предлагаются в следующем соотношении:

  • Статья до 5000 знаков - текстовый блок до 200 знаков

  • Статья до 7000 знаков - текстовый блок до 300 знаков

  • Статья до 10000 знаков - текстовый блок до 500 знаков

Рекламные блоки бесплатно размещаются в нижней части рассылки IZone Web. Можно присылать заявку на размещение вашего рекламного блока после каждой вашей статьи. Можно опубликовать несколько статей у нас, а потом спустя некоторое время прислать заявку на размещение группы ваших блоков.

Если вы подаете заявку на размещение у нас рекламного блока после каждой вашей статьи, то форма подачи заявки следующая:
Присылаете письмо, в котором должны обязательно присутствовать следующие моменты:
- Название вашей статьи, количество знаков без пробелов в статье и номер выпуска журнала, в котором ваша статья опубликована.
- Текст вашего рекламного блока (объявления)
Ваш рекламный блок выйдет в одной из ближайших рассылок (в течение 2-4 дней).

Если вы подаете заявку на размещение у нас сразу нескольких рекламных блоков после публикации нескольких ваших статей, то форма подачи заявки следующая:
- Названия ваших статей, количество знаков без пробелов в каждой статье и номера выпусков журнала, в котором ваши статьи опубликованы.
- Текст вашего рекламного блока (или блоков).
- Ваши комментарии по вашей рекламе у нас (количество раз публикаций которые вам причитаются; также в зависимости от этого текст и размеры у рекламных блоков могут быть одинаковыми, а могут быть и разными). Пожалуйста четко указывайте в ваших комментариях все нюансы, чтобы мы вас поняли с первого раза.
Ваша рекламная кампания начнется в одной из ближайших рассылок (в течение 2-4 дней) и будет продолжаться положенное вам количество времени (выпусков рассылки).

Обратите внимание:

  • Вы имеете право на получение бесплатного рекламного блока только в случае факта публикации вашей статьи.
  • Статьи принимаются нами только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Присланные нам статьи не резензируются, не комментируются, не возвращаются. В переписку с авторами, редакция не вступает.

P.S. Мы оставляем за собой право:

  • На распространение копий присланных нам материалов
  • Не публиковать материалы противоречащие нашей концепции.
Статьи для публикации присылать на адрес editor@izcity.com, тема: avtor

Рекламные блоки для размещения в нашей рассылке присылать на адрес reklama@izcity.com, тема: free

Вверх | На главную

Условия использования материалов

Использование материалов нашего журнала регламентируется настоящими правилами (с 15.09.2003г.).

Использование CHM-файлов
Если вы хотите использовать у себя полностью chm-файлы с номерами журналов (например, вы провайдер и хотите выложить журналы у себя на ftp-сервере, или у вас архив софта и вы хотите некоторые архивы журналов держать у себя на сайте), то нет никаких проблем... Можно использовать при соблюдении следующих факторов:
1. Нельзя ничего внутри изменять (ну это, как вы знаете - общее правило...).
2. При использовании обязательна ссылка на нас. Ссылка должна указывать на наш сайт http://www.izcity.com

Использование отдельных статей из выпуска
Наши собственные статьи, т.е. статьи наших авторов (отсутствует под статьей ссылка на источник) - можно использовать с указанием ссылки на наш сайт http://www.izcity.com
Использование статей с других источников (под статьей есть ссылка на источник информации) - запрещено.

О наших материалах
Информационную начинку нашего журнала составляют, как материалы собственных авторов, так и дайджест с наиболее популярных компьютерных ресурсов Рунета. Все публикуемые у нас материалы - юридически чисты. Каждый материал (или статья) в нашем журнале имеет своего автора или правообладателя (собственника прав на статью). Все материалы публикуются либо с разрешения авторов или владельцев авторских прав, либо присылаются ими непосредственно в редакцию IZone для публикации.

Вверх | На главную

Подпишитесь на нашу рассылку IZone WEB!
Своевременно полученная информация - залог успеха. Для того, чтобы всегда быть в курсе всех наших новинок - подпишитесь на нашу рассылку. Удобно и практично: наша информация будет доставляться в ваш почтовый ящик. Периодичность рассылки: 3 раза в неделю.
Наши подписчики получают краткую аннотированную информацию обо всех новинках нашего сайта. Это выход свежих номеров журнала "Internet Zone", бесплатные программы, различные утилиты, средства и сервисы для создания и "раскрутки" сайта, различная компьютерная документация и т.д.
Для подписки на рассылку - посетите нашу страницу подписки в Интернет по адресу: http://www.izcity.com/info/sub.htm либо воспользуйтесь формой справа (необходимо подключение к Интернет)
Подписка на рассылку
Рассылка MailList.Ru

Вверх | На главную


Работа с журналом

Помощь при работе с журналом

Свежие номера здесь! Версия текста от 28.11.2003 г.

Системные требования

Операционная система, начиная от Windows98 и выше.
В системе должен быть установлен браузер Internet Explorer версии начиная от 5.0 или выше.
!!! Обязательно в браузере должны быть включены: поддержка java-скрипт, показ рисунков и анимации.
Разрешение экрана монитора желательно должно быть не менее, чем 1024х768.

Для тех, кто в первый раз...

Что такое CHM?

Compiled HTML - специально разработанный Microsoft формат данных для поддержки гипертекстовых справочных систем. Не требует специальных средств для просмотра. Всё уже есть в Windows. В этом формате сделаны справки к браузерам IE, начиная с четвертой версии и выше, справка к Microsoft Office и т.д.

Как лучше начать просмотр выпуска журнала?

Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню слева и выбрать Открыть все. Данная операция одним махом открывает все вложенные в папки страницы. По окончанию просмотра журнала, аналогично можно выбрать Закрыть все.
Весьма удобно - пользуйтесь. Можно открывать рубрики и поодиночке - используйте крестик слева от папки/рубрики.

Навигация: кнопки вверху

Назад/Вперед
Данные кнопки аналогичны одноименным кнопкам в браузере. Служат для быстрого перемещения между просмотренными страницами

Домой
Нажав на эту кнопку, вы попадете на стартовую страницу

Шрифт
Весьма полезная кнопка. Регулирует размер шрифтов для просмотра. Нажимаете и все. Шрифты меняются по кругу. Обязательно найдется устраивающий вас размер шрифта. Если установки размера шрифтов по умолчанию вас устраивают, то можете вообще не пользоваться данной кнопкой.

Печать
Вывод на печать необходимой вам страницы. Если у вас установлен принтер, то можете пользоваться.

Параметры
Различные настройки и команды.

Навигационное меню слева

- В зависимости от размеров вашего монитора, вы можете зацепить мышкой и расширить/сузить границу-бордюр между навигационным меню и правой частью журнала со статьями.

- Одинарный щелчок мышкой по крестику слева от папки/рубрики (или двойной щелчок по названию) открывает содержимое папки. Обратная операция: щелчок мышкой по минусу (или двойной щелчок по названию) - закрывает папку/рубрику.

- Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню и в зависимости от текущего состояния папок, вы можете выбрать Открыть все/Закрыть все. Данная операция одним махом открывает/закрывает все вложенные в папки страницы.

- Если вы усиленно используете принтер, то здесь же, щелчком правой кнопки мышки по папке можно выбрать варианты печати.

- В Навигационном меню также присутствует вверху закладка Избранное. При просмотре вы можете понравившиеся статьи заносить в Избранное для последующего быстрого доступа к этим статьям.

Разное

Просмотр страниц

При щелчке правой кнопкой мышки по просматриваемой странице - появляется меню с командами.

Используйте клавиатуру

При просмотре выпуска удобно использовать клавиши клавиатуры. Например, клавиши Page Up и Page Down служат для быстрой прокрутки. А вот клавиши справа внизу на клавиатуре со стрелками вверх и вниз - удобно использовать для плавной прокрутки читаемой страницы.

При просмотре CHM-выпуска журнала вместо рисунков вижу только рамки, а сами рисунки не видны.
Также не мигает, как бы застыл анимированный баннер внизу некоторых страниц.

Для корректной работы CHM-формата требуется установленный в системе браузер Internet Explorer и соответственно CHM-формат использует его настройки. В вашем браузере отключен показ рисунков и анимации. Включите их (Сервис > Свойства обозревателя... > вкладка Дополнительно)

Каким образом открыть отдельную страницу выпуска в отдельном окне браузера Internet Explorer?

Кликнуть правой кнопкой по любому месту на странице, в появившемся контекстном меню выбрать "Свойства", значение поля "Адрес (URL)" скопировать в буфер обмена, вставить в адресную строку IE и нажать Enter (или кнопку "Переход" в браузере). Нужная вам страница откроется в браузере
(правда, обратите внимание: при попытке сохранить такую страницу на диск в виде html - сохранится только текст, без картинок, хотя при просмотре картинки будут доступны).

Как сохранить на диск (в формате HTML) одну или несколько понравившихся мне статей (или даже целиком весь выпуск) полностью со всем оформлением, включая и графику?

Для этого придется распаковать/декомпилировать весь выпуск. См. здесь: http://www.izcity.com/info/chm.htm

Как осуществить поиск в пределах одной страницы?

Используйте сочетание клавиш Ctrl-F.

Как распечатать текущую страницу?

Используйте сочетание клавиш Ctrl-P.

В chm-выпуске вашего журнала нашел интересующую меня программу. Как ее скачать не браузером, а моей качалкой, т.е. download-менеджером?

Рассмотрим данный момент на примере популярной качалки FlashGet (http://www.amazesoft.com/). Итак, вот несколько способов для того чтобы скачать нужный вам файл, используя качалку.

1. Первый способ. Стандартный, не требующий от вас лишний телодвижений. Если ваша качалка интегрирована с браузером (производит слежение за кликами), то никаких проблем возникнуть не должно. При клике по ссылке, будет происходить запуск качалки. Если этого не происходит, то проверьте за какими типами файлов ваша качалка производит слежение. Например, во FlashGet по умолчанию не "заряжено" слежение за avi-файлами. Добавьте этот формат вручную в настройках FlashGet.

2. Второй способ: откройте у FlashGet Корзину (выберите в настройках ее показ). И теперь при просмотре chm-выпуска журнала - просто мышкой перетаскивайте нужные вам ссылки в Корзину FlashGet. Вуаля!
Помимо FlashGet, Корзинку имеют и все другие продвинутые качалки. Например, ReGet и т.д.

3. Если файлов, которые нужно скачать, на странице очень много, например 30-40 шт.:), то можно вообще открыть нужную вам страницу в отдельном окне браузера Internet Explorer (см. выше как это сделать), ну а далее выберите в контекстном меню браузера (щелчок правой кнопкой по странице) команду: Закачать все при помощи FlashGet. В появившемся окне FlashGet вручную или с помощью фильтров можно подкорректировать опции загрузки (если что-то ненужное попадет в список загрузки).


IZone

Свежие номера здесь!
IZONE
550
30.11.2003

Полезный совет:
Щелкните правой кнопкой мышки по любому месту в меню слева и выберите Открыть все.

Полезный совет-2:
Почитайте как работать с журналом в папке Your help

Полезный совет-3:
Скачайте другие
выпуски

IZONE
электронный
компьютерный журнал
о высоких технологиях
Читай лучшее!
Кадры решают все!
Программа "Кадры"
  • Автоматизация работы кадровой службы для предприятий любых форм собственности.
  • Построение разветвленной структуры предприятия, ведение штатного расписания.
  • Ведение учета личных карточек с автоматическим формированием приказов.
  • Возможность стыковки с бухгалтерскими программами.
  • Формирование произвольных отчетов по любым параметрам личной карточки.
     Подробнее >>
Программное обеспечение для учебной части
Программа "Студент" поможет вам:
  • максимально упростить и автоматизировать работу по приему, перемещению и отчислению учащихся;
  • автоматически формировать первичную документацию на каждого студента (контракты, подготовка и печать протоколов и приказов о зачислении);
  • настроить структурную схему учебного заведения;
  • вести учебное расписание как учреждения в целом, так и для каждого отдельного подразделения;
  • гибкое ведение учебных планов с учетом специальностей, специализаций, курсов, групп;
  • расширить учетную информацию личной карточки с использованием "Дополнительных сведений" и делать по ней выборку;
  • контроль оплаты обучения с учетом сроков сессии и приказов о продлении контракта;
  • моделировать произвольные отчеты из индивидуальных сведений учащихся на основе критериев, указанных пользователем;
  • совместимости с 1С:Бухгалтерией и другими программами (импорт-экспорт данных);
  • интеграции со стандартными офисными приложениями, такими как MS Word, MS Excel.
     Подробнее >>