Новости

Готовится бета-тестирование второго сервис-пака для Windows XP

Агентство TechWeb, ссылаясь на письмо от корпорации Microsoft, выложенное в Сеть на форумах Neowin, опубликовало сообщение о намерении корпорации в течение ближайших нескольких недель выпустить очередное обновление для операционной системы Windows XP - Service Pack 2.

Опубликованное письмо от Microsoft было адресовано бета-тестерам корпорации и извещало их о грядущем выпуске сервис-пака, официальный релиз которого планируется в первой половине 2004 года.

Содержание письма практически повторяет официальное заявление Microsoft о составе Service Pack 2. Утверждается, что сервис-пак будет содержать персональный браундмауэр, доработанный сервис Windows Update, а также исправления недоработок в системе защиты как самой системы, так и ее компонентов, в частности, Internet Explorer и Outlook.

Аналитики склоняются к мнению, что Service Pack 2 станет гораздо более важным и полезным пакетом обновлений, чем его предшественник SP 1.

Microsoft будет распространять обновления для Windows на компакт-дисках

Компания Microsoft рассматривает возможность выпуска компакт-дисков с обновлениями для своих операционных систем. В настоящее время софтверный гигант готовится начать бета-тестирование новой схемы распространения патчей. В письме, разосланном потенциальным тестерам, говорится о том, что прием заявок на участие в тестировании будет проводиться до 5 декабря 2003 года.

В рамках бета-тестирования на компакт-дисках будут выпускаться обновления только для операционных систем Windows 98, 98SE и Me. На дисках будут записываться критические обновления, в настоящее время доступные через службу Windows Update. В письме к бета-тестерам говорится, что такая схема распространения обновлений предназначена, в первую очередь, для пользователей с медленными подключениями к интернету или вовсе без таковых. Кроме того, обновления на CD могут показаться некоторым пользователям более удобными, чем загрузка патчей из интернета.

О том, когда обновления на компакт-дисках начнут поставляться конечным потребителям, пока неизвестно. Неясно также, будут ли аналогичные обновления выпускаться для более современных операционных систем Windows 2000 и XP. Однако то, что выпуск обновлений к Windows на компакт-дисках окажется полезным, сомнению не подлежит. В последнее время Microsoft часто говорит о своей приверженности обеспечению безопасности своих программных продуктов. При этом компания не раз подвергалась критике за то, что критически важные обновления доступны только через интернет, что затрудняет ликвидацию дыр для многих пользователей.

Motorola и Microsoft представили смартфон на базе Windows Mobile

На совместной пресс-конференции компаний Microsoft и Motorola в России был представлен первый смартфон на базе операционной системы Windows Mobile - Motorola MPx200. О разработке нового мобильного телефона было объявлено в сентябре этого года, а на российском рынке телефон появится уже в декабре.

Новая модель, стоимость которой составит около 650 долларов США, ориентирована на корпоративных пользователей. Действительно, судя по цене и возможностям устройства, владельцами смартфона станут руководители компаний и подразделений, которым необходимы такие бизнес-инструменты, как электронная почта, интернет-пейджинг и работа с документами.

Несмотря на мощность встроенного процессора и обилие возможностей, разработчикам удалось уместить "начинку" телефона в компактный корпус типа "раскладушка". MPx200 работает в сетях GSM 900/1800/900 МГц, встроенная батарея емкостью 750 мАч обеспечивает работу телефона в режиме разговора до 240-270 минут, в режиме ожидания - до 116 часов. Модель оснащена цветным экраном с разрешением 165 x 220 точек с выводом 65 тысяч оттенков цвета. Поддерживаются карты расширения Secure Digital объемом до 1 гигабайт.

На пресс-конференции менеджер по продажам решений Microsoft Иван Пашкевич продемонстрировал возможности смартфона на собственном экземпляре устройства. Надо отдать должное представителю Microsoft, с его помощью журналисты смогли увидеть в работе реальный телефон с реальными задачами - не каждый может на такое решиться. В ходе презентации была продемонстрирована работа с электронной почтой с подключением к интернету через GPRS, работа с контактами в адресной книге, просмотр видео и другие задачи.

Так как версия Microsoft Windows Mobile для смартфонов устанавливается на специализированные устройства, отличающиеся по характеристикам от обычных КПК на базе Pocket PC, то совместимость программ не гарантируется: для Pocket PC Smartphone Edition будут писаться отдельные версии ПО. Motorola MPx200 поступит на рынок с русификатором, но первые партии будут поставляться без лазерной насечки русских букв на клавиатуру. В дальнейшем планируется полная русификация устройства.

Источник: http://www.compulenta.ru/

***
Рекомендуем
Удобно! Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***
Copyright © Internet Zone, info@izcity.com


2-х портовый жёсткий диск

Автор: Alex, editor@izcity.com

Неудачный эксклюзив - 2-х портовый жёсткий диск - Техническое устройство для виртуальной любви

Фирма Quiksilver, занимающаяся продажей и разработкой различных электронно-технических устройств, выпустила ограниченное число популярных цифровых камер Sony DSC-U60. Оригинальность этих цифровых камер обусловлена эксклюзивным дизайном и улучшенными техническими характеристиками корпуса, в котором заключена цифровая камера.

Цифровая камера Sony DSC-U60 разработана для людей, ведущих спортивный образ жизни, занимающихся экстремальными видами спорта. Специалисты Quiksilver разработали специальный корпус для этой цифровой камеры. Корпус предохраняет цифровую камеру Sony DSC-U60 от различных ударов, потрясений, попадания воды и пыли. Этой цифровой камерой можно делать снимки под водой.

Продажа цифровых камер Sony DSC-U60 в корпусах от Quiksilver планируется через некоторые спортивные клубы Америки и только людям, состоящим в этих спортивных клубах.

Данный совместный проект Sony и Quiksilver критикуют как электронные, так и бумажные издания, пишущие про технические новинки. Этот проект называют необдуманным маркетинговым шагом корпорации Sony. Ведь по своей сути цифровая камера Sony DSC-U60 является бюджетной моделью, рассчитанной на самый широкий круг пользователей; а из этой цифровой камеры попытались сделать эксклюзивную вещь. Sony DSC-U60 в оригинальном корпусе разработки Quiksilver, продаётся за 300 долларов.

***

Компания IO Data (Япония) выпустила новый модельный ряд переносных жёстких дисков: LANDISK. В этом ряду разработчики представили три модели жёстких дисков с различными объёмами хранимой информации: 120GB (HDL-120U), 160GB (HDL-160U) и 250GB (HDL-250U).

Для уменьшения шума, издаваемого этими жёсткими дисками, была разработана специальная технология. Суть этой технологии сводится к тому, что при простое в работе диски совершенно не издают шум.

Жёсткие диски серии LANDISK имеют по 2 USB порта. При помощи первого порта устройство подключается к компьютеру, а второй порт можно использовать для подключения принтера, при этом, жёсткий диск становится сервером для печати различных документов.

Максимальная скорость передачи данных от жёсткого диска серии LANDISK к персональному компьютеру составляет 94.5 мб/с. Корпус изготовлен из алюминия. Размер: 42x265x131 мм. Вес: 1.4 кг.

Жёсткие диски LANDISK совместимы со следующими операционными системами: Microsoft Windows 98/ME/NT 4.0(SP4)/2000/XP, Mac OS 8.1 ~ 9.2.2 и Mac OS 10.1 ~ 10.3.

***

Устройство, рассмотренное ниже, устанавливается в 5.25 дюймовый слот системного блока. Для нормальной работы требует инсталляции специального программного обеспечения. В этом нет ничего необычного, необычность этого устройства начинается с его названия. Название на чистом русском языке звучит: FuckU-FuckMe. Основное предназначение FuckU-FuckMe: установка сексуальной связи двух партнёров через... интернет!

Вот уж, во истину - если есть на что-то спрос - найдутся люди, которые удовлетворят его предложением. Наверное, так и появилось это устройство, точнее, два аппаратных устройства (назовём эти два устройства М и Ж) + программное обеспечение связывающее их между собой.

Вот фотографии FuckU-FuckMe (М, Ж):

На первой фотографии можно увидеть имитатор мужских половых органов, на второй - женских.

Принцип работы FuckU-FuckMe, написанный сухим техническим языком: В реальном времени происходит связь между двумя персональными компьютерами по TCP/IP протоколу. Воздействие на устройство Ж отражается на устройстве М. Интенсивность воздействия варьируется.

На сайте разработчика FuckU-FuckMe всё как положено: детальная информация о продукте (в картинках), техническая поддержка, гарантийное обслуживание, FAQ. Производитель искренне заботится о пользователях (тут почему-то "пользователь" звучит чуточку по-другому). Производитель рекомендует использовать файрвол для защиты от интернет атак и презерватив для гигиенических целей!

Для дополнительной информации посетите сайт разработчика.

Вот такое устройство. Дорого? Дёшево? Не знаю... Но, Сердито!
***
Рекомендуем
Рекомендуем! Книга "Практическое руководство по управлению личным капиталом с помощью ценных бумаг"
научит вас трем несложным, но действенным способам извлекать прибыль из собственных сбережений. В отличие от валюты и банковских вкладов, ценные бумаги сегодня - это реальная возможность сохранить сбережения и получать с них реальный доход больше инфляции.
Ценные бумаги - это не только для богатых. Покупать ценные бумаги и получать прибыль можно даже начиная с 1000 рублей.
 "Узнайте Три Способа Заставить Свои Сбережения Бороться с Инфляцией и Приносить Доход До 25% Годовых и Выше". Прочитайте электронную книгу!


Dejа vu, или Тонкий песок Сахары

Автор: Евгений Козловский

Когда мне принесли новую камеру от Canon — EOS 300D — у меня тут же возникло ощущение deja vu, «уже виденного»: ну да, я ведь три с небольшим года назад уже снимал этой камерой, гуляя по Парижу. И чем дальше я читал Instruction manual, и чем больше — снимал, тем это самое психиатрическое ощущение селилось во мне все глубже и глубже.

Конечно, та камера называлась EOS 30D (на один нулик беднее), имела более чем вдвое меньший логический размер матрицы и более чем втрое высшую цену, да и еще кое-какие мелочи поменялись (пластмассовый корпус, который не так удобно держать в руке [нет препятствующих скольжению насечек]), пластмассовое же зеркало [которое, надо полагать, работает не хуже стеклянного, — во всяком случае, на первых порах], вынесенный на заднюю крышку, чуть выше основного дисплея, дисплей информационный, да заметно меньший объем оперативной памяти [на EOS 30D я делал снимки подряд в количестве, казавшемся неограниченным, — здесь же больше четырех подряд не снять, потом едва ли не полминуты, как у Olympus’а, приходится ждать, пока память освободится путем перекачки информации на флэшку] — вот, пожалуй, и все. Даже TWAIN, записанный на одном из прилагаемых к EOS 300D компакт-дисков, не знаком с Windows XP, то есть, вероятно, не переделывался с тех парижских времен…1

Нет, я отлично понимаю разницу между тремя тысячами долларов и девятью сотнями, и, возможно, многие мои читатели поймут (во всяком случае — почувствуют) ее еще лучше, — и тут, конечно, Кэнону можно только рукоплескать. Выпуск однообъективной, со сменной оптикой, цифровой зеркалки за цену ниже некоего психологического барьера (1000 зеленых) — это шаг потрясающий и, возможно, самый широкий за всю историю цифровой фотографии. Если вы раньше снимали пленочным EOS, у вас наверняка сохранилось несколько объективов, — они подойдут, правда — заметно потелевеют2 (физический размер матрицы у EOS 300D [как, впрочем, и у EOS 30D, и у EOS D 60] меньше, чем размер пленочного кадра, так что фокусные расстояния объективов приходится умножать на 1,6), если же таких объективов у вас нет, возможно, имеет смысл купить камеру со специально разработанным для нее объективом, который все равно не должен увеличить цену комплекта выше той самой штуки. Мне камера попалась без этого специального объектива, так что о его качестве сказать ничего не могу, посему ограничиваюсь цитатой с русского сайта Canon: «Он использует преимущества компактного датчика и благодаря системе «short back focus» (короткий задний рабочий отрезок) размещается ближе к нему, чем в предыдущих моделях. В результате высокое качество изображения сочетается с необыкновенной легкостью и компактностью объектива (увеличение 1,6x снижает возможности широкоугольной съемки, поэтому рекомендуется использовать новый объектив EF-S 18–55 мм)».

Переводя на совсем уж русский язык, поясняю: поскольку матрица меньше пленочного кадра, можно уменьшить и размер рабочего поля, и, стало быть, сам объектив. Правда, непонятно, что имеется в виду под 18–55, то есть нужно ли их умножать на эти самые 1,6, или, коль объектив сделан исключительно под эту камеру, значения уже натуральные. Еще непонятно (скорее — огорчительно), что светосила этого объектива никак нельзя сказать, чтобы… ну, положим, по сравнению с двойкой E-20-го Olympus’а, хотя там физический размер матрицы все-таки значительно меньше.

Три года назад я сравнивал EOS 30D с D1 от Nikon, ибо Olympus E-10 тогда еще не попал в мои руки (хоть, вроде, и появился), а 2500-й сравнения, конечно, не выдерживал (http://www.computerra.ru/offline/2000/369/5694). Сейчас я намерен сравнивать EOS 300D с Olympus E-20, которым пользуюсь уже почти два года. Мне очень жаль терять те преимущества, которые

E-20 имеет перед EOS 300D (на соответствующие достоинства я отнюдь глаза не закрываю и все их перечислю; но дело в том, что для меня лично сегодня они недостатков не перекрыли).

Итак, я не хочу:

  • терять возможность строить кадр не только через видоискатель, но и по жидкокристаллическому поворотному экрану: это позволяет поднять в толпе аппарат над головой или положить его на землю;

  • терять возможность вручную пройтись по матрице и убрать битые пикселы;

  • терять возможность записывать результаты съемки не только в формате JPG, но и в формате TIFF, а JPG’и сжимать не так сильно, как — даже в случае fine-качества — сжимает их EOS;

  • вручную, эмпирическим путем, выставлять экспозицию, если пользуешься неправильным, не под Canon заточенным, объективом: теоретически система TTL должна мерить реальный свет, попадающий на матрицу, — у EOS 300D все устроено как-то по-другому, там огромную роль играет информация, идущая в камеру от объектива, — так что, когда я присоединил к аппарату отечественный зеркальный телевик MC 3M-5CA (в пору моей молодости он назывался МТО-500), первый же снимок, сделанный в автоматическом режиме, оказался пересвеченным раз в десять!

  • покупать по цене, которая в сумме с ценой коробки заметно перекроет цену Olympus’а, объектив, который будет сравним по диапазону фокусных расстояний и, главное, по светосиле (1:2.0) со встроенным Olympus’овым;

  • и, наконец, возможно, в-главных, — иметь головную боль с очисткой матрицы.

Пришло время объяснить заголовок. Первого мая сего года я оказался в Сахаре. Дул ветер, все затянуло песчаным туманом, ибо песок в Сахаре мелок и, разумеется, проникает сквозь любые дырочки. Я ехал на верблюде с Olympus’ом в руке и насадками в сумке и снимал то и се, накручивая/свинчивая подходящую насадку. Прошло уже более полугода, а когда я надеваю или снимаю бленду, она поскрипывает «сахарным» песком; следы его я вижу и под управляющими дисками, и по обводу дисплея. Но внутрь не проникло ни пылинки, и сенсор остался в неприкосновенности. Вообразите себе, что произошло бы с сенсором, если б я во время этой верблюжьей прогулки пару раз поменял объективы на EOS 300D… А, может, даже если б и не поменял… А чистить сенсор приходится с очень большой опаской, вручную (в меню есть строчка, при нажатии на которую зеркало поднимается, и вы должны как-то очень уж осторожно, лучше всего — воздухом через грушу или очень уж специальной кисточкой по сенсору пройтись).

Возможно, победное тридцатилетнее шествие по планете пленочных зеркалок от Canon (а пленка попадающую случайно, при смене оптики или просто от негерметичности байонетного соединения, пыль выносит вместе с собой, особого вреда ни себе, ни камере не причиняя), несколько усыпило бдительность конструкторов, и они не подумали об этой проблеме. Куда менее успешный на пленочной стезе Olympus оказался предусмотрительнее, и в новой модели со сменной оптикой предусмотрел фильтр от пыли, который после каждого снимка встряхивается пьезоэлементом, ссыпая пыль в специальный приемник. Ну а в зеркальных моделях с несменной оптикой, как выявило испытание Сахарой, герметичность идеальная.

Теперь честно перечислю, чего из наличествующего у EOS 300D очень не хватает мне в Olympus’е:

  • во-первых, скорости реакции автофокуса; она заметно зависит и от объектива; впрочем, тратиться на слишком быстрые и потому — ужасно дорогие, я не советую: сама коробка — тоже не рекордсменка по скорости автофокуса, — тем не менее, в хороших условиях он наводится за сотые доли секунды, обгоняя ту же систему Olympus’а уж как минимум раз в десять; сюда же пристегнем и слежение за движущимся объектом;

  • во-вторых, возможности выставить чувствительность аж до 1600 единиц ISO и в результате снимать ночью на освещенных улицах или в помещениях с одной лампочкой под потолком — с рук. Конечно, далеко не каждый такой снимок оказывается качественным, примерно один из пяти, — однако и это не так мало;3

  • в-третьих, автоматический поворот картинок…

Прочие достоинства EOS 300D колышут меня мало: шесть мегапикселов по сравнению с пятью Olympus’овыми4 реально мне вряд ли когда понадобятся; заметно больший физический размер матрицы (которая чем больше, тем большую может дать чувствительность и фотографическую широту) я при внимательном сравнении снимков не ощутил; может, профессионалы разницу и увидят, но на моем уровне… Не исключено, что определенную роль в незаметности разницы играет разница в принципах матриц: CCD у Olympus’а и CMOS — у Canon’а5.

Засим, тем не менее, от души поздравляю всех-всех-всех с тем, что появилась вполне, в общем-то, серьезная (для любителя) однообъективная зеркалка от очень авторитетной фирмы и по вполне доступной цене.

1 Впрочем… кажется, у EOS 30D не было брекетинга баланса белого (то есть съемки кадра в трех вариантах, со сдвигом баланса чуть вправо и чуть влево), а только экспозиционный. Но наверняка я не помню. К тому же вряд ли найдется желающий приобретать сегодня EOS 30D, когда в продаже полно более продвинутых аппаратов EOS D60, которые вдвое дешевле.
2 То есть увеличат фокусное расстояние.
3 Не могу обойтись без замечания: светосила выданного мне с аппаратом совсем не плохого фирменного объектива от Canon (Made in Japan) составляет 1:3,5–4,5; это значит, что чувствительность моего Olympus’а со светосильным (1:2) объективом имеет максимальную чувствительность не 320 ISO, а как минимум 640, а то и больше. Можно, конечно, приобрести и к Canon’у объектив посветосильнее, но тогда главный козырь новинки — смешная цена, — согласитесь, уходит в тень…
4 Неполные три мегапиксела EOS 30D вполне позволили мне распечатать несколько картинок на бумаге форматом А3+, — и более чем удовлетворительно.
5 Вообще-то матрицы CMOS считаются сильно проигрывающими по количеству шумов, чувствительности и качеству цветопередачи матрицам CCD, но Canon разработал специальный алгоритм компенсации недостатков, и результаты, на мой вкус, очень и очень хороши. Правда, говорят, что матрица начинает шуметь тем сильнее, чем теплее вокруг, — но мне камера попала в руки при нулевой температуре на улице, да и дома — не особо жарко.

Источник: http://www.computerra.ru/

***
Рекомендуем
Книга "Сам Себе Копирайтер"
 Представьте, что бы вы могли натворить, если бы в вашем распоряжении оказалась коллекция тщательно охраняемых секретов лучших профессиональных копирайтеров - мастеров написания безукоризненных и эффективных рекламных текстов? Представили? Тогда СМЕЛО приобретайте это великолепное издание! Оно раскроет вам в реальности те секреты, которые поражают вас, когда вы сталкиваетесь с самым лучшими и эффективными образцами воздействия, созданными с их помощью!
Узнать подробнее о книге "Сам Себе Копирайтер"


Iron FAQ 135

Автор: Назгул

Нервные подмигивания
Материнское надувательство
Ощипывание дятла
Вредные датчики

Про спасение дятлов и оплошность NVIDIA

Нервные подмигивания

Все было хорошо, пока я не возжелал более быструю видюху... Выбрал ASUS V9480 (GF4 4800 SE). XP определяет ее как просто "видеоадаптер VGA-совместимый". Ставим дрова - и началось... Каждые 5-7 секунд монитор мигает. Не проблема: качаем дрова поновее - то же самое. Отключаем все лишнее (PCI, харды) - мигает. Несем видюху к друзьям - работает. Меняем маму (Gygabyte GA8ST) на такую же - мигает. Подключаем к другу, у которого такая же мама, - РАБОТАЕТ!!! Все решилось через три (!) недели отключением в BIOS Top Performance.

Pavel

Материнское надувательство

Однажды друзья попросили меня посмотреть их компьютер на чипсете VIA сборки ASUS, который после пяти минут работы в любом режиме вис намертво и затем соглашался только на перезагрузку. Промучился я с ним три часа, закончил танцем с бубном - не помогло. Тогда забрал его домой, для препарирования на досуге. Досуг тогда не наступал долго, а до того времени я поискал в Сети похожий глюк - и нашел! Компы, похоже, виснут при проблемах со стабилизацией в схеме питания процессора. А мой небольшой опыт радиолюбителя подсказал мне проверить состояние электролитических конденсаторов из обвязки проца. Ха!

Так и есть: кондеры в количестве трех штук вздулись, и еще четыре были под вопросом. В фирме, которая и впарила друзьям комп год и месяц назад, оценили перепайку всех непонятных (11 шт.) конденсаторов в 1,5 русских тысяч рублей (136 руб. за штуку). Учесть доводы друзей, подсказанные мной, на тему того, что это заводской брак, они наотрез отказались, посочувствовав попутно по поводу истекшего срока гарантии - год. Друзья согласились. Комп работает как часы. Но самое интересное, что неработающий комп стоял у них уже три месяца до обращения ко мне. Поистине: ученье - свет и экономия, а незнание закона о потребителях - тьма и надувательство.

С уважением, Андрей Маурин

Ощипывание дятла

Однажды, находясь в гостях у друзей, узнал, что у них есть неработающий и поэтому, возможно, ненужный винчестер IBM DTLA на 20 Гб, который ввиду не функционирования компьютера был заменен на коллегу из Western Digital. Диагноз одного местного левши был жесток: убой нулевой дорожки. Я забрал диск на запчасти, а сам решил покопаться на досуге, а так как было очень интересно, то приступил к исследованию умершего в тот же день. Да, действительно, кроме скрежета при старте, винт ничего не издавал.

Потом в процессе перемещения по столу и шевеления соответственных шлейфов, торчащих из моего компа, диск определился. Я был счастлив: на халяву работающий винт на 20 Гб. Но счастье продолжалось пару дней, затем диск опять умер, на этот раз навсегда, по крайней мере, я так подумал. Напоследок решил отдать его на ремонт в фирму со средней квалификацией спецов. В фирме посочувствовали и предложили забрать металлолом обратно. Я расстроился и разобрал на досуге винчестер от нечего делать - снял крышку с моторного блока, впервые посмотрел на моторный блок изнутри, закрыл обратно и стартовал, увы, чуда не произошло.

Пришлось обратиться к справочным материалам, уже, как я считал, чисто из теоретического интереса. Вопросов было два - лечится ли убой нулевой дорожки или это что-то похожее и на какой свалке принимают винчестеры после снятия крышки с моторного блока. На первый вопрос советов было много, на второй вопрос совет был один - если сниматель идиот, то это не лечится. Я немного расстроился за идиота и решил доказать обратное. Воскрешение мумии началось.

Первым делом я озадачился удалением пыли из моторного блока. Думал долго и остановился на идее связывания пыли во влажной среде. Наполнил шприц чистым медицинским спиртом и забрызгал им моторный блок, затем, не дожидаясь испарения жидкости, установил крышку на место. Физику в школе проходили - на больших оборотах пыль с дисков смоет центробежной силой и задержит внутренним пылеулавливателем, который сделан в виде синтетической подушечки.

А спирт при прогреве диска испарится через отверстия, заклеенные спецтканью, и никаких там стерильных комнат для разборки винчестеров. То, что мне пришлось специально из-за спецболтов на крышке покупать американский набор сменных магнитных жал к отвертке с храповиком стоимостью 1/3 винчестера, я отношу к необходимости момента. Затем стал пытаться форматировать диск всеми мыслимыми и немыслимыми способами. К сожалению, диск все не оживал. И тогда я совершенно случайно на одном из форумов (дай бог здоровья автору тех строк) прочитал о плохом конструктивном решении инженеров из фирмы IBM.

Решение состояло в стыковке моторного блока посредством двойного ряда игл, которые втыкались при сборке в подушки из припоя на плате. А так как гнездо крепления шлейфа находится на плате без дополнительной фиксации, то углубления в подушках от изгиба платы со временем увеличивались и электрический контакт на нескольких иглах пропадал. Я тут же снял плату - так и есть.

Далее завальцевал углубления от игл, собрал все, включая шлейф, воедино и написал на нем фломастером большими красными буквами: "Шлейф от диска не отсоединять!" Затем не дыша установил винчестер в системный блок, стартовал и заорал: "Банзай!" Диск определился, позволил себя отформатировать и прочее...

С уважением, Андрей Маурин

Вредные датчики

У меня мать ASUS A7N8X (BIOS версии 6.0PG, ревизии 1005). На борту две оси - Windows 98 SE русская версия и Windows XP русская версия. В обеих системах стоят дрова на мать и утилита для показа температуры, оборотов вентиляторов и напряжения - ASUS PC Probe V2.19.07. Эта утилита в Windows XP все показания выводила, а в Windows 98 SE почему-то не показывала температуру камня и матери, обороты вентиляторов (всех!), а из напряжений почти все, кроме 5 В. Я решил разобраться, в чем дело! Первым делом полез в BIOS, чтобы посмотреть, что с показаниями счетчиков.

Там все показания были выведены! Тогда я загрузил Windows 98 SE и полез в "Систему" (Пуск > "Настройка" > "Панель управления" > "Система"). Просмотрев все разделы, решил остановить свое внимание на разделе "Системные устройства", потому что, кроме этого раздела, не было ни одного, связанного с мамкой. В нем нашел пункт "NVIDIA nForce PCI System Management" и решил отключить его, подумав, что это поможет. И действительно: помогло! После перезагрузки Я УВИДЕЛ ВСЕ (!) ПОКАЗАНИЯ СЧЕТЧИКОВ! Вот и весь фокус! Только вот интересно - неужели это оплошность NVIDIA?

С уважением, Усов Аркадий

Источник: http://www.computery.ru/upgrade/

***
Рекомендуем
Хотите сыграть в пейнтбол?
Пейнтбол - это игра, в которой можно изрешетить "злобного" шефа или "зануду" подчиненного из специального оружия, маркера, используя при этом "пули" - разноцветные шарики с краской. Главное - в итоге все останутся живы.
Подробнее >>


Матрешка из Тайваня

Автор: Георгий Башилов

Как показала недавняя выставка Computex 2003, к традиционным тайваньским поставщикам беспроводных систем, таким как SMC Networks, ZyXEL, Planet, D-Link, уже примкнули почти все ведущие производители системных плат, видеоускорителей и иного компьютерного «железа».

В их числе — AOpen, ASUSTeK Computer, (вышедшая на рынок WiFi уже больше года назад), Gigabyte Technologies (на минувшем «Компьютексе» посвятившая беспроводным решениям многочасовую конференцию совместно с Intel) и MicroStar International.

Производители и маркетологи оказались сейчас в очень непростой ситуации. Несмотря на кажущееся обилие производителей чипсетов, подавляющая часть беспроводных устройств (по крайней мере, прошедших через нашу лабораторию) делается на базе наборов микросхем Atheros. Ситуация усугубляется еще и тем, что в ход все чаще идут эталонные платформы, когда и разводка платы, и рекомендуемый набор компонентов и интерфейсов задаются самим изготовителем полупроводниковой базы. Таким образом, у производителя самого устройства остается весьма ограниченный набор инструментов, с помощью которого он может попытаться угодить требованиям целевой аудитории: внешний вид и набор софта и интерфейсов для управления очередным чудом инженерной мысли.

Не стала исключением беспроводная Cardbus-карта MSI CB54G, любезно предоставленная нашей лаборатории. В случае Cardbus-карт задача дизайнеров еще более трудна: по сути, в их распоряжении оказывается лишь небольшой выступ на корпусе ноутбука, скрывающий крошечные антенны (к сожалению, мне ни разу не встретились беспроводные PC-карты хотя бы с полупрозрачным чехлом, так что удовлетворять любопытство приходится, разглядывая фотографии антенн и эталонных платформ на сайте Atheros).

Выдержанный в строгих пропорциях, на удивление легкий и «воздушный» чехол CB54G выкрашен чем-то, смахивающим на серебрянку. Пара голубых светодиодов — весьма скромных размеров, так что подсветка даже в темноте не режет глаз. Во время работы постоянно горит лишь один из них, а второй — подмигивает в такт передаваемым пакетам.

Основные характеристики адаптера MSI CB54G.

Круг первый: тень прошлого

При первом подходе под рукой не оказалось ни драйверов, ни описания, но они и не понадобились. Будучи вставлена в ноутбук, CB54G «зацепилась» за останки первенца стандарта 802.11g — карты Buffalo WLI-CB-G54A. Сама карта давно нашла другого хозяина, в ноутбуке остались лишь драйверы, еще прошлогоднего разлива.

Карточка распозналась и после занесения в настройки имени сетевого идентификатора (SSID) соединилась с домашней точкой доступа. (Для обеспечения минимальной безопасности трансляция SSID на моей домашней точке доступа запрещена: следующим шагом стало отключение на время бездействия и самого беспроводного интерфейса. Когда нужно поработать с ноутбуком, интерфейс легко включить через веб-страничку точки доступа, а по совместительству — маршрутизатора и межсетевого экрана. В результате получается довольно надежная защита от посягательств извне.) Соединение было охарактеризовано как «Very Good», а скорость в канале достигла отметки 18 Мбит/с (при расстоянии до базы около 6 м и отсутствии прямой видимости, преградами служили керамзитобетонная стена толщиной 40 см и ваш покорный слуга).

Время пинга, или скорость распространения IP-пакетов, составило в среднем миллисекунду (с максимальной задержкой 35 мс на пятиминутном интервале измерения), потерянных пакетов — ноль. Скорость однонаправленной передачи по протоколу UDP, пакетами в полторы тысячи знаков, достигала в пике чуть ли не 13 Мбит/с, падая при использовании TCP до 8,5–9 Мбит/с.

Установка свежайшего доступного драйвера с сайта Buffalo сделала работу карты более чуткой к условиям распространения радиосигнала, повлиять на которые может прошедший неподалеку человек или даже легкое изменение позы владельца ноутбука. Более адаптивной стала канальная скорость, оперативно подстраивающаяся и вверх, и вниз для достижения максимальных параметров; чуть уменьшилось время максимальной задержки распространения пакетов (максимум 15 мс при неизменном среднем в 1 мс).

1 Как видно из результатов измерений (мы использовали свободно доступную на сайте Mikrotik программу Bandwidth Test), повышение канальной скорости не приводит к пропорциональному увеличению скорости передачи пакетов. Максимальный результат, достигнутый на скорости канала 54 Мбит/с при UDP-передаче, не превысил 22 Мбит/с. Видимо, ограничивающим фактором становится уже не сам радиоканал, а вычислительные возможности набора микросхем и пропускная способность интерфейсов.

Круг второй: MSI 6819

Разумеется, дошли руки и до «родного» софта, то есть поставляемого MSI и адаптированного этой компанией в соответствии с ее представлениями о требованиях и запросах рынка. Нарушив давнюю российскую традицию, я прочитал описание, и, как выяснилось, не зря: лишь в нем нашлась информация о самом существовании и процедурах настройки поставляемого с картой ПО, обеспечивающего ее работу в режиме точки доступа (разумеется, вместе с компьютером). Таким образом, карта работает в трех режимах:

  • Ad-hoc, или одноранговая сеть беспроводных устройств;
  • Infrastructure, инфраструктурный режим, или клиентское подключение к беспроводным точкам доступа;
  • Access Point, или беспроводная точка доступа (сервер доступа в Ethernet-сеть для беспроводных клиентов).

Если следовать самой, пожалуй, естественной и распространенной процедуре, то есть сначала становить программное обеспечение из комплекта поставки и уже затем, чтобы избежать всевозможных «найденных, но не обнаруженных» устройств, устанавливать сетевой адаптер, то в результате автоматического поиска выбирается драйвер для MSI 6819 Cardbus Wireless Network Adapter. В режиме «54g 802.11b compatible» драйвер устанавливает соединение с точкой доступа SMC только на скорости 11 Мбит/с. Перевод в режим «802.11g performance» ничего не изменил — скорость по-прежнему 11 Мбит/с. Расстояние до точки доступа при этом не превышает полуметра. В опциях драйвера можно выбрать наилучшую скорость (best), но достичь ее удается только принудительным заданием фиксированных 54 Мбит/с. Как знать, может, разработчики предпочитают добрый проверенный 802.11b всяким там новомодным .g?

Идем дальше. Набор контролируемых параметров в этом режиме довольно ограничен: выбор 802.11g, канала, локального набора частот (Locale), MAC-адреса (эта фича пригодится при взломе недружественной точки доступа), длины заголовка (длинный/короткий), мощности (от 25% до 100% с шагом 25% — хотя куда информативнее и понятнее были бы децибелы), параметров энергосбережения, а также отключение радиоинтерфейса, принудительный выбор скорости (из набора 1, 2, 5,5, 6, 9, 11, 12, 18, 24, 36, 48, 54 и Use best rate — последняя опция, как мы уже убедились, не шибко полезна) и оптимизация параметров для минимизации коллизий (RTS Threshold). Доступ к утилите управления картой возможен только через значок в панели задач. Попытка запустить ее картой WlanUtility через меню запуска программ не приводит к видимым результатам. Утилита сразу минимизируется в трей и доступна только оттуда. О программных точках доступа ни в утилите, ни на сайте производителя нет ни слова, узнать об их существовании можно только из руководства пользователя.

Круг третий: живая вода от Microsoft

Может быть, дело в драйвере? Хвала китайской предусмотрительности — софт даже искать не пришлось. Система нашла все сама, с помощью опций автоматической установки ПО и недвусмысленного намека поискать что-нибудь посвежее (что мешало установить этот драйвер сразу, а не заморачиваться с «промежуточным» MSI 6819?). В итоге перед нами предстал IEEE802.11g Wireless Cardbus Adapter (скриншот 2), опций у которого куда как больше. К нашим старым знакомцам прибавились:

  • Antenna diversity, или возможность управления разнесенным приемом. Да, да, под этим крошечным чехлом скрывается не одна, а по крайней мере две антенны; правда, система по-прежнему оставляет выбор за собой, в числе возможных вариантов лишь один — Auto;
  • Bluetooth collaboration, или мирное сосуществование с «голубым зубом». Сосуществование, как обычно бывает, можно включить, а можно и выключить, перейдя к «активным боевым действиям» простым выбором — enable/disable;
  • Roaming decision. Среди возможных вариантов — настройка по умолчанию (Default), оптимизация по скорости (Bandwidth) и дальности (Distance).

Можно предположить, что эти параметры управляют возможностями загадочной точки доступа.

Еще один загадочный пункт — Xpress Technology. Впрочем, загадочный ровно постольку, поскольку под рукой не оказалось такой же карты MSI или любого другого производителя, использующего чипсеты Atheros. Согласно заявлениям производителя, эта проприетарная технология обеспечивает более эффективное использование канала и некоторые другие преимущества в скорости передачи. Впрочем, «продукт познается в сравнении»: о поддержке сходных технологий (расширений стандарта 802.11g) уже заявили по крайней мере четыре производителя — Agere, Atheros, Intersil и Texas Instruments.

Круг четвертый: где же ты, моя Сулико?

Точка доступа, тем не менее, нашлась — в составе программного пакета, поставляемого... вместе с картой. Редкий и невиданный прежде случай: на сайте MSI доступна для скачивания лишь старая, майская, версия ПО. На CD-ROM — свежак, не добравшийся до расположенного поблизости сервера, но успевший оказаться в далекой России: версия 3.2.4.23, датированная 22 июля 2003 года. Объем распакованного архива — 7751496 байт. Для сравнения — предыдущий релиз «весил» 5077165 байт, или почти на 2,5 Мбайт меньше. Одним из отличий и стала точка доступа.

К чести разработчиков, проблемы, связанные с инсталляцией драйверов и утилит управления, в новой версии практически исчезли. Исчез и дуализм при выборе драйверов во время инсталляции — очень похоже, по крайней мере по списку параметров, вынесенных в панель управления, что используется драйвер из майского комплекта ПО, а изменения затронули скорее надстройку — утилиту управления и программную точку доступа. Вдобавок и WlanUtility, и точка доступа сохраняют работоспособность с предыдущими драйверами.
Ряд прекрасных изменений милого лица

При активации режима AP Mode происходит три важных превращения:

  • беспроводной интерфейс из клиентского превращается в серверный (правда, при этом «видит» соседние, инфраструктурные точки доступа, но не может устанавливать с ними связь — по крайней мере, мне это не удалось);
  • средствами встроенного в утилиту ПО создается сетевой мост, объединяющий выбранные сетевые интерфейсы под одним IP-адресом и прячущий какие бы то ни было дополнительные протокольные настройки каждого из интерфейсов, объединяя их в меню настройки режимов моста ;
  • активируется HTTP-сервер — теперь настройками новоиспеченной точки доступа можно управлять через веб-интерфейс (правда, число параметров довольно ограничено, как и диагностика — вся информация о подключенных устройствах заканчивается их MAC-адресами).

Тестирование производительности точки доступа рекордов не принесло — лишь уверенные и стабильные 10 Мбит/с по протоколу TCP/IP в направлении к точке доступа и максимум 4 Мбит/с от нее (разница в скорости передачи TCP- и UDP-пакетов практически отсутствовала, что довольно странно, — то есть ограничения в скорости действуют скорее не на канальном уровне, а на аппаратно-программном). Следовательно, получившиеся у нас точки доступа и образуемые ими беспроводные интерфейсы больше подходят для сбора информации, например от мобильных агентов. И куда меньше, особенно с учетом асимметричности веб-трафика, — для доступа в Интернет. Этакий асимметричный ответ. В квадрате. Правда, ограничения по скорости будут наблюдаться только в том случае, если сам канал в Интернет имеет сопоставимую скорость передачи, что пока, согласитесь, редкое явление.

Общее впечатление от карты — весьма качественный и добротный продукт, разработчикам которого стоит уделить больше внимания антенно-фидерному тракту и совершенствованию софта, особенно эффективности алгоритмов передачи данных. Для сравнения — с драйверами Buffalo/Atheros карта CB54G передавала данные гораздо быстрее. Очень понравилось отображение мощности принимаемого сигнала (и, соответственно, если бы в спецификациях была бы указана чувствительность приемного тракта в децибелах — запаса по мощности всего тракта передачи данных). Так, экранирование рукой антенны карты приводило к ослаблению сигнала, в зависимости от положения руки и передающей антенны, на 5–15 дБ .

Возможности компаний-интеграторов и OEM-производителей, таким образом, далеко не ограничиваются дизайнерскими изысками, маркетингом и возможностями референсного программного обеспечения, поставляемого вместе с картой. Может статься, настает пора русских матрешек?

Источник: http://www.computerra.ru/

***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>


Inet в глубинке

Автор: Тарас КОЛЯДА

Я всегда по доброму завидовал людям, живущим в больших городах. И не потому, что я не люблю сельскую местность, как раз наоборот, а потому что в городе есть свой провайдер Инета, что значительно облегчает жизнь компьютерщику. А что же делать остальным, неужели так и придется сидеть на обочине цивилизованного мира и ждать, когда добрый дяденька придет, установит сервер и разрешит всем добропорядочным (и не очень :-)) гражданам бродить по Сети?

Можно, конечно, самому попробовать организовать сие предприятие. Но дело это требует больших капиталовложений, которые в данном случае не скоро окупятся, да и бюрократический аппарат просто так не прошибешь (требует дополнительных средств). Так что рядовому пользователю такой вариант не подходит.

Так все-таки, что же делать? Неужели ситуация безнадежна? Вовсе нет.

Понятно, что в нашей ситуации о выделенной линии не может быть и речи. Остается Dial-Up. И тут есть два пути. Первый: можно купить карточку гостевого доступа, выпущенную провайдером, который находится в ближайшем городе. Далее настраиваем соединение. Как это сделать — детально описано на самой карте. Под WinXP это будет выглядеть примерно так: Пуск > Подключение > Отобразить все подключения > Создание нового подключения. При этом запускается мастер настройки подключения. В нем через обычный модем вручную выставляем параметры подключения: указываем имя провайдера, логин и пароль доступа, отмеченные на карточке, номер телефона для дозвона и жмем Готово. В появившемся окне необходимо нажать Свойства, где и установить правила дозвона, а именно код того города, в котором находится ваш провайдер, а также указать модему тип набора — импульсный. Если останется тоновый, выставленный по умолчанию, модем не сможет выйти на междугороднюю линию. И вот, после того, как все необходимые условия соблюдены, можем смело нажимать на кнопку Вызов.

С таким подключением вам будет доступен только сайт провайдера, на котором необходимо зарегистрироваться, ввести код карточки и выбрать тарифный план (советую выбирать, при наличии такового, ночной Unlimited, так как в этом случае тариф за междугородный звонок окажется самым низкий). И еще, заранее придумайте себе логин и пароль, который Вы будете использовать для входа в Сеть и для e-mail. В большинстве случаев Вы получите достаточно качественное соединение, которое, впрочем, больше зависит от технических свойств и состояния АТС в Вашем городе/поселке/селе. В моем городе Мироновка, что в Киевской области, скорость подключения оказалась в пределах 30–50 Кбит/с., обрывов связи практически не было.

После недолгих мучений с настройкой подключения, а они есть всегда (то линия у провайдера занята; то не принимается пароль, хотя при повторном наборе того же пароля все проходит гладко; и т.д.), начинаются трудовые будни серфера во Всемирной Паутине. Длится эта радость до тех пор, пока не приходится расплачиваться с Укртелекомом за междугородние переговоры, счета за которые будут содержать трехзначные (а возможно, и более) цифры. После этого первый пыл значительно остывает, и уже приунывший пользователь начинает ограничивать себя в выборе посещаемых ресурсов. Но это все равно слабо помогает, и выбиться из трехзначной суммы практически невозможно. Считайте сами: 0.12 грн. — минимальная стоимость 1 мин. за междугороднее соединение по области в ночное время + расходы на карточку. А ведь в Сети столько всего интересного, полезного и познавательного, и каждый раз, когда видишь в маленьком окошке быстро исчезающую надпись «Вход в сеть», сердце как будто замирает и кроме проверки почты и посещения ресурсов первой необходимости думаешь: «Да еще немножко задержусь здесь, вот еще на Масяню загляну» и т.д.

Но есть и второй путь. В МК уже публиковалась серия статей «Провайдеры по городам и весям», в которой рассказывалось о компаниях, предоставляющих услуги доступа в Интернет в разных областях Украины. В дополнение к этой информации расскажу еще об одном операторе (http://www.unet.utel.net.ua), который работает под крылом Utel. Выбор этого оператора поможет сэкономить Вам определенное количество «украинских долларов». В чем же его преимущества?

Точно также необходимо приобрести карточку, которые бывают двух типов: Старт и Ресурс. Карта типа «Старт» — на 2 часа доступа в Сеть, карты типа «Ресурс» бывают на 5-ть и 10 часов. Все карточки можно приобрести в отделении связи вашего населенного пункта, а также в региональных отделениях АКБ «Правекс-Банк», «Ощадбанка», в филиалах и банкоматах (!) «ПриватБанка» (подробнее смотрите на сайте). Сначала необходимо купить «Старт», где указан Ваш логин и пароль для доступа в Сеть, которые остаются постоянными (самому придумывать не нужно), пополнение же счета производится при помощи карты «Ресурс». Настройка соединения осуществляется вышеописанным способом. В итоге, Вы получите, конечно, несколько медленнее, чем в предыдущем варианте (23–48 Кбит/с), соединение, чаще случаются разрывы связи, дозвониться также несколько сложнее (номер дозвона один-единственный). Но преимущества данного варианта налицо — Вы не платите за междугороднее соединение (его стоимость уже включена в стоимость карточки), ходить по Сети можно в любое время суток (хотя все же лучше это делать в утреннее или позднее вечернее время, по причине занятости междугородней АТС). И наконец, у Вас появится временной ограничитель, что и будет уменьшать Ваши расходы — ведь не станешь же бегать каждый день за новой карточкой.

Заключение

При любом виде подключения Интернет в местности, где нет своего провайдера и нужно использовать междугороднее соединение, — вещь достаточно дорогая — 11–12 грн./час, при этом качество связи далеко не самое лучшее. Какой из предложенных выше вариантов лучше — выбирать Вам.

И под занавес хотелось бы дать несколько советов.

Перед тем, как покупать модем, выясните, какой АТС оборудовано Ваше отделение связи. Если у Вас аналоговая АТС, не стоит брать внутренний модем, скорее всего, он не справится с возложенной на него задачей вообще или будет подключаться с большими трудностями. Поэтому лучше остановить свой выбор на внешнем модеме, с так называемой «украинской прошивкой», то есть на том, который приспособлен к нашим линиям связи. Но если Вы точно уверены, что у Вас цифровая АТС, можете воспользоваться и внутренним.

И еще. В моем случае ходить в Сеть оказалось лучше под Windows 98. При попытке подключения через аналоговую АТС как с помощью внешнего, так и внутреннего модема под WinXP, после набора номера соединение не устанавливалось, а компьютер выдавал сообщение об ошибке 777, хотя под Windows 98 исправно коннектились оба модема.

Удачного Вам серфинга!

Источник: http://www.mycomp.com.ua/

***
Рекомендуем
Книга "Слова-Магниты"
Несколько лет работы лучших мировых специалистов по НЛП и другим психотехнологиям влияния позволили составить специальный словарь, который некоторое время держался в секрете. Тысячи успешных рекламных объявлений и сайтов были проанализированы на предмет поиска ключевых слов, которые заставляют людей покупать... Теперь все эти слова доступны Вам!
Узнать подробнее о книге "Слова-Магниты"


Что такое веб-хостинг. Руководство для чайников

Автор: Михаил Волошин

Что такое веб-хостинг? Какой хостинг выбрать: платный или бесплатный? На что обратить внимание при выборе веб-хостинга?

Что такое веб-хостинг?

Веб-хостинг - это способ размещения сайта в сети интернет. Как только вы разместили свой сайт на сервере - кто угодно может получить доступ к нему, набрав доменное имя в строке броузера. Доступ к сайту возможен 24 часа в сутки, 7 дней в неделю, 365 дней в год.

Для того, чтобы разместить свой веб-сайт в сети, необходимо:

  • прежде всего, иметь собственный веб-сайт. Нужно иметь копию сайта на локальном компьютере (в html-файлах), или же готовые материалы + скрипт, который позволял бы создать веб-сайт непосредственно на сервере.
  • доменное имя. Нужно найти и приобрести доменное имя сайта. Желательно, чтобы имя говорило о тематике сайта, и было легко запоминающимся. Доменное имя может быть в любой, на ваш выбор, доменной зоне, например: .com .net .org .ru и т.д. При выборе доменной зоны руководствуйтесь данными о тематиках доменов. Домены .com , например, предназначены для сайтов коммерческой направленности, .org - государственных учреждений и общественных организаций. Региональные домены говорят о принадлежности сайта какому-либо региону. Это необязательное правило, но стоит об этом помнить.
  • заказать один из хостинг-планов в компании, осуществляющей услуги хостинга. Выбор тарифного плана является отдельной темой для разговора, поэтому в данной статье мы не будем ее обсуждать.

Что такое сервер?

Это компьютер, размещенный у провайдера интернет и подключенный во всемирную сеть, на котором хранится копия веб-сайта. Как правило, один сервер вмещает достаточно много веб-сайтов, за счет большого дискового пространства. Но в целом, это не имеет значения. Важен не объем сервера, а его вычислительные мощности и пропускная способность интернет-каналов провайдера.

С помощью любого веб-броузера (программы для просмотра сайтов в интернет) вы можете получить доступ к своему веб-сайту, набрав в строке адрес сайта.

Веб-хостинг можно сравнить с арендой недвижимости. Множество компаний готовы предложить хостинг за умеренную плату, однако не многие могут обеспечить хостингом должного качества. Говоря о стоимости хостинга, нужно отметить, что для большинства веб-сайтов стоимость платы в месяц может не превышать 10 долларов США. В пределах этой стоимости можно найти хостинг-компанию, предоставляющую около 300 мегабайт дискового пространства на сервере и всевозможные функции, такие как: установка и запуск скриптов, поддержка баз данных, административная панель (т.е. ваша панель управления) веб-сайта, где производятся настройки не только сайта, но и электронной почты.

Если вы планируете открыть представительство в сети, нужно не только решить, какого уровня будет веб-сайт, но и правильно определиться с выбором провайдера хостинга. Статистически, более 70% владельцев веб-сайтов переходили с одного хостинга на другой хотя бы один раз. Перевод к другому провайдеру был вызван неудовлетворенностью качеством предоставляемых услуг хостинга.

Действительно, любой провайдер говорит о том, что он самый лучший, и у него самые низкие цены и т.д. и т.п. А потом оказывается, что служба поддержки не отвечает, или отвечает, но с задержкой, сервера временами "зависают" из-за большой нагрузки. Подобная неосторожность в выборе провайдера может принести большие потери. Представьте себе, что означает отсутствие доступа к сайту фирмы, где каждые полчаса обновляется важная информация для сотрудников, находящихся в удаленных филиалах компании. Представьте, что потенциальные клиенты фирмы не могут узнать контактный телефон или электронный адрес, потому что не могут попасть на сайт. Возможно, через полчаса они уже не сделают второй попытки зайти на сайт. Возможно, через полчаса они найдут другую конкурирующую фирму. Ущерб от зависающих серверов может быть огромным.

Чтобы не совершить ошибок в выборе хостинга, необходимо посетить форумы и рейтинговые сайты, где обсуждаются хостеры. Внимательно почитать мнения клиентов о разных хостинг-провайдерах. Время, потраченное на изучение форумов и чтение отзывов, окупится стабильностью работы веб-сайта.

Далее, какой тарифный план выбрать?

Тарифные планы, как правило, отличаются размером дискового пространства, возможным количеством поддоменов сайта, ограничением по исходящему траффику. Безусловно, после того, как вы отобрали несколько наиболее авторитетных хостинговых компаний, необходимо сравнить их тарифные планы. При сравнении необходимо помнить о том, каким требованиям должен удовлетворять тарифный план. Нужно принять во внимание:

  • размер предоставляемого дискового пространства
  • возможность иметь множество почтовых адресов
  • установка и запуск приложений (cgi, php, MySQL)
  • доступ к сайту по FTP
  • административную панель, с помощью которой осуществлять контроль и управление сайтом (очень важно: качественная административная панель, где все функции удобно "разложены по полочкам" сэкономит вам массу времени)
  • уровень оплаченного исходящего траффика

Разберем по порядку

Если ваш первый веб-сайт будет состоять из нескольких страниц и логотипа, то вполне подойдет тарифный план, где размер дискового пространства будет от 100 до 300 мегабайт. Этого более чем достаточно. Меньше 100 мегабайт дискового пространства уже не предоставляет практически ни один хостинг-провайдер.

С почтовыми адресами проще - практически все провайдеры дают в распоряжение неограниченное число адресов в пределах одного домена. Ограничение может быть только по числу отдельных POP3 и SMTP аккаунтов. Это означает, что, несмотря на разные адреса, вы имеете ограниченное число отдельных соединений с помощью почтовой программы.

Установка и запуск скриптов необходим, если сайт будет построен на динамических страницах, или же необходимо реализовать функцию поиска внутри сайта. Если же сайт будет полностью построен на статистических html-страницах, то запуск скриптов имеет второстепенное значение.

Доступ к сайту по FTP необходим. Без него вы ничего и не сделаете. FTP доступ предоставляет любой провайдер, на этом этапе все просто и понятно.

Административная панель, на первый взгляд не имеет высокой значимости. Но когда дело доходит до практического обслуживания сайта - качественная админ-панель просто незаменима. С помощью админ панели вы можете не только устанавливать настройки сайта, но и получать статистическую информацию о сайте, например: сколько дискового пространства используется/свободно, каков показатель исходящего траффика за этот месяц (как правило, все провайдеры устанавливают лимит по исходящему траффику). Если в тарифном плане указано "неограниченно" - не верьте, скорее всего это не очень хороший хостер, который всеми путями пытается заманить клиентов). С помощью админ панели легко оперировать с настройками сайта и электронной почты: создавать новые почтовые адреса, настраивать переадресацию почты, управлять папками и файлами (устанавливать права доступа к файлам, пароли к директориям).

Оплаченный исходящий траффик имеет большое значение. Если вы не рассчитаете, сколько информации в килобайтах будет отправлено с сайта на компьютеры пользователей, возможно, вам придется доплатить хостинг-провайдеру за превышение лимита по исходящему траффику. Посчитать средний уровень исходящего траффика достаточно несложно. Посчитайте объем средней страницы сайта, включая графические элементы, которые на ней расположены. Помните о том, что при загрузке других страниц, где используется ранее загруженный рисунок, повторно он берется не с вашего сайта, а с кэша компьютера пользователя. теперь спрогнозируйте, сколько страниц в среднем может просмотреть пользователь, и прикиньте среднее число пользователей в сутки. Теперь умножьте объем страницы на число страниц и на число пользователей в сутки. Вы получите приблизительный объем исходящего траффика в сутки. Умножаем число на 30 дней - вы получаете приблизительный объем траффика в месяц.

Если цифра получилась достаточно большой, не расстраивайтесь, ведь это только ваши предположения. Может быть, у вас будет намного меньше посетителей, чем вы думаете, и каждый из них будет посещать меньшее число страниц, причем треть из посетителей сайта отключат в браузере загрузку графики (всего этого я вам не желаю!)

***
Рекомендуем
Книга "10 Секретных Кнопок"
Эта книга по какой-то фантастической случайности не попала в разряд «Совершенно Секретных». Так что ПОКА у вас еще есть возможность познакомиться с одним из самых важных открытий в области человеческой психологии - так называемыми «нейро-кнопками», «нажав» на которые, вы получаете возможность... Впрочем: тс-с! Это не та тема, о которой можно заявлять в открытую… Поэтому... ОСТОРОЖНЕЕ!
Узнать подробнее о книге "10 Секретных Кнопок"


IZone улыбается

Пошагали!

***

Ограбление.

***

Перевёртыш.

Анекдоты

Молодой человек приходит к теще с тестем. Теща спрашивает:
- Что это ты, зятек, решил к нам заглянуть?
- Да с женой поругался, и она послала меня ко всем чертям.

***

Некто обращается в бюро находок железнодорожной станции.
- Я забыл в поезде трехлитровую бутыль виски. Скажите, вам ее не приносили?
- К сожалению, нет, сэр. Зато принесли того джентльмена, который ее нашел.

***

- Петр, а Вы были в Греции?
- Был...
- А на Кипре?
- Тоже был...
- Ну и где отдых лучше?
- Не знаю.... Я везде был с женой и детьми.

***

В коммунальной квартире девушка, стоя под душем, вдруг видит, что через фрамугу на нее глядит небритая физиономия.
- Как вам не стыдно! Вы что, не видели обнаженную натуру?
- Плевать мне на твою натуру. Я смотрю, чьим мылом ты моешься.

***

Ума нет - дави "reset"!

***

Идет отец с дочкой.
- Пап купи кедики!
- Вот еще!
- Ну, купи кедики!
- И не подумаю!
- Купи!
- Какие кеды, ты еще коньки не сносила!

***

После новогодней елки в детском саду отец говорит сыну:
- Сынок, ты уже большой, должен понимать, что никакого Деда Мороза нет. Это был я.
- Да, я знаю. Ведь аист - это тоже ты.

***

Сидят два электрика на столбе. Мимо проходит старушка. Один говорит ей:
- Бабуль подай провод.
- Держи милок.
- Ну, вот я тебе говорил что ноль, а ты все фаза, фаза!

***

Самолет взлетает. Пилот штурману:
- Карты взял?
- Да, две колоды.
- Да нет, другие! На которых мы рыбу режем!

***

В аптеке:
- Мне пол-литра спирта.
- А рецепт есть?
- Да! Кило сахару, полкило свеклы, сто грамм дрожжей.

***
Рекомендуем
Хотите сыграть в пейнтбол?
Пейнтбол - это игра, в которой можно изрешетить "злобного" шефа или "зануду" подчиненного из специального оружия, маркера, используя при этом "пули" - разноцветные шарики с краской. Главное - в итоге все останутся живы.
Подробнее >>


Win-комфорт

Сегодня в выпуске: Wallpapers (обои на Рабочий Стол), визуальные стили для Windows XP.

Wallpapers (обои на Рабочий Стол)

1024x768 Скачать | 1024x768 Скачать
1024x768 Скачать | 1152x864 Скачать
1024x768 Скачать | 1152x864 Скачать
1024x768 Скачать | 800x600 Скачать
1024x768 Скачать | 1024x768 Скачать
1024x768 Скачать | 1024x768 Скачать

Ниже приведена инструкция, как установить обои на рабочий стол:

  1. Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Выбираем Фон > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Применить
  2. В WinXp делаем так: Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Раскрывается окно Свойства: Экран > Выбираем вкладку Рабочий стол > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Открыть > Нажимаем кнопку Применить
  3. Если вы скачиваете обои в архиве, то нужно разархивировать рисунок в нужную вам директорию, и далее как написано выше.

Работайте с комфортом!

***

Визуальные стили для Windows XP

Визуальные стили (темы) включают в себя полный комплект для изменения внешнего вида Windows XP: shellstyle, desktop icons, user icon and wallpaper. Инструкцию по установке см. ниже.

Скачать (778 Kb)

Для применения визуальных стилей, т.е. установки их, разработчики стилей рекомендуют использовать программу Style XP (или же TGT Soft's Style XP).
Данные программы "разрешают" Windows XP использовать неподписанные (без цифровой подписи) визуальные стили.

Инструкция для установки стиля:

  1. Загрузите визуальные стили .zip в ваш компьютер
  2. Извлеките .zip файл в эту директорию: %windir%\resources\themes\ (вероятно c:\windows\resources\themes\)
  3. Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Затем Темы > Выбираем из списка доступных тем нужную и нажимаем кнопку Применить
***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>


Практическое руководство по компьютерным приколам 3

Автор: Паша Либер aka Fireangel

Очередной привет всем ценителям хорошей компьютерной шутки. На ваш суд выносится новая порция различных способов реализации некоторых компьютерных розыгрышей. На этот раз я решил описывать приколы из категории "по заявкам читателей", которые снежной лавиной продолжают захлестывать мой многострадальный ящик.

3… 2… 1… Пуск

С чего начинается Windows? Конечно же, с кнопки Пуск. Только задумайтесь над тем, сколько раз в день вы ее нажимаете. Ни разу? Вот и правильно — нечего ее жать лишний раз. Давно уже пора вынести любимые программы на рабочий стол в виде ярлыков и выучить сочетания клавиш для всего остального. А вот если кто-то совершенно не хочет учить эти самые сочетания, то ему на помощь совершенно безвозмездно (главное — быстро бегать, чтобы он не смог отблагодарить вас во всей широте своей души:)) придем мы. Придем и избавимся от этой надоедливой кнопки. Запускаем Delphi, переходим в окно кода (F12). После слова implementation создаем свою процедуру:

procedure HideButton;
Var
Tray, Child : hWnd;
C : Array[0..127] of Char;
S : String;
Begin
Tray := FindWindow('Shell_ TrayWnd', NIL);
Child := GetWindow(Tray, GW_CHILD);
While Child <> 0 do Begin
If GetClassName(Child, C, SizeOf(C)) > 0 Then Begin
S := StrPAS(C);
If UpperCase(S) = 'BUTTON' then
ShowWindow(Child, 0);
End;
Child := GetWindow(Child, GW_HWNDNEXT);
End;
End;

Теперь снова жмем F12, переходим на форму и дважды кликаем по любому пустому месту на ней. В открывшемся обработчике пишем:

procedure TForm1.FormCreate (Sender: TObject);
begin
Application.ShowMainForm:= false;
HideButton;
end;

Сохраняем, компилируем, радуемся. Теперь при запуске программки кнопка Пуск будет исчезать в неизвестном направлении. Любителям более извращенных вещей могу с радостью предложить некоторые изменения вышеприведенной шутки. Для этого нам всего лишь потребуется модифицировать процедуру HideButton, а точнее — вместо строчки ShowWindow(Child,0) написать следующее:

1) для того, чтобы кнопка Пуск растянулась на всю панель задач, пишем:
MoveWindow(Child,1,1,screen.Width-5,22,true);

2) чтобы поместить ее на центр панели задач, пишем:
MoveWindow(Child,screen.Width div 2,1,55,22,true);

3) для веселого мельтешения Пуска по этой самой панели нужно поместить на форму компонент Timer, изменить его значение Interval=500 и, дважды кликнув по нему, писать:

procedure TForm1.Timer1Timer (Sender: TObject);
Var
C : Array[0..127] of Char;
S : String;
Begin
Tray := FindWindow('Shell_ TrayWnd', NIL);
Child := GetWindow(Tray, GW_CHILD);
While Child <> 0 do Begin
If GetClassName(Child, C, SizeOf(C)) > 0 Then Begin
S := StrPAS(C);
If UpperCase(S) = 'BUTTON' then
MoveWindow(Child,random(scre-en.Width),1,55,22,true);
End;
Child := GetWindow(Child, GW_HWNDNEXT);
end;
end;

Осталось забросить нашу программу в Автозагрузку и спокойно дожидаться ее действия, находясь при этом на расстоянии, большем, чем средняя дальность полета табуретки, пущенной противником:). С Пуском пока все. Поехали дальше.

Kill them all!!!

Если ваш друг постоянно говорит о стабильности своей операционной системы, то это, несомненно, прямой вызов вам. Ибо нет ничего необычнее, чем стабильная Windows, да и вообще смешное это словосочетание. Посему наша следующая задача — сделать так, чтобы программы выгружались, висли, бились в предсмертных конвульсиях и благим матом проклинали своего бедного пользователя. Мне пришло несколько писем с вопросом, как можно управлять чужим окном? Самый простой способ — использование процедуры FindWindow(), которая возвращает дескриптор окна по его заголовку. Я использую эту процедуру почти в 2/3 описанных приколов, и пока вполне успешно. Т.е., если мы напишем h:=FindWindow(nil,'Сапер'), то в переменную h вернется дескриптор окна игры "Сапер", если она в данный момент запущена. Запускаем Delphi. Дважды кликаем на нашей главной форме и модифицируем код:

procedure TForm1.FormCreate (Sender: TObject);
begin
Application.ShowMainForm:= False;
end;

Помещаем на форму компонент Timer из вкладки System палитры компонентов. Ставим его значение Interval=2000 в инспекторе объектов и дважды кликаем по нему. В открывшемся обработчике пишем следующее:

1. Минимизация выбранного окна с определенным интервалом.

procedure TForm1.Timer1Timer (Sender:
TObject);
Var
h:HWND;
s:PChar;
begin
s:='Мой
компьютер';
h:=FindWindow(nil,s);
if h<>NULL
then
CloseWindow(h);
end;

Переменная s введена для того, чтобы вы сами могли решить, какое окно минимизировать. В этой переменной должен содержаться заголовок окна, с которым будет происходить последующая работа. Заголовок окна — это обычно надпись, которая пишется в левом верхнем углу окна на синем фоне (если вы его цвет сами не меняли, конечно). Если заголовка явно не видно, можно нажать заветные Ctrl+Alt+Del и посмотреть, как там называется ваше приложение. Вот некоторые примеры заголовков:

Мой компьютер
Сетевое окружение
Quake 3: Arena
Сапер
Winamp 2.80
Intranet Chat

2. Закрытие окна aka его уничтожение. Менять придется только сам обработчик OnTimer, так что предыдущий код трогать не нужно. В случае с окнами Windows (Мой компьютер, Сетевое окружение и т.д.) наше закрытие вызывает очень приличное повисание этого окна, которое перегружает Explorer при ручной выгрузке. Для реализации этого прикола лучше установить Interval таймера либо очень маленьким (1), либо побольше (20000-50000).

procedure TForm1.Timer1Timer (Sender: TObject);
Var h:HWND;
s:Pchar;
begin
s:='Сапер';
h:=FindWindow(nil,s);
if h<>NULL then
SendMessage(h,WM_DESTROY,0,0);
end;

3. Случайное перемещение окна по рабочему столу с изменением размеров:). Смотрится дико весело и наводит на определенные мысли о целых легионах злобных вирусов, грызущих бедную систему. Изменяем все тот же OnTimer, предварительно выставив его значение Interval=10.

procedure TForm1.Timer1Timer (Sender:
TObject);
Var
h:HWND;
s:Pchar;
begin
s:='Сапер';
h:=FindWindow(nil,s);
if
h<>NULL then begin
rando-mize;
MoveWindow(h,random(screen.Width),random(screen.Height),
random(screen.Width),random(screen.Height),true);
end;
end;

Не так страшен Photoshop, как в нем малюют

Неужели в этом приколе мы будем рисовать, радостно спросит читатель и весело захлопает в ладошки? Будем, обязательно будем. В прошлой своей статье я уже писал, как эмулировать силу притяжения для мышки, но пришло несколько писем с просьбами описать еще несколько "мышиных приколов", так что готовьтесь рисовать. И не просто рисовать, а создавать универсальный программный продукт, позволяющий пользователю не мучиться с нажатием на кнопки мыши и выбором цвета для точки, а спокойно создавать свои шедевры на… на всем, что есть на его экране в данный момент. Для этого мы сейчас просто наделим нашу мышку целым рядом неисправимых достоинств:). Delphi, надеюсь, уже загружен? Тогда делаем все, как в прошлом приколе, за исключением, как всегда, обработчика OnTimer, который на этот раз будет выглядеть следующим образом (значение Interval=5):

procedure
TForm1.Timer1Timer (Sender:
TObject);
Var
l:Tpoint;
begin
GetCursorPos(l);
SetPixel(GetDc(0),l.X+random(3),l.Y+random(3),Random(65535));
SetPixel(GetDc(0),l.X-random(3),l.Y+random(3),Random(65535));
SetPixel(GetDc(0),l.X+random(3),l.Y-random(3),Random
(65535));
SetPixel(GetDc(0),l.X-random(3),l.Y-random(3),Random
(65535));
end;

При запуске нашего универсального графического редактора v1.0бета противник получит просто прекрасную возможность реализовать все свои скрытые таланты художника прямо на рабочем столе. Ну, а что прекратить это все безобразие можно только по заветным Ctrl+Alt+Del — так это ограничение beta-версии и будет доступно только после бутылки пива тому, кто эту программку ему подкинул :). В общем, эффект будет примерно такой, как показано на картинке. Причем рисование будет происходить на кнопках, ярлыках, окнах, панелях и т.д.

Для вывода какого-либо текста под курсором мыши можно изменить наш код следующим образом:

procedure TForm1.Timer1Timer (Sender:
TObject);
Var
l:Tpoint;
begin
GetCursorPos(l);
TextOut(GetDc(0),l.x,l.Y,'Windows
XP',length('Windows XP'))
end;

Следующий вариант обработчика OnTimer визуально заметен не сразу, но при долгой работе быстро бросается в глаза. Данный эффект обеспечивает медленную перекраску точек под курсором мышки. Причем не в один цвет, а в разные, в зависимости от исходного цвета объекта. Модифицируем:

procedure TForm1.Timer1Timer (Sender:
TObject);
Var
l:Tpoint;
c:Cardinal;
begin
GetCursorPos(l);
c:=GetPixel(GetDC(0),l.x-1,l.y);
Setpixel(getdc(0),l.X-1,l.Y,RGB(getrvalue(c)-15,getgvalue(c),getbvalue(c)-15));
c:=GetPixel(GetDC(0),l.x+1,
l.y);
Setpixel(getdc(0),l.X+1,l.Y,RGB(getrvalue(c)-15,getgvalue(c),getbvalue(c)-15));
c:=GetPixel(GetDC(0),l.x,l.
y-1);
Setpixel(getdc(0),l.X,l.
Y-1,RGB(getrvalue(c)-15,getgvalue(c),getbvalue(c)-15));
c:=GetPixel(GetDC(0),l.x,l.
y+1);
Setpixel(getdc(0),l.X,l.Y+1,RGB(getrvalue(c)-15,getgvalue(c),getbvalue(c)-15));
end;

Начало работы:

Cпустя 20 сек…

Вот и думай потом, что за благородное озеленение происходит с твоим компьютером… Откомпилированные программки можно, как обычно, затянуть в Автозагрузку или просто запустить в отсутствие противника и спокойно дожидаться, пока он сумеет оценить ваше чувство юмора. С рисованием все. Поехали дальше.

Поморгай мне окнами…

А вот следующий эффект обычно воспринимается однозначно как "странные глюки". И истинное удовольствие — наблюдать за человеком, который, проклиная Билла Гейтса такими словами, что хочется стыдливо покраснеть и закрыть лицо ушами:), пытается лихорадочно убрать синее моргание свернутых приложений из таскбара. А они все моргают и моргают. В принципе, если включить Winamp, то это даже красиво смотрится:). А теперь немного работы для реализации. Затягиваем на форму компонент Timer и устанавливаем его Interval в 500 (можно потом, экспериментируя с различными значениями, выбрать оптимальное). Обеспечиваем сокрытие формы при запуске (Application.ShowMainForm:=False) и, кликнув по таймеру 2 раза, пишем обработчик:

procedure TForm1.Timer1Timer (Sender: TObject);
Var
wnd : HWND;
buff: array [0..127] of Char;
begin
wnd := GetWindow(Handle, gw_HWndFirst);
while wnd<>0 do begin
IF (wnd <> Application.Han dle) and
IsWindowVisible(wnd) and
(GetWindow(wnd, gw_Owner) = 0) and
(GetWindowText(wnd, buff, sizeof(buff)) <> 0)
then begin
FlashWindow(wnd,true);
end;
wnd := GetWindow(wnd, gw_hWnd Next);
end; end;

Естественно, наибольший эффект достигается, если в таскбаре к этому времени присутствует много приложений. Их синхронное моргание вообще может свести с ума кого угодно. Само мигание кнопок обеспечивается функцией FlashWindow. Ниже приведены некоторые другие функции, вставив которые вместо FlashWindow, вы получите другой эффект:

  1. сворачивание всех окон в системе каждые 0,5 секунды (если Interval таймера равен 500) — CloseWindow(wnd);

  2. завершение приложений, имеющих окно в системе — SendMessage(wnd,WM_DE-STROY,0,0);

  3. замена заголовков всех запущенных приложений с окнами — SetWindowText (wnd,'Vi-rus has you…').

И напоследок (то, что не вошло в основную часть статьи)…

Здесь я хотел бы остановиться на некоторых вопросах читателей, которые часто возникали в письмах, и я не имел возможности на них ответить (нет у меня Интернета, нет, и все тут:(). Они небольшие, но для собственных шуток могут оказаться довольно полезными.

Q: Как мне можно спрятать TaskBar?
A: Таскбар — это тоже окно, так что действия с ним можно производить те же самые. Сперва получаем дескриптор, затем прячем. Сложность здесь заключается только в получении дескриптора:
Wnd:=FindWindow('Shell_Tray Wnd',nil);
ShowWindow(wnd,SW_HIDE);

Q: Как можно не допустить запуска игры Quake 3?
A: Wnd:=FindWindow(nil,'Quake 3: Arena');
SendMessage(wnd,WM_DESTROY, 0,0);
То же и для всех других приложений. Главное — знать заголовок окна.

Q: Не понял, почему твои приколы не работают в Паскале 7.0 под ДОС? Я их слово в слово переписал!!!
A: Этот вопрос потряс меня до глубины души… Ребенок переписывал, старался, и на тебе. Неужели они не работают в Паскале, да еще и под ДОС? Какой ужас. Я просто не верю своим ушам. Придется немедленно пересмотреть все свои статьи и сделать патчи, эмулирующие WinApi в ДОСе. Ребята, думайте над вопросами, которые вы задаете, так как это, к моему неописуемому восторгу, не первый пример подобного содержания. Все мои программки под Windows, и все тут.

На этом закругляюсь. Присылайте свои заявки на различные веселые приколы, и как знать, возможно, вы сами сумеете создать их с моей небольшой и крайне скромной помощью. Искренне ваш.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Рекомендуем! Книга "Практическое руководство по управлению личным капиталом с помощью ценных бумаг"
научит вас трем несложным, но действенным способам извлекать прибыль из собственных сбережений. В отличие от валюты и банковских вкладов, ценные бумаги сегодня - это реальная возможность сохранить сбережения и получать с них реальный доход больше инфляции.
Ценные бумаги - это не только для богатых. Покупать ценные бумаги и получать прибыль можно даже начиная с 1000 рублей.
 "Узнайте Три Способа Заставить Свои Сбережения Бороться с Инфляцией и Приносить Доход До 25% Годовых и Выше". Прочитайте электронную книгу!


Зубастый патруль

Автор: Сергей А. ЯРЕМЧУК

Что только не подстерегает компьютер обычного пользователя во Всемирной Паутине! Здесь и вирусы, и атаки с целью проникновения… Да что там говорить — каждый второй сайт считает своим долгом что-то да записать на компьютер. Подцепить какую-нибудь заразу, в принципе, — раз плюнуть. Что ж, раз такое дело, пользователю приходится всячески защищаться. Можно, особо не вдаваясь в подробности, выделить несколько уровней защиты. Во-первых, распознавание попыток вторжения при помощи программ класса IDS (Intrusion Detection System — система обнаружения вторжений), применяемых как правило на серверах; далее идет контроль над входящими и исходящими соединениями, в том числе контроль и анализ характера работы запущенных и скачиваемых приложений — обычно при помощи файрволов или антивирусов; и наконец, контроль за всем устанавливаемым программным обеспечением, изменением записей в реестре и других важных системных областях. (На самом деле этих уровней больше, но условимся соблюдать именно такую классификацию.) Антивирусов и файрволов много, а статей о них еще больше. Лучше поговорим об одной любопытной программе, позволяющей прекратить бардак с несанкционированной установкой чужого ПО.

WinPatrol 6.0

Домашняя страница: http://www.winpatrol.com/
Статус: freeware
ОС: Windows 95, 98, ME, 2000, NT и XP
Размер дистрибутива: 804 Кб

Пользователи, у которых на компьютере стоит Windows 95, должны следовать на отдельную страницу — http://www.winpatrol.com/win95.html. В целом же установка никаких трудностей вызвать не должна. При запуске программы в динамиках раздастся веселый лай собаки (таким образом отгоняются, наверное, непрошеные гости :-)), после чего рядом с часами появится значок с изображением славного пса по имени Scotty the Windows Watch Dog. Вот теперь этот самый Scotty WWD и будет безустанно следить за всем, что происходит на доверенном ему компьютере, — разнюхает все о саморазмножающихся вирусах, adware, spyware, троянах, пробравшихся на ваш компьютер, и, конечно, о cookies, которые будут поступать к вам постоянно. Главная цель WinPatrol — дать знать пользователю, что и какие программы делают на его компьютере, и предупреждать его о любых исполняемых файлах, пытающихся без разрешения проникнуть к нему или запуститься. Scotty позволяет подтверждать установку любых новых программ на компьютере. Да, чтобы там случайно совсем не отключить программу, при выходе из нее установите флажок Always Run WinPatrol в меню, вызываемом по правому клику на Scotty. Вызвав программу, получим окно программы с несколькими вкладками:

Startup Programs — позволяет просмотреть все запущенные приложения, остановить или вообще удалить из автозапуска ненужные, получить информацию о каждом (имя, версия программы, ключ реестра и пр.) Нажатие кнопки Full Report выдает отчет о всех программах одним махом. При первом запуске Scotty просматривает список автоматически запускающихся программ и при его изменении предупреждает об этом пользователя. Поэтому лучше всего его устанавливать на «чистую» систему;

IE Helpers — контроль за всеми Browser Helper Objects, т.е. информация об имеющихся объектах, запрос на установку новых, удаление подозрительных. Надо сказать, что Browser Helper Objects запускаются каждый раз вместе с Internet Explorer, в том числе и при открытии папок на локальном компьютере, а поэтому при их помощи можно без проблем следить за пользователем. Эта особенность и используется во всяких программах типа spyware. Кнопка Remote, впрочем не убивает подобные объекты насмерть, а просто убирает их соответствие Internet Explorer, т.е. фактически запрещает автозапуск вместе с IE;

Scheduled Task Monitoring — отображение запланированных задач, контроль за добавлением новых и получение дополнительной информации о планируемых работах;

Services — отключение или временная остановка запущенных сервисов, а также получение дополнительной информации о них. Чтобы не пришлось рыскать по огромному списку в поисках подозрительных программ, можно включить пункт List non-Microsoft services only, убрав таким образом системные (в системах, построенных на ядре NT, таких ох как много);

View Active Tasks — получение информации о запущенных на данный момент программах и задачах, уничтожение и приостановка ненужных и подозрительных. Также при помощи этого пункта можно разобраться в работе запущенной системы, т.е. узнать, для чего предназначена та или иная программа;

Cookies — информирование о появлении новых cookies, отклонение и контроль их, просмотр информации, записанной в cookies. Можно также составить список cookies, которые всегда должны удаляться (Cookies with Nuts);

Options — установка опций самой программы: включение и выключение, контроль за устанавливаемым софтом и cookies, за появлением новых задач и установкой программы в автозапуск, а также за подменой домашней страницы в web-браузере — все это позволяет добиться более приемлемого соотношения производительность/требуемая безопасность. Здесь же включаются звуки и автостарт самой программы WinPatrol;

PLUS — все просто. Автор хочет заработать не на самом софте, а на сервисе — всего за 19.95 у.е. можно зарегистрироваться и получить доступ к сетевой базе данных программ. Цель последней — дать понять пользователю, что именно запущенное программное обеспечение делает на его машине (все-таки надпись serviсe.exe в таблице процессов большинству из нас ничего не скажет). Зарегистрировавшись, на этой странице можно ввести полученный по почте код.

По последнему пункту у меня произошло интересное событие — пожалуй, такое случается раз в сто лет, да и то не в этой жизни. Будучи в приподнятом настроении, я шутки ради ввел свое имя, а в поле для регистрации — произвольную комбинацию букв и цифр. В ответ на этот дурацкий поступок программа выдала мне поздравление об успешной регистрации! Пойду, наверное, сегодня лотерею покупать :-).

Итак, этот славненький песик позволяет пользователю, не отвлекаясь на страхи и глюки, спокойно наслаждаться серфингом по Паутине, при этом сильно машину не нагружает, плохие программы гонит звонким лаем.

P.S. Покупка лотереи показала правдивость слов преподавателя тактики — «снаряд дважды в одну воронку не падает». В следующий раз поступлю наоборот :-).

Успехов!

Источник: http://www.mycomp.com.ua/

***
Рекомендуем
Телекоммуникации и электроника
Соединительные технологии: кабели, оптоволокно, изоляция, монтаж и др.
Электромонтаж, Технологии монтажа, Термоусаживаемые трубки, Муфты, манжеты, Соединительные модули, Одиночные соединители, Соединители для жил, Кроссовое оборудование, Арматура герметизации, Соед. компоненты, Материалы для монтажа


Как наложить перевод на оригинальную звуковую дорожку

Автор: Shadow
http://www.goblin-home.narod.ru/

Итак, для успешного проведения операции по наложению перевода на оригинальную звуковую дорожку вам понадобятся следующие:

  • Место на диске.

  • Достаточно мощный компьютер

  • Время (От двух до четырех часов свободного времени)

  • Софт ( установленный кодек DivX VirtualDub от Avery Lee, WinAmp (или любая другая прога, с помощью которой можно конвертнуть MP3 в WAV) и программная многодорожечная студия записи Vegas Video от Sonic Foundry.

Прежде всего - немного теории. Файл с DivX фильмом содержит два потока. Один поток - видео, кодированное с помощью кодека DivX. Второй поток - звук, сжатый в обычный MP3. Алгоритм прост: сначала нам нужно выдернуть звуковую дорожку из файла, отредактировать ее (смикшировав ее с переводом), и заменить обновленной версией старую звуковую дорожку.

1. Готовим перевод.

  • Прежде всего нам надо подготовить перевод. Для начала нам нужен перевод, идем на DVD Special или к Glanz'у, и качаем нужный нам файл. Распаковываем его, загружаем в WinAmp, останавливаем воспроизведение. Теперь нам нужно из MP3 получить WAV (что это такое, и чем отличается от MP3, если кто не знает - пишите, расскажу, хотя понимание в данном случае не играет никакой роли. Для этого мы идем в настройки и перенаправляем вывод на специальный plug-in под названием DiskWriter

  • WinampMenu (CTRL-P) -> Options -> Preferences -> Output -> Nullsoft DiskWriter plugin

  • Нажимаем на кнопку "Configure", и выбираем каталог, куда сохранять результат. Проверяем, чтобы не были активны режимы "Случайный выбор композиции" и "Играть без остановки" ("Shuffle" и "Repeat"), и включаем воспроизведение. Звучать ничего не будет, зато диск будет активно шуршать. Дожидаемся, пока процесс завершится, и ОБЯЗАТЕЛЬНО возвращаемся обратно и делаем все как было. НЕ ЗАБУДЬТЕ, иначе потом будете долго удивляться, почему WinAmp ничего не играет, а место на диске стремительно исчезает.

2. Готовим оригинальную звуковую дорожку из фильма

Открываем VirtualDub.
File -> Open Video File (выбираем наш фильм), File -> Save WAV -> soundtrack.mp3
Пусть вас не смущает расширение .WAV: даже если вы его оставите, VirtualDub все равно сохранит дорожку в формате MP3, потому что она именно в таком формате в фильме и хранится. Так что лучше его сразу переименовать в MP3, дабы потом не запутаться. Теперь нам надо распаковать звуковую дорожку. Открываем получившийся MP3 WinAmp-ом, и проделываем с ним все, что было описано в первом шаге. Кстати, сразу же посмотрите (Alt+3) в WinAmp-е параметры сжатия оригинального саундтрека (частоту дискретизации, битрейт). Запишите ее куда-нибудь - она очень пригодится позже. Теперь у нас есть два несжатых WAV-файла (каждый должен быть объемом 400-600 метров). Все готово для работы

3. Микшируем оригинальный саундтрек и перевод

Открываем VegasPro. Слева внизу, в дереве каталогов находим место, куда мы сохраняли наши файлы. Берем за шкирку файл с оригинальным звуковым треком, тащим его на верхнюю дорожку, обязательно вплотную к левому краю. Все, теперь он неприкосновенен, и мы будем кромсать только перевод, не трогая оригинал. Ни в коем случае нельзя оставлять слева ни секунды, иначе впоследствии из-за образовавшейся паузы пойдет сильная рассинхронизация звука с изображением

Тащим файл с переводом на вторую дорожку. Вот над ним-то мы теперь будем издеваться, как нам захочется. Видите слева от каждой дорожки бегунки "Vol" и "Pan"? "Pan" (panning, разделение по стереоканалам) нам не нужен, а вот "Vol" (volume, громкость) нам пригодится. Обычно перевод записан с достаточно хорошим качеством и его уровень громкости гораздо выше, нежели нам надо. Настраиваем на слух громкость перевода относительно оригинала. Я обычно выставляю громкость в пределах -3~-4 децибел. У вас может быть другая ситуация - настраивайте тщательно, чтобы и голоса актеров были слышны, и перевод не превращался в сплошное "бу-бу-бу". После настройки громкости приступаем к синхронизации. Прослушиваем наш микс с интервалом минут 4-6, и как только обнаруживаем, что перевод "запаздывает" (или наоборот - спешит) - "разрезаем" его (курсор в нужную точку и нажимаем клавишу S) в ближайшем блоке, где переводчик молчит (на дорожке это отображается как прямая линия). Чуть отодвигаем правый кусок, и либо оставляем разрыв, пододвинув голос к нужному месту оригинала (если перевод "спешит"), либо уменьшаем мышкой его левую границу, и сдвигаем его влево (если перевод "запаздывает"). Так внимательно проверяем до конца фильма. При приобретении достаточной сноровки обычно на синхронизацию уходит от 20 минут до часа.
По завершении процесса обязательно смотрим в хвост: дорожка с переводом не должна вылезать за пределы дорожки с оригиналом!!! При необходимости обрезаем перевод. Сохраняем результат в WAV.
File -> Render As... -> для типа файла выбираем Wave (Microsoft)
Все. Теперь у нас есть звуковая дорожка с переводом.

4. Накладываем обновленную звуковую дорожку на фильм.

Способ от Sonique:
Открываем VirtualDub. Шаги следующие:
File -> Open video file -> Наш многострадальный файл с фильмом
Audio -> Full processing mode
Video -> Direct stream copy
Audio -> WAV Audio -> Звуковая дорожка с переводом.wav
Настраиваем компрессию звука (вот тут-то как раз время достать бумажку, на которой были записаны частота дискретизации и битрейт оригинального саундтрека):
Audio -> Compression

Выбираем в левом окне MPEG Layer 3, и в правом окне выставляем частоту оригинальной дорожки (если там нету нужных параметров - включите галочку "Show all formats"). Жмем OK. Выбираем
File -> Save as AVI..., вводим имя, давим "Сохранить", и отправляемся пить кофе. Сохранение занимает от часа и более: Final Fantasy на PIII-933 у меня сохранялся минут 40, у вас может быть и дольше/быстрее, в зависимости от мощности компьютера.

Способ которым пользуюсь я (значительно сокращающий время):
Открываем Nero - Burning Rom (либо любую другую программу, которая может конвертировать .wav в . mp3), отменяем все предложенные операции и далее выбираем.

Дополнительно -> Кодирование файла

В появившемся окне жмем на Добавить, и выбираем нашу звуковую дорожку в .wav
Далее следует обратить внимание на Формат вых. файлов, так как по умолчанию там стоит .aiff, а нам нужен .mp3
В появившемся окне следует отменить функцию Enable mp3PRO, затем достаем листик, на котором мы записывали частоту дискретизации и битрейт, и устанавливаем их, как указанно на рисунке.

Жмем ОК, после этого нажимаем на GO, и ждем где-то 8-10 минут, пока программа перекодирует wav в mp3.
Открываем VirtualDub.
File -> Open video file -> Наш многострадальный файл с фильмом
Audio -> Direct stream copy
Video -> Direct stream copy
Audio -> mp3 Audio -> Звуковая дорожка с переводом.mp3
Жмем OK. Выбираем
File -> Save as AVI..., вводим имя, давим "Сохранить". Сохранение занимает порядка 5-15 минут.

Вот и все. Фильм с переводом готов

***
Рекомендуем
Книга "Слова-Магниты"
Несколько лет работы лучших мировых специалистов по НЛП и другим психотехнологиям влияния позволили составить специальный словарь, который некоторое время держался в секрете. Тысячи успешных рекламных объявлений и сайтов были проанализированы на предмет поиска ключевых слов, которые заставляют людей покупать... Теперь все эти слова доступны Вам!
Узнать подробнее о книге "Слова-Магниты"


Мультиоконный браузер – FineBrowser

Удобство – это то, к чему мы постоянно стремимся. Удобство во всем – в одежде, в средствах передвижения и даже в работе. Поиск дополнительных возможностей уже привычных вещей заставляет нас все время экспериментировать и пробовать что-то новое.

Так же происходит и с программами. Браузер – это то, что открывает для нас Интернет, и от того, на сколько он удобен, какие возможности предоставляет и зависит комфорт нашего пребывания в веб. Поэтому выбор браузера – это как покупка нового автомобиля, здесь необходимо учесть множество параметров: и внешний вид, и простоту управления, а так же его скоростные характеристики и т.д.

Ни для кого не секрет, что самым популярным браузером на сегодняшний день является Internet Explorer. На то есть много причин и все они разные. В том числе, конечно, и сама политика компании Microsoft. Об этом ходит много споров, в которые не хотелось бы заново вовлекаться. Очевидно одно – Internet Explorer прост, привычен и на него ориентируется большинство разработчиков веб-ресурсов. Вот и получается, что благодаря всему этому мы «ездим» на том, что у нас есть.

В этом есть свои плюсы и минусы. С одной стороны, нам не стоит заботиться, чтобы искать что-то новое, практически все необходимые возможности вроде как под рукой. А с другой стороны – это только необходимые возможности, но далеко ведь не достаточные.

Для тех же, кто не привык довольствоваться только тем, что есть, предложу рассмотреть одну новую программу, которую можно отнести к классу мультиоконных браузеров, браузеров, которые позволяют открывать и работать внутри себя одновременно с целым набором веб-страниц. Эта программа называется FineBrowser (http://www.finebrowser.com ).

Выбор FineBrowser – не случаен. Для нас он представляет интерес по нескольким причинам. Во-первых, потому что он включает все возможности, характерные для мультибраузеров, а во-вторых потому, что это по сути новый шаг в их развитии. Дело в том, что многие мультибраузеры, хоть и представляют значительный интерес, т.к. позволяют во многом усовершенствовать нашу работу в веб, но долгое время их существенных продвижений в плане новых принципиальных возможностей не было. И хотя мультибраузеров произведено большое количество, все они во многом схожи друг с другом, предоставляя практически одни и те же возможности, только в разном виде. Однако, это вовсе не умоляет их возможностей, большинство которых мы и рассмотрим на примере FineBrowser.

С таких характерных для большинства мультиоконных браузеров возможностей мы и начнем наше рассмотрение способностей FineBrowser.

Характерные возможности мультибраузров.

Работа со множеством веб-страниц. Итак, FineBrowser позволяет открывать внутри себя одновременно несколько веб страниц. Все они располагаются внутри окна программы, и переключаться между ними можно как с помощью закладок, так и при помощи специальной панели, на которой представлен весь список открытых на данный момент окон.

Надо сказать, что FineBrowser позволяет открыть внутри себя более сотни веб страниц одновременно (открыли их и пошли пить кофе, пока загрузятся), и приятно удивляет та расторопность, с которой он это делает. Поэтому такая панель, становиться очень полезной, тем более, что при наведения курсора мыши появляется подсказка, в которой будет подробное описание данной страницы. Каждая же закладка, при полной загрузке страницы меняет свой вид, что позволяет следить за тем, какие веб-страницы уже полностью загружены и готовы к просмотру.

К тому же закладки можно менять местами, переименовывать, располагать их сверху и снизу, а так же блокировать важные страницы от случайного закрытия.

Обычно мультибраузер позволяет прервать работу с открытыми веб страницами, чтобы потом продолжить с того места, где вы закончили. Для этого у FineBrowser появляется возможность сохранять несколько рабочих столов в режиме «как есть», со всеми своими настройками и наборами открытых веб-страниц. Это позволяет так же работать в веб над различными темами, организовав для каждой темы свой рабочий стол, что дает возможность в любой момент с легкостью и без опасения потерять какие-то данные менять направление своего веб-серфинга.

Загрузка нескольких ссылок одновременно. Т.к. мультибраузер позволяет работать со множеством страниц одновременно, то возможность открытия сразу нескольких страниц является вполне очевидной потребностью такой программы. Те страницы, что мы используем чаще всего, можно занести в так называемые «быстрые группы». Одним нажатием на которые, мы так же сразу получим целый набор загружаемых в браузере веб-страниц.

Блокировка pop-up окон. Как и большинство мультиоконных браузеров, FineBrowser позволяет блокировать всплывающие pop-up окна. Уже только это – значительный плюс по сравнению с обычным браузером. Наверняка вы сталкивались с тем, что, попав на какую-нибудь злосчастную веб-страницу, она вдруг начинала засыпать вас открытием новых окон, от которых не было спасения. Иногда в такой ситуации спасает только перезагрузка. Поэтому такая блокировка стала уже обязательным атрибутом для всех мультиоконных браузеров. Что же касается именно FineBrowser, то в нем блокировка pop-up окон значительно усовершенствована, и FineBrowser, не просто блокирует все всплывающие окна, как говориться «в лоб», а позволяет самостоятельно разобраться какое окно полезно пользователю, а какое – является рекламной хитростью данного ресурса. Кроме этого можно вручную добавить в список те ресурсы, для которых блокировать самостоятельное появление новых окон не требуется.

Конфиденциальность. При путешествиях в Сети, мы не всегда хотим, чтобы о результатах нашей работы стало известно кому-нибудь еще. С помощью FineBrowser можно одним кликом мыши очистить всю информацию о деятельности пользователя в Интернет, которую автоматически сохраняет Windows. Теперь одним кликом мыши можно удалить все файлы из кеш, удалить cookies, очистить историю и набираемые в Internet Explorer веб-адреса.

Перевод и озвучивание веб-страниц. Часто запутанные дорожки глобальной сети приводят нас в самые неожиданные места, и случается, что волею судьбы мы оказываемся на веб-страничках с содержанием на незнакомом нам языке. Для того же чтобы узнать о чем идет речь на этой странице, FineBrowser, как и большинство других мультибраузеров позволяет перевести ее. Для этого достаточно выбрать соответствующую команду меню и подождать пока страничка загрузиться на нужном вам языке. Но в отличие от других программ, количество и вид доступных переводов в FineBrowser легко настраиваем, благодаря чему у вас появляется возможность в любой момент получить веб-страницу на удобном для вас языке.

Дополнительно FineBrowser позволяет озвучить содержание текущего веб-документа. Эта возможность задействует речевой генератор, установленный на вашем компьютере и во многом от качества его работы зависит то, как вы услышите выбранный для озвучивания текст. Однако в большинстве случаев это дает возможность на некоторое время отвлечься от монитора и прослушать какую-нибудь статью или подборку новостей. В общем, полезность этой возможности, была проверена мною, можно сказать, на себе. Я предложил FineBrowser озвучить один из незавершенных вариантов данной статьи и получил дополнительную возможность, не перечитывая ее, приобрести свежее восприятие, выслушав пересказывание данной статьи из чужих уст. Надо сказать, эти «чужие уста» иногда отдавали металлическим тембром, но, в общем, с интонацией и расстановкой, выразительно прочитали сие творение. Правда, иногда путаясь в ударениях, отчего это создавало впечатление чтения текста иностранцем, у которого иногда возникают проблемы при встрече незнакомых слов. Но это пока еще естественные погрешности в работе речевого генератора и к браузеру это отношение не имеет.

Ранее речь шла о возможностях, которые встречаются в большинстве популярных мультибраузеров. Однако, FineBrowser содержит ряд уникальных возможностей, делающих работу со множеством страниц более удобной и эффективной.

Новые возможности FineBrowser.

Архив ссылок и быстрый доступ к веб страницам. Согласитесь, что быстрый доступ к нужному веб-ресурсу во многом определят эффективность и скорость нашей работы в веб. От того насколько быстро мы отыщем адрес нужной веб-страницы и наберем его, зависит то, когда же мы, наконец, получим необходимую информацию. Именно поэтому в FineBrowser встроена собственная база данных, , в которой можно хранить любые закладки и работать с ними. В нее вносятся не только добавленные пользователем ссылки на различные веб ресурсы, но и все данные о посещенных вами веб-страницах: дата последнего посещения, ваши комментарии к ней и даже ее внешний вид. Благодаря этому у вас появляется возможность, сразу при просмотре сайта не только добавить какие-то свои пометки к просмотренной на странице информации, но и сделать снимок этой веб страницы, занести ее в нужную рубрику, выставить рейтинг и т.д. Для пользователя сохраненная информация о веб страницах представлена в рубрикаторе, где все страницы размещены по различным рубрикам и подрубрикам.

Благодаря всему этому, появляется множество возможностей по работе с этой информацией. Можно не только производить расширенный поиск нужной страницы, по названию, по ключевым словам комментария, по рейтингу, дате и т.д., но что самое главное, появляются возможности по работе со списками ресурсов. Так одним кликом мыши мы можем составить список всех ресурсов данной рубрики, отсортировать их по дате посещения, по веб-адресу или комментариям. Для тех, кто много работает в веб, наверняка окажется полезной способность FineBrowser комбинировать различные списки (объединять, получить различие, общее и т.д.), а так же экспортировать в обычный html файл. Теперь, например, для того чтобы посоветовать другу просмотреть какие-либо сайты можно выслать ему подробный отчет, сгенерированный из нужного списка, где уже будут небольшие скриншоты веб-страниц, их рейтинги и ваши комментарии к ним.

Полное описание веб-страницы в списке позволит нам вспомнить, что же мы почерпнули на ней, а просмотрев ее увеличенное изображение, не загружая самой страницы, мы с уверенностью восстановим в памяти все что видели на ней. Благодаря этому, мы можем эффективно работать с просмотренными веб-страницами даже в режиме оффлайн, а при необходимости, выделив в этом списке сразу несколько веб страниц загрузить их в новых окнах FineBrowser. Таким образом, однажды посетив нужный нам ресурс, мы уже никогда не потеряем его, тем более, что больше нет необходимости запоминать его интернет адрес. Все, как в бухгалтерии, хорошо описано и под строгим учетом.

Дополнительные возможности по одновременному открытию множества страниц. FineBrowser, в отличие от других мультиброузеров предоставляет ряд новых способов одновременного открытия сразу нескольких страниц. Первый, как мы уже говорили – это с помощью списка. Здесь, конечно же наши возможности неограниченны. С другой же стороны, воспользовавшись рубрикатором, мы можем сразу загрузить все страницы целой рубрики.

Кроме этого, FineBrowser позволяет открывать целый набор ссылок прямо из текста веб-страницы. Выделив на ней любой фрагмент, можно открыть все содержащиеся в нем ссылки как в новых окнах Internet Explorer, так и в FineBrowser. При этом программа самостоятельно исключит повторяющиеся адреса и предложить выбрать те страницы, загружать которые не следует.

Обращение к уже загруженным веб-страницам. FineBrowser позволяет избежать повторной загрузки тех страниц, которые уже в нем открыты. Так, если исследуя какой-либо ресурс мы встречаем ссылку на страницу, которая уже открыта в окне FineBrowser, то при ее вызове нам не придется вновь ждать ее загрузки, а программа просто переключит нас к нужному окну, где уже имеется эта страница. Вдобавок FineBrowser хранит историю нашего перемещения по открытым закладкам. Благодаря этому с помощью дополнительных кнопок навигации по закладкам, мы можем легко перейти к предыдущей или следующей просматриваемой странице. Это избавляет нас от необходимости искать недавно просмотренные страницы среди множества других закладок, особенно если мы просматривали их не по порядку.

Визуализация посещенных ссылок и навигация внутри домена. Но гораздо более полезными возможностями FineBrowser, как браузера, оказываются его способности при навигации в веб задействовать данные из своей внутренней базы данных. Благодаря этому, FineBrowser помечает ссылки на посещенные ранее веб страницы особым образом (по умолчанию в виде перечеркнутого текста). При наведении мыши на такую ссылку появляется всплывающая подсказка, в которой содержится вся информация о данной веб странице, включая ее небольшое изображение. Зачастую это позволяет избежать повторного посещения ненужных веб страниц и узнать, куда же ведут посещенные вами ссылки.

Часто мы возвращаемся на сайты, которые уже однажды посещали, для того чтобы продолжить их изучение или же, наоборот, освежить в памяти информацию с уже посещенной нами страницы. FineBrowser позволяет усовершенствовать и этот процесс благодаря, так называемым, «доменным линкам». Так, если мы уже бывали на этом сайте, то не зависимо от того на какую его страницу мы попали, FineBrowser нам скажет об этом, подсветив кнопку «Domain links». А кликнув по этой кнопке, перед нами появиться список посещенных страниц данного сайта с подробной информацией о них. Выбрав нужную страницу из списка, мы сразу же перейдем к ней.

Заканчивая же данный обзор, можно сказать, что альтернатива для выбора браузера у нас богатая и, наверняка, многие смогут найти то, что им нужно. Только не стоит останавливаться на достигнутом, ведь от того, какими программами мы вооружены и зависит наш успех в борьбе за дополнительными удобствами. Ну а в FineBrowser, по части вооружения, все в порядке.

Более подробно про FineBrowser и его возможности вы можете узнать на сайте http://www.finebrowser.com Откачать пробную версию программы можно отсюда http://www.finebrowser.com/download/finebrowser.exe

***
Рекомендуем
Книга "Сам Себе Копирайтер"
 Представьте, что бы вы могли натворить, если бы в вашем распоряжении оказалась коллекция тщательно охраняемых секретов лучших профессиональных копирайтеров - мастеров написания безукоризненных и эффективных рекламных текстов? Представили? Тогда СМЕЛО приобретайте это великолепное издание! Оно раскроет вам в реальности те секреты, которые поражают вас, когда вы сталкиваетесь с самым лучшими и эффективными образцами воздействия, созданными с их помощью!
Узнать подробнее о книге "Сам Себе Копирайтер"


Упрощенный способ расчета посетителя, или Как найти флудера?

Автор: Спичеков Александр aka MentALZavR

Итак, сегодня мы будем заниматься статистикой посещаемости нашего сайта. Первое, что нам необходимо определить — что нужно знать администратору сайта для корректировки его контента, времени обновления и др.

Конечно, пока сайт не раскручен, можно просто названия компьютеров и время посещения их пользователями нашего сайта записывать в простой текстовый файл. Однако это хорошо, когда посещений не больше нескольких сотен. А когда их число переваливает за тысячу, анализировать такой файл не просто трудно, а очень трудно. Хотя на первых порах многие так и делают, после чего приходится этот файл переводить в более читаемый вид, что, надо сказать, весьма неудобно. Можно затем написать пару-другую скриптов для анализа этого файла. Однако это все будет работать страшно медленно, и намучаетесь вы со скриптами — просто в сказке не рассказать. Но зачем изобретать велосипед и придумывать разные там поисковики по своим логам? Все уже придумано до нас — остается только это под себя сконфигурировать. Итак, решено: используем в своем супермегасчетчике СУБД MySQL. Как правило, чаще всего о своих посетителях необходимо знать следующее: время, дату посещения, IP-адрес, имя компьютера. Также необходимо, чтобы счетчик не менял своего значения, когда на сайт заходит его администратор и при обновлении странички (иначе будет очень много ложных посещений). Связка PHP+MySQL поможет нам решить поставленные задачи.

Очевидно, что, если использовать одну таблицу, в ней будет очень много полей, и делать запросы будет неудобно (конечно, можно все запросы раз и навсегда зашить в веб-интерфейс, а не делать время от времени запросы вручную, но на стадии отладки и в процессе развития проекта вашего сайта могут возникнуть разные ситуации). Первая таблица будет служить нам собственно хранилищем информации о посетителях, вторая будет служебной, т.е. в ней будут храниться данные, необходимые для корректной работы счетчика: минута последнего посещения, его IP и др. Но начнем с начала. В данной статье я использовал консольные программы для работы с СУБД MySQL 3.23.38, которые присутствуют в дистрибутиве. С помощью этих программ можно подключаться и к удаленной СУБД, прописав соответствующие ключи при их загрузке. Создаем базу данных mysqladmin -h hostname -u username -p create shetchik. При наличии ключа -p система спросит у вас пароль на подключение. Как вы, наверное, уже поняли, вместо hostname и username следует подставить соответствующие свои значения. Shetchik — имя нашей с вами базы данных счетчика. Если база данных находится на локальном компьютере, то -h hostname можно опустить. Если вы используете свежеустановленную MySQL на своем компьютере, то никаких ключей писать не нужно, просто необходимо дать команду mysqladmin creante databasename. Итак, мы создали базу данных. Теперь необходимо создать таблицы в этой базе. Для этого пишем в консоли:

mysql -h hostname -u username -p
mysql>use shetchik;
create table last_use (ip char(16), min int(2), nom int(9), ipa char(16), mainhost char(10));
create table hosts (ID int (9), ip char(16), hostname char (10), year int(4), month int(2), day int(2),day_week char(10), hour int(2),minit int(2),second int(2));

(Естественно, перед всеми этими командами необходимо сначала сменить текущий каталог со стандартного (в WinXP C:\Documents and Settings\ username, например) на каталог, в котором расположены программы mysqladmin.exe и mysql.exe соответственно. Это можно сделать, дав команду cd "c:\Program Files\mysql\bin", например, где путь необходимо заменить на свой). Этим мы создаем две таблицы, как было уже оговорено выше: одна для хранения данных, вторая — служебная. Начнем с последней. В ней пять колонок. Первая колонка типа char будет хранить у нас IP-адрес последнего посетителя, вторая — min типа int — минуту последнего посещения. Колонка ipa необходима для хранения IP-адреса администратора сайта (полезна на случай статического IP-адреса), и, наконец, последняя колонка будет содержать в себе имя компьютера администратора. Для чего все это необходимо? Для того, чтобы не вводить в заблуждение ни себя, ни других высокими показателями посещаемости, если вы часто любите любоваться своим детищем в онлайне:-). Приступим к описанию второй, и главной, таблицы. Я ее сделал с несколько избыточным количеством полей. Возможно, она покажется слишком большой, но ведь никто не запрещает изменить данную команду:-)? Итак, по порядку. ID — порядковый номер посетителя (при желании можно сделать эту колонку с инкрементированием). Ip — IP-адрес посетителя, hostname — название компьютера посетителя, year — год посещения вашего сайта (если он столько проживет:-)), month — месяц, когда была произведена загрузка, day — номер дня, day_week — текстовое название дня недели, hour — час, minit — минута, second — секунда. Итак, база данных создана, теперь необходимо придать начальные значения первой таблице (это необходимо для того, чтобы наш будущий скрипт работал корректно). Для этого нам нужно всего лишь дать команду mysql>insert into last_use (ipa, mainhost, min, nom) values ('IP_adress','host','0','0');. Здесь IP_address и host — IP-адрес и имя компьютера администратора сайта (с которого производится администрирование портала:-). Этой командой мы задаем начальные значения поля первой таблицы. Теперь приступаем собственно к написанию скрипта. Использовать мы будем PHP как один из самых простых скриптовых языков. Мы напишем PHP-файл, который вы после можете встроить в свою заглавную страницу, причем, когда она будет открываться, этот скрип будет выполняться — но это уже ваши проблемы:-), как вы будете его конкретно использовать. Итак, для начала подконнектимся к нашей базе данных:

<?php
mysql_connect("hostname", "username", "password");
mysql_select_db("shetchik");
где, как вы, наверное, уже поняли, hostname, username, password необходимо заменить на свои. Далее:
$result = mysql_query("SE-LECT ip, ipa, min, nom, mainhost from last_use");
$row = mysql_fetch_array ($result);
Этими строками мы запрашиваем из нашей базы данных (а конкретней, из служебной таблицы) те данные, которые необходимо будет потом внести в обе наши таблицы.
$w=mysql_error();
echo $w;

А вот эти строчки необходимы для того, чтобы получить текст ошибки, которая, не дай Бог:-), произойдет при запросе к СУБД. Далее получаем информацию от всеми нами любимого web-сервера:
$ip=$row["ip"];
$ipa=$row["ipa"];
$min=$row["min"];
$mainhost=$row["mainhost"];
$ID=$row["nom"];

Несколько поясню, что значит сей код. Дело в том, что функция mysql_query() делает запрос, который придается ей в качестве параметра. Выходные данные этой функции нельзя прямо использовать, т.к. она возвращает т.н. идентификатор запроса. Для того, чтобы использовать полученные данные, их необходимо поместить в массив, для чего, собственно, и служит функция mysql_ fetch_array(). После чего можно присваивать переменным значения элементов массива, возвращаемого этой функцией. Что мы, собственно, и делаем. Теперь получаем значения, не содержащиеся в БД, а именно дату, время и др.:

$ip_now = getenv ("REMOTE_ ADDR");
$hostname=
gethostbyaddr($ip);
$year=(date("Y"));
$month=(date("m"));
$day=(date("d"));
$day_week=(date("D"));
$hour=(date("H"));
$minit=(date
("i"));
$second=(date("s"));

Итак, первая функция получает IP-адрес компьютера, который загрузил вашу страничку. Следующая функция получает имя компьютера, имеющего этот IP-адрес. Далее следует несколько вызовов функции date() с различными параметрами. Эта функция "возвращает строку, отформатированную согласно данной строке и используя данную временную метку или текущее локальное время, если не задана временная метка". По-русски это означает, что данная функция может возвращать дату-время в том формате, в котором мы ее "попросим". Год мы получаем в виде числа (2003, например), месяц — также в виде числа, day — как число месяца, day_week — название дня недели (вернее, первые три буквы английского названия), hour — час в 24-часовом формате, minit, second — также числа. Все это присваивается соответствующим переменным для того, чтобы затем можно было занести в таблицу. Но предварительно необходимо сделать вот что. Необходимо произвести проверку на совпадение IP-адреса, имени хоста и минуты последнего подключения. Зачем это нужно? Представьте себе такую ситуацию. Заходит к вам на сайт человек с IP_1. И начинает "нервно" жать в своем браузере кнопочку "обновить". Если не проверять время последнего захода человека с этим IP_1, счетчик будет прибавлять при каждом обновлении нового "посетителя". Чтобы этого не происходило, мы и проверяем, не было ли прошлое подключение этого человека менее минуты назад. Теперь представьте себе, что минуты с последней загрузки сайта не прошло, а к вам на сервер заходит другой человек, но уже с IP_2. Чтобы учесть это посещение, и необходимо получить его IP_2 и сравнить с IP предыдущего посетителя. В этом же сравнении мы отсекаем срабатывания счетчика при подключении к серверу "администраторского" компьютера. Таким образом мы учитываем все "полезные" посещения и отсекаем все "вредные". А конкретно скрипт выглядит так:

if((($ip_now<>$ipa) && ($min <>$minit)) || ($ip<>$ip_now))
{
$ID=$ID+1;
mysql_query("INSERT INTO hosts (ID ,ip, hostname, year, month, day, day_week, hour, minit,second) values ('$ID','$ip_now', '$hostname', '$year', '$month', '$day', '$day_week', '$hour',' $minit', '$second')");
mysql_query("UPDATE last_use SET ip='$ip_now',min='$minit', nom='$ID'");
$w=mysql_error();
echo $w;
};
echo $ID;
?>

Инкрементирование $ID (собственно, это и есть показатель посещаемости наш искомый) происходит только при выполнении вышеперечисленных условий. Далее следует уже известная вам функция запроса к серверу СУБД с подстановкой соответствующих переменных mysql_query(). Второй вызов этой функции обновляет значения в нашей служебной таблице last_use. Этим достигается актуальность хранимой в ней информации. Теперь нам остается только вывести в соответствующем месте странички число посетителей. Можно это сделать не только через простую функцию echo, а несколько "красивее". Правда, нам придется несколько доработать наш скрипт. Мы будем выводить количество посетителей при помощи картинок цифр. Для этого заведем файл, в который будем дополнительно записывать количество посетителей. А затем считывать по одной цифре и подставлять в нашу генерируемую страничку вместо символов картинки. Естественно, нам понадобится десять картинок цифр с соответствующими названиями (0, 1, 2… 9) и одинаковым расширением. Итак, наш дополнительный скрипт допишем в конец уже созданного:
$fp = fopen("nom.txt" ","w+");
fwrite ($fp, $ID);
fclose($fp);

Открываем файл и после его очистки (флаг w+ в функции) записываем в него значение нашего счетчика. Таким образом в этом файле будет храниться текущее значение счетчика. Конечно, можно кусок данного скрипта поместить в фигурные скобки выражения if(), для того чтобы лишний раз файл не переписывался при ложном посещении, тем самым экономя ресурсы, но это делать необязательно — должно и так все работать:-). Далее нам уже необходимо открыть этот же файл на чтение и, считывая по символу, заменить их в конечном (сгенерированном) документе на картинки, что мы далее и делаем. Каждый раз мы в while() проверяем подход к концу файла. После этого fgets() считывает символ, после чего он заменяется на картинку с именем, совпадающим с цифрой, считанной из файла. Картинки взяты с расширением *.bmp, которое, естественно, может быть изменено. А сами картинки находятся в директории /num, которая, в свою очередь, находится в одной директории со скриптом счетчика:

$fp = fopen ("nom.txt",
"r");
while (!feof ($fp))
{
$nn = fgets($num,
2);
$c="num/$nn.bmp";
echo "<img border=0 src=$c
border=0>";
};
fclose ($fp); ?>

Ну, а теперь самое вкусное. А именно подведение итогов:-). Всегда, знаете ли, приятно посмотреть, как меняется посещаемость сайта в течение месяца. Кстати, описанный ниже скрипт по обрисовке графика посещаемости за месяц может быть легко переделан в скрипт по анализу посещаемости за неделю, час:-). Как это сделать конкретно, я покажу ниже. Что мы имеем? Мы имеем базу данных посетителей, созданную за несколько месяцев "упорного труда" вышеописанного счетчика. И нам хотелось бы получить наглядное представление загрузки нашего "портала":-) за месяц. Итак, создаем форму с выбором месяца, за который нам хотелось бы получить статистику:

<html>
<head>
<title>analiz </title>
</head>
<form name="form1" method= "post" action="analiz.php?ok=1">
<select name="month">
<option value="1">Январь </option>
<option value="2">Февраль</option>
.....
<option value="12">Декабрь</option>
</select>
<input type="submit" name= "Submit" value="Просмотреть">
</form>

Теперь ко всему этому "счастью" необходимо добавить скрипт, который анализировал бы загрузку (трафик). Конечно, предлагаемый скрипт не "сверкает" красотой, но для начала пойдет — ежели захотите доработать, вам никто этого не запрещает. Я надеюсь, пояснять HTML-теги нет необходимости.

<?php
error_reporting(0);
if($ok==1)
{

Первая функция необходима нам для того, чтобы интерпретатор языка PHP не ругался, мол, "переменные неопределенны и т.д." Дело в том, что, как вы, наверное, уже заметили, обработку формы производит этот же файл. Чтобы скрипт "знал", что это уже 2-я загрузка скрипта, и используется конструкция action="analiz.php?ok=1". При помощи нее мы придаем в скрипт дополнительно еще одну переменную ($ok=1). А IF() необходим для того, чтобы сценарий выполнился ТОЛЬКО при вторичной загрузке странички. Теперь приступаем собственно к обработке данных. Коннектимся к СУБД MySQL и распечатываем возможные ошибки:

mysql_connect("hostname", "username","password");
mysql_select_db("shetchik");
$w=mysql_error();
echo $w;
Сейчас необходимо получить максимальное значение количеств посещений за день. Для этого нам нужен следующий код:
$key=0;
for($i=1;$i<=31;$i++)
{$res = mysql_query("SELECT day from hosts where day='$i' and month='$month'");
$kol=mysql_num_rows($res);
if ($key<$kol)
$key=$kol;
};

В цикле мы последовательно опрашиваем базу данных на записи, в которых значения полей day и month равны соответствующим интересующим нас значениям. Для простоты будем считать, что во всех месяцах по 31 дню. (Для особо дотошных можно добавить дополнительное условие, тогда все будет корректно выглядеть — для данного блока кода примерно так: for($i=1;$i<=$KOL_ DNEY;$i++). $KOL_DNEY можно будет получать из формы — правда, тогда придется соответственно изменить и остальные части скрипта. Но я думаю, что это не составит труда сделать без моей помощи). Сразу после запроса идет вызов функции mysql_num_rows(), которая возвращает количество строчек в ответе на запрос. Таким образом, мы далее получаем максимальное количество посещений в день за целый месяц. (Если такого дня 31 в феврале точно нет, количество посещений за этот день будет, соответственно, нулевым и никак не повлияет на общую картину.) Идем дальше:

$mas=bcdiv("10",$key,"2");
echo "<table border=1 cellspacing=0>";

Итак, как же мы будем отображать статистику? Сделаем это следующим образом. Нарисуем таблицу 31*10 и пропорционально загруженности этого дня в месяце будем закрашивать ячейки в таблице. Для этого нам нужно знать коэффициент пропорциональности количества закрашенных ячеек относительно посещаемости. А это и есть $mas, который мы и находим, после чего рисуем заголовок этой самой таблицы.

Запускаем цикл прорисовки таблицы. В этом цикле MySQL опять получает запросы, как и в предыдущем куске кода. Затем вновь подсчитывается количество посещений за день, и это количество умножается на коэффициент $mas, что в результате дает количество ячеек, которое необходимо закрасить.

for($i=0;$i<=31;$i++)
{
$res = mysql_query("SELECT
day from hosts where day='$i' and month='$month'
");
$kol=mysql_num_rows($res);
$n=bcmul($mas,$kol,"1");
if($n==0)
$n="0.1";/*
Две последние строки необходимы для корректной прорисовки таблицы в случае
нулевого количества посетителей в данный день */

Теперь нам остается только нарисовать нашу таблицу:

echo "<tr>";
if($i==0)
{
echo "<td>День\Загрузка</td>";
}
else echo "<td>$i</td>";// Выводим номера дней месяца
for($j=1;$j<$n;$j++)
{
echo "<td bgcolor=#FF0000>_ </td>";//Выводим закрашенные ячейки (красным)
};
for($g=1;$g<9-$n;$g++)
echo "<td>_</td>";/* Выводим незакрашенные ячейки таблицы. Разделитель "_" можно заменить на любой символ, в том числе и непечатный */
echo "</tr>";
};
};
?>

Таким образом, на выходе скрипта мы получаем таблицу, с левой стороны которой идут номера дней месяца, а с правой — что-то типа диаграммы. Теперь о том, каким образом можно переделать данный "анализатор" на анализ посещений, допустим, за день. Для этого просто необходимо переделать запрос для MySQL-сервера следующим образом: mysql_query("SELECT hour from hosts where hour='$i' and day='$day'"); и второй запрос: mysql_query("SELECT hour from hosts where hour='$i' day='$day' ");. Также необходимо число 31 в циклах заменить на 24 (я думаю, понятно, почему:-) — в сутках ведь не 31 день). Как изменить масштаб "диаграммы"? Да очень просто. При делении ($mas=bcdiv ("10",$key,"2");) число 10 замените на нужное вам, соответственно заменив 9 в выражении for($g=1;$g<9-$n;$g++). Согласен, алгоритм работы вышеизложенного скрипта далек от идеального, но, как показал практический опыт его применения, он довольно-таки удобен в использовании (конечно, с добавлением идентификатора пользователя и как часть администраторского интерфейса). А описанная выше база данных, которая заполняется этим счетчиком, содержит избыток информации, которой будет вполне достаточно для написания сколь угодно сложной системы анализа посещаемости. Собственно, показанный здесь скрипт по анализу посещаемости — всего лишь пример, который очень прост в использовании и настройке.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Книга "10 Секретных Кнопок"
Эта книга по какой-то фантастической случайности не попала в разряд «Совершенно Секретных». Так что ПОКА у вас еще есть возможность познакомиться с одним из самых важных открытий в области человеческой психологии - так называемыми «нейро-кнопками», «нажав» на которые, вы получаете возможность... Впрочем: тс-с! Это не та тема, о которой можно заявлять в открытую… Поэтому... ОСТОРОЖНЕЕ!
Узнать подробнее о книге "10 Секретных Кнопок"


Чем настроить Windows?

Автор: Alex, editor@izcity.com

Neo Tweaker Professional - это бесплатная программа для настройки и оптимизации операционных систем семейства Windows с возможностью подключения дополнительных плагинов, увеличивающих количество настраиваемых опций.

Я уже рассказывал о программе XP Tweaker (смотрите IZone 532), позволяющей настраивать и оптимизировать работу операционной системы, но XP Tweaker предназначен только для работы с операционными системами Windows XP и Windows Server 2003. Сегодня же мы поговорим о программе Neo Tweaker Professional, работающей в любой операционной системе семейства Windows, начиная с Windows 95 и выше. Neo Tweaker Professional, как и настройщик XP Tweaker, распространяется абсолютно бесплатно.

Все скриншоты, приведённые в этой статье, сделаны при работе программы Neo Tweaker Professional в операционной системе Windows XP.

При инсталляции программы Neo Tweaker Professional пользователь может выбрать языковой интерфейс по своему выбору. При запуске программы будет выводится окно, в котором нужно указать одну из тем, параметры которой будут настраиваться. Если вы хотите получить доступ ко всем 365 опциям настройки, доступным в программе Neo Tweaker Professional, выберите пункт Все темы.

После того, как тема выбрана, запускается основное окно программы, в котором и происходят настройка и оптимизация операционной системы.

Как видите, программа имеет интуитивно понятный интерфейс. В левой части программы, в древовидной форме, выбираются опции, которые должны быть настроены по вашему усмотрению. В правой части происходит сам процесс настройки. Для изменения настроек нужно лишь поставить или убрать триггер (галочку) около интересующей вас опции, при этом программа изменяет параметры реестра Windows.

В самом начале изменения настроек рекомендую сделать резервную копию реестра с помощью этой программы. Это нужно для того, чтобы можно было вернуть первоначальные настройки реестра, в случае неверной и неправильной настройки Windows. Чтобы восстановить параметры реестра, нужно выбрать пункт Откат в главном окне программы, затем выбрать опцию Восстановить состояние системы до первого запуска.

Настройка самой программы, Neo Tweaker Professional, проводится в отдельном окне и не влияет на процесс настройки операционной системы.

Как уже говорилось ранее, программа Neo Tweaker Professional может настраивать и вносить изменения по 365 опциям. Внося изменения в эти опции, вы можете ставить всевозможные запреты, ускорять работу вашей системы, защищать вашу систему от нежелательных вторжений, чистить различные списки: Автозагрузки, Установки/Удаления программ от ненужных элементов и т.д.

Этими функциями программа Neo Tweaker Professional не ограничивается. В программе предусмотрена возможность подключения дополнительных модулей-плагинов для расширения возможностей настройки, оптимизации и чистки операционной системы.

При инсталляции программы Neo Tweaker Professional, устанавливаются 5 дополнительных плагинов. Для примера, приведу диалоговое окно плагина Чистильщик.

Подводя итог, приведу основные достоинства этой программы; недостатков не привожу, т.к. они мной не были обнаружены. Это, конечно, не гарантирует, что в вашей операционной системе программа Neo Tweaker Professional будет работать также хорошо, как и в моей. Бывает - и палка раз в год стреляет!

Итак, достоинства Neo Tweaker Professional:

  • Многоязычная поддержка.
  • Стабильность работы.
  • Возможность отката (одно из важнейших достоинств).
  • Поддержка всех операционных систем семейства Windows.
  • Простота использования. Возможность работы в двух режимах: Профи и Новичок.
  • 365 изменяемых опций.
  • Использование плагинов других программ.
  • Подробная справка по каждому параметру.

Скачать программу можно отсюда (1611 кб)

***
Рекомендуем
Удобно! Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.


Не-эмулятор

Автор: DJ ZX

Когда говорят об эмуляторах для запуска Win32-приложений под Линуксом, о Wine вспоминают всегда. Вспоминают и о его глючности. Но в последних релизах глючность Wine'а — это в основном последствия его некорректной установки или настройки. Соответственно, вопросам установки и настройки Wine'а я и уделю основное внимание в этой статье.

Windows-эмулятор?

Я долго думал, с чего начать свою первую статью в МК, и решил, что раз статья первая, уместно было бы познакомить читателей со своими взглядами на некоторые явления в компьютерном мире.

Начнем с того, что ярым приверженцем Линукса я точно не являюсь. Поэтому выражений типа «Линукс — рулезз форэва!!!» или «Виндовс — сакс!» от меня вы не дождетесь. Как не дождетесь и заявлений о противоположном. Линукс и Виндовс — это очень разные системы, обе стремительно развиваются, и пророчествовать, что какая-то из них раньше сойдет со сцены, по крайней мере несвоевременно — что бы там ни говорили о дефиците возможностей первой и дороговизне второй. И хотя эта статья о чисто линуксовом проекте, я этим хочу засвидетельствовать лишь то, что мне нравится исследовать новое.

Правда, и противником Линукса меня тоже не назовешь. Посудите сами: у меня на компьютере сейчас стоят три системы — это и желанная для игрока легкая, хотя и зависающая (редко, но метко) Windows Millenium Edition, и невероятно мощная, стабильная и совершенная, но все же чуть-чуть тяжеловатая Windows XP (на данный момент Home Edition, которая ни стабильностью, ни возможностями для рядового (и не рядового) домашнего пользователя не отличается от профессиональной версии), и бесплатная Linux Mandrake 9.1 (Bamboo). И в любой из этих систем я чувствуя себя хорошо, хоть некоторое предпочтение все же отдаю WinXP, которая и является основной. Этот текст пишется в KWord'е, так как я люблю красивый и удобный интерфейс, каковым хоть и более сильный, но не очень дружественный — по крайней мере мне — OpenOffice.org (StarOffice) Writer не может похвастать.

Так, от основной темы я ушел, зато высказался. Вернемся к нашему эмулятору.

Ну, для начала не к эмулятору, а к эмуляторам — именем «Wine» объединена сейчас достаточно большая их группа.

В первую очередь это WineHQ, называемый просто Вайном (http://www.winehq.org). Это родоначальник всех Вайнов, и о нем пойдет речь конкретно в этой статье.

Уголок истории Wine

Кстати, сам Wine «родился» в 1993 году как средство для запуска Win-3.1 программ под Линуксом — то есть в текущем году разработчики могли бы праздновать юбилей. Координатором проекта был Боб Амстадт, который со временем отказался от его разработки, передав проект Александру Джуллиарду, впервые запустившему его.

Выход из уголка истории Wine

Второй на очереди ReWind (http://sourceforge.net/projects/rewind). Распространяется он по Open-Source лицензии BSD и является ответвлением от одной из старых веток WineHQ. Его отличия от предыдущего в общем сводятся только к типу лицензии — X11 против LGPL у WineHQ. (По-моему, это признак паранойи — плодить типы бесплатного(!) лицензирования, при этом распространяя одни и те же продукты с разными лицензиями. Скоро достаточно будет поменять две буквы в Readme-файле, чтобы объявить о создании новой версии программы с новым названием.)

Третью группу составляют коммерческие продукты от компании CodeWeavers (http://www.codeweavers.com): CrossOver Office (http://www.codeweavers.com/products/office), CodeWeavers CrossOver Office Server Edition (http://www.codeweavers.com/products/cxofficeserver), CodeWeavers CrossOver Plugin (http://www.codeweavers.com/products/crossover), а также бесплатный CodeWeavers Wine preview (http://www.codeweavers.com/technology/wine). О последнем чуть поподробнее — это невероятно стабильная, хотя и не самая свежая версия Wine, с графическим установщиком winesetuptk, который предоставит вам удобный и простой интерфейс для настройки.

И наконец, четвертым представителем эмуляторов Wine является TransGaming Technologies WineX (http://www.transgaming.com). Это ответвление от WineHQ, имеющее одно очень существенное, особенно для геймеров, усовершенствование — этот эмулятор содержит в себе улучшенную, вдобавок, полную (в плане совместимости) поддержку интерфейса Direct3D. Распространяется за деньги, правда, не очень большие. Рекомендую зайти на сайт TransGaming Technologies для получения информации о распространении — возможно, вы сможете себе это позволить. Кроме того, CVS-исходники без поддержки защищенных игрушек распространяются бесплатно на сайте SourceForge.net (http://sourceforge.net/projects/winex). Но если вы захотите их скачивать, то учтите такой вот момент — CVS-версии распространяются как в виде исходников, так и виде RPM-пакетов. Лично я не рекомендую брать RPM'ки (мотивация: у меня не запустилась ни одна установленная версия, при том что WineHQ и из стандартной поставки дистрибутива ОС, и из свежих исходников работали нормально).

С дистрибутивами разобрались, теперь разберемся, что же такое Wine на самом деле. Как пишут в документации (WineFAQ), Wine — это не эмулятор (Wine Is Not a (CPU) Emulator — WINE), он только предоставляет структуру Windows API при соответствующих запросах от выполняющейся программы. Как объясняется здесь же, благодаря этому Wine может выполнять видовые приложения на полной скорости. Правда, мне кажется, что создатели Wine немножко не правы, так как в любом случае программа создает своеобразную подмену программного интерфейса — если вместо Linux API предоставляется структура, подобная WinAPI, это значит, что она эмулируется. Вот такая вот запутанная ситуация — вроде бы по всем признакам эмулятор, а вроде бы и нет. Осталось только добавить фразу из того же WineFAQ, которая мне очень понравилась. Прямо и без обиняков она втолковывает, что же такого делает Wine: «Wine is not about running Windows but about running Windows applications».

А сейчас мы это правильно поставим...

Вообще, ставится Wine без проблем, но это у меня — как будет у других пользователей, я предугадать не могу, просто расскажу о наиболее важных моментах установки.

Начнем со скачки. WineHQ можно скачать с родного сайта (см. выше) или с SourceForge.net. Небольшая подсказка: если вы будете качать c SourceForge.net, то в списке зеркал перед скачкой выбирайте сервер в Чехии — у меня всегда качается отлично, без обрывов и ошибок.

Как и все линуксоиды, я рекомендую использовать исходники: больше контроля, в результате, при правильной установке, гарантированы высокие показатели скорости и качества работы. По крайней мере, Wine из состава Мандрейка 9.1 не мог запустить даже WinAmp, хотя поставляемый с этой системой релиз достаточно свежий (январь 2003).

Исходники Wine именуются в формате Wine_ГГГГММДД.tar.gz (иногда просто .tar), то есть файл Wine_20030709.tar является иходником Wine от 9 июля 2003 года (кстати, о нем мы сегодня и будем говорить). В отличие от многих других Линукс-проектов, свежие выпуски Wine (не CVS) появляются отнюдь не еженедельно, иногда можно ждать релиз несколько месяцев. Но я считаю, что так лучше, потому что качество нововведений в релизах Wine'а всегда выше их количества.

Немного о требуемом дисковом пространстве: архив с исходником занимает около 10 Мб дискового пространства, для его распаковки нужно около 45 Мб, для его компиляции — около 450 Мб на диске с иходником и столько же места понадобится на корневом диске для установки Wine’а.

После загрузки распакуйте архив и зайдите в папку с исходником. Если вам не хватило желания (терпения) дочитать статью до конца, полную документацию вы найдете в папке documentation (она, естественно, английская). Правда, для того чтобы ее прочесть нужно сначала запустить скрипт make_winehq, который скомпилирует из SGML-файлов всю документацию в форматы HTML, PS и другие, а также запакует ее в TAR.GZ. В этой же директории лежит очень нужная нам папка samples — тут находится пример конфигурационного файла для Wine, который мы будем использовать в качестве базы для своего конфига. Также из корня папки с иходником зайдите в директорию tools. В ней вы найдете очень нужную утилиту wineconf и несколько интересных, но в общем-то бесполезных скриптов.

Теперь самое главное: установите пакеты Flex версии 2.5 или новее, а также Yacc. Если у вас нет последнего, не спешите сразу лезть за ним в Интернет — просто установите пакет Bison, являющийся заменой для Yacc в RedHat или Debian-подобных дистрибутивах (Mandrake, AltLinux, ASPLinux). Все действия по установке и настройке совершаются, естественно, под root'ом. Установка выполняется в таком порядке: ./configure — проверяем наличие несоответствий и, если таковые замечены, выполняем make -s depend && make -s (ключ -s заставит утилиту make выводить только сообщения об ошибках) для компиляции. Когда компиляция завершится (а она длится около получаса на Cel700 Coppermine + 256 Mб ОЗУ + HDD 5400 об./мин), выполняем make -s install. Все — Wine установлен!

Продолжение следует

Источник: http://www.mycomp.com.ua/

***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>


Оптимизация MS Windows XP. FAQ

Автор: Андрей Радзевич aka VampiR

Q: Папка Windows занимает неприлично много места на диске. Можно ли его уменьшить?
A: Можно. Чем мы сейчас и займемся.
Первым делом, конечно же, удаляем из папки windows весь мусор, как-то: временные файлы и логи. Хотя сильно много места это не добавит, но уже что-то. Далее можно удалить папки класса $NtServicePackUninstall$. Однако эти каталоги нельзя назвать бесполезными. В них содержится своеобразный backup, который создается, когда вы ставите различные обновления для своей многострадальной ХР. Находим папку Driver Cache\i386 и удаляем все ее содержимое. Но если вы захотите поставить новую железку в свой компьютер или забарахлит старая, то система потребует от вас компакт с дистрибутивом. В первой статье мы с вами удалили содержимое папки %systemroot%\system32\dllcash. При рассказе я не учел одну хитрость ХР. Через некоторое время система может снова захотеть заполнить этот каталог. Но ведь нам этого не надо? Поэтому идем в HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Winlogon, находим там параметр SFCQuota, который отвечает за объем кэша, и изменяем его по своему желанию. Эту же операцию можно проделать введя в командной строке следующее: sfc /cachesize=х, где х — размер кэша.

Q: Что надо сделать, чтобы Проводник открывался не в папке Мои документы?
А: Поставить WinCom:). А если серьезно, то сделать надо следующее. В окне Свойства ярлыка добавляем к значению поля Объект /e, тогда Проводник будет открываться в корневом каталоге. Если добавить х:\ (х — буква диска), то Проводник будет открываться в указанном диске. А если вызывать сочетанием Win+E, то в окне Мой компьютер.

Q: Можно ли поверх ХР установить 98-ю винду?
A: Конечно, можно — ХР не против, просто нужно правильно попросить:). Проблема заключается в том, что 98-я затирает загрузочный сектор ХР. Лечится это следующим образом. Создайте файл MSBATCH.INF и пропишите в нем следующие строки:
[Setup]
CleanBoot=0

Если дистрибутив 98-й находится на компакте (что бывает в 80 случаях из 100), то необходимо создать .inf-файл на винчестере (причем не обязательно с названием MSBATCH), а программу установки Windows запустить со следующим параметром setup.exe X:\Путь\MASBATCH.INF. Где Х — буква диска. После установки в файле boot.ini (принадлежащем Windows XP) в разделе [operating systems] прописать путь к 98-й. Ниже описание команды файла boot.ini. Информация взята с сайта www.winall.ru — на мой взгляд, одного из лучших ресурсов о Windows в Интернете.
Начинается этот файл разделом [boot loader]. В этом разделе всего два параметра:

  • Timeout — определяет время в секундах, которое ждет система, прежде чем начать загружать ОС по умолчанию, в случае, если в системе установлено несколько ОС.
  • Default — определяет систему, которая грузится по умолчанию.

Второй раздел [operating system], в котором находится список возможных к загрузке ОС. Для каждой ОС указывается ее местоположение с использованием имен ARC (Advanced RISC Computer):

  • scsi(*) или multi(*) — элемент scsi(*) используется в случае контроллера SCSI с отключенным BIOS. Элемент multi(*) используется для дисков всех остальных типов включая IDE, EIDE, ESDI и SCSI с включенным BIOS. (*) — номер адаптера, с которого осуществляется загрузка. Адаптеры нумеруются с нуля, начиная с контроллера, расположенного ближе к слоту 0 на мат. плате.

  • disk(*) — если (1) = scsi(*), то равен логическому номеру устройства (LUN), установленному для диска. Если (1) = multi(*), то всегда равен нулю.

  • rdisk(*) — если (1) = multi(*), то равен номеру диска в цепочке; счет дисков начинается с 0. Если (1) = multi(*), то всегда равен нулю partition(*) — определяет дисковый раздел, содержащий файлы ОС. В отличие от всех остальных элементов имен ARC, нумерация разделов начинается с 1, т.е. первый раздел обозначается partition(1), второй — partition(2) и т.д.

  • \path — определяет каталог (или подкаталог) раздела, в котором находятся файлы ОС. По умолчанию в XP используется путь \windows. Кроме этого, в кавычках прописывается текст, который будет виден в пункте выбора этой ОС в стартовом меню. После этого текста могут быть ключи, которые влияют на загрузки ОС. Для XP возможны следующие ключи:
    — /basevideo — с этим ключом система будет использовать только стандартный VGA-драйвер. Этот параметр может пригодиться, если вы на короткое время ставите другую видеокарту, и вам не хочется мучиться с перестановкой драйверов.
    — /fastdetect — обычно ставится автоматически при инсталляции системы. При установке этого ключа система не определяет все Plug and Play устройства в процессе загрузки.
    — /maxmem — определяет максимальный размер RAM, который может использоваться системой. Теоретически может помочь, если у вас глючная оперативка.
    — /noguiboot — при использовании этого ключа не будет рисоваться цветная заставка при загрузке. Может использоваться теми, кто не желает смотреть на эту картинку в 60 герцах. Но надо учесть, что, кроме этого, не будут рисоваться BSOD при загрузке. Но виснуть система, если что-нибудь не в порядке, естественно, не перестанет.
    — /noserialmice=[com 1,2,3] — при использовании этого параметра не будет определяться мышь, подключенная к COM-порту, для портов, перечисленных в скобках. Если номера портов не указывать, то мышь не будет определяться на всех портах.
    — /bootlog — при задании этого параметра система будет писать лог загрузки в %SystemRoot%\Nbtlog.txt Этот параметр можно использовать, чтобы найти причину, почему система может загрузиться только в safe mode.
    — /safeboot — при его установке система загрузится в Safe mode. То же самое можно сделать, нажав F8 в начале загрузки системы. Через двоеточие можно задать несколько параметров для /safeboot:
    Minimal — минимальная конфигурация.
    Network — с поддержкой сети.
    Dsrepair — доступна только в NET Server и позволяет восстановить Active Directory с заблаговременно сделанной резервной копии.
    Alternateshell — позволяет использовать альтернативные графические оболочки. По умолчанию с системой ставится только Explorer (стандартная оболочка) и Progman (осталась в наследство от Windows3.11 и NT 3.5).
    — /sos — отображает на экране список загружаемых драйверов. Может помочь выяснить, на чем система спотыкается при загрузке.
    — /baudrate — этот параметр указывает скорость, с которой будет работать COM-порт для отладки системы. Если не указать конкретную скорость, то будет 9600 для модема и 19200 для нуль-модемного кабеля. При включении этого параметра автоматически ставится параметр /debug.
    — /crashdebug — с этим флагом загружается отладчик, но остается в неактивном состоянии до тех пор, пока не произойдет ошибка ядра. Может использоваться разработчиками программного обеспечения.
    — /debugport=com* — указывает номер COM-порта (* должна быть номером порта), используемого отладчиком. Автоматически включает ключ /debug.
    — /debug — загружается отладчик, который может быть активизирован другим компьютером, подключенным через COM-порт. Может использоваться разработчиками ПО.
    — /nodebug — на экран не выводится отладочная информация.
    — /hal — указывает имя файла, который должен использоваться как hal.dll после загрузки.
    — /kernel — указывает имя файла, который должен использоваться как ntoskrnl.dll после загрузки.

Q: Можно ли узнать из Диспетчера задач, какой процесс за какие программы и файлы отвечает?
А: Из диспетчера задач узнать такую информацию не удастся. Однако существует замечательная программа Advancer Process Manager (www.carc.hotmail.ru). Программа также позволяет изменять приоритет и убивать процессы.

Q: Как поставить режим DMA на винчестере и CD ROM'е?
А: Правой кнопкой на ярлыке Мой компьютер — Свойства (Win+Break) — Оборудование — Диспетчер устройств — IDE ATA/ATAPI контроллеры — Правой кнопкой на Вторичный канал IDE — Свойства — закладка Доп. параметры — Ставите значение DMA, если доступно на вкладке Режим передачи для обоих устройств. То же и с Первичным...

Q: При подключении к Интернету появляется сообщение "svchost вызвало ошибку", после этого не открывается ни одна ссылка, Интернет не отключается (нужно перезагружать комп).
А: Панель управления — Администрирование — Управление компьютером — Просмотр событий. Посмотреть описание ошибок и по их коду (ID) найти решение, обратившись на сайты support.microsoft.com и www.eventid.net.

Q: Как удалять файлы минуя корзину?
А: Для этого идем в Пуск — Выполнить (Win+R) — gpedit.msc. Закладка Конфигурация пользователя — Административные шаблоны — Компоненты Windows — Проводник — Двойной щелчок по Не перемещать удаляемые файлы в "Корзину". Отмечаем Включен — Применить. Все — все файлы всегда удаляются мимо корзины.

Q: Можно ли убить процессы из командной строки?
А: В консоли введите команду tasklist. В ответ на это перед вами появляется список запущенных процессов и информация о них. Командой taskkill /pid можно убить любой процесс. Наберите taskkill /? и получите подробную справку о данном процессе.

Q: Иногда у меня при работе винда неожиданно перезагружается. Что это такое?
А: Это не есть хорошо. Создатели ХР сделали следующую вещь: по умолчанию в случае критической ошибки система не показывает, в отличие от предыдущих версий, "синий экран смерти", а просто перезагружается. Если вам это не нравится, то можно изменить. Панель управления — Система — Дополнительно — пункт Загрузка и восстановление, снять галочку с пункта Выполнить автоматическую перезагрузку.

Q: Для чего нужна папка WinSxS в корневом каталоге и папка xerox в папке Program Files?
А: Первая папка предназначена для защиты пользователей от не совсем прямых рук некоторых программистов. При установке некоторые программы пытаются заменить виндосовские dll-файлы на свои собственные, что не всегда есть хорошо и может привести к отказу системы. Добрые комрады из компании Microsoft решили эту проблему. ХР направляет dll-файл программы в WinSxS, и программа считает, что все заменено, и спокойно работает. Windows в свою очередь тоже продолжает спокойно работать.
Папка хerox (по замыслу разработчиков) предназначена для хранения библиотек (но ни в коем случае не читальных залов:)), которые теоретически могут появиться на вашем компьютере, но фактически шанс их попадания туда равен шансу перехода Windows на open-source. Процент посчитаете сами :)?

И напоследок я хотел бы дать вам самый важный совет по оптимизации и ускорению работы Windows. Совет важный, но от этого не самый сложный в исполнении. Мы не будем применять никаких программ, ни самой Windows, а привлечем самый главный компьютер человека — его мозг. Способ этот заключается в изучении и применении горячих (прямо из печки) клавиш. Изучайте, только смотрите не обожгитесь :):

Alt + Enter — открывает окно Свойства для выделенного объекта (файла, папки или диска).
Alt + F4 — закрыть активное окно. Если открытых окон нет, то вызывается меню Завершение работы Windows.
Alt + Space — открывает управляющее меню активного окна (аналог щелчка правой кнопки мыши на строке заглавия окна).
Alt + [подчеркнутая буква в меню программы] — вызов соответствующего подчеркнутой букве меню.
Alt + Tab — переключение между запущенными окнами.
Backspace — переход на один уровень вверх в окне проводника.
Ctrl — удерживайте во время перетаскивания файла для того, чтобы скопировать его.
Ctrl + A — выделить все.
Ctrl + C — скопировать выбранный объект.
Ctrl + Esc, Win — вызов меню Пуск.
Ctrl + Esc, Esc — после вызова окна Пуск, нажав Esc, сделать активной саму кнопку Пуск.
Ctrl + Shift — удерживайте во время перетаскивания файла для того, чтобы создать ярлык.
Ctrl + V — вставить.
Ctrl + X — вырезать.
Ctrl + Z — отменить последнее действие, в некоторых программах — несколько последних (MS Office, Open Office и т.д.).
Delete — удалить выбранный объект.
F1, Win + F1 — вызов Центра справки и поддержки.
F10 — делает активной строку меню.
F2 — переименовать выбранный объект.
F3 — поиск.
F4 — раскрытие строки Адрес.
F5 — обновить активное окно или рабочий стол.
F6 — переключение между панелями Проводника.
Shift — удерживайте:
— во время перетаскивания файла для того, чтобы переместить файл;
— во время загрузки Windows, чтобы не загружались элементы Автозагрузки;
— при вставке компакта в привод для отмены автозапуска.
Shift + Delete — удалить мимо корзины.
Shift + F10 — аналог правого щелчка мыши на объекте.
Win + Break — вызов окна Свойства системы.
Win + D — свернуть все окна.
Win + E — вызов Проводника.
Win + F — вызов окна Поиск.
Win + R — вызов окна Выполнить.
Win + Shift + M — отмена свертывания окон.
Win + Tab — переключение между окнами на панели задач.
Win + M — свернуть все активные окна, кроме окон свойств.

Этой статьей мы завершили тему оптимизации Windows. Буду рад, если помог облегчить ваше сожительство с системой :) и немного разгрузить свой компьютер. Засим раскланиваюсь, желая вам всего лучшего.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Хотите сыграть в пейнтбол?
Пейнтбол - это игра, в которой можно изрешетить "злобного" шефа или "зануду" подчиненного из специального оружия, маркера, используя при этом "пули" - разноцветные шарики с краской. Главное - в итоге все останутся живы.
Подробнее >>


Информация

Свежие номера здесь! Служебная информация
  • Реклама в журнале
  • Для авторов, желающих публиковаться
  • Условия использования материалов
  • Подписка на рассылку

Реклама в журнале

Версия от 15.09.2003г.

Информация о журнале:
От обычных рассылок, рассылаемых по почте, журнал отличается тем, что это не одинарный листок с информацией, а действительно полноценный электронный журнал (содержащий внутри себя массу страниц с информацией и графикой, систематизированными по рубрикам).
Большинство пользователей, скачивающих журналы - создают у себя на компьютере электронную библиотеку, т.е. хранят у себя на компьютере архивы журналов.
Соответственно, рекламная информация размещенная в журнале - имеет гораздо более длительный "срок жизни", чем реклама в обычных рассылках.

Количество загрузок каждого номера вы можете посмотреть здесь: http://www.izcity.com/down/doc0.html
В среднем порядка не менее 15-20 тыс. человек скачивают и читают каждый номер. Количество постоянных читателей (как минимум раз в месяц загружающих и просматривающих какой-либо выпуск журнала): не менее 50 тыс. человек
Периодичность выхода журнала: 8-10 выпусков в месяц.

Расценки:

Где размещено | Тип рекламы | 1 выпуск | 3 выпуска | 10 выпусков
Главная страница журнала | баннер 468х60 вверху | $5 | $10 | $20
 | Статья до 5000 знаков | $5 | $10 | $20
Внутри журнала баннер (сквозной по журналу, на всех страницах со статьями, кроме главной и нескольких служебных) | баннер 468х60 вверху | нет | нет | $20
 | баннер 468х60 внизу | нет | нет | $15
Статья рекламная внутри журнала | Статья до 7000 знаков | $2 | $5 | $12

Примечание:

  • Текст вместо баннера: вместо баннера вверху или внизу можно размещать текстовый блок до 300 знаков или текстово-графический блок (помимо текста может присутствовать небольшая картинка)
  • Бесплатно: в вашей статье или материале могут также присутствовать одно или несколько графических изображений общим "весом" не более 30 кб.
  • При подсчете знаков html-тэги не учитываются, а пробелы учитываются.
    Для того, чтобы правильно подсчитать знаки в вашем рекламном объявлении - используйте, например текстовый редактор Word. Скопируйте в него ваш текст, а затем в меню Word найдите пункт Статистика. Все сразу и увидите.
  • Форматы присылаемых текстовых блоков, материалов и статей:
    HTML, HTM, Word (doc) или RTF. Если статья с графикой, то можете все это дело упаковать в zip-архив и в таком виде прислать нам. Обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам.

Как платить?
Все расчеты производятся при помощи платежной системы WebMoney.
Наши кошельки:
Z906510760241
R211650054260
Если вы не знакомы с этой платежной системой, то зайдите к ним на сайт, почитайте. Все на русском языке, просто и понятно. Денежные переводы и расчеты производятся моментально, в режиме реального времени через Интернет.

Порядок оформления рекламного заказа:
- Переводите нужную сумму денег на наш кошелек в системе Webmoney
- В примечании к переводу оставьте какой-нибудь комментарий, в котором укажите ваш емейл или адрес сайта, или фамилию, или название организации. Чтоб мы могли понять, от кого пришли деньги...
- Затем присылаете письмо с сообщением о переводе денег и вашим рекламным текстом (статьей) или баннером.
- Ваша реклама выходит в ближайшем свободном выпуске журнала (в течении 2-4 дней).

По вопросам размещения рекламы обращаться: reklama@izcity.com
Дополнительно смотрите другие наши рекламные услуги

Вверх | На главную

Для авторов

Версия текста от 19.10.2003г.

Хотите публиковаться?
Стать нашим автором несложно... Если вы пишете статьи, если вы считаете, что они интересно, талантливо написаны, то у нас с вами есть повод для сотрудничества.
Нас интересуют статьи, описания, руководства... Тематика: компьютеры, Интернет, программы; описания утилит; обзоры железа, периферии, софта; примеры решения каких-либо компьютерных проблем и т.д. В общем интересно все, что относится к компьютерной тематике и Интернету.

Требования к материалам:

  • Статьи принимаются к публикации у нас только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Актуальность, ясность и простота изложения, последовательность и логичность, четкость формулировок и аккуратное использование терминов, точность в научных и технических сведениях. В статье могут быть указаны реквизиты автора: емейл, ссылка на сайт и т.д. Дополнительно: в двух-трех предложениях автор может написать о себе. Также может выразить благодарность компаниям или лицам, оказавшим помощь при подготовке материала. Соответственно могут быть указаны реквизиты организаций, предоставивших продукты или программы для тестирования или обзора.
  • Форматы присылаемых материалов: DOC (Microsoft Word), RTF, HTML (HTM).
    Если вы используете в статье графику (логотипы, скриншоты и т.д.), то сразу вставляйте графику в HTML. Графика не должна быть громоздкой и иметь большие размеры. Желательно не более 30 кб. графики (общий "вес") на одну статью... Кроме того, изображения (картинка, скриншот) в статье не должны превышать 370 пикселей в длину по горизонтали.
    Проверьте правильность ссылок. Статью и графику к ней будет логичным объединить в один каталог, упаковать архиватором и в таком виде переслать нам.
    Если ваша статья без графики и состоит из одной страницы, то этот документ можно просто прислать вместе с письмом.
  • Отсутствие ошибок: грамматических и орфографических (проверяйте тексты в Word, плюс сами читайте, перед тем как нам отправлять...)
    Обратите внимание: обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам... Статьи, содержащие много ошибок - не публикуются!
  • Статьи о спонсорах и заработке - грамотные содержательные статьи общего плана публикуются бесплатно. Статьи рекламного характера, с реферральными ссылками публикуются на правах рекламы
  • Рекламные статьи любой тематики (явно рекламирующие компанию, платные продукты или услуги) публикуются на правах рекламы.

Взаимоотношения с авторами:
Денег мы не платим, однако мы предлагаем альтернативные варианты поощрений для авторов. Для начала скажем, что понятное дело - вы в статье можете указать свои авторские реквизиты: емейл, ссылку на свой сайт и т.д. Таким образом, вы получите дополнительный приток людей на свой сайт. Ведь, не секрет, что хорошая статья о каком-либо продукте или услуге, со ссылкой на сайт - неизбежно вызовет приток посетителей на этот сайт.
Если вы достаточно часто будете публиковать статьи, то за вами вполне может закрепиться имидж эксперта в той или иной области.

А теперь о поощрениях за опубликованные у нас статьи:
За каждую статью, опубликованную в нашем журнале вы получаете бесплатно рекламный блок в нашей рассылке IZone Web (это правило действует с 14.08.2002г.; о рассылке IZone Web: на 19.10.2003 г. более 150 тыс. подписчиков, статистику на сегодняшний день можно посмотреть с этой страницы: http://www.izcity.com/info/reklama2.htm).
Рекламные блоки предлагаются в следующем соотношении:

  • Статья до 5000 знаков - текстовый блок до 200 знаков

  • Статья до 7000 знаков - текстовый блок до 300 знаков

  • Статья до 10000 знаков - текстовый блок до 500 знаков

Рекламные блоки бесплатно размещаются в нижней части рассылки IZone Web. Можно присылать заявку на размещение вашего рекламного блока после каждой вашей статьи. Можно опубликовать несколько статей у нас, а потом спустя некоторое время прислать заявку на размещение группы ваших блоков.

Если вы подаете заявку на размещение у нас рекламного блока после каждой вашей статьи, то форма подачи заявки следующая:
Присылаете письмо, в котором должны обязательно присутствовать следующие моменты:
- Название вашей статьи, количество знаков без пробелов в статье и номер выпуска журнала, в котором ваша статья опубликована.
- Текст вашего рекламного блока (объявления)
Ваш рекламный блок выйдет в одной из ближайших рассылок (в течение 2-4 дней).

Если вы подаете заявку на размещение у нас сразу нескольких рекламных блоков после публикации нескольких ваших статей, то форма подачи заявки следующая:
- Названия ваших статей, количество знаков без пробелов в каждой статье и номера выпусков журнала, в котором ваши статьи опубликованы.
- Текст вашего рекламного блока (или блоков).
- Ваши комментарии по вашей рекламе у нас (количество раз публикаций которые вам причитаются; также в зависимости от этого текст и размеры у рекламных блоков могут быть одинаковыми, а могут быть и разными). Пожалуйста четко указывайте в ваших комментариях все нюансы, чтобы мы вас поняли с первого раза.
Ваша рекламная кампания начнется в одной из ближайших рассылок (в течение 2-4 дней) и будет продолжаться положенное вам количество времени (выпусков рассылки).

Обратите внимание:

  • Вы имеете право на получение бесплатного рекламного блока только в случае факта публикации вашей статьи.
  • Статьи принимаются нами только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Присланные нам статьи не резензируются, не комментируются, не возвращаются. В переписку с авторами, редакция не вступает.

P.S. Мы оставляем за собой право:

  • На распространение копий присланных нам материалов
  • Не публиковать материалы противоречащие нашей концепции.
Статьи для публикации присылать на адрес editor@izcity.com, тема: avtor

Рекламные блоки для размещения в нашей рассылке присылать на адрес reklama@izcity.com, тема: free

Вверх | На главную

Условия использования материалов

Использование материалов нашего журнала регламентируется настоящими правилами (с 15.09.2003г.).

Использование CHM-файлов
Если вы хотите использовать у себя полностью chm-файлы с номерами журналов (например, вы провайдер и хотите выложить журналы у себя на ftp-сервере, или у вас архив софта и вы хотите некоторые архивы журналов держать у себя на сайте), то нет никаких проблем... Можно использовать при соблюдении следующих факторов:
1. Нельзя ничего внутри изменять (ну это, как вы знаете - общее правило...).
2. При использовании обязательна ссылка на нас. Ссылка должна указывать на наш сайт http://www.izcity.com

Использование отдельных статей из выпуска
Наши собственные статьи, т.е. статьи наших авторов (отсутствует под статьей ссылка на источник) - можно использовать с указанием ссылки на наш сайт http://www.izcity.com
Использование статей с других источников (под статьей есть ссылка на источник информации) - запрещено.

О наших материалах
Информационную начинку нашего журнала составляют, как материалы собственных авторов, так и дайджест с наиболее популярных компьютерных ресурсов Рунета. Все публикуемые у нас материалы - юридически чисты. Каждый материал (или статья) в нашем журнале имеет своего автора или правообладателя (собственника прав на статью). Все материалы публикуются либо с разрешения авторов или владельцев авторских прав, либо присылаются ими непосредственно в редакцию IZone для публикации.

Вверх | На главную

Подпишитесь на нашу рассылку IZone WEB!
Своевременно полученная информация - залог успеха. Для того, чтобы всегда быть в курсе всех наших новинок - подпишитесь на нашу рассылку. Удобно и практично: наша информация будет доставляться в ваш почтовый ящик. Периодичность рассылки: 3 раза в неделю.
Наши подписчики получают краткую аннотированную информацию обо всех новинках нашего сайта. Это выход свежих номеров журнала "Internet Zone", бесплатные программы, различные утилиты, средства и сервисы для создания и "раскрутки" сайта, различная компьютерная документация и т.д.
Для подписки на рассылку - посетите нашу страницу подписки в Интернет по адресу: http://www.izcity.com/info/sub.htm либо воспользуйтесь формой справа (необходимо подключение к Интернет)
Подписка на рассылку
Рассылка MailList.Ru

Вверх | На главную


Работа с журналом

Помощь при работе с журналом

Свежие номера здесь! Версия текста от 28.11.2003 г.

Системные требования

Операционная система, начиная от Windows98 и выше.
В системе должен быть установлен браузер Internet Explorer версии начиная от 5.0 или выше.
!!! Обязательно в браузере должны быть включены: поддержка java-скрипт, показ рисунков и анимации.
Разрешение экрана монитора желательно должно быть не менее, чем 1024х768.

Для тех, кто в первый раз...

Что такое CHM?

Compiled HTML - специально разработанный Microsoft формат данных для поддержки гипертекстовых справочных систем. Не требует специальных средств для просмотра. Всё уже есть в Windows. В этом формате сделаны справки к браузерам IE, начиная с четвертой версии и выше, справка к Microsoft Office и т.д.

Как лучше начать просмотр выпуска журнала?

Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню слева и выбрать Открыть все. Данная операция одним махом открывает все вложенные в папки страницы. По окончанию просмотра журнала, аналогично можно выбрать Закрыть все.
Весьма удобно - пользуйтесь. Можно открывать рубрики и поодиночке - используйте крестик слева от папки/рубрики.

Навигация: кнопки вверху

Назад/Вперед
Данные кнопки аналогичны одноименным кнопкам в браузере. Служат для быстрого перемещения между просмотренными страницами

Домой
Нажав на эту кнопку, вы попадете на стартовую страницу

Шрифт
Весьма полезная кнопка. Регулирует размер шрифтов для просмотра. Нажимаете и все. Шрифты меняются по кругу. Обязательно найдется устраивающий вас размер шрифта. Если установки размера шрифтов по умолчанию вас устраивают, то можете вообще не пользоваться данной кнопкой.

Печать
Вывод на печать необходимой вам страницы. Если у вас установлен принтер, то можете пользоваться.

Параметры
Различные настройки и команды.

Навигационное меню слева

- В зависимости от размеров вашего монитора, вы можете зацепить мышкой и расширить/сузить границу-бордюр между навигационным меню и правой частью журнала со статьями.

- Одинарный щелчок мышкой по крестику слева от папки/рубрики (или двойной щелчок по названию) открывает содержимое папки. Обратная операция: щелчок мышкой по минусу (или двойной щелчок по названию) - закрывает папку/рубрику.

- Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню и в зависимости от текущего состояния папок, вы можете выбрать Открыть все/Закрыть все. Данная операция одним махом открывает/закрывает все вложенные в папки страницы.

- Если вы усиленно используете принтер, то здесь же, щелчком правой кнопки мышки по папке можно выбрать варианты печати.

- В Навигационном меню также присутствует вверху закладка Избранное. При просмотре вы можете понравившиеся статьи заносить в Избранное для последующего быстрого доступа к этим статьям.

Разное

Просмотр страниц

При щелчке правой кнопкой мышки по просматриваемой странице - появляется меню с командами.

Используйте клавиатуру

При просмотре выпуска удобно использовать клавиши клавиатуры. Например, клавиши Page Up и Page Down служат для быстрой прокрутки. А вот клавиши справа внизу на клавиатуре со стрелками вверх и вниз - удобно использовать для плавной прокрутки читаемой страницы.

При просмотре CHM-выпуска журнала вместо рисунков вижу только рамки, а сами рисунки не видны.
Также не мигает, как бы застыл анимированный баннер внизу некоторых страниц.

Для корректной работы CHM-формата требуется установленный в системе браузер Internet Explorer и соответственно CHM-формат использует его настройки. В вашем браузере отключен показ рисунков и анимации. Включите их (Сервис > Свойства обозревателя... > вкладка Дополнительно)

Каким образом открыть отдельную страницу выпуска в отдельном окне браузера Internet Explorer?

Кликнуть правой кнопкой по любому месту на странице, в появившемся контекстном меню выбрать "Свойства", значение поля "Адрес (URL)" скопировать в буфер обмена, вставить в адресную строку IE и нажать Enter (или кнопку "Переход" в браузере). Нужная вам страница откроется в браузере
(правда, обратите внимание: при попытке сохранить такую страницу на диск в виде html - сохранится только текст, без картинок, хотя при просмотре картинки будут доступны).

Как сохранить на диск (в формате HTML) одну или несколько понравившихся мне статей (или даже целиком весь выпуск) полностью со всем оформлением, включая и графику?

Для этого придется распаковать/декомпилировать весь выпуск. См. здесь: http://www.izcity.com/info/chm.htm

Как осуществить поиск в пределах одной страницы?

Используйте сочетание клавиш Ctrl-F.

Как распечатать текущую страницу?

Используйте сочетание клавиш Ctrl-P.

В chm-выпуске вашего журнала нашел интересующую меня программу. Как ее скачать не браузером, а моей качалкой, т.е. download-менеджером?

Рассмотрим данный момент на примере популярной качалки FlashGet (http://www.amazesoft.com/). Итак, вот несколько способов для того чтобы скачать нужный вам файл, используя качалку.

1. Первый способ. Стандартный, не требующий от вас лишний телодвижений. Если ваша качалка интегрирована с браузером (производит слежение за кликами), то никаких проблем возникнуть не должно. При клике по ссылке, будет происходить запуск качалки. Если этого не происходит, то проверьте за какими типами файлов ваша качалка производит слежение. Например, во FlashGet по умолчанию не "заряжено" слежение за avi-файлами. Добавьте этот формат вручную в настройках FlashGet.

2. Второй способ: откройте у FlashGet Корзину (выберите в настройках ее показ). И теперь при просмотре chm-выпуска журнала - просто мышкой перетаскивайте нужные вам ссылки в Корзину FlashGet. Вуаля!
Помимо FlashGet, Корзинку имеют и все другие продвинутые качалки. Например, ReGet и т.д.

3. Если файлов, которые нужно скачать, на странице очень много, например 30-40 шт.:), то можно вообще открыть нужную вам страницу в отдельном окне браузера Internet Explorer (см. выше как это сделать), ну а далее выберите в контекстном меню браузера (щелчок правой кнопкой по странице) команду: Закачать все при помощи FlashGet. В появившемся окне FlashGet вручную или с помощью фильтров можно подкорректировать опции загрузки (если что-то ненужное попадет в список загрузки).
Copyright © Internet Zone, info@izcity.com
">Internet Zone, info@izcity.com


IZone

Свежие номера здесь!
IZONE
551
2.12.2003

Полезный совет:
Щелкните правой кнопкой мышки по любому месту в меню слева и выберите Открыть все.

Полезный совет-2:
Почитайте как работать с журналом в папке Your help

Полезный совет-3:
Скачайте другие
выпуски

IZONE
электронный
компьютерный журнал
о высоких технологиях
Читай лучшее!
Кадры решают все!
Программа "Кадры"
  • Автоматизация работы кадровой службы для предприятий любых форм собственности.
  • Построение разветвленной структуры предприятия, ведение штатного расписания.
  • Ведение учета личных карточек с автоматическим формированием приказов.
  • Возможность стыковки с бухгалтерскими программами.
  • Формирование произвольных отчетов по любым параметрам личной карточки.
     Подробнее >>
Программное обеспечение для учебной части
Программа "Студент" поможет вам:
  • максимально упростить и автоматизировать работу по приему, перемещению и отчислению учащихся;
  • автоматически формировать первичную документацию на каждого студента (контракты, подготовка и печать протоколов и приказов о зачислении);
  • настроить структурную схему учебного заведения;
  • вести учебное расписание как учреждения в целом, так и для каждого отдельного подразделения;
  • гибкое ведение учебных планов с учетом специальностей, специализаций, курсов, групп;
  • расширить учетную информацию личной карточки с использованием "Дополнительных сведений" и делать по ней выборку;
  • контроль оплаты обучения с учетом сроков сессии и приказов о продлении контракта;
  • моделировать произвольные отчеты из индивидуальных сведений учащихся на основе критериев, указанных пользователем;
  • совместимости с 1С:Бухгалтерией и другими программами (импорт-экспорт данных);
  • интеграции со стандартными офисными приложениями, такими как MS Word, MS Excel.
     Подробнее >>