Новости

Microsoft "Платформа 2004": Развитие ПО для корпоративных пользователей

Как уже рассказывала "Компьюлента", на конференции Microsoft "Платформа 2004" в ходе своего доклада вице-президент компании Кирилл Татаринов отметил новую инициативу Dynamic Systems Initiative как одно из самых важных событий текущего года. Инициатива была объявлена в марте 2003 года на конференции по управлению в Лас-Вегасе (Невада). С тех пор, по словам Кирилла Татаринова, эта инициатива активно развивалась и внедрялась в новых продуктах и инструментах Microsoft.

"Если мы посмотрим на традиционный рынок информационных технологий, то увидим, что существует огромное количество компонентов, как программных, так и аппаратных, которые не были построены, не были спроектированы готовыми для эксплуатации. Это значит, что данные компоненты не включают в себя необходимых инструментальных средств, позволяющих быстро и динамично загружать и внедрять эти компоненты в эксплуатацию. В конечном счете, это приводит к тому, что эксплуатация требует колоссальных затрат на стыковку между отдельными компонентами, на управление этими компонентами централизованным образом. Естественно, если они не включают в себя инструментарий, ими трудно управлять, поскольку все должно быть сделано вручную. И эти ручные затраты - как раз то, что ведет к колоссальному усложнению эксплуатации", - заявил Кирилл Татаринов.

Для решения этой проблемы, по мнению вице-президента Microsoft, необходимо, чтобы требования пользователей программ были известны разработчикам. Таким образом можно получить "полностью функционирующий жизненный цикл информационных технологий". Именно эту проблему компания намерена решать в рамках инициативы DSI. Новые инструменты разработки, над которыми работает Microsoft, помогут разработчикам как самой компании, так и ее партнеров, создать системы и компоненты, которые полностью готовы к эксплуатации, то есть встраивают в себя весь необходимый инструментарий. Это позволит "значительно упростить вопросы эксплуатации всей системы, поскольку компоненты полностью описаны, вся инструментация встроена, все стыкуется вместе" и позволяет управлять системой централизованно.

Следующая версия Windows, Longhorn, по словам Кирилла Татаринова, будет первой системой, которая полностью реализует все аспекты инициативы DSI. Однако, элементы DSI появятся и в других продуктах, которые будут выходить "в промежутке между Windows Server 2003 и Longhorn". Одним из уже выпущенных элементов является система автоматического внедрения ПО Automated Deployment Services, а также Microsoft Corporate Error Reporting - ПО для централизованного управления информацией о зависаниях и ошибках программ во всей компьютерной сети предприятия.

В начале следующего года Microsoft планирует представить программный пакет Microsoft Virtual Server, который обеспечит "виртуализацию на основе Windows Server 2003". Кроме того, планируется модернизировать инструмент Microsoft Software Update Services для автоматической установки заплаток для ПО компании. Две недели назад был представлен Systems Management Server 2003 - продукт для управления "дополнениями для загрузки программ". Немаловажным продуктом в рамках инициативы DSI стал Microsoft Operations Manager - продукт для централизованного мониторинга всего IT-департамента, а также для централизованного управления и отслеживания ошибок и событий. Соответствующий пакет для управления определенным программным компонентом - MOM Management Pack - будет поставляться с каждым программным продуктом Microsoft.

В конце следующего года Microsoft планирует выпустить новую версию SQL Server - SQL Server Yukon. Наиболее важным компонентом DSI, по словам Кирилла Татаринова, является платформа разработки Visual Studio .Net. Релиз следующей версии VS .Net под кодовым названием Whidbey запланирован на конец следующего или начало 2005 года. Whidbey станет "центром инициативы DSI".

В продаже появились пиратские копии Longhorn

Известные своей наглостью малайзийские софтверные пираты уже продают операционную систему Microsoft Windows версии Longhorn более чем за год до ее официального релиза.

Компакт-диски с Microsoft Longhorn продаются всего за 6 ринггитов (1,58 доллара США) в торговом комплексе в южномалайзийском городе Джохор-Бару на границе с Сингапуром, наряду с тысячами других пиратских программ, музыкальных и DVD-дисков, сообщил один из юристов Microsoft Джонатан Селвасегарам.

Пиратские копии сделаны с одной из ранних версий Longhorn, которая демонстрировалась и распространялась на конференции разработчиков Microsoft в Лос-Анджелесе (штат Калифорния) в октябре этого года. "Это не готовый продукт, - предостерегает Селвасегарам. - Даже если он будет работать некоторое время, я думаю, что очень рискованно устанавливать его на домашний компьютер".

Глава Microsoft Билл Гейтс утверждает, что ОС Longhorn, выход которой в свет ожидается не ранее 2005 года, станет самым крупным софтверным проектом компании за последнее десятилетие. По заверениям представителей Microsoft, Longhorn будет отличаться принципиально новой файловой системой, тесной взаимосвязью с интернетом, повышенной безопасностью и устойчивостью работы.

Единые стандарты Linux

Компания SuSE заявила о планах по введению единых стандартов для интеграции и управления приложениями в среде open source.

Помочь реализации этих идей должна и Novell, которая недавно приобрела SuSE. Масштабы Novell, ее клиентская база и программное обеспечение Red Carpet, доставшееся ей вместе с покупкой компании-разработчика программ на основе открытых исходников Ximian, должны помочь осуществлению этих грандиозных планов, считает технический директор SuSE Юрген Гек.

Гек заявил, что для разработки Linux-приложений в промышленных масштабах необходимо упростить процедуры установки и управления программами. Ряд партнеров SuSE уже продвигают свои программы управления приложениями Linux. SuSE хочет, чтобы эти компании разработали общий стандарт, включающий АРI, которые могут использоваться мелкими разработчиками для интегрирования своих продуктов в эти управляющие приложения.

Президент SCO Group Дарл Макбрайд попытался помешать приобретению SuSE компанией Novell, заявив, что когда Novell продала SCO свои права на Unix System V, та обязалась не конкурировать с Unix. Макбрайд считает, что раз Linux является вариацией Unix, то объединенная Novell/SuSE автоматически становится конкурентом SCO. Юрген Гек на это ответил, что SCO, напротив, является партнером SuSE по UnitedLinux, иронично заметив, что чтобы стать конкурентом SuSE, SCO нужно начать производить хоть что-нибудь.

Источник: http://www.compulenta.ru/

***
Рекомендуем
Книга "Магия Твоих Текстов (1-ый том)"
 Эта книга - первая в серии книг по спецтехнологиям профессионального создания безупречных текстов с применением специальных техник гипноза. Мощный и глубокий стиль в сочетании с прекрасной подборкой приемов и методов гарантированно превратит вас в профессионала по созданию ЭФФЕКТИВНО РАБОТАЮЩИХ ГИПНОТЕКСТОВ буквально в считанные часы!
Книга содержит массу сведений исключительно прикладного характера и будет полезна всем, кто интересуется секретами и загадками психотехнологий – НЛП, Эриксониансокго гипноза, Вириа и их применением в качестве инструментов «власти» над клиентами, аудиторией, посетителями сайтов.
Материал книги не требует предварительного знакомства со спецтехнологиями.
Узнать подробнее о книге "Магия Твоих Текстов (1-ый том)"
***
Copyright © Internet Zone, info@izcity.com


ATI Radeon 9800 Pro. Обзор видеокарты Gigabyte RADEON 9800 PRO GV-R98P128D

Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

ATI Radeon 9800 Pro
Обзор видеокарты Gigabyte RADEON 9800 PRO GV-R98P128D

Автор: Артем Семенков

Рынок видеокарт переживает сейчас времена настоящих баталий: с одной стороны NVIDIA, недавний лидер рынка графических ускорителей, а с другой — ее главный конкурент — компания ATI. Последняя явно на подъеме и сдавать свои позиции не собирается. А недавно еще и анонсировала новое поколение чипов Radeon 9600 XT и Radeon 9800 XT, с выходом которых список ее партнеров пополнился таким брэндом, как ASUS. До нашего рынка Radeon 9600 XT и Radeon 9800 XT, а тем более реальные изделия от ASUS, не добрались, поэтому пока вашему вниманию представляем ATI Radeon 9800 Pro и обзор реального изделия, построенного на его базе — видеокарты Gigabyte RADEON 9800 PRO GV-R98P128D.

ATI Radeon 9800 Pro

Radeon 9800 Pro (кодовое название R350) — относительно новое (у нас новое, за рубежом — не совсем новое, так как вышел Radeon 9800 XT) DirectX 9 графическое ядро от ATI, призванное заменить Radeon 9700 Pro (кодовое название — R300).

Графический процессор Radeon 9800 Pro базируется на обновленном ядре Radeon 9700 Pro.

После прочтения вышенаписанного у читателей возникает понятный вопрос: что же революционного несет ATI Radeon 9800 Pro в сравнении со своим предшественником — Radeon 9700 Pro, или же это всего-навсего разогнанная версия 9700-го?

Для удобства представления различий приведем таблицу, в которой собраны тактико-технические характеристики ATI Radeon 9800 Pro и ATI Radeon 9700 Pro. Помимо этого, добавим к двум названным чипам главного конкурента 9800-го — NVIDIA GeForce FX 5900 Ultra.

ATI Radeon 9800 Pro, как видно из таблицы, имеет не очень много отличий от своего предшественника ATI Radeon 9700 Pro. Они заключаются лишь в частотах, которые у первого возросли до 380 МГц для графического ядра и 680 (DDR) МГц для памяти (у Radeon 9700 Pro — 325 МГц для графического ядра и 620 (DDR) МГц).

Главным отличием, конечно же, является поддержка Radeon'ом 9800 Pro фрагментарного потокового FIFO-буфера (Fragment-Stream FIFO buffer) (SmartShader 2.1) — новая технология, позволяющая запускать шейдеры бесконечной длины).

Что это даст? А даст это нам реальный прирост производительности:). Представим себе такую картину: скажем, играете вы в какую-нибудь современную компьютерную игру, оптимизированную под API Microsoft DirectX 9: сцена вовсю напичкана пиксельными и вершинными шейдерами, видеокарта обрабатывает сцену, и длина какого-нибудь участка кода этих самых шейдеров превышает максимальное значение. В таком случае видеопроцессор вынужден разбить код на несколько участков и сделать несколько проходов для обработки каждого из них, тем самым увеличив нагрузку на подсистему памяти, что, соответственно, приведет к падению производительности.

Но не стоит слишком обольщаться: значимое преимущество от фрагментарного потокового FIFO-буфера можно ощутить только в приложениях, использующих пиксельные программы версии 2.0.

"Плюсик" в названии технологии Hyper Z III+ означает оптимизацию Z-кэша: оптимизация под данные трафаретного типа, которые позволяют создавать реалистичные игры в современных компьютерных играх.

Новая — 2,1 — версия технологии SmoothVision использует оптимизированный контроллер памяти, что теоретически приведет к увеличению производительности в 4х и 6х режимах сглаживания, но лишь при разрешении 1024х768 и выше.

Также стоит отметить цветовую степень сжатия. У ATI Radeon 9800 Pro она составляет 6:1, тогда как у NVIDIA GeForce FX 5900 — 4:1.

Gigabyte RADEON 9800 PRO GV-R98P128D

Видеокарта имеет интерфейс AGP х2/x4/x8. Компоновка ее стандартна, что вполне объяснимо: разработчики не рискуют экспериментировать с дорогими видеокартами, построенными на старших моделях графических чипов, коей Gigabyte RADEON 9800 PRO GV-R98P128D и является. Да и, кроме того, разработать новый дизайн для дорогой платы — довольно накладное дело.

Кулер нестандартный — Gigabyte в своих продуктах использует собственные разработки, и Gigabyte RADEON 9800 PRO GV-R98P128D не стала исключением: графическое ядро ATI Radeon 9800 Pro прикрыто массивным алюминиевым радиатором с вентилятором, расположенным в центре.

Чипы памяти радиаторами не прикрыты.

Видеокарта несет на своем борту 128 мегабайт 2,8-наносекундной памяти, что соответствует частоте в 350 (700 DDR) МГц, но память работает на стандартной частоте — 340 (680 DDR) МГц. Память производства Samsung упакована в чипы BGA и имеет маркировку K4D26323RA-GC2A. Шина обмена с памятью составляет 256 бит.

Частота графического ядра стандартна — 380 МГц.

Карта имеет стандартный набор выходов: аналоговый, цифровой (DVI) и TV-OUT. TV-OUT реализован посредством самого чипа ATI Radeon 9800 Pro, так как в него уже интегрированы средства для реализации TV-OUT'а.

Видеокарта поставляется в коробке с двойной обложкой, развернув которую, можно прочитать об основных инновациях ATI Radeon 9800 Pro и непосредственно о продукте от Gigabyte, RADEON 9800 PRO GV-R98P128D.

В коробке, помимо самой видеокарты, находились:

  • руководство пользователя;
  • диск с драйверами;
  • переходник S-Video-to-RCA;
  • переходник DVI-to-d-Sud;
  • удлинители S-Video/RCA;
  • диск с драйверами и утилитами;
  • несколько дисков со старыми играми.

В целом можно сказать, что комплект поставки более чем удачен, особенно для продуктов ATI: обычно производители видеокарт, да, впрочем, и сама ATI, очень халатно относятся к этому вопросу.
На диске с драйверами обнаружилась довольно полезная утилитка-твикер Vtuner собственной Gigabyte'овской разработки, предназначенная для разгона видеокарты.

Overclocking, или разгон, по-нашему

Видеокарта разгонялась при помощи утилиты RivaTuner. Стабильность работы при разгоне проверялась с помощью бенчмарков GLMark и 3DMark 2001 SE, которые прокручивались три раза. Если появлялись искажения на мониторе, то частоту памяти понижали на несколько мегагерц. Если компьютер зависал, то частоту графического ядра понижали на несколько мегагерц. Если же все три раза бенчмарки прокручивались нормально, то разгон удался. Дополнительного охлаждения не применялось.

Видеокарта Gigabyte RADEON 9800 PRO GV-R98P128D разогналась до следующих частот: 430 МГц для графического ядра и 750 МГц для памяти.

Тестирование

Тестовые испытания проводились на тестовом стенде следующей конфигурации:
Материнская плата: FIC AD11 (AMD 761+ VIA 686B).
Процессор: AMD Athlon XP 2000+ (Tbred).
Память: 512 Мб PC2100 NCP DDR SDRAM CL 2.0.
Жесткий диск: Maxtor Fireball 3 30 Гб.
Видеокарты: Gigabyte RADEON 9800 PRO GV-R98P128D (ATI Radeon 9800 Pro) и NVIDIA GeForce FX 5900 Ultra.
CD-RW NEC 9300A.
Звуковая плата: ESS Alegro 1989.
Модем: Acorp M-56PIM.

На тестовом стенде были установлены операционная система Microsoft Windows XP с установленным Service Pack 1 и следующие тестовые программы и реальные игровые приложения:

  • драйвер для видеокарт ATI — Catalyst 3.8;

  • драйвер для видеокарт NVIDIA — Detonator;

  • MadOnion 3DMark2001 SE;

  • FutureMark 3DMark 2003;

  • Unreal Tournament 2003;

  • Serious Sam The Second Encounter (OpenGL);

  • Doom III (alfa-версия);

  • Splinter Cell (patch 1.12b);

  • Quake3 Arena;

  • Codecreatures;

  • Unreal II: The Awakening;

  • Return to Castle Wolfenstein (Multiplayer), Checkpoint;

  • Vulpine Glmark.

Условия тестирования

VSync отключался. Компрессия текстур отключалась непосредственно в игровых приложениях. Все тестовые программы и игровые приложения настраивались на максимальную детализацию, использовался 32-битный цвет.

Качество 2D

Этот параметр довольно спорный, и оценить его можно только субъективно, так как качество выводимого изображения зависит и от монитора, и от соединительного кабеля.
Качество видеокарты Giga-byte RADEON 9800 PRO GV-R98P128D в разрешениях 1280x1024x75 Гц, 1024x768x85 Гц можно охарактеризовать как хорошее.

Результаты тестирования

3DMark 2003

Последняя версия синтетического бенчмарка от FutureMark (бывшая MadOnion) — самый скандальный, если можно так выразиться, тест. Причина этой скандальности — в нечестной борьбе вендоров и оптимизации драйверов под этот бенчмарк. Хотя с последними драйверами они, похоже, исправились и убрали заточки, хотя кто их знает…

Разница в попугаях довольно незначительна, но давайте рассмотрим результаты тестирования подробнее.

Сцена GT1 — Wings of Fury не очень сложная: вершинные шейдеры версии 1.1, 32.000 полигонов, мультитекстурирование, точечные спрайты, что не такой уж большой труд для современных графических чипов. ATI Radeon 9800 Pro с незначительным отрывом лидирует.

Следующая сцена — GT2 — Battle of Proxycon — более сложная, а осложнена она пиксельными шейдерами версии 1.4 и большим количеством полигонов. Здесь видеокарты показывают почти одинаковые результаты, а расхождение в 0,2 fps вполне можно списать на погрешность тестирования.

GT3 — Troll's Lair — пиксельные шейдеры двух версий (1,1 и 1,4) и победа Radeon 9800 Pro. Также хотелось бы заострить внимание на том, что с повышением разрешения разница между графическими чипами уменьшается и в разрешении 1280х1024 составляет всего 4 fps, поэтому можем предположить, что в большем разрешении разницы не будет вообще.

GT4 — Mother Nature — вот они, пиксельные шейдеры 2.0 — то, что так отмечали в своих пресс-релизах и то, на чем так заостряли наше внимание вендоры. Разница между NVIDIA GeForce FX 5900 Ultra и ATI Radeon 9800 Pro составляет всего 1 fps в пользу последней.

Тесты на скорость заполнения. При сингл-текстурировании выигрывает ATI Radeon 9800 Pro, а при мультитекстурировании побеждает NVIDIA GeForce FX 5900 Ultra, что, в общем-то, предсказуемо, так как у первого количество текстур на текстурный блок составляет восемь, а у второго — шестнадцать.

С вершинными шейдерами программа справляется лучше у ATI Radeon 9800 Pro, а с пиксельными — у NVIDIA GeForce FX 5900 Ultra, но разрыв незначителен как в первом, так и во втором случае.

RagTroll — довольно интересная сцена: 16 троллей, прорисованных с использованием 5500 треугольников, прыгают с большой высоты и падают наземь.

Суицид какой-то массовый, ей богу:). Незначительная победа Radeon'a, и, опять же, при повышении разрешения разница между графическими чипами уменьшается.

Quake 3 Arena

Наш старичок, больше двух сотен fps и победа продукта компании NVIDIA с отрывом в 2 fps.

Return to Castle Wolfenstein

Эта игра построена на усовершенствованном движке Quake 3 Arena. Та же картина, что и в Quake 3 Arena, и те же 2 fps преимущества у GeForce FX 5900 Ultra.

Serious Sam 2 The Second Encounter (OpenGL)

Опять OpenGL-приложение, и опять — победа FX 5900 Ultra с отрывом в 4 fps.

Doom III Alfa Version

Комментировать результаты тестирования нет смысла, так как пока доступна лишь сырая альфа-версия Doom III. Результаты приводятся лишь для примерного представления будущих игр.

Unreal Tournament 2003

А теперь Direct3D-приложение и победа на стороне ATI. Ходят слухи, что под это игровое приложение тоже существует множество заточек, но верить слухам — неблагодарное дело, однако мы решили перестраховаться и привести результаты Unreal II: The Awakening.

Unreal II: The Awakening

Данное игровое приложение построено на модифицированном движке Unreal Tournament 2003. Результаты опять в пользу ATI, но посмотрите на разрыв между результатами ATI Radeon 9800 Pro и NVIDIA GeForce FX 5900 Ultra — он совсем незначителен, а в Unreal Tournament 2003 он довольно приличный.

Качество изображения

При включении антиалиасинга и анизотропной фильтрации картина та же: победа NVIDIA GeForce FX 5900 Ultra в OpenGL- и проигрыш в Di-rect3D-приложении.

Выводы

С выходом ATI Radeon 9800 Pro на рынке видеочипов наступил коренной перелом — компания ATI из догоняющего превратилась в полноправного конкурента.

Лидером ее, правда, назвать нельзя, так как картина здесь неоднозначна: с одной стороны, ATI Radeon 9800 Pro лучше справляется с обработкой вершинных шейдеров, сингл-текстурированием и Direct3D-приложениями, с другой — NVIDIA GeForce FX 5900 Ultra лучше проявляет себя в пиксельных шейдерах, мультитекстурировании и OpenGL-приложениях.

Но как в первом, так и во втором случае разница между результатами довольно незначительна и составляет в среднем 4-6 fps.

Gigabyte RADEON 9800 PRO GV-R98P128D — типичная видеокарта на ATI Radeon 9800 Pro — с грамотным охлаждением, неплохим разгонным потенциалом, а также хорошей комплектацией.

Конфигурация тестового стенда |  |  |
 | "Железо" | Особенности | Драйвер
Центральный процессор | FIC AD11 | Набор логики AMD 761+ VIA 686B |
Системная плата | AMD Athlon XP 2000+ | ядро Tbred |
Память | 512 MB PC2100 NCP DDR SDRAM | CL 2.0 |
Жёсткий диск | Maxtor Fireball 3 | 30 Гбайт, 7200 об/мин |
CD-RW | NEC 9300A | Скоростная формула 48x24x48 |
Видеокарта | Gigabyte RADEON 9800 PRO GV-R98P128D | ATI Radeon 9800 Pro | ATI Catalyst 3.8
Видеокарта | Albatron Gigi GeForce FX 5900EPV 128MB (разогнанная до частот NVIDIA GeForce FX 5900 Ultra); | NVIDIA GeForce FX 5900 Ultra | NVIDIA Detonator 52.16
Звуковая плата | ESS Alegro 1989 |  |
Модем | Acorp M-56PIM |  |

Технические характеристики |
Видеокарты |
№ | 1
Чип | ATI Radeon 9800 Pro
Карта | Gigabyte RADEON 9800 PRO GV-R98P128D
Производитель | Gigabyte
Модель | RADEON 9800 PRO GV-R98P128D
Память | Samsung K4D26323RA-GC2A
-нс | 2.8
Частоты | 380 МГц
 | 340 (680 (DDR)) МГц
Разгон | 430 Мгц
 | 375 (750 (DDR)) МГц
Драйверы | ATI Catalyst 3.8, NVIDIA Detonator 52.16
Графического чипа |
Технологический процесс | 0,15 мкм
Технология чипа | 256 бит
Кол-во транзисторов | 107 миллионов
Шина памяти | 256 бит DDR/DDRII
Пропускная способность памяти | 21,8 Гбайт/с
Скорость пиксельных программ | 3,04 гигапиксель/с
Скорость заполнения | 18,2 млрд. сэмплов/с
Режимы сглаживания | 2x, 4x, 6x
Скорость обработки треугольников/c | 380 млн.
Режим AGP | 1x/2x/4x/8x
Объём видеопамяти | 128/256 Мбайт
Частота памяти | 340 МГц (680 DDR)
Тип памяти | BGA 2,8 нс
Частота графического ядра | 380 МГц
Кол-во блоков вершинных программ | 4
Кол-во пиксельных конвейеров | 8
Кол-во текстурных блоков на конвейер | 1
Кол-во текстур на текстурный блок | 8
Версия DirectX | 9
Версия пиксельных программ | 2
Версия вершинных программ | 2
Режим сглаживания | Мультисэмплинг
Оптимизации | Hyper Z III+, SmartShader 2.1, SmoothVision 2.1
Число выходов на мониторы | 2
RAMDAC | 2 x 400 МГц
Число битов на канал цвета | 10

Результаты тестирования видеокарты |  |
Тестовые приложения | Radeon 9800 Pro | GeForce FX 5900 Ultra
3DMark 2003 |  |
1024x768x32 |  |
Scores | 5184 | 5113
GT1 - Wings of Fury, fps | 129.1 | 123.4
GT2 - Battle of Proxycon, fps | 37.8 | 37.3
GT3 - Troll's Lair, fps | 33.0 | 25.6
GT4 - Mother Nature, fps | 33.3 | 32.1
FillRate (Single Texturing), MTexels/s | 1803.4 | 1306.3
FillRate (Multi Texturing), MTexels/s | 2811.4 | 2913.5
Vertex Shader, fps | 18.3 | 15.3
Pixel Shader 2.0, fps | 48.3 | 51.2
RagTroll, fps | 24.0 | 21.4
1280x1024x32 |  |
Scores | 3942 | 3912
GT1 - Wings of Fury, fps | 113 | 107.1
GT2 - Battle of Proxycon, fps | 25.8 | 25.6
GT3 - Troll's Lair, fps | 23.5 | 19.5
GT4 - Mother Nature, fps | 27.3 | 26.3
FillRate (Single Texturing), MTexels/s | 1771.7 | 1386.5
FillRate (Multi Texturing), MTexels/s | 2773.0 | 2873.3
Vertex Shader, fps | 17.9 | 14.2
Pixel Shader 2.0, fps | 35.7 | 36.9
RagTroll, fps | 17.8 | 16.4
Игровые приложения |  |
1024x768x32 |  |
Quake3 Arena (OpenGL), Demo: 002, fps | 208.3 | 210.2
Return to Castle Wolfenstein (OpenGL), Demo: CheckPoint, fps | 85.1 | 87.2
Serious Sam 2 The Second Encounter (OpenGL), Demo: Value The Jaguar, fps | 77.1 | 81.1
Doom III Alfa Version (OpenGL), fps | 38.4 | 27.1
Unreal Tournament 2003 (Direct3D) Demo: antalus-flyby, fps | 133.7 | 124.1
Unreal II: The Awakening (Direct3D), fps | 63.42 | 61.1
1280x1024x32 |  |
Quake3 Arena (OpenGL), Demo: 002, fps | 198.4 | 200.3
Return to Castle Wolfenstein (OpenGL), Demo: CheckPoint, fps | 85.0 | 86.3
Serious Sam 2 The Second Encounter (OpenGL), Demo: Value The Jaguar, fps | 76.2 | 80.1
Doom III Alfa Version (OpenGL), fps | 25.6 | 15.3
Unreal Tournament 2003 (Direct3D) Demo: antalus-flyby, fps | 127.1 | 118.2
Unreal II: The Awakening (Direct3D), fps | 61.54 | 58.2
Качество изображения |  |
1024x768x32 |  |
Unreal Tournament 2003 (Direct3D) |  |
4X FSAA & 4X Aniso | 83.6 | 87.9
Return to Castle Wolfenstein (OpenGL) |  |
4X FSAA & 8X Aniso | 65.1 | 62.8

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

Диагностика винчестеров, или С чем едят S.M.A.R.T.?

Автор: Сергей Юшко aka Gedemin

Какая "железка" самая ценная в компьютере? Что вы боитесь потерять больше всего? Монитор? Согласен, дорого. Но, купив новый монитор, вы быстро забудете о потере. Процессор? И замена процессора совсем не фатальна. А вот выход из строя винчестера (спокойно, мы не об огнестрельном оружии говорим, а о девайсе, именуемом в простонародье "винт", "веник", а на буржуйском языке — HDD) влечет не только финансовые потери. Мы теряем гигабайты ценнейшей информации. Накопленные непосильным трудом огромные объемы софта и доков бесследно исчезают. Да и тщательно подобранные гигабайты музыки и видео терять не очень-то хочется… "А что же делать?" — спросите вы. Выход винчестера из строя многие считают вещью непредсказуемой. Но, оказывается, есть способы и технологии, способные вычислить хотя бы примерное время, когда ваше хранилище ценной информации уйдет в мир иной. Уже давно (учитывая темпы развития компьютерных технологий — давно) крупнейшие "винчестеропроизводители" придумали способ помочь нам.

Но об этом чуть попозже. Для начала сделаем небольшой экскурс в строение самого винчестера. Что же там напихано, в этой маленькой и довольно-таки тяжелой коробочке? Точнее, разбираться мы будем не со всеми железками, а рассмотрим в общих чертах сам диск, на котором и хранится информация.

Весь винчестер (точнее, диск) разбит на сектора. Какой-то конкретный адрес на диске можно задать либо через номер сектора, либо через номер дорожки, номер головки и номер сектора на данной дорожке. Номер сектора вычисляется по несложной формуле: номер_сектора = (номер_дорожки * число_головок * число_секторов_на_дорожке) + (номер_головки * число_секторов_на_дорожке) + (номер_сектора_на_дорожке — 1). Простая арифметика… Ссылочку на калькулятор подсказать:)? Секторы, в свою очередь, объединяются в кластеры. Описывать принципы деления для FAT16/32 я, пожалуй, не буду (понадобится — сами раскопаете документацию, ее превеликое множество). Скажу лишь, что объединение в кластеры понадобилось из-за неудержимого роста размеров винчестеров, когда таблица секторов FAT требовалась очень большая, а с ее хранением возникли проблемы.

Есть на диске места, запретные для простого смертного, куда Windows при всем вашем огромном желании записывать что-либо не станет. Почему? А потому, что знает, что, если испортить эти записи, то не жить больше "Окошкам". На нулевой дорожке расположен Master Boot Record. А хранится в этом секторе информация об активном разделе и его загрузочном секторе. В том же секторе находится и таблица разделов (Partition Table). В ней записана информация о разделах диска: загрузочный раздел или нет, адреса начала и конца раздела, размер раздела и т.п. Подробно останавливаться на разделах тоже не будем. Перейдем сразу к загрузочному сектору (Boot Sector). Загрузочный сектор есть в начале каждого логического диска. Он содержит в себе ссылку на загрузчик (должен же кто-то и Windows, ну, или что там у вас стоит, загрузить). Еще он хранит уйму полезной информации, как-то: версия операционной системы, тип файловой системы, число секторов в кластере (зависит от файловой системы), размер данного логического диска и другую важную информацию. После загрузочного сектора идет таблица размещения файлов или просто FAT (File Allocation Table). Каждый элемент этой таблицы соответствует одному кластеру. Служит она для поиска файлов на диске. Поскольку эта таблица имеет большую важность, то записана она сразу в двух идентичных экземплярах, идущих один за другим. Далее следует корневой каталог (Root Directory). Это список директорий и файлов. Здесь хранятся их параметры: имя файла, расширение, дата создания, размер, атрибуты и номер первого кластера, по которому и ищется файл в FAT. И только после всех этих разделов идет область файлов. Именно здесь и находится информация, заботясь о которой, мы, собственно, и решили прибегнуть к помощи S.M.A.R.T.

Теперь о том, почему же диск портится, а, следовательно, и жизненно важная (или не очень:)) информация теряется. Про то, что винчестер ронять с большой высоты не следует, надеюсь, уже все знают. Вообще-то его и с небольшой высоты кидать не стоит… Даже если ваш HDD достойно выдержит удар, произойдет разбалансировка дисков винчестера, то есть их смещение. И это значительно приблизит кончину жесткого диска. Хотя еще некоторое время он прослужит вам верой и правдой.

В современных винчестерах, имеющих скорость 7200 об/мин (про 10.000 об/мин я пока промолчу ввиду их малой распространенности), порой актуальна проблема высокой температуры. Вы глубоко заблуждаетесь, если считаете температуру в 60°C нормальной для работы HDD. Если проблема высокой температуры у вас существует, поставьте на винчестер вентилятор. И ни в коем случае не ставьте HDD рядом с CD-RW — это чревато дополнительным нагревом.

А когда винчестер работает, малейшие удары он воспринимает гораздо чувствительнее. Вы знаете размеры головки винчестера? Они исчисляются в миллиметрах и долях миллиметра! А высота считывающей головки над диском — вообще нанометры (для тех, кто в танке: 1.000.000.000 нанометров = 1 метр)! Потрясает? Конечно. А теперь представьте, к чему приводит малейший удар по системному блоку во время работы винчестера! Еще могу сообщить, что расстояние между дорожками на диске менее одного микрометра. Какая же точность наводки считывающей головки требуется! Все удары ведут к раскалибровке точного и отлаженного механизма. И даже научный гений конструкторов HDD и многочисленные защитные механизмы не способны спасти диск от постепенного накапливания bad-блоков. Почему же при тестировании винчестера различными утилитами bad'ов почти не обнаруживается? А тут нам помогает такая штука, как переадресация. Хитрые господа "винчестеропаятели" выделили специальный объем памяти на диске, куда мы изначально ничего не можем записать, служащий для переадресации. И создали четыре (как минимум) дефект-листа: Primary list (P-list), Grown list (G-list), лист сервометок и временный лист. Дело в том, что даже на только что изготовленном заводском диске есть bad'ы. Изготовить идеальный диск невозможно. Прямо на заводе с помощью специальной аппаратуры диски тестируют, непригодные для использования секторы отмечают как bad'ы и помещают в P-list. Затем происходит переадресация этих секторов в зарезервированную специально для этого память, о которой я только что упомянул. Вот и получается, что диск попадает к нам без единого bad'а (если, конечно, его на фирме не пристукнут маленько:)). Когда на диск производится запись информации, каждый кластер тестируется на пригодность. Если записать-считать информацию в кластер не удается, он помечается как подозреваемый bad и помещается во временный дефект-лист. Если повторная попытка его записи-считывания опять заканчивается неудачей, он уже отмечается как bad, записывается в G-list и переадресуется в резервную область. Лист сервометок служит для записи дефектных сервометок (сервометки были созданы для лучшего позиционирования головок винчестера, но и тут могут появляться ошибки).

Небольшой экскурс в мир организации хранения информации на диске закончен. Пора бы уж и приступить к основной нашей теме. Что же такое S.M.A.R.T., кто, когда и зачем его придумал? И почему стоит о нем знать? И не только знать, но и пользоваться. Итак…

S.M.A.R.T. (Self-Monitoring, Analysis and Reporting Technology) — дословно "технология самодиагностики, анализа и отчета". Немножко истории… Идея самой технологии S.M.A.R.T. принадлежит таким гигантам, как Seagate, Western Digital и Quantum (инициатором была именно она). Они-то и разработали S.M.A.R.T.1 в 1993 году. Сколько версий создано на сегодняшний день, я даже и не знаю… В 1995 году к этим компаниям присоединились еще Maxtor, Samsung и IBM (некоторые источники основателем S.M.A.R.T. называют почему-то именно эту фирму — возможно, потому, что момент начала бурного развития S.M.A.R.T. совпал с моментом, когда IBM поддержала эту технологию). Чуть попозже к ним примкнула и Hitachi.

По сути дела, S.M.A.R.T. — это такая микропрограмма, которая находится в контроллере диска. Она контролирует многие параметры работы и состояния винчестера. Теперь введем такое понятие, как атрибуты. Атрибуты — это специальные, обычно численные, характеристики для описания параметров. А параметров, по которым S.M.A.R.T. тестирует винчестер, очень много. Причем набор может быть различным для разных производителей HDD. Каждая фирма сама определяет, какие параметры являются наиболее критичными для ее продукции. Но основной набор идентичен для всех. Я приведу параметры, найденные мной в различной документации.

  • Raw Read Error Rate — частота появления ошибок при чтении данных с поверхности диска по вине аппаратной части накопителя.

  • Throughput Performance — средняя производительность (пропускная способность) диска. Уменьшение значения этого атрибута с большой вероятностью указывает на проблемы в накопителе.

  • Spin Up Time — время раскрутки пакета дисков. Среднее время раскрутки шпинделя диска от 0 RPM до рабочей скорости. Может быть указано в миллисекундах или секундах (зависит от производителя винчестера и программы, при помощи которой вы просматриваете атрибуты).

  • Start/Stop Count — количество циклов запуск/останов шпинделя.

  • Reallocated Sectors Count — количество переназначенных секторов (о переназначении мы уже говорили, но при большом количестве переназначенных секторов скорость работы винчестера может довольно ощутимо снизиться, так как считывающим головкам постоянно приходится переходить с дорожки на дорожку).

  • Seek Error Rate — частота появления ошибок позиционирования головок. В случае сбоя в механической системе позиционирования, повреждения сервометок, сильного термического расширения дисков и т.п. возникают ошибки позиционирования. Чем их больше, тем хуже состояние механики и/или поверхности жесткого диска.

  • Seek Time Performance — средняя производительность операций позиционирования головок. Данный параметр показывает среднюю скорость позиционирования привода головок на указанный сектор. Снижение значения этого атрибута говорит о неполадках в механике привода.

  • Power On Hours — количество отработанных часов во включенном состоянии. Снижение значения атрибута до критического уровня указывает на выработку диском ресурса (MTBF — Mean Time Between Failures). На практике даже падение этого атрибута до нулевого значения не всегда указывает на реальное исчерпывание ресурса, и накопитель может продолжать нормально функционировать.

  • Spin Retry Count — количество повторов попыток старта шпинделя диска. Данный атрибут фиксирует общее количество попыток раскрутки шпинделя и его выхода на рабочую скорость при условии, что первая попытка была неудачной.

  • Recalibration Retries — количество повторов попыток рекалибровки накопителя. Данный атрибут фиксирует общее количество попыток сброса состояния накопителя и установки головок на нулевую дорожку при условии, что первая попытка была неудачной.

  • Device Power Cycle Count (Drive Power Cycle Count) — количество полных циклов запуска/останова жесткого диска.

  • Soft Read Error Rate — частота появления программных ошибок при чтении данных с диска. Показывает частоту появления ошибок при операциях чтения с поверхности диска по вине программного обеспечения, а не аппаратной части накопителя.

  • Load/Unload Cycle Count — количество циклов вывода головок в специальную парковочную зону/в рабочее положение.

  • Drive Temperature — температура (а вы что думали?:)). Теоретически должна отображаться в градусах Цельсия, но у меня выдало такую цифру, что даже засомневался, а не Реамюры ли это.

  • Reallocation Event Count — количество операций переназначения (ремаппинга). Поле raw value этого атрибута показывает общее количество попыток переназначения сбойных секторов в резервную область, предпринятых накопителем. При этом учитываются как успешные, так и неудачные операции.

  • Current Pending Sector Count — текущее количество нестабильных секторов. Поле raw value этого атрибута показывает общее количество секторов, которые накопитель в данный момент считает претендентами на переназначение в резервную область (remap). Если в дальнейшем какой-то из этих секторов будет прочитан успешно, он исключается из списка претендентов. Если же чтение сектора будет сопровождаться ошибками, то накопитель попытается восстановить данные и перенести их в резервную область, а сам сектор пометить как переназначенный (remapped). Постоянно ненулевое значение raw value этого атрибута говорит о низком качестве (отдельной зоны) поверхности диска.

  • Uncorrectable Sector Count — количество нескорректированных ошибок. Показывает общее количество ошибок, возникших при чтении/записи сектора, которые не удалось скорректировать. Рост значения в поле raw value этого атрибута указывает на явные дефекты поверхности и/или проблемы в работе механики накопителя.

  • UltraDMA CRC Error Count — общее количество ошибок при передаче данных в режиме UltraDMA. Поле raw value содержит количество ошибок, возникших в режиме передачи данных UltraDMA в контрольной сумме.

  • Write Error Rate (Multi Zone Error Rate) — частота появления ошибок при записи данных.

  • Disk Shift — сдвиг пакета дисков относительно оси шпинделя (часто возникает при падении винчестера).

  • G-Sense Error Rate — частота появления ошибок в результате ударных нагрузок. Данный атрибут хранит показания ударочувствительного сенсора — общее количество ошибок, возникших в результате полученных накопителем внешних ударных нагрузок (при падении, неправильной установке и т.п.).

  • Loaded Hours — нагрузка на привод головок, вызванная общей наработкой часов накопителем. Учитывается только период, в течение которого головки находились в рабочем положении.

  • Load/Unload Retry Count — нагрузка на привод головок, вызванная многочисленными повторениями операций чтения, записи, позиционирования головок и т.п. Учитывается только период, в течение которого головки находились в рабочем положении.

  • Load Friction — нагрузка на привод головок, вызванная трением в механических частях накопителя.

  • Load/Unload Cycle Count — общее количество циклов нагрузки на привод головок.

  • Load-in Time — общее время нагрузки на привод головок. Предположительно данный атрибут показывает общее время работы накопителя под нагрузкой при условии, что головки находятся в рабочем состоянии (вне парковочной зоны).

  • Torque Amplification Count — количество усилий вращающего момента привода.

  • Power Off Retract Count — количество зафиксированных повторов включения/выключения питания накопителя.

  • GMR Head Amplitude — амплитуда дрожания головок (GMR-head) в рабочем состоянии.

Все эти параметры (ну, или хотя бы часть) S.M.A.R.T. периодически тестирует и записывает. Но до записей нужно еще добраться. Для этого существует множество программ, которые умеют это делать. Они в достаточно удобной форме выводят текущие значения параметров (Value) и их предельные допустимые значения ("обзываемые" английским словом Threshold). Величину Threshold каждая фирма определяет самостоятельно исходя из особенностей строения и работы своих винчестеров. Каждому параметру изначально присваивается значение Value обычно от 100 и выше. Затем по мере ухудшения параметра его значение уменьшается. При падении величины Value до значения Threshold винчестер теоретически должен выйти из строя. Но даже в такой печальной ситуации ваш хранитель информации может успешно продолжать работать. Однако при этом огромен риск в любую секунду потерять все накопленное. Некоторые параметры отмечены значком "*". Это значит, что они являются наиболее критическими для нормальной работы HDD. И в случае падения значения этого параметра ниже критического значения наиболее вероятен выход винчестера из строя. Каждый из параметров, в свою очередь, имеет свой тип:

— On-line collection (OC) — означает, что значение данного атрибута считается во время on-line (или on-line и off-line) тестов, а не только при off-line-тесте.
— Pre-failure (PF) — поле threshold содержит минимально допустимое значение, ниже которого вероятность поломки винчестера становится очень высокой.
— Performance related (PR) — означает, что значение атрибута зависит от производительности накопителя по отдельным показателям.
— Events count (EC) — атрибут является счетчиком событий.
— Error rate (ER) — атрибут является относительной частотой ошибок по данному параметру.
— Self-preserve (SP) — значение атрибута обновляется и сохраняется автоматически.

Тесты могут выполняться в двух режимах: автономном (off-line) и монопольном (on-line). Во время автономного тестирования винчестер сообщает об успешном окончании теста еще до его завершения. Затем происходит сам процесс тестирования, причем во время тестирования возможно выполнение других команд. То есть тестирование происходит в фоновом режиме. Во время монопольного режима тестирования выполнение других команд невозможно. Попытка исполнить другую команду приведет к прерыванию теста.

В конце статьи хочу еще упомянуть пару программок для получения данных S.M.A.R.T. Есть такая хорошая программка Smartudm. У нее есть одновременно и плюс, и недостаток — она не идет под Windows NT/XP, а требует старый добрый DOS. С одной стороны, это причиняет некоторые неудобства, но зато никакая "умная" Винда не мешает ей работать (так надежнее). Я просто записал ее на загрузочную дискетку и периодически при загрузке тестирую с ее помощью состояние своего винчестера. Smartudm выводит следующие данные: имя атрибута (Attribute), его номер (ID), значение (Value), критическое значение (Threshold), самое низкое значение за все время тестирования (Worst), текущее значение в шестнадцатеричной форме (Raw), тип атрибута (Type). А еще она выводит такую важную величину, как T.E.C. (Threshold Exceed Condition) — предположительное время снижения какого-либо параметра до критического уровня, то есть примерное время выхода винчестера из строя. Это не обязательно полный отказ работать — может быть и просто снижение производительности. К тому же, обычно винчестеры продолжают неплохо справляться со своей задачей, даже выработав установленный производителем ресурс. Но все же приближение T.E.C. — хороший повод призадуматься о резервном копировании ценной информации.

Ну, а если вы не любите DOS, то выход и здесь найдется. Для вас создана программа SIGuardian (http://www.siguar-dian.com/). Она тихо-мирно висит в трее и тестирует винчестер через заданный вами интервал времени. В ней можно также просмотреть информацию о винчестере, значения параметров, все тот же ненавистный T.E.C. Но есть здесь и такие интересные кнопочки, как "Имитация T.E.C." и "Имитация изменения атрибута". Служат они для имитации программой критических ситуаций. Но никаких серьезных последствий в себе не несут. Можете смело запускать (автор статьи не несет никакой ответственности за какой-либо вред, причиненный вашему компьютеру описанными в статье программами, а также кривыми руками пользователей:)). Это всего лишь имитация. Правда, попавшая ко мне версия SIGuardian — платная. Поэтому некоторые функции были недоступны. А вообще лучше всего залезть на официальный сайт производителя вашего винчестера. Обычно там вылаживаются S.M.A.R.T.-программы для тестирования винчестера, написанные с учетом особенностей именно этой марки HDD. Все-таки "родные" программы — надежнее.

Заранее хочу предупредить: после первого тестирования программа T.E.C. вам не выдаст, а вот после второго может сообщить очень близкую дату (ближайший месяц, неделю, день). Не пугайтесь. Через несколько дней программа накопит достаточно данных, и, скорее всего, дата будет существенно перенесена в будущее. С каждым тестом T.E.C. будет пересчитываться и уточняться.

На некоторых материнских платах в BIOS есть пункт, в котором упоминается S.M.A.R.T. Советую напротив него поставить enable.

Надеюсь, я вас убедил, что использовать преимущества технологии S.M.A.R.T. очень полезно. Возможно, это поможет вам спасти горы нужной и ценной информации. А еще S.M.A.R.T. логично использовать при покупке б.у. винчестера. Эта технология легко поможет определить действительное состояние HDD: состояние самого диска (количество переназначенных секторов), время эксплуатации винчестера, существующие проблемы и т.д. Но не забывайте, что S.M.A.R.T. не предупредит вас о порче винчестера при ударах во время переноски и других внештатных ситуациях. Так что резервное копирование информации не теряет своей актуальности.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>


Идеальная матрица

Автор: Александр Филонов

Чем отличается цифровой фотоаппарат от пленочного? Сущей мелочью: способом фиксирования света, прошедшего через объектив. Все остальное — процессоры, шины, устройства накопления и т. п. — лишь дополнительные причиндалы, идущие в комплекте с матрицей, воспринимающей этот самый свет. Что касается автоматики фокусировки и экспозиции, так она есть и в традиционных камерах, так что, по сути, все сводится к одним лишь матрицам, заменяющим собой пленку.

Для начала разберем принципиальные отличия пленки от некой гипотетической матрицы1. Отличие главное: светочувствительные элементы пленки (зерна галоидного серебра) по природе своей стохастичны — как их размеры и форма, так и расположение в эмульсии подчиняются закону нормального распределения, а все элементы матрицы расположены в виде регулярной решетки, причем их размер и форма четко фиксированы. Отличие менее принципиальное: элементом, образующим изображение в цветной пленке, является «облачко» красителя, конденсирующегося при обработке вокруг зерна металлического серебра. Естественно, контуры «облачка» размыты, а границы пиксела цифрового изображения обозначены четко. Остальные отличия относятся не ко всем типам матриц, о чем будет сказано ниже.

Поскольку в дальнейшем мы будем часто прибегать к «пленочным аналогиям», рекомендую ознакомиться с «устройством» современной пленки, описанным во врезке.

Разрешение

Разрешение зависит от количества точек изображения. Чем выше чувствительность пленки, тем ниже ее разрешение, и наоборот. У матриц все обстоит иначе: размер пиксела фиксирован, и чувствительность матрицы определяется чувствительностью пиксела. Теоретически она ограничена одним фотоном, но практически при очень слабом сигнале флюктуационные шумы «забивают» полезный сигнал.

Есть и еще один фактор, препятствующий повышению разрешения матриц без увеличения их геометрических размеров, — дифракция. Если пиксел будет сравним с длиной волны улавливаемого света, неизбежны дифракционные эффекты, так что размер пиксела опять-таки ограничен снизу длиной волны. Дело усугубляется тем, что матрицы чувствительны к инфракрасной составляющей спектра (в чем легко убедиться, направив в объектив светодиод ПДУ телевизора), имеющей значительную (в рамках видимого спектра) длину волны, а галоидное серебро без специальной обработки не видит ее в упор.

Далее, теоретическая чувствительность может быть достигнута лишь при охлаждении матрицы до абсолютного нуля, что практически недостижимо, поэтому реальная чувствительность сенсоров ограничена снизу уровнем тепловых шумов, а сверху — уровнем насыщения, когда дополнительная экспозиция уже не усиливает сигнал (что, полагаю, очевидно, и в комментариях не нуждается). Тут, надо заметить, принципиальную роль играет тип самих датчиков: ПЗС (он же CCD) или КМОП (CMOS).

Тип датчика

У обеих систем есть и достоинства, и недостатки. Принципиально датчики с потоково-зарядной связью (ПЗС) отличаются от комплементарных пар тем, что под воздействием света теряют заряд, а КМОП-датчики, наоборот, приобретают. Любопытно, что, поскольку вторая схема предусматривает возможность перенасыщения, при дальнейшей экспозиции возникает обратный эффект: КМОП-матрица начинает терять заряд, что ведет к эффекту истинной соляризации (на снимке попавшее в кадр солнце может оказаться темно-фиолетовым или даже черным), что роднит КМОП-матрицы с пленкой2.

Foveon X3: трехслойная матрица, каждый пиксел которой способен воспринимать три цветовые составляющие.

При этом спектральные характеристики ПЗС-матриц несколько лучше, что, казалось бы, дает им преимущество перед КМОП-сенсорами, но не тут-то было: компания Canon на очередном витке развития цифровых технологий обратилась к технологии КМОП, как более перспективной. Остальные производители профессиональной фототехники пока относятся к этому начинанию с осторожностью, и кто окажется дальновиднее, пока неясно, но Canon сделала чрезвычайно сильный ход, выбросив на рынок зеркальную камеру 300D с КМОП-матрицей по демпинговым ценам3.

Битый (и битный) цвет

Еще одно принципиальное отличие цифры от пленки: матрица (за одной оговоркой, имя которой Foveon) не видит цвета пиксела, воспринимая лишь интенсивность упавшего света, вследствие чего каждый пиксел изображения должен состоять из группы пикселов разных цветов. Цвет подпиксела при этом определяется прикрывающим его светофильтром. Как легко догадаться, при расположении пикселов в виде прямоугольника цвета приходится разбивать не на триады, как в основной цветовой схеме RGB (красный-зеленый-синий), а на тетрады. Чаще всего приоритет отдается зеленому цвету, и наиболее активным в схеме расположения светофильтров выступает зеленый — GRGB — как самый распространенный и олицетворяющий среднюю часть спектра, где человеческий глаз имеет наибольшую чувствительность. Впрочем, среди отклонений от нормы, кроме дальтонизма, как недавно выяснилось, существует тетрахроматизм, когда на глазном дне присутствуют колбочки, чувствительные не к трем, а к четырем цветам4, дополнительным среди которых выступает изумрудно-зеленый. Видимо, именно это и подвигло компанию Sony на создание матрицы с четырьмя разными фильтрами, из которых дополнительным выступает как раз изумрудно-зеленый. Насколько такой подход оправдан, покажет только практика.

Из прочих «светофильтровых» отклонений от стандарта наиболее заметным являются матрицы Foveon X3, где используется квантовый эффект: свет с разной длиной волны поглощается на разной глубине полупроводника. Таким образом, по цветовой схеме эта матрица наиболее близка к пленке: каждая точка изображения выступает не группой расположенных рядом точек, а одним «бутербродом» разноцветных пикселов. Подобная схема устраняет цветовые артефакты, возникающие из-за «размазывания» одной точки по группе из четырех разноцветных пикселов, что можно отождествить с увеличением разрешения в три раза.

Единственный элемент пленки, отсутствующий во всех вариантах, — это противоореольный подслой, нужда в котором отпадает потому, что вся энергия света поглощается кристаллом и паразитные отражения невозможны по определению.

Компоновка пикселов

SuperCCD SR Хотя устройства отображения цифровых картинок «понимают» лишь один формат — в виде прямоугольной матрицы, — устройства считывания информации могут воспринимать ее по-разному, перекладывая ответственность за прямоугольную компоновку на процессор.

В идеале следовало бы применить гексагональное расположение подпикселов, поскольку оно обеспечивает наибольшую плотность компоновки, но на нынешнем уровне развития технологий такая компоновка представляется слишком сложной, требуя считывания информации не по двум координатам (вертикаль и горизонталь), а по трем (условно: горизонталь, +60 градусов, –60 градусов) и куда более сложной интерпретации данных. Вероятно, со временем эту трудность преодолеют, пока же компания Fujifilm5 нашла приемлемый паллиатив, названный матрицами SuperCCD (как легко догадаться, на базе технологии CCD), расположив восьмиугольные пикселы в виде ромба, что обеспечило более удобное (хотя и не более быстрое) считывание информации. Интерполируя полученные данные, можно теоретически получить разрешение в 1,4–1,76 раз выше, чем у прямоугольной матрицы (то ли корень из 2, то ли корень из 3 — надо бы проделать геометрические выкладки, да все как-то лень).

А раз уж производством столь диковинных матриц может заниматься лишь компания, их породившая, на достигнутом она не остановилась, попытавшись еще больше уподобить их обычной пленке.

Размер зерна и чувствительность

В начале уходящего года Fujifilm объявила о создании матриц SuperCCD четвертого поколения. Правда, в отличие от предыдущих поколений, нынешнее породило два подвида: HR и SR. И то и другое решения основываются на элементарном удвоении каждого пиксела и суммировании сигналов, от них поступающих. Водораздел проходит по геометрическим размерам пикселов. В матрицах с индексом HR — оба пиксела одного и того же размера, что обеспечивает более высокую чувствительность. Куда интереснее решение SR, где один пиксел вчетверо меньше другого, за счет чего достигается высокая чувствительность в тенях (большой, или Н-пиксел) и низкая — в светах (малый, или S-пиксел). Благодаря этому динамический диапазон матрицы увеличивается в четыре раза, фактически соперничая с пленкой (заметим, достигающей такого результата за счет того же решения — сочетания больших [высокочувствительных] и малых [низкочувствительных] зерен галоидного серебра).

В стандартной мозаичной матрице фотосенсор может измерить только одну цветовую составляющую.

Физические пределы

Вследствие меньших физических размеров матриц объективы цифровых камер получаются меньше и легче, чем у пленочных, однако конструктора здесь подстерегают свои подводные камни: чем меньше размер линзы, тем труднее сделать ее качественной (тут есть свои хитрые ходы — к примеру, жидкостные линзы, но это отдельный разговор) и тем меньше отдельный пиксел! А когда размер пиксела сравним с длиной волны, как уже упоминалось, неизбежны дифракционные и интерференционные эффекты… Так что микроминиатюризация совершенно четко ограничена снизу длиной волны около 1000 нм (из-за чувствительности сенсоров к инфракрасному свету). И дальнейшее повышение качества возможно только за счет увеличения матрицы при сохранении геометрических размеров отдельного пиксела.

Попытка прорицания

Обобщив вышесказанное, можно нарисовать образ идеальной матрицы, устраняющей все недостатки и аккумулирующей все достоинства существующих и несуществующих (пока), но теоретически возможных матриц. Ей должна быть присуща гексагональная структура, причем каждый пиксел должен быть представлен двумя-тремя подпикселами разного размера (и, очевидно, чувствительности), а каждый пиксел должен представлять собой трех-четырехслойный «бутерброд» сообразно разным длинам волн. Можно дробить и мельче, пока не будет достигнут порог восприятия человеческого глаза. Вот и получится нечто вроде Foveon UltraSuperCCD x3. Только производители должны сперва договориться о перекрестном лицензировании технологий, а такие вопросы, увы, решаются куда медленнее, чем технические проблемы.

Шесть слоев с хвостиком

Для простоты допустим, что зерно галоидного серебра представляет собой эллипсоид, большая ось которого параллельна подложке. Сразу отметим, что чувствительность пленки зависит от размера зерна: чем оно больше, тем выше его чувствительность. В общем случае пленка представляет собой семислойный «бутерброд», состоящий из трех цветных слоев, отождествляемых с основными цветами спектра по субстрактивной схеме, «прошитых» в желатиновой основе эмульсии, и противоореольного подслоя, отделяющего желатин от подложки с одной-единственной целью: устранить паразитное отражение света от подложки, порождающее размытое световое пятнышко вокруг каждой точки изображения. «Но слоев только четыре! — скажете вы. — А где же еще три?» Совершенно верно. Еще три появляются за счет того, что каждый цветной слой в общем случае состоит из двух подслоев: высоко- и низкочувствительного (большие и малые зерна соответственно) — с целью расширения динамического диапазона пленки. Слои расположены один под другим в следующем порядке (начиная от поверхности эмульсии): красный, зеленый, синий — прежде всего потому, что, отличаясь энергией, лучи света поглощаются и рассеиваются в эмульсии с разной скоростью (правда, в дело вмешивается еще и дифракция, но ею для простоты пренебрежем).

1 Гипотетической — потому что матрицы весьма разнообразны, что вносит некоторый разнобой, но на базовом уровне их можно считать одинаковыми.
2 Хотя на пленке истинная соляризация наблюдается крайне редко благодаря большему динамическому диапазону, мне она несколько раз встречалась. Ни в коем случае не путайте с псевдосоляризацией — подробности о ней можно найти в учебниках по фотопечати.
3 См. «Огород Козловского» в этом номере.
4 Эта патология присуща только женщинам. В целях политкорректности (ПК), столь популярной за бугром, следует отметить, что дальтонизмом страдают только мужчины, и причиной тому служит не половая сегрегация, а Y-хромосома, не ведающая о демократии.
5 Следует читать Фудзифильм. Компания названа в честь знаменитого японского вулкана, а слово «Фуджи» — лишь вульгарная двойная транслитерация — с японского на английский, а с английского на русский.
6 По утверждениям производителя — в два раза, но практическая проверка показывает результат лишь около 1,5 раза. — А.Ф. Как владелец камеры на Ultra CCD 3, могу сказать, что частенько интерполяцию лучше отключать. — В.Г.

Источник: http://www.computerra.ru/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
 См. подробнее: http://www.izcity.com/ebay/


Мастерство удивлять. Компактный флэш-накопитель Gembird 1 Гб USB 2.0

Ионизаторы воздуха
Люди, долго живущие или работающие в помещениях с кондиционерами, болеют чаще, потому что в кондиционированном воздухе отсутствуют ионы обеих полярностей. Здесь поможет только ионизатор воздуха.
Подробнее >>
***

Мастерство удивлять
Компактный флэш-накопитель Gembird 1 Гб USB 2.0

Автор: Ka

Gembird 1 Гб USB 2.0

Вы не пугайтесь, девушка я нормальная, даже психологически выдержанная. Просто случилось со мной на днях эмоциональное потрясение, которое и побудило совершить такой безрассудный поступок, как написание данной статьи. А случаи, когда мне приходилось так сильно удивляться, можно пересчитать по пальцам. Первый произошел, когда моя мама отказалась выйти замуж за самого настоящего миллионера.

Второй случился через несколько лет, когда я жила в Варшаве и познакомилась с девушкой, которая в свои девятнадцать спокойно водила машину, причем так, что никто из водителей мужского пола не пытался ее подрезать, - не догоняли. Дальше больше - вернувшись в Москву, я обнаружила, что девочки открыто встречаются с девочками, а мальчики - с мальчиками, и все при этом счастливы. Шоком назвать это нельзя, но слегка потрясло.

С тех пор я думала, что моей психике уже ничего не грозит. Но если бы на днях вы зашли в редакцию, то увидели бы заливисто смеющуюся девушку (метр на коньках в прыжке), которая держит в руках серебряный свисток и, захлебываясь слюной, верещит: "Один гигабайт! Один! Совсем один!". Сжимая в кулачке флэшку с объемом памяти 1/40 моего ноутбука, я не могла не восхищаться парадоксальностью человеческого мышления - чем меньше девайс, тем больше информации в него залезает.

Счастьем своим хотелось поделиться с каждым. Но жители редакции не захотели разделять мой оптимизм, и среднестатистический разговор длился ровно 5 секунд.

Например, с менеджером тестовой лаборатории у нас произошел такой диалог:
- Вано, смотри какая штука! Целый гигабайт!
- Еще не потеряли, странно…

Вот красавцы! Нельзя же быть такими нудными. Мы, люди, очень быстро разучиваемся ценить те достижения, к которым когда-то так долго стремились. Подумать только - гигабайт, целый гигабайт информации может поместиться в брелок стоимостью двести с небольшим уравновешенных евнухов.

Причем устройство-то, что называется, "лизнул-выпил-закусил" - никаких тебе драйверов не надо, если, конечно, вы не из тех, которые до сих пор сидят на 98-х виндах. Также прилагается замечательный шнурок на шею, и будь он у Черешнева, не было бы таких стенаний в статье под названием "Как седеют редакторы" (Upgrade # 117). Кроме всего прочего, сбоку флэшки находится переключатель защиты от записи. Но это стандартная фишка.

Подумать только, целый гигабайт - хоть обзаписывайся. Чем я и занялась. Но прежде чем залить на флэшку любимейший фильм, захотелось узнать насколько все-таки быстр этот F-Drive. По показаниям HD Tach 2.61 по интерфейсу USB 1.1 флэшка, естественно, ничем не выделилась - максимальная скорость чтения составила 889 кб/с, записи - 865 кб/с. По USB 2.0 все забегало куда быстрее - 4,9 Мб/с при чтении с диска, 3,9 - при записи. Скорость была подтверждена и в реальных задачах - фильм весом 688 Мб записался за 2 мин 53 сек, а прочитался - за 2 мин 22 сек, то есть все честно.
Но когда я взглянула на графу "время доступа", флэшка удивила меня во второй раз - 83 мс! Это же слишком много!

Впрочем, и этому нашлось объяснение. Как вы помните, в статье "Где взять хороший бокс" (Upgrade # 117), посвященной тестированию Firewire и USB 2.0 контроллеров для жестких дисков, в число участников попал чип PL-0257 (производства Profilic), который оказался лучшим из ATA-USB-чипов. Так вот, в нашу флэшку также поставили контроллер от Profilic, однако другой маркировки (Profilic PL-2551).

Судя по информации на сайте разработчиков, этот чип сделали сверх-универсальным - на нем можно хоть космическую станцию распаять, а, как мы все знаем на примере комби-приводов DVD / CD-RW, универсализация - это обязательное ухудшение скоростных характеристик. Вот вам и объяснение.

Наверное, идеальных флэшек просто не бывает. И наш F-Drive, при своей очень привлекательной цене и довольно высоких линейных скоростях, также имеет один недостаток - подтормаживает при записи большого количества мелких файлов. Впрочем, таскать на F-Drive фильмы и коллекцию любимой музыки - самое оно.

Характеристики

Модель
Gembird F-Drive
Цена
$260
Материал корпуса
пластик
Цвет корпуса
cеребристый
Интерфейс
USB 2.0
Объем
1 Гб
Скорость чтения
USB 1.1 - 910 кб/с
USB 2.0 - 4300 кб/с
Скорость записи
USB 1.1 - 750 кб/с
USB 2.0 - 1000 кб/с
Габариты
92 x 28 x 15 мм
Вес
20 г
Комплектация
компакт-диск с драйверами
шнур для крепления на кольце для ключей
инструкция
гарантийный талон
Гарантия
1 год
Дополнительно
переключатель защиты от записи
Подробности
www.gembird.com

Источник: http://www.computery.ru/upgrade/

***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Спутниковые часы

Автор: Alex, editor@izcity.com

Спутниковые часы - Видео хранилище - Цифровая камера с ручными настройками

Garmin International в содружестве с Timex разработали не совсем обычные электронные наручные часы - Timex Ironman. Главная изюминка этих часов заключается в том, что они могут отображать скорость, с которой передвигается человек, надевший эти часы, и расстояние, пройдённое человеком в реальном времени.

Встроенная в часы Timex Ironman система определения скорости и пройденного человеком расстояния основана на взаимодействии аппаратных средств часов со спутниковой связью. В комплекте с часами поставляется конвертер GPS данных, который передаёт и принимает различные сигналы как с самих часов, так и со спутника. Технология GPS разрабатывалась как навигационное средство для определения скорости, преодолённого расстояния, местоположения объекта на каком-либо определённом участке местности. Под участком местности подразумевается некая географическая область, данные о которой загружены в GPS модуль устройства. Через спутник часы Timex Ironman синхронизируются с эталонными атомными часами, а это высочайшая гарантия точности отображаемого времени.

Характеристики электронных часов Timex Ironman:

  • Отображение скорости объекта.
  • Отображение расстояния, на которое переместился объект.
  • Измерение скорости в км/ч или миль/ч.
  • Гарантированная точность хода.
  • Синхронизация с атомными часами.
  • Максимальная скорость, которую могут отображать и рассчитывать часы: 725 км/ч (450 миль/ч).
  • Автоопределение часового пояса.
  • Таймер.
  • Секундомер.

Часы Timex Ironman ещё находятся на стадии разработки. Серийный выпуск и розничные продажи этих часов начнутся в апреле 2004 года. К этому времени производитель планирует увеличить число функций, доступных пользователю Timex Ironman. Цена на эти электронные часы, по заявлению разработчиков, будет составлять 225 долларов.

***

Представители корпорации IO Data (Япония) заявили о выпуске внешнего накопителя на жёстком диске, предназначенного для хранения видеоинформации.

Новое устройство VR-HDAMS0 способно записывать видеоинформацию с персонального компьютера через USB порт. Также имеется возможность записи видеоинформации на это устройство с любого источника видеоизображения, способного передавать цифровой видео сигнал. Данный накопитель на жёстком диске является альтернативой современным видеомагнитофонам. Разрабатывался он, прежде всего, для домашнего использования.

***

Компания Leica Camera представила свою новую разработку: быстродействующую цифровую фото камеру LEICA DIGILUX 2, предназначенную для любительских и домашних съёмок.

В этой цифровой любительской фото камере, производители сочли нужным сделать функции, присущие профессиональным аналоговым камерам с зеркальным объективом. Фокус, апертура, фокусное расстояние в цифровой камере LEICA DIGILUX 2 может устанавливаться вручную, с помощью поворота колец на объективе. Такая возможность установки параметров вручную, в сочетании с автоматически настраиваемыми параметрами, позволяют человеку проявить свои творческие способности в процессе фотографирования объектов.

Цифровая фотокамера LEICA DIGILUX 2 оснащена 2.5 дюймовым экраном для просмотра фотографируемого объекта. Встроенная SD память объёмом 64 мб позволяет делать от 6 до 484 цифровых фотоснимков, в зависимости от качества получаемой фотографии и её разрешения.
***
Рекомендуем
Удобно! | Программа "Кадры" Автоматизация работы кадровой службы для предприятий любых форм собственности; Построение разветвленной структуры предприятия, ведение штатного расписания и т.д. Подробнее >>
 | Программа "Кадровик-студент" Автоматизация работы по приему, перемещению и отчислению учащихся


Библиотеки online

Автор: Светлана Шляхтина

Куда ни посмотри, а информация стала сегодня иметь не меньшее значение и не меньшую ценность, нежели, скажем, природные недра или земля. И, соответственно, ее своевременное получение теперь еще более актуально. Источников получения информации не перечесть, и по-прежнему библиотеки занимают в этом списке не последнее место. Хотя нельзя не признать того, что обычных посетителей публичных библиотек не стало больше, и тому есть вполне понятное объяснение - на помощь пришел Интернет с его всеобъемлющими возможностями.

И теперь довольно часто намного быстрее найти нужный текст (книгу, документ и пр.) в Сети в виртуальной библиотеке, нежели отправляться за ним в читальный зал обычной публичной библиотеки. Или в обычной публичной, заказав его по электронной почте.

Правда, не стоит забывать, что в функционировании виртуальных библиотек есть и ложка дегтя, ведь довольно часто в Интернет бывают выставлены тексты, воспроизведение которых полностью противоречит закону "Об авторском праве и смежных правах", в итоге чего авторы текстов не получают никаких гонораров от их воспроизведения. Но это уже другая тема, а для пользователей Сети, поистине, наступил настоящий информационный рай.

По виртуальным библиотекам Сети

На сегодня можно уже смело признать, что к немалой радости пользователей Сети число виртуальных библиотек растет, и довольно неплохими темпами (а с 2001 года активно ведутся работы по созданию общеевропейской виртуальной библиотеки на основе архивов национальных библиотек Финляндии, Германии, Италии, Нидерландов, Португалии, Словении, Швейцарии и Великобритании), а сами библиотеки все расширяют свой ассортимент. Электронные тексты пользуются все большей популярностью. И есть за что: не пылятся и не горят, легко цитируются и не занимают много места, да и получить их можно в любой нужный момент, не отрываясь от вожделенного монитора. И в итоге выигрывают пользователи Интернета, для которых довольно часто уже не возникает проблемы, где достать конкретное произведение - для этого часто достаточно просто заглянуть на страницы той или иной виртуальной библиотеки. Здесь скорее всего вы сможете найти то, что уже давно хотелось почитать. А возможно, и, путешествуя по библиотечным виртуальным просторам, незаметно для себя увлечетесь и проведете в Сети не один день и даже не одну неделю.

Технология посещения виртуальных библиотек проста до банальности - как правило, вам потребуется организовать поиск нужной книги, а затем скачать ее на свой компьютер. Естественно, что в подавляющем большинстве случаев тексты в библиотеке хранятся в заархивированном виде, что существенно ускоряет процесс скачивания. Иногда, правда, это касается лишь узкопрофильных библиотек с небольшим количеством материала, нужные тексты приходится искать не по поиску, а непосредственно, перебирая все документы в той или иной подгруппе. Но это, конечно, уже малопривлекально для пользователя, и обычно характерно для виртуальных библиотек в самой начальной стадии становления.

Поиск того или иного произведения разумнее всего начать с посещения поисковой системы "Букинист" (http://bukinist.agava.ru), предназначенной для поиска книг и других электронных текстов, имеющихся в свободном доступе в Интернете. На момент написания статьи в ней было проиндексировано более 290 сайтов с открытыми текстами. Обратившись к "Букинисту", во многих случаях вы практически мгновенно получите исчерпывающую информацию о том, где сможете скачать нужный текст, если, конечно, речь не идет о научном труде или редком издании.

Можно пойти и другим путем и сразу обратиться в одну из виртуальных библиотек. Наибольший выбор вас ожидает в библиотеке Максима Мошкова, что расположена по адресу http://lib.ru, и в онлайновой библиотеке Bestlibrary.Ru (http://www.bestlibrary.ru). В первой вас ожидают около 28 тыс. текстов, а в ассортименте окажутся самые разные произведения в жанрах отечественной и зарубежной прозы, поэзии, советской и зарубежной фантастики, китайской поэзии и античной литературы, а также исторические романы и детективы, литература по психологии, торговле, философии, религии, астрологии и политике. В разделе развлечений присутствуют авторская песня и русский рок, юмор, спорт, кинофильмы, карточные игры и многое другое. Неплохо представлен и раздел старинной античной и европейской литературы. Во второй хранятся свыше 8,5 тысяч текстов и представлено порядка 1300 авторов и также широкий спектр произведений: лучшие отечественные и зарубежные литературные произведения разных жанров, есть мистическая литература, любовные или "женские" романы, фантастические произведения и романы в жанре фэнтези. В обоих случаях очень удобно организованы поиск и каталог (по авторам в алфавитном порядке и по разделам).

Неплохой выбор классической поэзии и прозы (свыше 2800 произведений и более 140 авторов - настоящее раздолье для подрастающего поколения, "страдающего" над Гоголем или Достоевским) вас ожидает на сайте "Классика.ру" (http://www.klassika.ru). Здесь можно не только быстро найти нужное произведение классического жанра, но и в случае затруднительной ситуации (если вы просто что-то хотите почитать, но не знаете, на чем остановиться) предоставить выбор системе, когда она выбирает случайное произведение в соответствии с вашими вкусами. А в завершение ознакомиться с рейтингом произведений и рейтингом авторов.

В поисках классики можно заглянуть и в публичную электронную библиотеку Евгения Пескина (http://public-library.narod.ru/), на страницах которой вы найдете произведения Блока и Булгакова, Гоголя и Гриневского (Александра Грина), Достоевского и Есенина, Лермонтова и Пушкина, Салтыкова-Щедрина и Тургенева, Чехова и Фета. Или в русскую виртуальную библиотеку (http://www.rvb.ru), где представлены классические и современные произведения русской литературы. Здесь можно найти полные или почти полные собрания сочинений А. С. Пушкина и Андрея Белого, Алексея Ремизова и Константина Батюшкова, Велимира Хлебникова и Юрия Мамлеева и ряда других авторов. Небольшую коллекцию произведений русских классиков вы найдете и в библиотеках по адресам http://ilibrary.ru/ и http://www.magister.msk.ru/library/.

Любителей русской фантастики XIX века ждут по адресу http://www.sf.amc.ru, где в свободном доступе представлено 1500 авторов и порядка 8000 книг. Кстати, кроме книг и библиографической информации, на сайте есть и свежие литературные новости, информация о премиях, ТОР-листы, "Фант-календарь", работы литературоведов, биографии писателей и интервью с известными писателями. Имеются и персональные страницы писателей-фантастов, в числе которых Стругацкие и Кир Булычев, Васильев и Громов, Крапивин и Логинов и др.

Небольшое количество детективов, прозы, фантастики и философских произведений вы найдете, заглянув в архив переводов и авторских текстов Tarra-Nova (http://tarranova.lib.ru). Можно побывать и в "Избе-читальне" Александра Кобринского http://www.geocities.com/SoHo/Hall/7820/arhiv.html, где вы получите доступ к произведениям Ивана Бунина, Рихарда Вагнера, С.М.Голицына, Жаботинского, А.И.Деникина и ряда других авторов.

Интересующимся прозой и поэзией молодых современных и пока еще не очень известных авторов можно заглянуть в библиотечку IP-клуба (http://www.ipclub.ru/biblio) или на сайт " СтихиЯ " (http://www.stihija.ru/index.shtml). Стихотворения как известных, так и незаслуженно забытых русских поэтов вас ожидают в "Антологии русской поэзии" по адресу http://skill21.narod.ru/page3.htm, где в числе представленных авторов - Жуковский и Карамзин, Ломоносов и Мандельштам, Бальмонт и Хармс и многие другие. Почитателям Шекспира, возможно, будет интересно заглянуть в мини-библиотеку "Шестьдесят шестой сонет" (http://libelli.narod.ru/sonnet66/), где их вниманию будут представлены переводы сонета на различные языки, а также статьи, обсуждения и т.п. Познакомиться с поэтическим и эпистолярным наследием новокрестьянских поэтов Сергея Есенина, Сергея Клычкова, Николая Клюева, Петра Орешина и Александра Ширяевца, а также с краткими биографическими и автобиографическими очерками не сложно, заглянув на сайт http://nk-poety.narod.ru/win/main/main.html. Огромная коллекция стихотворений и прозаических произведений русских и зарубежных поэтов вас ожидает в поэтической библиотеке "Артикул" (http://www.ipmce.su/~igor/). А стихи на вечные и всеобъемлющие темы любви можно найти по адресу http://www.geocities.com/HotSprings/4794/arts-Lyric.html. Поэтическая коллекция текстов русских, советских и зарубежных поэтов разместилась по адресу http://www.ints.ru/~le/selected/index.htm, а английские, испанские, украинские и белорусские стихи - в переводах и в оригинале - на сайте http://heart-to-heart.hobby.ru/foreign.htm.

Свыше 400 книг по различным отраслям знаний (компьютеры, психология, экономика), а также художественная литература вас ждут в электронной библиотеке по адресу http://lib.perm.ru. Хороший выбор литературы и в белорусской виртуальной библиотеке, что расположена по адресу http://www.library.by/. Художественные произведения свыше 200 авторов на русском и английском языках имеются на сайте "Комкон" http://library.komkon.org/. А по адресу http://virtlib.odessa.net/ расположилась большая одесская библиотека, в которой посетителей ожидает неплохой выбор детективов и фантастики, любовных исторических романов, энциклопедий и словарей, книг по медицине и психологии, философии и мистике, технических руководств и компьютерной литературы и многое другое.

Собрание научных, научно-популярных работ и художественных произведений экономической направленности вы сможете найти по адресу http://ek-lit.agava.ru. Представленных текстов тут совсем немного, но можно наткнуться на достаточно редкие произведения.

Некоторый набор учебных пособий и научных изданий ожидает всех желающих в виртуальной библиотеке по адресу http://virlib.eunnet.net. В поисках научной литературы определенно стоит заглянуть и в научную электронную библиотеку (http://www.elibrary.ru), доступ к которой открыт, правда, только для сотрудников ряда организаций. Но выбор литературы богатый (2350 наименований журналов) и это вполне понятно, ведь это глобальный российский проект, одна из основных задач которого - обеспечить российских ученых, специалистов, студентов и преподавателей вузов доступом к электронным версиям 331 журнала издательства Elsevier. Представлены здесь и полнотекстовые версии российских научных журналов. Свыше 4350 учебных и справочных текстов ожидает посетителей на страницах университетской виртуальной библиотеки In Folio (http://infolio.asf.ru/).

Интересующимся же вопросами психологии имеет смысл побывать в столице сетевой психологии по адресу http://psy.piter.com, в электронной библиотеке которой представлено несколько сотен полнотекстовых книг и статей психологической тематики по таким направлениям, как практическая психология, психология зависимостей, детская психология и др. Кроме того, здесь размещены электронные версии книг издательства "Питер" (как полные тексты, так и отдельные главы). Самая разная - от авторских статей до канонических текстов - литература по психологии в свободном доступе вас ждет на "Сайте психфака всея Руси и ее окрестностей" (http://flogiston.ru/projects/projects.shtml) и в психологической библиотеке PSyberLink http://www.nsu.ru/psych/internet/bits/index.htm.

Для интересующихся культурой Востока открыт Восточный портал (http://www.oriental.ru/) и библиотека япониста (http://jlib.sinor.ru/), где есть реальная возможность ознакомиться с художественной литературой Японии и Китая. А в поисках легенд и мифов стоит заглянуть в одноименную библиотеку по адресу http://www.fbit.ru/free/myth/.

Коллекция редких источников по истории религии: библия, неканонические книги и антихристианская литература находятся в библиотеке еретиков на http://www.heretics.com/library/index.htm, а материалы по дохристианской культуре славян - на сайте "Курган" (http://www.rql.kiev.ua/kurgan/). Заглянув же в библиотеку православного христианства (http://www.wco.ru/biblio/), при желании вы сможете почитать библию, богословие, духовные наставления, молитвы, ознакомиться с духовной поэзией и прозой.

Полное собрание сочинений Николая и Елены Рерихов в свободном доступе по адресу http://rikla-plasma.narod.ru/, а книги по философии - на сайте "Философия в России" (http://www.philosophy.ru/library/library.html). Латинская афористика и эпиграммы, тексты классиков и средневековые латинские тексты вас ждут по адресу http://www.doktor.ru/latin/index.htm, а афоризмы, пословицы, загадки, застольные речи, скороговорки и прочее - на сайте "Слово" (http://slovo.and.ru/).

Интернет-созвездие публичных библиотек

Если в виртуальной библиотеке нужного текста вам найти не удалось - вариант вполне возможный, ведь если самая большая виртуальная библиотека насчитывает порядка 30 тысяч текстов, то в публичных счет идет уже на миллионы, поэтому загляните в крупную публичную библиотеку. Там вы обязательно сможете заказать нужный вам документ, статью из журнала или газеты, брошюру, главу из книги или даже книгу, какой бы редкой она ни была. Как правило, это несложно сделать прямо в Сети, заполнив соответствующую форму заказа, или же отправив запрос по электронной почте. В результате, в течение нескольких дней (конкретный срок зависит от того, есть ли нужный документ в электронной базе данных библиотеки или же придется его сканировать) вы получите нужный текст в виде готовой распечатки или все по той же электронной почте. При необходимости нужная электронная копия будет изготовлена прямо с первоисточника. Кроме того, между многими библиотеками существуют договора об обмене электронными копиями, в результате чего можно получить и документ, отсутствующий в данной конкретной библиотеке через службу электронной доставки какой-либо другой библиотеки. Правда, все это удовольствие обойдется вам, конечно, не бесплатно.

Как правило, после получения заказа вы получите на свой e-mail письмо с информацией о возможности, стоимости и сроке выполнения заказа. Далее нужно либо подтвердить свой заказ, либо отказаться от него. При подтверждении, естественно, потребуется предварительная оплата услуг библиотеки.

Служба электронной доставки документов работает, к примеру, в библиотеке Академии Наук (http://www.csa.ru/BAN), действующие фонды которой включают более 16,5 млн. экземпляров изданий. Заказ может быть отправлен по электронной почте, но получен только лично в виде готовой распечатки в указанной читателем библиотеке, что несколько портит ситуацию.

А вот спектр услуг библиотеки Новосибирского Академгородка (http://prometeus.nsc.ru/about/) гораздо шире. Иногородние абоненты без проблем смогут получить заказ как по обычной почте в виде распечатки, так и в электронном виде на свой e-mail. Заказать нужный текст по электронной почте не сложно и в библиотеке по естественным наукам РАН (http://ben.irex.ru). А в библиотеке химического факультета МГУ (http://www.chem.msu.su/rus/jlib) нужный текст можно просто скачать, и никакие финансовые расходы вам нести не придется. Правда, это касается только ряда узкоспециализированных документов.

Без проблем вы сможете заказать статьи из любого периодического издания (газеты, журнала), а также любую информацию из любой книги, справочника и базы данных в Государственной публичной исторической библиотеке, что находится по адресу http://www.shpl.ru. Для этого достаточно заполнить форму заказа, что можно сделать через меню "Оформление заказа", если вы точно знаете, какие страницы из какого издания вам необходимы или через меню "каталог периодических изданий", в котором можно выбрать интересующий журнал и просмотреть его оглавление.

Аналогичные услуги оказывает и научная библиотека МГУ (http://www.lib.msu.su), универсальный фонд научной и учебной литературы которой насчитывает 8,5 млн. текстов. Работает электронная доставка документов и в Нижегородской государственной областной универсальной научной библиотеке (http://www.nounb.sci-nnov.ru), и в Российской национальной библиотеке (http://www.nlr.ru). А в Российской государственной библиотеке (http://www.rsl.ru) есть возможность получить текстовую копию любых печатных материалов из фондов РНБ, за исключением архивных, рукописных и газетных материалов. При желании вы без проблем получите нужные документы и из фондов Центральной научной сельскохозяйственной библиотеки (http://www.cnshb.ru).

В качестве заключения

В общем, проблема получения сегодня нужной вам информации (при условии, конечно, что она когда-то была опубликована и имеется в библиотечных фондах) практически перестала существовать. А какой вариант для этого выбрать, решать уже вам, и зависит это от характера требуемого документа. Хотя, не думается, что такой информационный рай будет продолжаться бесконечно, ведь когда-нибудь правовые проблемы всерьез затронут пока мало контролируемый в России Интернет, и тогда уже волей-неволей, но в виртуальных библиотеках останутся лишь возможные для воспроизведения тексты.

Источник: http://www.comprice.ru/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Простейшая авторизация для вашего сайта

Автор: Xpert

Web-мастерам, использующим в качестве движка для сайта что-либо собственноручно написанное рано или поздно надоедает обновлять сайт, редактируя файлы по FTP или работая напрямую с базой данных. И тогда начинается написание скриптов администрирования, которые бы позволили управлять сайтом в интерактивном режиме с приятным внешним видом и наконец-то сделали процесс обновления более приятным. Первый вопрос, который обычно возникает в таком случае - это вопрос авторизации - не будешь же давать возможность каждому, нашедшему на сайте административный раздел, творить все, что ему взбредет в голову. Сегодня мы с вами рассмотрим процесс написания простейшей авторизации.

Для начала несколько уточняющих моментов. Первое - пишем на PHP, так как это наиболее распространенный на сегодняшний день язык написания систем управления сайтами. И второе -я лично против самописных скриптов, отвечающих за сам ввод логина пароля. Поэтому не будем изобретать велосипед, т.е. собственный принцип авторизации, а воспользуемся стандартными возможностями.

Итак, будем пользоваться обычной аутентификацией - окном для ввода пароля, какое используется, например, на Rambler и множестве других сайтов.

Пример окна запроса на авторизацию

Возможность входа в защищенную зону сохраняется в течение всего сеанса работы окна браузера, но после того, как вы его закроете, войти снова можно будет лишь набрав имя пользователя и пароль. То есть, воспользовавшись вашим компьютером, незаконных действий от вашего имени совершить невозможно. Чем еще хорош этот метод? Он не принимает никаких переменных со сторонних серверов и после трехкратного неверного ввода пароля вам придется обновлять страницу, что затрудняет взлом системы подбором.

А выглядит это вот так:

Введенный пользователем логин хранится в переменной $PHP_AUTH_USER, пароль - в $PHP_AUTH_PW. Кстати, обратите внимание на проверку существования записи пользователя с таким именем в БД - это критический момент, который учитывать весьма важно. В случае, если такой проверки не будет, это приведет к плачевным результатам - $row[password] будет равно нулю, то есть введя несуществующее имя пользователя и пустой пароль можно будет попасть в защищенную зону.

Между инструкциями Header("HTTP/1.0 401 Unauthorized"); и exit(); вставляем что угодно - от простой фразы о том, что сюда нельзя до предложения куда-нибудь сходить, слетать, сбегать, сползать и так далее. Да, чуть не забыл - в переменных $dbhost, $dbuser, $dbpasswd и $dbname хранятся данные, обеспечивающие доступ к базе и имя базы.

Подобный код необходимо вставить на каждую страницу защищенной зоны, например, через include.

Вот вы и защищены. От себя могу еще добавить, что паролирование таким способом лично мне кажется весьма удобным и надежным.

***
Рекомендуем
Удобно! Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.


Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

Режем баннеры и popup'ы на бесплатных хостингах-2

Автор: Xpert

Затронутая в предыдущей статье на эту тему (Izone524) проблема вызвала неподдельный интерес многих Web-мастеров и просто пользователей. Как говорится, наболело. Мной была даже составлена шуточная версия статьи - ее вы можете увидеть в теме Режем баннеры и ... - новый вариант на нашем форуме. Хотелось бы также поблагодарить за присланные материалы Victor Berdnik - именно они послужили основой для новой статьи и, в общем-то, поводом к ее написанию.

Поговорим о новых методах противодействия штучкам хостеров.

Chat.ru

Имя этого хостера уже давно стало нарицательным и оно в принципе созвучно фразе «Хостинг хуже некуда…». Однако многие сайтовладельцы не спешат менять его на что-либо более приличное. Оно и понятно - зачем менять шило на мыло. Теперь относительно кода, который вызывает popup. Он очень похож на код, применяемый Яndex'ом на Народе, совпадает буквально все, разве что имена вызываемых Java-скриптов разные. Интересно, кто же его у кого скоммуниздил? :)

Для его нейтрализации необходимо добавить в самый конец страницы следующие строки:

<noscript><noscript>
<plaintext><plaintext>

Еще один возможный и тоже прекрасно работающий вариант нейтрализации подобного кода выглядит так (помещать тоже в самый конец страницы). Очень неплохое, хочется подметить, применение передовых разработок в CSS:

<div style="position: absolute; top:0; left:0; width:0; height:0; overflow: scroll;"><xmp>

Fatal.ru

Достаточно интересный проект, пока что огорчает только лимит траффика и самореклама, из которой можно выбирать встраиваемый баннер и столь нелюбимый popup. А вызывается все это так:

Среди всего этого многообразия кода нас интересует следующая строка: wd = window.open ('http://fatal.ru/ad/ad.cgi?1121', 'w949273581'). Совершенно, кстати, глупый фрагмент, учитывая то, что идентификатор wd нам не понадобится. Вернее, не понадобится он в данном коде. Нам-то эта оплошность как раз на руку. Пишем в начале страницы:

<script language="JavaScript">
wd.close();
</script>

Окно пусть не пропадает совсем, но хотя бы закрывается сразу после своего открытия…

By.ru

В прошлый раз нам не удалось обмануть popup этого проекта. И сегодня не удалось. К сожалению, хотя код и похож на код Fatal и есть в нем тот же огрех, вышеописанный прием не работает. Однако, поскольку кому-то это может пригодиться, я выкладываю наработки. Рассмотрим код. Вот этот вставляется в начало каждой страницы:

<!-- строчка рекламы by.ru -->
<script language="JavaScript" type="text/javascript" src="http://more.by.ru/up/up.js?1116711296"></script>
<html>

Цифры в параметре могут быть другими, но сути это не меняет. Все это вызывает такой (или, опять же, подобный) внешний скрипт:

Заключение

Честно говоря, очень хочется спать, но напишу еще пару строк. Отвечу на два достаточно распространенных вопроса. Первый - что вам за это будет? Ответ: если сможете все грамотно обставить, например, скрипту придать функциональность, а код в конце страницы якобы забыть при переносе из другого файла, то вам скорее всего просто сделают предупреждение. Могут, естественно, и удалить. Но это и так могут - ведь вы на бесплатном хостинге, а ничто не вечно под луной. Второй - зачем вам это надо? Чтобы не раздражало посетителей вашего сайта, не напоминало им лишний раз, что ваше детище все еще расположено на бесплатном хостинге.

И да не узнают про ваши проделки злобные админы злобного хостера :).
***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
 См. подробнее: http://www.izcity.com/ebay/


Тайна секретного шаблона (или пособие по взлому N2)

Как не болеть и жить долго? Ионизаторы воздуха
Как не болеть и жить долго в условиях загрязненной экологии и городской среды?
Поставьте себе ионизатор в квартире и дышите чистым воздухом!
Как в лесу, на море или в горах.
Подробнее >>
***

Тайна секретного шаблона (или пособие по взлому №2)

Автор: Игорь Викторович Ананченко
http://aiv.spb.ru/

Очищая почтовый ящик от спама увидел письмо "Срочная РАЗОВАЯ работа - 600$ Требования: ПК-пользователь, знание системы Web Money Transfer, умение работать с поисковыми системами. Подробности по адресу: http://podrobno.by.ru". Интереса добавил выпуск 315 IZone Dollar ("598$ ОСТАВЬТЕ СЕБЕ!!!" Выпуск подготовил: Андрей Куракин) с ссылкой на все тот же сайт. Цитирую рассылку <<...люди, которые извлекают из Интернета десятки и сотни тысяч долларов в год!!! ...У них есть свой закрытый сайт, свой форум, своя внутренняя почта. Регулярно они закупают на Западе передовые бизнес разработки и распространяют их среди членов своего клуба. Именно эти разработки и позволяют им делать в Интернете десятки тысяч долларов в месяц...А теперь самое главное. Мой приятель, который работает сисадмином на этом сайте, после долгих приставаний с моей стороны согласился предоставить мне этот пароль за чисто символическую (для него!) цену всего за- 600$ !!!>> Продолжая тему, привожу информацию взятую непосредственно с названного сайта ”Так как переводить 600$ за пароль я буду через Web Money, то и собирать данную сумму мне придется именно в WM. Поэтому Вам необходимо зайти на http://www.webmoney.ru, открыть там счет и положить на него примерно 2,2 – 2,5$...Сразу же после получения мною пароля, я немедленно разошлю его всем участникам «Клуба 300» по своему списку. Далее Вам будет нужно зайти на секретную страничку сайта – http://mouse.spaceweb.ru/~qw734mru/Templatesinter.html – где Вы сможете ввести полученный от меня пароль и перейдете в раздел с «шаблонами»". Ну и что скажете вы, дочитав до этого места. Пока еще ничего! Это присказка не сказка, сказка братцы впереди...

Ссылка опубликована, посмотрим куда она ведет, а ведет на довольно пристойный на первый взгляд сайт. Адрес слегка длинноват, ну да ладно. На экране фрейм, с пунктами меню /ОБМЕН ОПЫТОМ Home Портфолио Все проекты Банк Новости клуба Розыск Админ Помощь/ При выборе любого попадаешь на страницу http://mouse.spaceweb.ru/~qw734mru/exit.html с минимумом текста /ОШИБКА ДОСТУПА!!! (У ВАС НЕТ ПРАВА ДОСТУПА НА ЭТУ СТРАНИЦУ)/ Кликнув правой клавишей мыши на главной странице во фрейме, получаем сообщение о копирайте (HTML код страницы просмотреть нельзя), введя что-то в окне ввода пароля, получаем все туже страницу exit.html. На первый взгляд все отлично, круто и производит впечатление на чайников (как и было задумано). А на второй - вот и он мой бесплатный подопытный кролик, принесенный волнами спама. Жалко птичку, жалко рыбку, жалко кролика, но недрогнувшей рукой приступаем к препарированию - процесс пошел.
Для начала определим, какой файл загружается во фрейм:

<html>
<head>
<title>ОБМЕН ОПЫТОМ</title>
<meta
http-equiv="Content-Type" content="text/html;
charset=windows-1251">
</head>
<frameset rows="90,*" frameborder="NO"
border="0" framespacing="0">
<frame name="top" scrolling="NO"
noresize src="top.html" frameborder="NO" border="0"
framespacing="0">
<frame name="main" scrolling="AUTO" src="Templates.html"
frameborder="NO" border="0" framespacing="0">
</frameset>

Очевидно, что Templates.html - его и вызываем http://mouse.spaceweb.ru/~qw734mru/Templates.html
С помощью правой клавиши мыши я не могу просмотреть HTML текст, но и не надо! Зачем мне правая клавиша мыши - я просматриваю текст, выбрав в браузере пункт меню "ВИД" подпункт "В ВИДЕ HTML". Во фрейме мне выдавался код фрейма, а теперь выдается код файла, загружаемого во фрейм.

Посмотрите, что отрабатывает при нажатии правой клавиши мыши:

<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=windows-1251">
<meta name="GENERATOR" content="Mozilla/4.7 [ru] (Win95; I) [Netscape]">
<title>ОБМЕН ОПЫТОМ</title>
<SCRIPT language=Javascript1.2>
<!--
var message='Copyright 2001-2004.'; function click(e)
{if (document.all) {if (event.button == 2) {alert(message);return false;}}
if (document.layers) {if (e.which == 3) {alert(message);return false;}}}
if (document.layers) {document.captureEvents(Event.MOUSEDOWN);}
document.onmousedown=click;
// -->
</SCRIPT>
....

Тривиальнейшее использование жаба скрипта! Бедная жаба, ей не стать лягушкой волшебницей в руках мага-кудесника, не потрудившегося убрать хотя бы то, что стоит в meta name.
Ничего достойного внимания больше на странице нет:

<input id=pa type=PASSWORD value="" size=20> &nbsp;&nbsp;<button OnClick=CP()>OK</button>

и в самом низу

</body>
<script src="557p.jav"></script>
</html>

При нажатии на кнопку пароль передается для обработки в файл src="557p.jav"
Только полный кретин, неуч или лентяй не подставит имя этого файла, так чтобы получился линк http://mouse.spaceweb.ru/~qw734mru/557p.jav

Вызвав его видим:

usera=3;
user0=new
Array('67r7RES438Frth','shablons.html');
user1=new
Array('67r7RES438Frth','shablons.html');
user2=new
Array('67r7RES438Frth','shablons.html');
function CP(){
for(i=0;i<usera;i++)
if(eval('user'+i+'[0]')==pa.value){eval('location=user'+i+'[1]');i=10}
else
location="exit.html"}

Это, ясен пень, чудо секретной технологии. Не барское дело подобный код комментировать! Вот не буду, ведь не зря говорят, с кем поведешься от того и наберешься. В общем, спаси и сохрани! Подставим shablons.html в линк, чтобы получилось http://mouse.spaceweb.ru/~qw734mru/shablons.html Жмем ввод и видим текст "Матрицы для FOREX" абсолютно бесполезный для не занимающихся FOREXом серьезно.

Не стану комментировать текст по существу и согласен с возможным возражением, что это всего лишь заготовка, на месте которой потом будет размещено нечто. Но это нечто сродни "калашу" попавшему в лапы продвинутой обезьяне. Она отличается от обычной тем, что не пройдет спокойно стороной мимо волшебного предмета, дающего силу и могущество. Обезьяна будет крутить, вертеть, нажимать на разные пимпочки и крючок, годясь тем, что у нее есть "это". Затем "это" будет обругано и выкинуто, как предмет не действующий и потому бесполезный. Если же ей сильно повезет, то она увидит предмет в действии, а мы увидим, стоит ли кавычить слово "повезло" или же нет.
<<Само собой разумеется, что таких денег у меня сейчас нет. Да даже если бы они и были рисковать такой суммой (а это моя зарплата за ТРИ месяца!..) как-то боязно. Я думаю, большинство из Вас меня понимают. :-) У меня нет абсолютно никаких оснований не доверять своему приятелю, но. Но у меня нет сейчас и этих 600$ !..>> Плохо, очень плохо, если нет тыщенки другой лишних баксов на девочек и для покупки хрен знает чего. Просто беда, если не наскрести $10-15 в месяц на нормальный хостинг с поддержкой исполняемых сервером скриптов. Скриптов простых как лапоть, примитивных как палено, общеизвестных, но все равно плохо взламываемых.
Вот и все. Добавлю только, что "Так не надо ставить пароли №1" можете найти здесь http://aiv.spb.ru/page.php?id=673.

p.s.
"Антон Палыч Чехов однажды заметил,
что умный любит учиться, а дурак учить.
Скольких дураков в своей жизни я встретил,
мне давно пора уже орден получить.
Дураки обожают собираться в стаю,
впереди главный -- во всей красе.
В детстве я думал, что однажды встану,
а дураков нету -- улетели все!
...
Дураком быть выгодно, да очень не хочется.
Умным очень хочется, да кончится битьем...
У природы на устах коварные пророчества.
Но может быть, когда-нибудь к среднему придем?"
Булат Окуджава

***
Рекомендуем
Книга "Магия Твоих Текстов (2-ой том)"
Вторая книга трилогии «Магия Твоих Текстов» содержит большой набор уникальных и эффективных практических приемов, овладев которыми, вы вплотную приблизитесь к «гроссмейстерскому уровню» овладения гипнотическими технологиями создания безупречных рекламно-пиарных, художественных, и иных произведений.
В книге подробно объясняются малоизвестные профессиональные секреты, даются практические рекомендации, и вся она написана в превосходном, доступном для моментального восприятия стиле.
Рекомендуется всем, кто занимается рекламой, копирайтингом, сетевыми продажами и интересуется РЕАЛЬНЫМИ секретами профессионального скрытого влияния на аудиторию с помощью психотехнологий.
Узнать подробнее о книге "Магия Твоих Текстов (2-ой том)"


ТЕЛЕКОММУНИКАЦИИ И ЭЛЕКТРОНИКА

Соединительные технологии: кабели, оптоволокно, изоляция, монтаж и др.

Гарантия и качество Изоляционные материалы

  • Термоусаживаемые трубки для кабелей связи
    Наиболее экономичное средство изолирования и герметизации различных соединений и компонентов, а также прекрасный материал для восстановления изоляции телефонных и силовых кабелей.
     смотреть >>
  • Термоусаживаемые кабельные муфты и манжеты
    Изделия для герметизации, механической защиты и ремонта кабельных соединений, а также восстановления поврежденных оболочек электрических кабелей связи. Ремонтные манжеты, кабельные муфты, изолирующие, герметизирующие ленты.
     смотреть >>

Качество и гарантия Материалы для монтажа электрических кабелей связи

  • Материалы фирмы 3М
    Изделия американской фирмы 3М - одного из лидеров в области производства изолирующих материалов.
     смотреть >>
  • Соединительные модули
    Телефония: многожильные соединительные модули AMP-Stack. Инструменты, вспомогательные принадлежности (чемодан, ручной пресс, пресс-клещи и др.)
     смотреть >>
  • Одиночные соединители
    Одножильные соединители Tel-Splice, инструмент со сменным картриджем.
     смотреть >>
  • Соединитель для жил электрических кабелей связи
    Соединитель DURASEAL-406-0001 предназначен для соединения жил электрических кабелей связи диаметром 0.8 - 1.4 мм.
     смотреть >>
  • Кроссовое и оконечное оборудование
    Кроссовое и оконечное оборудование для медножильных кабелей связи на основе плинтов производства фирм Тайко Электроникс Райхем и Кроне (KRONE). Плинты изготовлены по технологии IDC (врезной контакт). Помимо стандартных 10-парных плинтов, поставляются однопарные модули VX производства фирмы Райхем. Для всех типов кроссов предусмотрены модули защиты по току и напряжению.
     смотреть >>
  • Арматура герметизации каналов связи
    Aрматура герметизации каналов телефонной кабельной канализации
    Изделия для герметизации кабельных каналов и герметичного ввода кабелей в каналы
     смотреть >>

Волоконная оптика

  • Соединительные шнуры из оптоволокна
    Одномодовые, многомодовые коммутационные и соединительные шнуры для оптических кабелей. Волоконнооптические розетки (адаптеры), механические соединители волокон...
    смотреть >>
  • Материалы для монтажа оптических кабелей
    Муфты, модульные системы оптоволоконной инфраструктуры, трубки для защиты сварных стыков оптических волокон.
     смотреть >>

Строительство

  • Телефонизация и электромонтаж
    Телефонизация и электромонтажные работы на строящихся и действующих объектах.
     смотреть >>

Технологии монтажа

  • Новейшие технологии для монтажа кабельных линий связи
    Простые и эффективные способы монтажа кабелей (как меди так и оптики). Различные соединители, инструмент, необходимый для монтажа, а также материалы для восстановления защитных покровов кабелей.
     смотреть >>
  • Обучение новым технологиям монтажа
    Бесплатные ознакомительные семинары, "шеф-монтаж"
    смотреть >>


FineBrowser - конкурс

Сегодня мы проводим конкурс на знание популярных отечественных программ. Мы предлагаем ответить Вам на вопросы по программе FineBrowser. Первые 3 участника, правильно ответившие на все вопросы, получат бесплатные регистрационные ключи для программы FineBrowser. Имена и фамилии победителей, а также время их ответа будут опубликованы на нашем сайте по завершению конкурса. Срок проведения конкурса с 4.12.2003 до 12.12.2003. Желаем удачно поучаствовать в конкурсе.

Для участия в конкурсе, заполните все поля
Перейти на сайт программы Имя и фамилия
E-mail
1-ое отличие FineBrowser от других мультиброузеров
 | FineBrowser позволяет размещать вкладки как сверху так и снизу
 | FineBrowser существенно упрощает навигацию по загруженным страницам (вкладкам), которые связаны между собой перекрестными ссылками
 | FineBrowser поддерживает быстрые группы для удобного доступа к любимым ссылкам
2-ое отличие FineBrowser от других мультиброузеров
 | Прямо в активном окне браузера можно добавить комментарии к просматриваемой странице, занести ее в архив Интернет ссылок, задать ее рейтинг, привязать к рубрикатору и многое другое
 | Блокирует pop-up окна
 | Позволяет задавать псевдонимы для любимых ссылок
Какие классы продуктов включает в себя FineBrowser?
 | Мультиброузер
 | Мультиброузер +firewall
 | Мультиброузер + Popup Killer + менеджер закладок + уникальные возможности для того чтобы избежать повторного просмотра одних и тех же web страниц
Как FineBrowser позволяет работать со скриншотами посещенных страниц?
 | Никак
 | Можно установить чтобы они автоматически снимались и задать размер для маленького и большого скриншота
 | Можно установить, чтобы они автоматически снимались и задать размер для маленького и большого скриншота. Потом можно видеть скриншоты посещенных страниц как в списке, так и в окне подсказки при наведении на посещенную ссылку
Что такое "доменные линки" в finebrowser и как с ними работать?
 | При посещении страницы сайта, на котором мы уже когда-то побывали, подсвечивается кнопка "Доменные линки". При нажатии на эту кнопку мы можем узнать, когда и на каких страницах этого домена мы уже бывали и прочитать свои комментарии к ним.
 | Перечень всех ссылок на загруженной странице
 | Перечень всех ссылок на загруженной странице, которые с текущего домена
Назовите "старшего брата" FineBrowser
 | iNetAdviser
 | IENavigator
 | AdsCleaner
Во сколько раз ниже стоимость программы для СНГ
 | Ни во сколько
 | Более чем в два раза
 | В 10 раз

Внимание: для отправки формы требуется Интернет-соединение.

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
 См. подробнее: http://www.izcity.com/ebay/


Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

Минутка отдыха

Мобильный компьютер.

Скороход.

***

Анекдоты

- Со мной такое вчера произошло, чего я врагу не пожелаю!
- И что же с тобой случилось?!
- Я в "Русское лото" миллион выиграл!

К новому русскому приходит дочка и говорит:
- Папа, я выхожу замуж.
- Как?! За кого?
- За попа.
- Че! Ты совсем сдурела?
- Ну любовь, папа... Понимаешь, сердцу не прикажешь...
- Ну ладно... ты хоть приведи его, познакомимся...
Приводит она молоденького дьякона, сидят они, кушают, выпивают. НР говорит:
- Слышь, зятек, вот дочка у меня шубки по 10000 зелени меняет каждый месяц. Как, мне интересно, вы жить-то будете? Как ты ее содержать будешь...
- Бог поможет...
- А еще она у меня привыкла в Париж летать каждую неделю новую прическу делать. Как теперь?
- Бог поможет...
- Да, и вот ездить она предпочитает на Феррари или Порше, каждые полгода новую модель берет... Как ты себе представляешь совместную жизнь с ней?
- Бог поможет...
Ну посидели, ушел жених домой. Дочка и спрашивает:
- Ну как, пап, тебе мой жених? - Ну как?... Лох лохом, но когда меня Богом называют, мне нравится!

Встречаются две подруги:
- Я слышала, что ты снова сошлась со своим бывшим мужем?
- Да.
- Но почему? Зачем?
- Не могу больше видеть его счастливую физиономию.

***

Wallpapers (обои на Рабочий Стол)

1024x768 Скачать | 1024x768 Скачать
1024x768 Скачать | 1024x768 Скачать

Ниже приведена инструкция, как установить обои на рабочий стол:

  1. Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Выбираем Фон > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Применить
  2. В WinXp делаем так: Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Раскрывается окно Свойства: Экран > Выбираем вкладку Рабочий стол > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Открыть > Нажимаем кнопку Применить
  3. Если вы скачиваете обои в архиве, то нужно разархивировать рисунок в нужную вам директорию, и далее как написано выше.

***

Визуальные стили для Windows XP

Визуальные стили (темы) включают в себя полный комплект для изменения внешнего вида Windows XP: shellstyle, desktop icons, user icon and wallpaper. Инструкцию по установке см. ниже.

Скачать (800 Kb)

Для применения визуальных стилей, т.е. установки их, разработчики стилей рекомендуют использовать программу Style XP (или же TGT Soft's Style XP).
Данные программы "разрешают" Windows XP использовать неподписанные (без цифровой подписи) визуальные стили.

Инструкция для установки стиля:

  1. Загрузите визуальные стили .zip в ваш компьютер
  2. Извлеките .zip файл в эту директорию: %windir%\resources\themes\ (вероятно c:\windows\resources\themes\)
  3. Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Затем Темы > Выбираем из списка доступных тем нужную и нажимаем кнопку Применить

***

Мелодии для мобильных телефонов

Круг: Владимирский централ

Ericsson (ноты набирать без пробелов)
+c +C +#C +c #a +#C +C p #g #G #A #g g #A #G p +c +C +#C #a #a +#d +#C +C p #g +C #A #a #g G

Telit
c(1/16) c(1/2) c#(1/2) c(1/16) A#(1/16) c#(1/2) c(1/2) p(1/16) G#(1/16) G#(1/2) A#(1/2) G#(1/16) G(1/16) A#(1/2) G#(1/2) p(1/16) c(1/16) c(1/2) c#(1/2) A#(1/16) A#(1/16) d#(1/16) c#(1/2) c(1/2) p(1/16) G#(1/16) c(1/2) A#(1/2) A#(1/16) G#(1/16) G(1/2)

Nokia
8c2 4c2 2#c2 8c2 8#a1 4#c2 2c2 8 1 8#g1 4#g1 2#a1 8#g1 8g1 4#a1 2#g1 8 1 8c2 4c2 4#c2 8#a1 8#a1 8#d2 4#c2 2c2 8 1 8#g1 4c2 4#a1 8#a1 8#g1 2g1

Panasonic
11*> 11****> 111*****> 11*> 66*> 111****> 11*****> 0*> 55*> 55****> 66*****> 55*> 5*> 66****> 55*****> 0*> 11*> 11****> 111****> 66*> 66*> 222*> 111****> 11*****> 0*> 55*> 11****> 66****> 66*> 55*> 5*****>

Motorola (для ускорения-замедления темпа изменяйте первую цифру от 1 до 4)
3 C+1 C+4 C#+2 C+1 A#1 C#+4 C+2 R1 G#1 G#4 A#2 G#1 G1 A#4 G#2 R1 C+1 C+4 C#+4 A#1 A#1 D#+1 C#+4 C+2 R1 G#1 C+4 A#4 A#1 G#1 G2

Siemens
C2(1/8) C2 Cis2(1/2) C2(1/8) Ais1(1/8) Cis2 C2(1/2) p1(1/8) Gis1(1/8) Gis1 Ais1(1/2) Gis1(1/8) G1(1/8) Ais1 Gis1(1/2) p1(1/8) C2(1/8) C2 Cis2 Ais1(1/8) Ais1(1/8) Dis2(1/8) Cis2 C2(1/2) p1(1/8) Gis1(1/8) C2 Ais1 Ais1(1/8) Gis1(1/8) G1(1/2)

Rttl
8c6, c6, 2c#6, 8c6, 8a#, c#6, 2c6, 8p, 8g#, g#, 2a#, 8g#, 8g, a#, 2g#, 8p, 8c6, c6, c#6, 8a#, 8a#, 8d#6, c#6, 2c6, 8p, 8g#, c6, a#, 8a#, 8g#, 2g,

Sony
CC*****, CC***, CisCis**, CC*****, Ais*****, CisCis***, CC**, P*****, Gis*****, Gis***, Ais**, Gis*****, G*****, Ais***, Gis**, P*****, CC*****, CC***, CisCis***, Ais*****, Ais*****, DisDis*****, CisCis***, CC**, P*****, Gis*****, CC***, Ais***, Ais*****, Gis*****, G**,

Внимание!
Порядок ввода мелодии в телефон смотрите в "Руководстве пользователя" для вашего телефона. Инструкцию ввода мелодий для некоторых моделей телефонов можно найти в IZone 521.

***
Рекомендуем
Книга "Магия Твоих Текстов (1-ый том)"
 Эта книга - первая в серии книг по спецтехнологиям профессионального создания безупречных текстов с применением специальных техник гипноза. Мощный и глубокий стиль в сочетании с прекрасной подборкой приемов и методов гарантированно превратит вас в профессионала по созданию ЭФФЕКТИВНО РАБОТАЮЩИХ ГИПНОТЕКСТОВ буквально в считанные часы!
Книга содержит массу сведений исключительно прикладного характера и будет полезна всем, кто интересуется секретами и загадками психотехнологий – НЛП, Эриксониансокго гипноза, Вириа и их применением в качестве инструментов «власти» над клиентами, аудиторией, посетителями сайтов.
Материал книги не требует предварительного знакомства со спецтехнологиями.
Узнать подробнее о книге "Магия Твоих Текстов (1-ый том)"


Soft FAQ 136

Автор: Сергей Трошин

Пререлизная неожиданность
О преобразовании лиц и предметов
Старое лучше нового
По мелочи
Место мыши вместо проблемы
Пользователи QNX! Ау!

Советы читателей и зубная боль Трошина

Пререлизная неожиданность

Наконец-то, методом проб и ошибок, выяснен путь установки патча от червяка Blaster / Lovesan на хитрую операционку: Windows XP с интегрированным пререлизным SP2! Такой диск какое-то время распространяется в Москве, и те несчастные, которые установили с него систему (кстати, работающую без каких-либо проблем) при попытке установить заплатку против "Бластера" от MS наблюдают окошко с сообщением типа: установлен сервис-пак, после которого это обновление не устанавливается... Так вот, выход, как обычно, есть! Он заключается в том, чтобы перезаписать необходимые файлы руками.

Первое. Если это не было сделано ранее, устанавливаем Recovery Console (можно с того же злополучного компакта WinXP+SP2): из-под Винды запускаем с компакта, из каталога i386, файл winnt32.exe с ключом /cmdcons, и, ответив на несколько вопросов, получаем в загрузочном меню операционных систем на старте компьютера опцию "Recovery Console". Она пригодится потом, а пока - второе. Чтобы из этой консоли можно было провести нужную нам операцию, ей (консоли) нужно дать право оперировать всеми файлами, а не только из папки Windows (по умолчанию).

Для этого проделываем следующее (с правами администратора, естественно): Пуск > Настройка > Панель управления > Администрирование > Локальные политики безопасности > Локальные политики > Параметры безопасности > параметр типа "Recovery Console: allow floppy copy & access to all drives and all folders" надо включить. Третье. Теперь следует выудить из ранее добытого патча (для английской WinXP это будет WindowsXP-KB823980-x86-ENU.exe) нужные файлы при помощи какого-нибудь архиватора, понимающего CAB SFX формат, например, WinRar. Нас интересуют файлы ole32.dll, rpcrt4.dll и rpcss.dll из подпапки sp2 в этом архиве. Их надо распаковать в какое-нибудь место с простым путем, например, C:\New\.

Файлы с такими же названиями из папки \Windows\ system32\ можно, перестраховавшись, куда-нибудь скопировать на случай форс-мажора. Четвертое. Теперь перезагружаем машину, выбираем свежепоявившийся пункт "Recovery Console" и попадаем в окно этой консоли, сильно смахивающее на DOS. Кстати, список возможных команд в ней вызывается командой HELP, а информация по нужной команде - <имя команды> /?

Для начала нам нужно подтвердить свое желание не ограничиваться одной папкой Windows: Set AllowAllPaths=TRUE, а потом и приступить к процедуре замены файлов: copy C:\New\ole32.dll C:\windows\system32; copy C:\New\rpcrt4.
dll C:\windows\system32; copy C:\New\rpcss.dll C:\windows\system32 (подтверждая при этом перезапись). Все, перезагружаемся в Windows и радуемся патчу!

Heon Harkonnen

Спасибо, к такому исчерпывающему совету можно добавить только банальное предостережение: если вы используете пререлизные альфы, беты и прочие тестовые версии какого-либо программного обеспечения, то всегда будьте готовы к любым неожиданностям.

О преобразовании лиц и предметов

В Upgrade # 34 (124) в софт-поддержке написано про формат jp2. Собственно, там было указано, как файл такого формата смотреть и преобразовывать. И даны ссылки на соответствующие утилиты. Дополню список. Известная мне программа просмотрщик SlowView щелкает такие файлы, как орешки. И открывает для просмотра (jp2 и др.), заодно конвертирует, причем очень просто. Для этого нужно открыть нужный графический файл (например, тот же jp2000) и задать команду в меню "Файл" - "Сохранить как..." (и выбрать нужный для сохранения формат, например, обычный jpeg). Вуаля - все готово. И зачем, спрашивается, нужны специальные просмотрщики и конвертеры? Да, программа бесплатна и живет по адресу www.slowview.at.

Кстати, она, плюс ко всему прочему, проигрывает MP3-файлы и DivX-видео. Полный список (большой) поддерживаемых форматов можно узнать, нажав кнопку "Настройка" > "Типы файлов" программы. В распакованном виде SlowView занимает меньше 2 Мб, если это о чем-то говорит.

Best regards, Soft56

Спасибо, программа действительно очень интересна и заслуживает внимания не только по факту бесплатности.

Старое лучше нового

После установки Nero Burning Rom v.5.5.10.50 процесс записи доходил как обычно шустро до 100% на скорости 52х. Но после этого диск раскручивался и останавливался на несколько минут, при этом мигал огонек, свидетельствующий о записи. Огонек гас, и привод просто в режиме чтения раскручивал и останавливал диск. Запись одного из дисков - ВОСЕМЬ минут (проблема с дисками исключена, потому что я такие диски записываю пачками - Verbatim). Также, если диск был заполнен, например, на 696 Мб (при заполнении 694 Мб - вроде то же самое происходило), то выскакивало окошко о нехватке места и диск "выплевывался". Проблема была устранена установкой предыдущей версии 5.5.10.42. Все опять пошло как по маслу. Записал диск на 698 Мб.
P.S. Установка новой версии производилась методом обновления, но и старую версию я тоже устанавливал методом обновления на 5.5.10.50. Думаю, чистая установка ничего не решит, но сам не пробовал.

С уважением, Fixman

Это один из распространенных случаев, когда старая версия программы или драйвера работает более стабильно, нежели самая свежая. Ничего удивительного в этом нет, а потому при поиске причины сбоя такой вариант никогда нельзя исключать. Скорее всего, в еще более новой версии программы этот глюк будет устранен.

По мелочи

После прочтения в журнале # 35 (125) технической поддержки хотелось бы дополнить ответы на вопросы, данные читателям. О файле ntoskrnl.exe. Недавно столкнулся с таким фактом - после переустановки в рабочей системе Windows XP внутреннего модема с одного PCI-слота в другой, система слетела напрочь с жалобой в самом начале загрузки на отсутствие данного файла и невозможностью работы. Вылечилось это просто обратной установкой модема в этот слот.

О неактивной кнопке Accept на сайте Windows Update. Довольно часто встречается случай, что эта кнопка блокирована в силу того, что программа установки считает, что человек не прочитал до конца лицензионное соглашение, а должен это сделать обязательно. Все просто - нажимая кнопку PageDown и добираясь до конца текста соглашения, мы активируем этот пункт меню.

С уважением, Дмитрий

Какая связь между положением модема в слотах и жалобой системы на отсутствие файла, знает, видимо, только тот, кто эту систему придумал.

Место мыши вместо проблемы

В Upgrade # 39 (129) написано о проблеме посторонних звуков в динамиках при движении мыши под Windows Server 2003. У меня установлена Windows 98, мышь Genius оптическая, и указанная проблема меня раньше тоже весьма доставала. А решается она очень просто - достаточно убрать подальше мышиный провод (а не саму мышь) - и снова будет ТИШИНА...

С уважением, Ruslan

Звуковой тракт весьма чувствителен к электромагнитным полям и, если есть помехи, надо искать их источник, меняя местоположение всевозможных проводов и устройств, способных помехи создавать.

Пользователи QNX! Ау!

Наткнулся на вашу старую статью про операционную систему QNX, хорошая статья, но вы не упомянули про сетевые возможности ОС. Возможно, что ваша статья попадет на глаза менеджеру, ломающему голову, как охватить системой несколько офисов в разных частях города. И QNX могла бы ему в этом помочь.

Мне в QNX больше всего понравилась сеть и обмен данными между процессами через Send-Recive. Парадоксально, но многие программисты в угоду совместимости с POSIX пользуются очередями, теряя возможности RTS, да и программы получаются более громоздкие. Ваша статья, в основном, ориентирована на индивидуального пользователя, хоть и не "чайника". Но для дома вряд ли нужна эта ОС.

Разве что для экспериментаторов-энтузиастов. Можно, конечно, импортировать программы из Линукса. Наверное, такое делается. Было бы хорошо сохранять исходники у импортированных продуктов, тогда вполне можно обойтись без исходников у родных утилит и программ QNX. Мне это кажется важным.

С уважением, Александр Бахмет

К сожалению, я, что называется, до мозга костей (и зубной боли) пользователь Windows, а потому и подходил к QNX с точки зрения пользователя. Надеюсь, что ваши замечания вызовут интерес к этой необычной системе тех, кого возможности Windows в чем-то не устраивают, ведь система реального времени, применяющаяся, например, на американских истребителях (по слухам), явно того заслуживает. И узкий промышленный статус этой любопытной, практически не зависающей, ОС, благодаря интересу пользователей, теоретически вполне мог бы измениться.

Источник: http://www.computery.ru/upgrade/

***
Рекомендуем
Книга "Магия Твоих Текстов (2-ой том)"
Вторая книга трилогии «Магия Твоих Текстов» содержит большой набор уникальных и эффективных практических приемов, овладев которыми, вы вплотную приблизитесь к «гроссмейстерскому уровню» овладения гипнотическими технологиями создания безупречных рекламно-пиарных, художественных, и иных произведений.
В книге подробно объясняются малоизвестные профессиональные секреты, даются практические рекомендации, и вся она написана в превосходном, доступном для моментального восприятия стиле.
Рекомендуется всем, кто занимается рекламой, копирайтингом, сетевыми продажами и интересуется РЕАЛЬНЫМИ секретами профессионального скрытого влияния на аудиторию с помощью психотехнологий.
Узнать подробнее о книге "Магия Твоих Текстов (2-ой том)"


Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

Total Commander 6.0

Автор: Андрей Радзевич aka VampiR

Свершилось то, о чем так долго мечтали большевики. Камрады-разработчики выпустили новую версию замечательного файл-менеджера Total Commander. Сегодня мы с вами разберем его новые возможности и решим, стоит ли переходить на него.

Разработчик: Christian Ghisler
Сайт: http://www.ghisler.com.
Где взять: ftp://ftp.simtel.net/.2/simtelnet/win95/filemngr/tcmdr600.exe
ОС: WinAll.
Размер: 1,47 Мб.
Язык: английский
Распространение: shareware (30 дней, 28 уссурийских енотиков).
Русификатор: http://wincmd.ru/download.php?id=lang_rus (22 Кб)

Сразу после запуска в глаза бросается первое отличие. На панели, отображающей ваше текущее местоположение, теперь появились две кнопки.

Кнопка со звездочкой является своеобразным меню Избранное. В выпадающее меню вы можете добавлять ссылки на свои любимые папки, а затем практически мгновенно (все-таки вам нужно время, чтобы мышкой щелкнуть:)) открывать их. При нажатии на кнопку со стрелкой в выпадающем меню вы увидите ссылки на папки, которые вы посещали во время текущего сеанса.

Теперь Total Commander поддерживает мультиоконность. Нажатием сочетания Ctrl+T вы занесете текущую папку в закладку, располагающуюся под окном свойств диска.

Сохраняются они там и после выхода из менеджера. Закрыть их можно сочетанием Ctrl+W. Присутствует возможность блокировки закладок для защиты от случайного закрытия, возможность сохранять/загружать закладки в/из файла для восстановления в случае поломки:). Если вы выделили какие-то файлы на в окне одной из закладок, то выделение сохранится и при переходе на другие закладки.

Окно настройки преобразилось и лично для меня стало более удобным в использовании. В левой части окна расположены названия меню, а в правой (большей) — само окно редактирования. Теперь непосредственно из окна настройки доступны функции, изменение которых в более ранних версиях происходило только из in-файла.

Теперь результаты поиска можно представить в виде закладки и в любой момент перейти к ним (но только для текущего сеанса:().

В шестой версии улучшена работа менеджера фоновых операций. При перемещении или копировании по нажатии F2, если вы копируете или перемещаете несколько объектов, они не копируются одновременно каждый в своем процессе, а направляются в очередь фоновых операций. При копировании отображается скорость передачи данных и время до окончания копирования. Также присутствует возможность поставить ограничение для скорости копирования или перемещения (чтобы сильно не напрягать вашего железного друга).

Если вы хотите знать информацию о свободном месте на всех дисках и переходить в папку Мои документы не отходя от места, то вам необходимо включить опцию Show parent dir also in root of drive (Показывать вышестоящую папку […] также в корне диска): Configuration — Options… — Display — Show... (Конфигурация — Настройка… — Экран — Показывать…). Теперь, щелкнув по кнопке […] в корневой папке диска, вы перейдете в меню Мой компьютер.

При работе с внешними архиваторами (WinRAR, например) появилась возможность работы последних в фоновом режиме. Также теперь в rar-архив можно добавлять файлы и пользоваться синхронизацией, что не может не радовать:).

Появилась возможность работы с файлами, а также папками, которые содержат в названии китайские, турецкие или еще какие символы. Данной функции я по-детски радовался, ибо не далее как неделю назад долго и безуспешно пытался удалить посредством Total Commander'a пятой версии ссылку на файл с названием на арабском. Шестая версия справится с данной проблемкой на ура.

Правда, вам не дадут паковать данные файлы в архив и загружать посредством FTP-клиента.

Ниже приведены краткие сведения о некоторых других изменениях:
При удалении группы файлов менеджер заботливо сообщит вам название файлов, которые вы собираетесь удалить (ограничивается пятью названиями).
Теперь сочетание Ctrl+T отвечает за создание закладок, а Ctrl+M — за групповое переименование.
Синхронизация папок с учетом zip-архивов и даты создания файлов на FTP-сервере.
При запуске нескольких окон Total Commander'a они нумеруются.
Появилась возможность менять значки иконок у папок и файлов, расположенных на панели задач.

Что мы получаем в итоге? Качественный продукт, подтверждающий звание самого популярного файл-менеджера. Программа из раздела must have (из разряда must see на 200%:)). В отличие от стандартного проводника, не требует виртуозного владения мышью для работы. Total Commander gрост в освоении, а с появлением новых функций пользоваться им стало еще проще. Удачной инсталляции.

Источник: http://www.nestor.minsk.by/kg/

***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Антивирусная защита из Германии

Автор: Alex, editor@izcity.com

Сегодня у нас в гостях AntiVir PE - бесплатный антивирус германской сборки, включающий в себя антивирусный сканер, антивирусный монитор и базу данных более чем на 70.000 вирусов.

Проблема вирусов и борьбы с ними особенно актуальна для людей в той или иной степени, связанных с интернетом: будь то простой пользователь, праздно шатающийся от сайта к сайту, или человек, для которого интернет является профессиональной средой. Никому из них не хочется в самый неподходящий момент лишиться важной, наработанной информации, содержащейся на жёстком диске компьютера. Как же защитить себя от напасти различных компьютерных вирусов? Какое средство от таких тараканов выбрать?

Чтобы найти для себя эффективное и практичное средство для профилактики и борьбы с компьютерными вирусами, человеку приходится опробовать методом проб и ошибок различное программное обеспечение. Желательно, чтобы эти пробы были бесплатны.

Я уже рассказывал об антивирусном сканере Stop! Free Edition (смотрите Freeware-обзор в IZone 534) и маленькой утилите, которая обнаруживает и обезвреживает наиболее распространенных вирусов-червей последнего времени (смотрите Freeware-обзор в IZone 535). В этой же статье мы посмотрим на бесплатный антивирус AntiVir PE, который в конце 2002 года, занял почётное пятое место в двадцатке наиболее качественных антивирусных программ, подвергнутых тестированию представителями авторитетного журнала Троянер-Инфо.

Вообще, антивирус AntiVir PE - это рай для компьютерных чайников. Все настройки в программе сведены к минимуму.

Главное окно сканера, входящего в пакет антивируса AntiVir PE, является классическим образцом антивирусных программ последнего времени. Пользователю нужно лишь выбрать директории, в которых содержатся файлы, предназначенные для антивирусной проверки, и нажать на кнопку сканирования, всё остальное программа сделает сама.

Процесс проверки файлов на наличие вирусов отображается в отдельном окне, в котором ведётся статистика сканируемых объектов.

Если пользователю нужно проверить отдельный файл или папку, то удобнее всего воспользоваться пунктом контекстного меню, вызываемого правым кликом мышью по файлу или папке (опять же классика антивирусостроения).

Отдельно стоит отметить работу антивирусного монитора, входящего в состав антивируса AntiVir PE. Монитор запускается вместе с операционной системой и проверяет все файлы, которые могут быть заражены. От пользователя не требуется никакой настроек, разве что для интереса можно посмотреть окно статистики, кликнув два раза мышкой по значку монитора в трее.

Разработчики AntiVir PE не стали изобретать ничего нового, они просто взяли и сделали добротную антивирусную программу с дружеским к пользователю интерфейсом.

Подводя итог, добавлю несколько положительных свойств бесплатного антивируса AntiVir PE:

  • Антивирусная база более чем 70.000 вирусов.
  • Нахождение и лечение файлов, заражённых неизвестными макровирусами.
  • Обеспечение надёжной защиты от загрузочных вирусов.
  • Интуитивно понятный интерфейс.
  • Возможность регулярного обновления антивирусных баз через интернет.

Антивирус работает в операционных системах Windows 9х/ME/NT/2K/XP.

Скачать AntiVir PE можно отсюда (3876 кб)

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Ионизаторы воздуха
Хотите не болеть и жить долго? Дышите чистым воздухом! В условиях загрязненного города, тем не менее можно дышать у себя дома чистым лесным, морским или горным воздухом. А поможет нам в этом ионизатор.
Подробнее >>
***

Несессер сетеману

Автор: Сергей УВАРОВ

Среднестатистический современный пользователь, обращающийся к возможностям Интернета в повседневной работе, имеет стандартный набор ПО: браузер, почтовик, программу для обмена короткими сообщениями и т.п. Истинные же сетеманы как правило стремятся расширить этот несессер, благо в Сети попадаются различные более специфический, но все же достаточно полезный софт. Нынешний обзор посвящен различным утилитам для повышения комфортности и удобства работы в Интернете. Предлагаю всем любознательным коннектиться и запускать качалки. Мы начинаем…

Flexiblesoft Dialer II 3.44

Разработчик: Flexiblesoft Company (http://www.flexiblesoft.com/)
Статус: trial
ОС: Windows 9x-XP
Интерфейс: многоязычный
Размер дистрибутива: 1.57 Мб

А начнем мы, как и полагается сетеманам, с установки коннекта с провайдером. Поскольку стандартными средствами Windows нам, продвинутым, пользоваться негоже, впору бы возжелать утилиту с более широкими возможностями. В принципе, если пользователь обладает довольно приличной телефонной линией вкупе с цифровой АТС, стандартного сервиса этой ОС ему должно быть вполне достаточно. Однако сегодня большинству пользователей хорошее качество связи при модемном доступе еще недоступно. Поэтому и пользуются интернетчики различными звонилками, одну из которых — Flexiblesoft Dialer II — мы и рассмотрим.

После установки утилита предлагает пользователю конвертировать текущие настройки удаленного доступа в свой формат, либо создать новое подключение. Программа поддерживает несколько соединений, имеет широкие возможности их настройки. Это и расширенные функции автодозвона, позволяющие при подключении к провайдеру прозваниваться по неограниченному числу телефонных номеров, настройка промежутка времени, по истечении которого при отсутствии связи программа будет менять номер. Также можно резервировать одни номера для дневного времени, другие — для ночного. Контроль скорости соединения также можно отдать под контроль программе, велев ей подключаться только на скорости не ниже установленной (например, 31 200).

Наверняка вы встречались с ситуацией, когда связь с провайдером как бы замерзала, неразлучная парочка мониторов в трее переставала перемигиваться, при этом Windows считала, что все в порядке и не разрывала коннект. Исправить данное недоразумение поможет функция ping, которая в определенные промежутки времени будет пинговать удаленный сервер провайдера и при отсутствии ответа с его стороны заново производить дозвон.

Что еще добротно реализовано в утилите, так это ведение статистики. Подсчет ведется по каждому конкретному соединению, за неделю или месяц. Причем, кроме подсчета затраченных денег, ведется подсчет трафика и его визуальное отображение.

Из дополнительных возможностей программы выделю:

  • встроенный планировщик заданий;
  • автозапуск приложений и документов при различных режимах работы программы;
  • звуковое оповещение различных действий;
  • возможность корректировки системного таймера по серверам точного времени.

Flexiblesoft Dialer обладает современным интерфейсом и имеет поддержку стилей (несколько «имиджей» поставляется с программой), интерфейс многоязычный, включая русский, trial-версия утилиты имеет ограничение в 50 запусков, скачать ее можно с http://www.flexiblesoft.com.

А теперь перейдем к подсчету трафика…

Looker-onLine 2.6

Разработчик: Демочко Артем (http://looker.by.ru)
Статус: freeware
ОС: Windows 9x-XP
Интерфейс: русский
Размер дистрибутива: 503 Кб

Программа отличается удобством в работе, непритязательным интерфейсом и всеми необходимыми опциями для ведения статистики работы в Интернете. Утилита позволяет подсчитывать входящий и исходящий трафик и время работы не только по отдельным сессиям, но и общую статистику за каждый день или месяц. Время работы в Интернете программа считает по введенным пользователем тарифам (дневной, ночной), при этом отпадает необходимость подключения к сети, чтобы узнать текущий баланс на счету.

Из дополнительных опций программы можно выделить:

  • встроенный «напоминатель», который извещает пользователя в указанное время о важных делах, запускает программу или открывает заранее указанные web-страницы;
  • возможность учета тарифов для нескольких провайдеров;
  • дозвон до провайдера из программы.

Программа не навязывает пользователю свое присутствие, сразу же после загрузки поселяясь в трей и активируясь только при подключении к Интернету; с помощью «напоминателя» можно указать время автоматического отключения от Сети.

Несмотря на то, что программа бесплатна, требуется ввод ключа и серийного номера, получаемых на сайте автора.

Загрузить Looker on-Line можно с http://looker.by.ru/download/looker-setup.zip.

Any Speed 1.4

Разработчик: PY Software (http://www.pysoft.com)
Статус: freeware
ОС: Windows 9x-XP
Интерфейс: английский
Размер дистрибутива: 880 Кб

Однако не только статистические данные могут быть полезны пользователю. Не менее ценна будет и информация о реальной скорости обмена данным между пользователем и конкретным сайтом, другим компьютером в сети или провайдером, предоставляющим доступ в Интернет. Для этих целей подойдет небольшая утилита Any Speed, позволяющая довольно быстро определить реальную скорость передачи данных между пользователем и необходимыми сайтами или компьютерами.

Достаточно указать требуемый адрес (IP компьютера или адрес web-сайта), определить параметры пингования сайта и размер тестового файла и нажать кнопку Старт. После чего программа начнет пинговать удаленный сервер, при этом отображая скорость получения данных в графическом и цифровом виде. Паузы и количество запросов, которые посылает программа, настраиваются произвольно. С помощью Any Speed можно определить, на каких участках Сети происходит замедление скорости передачи.

Загрузить утилиту можно с http://www.activewebcam.com/Downloads/anyspd11.zip.

SmartWhois 3.6

Разработчик: Tamo Soft, Inc. (http://www.tamos.ru)
Статус: trial
ОС: Windows 9x-XP
Интерфейс: многоязычный
Размер дистрибутива: 1,31 Мб

А что прикажете делать, если позарез :-) нужно получить детальную информацию об интересующем домене или неизвестном IP-адресе? Такое возможно благодаря наличию онлайновых сервисов Whois, предоставляющих полную информацию о введенном домене или IP-адресе. Список таких серверов очень широк, поэтому софтовые сайты пестрят утилитами для более удобной работы с этим сервисом. SmartWhois — одна из альтернатив онлайновым серверам. Интерфейс программы русифицирован и вполне интуитивен. Запросы делаются на получения сведений об IP-адресе или домене, причем имеется возможность ввода нестандартного запроса. После установки программа добавляет свой значок на панель инструментов Internet Explorer'a, что очень удобно, если нужно проверить информацию о текущем загруженном сайте. Скорость работы программы не вызывает нареканий — информация доставляется примерно за 5—10 секунд, благо список whois-серверов довольно велик. Полученные сведения (как для одного, так и нескольких доменов) можно сохранить в различных форматах (.txt, .xml, .html), а также как архив SmartWhois.

Trial-версия программы работоспособна на протяжении 30 дней, загрузить ее можно с http://www.tamos.ru/sw3.zip.

Internet Explorer Text Archiver 4.0

Разработчик: PC911 (http://www.pcnineoneone.com/)
Статус: freeware
ОС: Windows 9x-XP
Интерфейс: английский
Размер дистрибутива: 7 Кб

Вариантов сохранения web-страниц придумано множество. Это и стандартное сохранение текущей открытой страницы, и использование оффлайн-браузеров, и копирование части страницы с ее последующей вставкой в текстовый редактор… И все же, когда требуется сохранить лишь часть текста на web-странице, вышеназванные варианты не всегда удобны. Альтернативой им может стать использование Internet Explorer Text Archiver'a. Программа представляет собой скрипт, при помощи которого необходимый абзац (кусок) текста на web-странице можно сохранить буквально в два клика, щелкнув правой кнопкой мыши и выбрав из контекстного меню пункт Archive Selected Text. При этом пользователю будет предложено целых три варианта имени сохраненного файла. Все сохраненные файлы записываются в папку, указанную пользователем.

Бесплатность, минимальный размер, простота установки скрипта и возможность намного быстрее сохранять требуемые части текста web-страниц действительно подкупают. На мой взгляд, ради этого имеет смысл наведаться по следующему адресу: http://www.pcnineoneone.com/tweaks/ietextarchiver.zip.

Citycat by Email 1.15

Разработчик: Алексей Шамис (http://sapisoft.by.ru)
Статус: freeware
ОС: Windows 9x-XP
Интерфейс: английский
Размер дистрибутива: 383 Кб

Сегодня многие интернет-пользователи узнают море полезной информации, не только посещая интересующие их ресурсы, но и подписавшись на рассылку новостей. Упростить подписку на рассылки с различных тематических сайтов призван сервер Subscribe.ru, имеющий в своей базе тысячи сайтов, а упростить работу с сервером поможет небольшая утилита Citycat by Email, позволяющая работать со списками рассылок посредством электронной почты. Вам больше не нужно тратить время в онлайне, достаточно скачать базу данных с имеющимися сайтами, разбитыми на тематические разделы. После чего можно с легкостью подписываться и отписываться от рассылок, искать требуемый сайт по каталогу, посредством программы заказывать прошедшие выпуски рассылок.

Утилита имеет интуитивно понятный интерфейс, умеет сортировать подписанные рассылки по алфавиту, понимает горячие клавиши, абсолютно бесплатна. Загрузить утилиту можно тут — http://sapisoft.by.ru/soft/citycat.rar, по отдельному адресу можно заполучить последнюю базу данных со списком имеющихся на сервере рассылок (http://sapisoft.by.ru/soft/base.zip).

(Продолжение следует)

Источник: http://www.mycomp.com.ua/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
 См. подробнее: http://www.izcity.com/ebay/


Ускорь свой Интернет!

Автор: Владимир Степанов
http://spacesoft.narod.ru/

Каждый из нас желает добиться максимальной, для своего модема, скорости передачи данных в Интернете. Существует немало программ для оптимизации модема и интернет-соединения, и сегодня мы о них поговорим.

Я решил представить вам две программы из этого класса, лучшие, на мой взгляд, это Modem Booster и Throttle.

Modem Booster 3.0 (ShareWare, английский интерфейс, Win 9x/Me/NT/2000/XP, 1.74 мб)
Throttle v.5.11.17.2003 (ShareWare, английский интерфейс, All Windows, 842 кб)

С установкой программ проблем, думаю, не будет, поэтому описывать ее не буду и сразу перейду к самому процессу оптимизации.

Итак, для того чтобы Modem Booster оптимизировал ваш модем необходимо наличие соединения с Интернетом на протяжении всего процесса оптимизации. Modem Booster будет подстраивать параметры вашего модема, до тех пор, пока они не будут соответствовать настройкам вашего провайдера. Программа не требует вашего вмешательства в процесс оптимизации. Просто выберете Автооптимизация (есть и ручная), и программа все сделает за вас. После запуска, программа в автоматическом режиме выполнит нужные настройки и сохранит их в системе. Процесс оптимизации может занять от 1 до 2 часов и может изменяться.

После того как Modem Booster выполнит все необходимые операции появиться окно результатов.

В окне результатов будет приведена статистика оптимизации:

Extreme Performance - результат сравнения между самой быстрой и самой медленной скоростью вашего модема ПЕРЕД оптимизацией. Если процент очень высокий, это означает, что вашу скорость модема можно на много увеличить.

Average Performance - результат сравнения средней скорости модема при первоначальных значениях и при оптимизированных значениях. Если Вы получаете 0%, то средняя скорость вашего модема до оптимизации равна средней скорости после оптимизации. Следовательно, ваши первоначальнальные параметры модема оптимальны, но если у вас больше 0%, это означает что параметры модема не оптимальные

Best of the Best Performance - результат сравнения лучшей скорости модема до оптимизации и после. Если Вы получаете 0%, то ваши параметры модема были оптимальны, но если вы получаете не 0%, то ваш модем был оптимизирован на то количество %, которое указано в этой строке.

Для того чтобы Moodem Booster использовал оптимальные параметры модема необходимо выходить в Интернет при помощи встроенной в Modem Booster звонилки.

Полнофункциональная trial-версия программы работает только 21 день.
Скачать Modem Booster можно здесь.

Теперь рассмотрим более простую программу Throttle.

В окне программы выбираете свою операционную систему и тип соединения (modem, DSL/ADSL modem, cable modem, ISDN modem). Функция Speed Setting оптимизирует ваш модем. Speed Setting содержит два уровня оптимизации:

Fast - быстро
Fastest - самый быстрый

Передвигаете указатель в нужное положение и нажимаете Go, после чего программа потребует перезагрузить компьютер. После перезагрузки параметры вашего модема будут настроены на оптимальную работу.

В не зарегистрированной версии указатель в положение Fastest передвинуть нельзя.
Скачать Throttle можно отсюда.

И от себя добавлю, что необходимо перепробовать не одну пару подобных программ, чтобы добиться от своего модема максимальной скорости.

***
Рекомендуем
Программа "Кадры". Автоматизация работы кадровой службы
Программа "Кадры" достаточно известна в области кадрового учета в России и странах СНГ. Ею уже сейчас пользуются более 800 российских и совместных предприятий. Присоединяйтесь!
Подробнее >>


Такая вот паранойя

Как не болеть и жить долго? Ионизаторы воздуха
Как не болеть и жить долго в условиях загрязненной экологии и городской среды?
Поставьте себе ионизатор в квартире и дышите чистым воздухом!
Как в лесу, на море или в горах.
Подробнее >>
***

Такая вот "паранойя"

Автор: Киви Берд

Программисты, работающие над ядром ОС Linux, обнаружили и заделали в исходных кодах «черный ход», «прорытый» столь хитро и искусно, что отныне досужие разговоры о неуловимых троянцах в программах больше не кажутся параноидальным бредом даже скептикам.

Обнаруженная дыра представляет собой две строчки кода, тщательно замаскированные под невинный контроль ошибок, добавленный к функции системного вызова wait4(). Эта функция доступна любой программе, работающей на компьютере, и, грубо говоря, дает операционной системе указание сделать паузу в исполнении данной программы, пока другая программа не завершит работу. На первый взгляд казалось, что добавка к коду просто проверяет, не использует ли программа, вызывающая wait4(), некую недопустимую комбинацию двух флагов и не запущена ли она пользователем с максимальными привилегиями (root). Если оба условия выполняются, то вызов прерывается.

Но при внимательном рассмотрении выяснилось, что код вовсе не проверяет, является ли пользователь всемогущим root. На самом деле, если обнаруживается нужное сочетание флагов, то вызвавший его процесс получает максимальные привилегии и моментально превращает wait4() в «черный ход». Другими словами, человек, знающий нужное сочетание флагов и место, где их следует установить, получает полный контроль над любой Linux-машиной. И вся эта гигантская разница — между тем, как код выглядит и что он в действительности делает, — заключена всего лишь в одном знаке на языке Си. Если бы этот нюанс обнаружили при обычных обстоятельствах, то наверняка сочли бы за элементарную ошибку программиста.

Суть же в том, что этот баг был выявлен при весьма подозрительных обстоятельствах. Хост-компьютеры для сайта коллективной разработки ядра Linux предоставляет софтверная компания из Сан-Франциско BitMover. Ее основатель Ларри Маквой (Larry McVoy) одновременно является и главным архитектором базы данных BitKeeper, управляющей исходными кодами Linux. По его словам, система «параноидально озабочена» целостностью разрабатываемых кодов и осуществляет обновления только в автоматическом режиме, с тщательной проверкой цифровых подписей. Именно благодаря этому сразу же была засечена попытка «по-тихому» обновить две строчки кода вручную. Сам Маквой поначалу не увидел в коде ничего подозрительного, но на всякий случай вынес обновление на суд сообщества программистов, где и выявился истинный смысл «ошибки», порождающей «троянского коня». Закладка была немедленно исправлена, так что, по всей видимости, злоумышленник не успел ею воспользоваться.
После тщательного анализа стало очевидно, что создавшие этот код люди прекрасно знают, что делают. Они отыскали именно такие флаги, которые по отдельности не вызывают ошибок, но при этом не используются совместно. По мнению экспертов, это мог сделать только человек, прекрасно разбирающийся в UNIX и нюансах работы ядра Linux. Как прокомментировал находку один из экспертов: в народе давно гуляют слухи об изощренных, невидимых закладках, но до сих пор попадались лишь слабые и несовершенные образцы троянов, теперь же мы получили конкретный пример действительно хорошего кода.

Источник: http://www.computerra.ru/

***
Рекомендуем
Хотите сыграть в пейнтбол?
Отличительная черта этой игры - ее полная демократичность. Маркер (оружие для игры в пейнтбол) уравнивает в правах всех - от банкиров и дипломатов до студентов и инженеров. Когда все облачены в камуфляж и маски, то разница в социальном статусе практически незаметна.
Подробнее >>


Информация

Свежие номера здесь! Служебная информация
  • Реклама в журнале
  • Для авторов, желающих публиковаться
  • Условия использования материалов
  • Подписка на рассылку

Реклама в журнале

Версия от 15.09.2003г.

Информация о журнале:
От обычных рассылок, рассылаемых по почте, журнал отличается тем, что это не одинарный листок с информацией, а действительно полноценный электронный журнал (содержащий внутри себя массу страниц с информацией и графикой, систематизированными по рубрикам).
Большинство пользователей, скачивающих журналы - создают у себя на компьютере электронную библиотеку, т.е. хранят у себя на компьютере архивы журналов.
Соответственно, рекламная информация размещенная в журнале - имеет гораздо более длительный "срок жизни", чем реклама в обычных рассылках.

Количество загрузок каждого номера вы можете посмотреть здесь: http://www.izcity.com/down/doc0.html
В среднем порядка не менее 15-20 тыс. человек скачивают и читают каждый номер. Количество постоянных читателей (как минимум раз в месяц загружающих и просматривающих какой-либо выпуск журнала): не менее 50 тыс. человек
Периодичность выхода журнала: 8-10 выпусков в месяц.

Расценки:

Где размещено | Тип рекламы | 1 выпуск | 3 выпуска | 10 выпусков
Главная страница журнала | баннер 468х60 вверху | $5 | $10 | $20
 | Статья до 5000 знаков | $5 | $10 | $20
Внутри журнала баннер (сквозной по журналу, на всех страницах со статьями, кроме главной и нескольких служебных) | баннер 468х60 вверху | нет | нет | $20
 | баннер 468х60 внизу | нет | нет | $15
Статья рекламная внутри журнала | Статья до 7000 знаков | $2 | $5 | $12

Примечание:

  • Текст вместо баннера: вместо баннера вверху или внизу можно размещать текстовый блок до 300 знаков или текстово-графический блок (помимо текста может присутствовать небольшая картинка)
  • Бесплатно: в вашей статье или материале могут также присутствовать одно или несколько графических изображений общим "весом" не более 30 кб.
  • При подсчете знаков html-тэги не учитываются, а пробелы учитываются.
    Для того, чтобы правильно подсчитать знаки в вашем рекламном объявлении - используйте, например текстовый редактор Word. Скопируйте в него ваш текст, а затем в меню Word найдите пункт Статистика. Все сразу и увидите.
  • Форматы присылаемых текстовых блоков, материалов и статей:
    HTML, HTM, Word (doc) или RTF. Если статья с графикой, то можете все это дело упаковать в zip-архив и в таком виде прислать нам. Обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам.

Как платить?
Все расчеты производятся при помощи платежной системы WebMoney.
Наши кошельки:
Z906510760241
R211650054260
Если вы не знакомы с этой платежной системой, то зайдите к ним на сайт, почитайте. Все на русском языке, просто и понятно. Денежные переводы и расчеты производятся моментально, в режиме реального времени через Интернет.

Порядок оформления рекламного заказа:
- Переводите нужную сумму денег на наш кошелек в системе Webmoney
- В примечании к переводу оставьте какой-нибудь комментарий, в котором укажите ваш емейл или адрес сайта, или фамилию, или название организации. Чтоб мы могли понять, от кого пришли деньги...
- Затем присылаете письмо с сообщением о переводе денег и вашим рекламным текстом (статьей) или баннером.
- Ваша реклама выходит в ближайшем свободном выпуске журнала (в течении 2-4 дней).

По вопросам размещения рекламы обращаться: reklama@izcity.com
Дополнительно смотрите другие наши рекламные услуги

Вверх | На главную

Для авторов

Версия текста от 19.10.2003г.

Хотите публиковаться?
Стать нашим автором несложно... Если вы пишете статьи, если вы считаете, что они интересно, талантливо написаны, то у нас с вами есть повод для сотрудничества.
Нас интересуют статьи, описания, руководства... Тематика: компьютеры, Интернет, программы; описания утилит; обзоры железа, периферии, софта; примеры решения каких-либо компьютерных проблем и т.д. В общем интересно все, что относится к компьютерной тематике и Интернету.

Требования к материалам:

  • Статьи принимаются к публикации у нас только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Актуальность, ясность и простота изложения, последовательность и логичность, четкость формулировок и аккуратное использование терминов, точность в научных и технических сведениях. В статье могут быть указаны реквизиты автора: емейл, ссылка на сайт и т.д. Дополнительно: в двух-трех предложениях автор может написать о себе. Также может выразить благодарность компаниям или лицам, оказавшим помощь при подготовке материала. Соответственно могут быть указаны реквизиты организаций, предоставивших продукты или программы для тестирования или обзора.
  • Форматы присылаемых материалов: DOC (Microsoft Word), RTF, HTML (HTM).
    Если вы используете в статье графику (логотипы, скриншоты и т.д.), то сразу вставляйте графику в HTML. Графика не должна быть громоздкой и иметь большие размеры. Желательно не более 30 кб. графики (общий "вес") на одну статью... Кроме того, изображения (картинка, скриншот) в статье не должны превышать 370 пикселей в длину по горизонтали.
    Проверьте правильность ссылок. Статью и графику к ней будет логичным объединить в один каталог, упаковать архиватором и в таком виде переслать нам.
    Если ваша статья без графики и состоит из одной страницы, то этот документ можно просто прислать вместе с письмом.
  • Отсутствие ошибок: грамматических и орфографических (проверяйте тексты в Word, плюс сами читайте, перед тем как нам отправлять...)
    Обратите внимание: обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам... Статьи, содержащие много ошибок - не публикуются!
  • Статьи о спонсорах и заработке - грамотные содержательные статьи общего плана публикуются бесплатно. Статьи рекламного характера, с реферральными ссылками публикуются на правах рекламы
  • Рекламные статьи любой тематики (явно рекламирующие компанию, платные продукты или услуги) публикуются на правах рекламы.

Взаимоотношения с авторами:
Денег мы не платим, однако мы предлагаем альтернативные варианты поощрений для авторов. Для начала скажем, что понятное дело - вы в статье можете указать свои авторские реквизиты: емейл, ссылку на свой сайт и т.д. Таким образом, вы получите дополнительный приток людей на свой сайт. Ведь, не секрет, что хорошая статья о каком-либо продукте или услуге, со ссылкой на сайт - неизбежно вызовет приток посетителей на этот сайт.
Если вы достаточно часто будете публиковать статьи, то за вами вполне может закрепиться имидж эксперта в той или иной области.

А теперь о поощрениях за опубликованные у нас статьи:
За каждую статью, опубликованную в нашем журнале вы получаете бесплатно рекламный блок в нашей рассылке IZone Web (это правило действует с 14.08.2002г.; о рассылке IZone Web: на 19.10.2003 г. более 150 тыс. подписчиков, статистику на сегодняшний день можно посмотреть с этой страницы: http://www.izcity.com/info/reklama2.htm).
Рекламные блоки предлагаются в следующем соотношении:

  • Статья до 5000 знаков - текстовый блок до 200 знаков

  • Статья до 7000 знаков - текстовый блок до 300 знаков

  • Статья до 10000 знаков - текстовый блок до 500 знаков

Рекламные блоки бесплатно размещаются в нижней части рассылки IZone Web. Можно присылать заявку на размещение вашего рекламного блока после каждой вашей статьи. Можно опубликовать несколько статей у нас, а потом спустя некоторое время прислать заявку на размещение группы ваших блоков.

Если вы подаете заявку на размещение у нас рекламного блока после каждой вашей статьи, то форма подачи заявки следующая:
Присылаете письмо, в котором должны обязательно присутствовать следующие моменты:
- Название вашей статьи, количество знаков без пробелов в статье и номер выпуска журнала, в котором ваша статья опубликована.
- Текст вашего рекламного блока (объявления)
Ваш рекламный блок выйдет в одной из ближайших рассылок (в течение 2-4 дней).

Если вы подаете заявку на размещение у нас сразу нескольких рекламных блоков после публикации нескольких ваших статей, то форма подачи заявки следующая:
- Названия ваших статей, количество знаков без пробелов в каждой статье и номера выпусков журнала, в котором ваши статьи опубликованы.
- Текст вашего рекламного блока (или блоков).
- Ваши комментарии по вашей рекламе у нас (количество раз публикаций которые вам причитаются; также в зависимости от этого текст и размеры у рекламных блоков могут быть одинаковыми, а могут быть и разными). Пожалуйста четко указывайте в ваших комментариях все нюансы, чтобы мы вас поняли с первого раза.
Ваша рекламная кампания начнется в одной из ближайших рассылок (в течение 2-4 дней) и будет продолжаться положенное вам количество времени (выпусков рассылки).

Обратите внимание:

  • Вы имеете право на получение бесплатного рекламного блока только в случае факта публикации вашей статьи.
  • Статьи принимаются нами только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Присланные нам статьи не резензируются, не комментируются, не возвращаются. В переписку с авторами, редакция не вступает.

P.S. Мы оставляем за собой право:

  • На распространение копий присланных нам материалов
  • Не публиковать материалы противоречащие нашей концепции.
Статьи для публикации присылать на адрес editor@izcity.com, тема: avtor

Рекламные блоки для размещения в нашей рассылке присылать на адрес reklama@izcity.com, тема: free

Вверх | На главную

Условия использования материалов

Использование материалов нашего журнала регламентируется настоящими правилами (с 15.09.2003г.).

Использование CHM-файлов
Если вы хотите использовать у себя полностью chm-файлы с номерами журналов (например, вы провайдер и хотите выложить журналы у себя на ftp-сервере, или у вас архив софта и вы хотите некоторые архивы журналов держать у себя на сайте), то нет никаких проблем... Можно использовать при соблюдении следующих факторов:
1. Нельзя ничего внутри изменять (ну это, как вы знаете - общее правило...).
2. При использовании обязательна ссылка на нас. Ссылка должна указывать на наш сайт http://www.izcity.com

Использование отдельных статей из выпуска
Наши собственные статьи, т.е. статьи наших авторов (отсутствует под статьей ссылка на источник) - можно использовать с указанием ссылки на наш сайт http://www.izcity.com
Использование статей с других источников (под статьей есть ссылка на источник информации) - запрещено.

О наших материалах
Информационную начинку нашего журнала составляют, как материалы собственных авторов, так и дайджест с наиболее популярных компьютерных ресурсов Рунета. Все публикуемые у нас материалы - юридически чисты. Каждый материал (или статья) в нашем журнале имеет своего автора или правообладателя (собственника прав на статью). Все материалы публикуются либо с разрешения авторов или владельцев авторских прав, либо присылаются ими непосредственно в редакцию IZone для публикации.

Вверх | На главную

Подпишитесь на нашу рассылку IZone WEB!
Своевременно полученная информация - залог успеха. Для того, чтобы всегда быть в курсе всех наших новинок - подпишитесь на нашу рассылку. Удобно и практично: наша информация будет доставляться в ваш почтовый ящик. Периодичность рассылки: 3 раза в неделю.
Наши подписчики получают краткую аннотированную информацию обо всех новинках нашего сайта. Это выход свежих номеров журнала "Internet Zone", бесплатные программы, различные утилиты, средства и сервисы для создания и "раскрутки" сайта, различная компьютерная документация и т.д.
Для подписки на рассылку - посетите нашу страницу подписки в Интернет по адресу: http://www.izcity.com/info/sub.htm либо воспользуйтесь формой справа (необходимо подключение к Интернет)
Подписка на рассылку
Рассылка MailList.Ru

Вверх | На главную


Работа с журналом

Помощь при работе с журналом

Свежие номера здесь! Версия текста от 28.11.2003 г.

Системные требования

Операционная система, начиная от Windows98 и выше.
В системе должен быть установлен браузер Internet Explorer версии начиная от 5.0 или выше.
!!! Обязательно в браузере должны быть включены: поддержка java-скрипт, показ рисунков и анимации.
Разрешение экрана монитора желательно должно быть не менее, чем 1024х768.

Для тех, кто в первый раз...

Что такое CHM?

Compiled HTML - специально разработанный Microsoft формат данных для поддержки гипертекстовых справочных систем. Не требует специальных средств для просмотра. Всё уже есть в Windows. В этом формате сделаны справки к браузерам IE, начиная с четвертой версии и выше, справка к Microsoft Office и т.д.

Как лучше начать просмотр выпуска журнала?

Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню слева и выбрать Открыть все. Данная операция одним махом открывает все вложенные в папки страницы. По окончанию просмотра журнала, аналогично можно выбрать Закрыть все.
Весьма удобно - пользуйтесь. Можно открывать рубрики и поодиночке - используйте крестик слева от папки/рубрики.

Навигация: кнопки вверху

Назад/Вперед
Данные кнопки аналогичны одноименным кнопкам в браузере. Служат для быстрого перемещения между просмотренными страницами

Домой
Нажав на эту кнопку, вы попадете на стартовую страницу

Шрифт
Весьма полезная кнопка. Регулирует размер шрифтов для просмотра. Нажимаете и все. Шрифты меняются по кругу. Обязательно найдется устраивающий вас размер шрифта. Если установки размера шрифтов по умолчанию вас устраивают, то можете вообще не пользоваться данной кнопкой.

Печать
Вывод на печать необходимой вам страницы. Если у вас установлен принтер, то можете пользоваться.

Параметры
Различные настройки и команды.

Навигационное меню слева

- В зависимости от размеров вашего монитора, вы можете зацепить мышкой и расширить/сузить границу-бордюр между навигационным меню и правой частью журнала со статьями.

- Одинарный щелчок мышкой по крестику слева от папки/рубрики (или двойной щелчок по названию) открывает содержимое папки. Обратная операция: щелчок мышкой по минусу (или двойной щелчок по названию) - закрывает папку/рубрику.

- Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню и в зависимости от текущего состояния папок, вы можете выбрать Открыть все/Закрыть все. Данная операция одним махом открывает/закрывает все вложенные в папки страницы.

- Если вы усиленно используете принтер, то здесь же, щелчком правой кнопки мышки по папке можно выбрать варианты печати.

- В Навигационном меню также присутствует вверху закладка Избранное. При просмотре вы можете понравившиеся статьи заносить в Избранное для последующего быстрого доступа к этим статьям.

Разное

Просмотр страниц

При щелчке правой кнопкой мышки по просматриваемой странице - появляется меню с командами.

Используйте клавиатуру

При просмотре выпуска удобно использовать клавиши клавиатуры. Например, клавиши Page Up и Page Down служат для быстрой прокрутки. А вот клавиши справа внизу на клавиатуре со стрелками вверх и вниз - удобно использовать для плавной прокрутки читаемой страницы.

При просмотре CHM-выпуска журнала вместо рисунков вижу только рамки, а сами рисунки не видны.
Также не мигает, как бы застыл анимированный баннер внизу некоторых страниц.

Для корректной работы CHM-формата требуется установленный в системе браузер Internet Explorer и соответственно CHM-формат использует его настройки. В вашем браузере отключен показ рисунков и анимации. Включите их (Сервис > Свойства обозревателя... > вкладка Дополнительно)

Каким образом открыть отдельную страницу выпуска в отдельном окне браузера Internet Explorer?

Кликнуть правой кнопкой по любому месту на странице, в появившемся контекстном меню выбрать "Свойства", значение поля "Адрес (URL)" скопировать в буфер обмена, вставить в адресную строку IE и нажать Enter (или кнопку "Переход" в браузере). Нужная вам страница откроется в браузере
(правда, обратите внимание: при попытке сохранить такую страницу на диск в виде html - сохранится только текст, без картинок, хотя при просмотре картинки будут доступны).

Как сохранить на диск (в формате HTML) одну или несколько понравившихся мне статей (или даже целиком весь выпуск) полностью со всем оформлением, включая и графику?

Для этого придется распаковать/декомпилировать весь выпуск. См. здесь: http://www.izcity.com/info/chm.htm

Как осуществить поиск в пределах одной страницы?

Используйте сочетание клавиш Ctrl-F.

Как распечатать текущую страницу?

Используйте сочетание клавиш Ctrl-P.

В chm-выпуске вашего журнала нашел интересующую меня программу. Как ее скачать не браузером, а моей качалкой, т.е. download-менеджером?

Рассмотрим данный момент на примере популярной качалки FlashGet (http://www.amazesoft.com/). Итак, вот несколько способов для того чтобы скачать нужный вам файл, используя качалку.

1. Первый способ. Стандартный, не требующий от вас лишний телодвижений. Если ваша качалка интегрирована с браузером (производит слежение за кликами), то никаких проблем возникнуть не должно. При клике по ссылке, будет происходить запуск качалки. Если этого не происходит, то проверьте за какими типами файлов ваша качалка производит слежение. Например, во FlashGet по умолчанию не "заряжено" слежение за avi-файлами. Добавьте этот формат вручную в настройках FlashGet.

2. Второй способ: откройте у FlashGet Корзину (выберите в настройках ее показ). И теперь при просмотре chm-выпуска журнала - просто мышкой перетаскивайте нужные вам ссылки в Корзину FlashGet. Вуаля!
Помимо FlashGet, Корзинку имеют и все другие продвинутые качалки. Например, ReGet и т.д.

3. Если файлов, которые нужно скачать, на странице очень много, например 30-40 шт.:), то можно вообще открыть нужную вам страницу в отдельном окне браузера Internet Explorer (см. выше как это сделать), ну а далее выберите в контекстном меню браузера (щелчок правой кнопкой по странице) команду: Закачать все при помощи FlashGet. В появившемся окне FlashGet вручную или с помощью фильтров можно подкорректировать опции загрузки (если что-то ненужное попадет в список загрузки).


IZone

Свежие номера здесь!
IZONE
552
4.12.2003

Полезный совет:
Щелкните правой кнопкой мышки по любому месту в меню слева и выберите Открыть все.

Полезный совет-2:
Почитайте как работать с журналом в папке Your help

Полезный совет-3:
Скачайте другие
выпуски

IZONE
электронный
компьютерный журнал
о высоких технологиях
Читай лучшее!

9-ти язычный говорящий переводчик ASSISTANТ AT-2092

Впервые карманный переводчик выполнен в виде КПК с сенсорным экраном.
Впервые многоязычный переводчик имеет такой большой обьем слов - по 20 тысяч слов на каждый язык и большой разговорник на 2 тысячи фраз.
Впервые переводчик имеет синтезатор речи на всех языках
(английский, немецкий, китайский, японский, корейский,
русский, французский, испанский, итальянский).

ASSISTANT AT-2092

Технические характеристики AT-2092

Синтезатор речи | на 9-ти языках
Записная книжка | 32 кб
Калькулятор | 12 разрядный
Часы | да
Календарь | да
Будильник | да
Мировое время | да
Пересчет валют | да
Метрическое преобразования | 8 пар единиц измерения
Дисплей | сенсорный
Подсветка | да

Цифровые диктофоны
DAINET
Купить ASSISTANT AT-2092 Цена 110$

Более 20 видов карманных переводчиков на сайте http://www.slovary.ru/

г. Москва ул. Новопоселковая д.6 корп.7 тел. (095) 497-5361, 497-5570