Новости-1

В ближайший месяц SCO покажет "ворованный" код

Корпорация IBM в пятницу одержала весьма важную победу в борьбе с компанией SCO. Суть дела, напомним, сводится к тому, что SCO обвинила IBM в незаконной передаче фрагментов исходного кода операционной системы Unix System V разработчикам сообщества open source. В результате, защищенные копирайтом технологии были использованы поставщиками дистрибутивов Linux с ядрами 2.4 и выше, тогда как владельцы авторских прав не получили с этого абсолютно никаких прибылей. Теперь SCO требует от IBM выплаты компенсации в размере 3 млрд. долларов США, а от всех пользователей Linux - приобретения лицензий на ОС. При этом, однако, в SCO не приводят никаких весомых доказательств своей правоты, за исключением громогласных заявлений. Тем не менее, руководство этой компании во главе с Дарлом Макбрайдом полностью уверено в своей правоте.

IBM же, в ответ на выпады SCO, не так давно подала встречный иск, потребовав от инициаторов конфликта раскрыть полную информацию о сути претензий и представить "украденный" код. Однако SCO практически сразу же направила в суд меморандум с прошением отклонить запрос IBM. Но и на этом обмен "ударами" не закончился, и в начале прошлого месяца IBM также выставила меморандум, настаивая на том, чтобы SCO все же опубликовала скопированный из Unix System V код. В противном случае, все иски должны быть отклонены.

И вот, 5 декабря суд штата Юта вынес весьма значимое решение по делу "SCO против Linux". Согласно постановлению федерального судьи Дейла Кимболла, истцы в тридцатидневный срок обязаны обосновать свои претензии и представить ответчикам "ворованный" код. Таким образом, развязка конфликта, вполне возможно, уже не за горами. Хотя, нужно отметить, что и SCO не собирается сидеть сложа руки. В частности, в ближайшее время компания намерена подать еще один иск, по которому IBM будет обвинена в нарушении копирайтов.

Yahoo предлагает новый метод борьбы со спамом

Компания Yahoo работает над созданием новой технологии борьбы со спамом. Для эффективной борьбы с непрошеной рекламой, по мнению одной из крупнейших интернет-компаний, придется внести некоторые коррективы в механизмы работы почтовых серверов. Коррективы эти будут сводиться к созданию системы так называемых доменных ключей (Domain Keys). Эти ключи будут использоваться для идентификации серверов друг другом и подтверждения подлинности отправителя. В результате, можно будет противостоять излюбленной спамерами модели рассылок с подделкой обратных адресов.

В заголовок каждого отправляемого письма сервер с поддержкой Domain Keys будет записывать зашифрованный закрытый ключ. Сервер получателя, со своей стороны, должен будет отправить запрос системе доменных имен и получить открытый ключ, соответствующий домену. Если с помощью этого открытого ключа можно расшифровать закрытый, то письмо считается подлинным. В противном случае, письмо классифицируется как спам и отсеивается.

Yahoo намеревается начать внедрение своей технологии уже в 2004 году. Технология Domain Keys будет реализована в собственной почтовой службе Yahoo. Разработчики других почтовых систем смогу лицензировать технологию доменных ключей совершенно бесплатно, что должно способствовать ее распространению. Широкая поддержка Domain Keys важна, так как, если эту систему не будут поддерживать большинство почтовых серверов, ее эффективность будет невысокой.

Google просит суд определить, могут ли поисковые запросы считаться торговыми марками

Компания Google обратилась в американский суд с просьбой дать разъяснения относительно того, могут ли запросы, вводимые пользователями поисковой системы и содержащие слова и словосочетания, зарегистрированные в качестве торговых марок, подпадать под соответствующие ограничения. Причиной для такого запроса стали жалобы, направленные в Google и судебные инстанции. В этих жалобах ряд фирм жалуются, что на страницах результатов поиска по запросам, содержащим их торговые марки, выводится реклама конкурентов.

Авторы жалоб считают такую практику неприемлемой. Итогом рассмотрения такого иска во Франции уже стал штраф, наложенный на Google решением суда. Несколько похожих исков находятся на рассмотрении и в США. Пока Google идет по пути удовлетворения жалоб и исключает из рекламной системы запросы, указанные недовольными компаниями. Однако вечно такая практика продолжаться не может, и в Google решили, что лучше всего в этой проблеме может разобраться суд.

В настоящее время вопросы торговых марок и контекстной рекламы в интернете практически не урегулированы. Дело в том, что реклама в поисковых системах получила распространение в последние несколько лет, и времени регламентировать ее правила законодательно просто не было. Google просит суд решить, правомерно ли понятие торговых марок по отношению к поисковым запросам, и насколько широко оно может трактоваться. Например, могут ли ограничения распространяться на фрагменты торговых марок или фразы, их напоминающие.

Источник: http://www.compulenta.ru/

***
Рекомендуем
Книга "10 Секретных Кнопок"
Эта книга по какой-то фантастической случайности не попала в разряд «Совершенно Секретных». Так что ПОКА у вас еще есть возможность познакомиться с одним из самых важных открытий в области человеческой психологии - так называемыми «нейро-кнопками», «нажав» на которые, вы получаете возможность... Впрочем: тс-с! Это не та тема, о которой можно заявлять в открытую… Поэтому... ОСТОРОЖНЕЕ!
Узнать подробнее о книге "10 Секретных Кнопок"
***
Copyright © Internet Zone, info@izcity.com


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

Новости-2

На мировом рынке наметился дефицит мобильных телефонов

Накануне зимних праздников производители сотовых телефонов столкнулись со значительным ростом спроса на свою продукцию. Этот рост является сезонным и всегда учитывается в производственных планах компаний. Однако в нынешнем году производители сотовых телефонов проявили излишнюю осторожность и сильно недооценили потенциал потребительского спроса. Возможно, компании предпочли перестраховаться после 2001 года, когда объемы производства мобильников оказались чрезмерно высокими, и производителям пришлось долго и упорно распродавать накопившееся складские запасы.

Как бы то ни было, в нынешнем году ситуация складывается обратная. Например, управляющий директор Nokia по России и странам СНГ Кеннет Йонссон отметил в интервью Reuters, что компании необходимо незамедлительно осуществить на эти рынки дополнительные поставки телефонов моделей 1100 и 2100. Генеральный директор Siemens Хайнрих фон Пирер, в свою очередь, заявил Reuters, что все имевшиеся в их распоряжении запасы телефонов распроданы.

Кроме того, на рынке комплектующих начал проявляться некоторый дефицит таких компонентов, как цветные ЖК-экраны и встраиваемые в телефоны фотоаппараты. В настоящее время велик спрос именно на модели с цифровыми камерами. Потребители в странах Европы и США активно меняют старые аппараты на мультимедийные новинки. Впрочем, негативный эффект от дефицита несколько сглаживается тем, что сейчас на рынке имеется как никогда много моделей телефонов по сходным ценам. Поэтому, даже если из магазинов исчезнет какая-либо модель, найти ей адекватную замену будет несложно.

Сверхтонкие провода из капель жидкости

Совместные исследования механизма образования капель жидкостей, проведенные учеными Университета Пердью и физиками из Чикагского университета, позволили разработать методику получения сверхтонких волокон из различных материалов, в том числе и проводящих электричество.

Суть разработанной технологии сводится к следующему. Когда через специальное сопло одно вещество медленно выталкивается в среду с другой вязкостью (подобно тому, как вытекают капли воды из водопроводного крана), происходит образование капли. При этом процесс отделения капли сопровождается появлением тонкого канала между соплом и формирующийся каплей. Когда вода капает из крана, этот канал относительно короткий и толстый, потому что вязкость воздуха намного ниже, чем у воды.

Ученые обнаружили, что длина этого формирующегося при каплеобразовании канала тем больше (а толщина - меньше), чем больше отношение вязкости внешней жидкости к вязкости жидкости, из которой образуется капля. Для объяснения этого явления и разработки соответствующего математического аппарата понадобилось два года работы.

На рисунках представлено образование капли воды в масле. На последнем хорошо виден тонкий канал, соединяющий каплю с соплом
На рисунках представлено образование капли воды в масле. На последнем хорошо виден тонкий канал, соединяющий каплю с соплом

Были проведены эксперименты по образованию капель в сверхвязких силиконовых гелях, чья вязкость в несколько раз больше, чем у воды. В результате, хотя капля формируется значительно дольше, чем обычно, удалось получить сверхтонкий канал, толщиной всего в 100 нанометров. Как заявляет один из участников проекта, профессор Осман Басаран, если образовывать капли из специального вещества, которое полимеризуется на свету, то можно получать из него тончайшие волокна. Этим способом, как надеется профессор, в будущем можно будет получать тончайшие гибкие волокна из прочнейших материалов и сверхминиатюрные проводники электричества, например, из специальных полимеров. Планируется, со временем, создать проводники с диаметром меньшим, чем длина волны электрона, что позволит значительно снизить тепловыделение и увеличить проводимость, получив некий аналог сверхпроводимости.

Американские покупатели музыкальных CD получат компенсации

Американский суд утвердил условия урегулирования коллективных исков, поданных членами клубов коллекционеров музыкальных записей против звукозаписывающих и торговых компаний. В этих исках ответчики обвинялись в сговоре с целью завышения цен на компакт-диски. По мнению истцов, звукозаписывающие лейблы и торговые компании заключили ряд тайных соглашений, регламентирующих минимальные цены на музыкальную продукцию. В результате, потребители понесли финансовые издержки, а музыкальные лейблы получили сверхприбыли.

В рамках нынешнего урегулирования были достигнуты договоренности о предоставлении компенсаций членам музыкальных клубов, которые приобретали музыку на заказ. Все состоящие в таких клубах, пострадавшие от завышения цен, смогут получить компенсации в виде ваучеров. Эти ваучеры дают право на скидки в размере 75% при приобретении новых дисков. При этом с заказчиков не будет взиматься плата за доставку заказанных записей.

Ранее похожее мировое соглашение было заключено по искам обычных потребителей, покупавших музыкальные записи в магазинах. В результате урегулирования около 3,5 млн. потребителей получат чеки на покупку компакт-дисков номиналом в 12,6 доллара США. Кроме того, звукозаписывающие компании бесплатно передадут школам и библиотекам музыкальные CD на сумму в 75,7 млн. долларов США. Кроме того, многие звукозаписывающие компании уже пошли на снижение цен на свою продукцию. Впрочем, это обусловлено не только жалобами потребителей, но и конкуренцией со стороны новых каналов распространения музыки, прежде всего, интернета.

Источник: http://www.compulenta.ru/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Большому офису - большие возможности

Автор: Баир Гармаев

Ricoh Торговая марка RICOH известна под многими обликами. Это, как правило, копировальные устройства, факсимильные аппараты, принтеры, фототехника, оптические накопители и носители. Многие современные типографии выросли из печатных салонов, построенных на базе цифровых дупликаторов. RICOH выпускает широкий ассортимент расходных материалов к перечисленным устройствам, а специалисты ИТ-индустрии припомнят элементную базу от RICOH Electronics. Но путь компании к вершинам рейтингов начинался с небольшого производства фотоматериалов. И за семьдесят лет интеллектуальный багаж RICOH в области печати вырос настолько, что сегодня компания по праву входит в тройку лидеров рынка офисного оборудования. И сегодня RICOH представляет уже комплексные решения для организации документооборота в офисе.

Одни из последних новинок в этом секторе - многофункциональные устройства Aficio 2035e и Aficio 2045e, способные совмещать в себе как устройства монохромной печати, копирования и сканирования документов, так и средства работы с факсимильными сообщениями. Эти "комбайны" предназначены для офисного применения в компаниях численностью от 30 человек и способны выдавать до 50 тыс. страниц в месяц и более.

Новые МФУ пришли на смену моделям Aficio 1035/1045, завоевавшим огромную популярность у российских пользователей. Новинки унаследовали все достоинства предшественников - надежность, функциональность и лучшее в своем сегменте отношение цена/качество. Прибавим к этому удобство пользования и модульную конфигурацию, что избавляет от необходимости платить за ненужные функции.

Особенность новых аппаратов в том, что они реализуют новый подход к документообороту, призванный минимизировать расход бумаги и тонера. Так, новые МФУ Aficio 2035e/2045e предлагают возможности безбумажной факсовой связи, что достигается путём интеграции аппаратов в сеть офиса. Теперь нет необходимости печатать письмо и идти к факсу, чтобы отправить его, равно как и тратить бумагу на входящие сообщения. Отправлять и получать сообщения можно прямо со своего рабочего места. Кроме этого, Aficio 2035e/2045e умеют, пользуясь прописанной администратором аппарата логикой, переправлять входящие факсимильные сообщения непосредственно адресатам в почтовый ящик.

Aficio 2035e/2045e предоставляют широкие возможности по удалённому управлению документами, администрированию и мониторингу благодаря встроенному веб-серверу. Доступ к нему осуществляется через обычный браузер, установка специализированного ПО на ПК пользователей не требуется. Традиционное же управление облегчает большой сенсорный ЖК-экран.

Aficio 2035e/2045e различаются скоростью печати √ 35 и 45 копий в минуту соответственно. Используется принцип электрографической печати с экспонированием двумя лазерными лучами. Обрабатываются документы форматов А6-А3, в лотки для бумаги можно загрузить до 3550 листов. Максимальное разрешение печати составляет 600 точек на дюйм, что вполне достаточно для любых офисных приложений. В новых аппаратах применяется тонер, получаемый путём полимеризации конденсата, то есть химическим, а не механическим способом. Это способствует образованию меньших, чем ранее, частиц, их диаметр составляет 5 мкм против 6,8 мкм в тонере для моделей Aficio 1035/1045. К тому же меньший размер частиц укорачивает время прогрева, которое с момента включения до готовности к работе составляет 15/20 с для Aficio 2035e/2045e соответственно.

Копирование документов в Aficio 2035e/2045e осуществляется также с разрешением 600 dpi, существует возможность масштабирования в пределах 25 - 400% с шагом 1%. Для хранения оригиналов в памяти аппараты располагают 64 МБ ОЗУ и 20-гигабайтным жёстким диском. Двустороннее копирование входит в число стандартных функций Aficio 2035e/2045e.

Принтер в составе МФУ поддерживает следующие языки описания страниц - PCL5e, PCL6, RPCS и Postscript 3. Для нужд хранения информации присутствуют 192 МБ ОЗУ и 20 ГБ жёсткого диска. Передача данных ведётся по интерфейсам IEEE 1284 (параллельный порт ПК) и Ethernet 10/100 Мб/с. Поддерживаются сетевые протоколы TCP/IP, IPX/SPX, SMB, IPP и AppleTalk. Aficio 2035e/2045e могут работать в сетях ПК под управлением Windows 95/98/Me/NT4.0/2000/XP, Mac OS 8.6 и более поздних версий (за исключением 10.0.x). Кстати, кроме указанных способов подключения новые МФУ позволяют установить платы высокоскоростных интерфейсов FireWire (IEEE 1394), USB 2.0 и даже карты беспроводной связи √ Wi-Fi (IEEE 802.11b) и Bluetooth. Последнее обеспечивает удобство пользования аппаратами для мобильных пользователей, которым теперь нет нужды подключать КПК или ноутбук к сети предприятия √ документ можно отправить на принтер или факс без проводов.

Сканер в новых аппаратах RICOH справляется с оригиналами форматов от А5 до А3. Оптическое разрешение сканирования √ 600 точек на дюйм, чего более чем достаточно для сканирования документов в офисе. Выходные форматы файлов √ PDF, JPEG, TIFF. Устройство может самостоятельно отправить полученное изображение по e-mail или в определённую папку на ПК, подключенном к офисной ЛВС. Кроме этого можно воспользоваться ПО доставки ScanRouter V2 Lite или вызвать процесс сканирования из приложения, поддерживающего интерфейс TWAIN, например, Adobe Photoshop. Для выбора адресата изображения аппараты Aficio 2035e/2045e имеют базу e-mail адресов ёмкостью до 2000 записей. Кроме этого, поддержка протокола LDAP (Lightweight Directory Access Protocol) позволяет найти нужный электронный адрес в глобальной адресной книге и таким образом упростить для администратора поддержку адресной книги на жестком диске самого аппарата. Чтобы воспрепятствовать использованию чужих адресов, доступ к адресам в книге можно защитить паролем.

Приём и передача факсимильных сообщений в Aficio 2035e/2045e производится на скорости 33,6 Кб/с. Связь осуществляется как по телефонным линиям (PSTN/PBX), так и через интернет, что позволяет значительно сэкономить на междугородной и международной связи. В первом случае используются протоколы ITU-T (CCITT) Super G3, во втором - T.37 (интернет-факс). Данные для передачи по телефонным линиям сжимаются с использованием методов MH, MR, MMR и JBIG (опционально).

Расходные материалы, используемые в Aficio 2035e/2045e √ тонер, девелопер (порошок для переноса тонера) и фотобарабан. Ресурс тонера типа 3120D составляет 30 тыс. страниц А4 с 6-процентным заполнением листа, девелопера типа 26 хватает на 300 тыс. страниц. Ресурс фотобарабана составляет 150 тыс. страниц. RICOH рекомендует использовать МФУ для печати 10-50 тыс. страниц в месяц, максимальная кратковременная нагрузка составляет 200000 страниц в месяц.

Потребности офисных работников не ограничиваются печатью, сканированием и копированием оригиналов. RICOH предоставляет пользователям богатые возможности послепечатной обработки документов. Так, МФУ Aficio 2035e/2045e могут быть укомплектованы одним из трех типов финишеров, отличающихся емкостями приемных лотков (до 2500) и максимальным количеством одновременно степлируемых документов (до 50). Один из финишеров способен автоматически изготавливать буклеты, фальцуя отпечатанные документы и прошивая по складке двумя скрепками.

Габариты Aficio 2035e/2045e составляют 67 х 65 х 72 см, масса √ менее 79 кг. Небольшие для устройств такого класса размеры позволяют установить МФУ даже в небольшом помещении. Целевая группа потребителей для аппаратов Aficio 2035e/2045e √ это рабочие группы численностью от 30 и более человек. RICOH рекомендует своим дилерам продавать эти МФУ по цене 4950 и 5710 евро соответственно. Похоже, начальникам ИТ-отделов стоит обратить внимание на эти устройства, предлагающие широкие возможности и помогающие экономить средства.

Источник: http://www.computerra.ru/

***
Рекомендуем
Телекоммуникации и электроника
Соединительные технологии: кабели, оптоволокно, изоляция, монтаж и др.
 Электромонтаж, Технологии монтажа, Термоусаживаемые трубки, Муфты, манжеты, Соединительные модули, Одиночные соединители, Соединители для жил, Кроссовое оборудование, Арматура герметизации, Соед. компоненты, Материалы для монтажа


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

Бюджетные лазерные принтеры HP LJ1010 и Samsung ML-1710

Перевод: Владимир Володин

Введение

Сейчас выбор различных печатающих устройств довольно большой, но самыми экономичными по-прежнему остаются монохромные лазерные принтеры. Если у вас нет необходимости печатать полноцветные диаграммы или фотографии и вам нужно печатать большое количество документов, то лучшим выбором станет монохромный лазерный принтер хорошего качества.

В нашем обзоре мы решили остановиться на двух современных бюджетных моделях от разных производителей. Принтеры были выбраны произвольно прямо с полки в магазине. Мы не хотели обращаться к производителям, чтобы не получить устройства, специально отобранные для обзора.

Первый заинтересовавший нас принтер Samsung ML-1710. Эта модель, как и ее старший брат из более высокого ценового диапазона ML-1750, получает восторженные отзывы во всех обзорах. Принтер хорошо выглядит. Для скорости печати 16 стр/мин, он обладает достаточно умеренной ценой 180$. С момента появления эта модель пользуется большим спросом.

Samsung ML-1710

Вторым, естественно, был выбран принтер от HP, так как, говоря про лазерные принтеры, невозможно не упомянуть эту компанию. HP LJ1010 - альтернативная замена более старых принтеров LJ1000. Мы использовали формулировку "альтернативная замена", так как есть еще одна подобная модель LJ1005. Тем не менее, LJ1010 ближе по цене к Samsung ML-1710, он стоит 180$. Хотя он и обеспечивает меньшую скорость печати - 12 стр/мин, но другие характеристики делают этот принтер сильным конкурентом для Samsung ML-1710.

HP LJ1010

Мы сравним принтеры по нескольким параметрам: технические характеристики, конструкция, скорость и качество печати.

Технические характеристики

В этой таблице приведены основные характеристики обоих принтеров. Вам не трудно будет заметить присутствующие здесь отличия.

 | HP LJ1010 | Samsung ML1710
Разрешение | 600 х 600 dpi | 600 х 600 dpi
Скорость печати | 12 стр/мин | 16 стр/мин
Частота процессора | 133 МГц | 66 МГц
Лоток для бумаг | 150 листов в стандартном отделении и 10 в многоформатном. | 250 листов в стандартном отделении и 1 в многоформатном.
Выходной лоток | 125 листов | 50 листов
Интерфейс | USB 2.0 | USB 1.1
Память | 8 МБ | 8 МБ
Время печати первого листа | 10 с | 12 с
Месячная нагрузка | 5000 стр. | 15000 стр.
Емкость картриджа | 2000 страниц (с поставляемым картриджем тоже 2000 стр.) | 3000 страниц (с поставляемым картриджем 1000 стр.)
Поддерживаемые ОС | Windows 9x/Me/2000/XP | Windows 9x/Me/2000/XP, Linux, Mac OS 8.6
Размеры (длина х ширина х высота) | 230 х 370 х 208 мм | 355 х 348 х 193 мм
Вес | 5,9 кг | 7 кг

Есть несколько интересных моментов: HP имеет более быстрый процессор и интерфейс (USB 2.0, а не USB 1.1). В дополнение к этому, многоцелевой лоток HP вмещает до 10 страниц, не в пример Samsung, у которого в этом лотке можно разместить только один лист.

Samsung, тем не менее, обладает более высокой скоростью и рассчитан на значительно большую месячную нагрузку. Еще один плюс - поддержка операционной системы Mac OS, чем HP похвастаться не может.

Перейдем к сравнению особенностей дизайна.

HP LJ1010 при задвинутом лотке для бумаги занимает меньше места, чем Samsung ML-1710. Как вы могли заметить из таблицы, оба принтера достаточно компактны и при необходимости легко переносятся с места на место.

Если лотки для бумаги в обоих принтерах в рабочем положении, то принтеры занимают практически одинаковое место на столе.

А если вы захотите добавить бумаги в лоток Samsung, то с открытым лотком он займет значительно больше места, чем HP.

Теперь рассмотрим тонер. Количество тонера в стандартно поставляемом картридже HP даст возможность напечатать около 2000 страниц. Samsung же позволит напечатать в два раза меньше - около 1000. Но тонера в новом картридже для Samsung, который продается отдельно, вам хватит на 3000 страниц.

Картридж HP менее громоздкий по сравнению с Samsung. Кроме того, нам совсем не понравилось, что часть барабана в картридже Samsung открыта и ничем не защищена.

Мы отдали предпочтение HP. Во-первых, этот принтер поступает со значительно большим количеством тонера, и его барабан защищен гораздо лучше.

Взглянем на механизм подачи бумаги. У обоих принтеров лотки для бумаги абсолютно разные и по виду, и по емкости. Лоток HP LJ1010 легко отбрасывается вниз и вмещает до 150 листов бумаги. Samsung ML-1710 использует выдвижной лоток с большей емкостью, вмещающий до 250 листов.

У HP LJ1010 лоток с прозрачной крышкой, что позволяет видеть, сколько бумаги осталось, у Samsung это не так наглядно, но у него есть индикатор количества бумаги.

Что же касается многофункционального лотка, тут HP более удобен. Крышка основного лотка служит подложкой для листов (их может быть до 10) в многофункциональном лотке. У Samsung тут дела обстоят несколько хуже. Во-первых, в этом отделении может находиться только один лист бумаги, во вторых, пользователю приходится поддерживать лист, пока принтер его не захватит.

Тестовая площадка

Прежде, чем говорить о проверке скорости принтеров, мы выделили два типа скорости. Первый - количество печатаемых страниц в минуту. Вторая - время, необходимое для печати первой страницы.

Параметры компьютера, на котором проводилось тестирование:

  • Процессор: Pentium 4 2.4 ГГц.
  • Операционная система: Windows 2000 ver 5.0.2195.
  • Память: 512 MБ.
  • Жесткий диск: Maxtor 80 ГБ, ATA 133, кэш 8 МБ, 7200rpm.
  • Графическая карта: S3 Graphics ProSavage DDR 32 МБ.

В качестве тестовых файлов мы использовали файлы разных программ, занимающие при печати одну страницу:

    1) Файл MS Word 2000 (21 КБ).
    2) Файл Adobe Photoshop 6.0 (19.1 MБ).
    3) Файл MS PowerPoint 2000 (6.97 MБ).
    4) Файл Adobe Pagemaker 5.5 (496 KБ).
    5) Файл Adobe Acrobat 5.0 (2.16 MБ).

Перечисленные выше файлы специально подобраны, с целью охватить наиболее часто используемые программы.

Для проверки качества печати мы использовали разрешение 600 dpi. Во всех тестах на скорость печати принтер вначале находился в режиме пониженного энергопотребления.

Количество печатаемых страниц в минуту

В этом тесте измерялось полное время печати пяти страниц для пяти тестовых файлов. Средний результат был переведен в количество страниц, печатаемых в минуту.

Принтер HP был очень близок к своей номинальной скорости 12 стр/мин (от 12 до 12,1 стр/мин), даже при небольшом количестве печатаемых страниц (5). А вот Samsung задержался около показателя 14, в то время, как номинальная скорость - 16 стр/мин. Средняя скорость для Samsung оказалась 13,7 стр/мин, а максимальная - 14,5.

Причина более низких, по сравнению с номинальными, показателей Samsung ML1710 кроется в более длительном времени подготовки к работе. Более длительная печать первой страницы объясняется тем, что механизм принтера перед началом печати должен прогреться. Естественно, при печати большого количества страниц, эта задержка гораздо меньше влияет на общее время. HP использует технологии, уменьшающие время прогрева, поэтому оно и не вносит значительных отклонений в показатели.

Время печати первой страницы

В этом тесте оба принтера тоже проверялись на пяти тестовых файлах. Время измерялось с момента отправления файла на печать до момента полного выхода напечатанной страницы.

При печати из режима сна с пониженным энергопотреблением первым оказался HP, показавший средний результат в 13,9 с, а Samsung справился с первой страницей за 20,5 с. Но при печати файлов остальных программ из нормального режима HP незначительно отставал, в среднем на 3 секунды.

Из этого следует несколько примечательных фактов: Samsung был более быстрым в большинстве тестов, но когда идет речь о печати из режима сна или пониженного энергопотребления, первым оказывается HP. Это важное наблюдение, так как в большинстве случаев печать начинается именно из этого режима.

Качество печати: тонкий текст

Для монохромных лазерных принтеров, которые чаще всего применяются в офисе, одной из самых важных характеристик является качество печати офисных документов. Здесь важна четкость всех линий. Оба принтера тестировались в режиме максимального качества печати.

Разительное отличие, естественно, HP здесь безоговорочно побеждает.

Качество печати: четкость линий

Снова вернемся к офисным документам. Они, как правило, содержат различные схемы, таблицы с линиями разной толщины. В таком случае совершенно естественно проверить качество печати линий. Оба принтера тестировались в режиме максимального качества печати.

Судно в примере является символом из шрифта wingding размером 14 пунктов. Обратите внимание, что тонкая волновая линия под судном значительно лучше видна на образце, напечатанном LJ1010. Здесь мы действительно были удивлены тем, что Samsung не смог четко напечатать эту линию при размере шрифта 14 пунктов, ведь это совсем не маленький шрифт.

Качество печати: детали изображения и контрастность

Теперь рассмотрим возможности принтеров по печати изображений. Мы хотим протестировать печать деталей изображения и его контрастность. Хорошее изображение для тестирования должно иметь как можно больше оттенков серого, чтобы тени и разные тона были видны как чистые и резкие области с хорошей контрастностью.

Посмотрев на эту головку чеснока, становится понятно, что диапазон передаваемых полутонов у HP гораздо лучше, это позволяет увидеть небольшие изменения тона, такие, как тени на головке чеснока.

Выводы

Вывод напрашивается сам собой. Samsung ML-1710 - отличная попытка корейского гиганта продвинуться на рынке принтеров. Но принтеры HP не оставляют никаких сомнений в том, что он один из лучших на рынке (в этом ценовом диапазоне).

Тем не менее, Samsung ML-1710 тоже производит неплохое впечатление. Начиная с привлекательного дизайна. Еще одно, что нас удивило, хоть принтер и обладает более старым интерфейсом USB 1.1, это не уменьшило скорость печати по сравнению с HP LJ1010. Единственная проблема Samsung ML-1710 - более низкое качество печати по сравнению с HP LJ1010. Но, не смотря на это, по качеству он выигрывает у многих принтеров, присутствующих на рынке. Так что, если вы используете операционную систему Mac OS и вам нужен монохромный лазерный принтер, следует посмотреть в сторону Samsung ML-1710. Это будет одним из лучших возможных решений.

С другой стороны, HP LJ1010 обладает многими выигрышными характеристиками, отличающими именно принтеры HP: быстрый разогрев, простота в использовании и отличное качество печати. Измеренное количество страниц в минуту немного меньше, чем у Samsung ML-1710, но при печати нескольких страниц эта разница почти не ощущается. При печати нескольких страниц раз от раза более важна быстрая печать первой страницы из режима с пониженным энергопотреблением.

LJ1010 не имеет каких-либо фантастических новшеств, но он может предложить хорошие технологии печати в связке с известной надежностью изделий HP. По цене 180$, включающей тонер на 2000 страниц, мы, пожалуй, не найдем лучшего принтера такого же класса. HP LJ1010 по всем параметрам доказал, что он лучше.

Источник: http://tech.stolica.ru/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Компьютерная лентяйка

Автор: Alex, admin@izcity.com

Карта памяти с доступом в интернет - USB утёнок - Компьютерная лентяйка

Новая разработка Gigabyte - это универсальная карта памяти, подходящая и для персональных компьютеров, и для КПК. Также устройство GN-WLBZ101/201 может передавать данные по беспроводному стандарту IEEE, что позволяет использовать его для доступа в интернет.

Такого сочетания функций ещё не было ни в одном USB устройстве. Пользователь может принимать и отсылать данные с помощью GN-WLBZ101/201 со скоростью 11 мб/с. С такой скоростью передачи данных человеку становятся доступны возможности высокоскоростного интернета с возможностью приёма/передачи потоковых видеоданных. Само устройство изготовлено таким образом, при котором человек может физически регулировать качество принимаемого сигнала, сгибая под нужным углом часть устройства, отвечающего за приём и передачу данных. В настоящий момент выпускаются такие девайсы со 128 мегабайтами встроенной памяти. Однако, разработчики уже заявили, что скоро появятся аналогичные устройства с удвоенным объёмом памяти. Устройство работает под операционными системами семейства Windows.

***

Компания по производству различных электронно-компьютерных аксессуаров Solid Alliance (Япония) выпустила USB карту памяти в виде игрушки-утёнка, способного светиться при подключении к USB порту персонального компьютера или ноутбука.

В Японии давно уже стало обыденным, что дети-школьники переносят различную информацию из школы домой в электронном виде. Карта памяти i-Duck USB разрабатывалась с ориентацией на то, что главными её потребителями будут дети. Объём хранимой информации в этом устройстве, по современным меркам, достаточно скромный. i-Duck USB позволяет хранить до 16 мб информации. Для удешевления себестоимости устройства разработчики предусмотрели возможность подключения i-Duck USB только по USB 1.1 протоколу. Тут они рассуждали исходя из того, что внутренняя память составляет всего 16 мб и от использования протокола USB 2 большого толка не будет. Цена на i-Duck USB карту памяти составляет 49 долларов.

***

Лень - двигатель прогресса! Эту формулу доказывают специалисты Cybiko Wireless Inter-Tainment System. Cybiko - это небольшая компания, которая ориентирована на разработку и выпуск универсальных пультов дистанционного управления различной функциональности.

В этот раз специалисты компании выпустили дистанционное управление для персонального компьютера. С помощью этого пульта профессиональные программисты и простые пользователи могут работать на компьютере, комфортно устроившись в нескольких десятках метров от него. А если работать надоест, то можно поиграть в игры, послушать музыку, посетить развлекательные сайты всемирной паутины и т.д. Разработчики утверждают, что при правильной настройке и правильном обращении с этим пультом дистанционного управления человеку становятся доступны все функции, которые только возможно реализовать на компьютере.

***
Рекомендуем
Книга "Слова-Магниты"
Несколько лет работы лучших мировых специалистов по НЛП и другим психотехнологиям влияния позволили составить специальный словарь, который некоторое время держался в секрете. Тысячи успешных рекламных объявлений и сайтов были проанализированы на предмет поиска ключевых слов, которые заставляют людей покупать... Теперь все эти слова доступны Вам!
Узнать подробнее о книге "Слова-Магниты"


On-line сертификация компьютерных специалистов

Автор: Игорь Викторович Ананченко и Г. М. Аванесов
http://aiv.spb.ru/

Без бумажки ты букашка, а с бумажкой человек
Народная мудрость.

Сертификаты, дипломы, удостоверения и прочие документы об образовании, напечатанные на качественной бумаге с водяными знаками, никогда не лишни. О них вспоминают, когда надо продемонстрировать свои глубокие познания. Одно дело продекларировать и дать понять, что “круче только яйца, а выше только небо”, рискуя прослыть хвастунишкой и совсем другое – вытащить ворох бумаг, подтверждающих регалии и глубокий профессионализм. Ситуация, когда требуется высоко профессионально пустить пыль в глаза, встречается в обыденной жизни не так и редко, например, при приеме на работу. Да и простой посетитель, пришедший в ваш офис, проникнется к вам чувством глубокой заинтересованности, увидев на стене вашу фотографию. Простенькую такую фотографию - на переднем плане вы здороваетесь за руку с президентом страны, на втором с десяток олигархов, смиренно дожидающихся своей очереди, на третьем - фон правительственного кабинета с символами государства. Если фотографии, демонстрирующей что ты человек высокого полета нет, то на худой конец сойдут и штук сорок различных сертификатов и дипломов от современных отечественных и зарубежных центров, подтверждающих высочайшие деловые качества, исключительное профессиональное мастерство и блестящую эрудицию. Личную встречу с президентом или, на худой конец, хотя бы с губернатором Чукотки мы вам организовать не можем, а вот рассказать о том, как любому человеку получить десяток другой сертификатов – это запросто.

Балбес сдает экзамен

Статья, которую читаете, написана двумя доцентами, ведущими компьютерные дисциплины в ВУЗах Санкт-Петербурга. Стаж каждого из нас в области преподавания более пятнадцати лет, что дает авторам право рассуждать на тему on-line сертификации с профессиональной позиции. Прежде чем обвинить нас в ерничестве и профанации on-line сертификации, обратите внимание, что в большинстве случаев конкретная реализация on-line сертификации с последующей выдачей сертификатов является ничем иным как профанацией системы обучения и контроля знаний. Покупая диплом в подворотне или переходе метро, человек понимает, что это низкокачественная фальшивка, с которой легко попасться. Когда некто добывает диплом, оформленный и проведенный через канцелярию ВУЗа, он понимает, что по сути это чистейшая липа, но так как бумага выдана с соблюдением всех формальностей, то уличить человека в преступном незнании гораздо сложнее. У человека точно такой же документ, как и у тех, кто своим честным трудом прошел все ступени обучения с первого курса до защиты диплома. Большинство систем on-line сертификации плохи тем, что позволяют получать сертификаты элементарно обманывая системы тестирования. Вы можете с ходу сказать, чем отличаются сертификаты подтверждающие знание в области компьютерных сетей от Microsoft, Brainbench или “Интернет-Университета Информационных Технологий”? Все сертификаты подлинные на бумаге с высококачественной печатью, практически исключающей возможность подделки, на каждом сертификате идентификационный номер, по которому на вебсервере фирмы можно проверить, что человек сдал экзамен и он сертифицированный специалист. Но вот сдал ли действительно этот человек и как сдавал – вот в чем вопрос? Главный аргумент в пользу on-line сертификации без контроля личности сдающего таков, что мы даем возможность каждому попробовать свои силы и оценить свой реальный уровень знаний. Мы верим в честность людей и считаем, что обманывать не хорошо! Кто бы спорил с тем, что возможность проверить свои силы плохо, а обманывать хорошо. С этим мы полностью согласны, но не согласны с тем, что идет выпуск официального вида бумаг, подтверждающих знания, без реального контроля знаний и того, кому эти бумаги выдаются. Современная коммерческая система ВУЗовского образования показала, что для успешного окончания большинства ВУЗов достаточно уровня IQ интеллекта макаки-резуса и увесистого мешка с долларами. Наличие последнего практически 100% гарантирует неизменно высокий результат и диплом ВУЗа. В итоге диплом о высшем образовании имеет практически каждый состоятельный человек, а система высшего образования ужасно скомпрометирована. Увидев фотографию с президентом над рабочим столом можно задуматься не только о связях в верхах, но и, усомнившись, о современных системах компьютерной верстки и монтажа. Увидев сертификаты и введя для проверки номеров в систему web-контроля на сайте системы тестирования можно, получив подтверждение в подлинности, не понять того, что вся система имеет в себе огромный изъян, а выданная по ценности бумага сопоставима с ценностью «филькиной грамоты». Один из авторов статьи пару лет назад, устав от рассуждений на тему недостатков системы on-line тестирования, не плохой в принципе, но на практике плохо реализованной, решил наглядно продемонстрировать некоторые изъяны реализации, написав программу “Балбес сдает экзамен”, позволяющую проходить тестирование в фирме Brainbench, сдавая экзамен методом случайного тыка. Программа выполняла регистрацию, сдавала экзамен, получала свою двойку (тест не пройден), опять выполняла регистрацию и так до тех пор, пока экзамен не был сдан. Протокол вопросов записывался на диск для возможного последующего изучения. Справедливости ради надо заметить, что программа распространялась с исходником и совершенно бесплатно, а в саму программу не был встроен модуль, позволяющий выбирать готовые ответы, помеченные как правильные, из базы данных. Вероятность правильного ответа хотя бы на 70% вопросов из 30 заданных, при возможности выбора случайным образом одного из 5 вариантов ответа слишком мала (Магия ПК “Компьютерные тесты – обратная сторона медали”), чтобы сдать экзамен с первой попытки. Поэтому реальную пользу от программы могли получить только программисты, которым было по силам подключить базу знаний для выборки правильных ответов, или люди имеющие неограниченный доступ к оптико-волоконному каналу, что в те времена было редкостью. Программа проходила как хорошая иллюстрация темы, но не как инструмент массовой генерации красивых бумажек. Конечно, запустив ее можно было получить сертификат с первой попытки, но с вероятностью такой же, как с первой попытки сразу сорвать в казино Джек Пот. Знакомство авторов началось с обсуждения именно этой программы.

Тест должен быть правильным, как и пиво

Одному из авторов хронически не везет в покупках пива – берешь самое что ни на есть по рекламе правильное, а достается какая-то гадость со вкусом консервантов. Итак, что такое правильный компьютерный on-line тест, завершающийся выдачей сертификата? Это тест, который сдает человек в специальном помещении, в котором находится представитель контролирующей стороны. Например, сертификационные тесты от MICROSOFT, ORACLE, INTEL, IBM, HP, NOVELL, SCO, DIGITAL, ADOBE, LOTUS и других лидеров мировой компьютерной индустрии, можно сдать в центре сертификации PROMETRIC (RU1) AЦT СПбГЭТУ "ЛЭТИ" (http://www.prometric.ru/). Естественно, что сама база с тестами может находиться по ту сторону океана, а доступ к ней осуществляться в режиме on-line, но у человека сдающего тест необходимо проверить документы, чтобы была гарантия, что сдает именно он. Кроме того, лицо, осуществляющее контроль, должно проследить, чтобы человек не использовал разные подсобные материалы-шпаргалки. В качестве примера можете посмотреть достаточно жесткие правила сдачи тестов названного центра http://www.prometric.ru/win1251/Reg&Test.htm. Наличие в помещении филиала для сдачи вебкамеры, позволяющей контролировать обстановку из главного центра тестирования, так же способствует тому, чтобы тест был действительно правильным. Представитель контролирующей стороны в помещении для сдачи способствует тому, что бы процедура сдачи была честной, но 100% гарантии можно дать только при возможности контроля за самим контролером: “Слюшай дорогой, вот тэбе подарок, уйди дорогой, нэ мешай дюмать!”. Если контроля за тем, как проходит процесс сдачи нет, то сдать любой тест проще простого:

  1. для прохождения теста нанимается специалист, который сдает тест;
  2. для прохождения теста используется база с ответами на вопросы;
  3. для прохождения теста используется мощная поисковая компьютерная система, позволяющая находить ответы на вопросы за приемлемое время, так как обычно время ответа на вопрос ограничено
  4. используются чисто хакерские трюки обмана системы тестирования.

К сожалению, приходится констатировать, что системы on-line тестирования с выдачей сертификатов без надлежащего контроля за процессом сдачи в последнее время появляются как грибы после дождя. Дело это весьма доходное. Конечно, о сверхприбылях, как от продажи наркотиков, речь не идет, но коммерческая самоокупаемость и доход в наличии. Сертификат от чистопородной американской фирмы это круто и производит впечатление на непосвященных, не знающих, что в США есть офшорные зоны, где любой человек в принципе может открыть свою компанию. В числе совладельцев должен быть хотя бы один житель страны, но разве трудно пройтись по списку сайтов колледжей США и написать письма нескольким студентам с предложением стать совладельцем фирмы? Один из них обязательно согласится. Процесс регистрации потребует единовременно порядка $200-$300, регистрация сайта с поддержкой скриптов еще $200. Печать бланков сертификата в типографии – около $1 за бланк. Вот собственно и все. Еще необходимы скрипты для обеспечения процесса тестирования и вопросы для текстов. Естественно, что если регистрировать фирму не в США, а в России, то будет еще дешевле, но есть один неприятный момент – могут появиться представители министерства образования и начать задавать глупые вопросы на тему каких-то там лицензий на право деятельности в сфере образования. На России и США, впрочем, свет клином не сошелся, а сертификат об образовании выданный, например, в Ниуэ (не слыхали о таком субъекте? А о связанном с ним домене .nu ?) будет смотреться еще экзотичнее. В качестве примера чисто американской фирмы с российскими корнями посмотрите сайт http://www.stbpwr.com.

Brainbench всемирный лидер on-line сертификации

Можно смело отнести названный центр (http://www.brainbench.com/) к классике жанра. Огромный выбор on-line тестов – более 450 доступно момент публикации. Три с половиной десятка тестов (например, MS Windows 95 Administration, Delphi 6.0 Fundamentals, Written English) можно пройти бесплатно, так же как и все бетта-тесты (то есть тесты находящиеся в предварительной обкатке –после их сдачи сертификат не выдается). Людям, знакомым с предысторией этого центра тестирования, известно, что Brainbench это бывший TekMetrics, абсолютно все тесты которого были раньше бесплатны. Один из авторов статьи получил с полсотни бумажных сертификатов от Brainbench в те времена, когда процедура прохождения тестов была бесплатна. Классика жанра подразумевает и классические ошибки, в том числе в реализации скриптов тестирования. Проходить один и тот же тест по два раза, один раз честно, проверяя свои собственные силы, второй – обманывая систему и получая высший результат, было весьма занятно. После того, как автор решил пообщаться на тему ошибок со службой suppot’a он увидел, не исправление ошибок, а незнакомое ему слово Chater (жулик), появившееся в его учетной записи вместо фамилии. Примечательно, что ошибки так и не были исправлены до тех пор, пока прохождение тестов не стало платным. Возможно, что ошибки так и остались не исправленными, но расплачиваться кредиткой за установление факта, что “воз и ныне там”, особого смысла мы не видим. Список предлагаемых тестов представлен здесь http://www.brainbench.com/xml/ bb/skillscenter/skillscenter.xml. Стоимость прохождения теста $49.95 для тестов технической направленности (например, C++) и $19.95 для не технической (например, Written Russian). Всего прошло сертификацию на этом центре примерно 4,4 миллиона (!) человек. Поэтому Brainbench можно без всяких натяжек назвать мировым лидером в области on-line сертификации. Ради интереса рекомендуем вам посетить этот сайт, только не пугайтесь весьма своеобразного дизайна. На первой странице на вас в упор глядит лысый изможденного вида мужик с заклейменным лбом, на следующей он же, только на голове разместилась колотушка. Не добавляет радости восприятия и красно-бело-серая цветовая гамма. Возможно, что для благополучной Америки такие картинки как-то ассоциируются с успехом и мозговым штурмом, для нас же с жертвами фашистских концлагерей и людьми, заклейменными как скот. Не будем останавливаться на таком очевидном факте, что без знания английского языка тесты сдать совсем не просто. Не менее очевидно, что если человек не может сдать тест на международном английском языке, то он пойдет на тот сайт, на котором аналогичный тест можно сдать на своем родном.

Интернет-Университет Информационных Технологий - дипломы и сертификаты

Свято место и в режиме on-line пусто не бывает. Без труда выберем фигуру поколоритнее, поразмашистей из наших, из местных, из славян… и затем, разделаем ее под орех. Вот и кандидат “Интернет-Университет Информационных Технологий - первое в России учебное заведение, в котором Вы можете получить бесплатное образование по Сети”. Вот и чудно – жаль только, что не добавили слово “высшее”, а то, что бесплатно просто замечательно. Мы знаем, где бывает бесплатный сыр, теперь знаем, где найти в Сети бесплатное образование. А что делать с давно существующими бесплатными образовательными сайтами? По мнению создателей университета их учитывать не надо, ведь они дают знания, но не бумаги об образовании! "Это только начало. Возможно, название нашего проекта покажется вам нескромным, но мы на самом деле ставим своей целью создание университета информационных технологий. Анатолий Шкред". Итак, что имеем в наличии на момент публикации статьи? 10 готовых курсов для изучения, 27 в процессе разработки, 42 заявлены в проекте – любой желающий может участвовать в конкурсе на разработку курсов. "По результатам успешного прохождения учебного курса слушателям выдается удостоверение. Дипломы Интернет-Университета Информационных Технологий будут выдаваться слушателям закончившим список всех курсов по выбранной специальности. В настоящее время полностью готовых специальностей со всем списком курсов пока нет. Документы могут быть выписаны на двух языках - русском и английском. Документы высылаются по почте после обязательной предоплаты". Из положительных моментов – слушателям предлагается набор лекций к каждому курсу, которые доступны после бесплатной регистрации и записи на курс. Каждая лекция завершается контрольными вопросами, только после правильных ответов на которые, можно перейти к сдаче вопросов по следующей теме. Когда все контрольные вопросы пройдены, сдается сам экзамен. Если возникли трудности, можно обратиться к преподавателям, разработавшим курсы. На первый взгляд все хорошо и пристойно. На второй – глаза бы наши не видели! Контрольных вопросов обычно три, а база с вопросами по каждой из тем не слишком мала. Поэтому можно несколько раз нажать на ввод и получить первоначальную комбинацию контрольных вопросов. Время раздумий не ограничено, а, значит, можно отсоединиться от Сети, почитать, проконсультироваться, подключиться и ответить на те же самые вопросы. Они не меняются, даже если вообще выйти из аккаунта. Число экзаменационных вопросов зависит от дисциплины, обычно 36. Выдаются экзаменационные вопросы сразу и не меняются. Поэтому вопросы можно не торопясь изучить, обдумать, проконсультироваться со знатоками, зайти на следующий день или через несколько дней на сайт и ответить. Такая система практически гарантирует сдачу экзамена. Но если вы его не сдали, то тут же можно попробовать сдать заново. Нажимаем кнопку и получаем новый список вопросов, в который войдет довольно много вопросов предыдущего экзамена. Поэтому авторы не удивились, увидев сообщение об успешной сдаче экзамена и текст <<Удостоверение выдано датетельный падеж "Аванесов Григорий Мкртычевич">> изумление и осознание своей глубокой серости и невежества пришло спустя секунды после прочтения текста. Всю жизнь учить людей, писать статьи, использовать великий и могучий русский язык и не знать о существовании названного падежа - ужас! Нас можно обвинить в предвзятости, но на страницах того же самого сайта мы видим отзыв <<Качественней работайте ребята. Я вот, например не прочь купить полезную вещь. Все равно за какую цену! Лишь бы я в ней пользу нашел. Этим летом я купил сборник 3-х книжек по специальности прикладная информатика {Моя специальность} опечаток многовато, причем таких, которые могут ввести в заблуждение неопытного читателя. В общем все одобряю НО поменьше халявте плз.. (PS. Могу назвать номера стр. с опечатками, впрочем, вы наверно и сами знаете) >>. Весьма интересна и реализация партнерской программы этого сайта. "Что это такое? Партнерская программа - это реальный способ заработать вместе с нами. Мы платим Вам за то, что с Вашего сайта к нам приходят покупатели. С каждого заказа сделанного покупателем, пришедшим с Вашего сайта, Вам начисляются проценты, которые Вы можете потратить в нашем магазине или получить наличными". Возможность “реального” заработка иллюстрирует пример продажи компакт диска со всеми материалами курсов. Каждый желающий может за 900 руб. купить компакт диск с материалами. Цена вполне допустимая, но только не для материалов, доступных для свободной перекачки. Даже если скачивать не архивы в формате zip, а сами тексты в виде pdf файлов, то всеравно набирается менее 10 МГб. Может, имеет смысл снизить цену? Но нет! Цитируем ответ А. Шкреда "Очень много замечаний про цену, поэтому позволю себе ответить. Дело именно в рыночной экономике, а не в воровской! Да Вы можете покупать это у пиратов по 100 рублей, Вы также можете купить и диплом в подземном переходе. Только вот знания и совесть продаются не везде. Вы имеете полное право выбирать в каком мире Вы живете и по каким правилам". Можно ли говорить о реальном заработке в рамках такой партнерской программы каждый решит сам, мы же такие “коммерчески выгодные предложения” со спокойной совестью игнорируем. Cкажем пару слов об авторе проекта, чтобы у читателей не сложилось впечатление, что организовал проект ничего в этой самой рыночной экономике не понимающий недавний выпускник какого-то ВУЗа, а тут как коршуны налетели на него два злобных доцента и заклевали за профанацию идеи образования, за нескромность и за русский язык. В том-то и дело, что если бы проект создал обычный студент Вася, мы только приветствовали бы его начинание, прощая ошибки и хорошо понимая, что опыт и умение приходит с годами. Однако, когда мы видим в спонсорах проекта издательство "Открытые Системы" и г-на Шкреда, занимающего в нем далеко не последнее место (угадайте с трех раз какое или просто посмотрите на сайте издательства), то говорим следующее, бог с ней с рыночной экономикой, образованием, организацией учебного процесс и личными амбициями, но русский язык это святое! В качестве спонсорской поддержки - выделите пару корректоров для правки материалов сайта. А после мы вернемся на обновленный сайт и даже пару дипломов про запас прикупим. Честно! Без вопросов! Мы ведь живем по совести, а не по понятиям и разумеем, что качество печати от издательства лучше, чем от любителей из подворотни. А что до содержания и наполнения бумажек, то оно дело десятое, ведь только форма и проформа сейчас и актуальны.

Центр сертификации

А есть ли альтернативные варианты прохождения сертификации на родном русском языке в других центрах. Да, есть. Например, на сайте RetraTech (http://www.certifications.ru/) можно бесплатно пройти тестирование в режиме on-line. Система тестирования организована более разумно, в сравнении с упомянутым интернет университетом. Пользователю дается ограниченное время для раздумий, а если он не ответит, то автоматически осуществляется переход к следующему вопросу. Сертификаты также можно заказать в двух вариантах – на русском и английском. Естественно, что для получения бумажных документов необходимо оплатить стоимость печати, оформления и доставки сертификатов. Стоимость одного сертификата – 240 р., доставки от 9 до 40 р. В случае неудачной сдачи тест можно пересдавать неограниченное число раз. Из положительных моментов отмечаем наличие действительно реальной партнерской программы. К сожалению, полностью воспользоваться ее преимуществами возможно только организации, но не частному лицу. Есть и негатив. Во-первых, базы с тестовыми вопросами не слишком велики, а значит, за несколько прохождений теста можно увидеть большую часть вопросов, входящих в базу. Если не лениться и во время сдачи копировать вопросы в окно текстового редактора, то после провальной сдачи можно проработать вопросы теста в спокойной обстановке и затем его успешно сдать. Во-вторых, мы видим точно такое же вольное обращение с русским языком, а конкретно большое число ошибок. Текст с экрана читать труднее, чем с листа бумаги, но что мешает загрузить варианты вопросов в текстовый редактор Word, который подчеркнет красным слова с ошибками, что касается знаков препинания, то их расстановку всегда можно считать авторской и нет вопросов. Авторы надеются, что к тому времени, когда вы прочтете эту статью, ошибки в тестах будут исправлены. Во всяком случае, один из авторов статьи, успешно сдавший пару тестов на этом сайте, настоятельно рекомендовал администрации обратить внимание на русский язык. В качестве еще одного недостатка можно отметить небольшой перечень сертификационных позиций – на момент публикации для сдачи доступно 14 законченных и 9 бета тестов.

Минздрав предупреждает или пора подводить итоги

Рассмотрение центров тестирования можно продолжать и далее, но стоит ли? В поисковой интернет системе наберите “on-line сертификация” или “сертификация специалистов в Интернет” и у вас на экране список сервисов искомой тематики. В статье мы рассказали, где и как проходить тестирование и даже о том, что любой человек при желании может создать свой собственный сертификационный центр. Информацию о хакерских трюках, позволяющих сдавать тесты и о том, где в Сети можно взять базы с вопросами тестов и правильными ответами на них мы сознательно не приводим! Процессу профанации мы противостоять не можем, но хотя бы не будем ему способствовать. Перечитав статью, мы увидели, что она получилась довольно жесткой по отношению существующим системам on-line тестирования, позволяющим пользователям проходить тесты в комфортной обстановке, например, прямо со своего домашнего компьютера, подключенного к сети Интернет. Так ли велики названные минусы по сравнению с плюсами, которые получает честный человек честно прошедший тест. К сожалению, названные минусы поглощают эти самые плюсы. В итоге получаем не свидетельства подтверждающие знания, а гору красивых бумажек за которые, честно говоря, жалко отдать даже 100-200 рублей, которые в наше время давно уже не деньги. Ужасно, что реализация on-line тестирования в том виде, в каком она сейчас практикуется, дискредитирует саму идею тестирования. А раз так, то весьма вероятна ситуация, когда любой сертификат, выданный по итогам on-line тестирования, будет восприниматься как «филькина грамота». Имеют ли право на существование системы on-line тестирования без обязательного контроля личности сдающего? Да, имеют, но только при условии, что в выдаваемых сертификатах будет явно указано, что тестирование проводилось в режиме on-line без контроля личности сдающего и что сдающему в процессе тестирования было разрешено использовать любой подсобный материал. Конечно, подобная запись снижает ценность сертификата в глазах того же самого работодателя, но это будет честно по отношению к людям, прошедшим тесты в режиме полного контроля. Вы знаете, что в нашей стране разрешена реклама табачных изделий и их продажа, но на каждой пачке сигарет и на каждой рекламе табака вы видите предупреждение Минздрава. Вы предупреждены, вы знаете, а дальше ваше право потреблять или не потреблять. Так и человек, который видит сертификат, должен знать, что с его получением, возможно, не все было чисто. Очевидно, что сколько не разглагольствуют иные господа о совести и честности, но вкатить подобную запись в выдаваемые ими сертификаты или дипломы они не решатся, так как это резко снизит ценность этих сертификатов в сравнении с аналогичными сертификатами от их конкурентов, но только без этой записи. Очевидно, что обязательность подобных пометок в сертификатах можно утвердить только на уровне минобразования, причем только для сертификационных центров, действующих согласно законам нашей страны (иностранным наше министерство не указа). Можно было не затрагивать проблему ценности выдаваемых сертификатов, но позиция замалчивания эту проблему не решит, а она существует. Авторы не сомневаются, что к ее решению рано или поздно, но всеравно придется вернуться на министерском уровне. С каждым годом все больше людей получают доступ к Сети и все больше используют системы on-line тестирования. Системы с каждым годом становятся все популярней и это авторы видят воочию, все чаще получая предложения типа: “Уделите мне 15 минут, пройдите за меня тестик. Вы эти дисциплины читаете и для вас ответить на вопросы, что раз плюнуть, а мне бумажка для устройства на работу нужна”.

***
Рекомендуем
Книга "10 Секретных Кнопок"
Эта книга по какой-то фантастической случайности не попала в разряд «Совершенно Секретных». Так что ПОКА у вас еще есть возможность познакомиться с одним из самых важных открытий в области человеческой психологии - так называемыми «нейро-кнопками», «нажав» на которые, вы получаете возможность... Впрочем: тс-с! Это не та тема, о которой можно заявлять в открытую… Поэтому... ОСТОРОЖНЕЕ!
Узнать подробнее о книге "10 Секретных Кнопок"


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

Естественные цвета и дизайн интерфейсов

Автор: Люк Вроблевски
Перевод: Максим Россомахин и Александр Качанов

Всемирная Паутина переполнена стерильным дизайном. Сайты компаний Hewlett-Packard, IBM, Dell, Microsoft, и множества других фактически неотличимы друг от друга (у них сходные цветовые схемы и расположение элементов). Можно было бы сказать, что такая однообразность интерфейса делает Сеть более удобной для работы, но в действительности такие сайты не оставляют в памяти пользователей никакого следа и не способны создать положительный контакт со своей аудиторией.

Самый простой способ избежать такой "серости" - прибегнуть к помощи Цвета. Пожалуй, ни один другой элемент дизайна не оказывает такого влияния на наше ощущение пространства (вебсайта, дома и т.п.), как Цвет. Цвета могут мгновенно менять наше настроение и мнение. Им подвластно создать уют, погрузить нас в пучину страха или возбудить нас. Для дизайна интерфейсов в особенности полезны естественные цвета. В широком диапазоне от сложных веб-приложений до презентационных сайтов цветовые комбинации, встречающиеся в природе, обладают набольшей способностью выделяться (помогая создать более запоминающийся вебсайт), направлять (позволяя пользователям сосредотачиваться на взаимодействии с элементами сайта), увлекать (делая общее расположение элементов страницы более удобным и привлекательным), и вдохновлять (предлагая новые идеи в выборе цветов).

Способность выделяться

В своей жизни мы быстро забываем о рутинных, обыденных событиях. Нам свойственно хранить в памяти необычные впечатления и события, имеющие какой-то эмоциональный багаж. Это справедливо и для путешествий по Сети. Когда все сайты выглядят одинаково, они с легкостью попадают в категорию ощущений "здесь я уже был, это я уже видел". И если учесть еще то, как быстро мы перемещаемся с одного сайта на другой, это ощущение всеобщее.

Поэтому, сайту нельзя пренебрегать любыми возможностями выделиться из общей массы. Если ваш сайт выделяется, есть шанс, что пользователи уделят ему больше времени или внимания при посещении. Они могут даже запомнить его и посетить вновь. Возможно, нет лучшего средства оставить благоприятное впечатление, чем Цвет. Людям свойственна немедленная реакция на цвет: они возбуждаются, они становятся счастливы или же скучнеют.

Уникальная палитра, основанная на найденных в Природе цветах, может вызволить вас из цветовой унылости World Wide Web (рис.1), помогая создать более запоминающийся веб-сайт. Например, естественная комбинация цветов (рис. 2), использованная при создании макета этого сайта (рис. 3), полностью контрастирует с более "стандартной" версией дизайна этого же сайта (рис. 4). Мягкие цвета достаточно нежны, чтобы быть фоном, но вместе с тем они позволяют достаточно чётко выделить четыре основных информационных области сайта.

Но прежде, чем применить "тона техасских прерий" к вашему сайту, вспомните о том, что ваш цветовой набор должен соответствовать аудитории вашего сайта. Так как цветовые ассоциации очень прочны в сознании людей, важно выбрать ту, которая лучше всего подходит для вашего случая.

Способность направлять

Естественные цвета часто менее насыщены и более приятны для глаз, чем их искусственные аналоги. В результате они дают пользователю возможность сосредоточиться на взаимодействии с сайтом, не отвлекая его слишком яркими оттенками. Когда вы пытаетесь сосредоточиться на информации, размещённой в слое с очень яркой цветовой гаммой (рис. 4), ваши глаза постоянно возвращаются к этим ярким цветам (в данном случае к синей полосе наверху). С другой стороны, оттенки жёлтого и голубого на альтернативном варианте дизайна (рис. 3) создают гармоничный баланс между изображениями, панелями навигации и контентом. (Это особенно полезно для веб-сайтов, имеющих значительный объём материалов). Наиболее заметными сделаны самые полезные элементы - меню и блоки с содержимым, но не фоновые цвета, для которых были выбраны природные цвета. Наши глаза привыкли к голубым, жёлтым и серым тонам, так как мы видим их каждый день вокруг себя.

Это явление становиться особенно важным в web-приложениях, с которыми пользователи работают порой часами и целыми днями. Наличие палитры, не отвлекающая пользователя, позволяет ему сосредоточиться на его работе и важной информации. Конечно, Цвет не является единственным необходимым элементом дизайна - структура сайта, взаимодействие и расположение его элементов и многое другое - все должно работать вместе, создавая полезный и удобный для работы веб-сайт или приложение. Но Цвет - важная часть системы, которую нельзя игнорировать.

Способность увлекать

Естественные цвета особенно полезны для ещё одного аспекта дизайна - ответной эмоциональной реакции пользователя. Для того, чтобы пользователь легко попал из Точки А в Точку Б, призывают на помощь юзабилити, но для создания у пользователя приятных ощущений от происшедшего и желания вновь их испытать и поделить ими с другими нужна какая-то индивидуальность.

Рассмотрим два варианта транзакционных форм. Одна использует холодную, пугающую палитру. Другая - более удобна в использовании благодаря применению тёплой и дружелюбной цветовой палитры на основе естественных оттенков. Банковским служащим, постоянно работающим с этим сетевым приложением, наиболее дружественный интерфейс покажется наиболее удобным для работы.

Способность вдохновлять

Естественные цвета, помимо всего прочего, вдохновляют. Разнообразие Природы непрерывно предлагает новых идеи и подходы при выборе цветов. Например, цвета, использованные в компании по привлечению туристов в Дублин, оказались вовсе не оранжевым, зелёным и белым цветами ирландского флага, как вы могли бы подумать. Вместо них были использована цветовая комбинация, характерная для морского побережья Ирландии. Такое сочетание цветов является более живым и привлекательным, делая Дублин забавным и эмоционально открытым. Жалко, что эта схема не была использована на всем сайте Дублина, из-за чего он менее ярок и менее привлекателен.

Всё, что было сказано о естественных цветах - не абсолютная панацея. Порой может понадобиться задать вашей аудитории хорошую эмоциональную встряску. В таком случае лучшим выбором будут сочетания цветов, не встречающиеся в природе (а потому кажущиеся неудобными). С другой стороны, ваши любимые голубые оттенки, так часто встречающиеся на корпоративных сайтах, могут показаться целевой аудитории именно тем, что они ищут. И все же, когда речь идет о сложных приложениях и уникальных решениях, естественные цветовые решения могут оказать вам неоценимую услугу.

Источник: http://www.webmascon.com/

***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Несколько примеров многоаспектных навигационных систем

Автор: Джеффри Вин (Jeffrey Veen)
Перевод: Александр Качанов

Так часто мы решаем, что веб-сайты должны иметь иерархическую структуру. Мы начинаем строить сайт с главной страницы, на которой располагаем навигацию верхнего уровня, с помощью которой посетители могут перейти на более низкие уровни иерархии. Так, словно мы все запрограммированы думать по схеме "сверху вниз".

Ну а как быть с информацией, которую не так-то легко выстроить в иерархию? Иногда у информации может быть множество атрибутов, которые имеют разную ценность и важность для разных групп посетителей. Иерархическая система подразумевает, что все посетители выстраивают важность атрибутов в одинаковом порядке, но ведь не всегда это так.

Давайте рассмотрим реальный пример. Пару недель назад я зашел в огромный супермаркет, где продавались кухонные принадлежности. Ко мне подошел продавец:

- Чем могу вам помочь? - спросил он.

- Мне нужна посудомойка, которая экономично расходует воду и электричество. Должна иметь лоток из нержавейки и хорошо вписываться в кухонный гарнитур, - коротко ответил я.

- У нас есть три варианта, - ответил продавец. - Сколько вы хотите потратить?

Отличный продавец. У него в голове хранился список всех имеющихся в наличии товаров, и он сумел сузить этот список до нескольких, основываясь критериях, что я ему указал. Он даже знал такие атрибуты, о которых я еще и не упоминал (цена), но которые могут оказать влияние на мое решение.

Вот если бы все веб-сайты могли работать так же эффективно! Если мои критерии отобразить схематически, меню навигации бы выглядело так:

appliances > dishwashers > energy consumption
(кухонные приборы > посудомойки > энергопотребление)

В такого рода интерфейсе пользователь выбирает пункт в списке категорий, пока он не найдет посудомойку, удовлетворяющую его запросам. Но что делать, если следующим важным критерием для какого-то пользователя будет внешний вид мойки, а не энергопотребление? А что, если для него самым важным критерием является цена? Представьте, вам надо найти все мойки с нержавеющим поддоном, чья цена не превышает 400 долларов. Вам придется перебрать все варианты в иерархии, чтобы найти в каждом варианте те товары, что удовлетворяют запросу!

Системы, оперирующие информацией с множеством атрибутов, в информатике называются многоаспектными системами (multi-faceted). В этих системах каждая крупица информации имеет несколько аспектов (граней), например - "материал поддона". И каждый этот аспект (грань) может иметь несколько значений (например, "нержавейка, пластмасса, кафель, золото"). Всякий раз, когда выбирается какое-либо значение в том или ином аспекте весь набор вариантов немного сужается. И так процесс повторяется шаг за шагом, аспект за аспектом. При выборе значения для каждого аспекта, система как правило выводит общее количество объектов, удовлетворяющих выбранным критериям. Конечная цель такого интерфейса: сузить список вариантов до такого размера, чтобы его легко было затем просмотреть.

Кажется, что такой интерфейс создать вовсе не трудно, но в реальности часто все наоборот. Современные веб-броузеры не приспособлены для процесса такого рода. В идеале пользователь мог бы поэкспериментировать со значениями каждого аспекта, но в реальности, каждое изменение любого значения ведет за собой обращение к серверу за новыми данными, из-за чего даже на самом быстром соединении впечатление от работы смазывается.

Так каковы же наилучшие варианты решений по созданию навигации для многоаспектных систем? Приведенные ниже примеры довольно эффективны. Каждый из вариантов предлагает пользователю свой способ работы с данными, при этом обходя неприятные ограничения броузера.

Рис.1. Сайт Broadmoor выводит атрибуты (в данном случае - даты) - в особом окошке.

  • Выбор аспекта. Здесь использованы две важные идеи: во-первых, пользователю предлагаются различные способы выбрать те значения, которые важны для него; во-вторых, используются элементы интерфейса, которые лучше всего подходят для отображения данного типа данных. Например, посмотрим на интерфейс бронирования мест на сайте Broadmoor Hotel, который выполнен на Flash. Выбор данных осуществляется с помощью календаря. Решение тривиальное, но вспомните сколько раз вам приходилось на сайтах выбирать дату из выпадающих списков?

Рис.2. Сайт Kohler прибегает к помощи JavaScript, чтобы сделать интерфейс более гибким.

  • Интерфейс отсеивания. Когда пользователь выбирает какое-либо значение для определенного аспекта, покажите общее количество объектов, удовлетворяющих данному выбору, чтобы пользователь мог увидеть, как его выбор сокращает (или в некоторых случаях, расширяет) конечный результат. Например, взглянем на веб-сайт компании Kohler, занимающейся изготовлением вентилей. Их интерфейс поиска вентилей автоматически выводит результат при изменении какого-либо параметра. Если выв выберите вентиль с отводной трубкой, количество объектов сокращается с 124 до 55. добавьте к этому крестовую ручку и выбор сократится до 7 типов. После этого можно смело нажимать ссылку "Show Products" и с легкостью просматривать результат поиска.

    Эффективность подобного типа интерфейса зависит большей частью от технологии. Сайт Kohler использует для обновления результатов JavaScript. К сожалению это требует обращения к серверу всякий раз, когда меняются критерии выбора. Чем больше логики переносится на сторону клиента, тем быстрее сможет работать интерфейс, тем свободнее сможет чувствовать себя пользователь. Это подтверждает пример Flash-интерфейса на сайте Broadmoor, который выводит результаты поиска по выбранным критериям без обращения к серверу и без обновления страницы.

Рис.3. Сайт Sears не предоставляет широкого варианта выбора, что несколько ограничивает свободу действий пользователя

  • Вывод результатов. Покажите пользователю какой-либо результат его действий. Некоторые системы просто выводят число (как на сайте Kohler выше); другие - сразу выводят список совпадений, как это делает обычный поисковый сервер. Существуют также гибридные варианты, когда выводится список наилучших вариантов с общим количеством всех вариантов. Выбор интерфейса зависит от типа выводимой информации. Также важно дать возможность пользователям уточнить свой выбор на той же самой странице, где выводятся результаты. Например, на сайте компании Sear.com посетителю предоставляется замечательный интерфейс поиска товара по множеству критериев, но после того, как только вы сделаете выбор и запустите поиск, вы получите только список результатов. Чтобы поменять критерии, вам придется вернуться назад и начать все выбирать сначала. По крайней мере, неплохо, что интерфейс хотя бы показывает количество товаров при выборе критериев.

Системы, основанные на многоаспектном представлении информации представляют собой интересное сочетание поискового интерфейса с интерфейсом навигации. У пользователя создается ощущения перемещения в огромном объеме информации, и в то же время пошаговый процесс выбора критериев во многом напоминает ему работу с продвинутыми поисковыми серверами. Чтобы обойти недостатки броузера и сделать интерактивную работу с данными максимально удобной, создатели лучших интерфейсов все чаще прибегают к новейшим технологиям.

Источник: http://www.webmascon.com/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Раздвижные двери CSS

Автор: Douglas Bowman
Перевод: Андрей Смирнов

Среди редко обсуждаемых преимуществ CSS—возможность наложения фоновых изображений с целью получения различных эффектов. В соответствии со стандартом CSS2 для каждого фонового изображения требуется отдельный HTML элемент. В большинстве случаев, типичный код, описывающий общепринятые компоненты интерфейса, предоставляет в наше распоряжение несколько HTML элементов.

Один из таких случаев—навигация на основе закладок. Пришло время вернуть контроль над закладками, популярность которых в качестве основного средства навигации постоянно растет. А теперь благодаря широкой поддержке CSS мы можем улучшить качество и внешний вид закладок на наших сайтах. Вы, скорее всего уже в курсе, что CSS можно использовать для «приручения» простого ненумерованного списка. Возможно, вы даже видели списки с дизайном в виде закладок, которые выглядят примерно так:

[Простой пример CSS-закладок в виде прямоугольников со сплошной заливкой.]

А что если бы мы могли взять код в точности из предыдущего примера и превратить закладки в нечто похожее на это:

[Художественно-выполненные закладки со скругленными углами и мягким трехмерным тонированием.]

С помощью несложного CSS это возможно.

В чем новшество?

Многие из встречавшихся мне CSS-закладок (закладки, основанные на CSS) страдают однообразием своего дизайна: цветные прямоугольники, возможно с обводкой, текущая закладка без обводки, цвет меняется для состояния hover. Неужели это все, что CSS может нам предложить? Несколько прямоугольников с одноцветной заливкой?

Перед тем как CSS получил широкое распространение, в навигационном дизайне появилось много новых идей: причудливые формы, искусные переходы цвета, имитирование интерфейсов из реального мира. Такой дизайн, однако, основывался в большой степени на сложных конструкциях из растрированного текста и многократно вложенных таблиц. Редактирование текста или смена последовательности размещения закладок были обременительным делом. Масштабирование текста было невозможным или приводило к серьезным проблемам в композиции страницы.

Навигация из простого текста легка в редактировании и загружается значительно быстрее, нежели навигация на основе растрированного текста. Кроме того, хотя мы и можем добавить атрибут alt для каждого изображения, простой текст, все же, более общедоступен, так как может быть масштабирован. Поэтому неудивительно, что навигация на основе простого текста возвращается в веб-дизайн. Однако внешний вид CSS-закладок до сих пор был шагом назад в дизайне, и уж конечно совсем не тем, что можно включить в дизайн-портфолио. Новые технологии (как, например, CSS) должны позволить создавать нечто лучшее и с таким же качеством дизайна, которое давало использование таблиц и закладок на основе растровых изображений.

Метод «Раздвижных дверей»

Мы можем создать красивые, действительно гибкие элементы интерфейса, которые расширяются и сужаются в зависимости от размера текста, используя два отдельных фоновых изображения. Одно—для левой части закладки, другое—для правой. Представьте, что эта пара картинок—Раздвижные двери, закрывающие один дверной проем. Эти двери сдвигаются и перекрываются больше, если дверной проем узкий, и наоборот, раздвигаются и перекрываются меньше, если нужно закрыть более широкое пространство. Это показано на иллюстрации:

[Рисунок показывает раздвижные двери в действии. На левом рисунке двери сдвинуты и закрывают меньшее пространство. На правом они раздвинуты и закрывают большее пространство.]

Согласно этой модели одно изображение перекрывает часть другого. Если предположить, что по краям наших картинок есть нечто уникальное, как, например скругленный угол закладки, мы вряд ли захотим, чтобы одна картинка полностью закрывала другую, находящуюся позади. Чтобы этого не произошло, мы сделаем переднюю (в нашем случае левую) картинку как можно более узкой. Но при этом картинка должна быть достаточно широкой, чтобы сохранилась ее видимая уникальность. В нашем случае уникальными являются скругленные углы, поэтому передняя картинка будет шириной с эту, скругленную часть изображения:

[На рисунке отдельно показана узкая левая сторона изображения со скругленным верхним левым углом, затем она же помещена перед изображением правой стороны со скругленным правым углом.]

Если размер закладки увеличится в результате, например, масштабирования текста, наши картинки разойдутся в стороны, обнажив неприятный разрыв. Следовательно, нужно оценить масштаб приемлемого расширения. Как сильно может увеличиться объект при масштабировании текста в браузере? Реально следует рассчитывать на возможность увеличения до 300%. Чтобы компенсировать этот рост, нужно растянуть фоновые изображения. В нашем примере, мы сделаем заднюю картинку (правая сторона) размером 400х150 пикселей, а переднюю—9х150 пикселей.

Не забывайте, что фоновые изображения видны только в «дверном проеме» элемента, к которому они применены («дверной проем»—область контента + отступ). Обе наши картинки прикреплены к внешним углам их соответствующих элементов. Видимые части этих изображений объединяются внутри дверного проема и образуют форму закладки:

[На рисунке показаны обе картинки с увеличенной по высоте нижней частью. Ширина правого изобржаения увеличена за счет добавления слева. Две части, видимые в дверном проеме образуют, стыкуясь, форму в виде закладки.]

Когда закладка увеличивается, изображения раздвигаются, заполняя более широкий проем, при этом видимая область изображений также становится больше:

[На рисунке два изображения слегка раздвинуты и образуют более широкую и высокую закладку. Теперь мы видим большую площадь каждого из них. Так как оба изображения имеют в запасе площадь для расширения, создается иллюзия, что сама закладка с текстом внутри увеличилась самым естественным образом.]

Для нашего примера я создал в Photoshop'е два изображения с мягким, имитирующим трехмерность, тонированием. Для одной из закладок я высветлил заливку и затемнил обводку—этот вариант будет представлять «текущую» закладку. Следуя выбранной модели с левым и правым изображениями, мы должны разрезать картинку на две части:

[Левое и правое изображения]

То же самое нужно сделать и со светлым изображением для текущей закладки. Получив таким образом все 4 изображения, (1, 2, 3, 4) мы можем приступить к созданию кода и CSS для наших закладок.

Создание закладок

По мере знакомства с созданием горизонтальных списков при помощи CSS вы заметите как минимум два способа расположения группы объектов в один ряд. У каждого есть свои преимущества и недостатки. Оба требуют обращения к довольно сложным аспектам CSS, в результате можно быстро запутаться. Первый способ использует строчные элементы, второй—свойство float.

Первый способ—возможно более распространенный—предполагает изменение свойства display на «inline» (строчный). «Строчный» метод привлекателен своей простотой. Однако он приводит к проблемам в реализации нашего метода Раздвижных дверей в некоторых браузерах. Второй способ, на котором мы и сосредоточим наше внимание, использует плавающую модель для выстраивания элементов списка в горизонтальный ряд. Плавающая модель, однако, тоже может разочаровать. Ее противоречивое поведение порой нарушает всю мыслимую логику. Но все же общее понимание того, как справляться с несколькими плавающими элементами и знание надежных способов «выхода» из плавающего ряда (или его заключения в контейнер) может сотворить чудеса.

Мы попробуем поместить несколько плавающих элементов внутрь другого плавающего элемента-контейнера. Это надо сделать так, чтобы внешний родительский плавающий элемент полностью окружил внутренние плавающие элементы. Тогда мы сможем добавить позади наших закладок фоновый цвет или фоновое изображение. Важно помнить, что положение следующего за закладками элемента должно быть восстановлено при помощи CSS-свойства clear. Тогда плавающие закладки не смогут влиять на расположение других элементов страницы.

Начнем со следующего кода:

<div id="header">
  <ul>
    <li><a href="#">Home</a></li>
    <li id="current"><a href="#">News</a></li>
    <li><a href="#">Products</a></li>
    <li><a href="#">About</a></li>
    <li><a href="#">Contact</a></li>
  </ul>
</div>

На практике блок #header мог бы содержать например, еще логотип и форму для поиска. В нашем примере мы сократим значение href для каждой ссылки до “#”. Понятно, что в реальной жизни вместо этого значка будет указан путь к файлу или папке.

Начнем работу с CSS с присвоения свойства float контейнеру #header. Это дает гарантию того, что контейнер в действительности «вмещает» элементы списка, которые тоже будут плавающими. Так как мы сделали #header плавающим, нам нужно присвоить ему ширину в 100%. Мы также добавим временный желтый фон, чтобы убедиться, что этот родительский элемент растягивается на всю ширину позади закладок. Ну и наконец зададим несколько основных шрифтовых свойств, чтобы обеспечить единство внешнего вида элементов:

#header {
  float:left;
  width:100%;
  background:yellow;
  font-size:93%;
  line-height:normal;
  }

Мы также зададим нулевое значение для полей и отступов элементов ul и li и уберем маркер списка. Для всех элементов списка напишем объявление float:left:

#header ul {
  margin:0;
  padding:0;
  list-style:none;
  }
#header li {
  float:left;
  margin:0;
  padding:0;
  }

Для ссылок мы зададим блоковое отображение с тем, чтобы контролировать происходящее, не беспокоясь о строчной модели:

#header a {
  display:block;
  }

Затем мы добавим наше правое фоновое изображение к элементу списка (изменения и добавления показаны полужирным шрифтом):

#header li {
  float:left;
  background:url("norm_right.gif")
    no-repeat right top;
  margin:0;
  padding:0;
  }

Перед добавлением левого фонового изображения сделаем паузу и посмотрим, что мы имеем к этой минуте, в примере 1. (Не обращайте внимания на правило, которое я применил к элементу body в файле примера. Оно лишь задает основные значения для полей, отступов, цветов и текста.)

- - -

Теперь мы можем разместить левое изображение впереди правого, применив его к ссылке (нашему внутреннему элементу). Сразу же добавим отступ, чтобы отодвинуть текст от краев закладки:

#header a {
  display:block;
  background:url("norm_left.gif")
    no-repeat left top;
  padding:5px 15px;
  }

Результат показан в примере 2. Наши закладки начали обретать форму. В этом месте обратимся к смущенным пользователям IE5/Mac, которые задают себе вопрос: «Что здесь вообще происходит? Закладки сложены в вертикальную стопку и растянуты по ширине на весь экран.» Не беспокойтесь, скоро дойдем и до вас. А пока просто следите за происходящим или временно переключитесь на другой браузер и будьте уверены—скоро мы решим проблему IE5/Mac.

- - -

Теперь, когда картинки для простых закладок заняли свое место, зададим изображения для текущей закладки. Сделаем это, обратясь к элементу списка с id="current" и ссылке внутри него. Так как мы не меняем никаких свойств фона кроме фоновых изображений, будем использовать свойство background-image:

#header #current {
  background-image:url("norm_right_on.gif");
  }
#header #current a {
  background-image:url("norm_left_on.gif");
  }

В нижней части наших закладок нам нужна какая-то обводка. Но применение свойства border к родительскому #header не позволит нам «просочить» текущую закладку через эту границу. Вместо этого мы создадим новое изображение с нужной нам обводкой по его нижнему краю. И пока мы работаем с этим изображением, добавим легкий градиент, чтобы это выглядело так:

Мы применим это изображение к фону нашего контейнера #header (вместо заданного ранее желтого цвета), сдвинем его вниз контейнера и назначим фоновый цвет, совпадающий с верхним цветом созданного градиента. Мы также уберем добавленный изначально отступ для элемента body и добавим отступ в 10 пикселей к верхней, левой и правой частям элемента ul:

#header {
  float:left;
  width:100%;
  background:#DAE0D2 url("bg.gif")
    repeat-x bottom;
  font-size:93%;
  line-height:normal;
  }
#header ul {
  margin:0;
  padding:10px 10px 0;
  list-style:none;
  }

Для завершения работы над закладкой осталось «просочить» текущую закладку через границу, о чем мы уже говорили выше. Вы можете подумать, что мы применим к нашим закладкам нижнюю границу, совпадающую по цвету с нижней обводкой фонового изображения элемента #header, а затем изменим цвет границы для текущей закладки на белый. Однако это привело бы к появлению крошечной «ступеньки», видимой для внимательного глаза. А вот если мы изменим отступ для ссылок, мы сможем создать четкие и прямые углы внутри текущей закладки, как показано на увеличенном рисунке:

[Увеличенное изображение двух вариантов: у первого видна крошечная ступенька в 1 пиксель из-за использоваиня нижней границы, во втором варианте мы видим четкий прямой угол.]

Мы добьемся этого, уменьшив нижний отступ для обычной ссылки на 1 пиксель (5px - 1px = 4px), а затем добавив этот пиксель к текущей ссылке:

#header a {
  display:block;
  background:url("norm_left.gif")
    no-repeat left top;
  padding:5px 15px 4px;
  }
#header #current a {
  background-image:url("norm_left_on.gif");
  padding-bottom:5px;
  }

Это изменение делает нижнюю границу видимой сквозь обычные закладки, но прячет ее для текущей закладки. Мы получаем пример 3.

Заключительные шаги

Внимательный взгляд мог заметить в предыдущем примере белые участки по углам закладок. Эти непрозрачные уголки мешают задней картинке быть видимой через левый угол переднего изображения. Теоретически мы могли бы сделать эти уголки такого же цвета как и фон позади них. Но наши закладки могут увеличиться по высоте, и тогда задний градиентный фон сдвинется вниз, что приведет к рассогласованию цвета уголков и фонового градиента. Вместо этого мы изменим наши картинки, сделав их уголки прозрачными. Если к обводке закладок применено сглаживание (anti-aliasing), мы зададим в качестве прозрачного цвета (matte) среднее значение заднего фонового градиента.

Теперь, когда уголки прозрачны, кусочек правого изображения просматривается через прозрачный угол левого. Чтобы избежать этого, добавим небольшой левый отступ к элементу списка, равный ширине левого изображения (9px). Чтобы сохранить центрирование текста после добавления отступа к элементу списка, необходимо убрать такую же величину левого отступа у ссылки (15px - 9px = 6px):

#header li {
  float:left;
  background:url("right.gif")
    no-repeat right top;
  margin:0;
  padding:0 0 0 9px;
  }
#header a {
  display:block;
  background:url("left.gif")
    no-repeat left top;
  padding:5px 15px 4px 6px;
  }

Но и этот вариант нас не устроит, так как левая картинка теперь отодвинута от левого края закладки на 9 пикселей добавленного отступа. Теперь, когда внутренние края левого и правого «дверных проемов» стыкуются друг с другом, нам больше нет надобности держать левую картинку впереди. И мы можем изменить очередность фоновых картинок, применив их к противоположным элементам. Мы также должны поменять картинки и для текущей закладки:

#header li {
  float:left;
  background:url("left.gif")
    no-repeat left top;
  margin:0;
  padding:0 0 0 9px;
  }
#header a, #header strong, #header span {
  display:block;
  background:url("right.gif")
    no-repeat right top;
  padding:5px 15px 4px 6px;
  }
#header #current {
  background-image:url("left_on.gif");
  }
#header #current a {
  background-image:url("right_on.gif");
  padding-bottom:5px;
  }

Сделав это, мы получаем пример 4. Заметьте, что предпринятые нами для создания прозрачных углов шаги, привели к появлению небольшой «мертвой» зоны в левой части закладки, где она не реагирует на наведение мыши. Мертвая зона находится вне текста, но она все же заметна. Прозрачные картинки для каждой стороны нашей закладки использовать необязательно. Если мы предпочтем не иметь на нашей закладке «мертвого» участка, нужно всего лишь использовать позади закладок сплошную заливку, а не градиент, и сделать уголки закладок такого же цвета. Пока же мы сохраним прозрачность углов. [В IE/Win упомянутая «мертвая» зона существовала и до предпринятых шагов, причем со всех сторон от текста ссылки. Решение этой проблемы освещено в следующей статье серии Sliding Doors of CSS, Part II.—прим. переводчика]

- - -

Ну и, наконец, последние штрихи. Все за один раз: делаем весь текст полужирным, текст на обычных закладках коричневым, а на текущей—темно-серым, этот же цвет присваиваем тексту для состояния ссылки hover, убираем подчеркивание ссылок. Все сделанные к этой минуте добавления и изменения представлены в примере 5.

Еще один метод для обеспечения совместимости

Рассмотрев пример 2, мы признали наличие проблемы с IE5/Mac, который растягивал закладки на всю ширину окна, выстраивая их вертикально одна под другой. Не совсем тот эффект, которого мы добиваемся.

В большинстве браузеров применение к элементу свойства float влечет его сжатие до минимально возможного размера, определяемого его контентом. Если плавающий элемент содержит картинку (или сам является картинкой), то он сожмется до ширины картинки. Если он содержит только текст, то сожмется до ширины самой длинной строки текста, не содержащей переносов.

Проблемы возникают в IE5/Mac, когда блочный элемент с шириной auto помещается внутрь плавающего элемента. В этом случае все браузеры сжимают плавающий элемент до минимально возможной ширины, не обращая внимания на внутренний блочный элемент. А вот IE5/Mac в описанной ситуации этого не делает. Вместо этого он растягивает плавающий и внутренний блочный элементы на всю доступную ширину. Чтобы обойти такое поведение, нам нужно применить float также и к ссылке, но только для IE5/Mac, не затрагивая другие браузеры. Сначала добавим float к уже существующему правилу. Затем применим «Метод обратного слэша», чтобы спрятать от IE5/Mac новое правило, которое удаляет float для остальных браузеров:

#header a {
  float:left;
  display:block;
  background:url("right.gif")
    no-repeat right top;
  padding:5px 15px 4px 6px;
  text-decoration:none;
  font-weight:bold;
  color:#765;
  }
/* Commented Backslash Hack
   hides rule from IE5-Mac \*/
#header a {float:none;}
/* End IE5-Mac hack */

В соответствии с примером 6 IE5/Mac теперь отображает закладки как положено. Для остальных браузеров ничего не изменилось. IE5/Mac содержит огромное количество CSS-багов, которые были исправлены в версии IE5.1. От этих багов в IE5/Mac страдает и метод «Раздвижных дверей». Их число превосходит все мыслимые пределы, и я не собираюсь с ними бороться. А так как обновление до 5.1 уже довольно длительное время доступно для всех желающих, процент Маков c OS 9 и установленным IE5/Mac постоянно сокращается и приближается к нулю.

Варианты

Мы только что детально разобрали метод «Раздвижных дверей», который позволяет создавать сверстанную с помощью ненумерованного списка и ссылок и доработанную при помощи нескольких правил CSS закладочную навигацию на основе простого текста. Такая навигация быстро загружается, проста в поддержке, а текст внутри нее может быть значительно масштабирован в любую сторону без нарушения дизайна. Стоит ли говорить, насколько гибким является этот метод при создании любой утонченно выглядящей навигации?

Использование этой техники ограничивается только нашим воображением. Заключительный пример иллюстрирует всего лишь один вариант. Но этот пример не должен ограничивать наши идеи.

Закладки, например, необязательно должны быть симметричными. Я быстро создал второй вариант закладок, в котором использовал простые цвета, угловатые формы и более широкую и сложную по форме левую сторону. Как показывает вариант 2, мы можем свободно менять порядок левого и правого изображений в зависимости от дизайна. При четком планировании и искусном обращении с картинками, можно отказаться от нижней границы в пользу стилевого сочетания картинок с фоном, расположенным позади, как показано в созданном мной варианте 3. Если ваш браузер поддерживает переключение между альтернативными стилями, вы можете просмотреть все представленные варианты, открыв этот мастер-файл и переключаясь в нем между таблицами стилей. [В NN7.1 доступ к альтернативным стилям осуществляется через главное меню View>Use Style, в Opera 7.20—через главное меню View>Style, в IE/Win такой возможности нет—прим. переводчика]

К примененной технике могут быть добавлены другие эффекты, которые мы здесь не рассматриваем. В нашем примере мы меняли цвет текста для состояния hover, но почему бы не поменять фоновое изображение целиком для получения интересных ролловер-эффектов. При наличии в коде двух вложенных HTML элементов мы всегда можем использовать CSS для накладывания фоновых изображений и получения эффектов, о которых мы и не мечтали. В нашем примере мы создали горизонтальный ряд закладок, но метод Раздвижных дверей можно использовать и во многих других случаях. Какое применение этому методу предложите вы?

Источник: http://www.webmascon.com/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Минутка отдыха

Парковка.

***

Не стойкий и не оловянный солдатик.

***

Анекдоты

Психиатр спрашивает пациентку:
- Скажите, мадам, а нет ли в вашей семье случаев мания величия?
- Есть, доктор, есть! Мой муж иногда заявляет, что он глава семьи!

В купе поезда мать объясняет маленькому сыну, как появляются дети:
- Берется глина, лепится заготовка, потом - если ее искупать в молоке, будет мальчик, а если в воде - девочка.
Попутчик, свесившись со второй полки, заинтересованно спрашивает:
- А что, старый способ отменили?

Он:
- В кино были... В парке были... На дискотеке были...
Теперь куда?
Она:
- В загс...

- Это не ваш мальчик зарывает в песок мою одежду, - спрашивает Наталью Васильевну соседка.
- Нет, это мальчик моей сестры. Мой набирает воду вашей шляпой.

Парень с девушкой гуляют по парку.
- Чувствуешь, как вкусно пахнет шашлыками? - спрашивает девушка.
- Давай подойдем поближе, - великодушно предлагает парень, - чтобы ты смогла нанюхаться вволю.

***

Wallpapers (обои на Рабочий Стол)

1024x768 Скачать | 1024x768 Скачать
1280x1024 Скачать | 1024x768 Скачать
1024x768 Скачать | 1024x768 Скачать

Ниже приведена инструкция, как установить обои на рабочий стол:

  1. Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Выбираем Фон > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Применить
  2. В WinXp делаем так: Сохраните рисунок в нужную вам директорию > Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Раскрывается окно Свойства: Экран > Выбираем вкладку Рабочий стол > Нажимаем кнопку Обзор > Указываем путь к рисунку > Нажимаем кнопку Открыть > Нажимаем кнопку Применить
  3. Если вы скачиваете обои в архиве, то нужно разархивировать рисунок в нужную вам директорию, и далее как написано выше.

***

Визуальные стили для Windows XP

Визуальные стили (темы) включают в себя полный комплект для изменения внешнего вида Windows XP: shellstyle, desktop icons, user icon and wallpaper. Инструкцию по установке см. ниже.

Скачать (782 Kb)

Для применения визуальных стилей, т.е. установки их, разработчики стилей рекомендуют использовать программу Style XP (или же TGT Soft's Style XP).
Данные программы "разрешают" Windows XP использовать неподписанные (без цифровой подписи) визуальные стили.

Инструкция для установки стиля:

  1. Загрузите визуальные стили .zip в ваш компьютер
  2. Извлеките .zip файл в эту директорию: %windir%\resources\themes\ (вероятно c:\windows\resources\themes\)
  3. Щелкаем правой кнопкой мышки по Рабочему столу > В контекстном меню выбираем Свойства > Затем Темы > Выбираем из списка доступных тем нужную и нажимаем кнопку Применить

***

Мелодии для мобильных телефонов

Ленинград: Агенство НЛС

Siemens
F1(1/8) F1(1/8) F1(1/8) E1(1/8) P(1/8) G1(1/8) P(1/8) Ais1(1/8) P(1/8) Ais1(1/8) A1(1/8) G1(1/8) A1(1/8) P(1/8) F1(1/8) P(1/8) D1(1/8) P(1/8) F1(1/8) F1(1/8) F1(1/8) E1(1/8) P(1/8) G1(1/8) P(1/8) Ais1(1/8) P(1/8) Ais1(1/8) A1(1/8) G1(1/8)

Nokia
8f0 8f0 8f0 8e0 8- 8g0 8- 8#a0 8- 8#a0 8a0 8g0 8a0 8- 8f0 8- 8d0 8- 8f0 8f0 8f0 8e0 8- 8g0 8- 8#a0 8- 8#a0 8a0 8g0

Motorola
F-2 F-2 F-2 E-2 R-2 G-2 R-2 A#-2 R-2 A#-2 A-2 G-2 A-2 R-2 F-2 R-2 D-2 R-2 F-2 F-2 F-2 E-2 R-2 G-2 R-2 A#-2 R-2 A#-2 A-2 G-2

Ericsson
f f f e p g p #a p #a a g a p f p d p f f f e p g p #a p #a a g

Samsung
48*** 48*** 48*** 38*** 0*** 58*** 0*** 7#8*** 0*** 7#8*** 78*** 58*** 78*** 0*** 48*** 0*** 28*** 0*** 48*** 48*** 48*** 38*** 0*** 58*** 0*** 7#8*** 0*** 7#8*** 78*** 58***

Panasonic
444* > 444* > 444* 33* 0* 555* 0* 6666* 0* 6666* > 666* 555* 666* 0* 444* 0* 222* 0* 444* > 444* > 444* 33* 0* 555* 0* 6666* 0* 6666* > 666* 555*

LG
F0:1/8 F0:1/8 F0:1/8 E0:1/8 -:1/8 G0:1/8 -:1/8 A#0:1/8 -:1/8 A#0:1/8 A0:1/8 G0:1/8 A0:1/8 -:1/8 F0:1/8 -:1/8 D0:1/8 -:1/8 F0:1/8 F0:1/8 F0:1/8 E0:1/8 -:1/8 G0:1/8 -:1/8 A#0:1/8 -:1/8 A#0:1/8 A0:1/8 G0:1/8

Alcatel
488 488 488 388 088 588 088 6#88 088 6#88 688 588 688 088 488 088 288 088 488 488 488 388 088 588 088 6#88 088 6#88 688 588

Philips
2FA 2FA 2FA 2MI 9 2SOL 9 2LA# 9 2LA# 2LA 2SOL 2LA 9 2FA 9 2RE 9 2FA 2FA 2FA 2MI 9 2SOL 9 2LA# 9 2LA# 2LA 2SOL

***

Ленинград: Терминатор

Siemens
G1(1/4) Dis2(1/8) D2(1/8) Dis2(1/8) G1(1/4) G1(1/8)
                        Dis2(1/8) D2(1/8) Dis2(1/8) G1(1/4) F1(1/4) G1(1/8)
                        Gis1(1/4) Dis2(1/8) D2(1/8) Dis2(1/8) Gis1(1/4)
                        Gis1(1/8) Dis2(1/8) D2(1/8) Dis2(1/8) Gis1(1/4)
                        Gis1(1/4) A1(1/8) Ais1(1/4) F2(1/8) Dis2(1/8) F2(1/8)
                        Ais1(1/4) Ais1(1/8) F2(1/8) Dis2(1/8) F2(1/8) Ais1(1/4)
                        Ais1(1/4) Gis1(1/8) G1(1/4) D2(1/8) C2(1/8) D2(1/8)
                        G1(1/4) G1(1/8) G2(1/4) G2(1/8) F2(1/4) Dis2(1/4)
                        D2(1/8) C2(1/4)

Nokia
4g0 8#d1 8d1 8#d1 4g0 8g0 8#d1 8d1 8#d1 4g0 4f0 8g0 4#g0 8#d1 8d1 8#d1 4#g0 8#g0 8#d1 8d1 8#d1 4#g0 4#g0 8a0 4#a0 8f1 8#d1 8f1 4#a0 8#a0 8f1 8#d1 8f1 4#a0 4#a0 8#g0 4g0 8d1 8c1 8d1 4g0 8g0 4g1 8g1 4f1 4#d1 8d1 4c1

Motorola
G-4 D#-2 D-2 D#-2 G-4 G-2 D#-2 D-2 D#-2 G-4 F-4 G-2 G#-4 D#-2 D-2 D#-2 G#-4 G#-2 D#-2 D-2 D#-2 G#-4 G#-4 A-2 A#-4 F-2 D#-2 F-2 A#-4 A#-2 F-2 D#-2 F-2 A#-4 A#-4 G#-2 G-4 D-2 C-2 D-2 G-4 G-2 G-4 G-2 F-4 D#-4 D-2 C-4

Sony
555* 2#***** 2***** 2#***** 555* 555***** 2#***** 2***** 2#***** 555* 444* 555***** 555#* 2#***** 2***** 2#***** 555#* 555#***** 2#***** 2***** 2#***** 555#* 555#* 666***** 666#* 4***** 2#***** 4***** 666#* 666#***** 4***** 2#***** 4***** 666#* 666#* 555#***** 555* 2***** 1***** 2***** 555* 555***** 5* 5***** 4* 2#* 2***** 1*

Ericsson
G #d d #d G g #d d #d G F g #G #d d #d #G #g #d d #d #G #G a #A f #d f #A #a f #d f #A #A #g G d c d G g G g F #D d C

Panasonic
555 2222* > 222* > 2222* 555 > 555* 2222* > 222* > 2222* 555 444 555* > 5555 2222* > 222* > 2222* 5555 > 5555* 2222* > 222* > 2222* 5555 > 5555 666* > 6666 444* 2222* 444* 6666 > 6666* 444* 2222* 444* 6666 > 6666 5555* > 555 222* 111* 222* 555 > 555* > 555 > 555* 444 2222 > 222* 111

LG
G0:1/4 D#1:1/8 D1:1/8 D#1:1/8 G0:1/4 G0:1/8 D#1:1/8 D1:1/8 D#1:1/8 G0:1/4 F0:1/4 G0:1/8 G#0:1/4 D#1:1/8 D1:1/8 D#1:1/8 G#0:1/4 G#0:1/8 D#1:1/8 D1:1/8 D#1:1/8 G#0:1/4 G#0:1/4 A0:1/8 A#0:1/4 F1:1/8 D#1:1/8 F1:1/8 A#0:1/4 A#0:1/8 F1:1/8 D#1:1/8 F1:1/8 A#0:1/4 A#0:1/4 G#0:1/8 G0:1/4 D1:1/8 C1:1/8 D1:1/8 G0:1/4 G0:1/8 G1:1/4 G1:1/8 F1:1/4 D#1:1/4 D1:1/8 C1:1/4

Philips
4SOL 2RE# 2RE 2RE# 4SOL 2SOL 2RE# 2RE 2RE# 4SOL 4FA 2SOL 4SOL# 2RE# 2RE 2RE# 4SOL# 2SOL# 2RE# 2RE 2RE# 4SOL# 4SOL# 2LA 4LA# 2FA 2RE# 2FA 4LA# 2LA# 2FA 2RE# 2FA 4LA# 4LA# 2SOL# 4SOL 2RE 2DO 2RE 4SOL 2SOL 4SOL 2SOL 4FA 4RE# 2RE 4DO

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Что такое пейнтбол?

На правах рекламы

Играем в пейнтбол

Давай сыграем! По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций.
Эмоциональную суть пейнтбола его теоретики определяют как "возвращение в детство": мальчишки традиционно играют в войну, а взрослые дяди традиционно хотят снова почувствовать себя мальчишками. Специальной подготовки не требуется; физическая сила и возраст не так важны, как сообразительность и решимость.
Отличительная черта этой игры - ее полная демократичность. Маркер (оружие для игры в пейнтбол) уравнивает в правах всех - от банкиров и дипломатов до студентов и инженеров. Когда все облачены в камуфляж и маски, то разница в социальном статусе практически незаметна.

Виды игр в пейнтбол

Давай сыграем! | "СТЕНКА НА СТЕНКУ" Описание: Две команды расходятся на базы - каждая на свою. По сигналу инструктора начинается игра. Цель: полностью запятнать команду противника. Выигрывает команда, в которой осталось больше незапятнанных игроков.
Давай сыграем! | "ЦЕНТРАЛЬНЫЙ ФЛАГ" Описание: Флаг устанавливается в центре игрового поля. Игра заканчивается, когда команда захватит флаг с его первоначального места или у пораженного противника и водрузит его на своей базе. "2 ФЛАГА" Описание: На каждой базе по флагу. Цель: захватить флаг противника и принести на свою базу.
Давай сыграем! | "ТОП ГАН" Описание: игроки собираются в центре поля, по первому свистку инструктора игроки разбегаются, по второму свистку инструктора начинается игра. Выигрывает последний - оставшийся непораженным игрок.
Давай сыграем! | "РЕИНКАРНАЦИЯ" Игра по сценарию "Захват флага". Особенности: пораженный игрок возвращается на "базу", ждет там несколько минут, а затем снова возвращается в игру. Игра заканчивается, когда захвачен флаг.

Дополнительные сценарии игр

ГЕНЕРАЛЫ
Создаются 2 равные команды. Все игроки получают по одной повязке своего цвета, кроме 2х игроков (по одному в каждой команде), которые получают 2 повязки (на обе руки) - это "Генералы". Генерала нельзя заменить во время игры - им от начала и до конца остается один и тот же игрок. Выигрывает команда, поразившая генерала противника.

ГРАЖДАНСКАЯ ВОЙНА
Две равные команды - "Север" и "Юг" - с отличающимися по цвету повязками. Игра по сценарию "Захват флага". Лимит времени 25 минут. Особенности: отсутствие фидера на маркере. Шарики заряжают в ствол вручную, по одному. Игра заканчивается, когда захвачен флаг.

ОХРАНА ПРЕЗИДЕНТА
Один игрок назначается "президентом", остальные игроки делятся на две неравные команды. Большая (60-70%) - охрана "президента", все остальные игроки - киллеры. Задача: сохранить "президента" целым и невредимым. Охранники стараются провести "президента" через всю территорию к финишной линии (варианты: форт, флаговая станция, большое дерево)."Президенту" разрешается бежать к финишной линии, если его охрана, которая в продолжении игры должна находиться от него не дальше 3-х метров, поражена. Игра заканчивается, если "президент" достиг финиша или поражен.

Хотите сыграть в пэйнтбол в ПэйнтЛенд Парке?

Присоединяйтесь! Подробнее >>


Алло, Провайдер!

Автор: Alex, admin@izcity.com

В этой статье рассматривается бесплатная программа MuxaSoft Dialer, относящаяся к разряду программ-звонилок. В отличие от других программ такого рода MuxaSoft Dialer не просто позволяет установить интернет-соединение, но и позволяет держать данные о текущем соединении под контролем.

В наше время подавляющее большинство пользователей пользуется модемным (dial-up) методом подключения к интернету. Всем этим пользователям приходится каждый раз для очередного выхода в сеть набирать телефонный номер провайдера. Можно, конечно, пользоваться стандартными средствами операционной системы для дозвона и установки интернет-соединения. Но нужно ли? Удобно ли? Ведь есть много программ, способных облегчить и улучшить этот процесс, сделать его наиболее быстрым и комфортным. Одной из таких программ является MuxaSoft Dialer.

История этой программы начинается с 1998 года. Всё это время разработчики постоянно совершенствовали и развивали своё детище, выпуская версию за версией. Уже 5 лет люди абсолютно бесплатно могут пользоваться этой звонилкой. Вот он - показатель того, что программа не безразлична своим создателям и востребована пользователями.

Звонилка MuxaSoft Dialer способна самостоятельно дозвониться к провайдеру через модем, обработать ошибки соединения, вести подробную статистику по каждому соединению (вплоть до качества связи), тарифицировать время и трафик с учетом выходных и праздничных дней, сообщить о превышении лимитного параметра, автоматически разорвать связь в определенное время, интегрироваться в ОС Windows на низком уровне (позволяет перехватывать начало дозвона из других программ, напр. FlashGet, ReGet, TheBat! Opera, Internet Explorer и т.д.), перехватить и взять под свой контроль уже существующее соединение и т.д.

На момент написания этой статьи, версия программы MuxaSoft Dialer - 4.1.

Рекомендуемые системные требования:

  • Процессор: 266 MHz
  • ОЗУ: 64 мегабайт или более
  • Жесткий диск: 10 мегабайт свободного места
  • Операционная система: Программа оптимизирована для работы с Windows 98, Millenium, 2000 и XP. Желательно наличие Windows XP или Windows Server 2003

В оперативной памяти программа занимает от 8 до 11 мб, в зависимости от режима работы.

После запуска установленной программы, она помещается в трей. По правому клику мыши вызывается контекстное меню программы, из которого доступны наиболее часто используемые функции и настройка параметров.

Программа MuxaSoft Dialer по своим возможностям даст фору практически любой программе подобного плана. Так что же умеет эта программа? Какие возможности она предоставляет пользователю? Настройки возможностей программы задаются в окне Параметры, доступ к которому можно получить из контекстного меню.

Вот список возможностей MuxaSoft Dialer:

Автоматическая установка связи без вмешательства пользователя
Вы можете просто дать команду программе на установку связи. Программа будет пытаться дозвониться еще и еще, пока не будет установлена связь.

Отображение процесса установки связи
При установке связи программа выводит Окно состояния, в котором отображается процесс установки интернет-соединения.

Подсчет затрат за услуги связи
В программе реализована возможность подсчета затрат как по времени соединения, так и по входящему и исходящему трафику.

Отображение параметров интернет-соединения в реальном времени
В небольшом окне программа отображает статистику текущего сеанса связи.

Интеллектуальная обработка ошибок
Вы можете указать программе, как реагировать на определенные ошибки, возникающие в процессе дозвона и нахождения в сети.

Перехват управления над уже установленными соединениями
Программа постоянно “следит” за наличием новых соединений в системе. Если вы звоните посредством других программ (например, почтовой программой), диалер в течение нескольких секунд перехватит соединение и начнет считать статистику в автоматическим режиме.

Система повышенной безопасности
Мощные криптографические системы защищают ваши конфиденциальные данные.

Удаленное управление программой по локальным сетям
Вы можете управлять программой с другого компьютера по локальной или глобальной (Internet) сети из любой операционной системы.

Защита программы паролем
Защита паролем обеспечивает шифрование профиля пользователя.

Аппаратно-зависимое шифрование
Шифрование данных осуществляется по аппаратно-зависимому алгоритму: исключение простого переноса конфигурационного файла на другой компьютер и использование его там.

Встроенный планировщик
Планировщик ведет себя подобно планировщику Windows, но предназначен для управления диалером.

Отчетность по соединениям
В запись о состоянии соединения в отчет записывается вся необходимая статистическая и аналитическая информация, например, отчетность об ошибках соединения.

Просмотр и управление статистикой
Мощное средство управления статистикой MuxaSoft LogManager II не только показывает статистику о соединениях, но и ведет графики (диаграммы) о затратах, трафике, качестве соединения и т.д.

Периодическое сохранение статистики
Статистика сохраняется каждые 30 секунд – исключение неверной записи статистики при аварийном завершении работы компьютера.

Вот такая программа получилась у команды разработчиков за более чем 5 лет работы.

Скачать программу MuxaSoft Dialer можно отсюда (3213 кб)

***
Рекомендуем
Книга "Слова-Магниты"
Несколько лет работы лучших мировых специалистов по НЛП и другим психотехнологиям влияния позволили составить специальный словарь, который некоторое время держался в секрете. Тысячи успешных рекламных объявлений и сайтов были проанализированы на предмет поиска ключевых слов, которые заставляют людей покупать... Теперь все эти слова доступны Вам!
Узнать подробнее о книге "Слова-Магниты"


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

Мир ПО-43

Компьютерные раскраски

IEtweak Однообразие - одна из вещей, которая раздражает человека. Если изо дня в день вы видите на экране компьютера одно и то же, не имея возможности что-то изменить, то волей-неволей можно зачахнуть. А ведь проблема решается очень просто - IEtweak сможет раскрасить вашу компьютерную жизнь яркими красками.

С помощью IEtweak вы сможете видоизменять фон панелей браузера Internet Explorer, который является, пожалуй, одной из самых часто используемых программ, управлять анимацией в правом верхнем углу окна, сменить надпись в панели задач (скажем, написав вместо "Internet Explorer" - "Пупкин-навигатор"), а также настроить некоторые сетевые характеристики - например, количество файлов, доступных для одновременного скачивания с одного и того же сервера. Кроме этого, программа позволяет сменить язык интерфейса на английский или польский - но это уже для настоящих эстетов.

В новой версии IEtweak 2 1.0.4.1 добавлены новые анимационные возможности, а также исправлены обнаруженные ошибки.

  • Загрузить IEtweak 2 1.0.4.1 (467 кб, англоязычный интерфейс)

"Она может двигать..."

MandrakeMove Компания Mandrake готовится к выпуску нового пакета программ Linux - специально для мобильных пользователей. Продукт будет называться MandrakeMove, а в его состав войдут Mandrake Linux 9.2 Discovery Pack и карточка флеш-памяти USB. Главная особенность в том, что операционка будет работать с компакт-диска без инсталляции, а вся необходимая пользователю информация - настройки системы и файлы - разместятся на карточке памяти.

Ориентировочная стоимость продукта - 70 долларов - включает в себя набор офисных и мультимедийных возможностей, игры и даже программы для работы с трехмерными изображениями. Одним словом, все, что может понадобиться для работы и отдыха. И еще одна важная деталь - если вам вдруг понадобится вставить другой компакт-диск, то Mandrake-CD можно будет вынуть без потерь для операционной системы. Требования к железу"довольно низкие: Pentium II и 128 Мб оперативной памяти - прожиточный минимум для MandrakeMove.

Спрячьте ваши файлы

Hide Files Практически у каждого из нас есть свой скелет в шкафу и секретные файлы на диске. Секреты, как известно, надо хранить под замком - шкаф никогда не отпирать, а файлы никому не показывать. Сделать это, оказывается очень просто - шкаф запереть, а ключ носить на шее. В случае с файлами ситуация еще проще - надо воспользоваться утилитой Hide Files.

Благодаря этой утилите вы сможете надежно скрыть необходимые файлы. После запуска Hide Files появляется окно, и вы сможете добавлять необходимые файлы в список или удалять их. После того как список сформирован - нажатием кнопки "On" вы скроете файлы так, что их не сможет найти ни одна живая душа. Даже тот, кто знает, что папки бывают "скрытыми", вряд ли сможет отыскать секретные данные - они как будто исчезнут. Как только вам надоест эта игра в прятки - запустите программу и нажмите кнопку "Off". Вуаля! Файлы на месте, как ни в чем не бывало. Кстати, при помощи Hide Files можно прятать не только файлы, но и целые папки.

  • Загрузить Hide Files 3.3 (208 кб, англоязычный интерфейс)

Источник: http://www.softkey.info/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Организация печати растрового изображения в приложениях для Windows

Автор: Александр Теут

Однако в реальных приложениях Windows с печатью возникает немало проблем, поскольку толком не описано, как же реализуются сколько-нибудь нетривиальные возможности печати.
Фень Юань. "Программирование графики для Windows"

Начиная создавать пользовательские интерфейсы программ под Windows с помощью библиотеки визуальных компонент (VCL), невольно приходишь к мысли, что разработчики Delphi и C++ Builder свели эту работу для программистов к перемещению мышкой по "Палитре компонент" и нескольким щелчкам её левой или правой кнопки в определённых местах формы. И, действительно, до некоторой степени такая точка зрения справедлива, а такой способ программирования приемлем: при сноровке, можно довольно быстро раскидать различные контролы по форме и далее полностью сосредоточиться на реализации функций, которые они будут выполнять, что позволяет создавать сложные и одновременно качественные программные продукты в кратчайшие сроки.

Но, с приобретением опыта и усложнением задач, становится тесно в рамках только VCL и приходится всё чаще (и надо признать не без удовольствия) окунаться в мир функций пользовательского интерфейса (API) и, в частности, интерфейса графических устройств (GDI), благо обширнейшая справка по ним поставляется вместе с вышеназванными продуктами.

В данной статье мы опишем процедуру вывода на печать растрового изображения средствами VCL и GDI. Сразу подчеркнём, что при кажущейся своей простоте - ведь имеется компонент PrinterDialog и класс TPrinter, вопросы вывода изображения на принтер, пожалуй, являются лидерами по трафику в конференциях по Delphi и C++ Builder.

Прежде чем мы приступим непосредственно к написанию строк кода печати, необходимо разобраться, что собой представляют растровые изображения в Windows, перечислить их типы и дать им хотя бы краткую характеристику.

Растровые изображения в ОС Windows

Растровое изображение представляет собой массив элементов (пикселей) каждый из которых имеет определённый цвет. В настоящее время Windows поддерживает три типа растров: аппаратно-независимый растр (DIB -Device-Independent Bitmap), DIB-секция и аппаратно-зависимый растр (DDB - Device-Dependent Bitmap). К объектам GDI относятся последние два из этого списка, то есть, в основном, только с ними можно работать в рамках GDI. Возможности последней для работы с аппаратно-независимыми растрами сильно ограничены и сводятся всего лишь к двум функциям, позволяющим отображать их на контексты графических устройств. В то же время преимуществом DIB является то, что в отличие от двух других типов растров он содержит в себе полную цветовую информацию, что позволяет выводить такой растр на любом графическом устройстве. Самым распространённым примером подобного типа растра является файл с расширением BMP. Он описывается рядом структур и массивом байтов и схематично представлен на рис.1.

Сразу отметим, мы рассматриваем в данной статье только одну из возможных версий подобных файлов, но зато самую распространённую в настоящее время.

Файл начинается с заголовка, представляющего собой структуру BITMAPFILEHEADER:

typedef struct tagBITMAPFILEHEADER {
WORD bfType;
DWORD
bfSize;
DWORD bfReserved1;
DWORD bfReserved2;
DWORD bfOffBits;
}
BITMAPFILEHEADER;

Заголовок позволяет приложениям определять, что данный файл содержит данные в формате BMP.

Далее следует ещё один заголовок, но уже блока описания растра - это структура BITMAPINFO. Она объявляется следующим образом:

typedef struct tagBITMAPINFO {
BITMAPINFOHEADER
bmiHeader;
RGBQUAD bmiColors[1];
} BITMAPINFO;

Как видно, членами данной структуры, в свою очередь, являются две другие структуры.

Структура BITMAPINFOHEADER, с помощью своих членов, описывает, в частности, геометрические размеры изображения, цветовую глубину пиксела, тип сжатия растра, размер растра и т.д. Более подробную информацию об этой структуре можно почерпнуть из справочного файла по WinAPI.

Массив структур RGBQUAD описывает цветовую таблицу растра в том случае, когда информация о цвете не содержится в самих пикселах. Сама структура RGBQUAD содержит четыре члена:

typedef struct tagRGBQUAD {
BYTE rgbBlue;
BYTE rgbGreen;
BYTE rgbRed;
BYTE rgbReserved;
} RGBQUAD;

Первые три из них задают значения интенсивностей голубого, зелёного и красного цветов, четвёртый член может содержать информацию об альфа-коэффициенте соответствующего пиксела.

Аппаратно-независимый растр без файлового заголовка, а именно с таким объектом работают в GDI, называют упакованным (packed) DIB-растром.

В отличие от DIB, формат DDB-растров известен только драйверу того графического устройства, в котором он выбран. Преимуществом аппаратно-зависимых растров является то, что для работы с ними в GDI существует большое количество функций и структур, к тому же отображение DDB на контексте устройства происходит очень быстро. С другой стороны, так как формат DDB является внутренним, вы не получаете прямого доступа к пикселам растра, и следовательно, не можете обеспечить надёжное копирование его на другое графическое устройство. Это является основной причиной всех трудностей организации печати растров созданных на базе аппаратно-зависимых растров, и приводит к необходимости конвертации DDB в универсальный формат, понятный всем графическим устройствам, то есть в DIB.

Процедура данного преобразования основывается на общей структуре упакованного DIB-растра. То есть, необходимо проинициализировать структуру BITMAPINFO и массив пикселей, извлекая необходимые значения из исходного DDB-растра.

Проще всего подобное преобразование осуществить для изображений, в которых информацию о цвете содержит непосредственно сам пиксел.

На этом теоретическая часть закончена, настало время приступить к практической реализации вышеизложенных сведений.

Построение пользовательского интерфейса и организация загрузки изображения

Создадим рабочее приложение, которое даст нам возможность распечатать растровое изображение. В качестве среды программирования будем использовать Borland C++ Builder v.5.0.

Открываем новый проект и помещаем в форму шесть компонент (рис.2): BitBtn1, BitBtn2, BitBtn3, ScrollBox1, PaintBox1 и OpenPictureDialog1 из "Палитры компонент".

Назначение кнопок можно понять из надписей на рисунке 2. Компонент ScrollBox очень удобен в качестве контейнера для других компонентов, не имеющих среди своих свойств вертикальной и горизонтальной прокрутки. Как раз таким компонентом и является PaintBox, который мы будем использовать для отображения на форме растрового изображения. Одним из основным его свойств является - Canvas, представляющее собой экземпляр класса TCanvas, с помощью которого выполняется большая часть графических операций в приложениях C++ Builder и Delphi (рис. 2).

Всё, интерфейсная часть программы готова! При этом основное время ушло на подбор изображений для кнопок. После дизайна, собственно, и начинается программирование - придание функциональности каждому контролу.

Для работы с растровыми изображениями незаменим VCL класс TBitmap, он, по сути, является оболочкой объекта GDI DIB-секция. Объявим переменную Bitmap в секции private заголовочного файла:

private: // User declarations
Graphics::TBitmap* Bitmap;
В секции public опишем прототип деструктора формы:
public: // User declarations
__fastcall ~TForm1();

Дело в том, что хорошим стилем программирования в C++ считается создание экземпляров класса в конструкторе, а их уничтожение в деструкторе, что несколько отличается от программирования с использованием Delphi, где для подобных целей, как правило, применяются обработчики событий для формы, соответственно, OnCreate и OnDelete.

Создадим в конструкторе формы объект TBitmap и сразу явно зададим его пиксельный формат:

__fastcall TForm1::TForm1(TComponent* Owner)
:
TForm(Owner)
{
Bitmap=new(Graphics::TBitmap);
Bitmap->PixelFormat =
pf24bit;
}

Кстати, по умолчанию, формат пиксела определяется текущими установками цветовой палитры экрана монитора компьютера.

Далее, заранее побеспокоимся об обеспечении уничтожения нашего объекта при закрытии программы, для этого нам понадобится деструктор:

__fastcall TForm1:: ~TForm1()
{
delete Bitmap;
}

Теперь у нас имеется объект, в который мы сможем загрузить растровое изображение.

Растровые изображения будем брать из файлов с расширением BMP. Для этой цели мы подготовили два компонента: BitBtn3 и OpenPictureDialog1. Нам необходимо при щелчке по кнопке BitBtn3 вызвать стандартный диалог открытия файлов, загрузить растровое изображение в Bitmap и нарисовать его на канве компонента PaintBox1. Для решения этой задачи наполним программным кодом тело обработчика события OnClick компонента BitBtn3.

В самом начале вызываем окно навигации для открытия файлов - это одна строка!

if (!OpenPictureDialog1 -> Execute()) return;

Также просто реализована в VCL загрузка аппаратно-независимого растра в объект класса TBitmap:

Bitmap->LoadFromFile (OpenPictureDialog1 -> FileName);

Здесь следует ещё раз обратить внимание на мощь библиотеки VCL. Если реализовывать загрузку подобного типа файлов средствами WinAPI, пожалуй, не обойтись без сотни строк кода.

Далее, предвидя повторяемость операции загрузки изображения, будем возвращать вертикальную и горизонтальную прокрутки компонента ScrollBox1 в начальное положение:

ScrollBox1->HorzScrollBar->Position=0;
ScrollBox1->VertScrollBar->Position=0;

Настало время подготовить компонент PaintBox1 к выводу на него изображения, содержащегося к данному моменту в объекте Bitmap. Вся подготовка сводится к указанию геометрических размеров PaintBox1:

PaintBox1->Width=Bitmap->Width;
PaintBox1->Height=Bitmap->Height;

Затем вызовем событие, отвечающее за его перерисовку:

PaintBox1->Repaint();

Сама перерисовка программируется в обработчике события OnPaint компонента PaintBox1 и занимает всего одну строку в его теле:

PaintBox1->Canvas->Draw (0, 0, Bitmap);

На этом этапе, уже можно запустить проект на выполнение и поупражняться в загрузке различных изображений, рис.3.

Печать изображения

Печать изображения реализуем через вызов обработчика события OnClick кнопки BitBtn2.

Как уже указывалось, сначала нам необходимо преобразовать изображение из аппаратно-зависимого растра в аппаратно-независимый. Для этого построим структуру BITMAPINFO, которая отвечает за геометрические и цветовые параметры растра, и создадим массив байтов, описывающий цвет каждого пиксела растра.

Поскольку мы определили для нашего изображения 24-битный формат пиксела, то структура BITMAPINFO имеет только один член, а именно: BITMAPINFOHEADER.

Заполним её члены.

Сначала инициализируем структуру целиком:

BITMAPINFOHEADER bmiHeader={sizeof(BITMAPINFOHEADER),0};

Далее, присвоим значения полям, описывающим геометрические размеры растра:

bmiHeader.biWidth=Bitmap->Width;
bmiHeader.biHeight=Bitmap->Height;

Следующий член, начиная с 32-битных версий Windows, всегда должен равняться 1:

bmiHeader.biPlanes=1;

Определяющим для наших дальнейших действий является задание битового формата пиксела (или цветовой глубины пиксела), за это отвечает член этой структуры biBitCount:

bmiHeader.biBitCount=24;

Остальные члены структуры инициализированы пока нулём. Таким образом, первую часть задачи преобразования мы решили, обратимся ко второй.

Определим размер массива, который будет содержать растр. Для этого, предварительно, необходимо найти размер строки растра в байтах. Используем стандартную формулу:

int BytesPerRow=((((Bitmap->Width * bmiHeader.biBitCount)+31)&~31)/8);

Если теперь найденную величину мы умножим на высоту изображения, то получим размер растра в байтах (кстати, это значение можно присвоить члену biSizeImage структуры BITMAPINFOHEADER):

bmiHeader.biSizeImage=BytesPerRow * Bitmap->Height;

Динамически создаём искомый массив для пикселей растра:

BYTE* pBits=new BYTE [bmiHeader.biSizeImage];

Далее нам потребуется манипулятор контекста устройства, в котором отображается наш растр, в данном случае это экран нашего монитора:

HDC ScreenDC=::GetDC(0);

Инициализируем конкретными значениями только что созданный массив, для этого используем функцию GetDIBits() (она позволяет копировать пикселы из DDB в DIB). Данная функция через свой 5 параметр возвращает указатель на массив пикселей растра, если в качестве других параметров ей указать манипулятор экрана, манипулятор нашего начального изображения, его геометрические размеры, указатель на структуру BITMAPINFO и, в общем случае, формат цветовой таблицы:

::GetDIBits(ScreenDC, Bitmap->Handle, 0, bmiHeader.biHeight, pBits, (BITMAPINFO*)&bmiHeader, DIB_RGB_COLORS);

Таким образом, мы решили и вторую часть нашей задачи - получили указатель на массив пикселей и этим завершили преобразование аппаратно-зависимого растра в аппаратно-независимый.

Не забудем вернуть манипулятор экрана системе, чтобы избежать утечек ресурсов GDI:

::ReleaseDC (0, ScreenDC);

Здесь, для справки, укажем, что в VCL существуют две функции GetDIBSizes() и GetDIB() (они описаны в файле graphics.pas), применяя которые, также можно производить преобразование DDB->DIB, но такого контроля над процессом преобразования, как в методе, описанном выше, они не обеспечивают.

На этом подготовка к печати завершена. Настала пора обратиться к компоненту PrintDialog из VCL, с помощью которого вызывается окно стандартного диалога печати. В этом окне пользователь, например, может выбрать один из установленных в системе принтеров, задать количество копий, указать тип бумаги и т.д.

Будем создавать данный компонент динамически. Это позволит использовать приложение и в том случае, если у пользователя в системе не установлен ни один принтер (в противном случае при запуске программы будет возникать ошибка, приводящая к её немедленному закрытию). Разумеется, печатать без принтера не получится, но другие функциональные возможности программы останутся доступными. Кстати, трудно представить себе программу, ориентированную исключительно на печать, даже наша демонстрационная программа позволяет хотя бы просто просматривать изображения, содержащиеся в файлах с расширением BMP.

Следующий код, динамически создаёт объект компонента PrintDialog с минимальным набором опций:

TPrintDialog *PrintDlg;

PrintDlg=new TPrintDialog(this);

PrintDlg->Options.Clear();

PrintDlg->Options<<poPrintToFile;

PrintDlg->Copies=1;

Четвёртая строка нужна главным образом, для обеспечения возможности распечатать изображение в файл на этапе отладки программы, что позволяет экономить расходные материалы принтера. Более подробно тестирование печати мы ещё рассмотрим в данной статье.

Далее вызываем стандартное окно для настройки печати:

if(!PrintDlg->Execute())
{
delete [] pBits;
delete
PrintDlg;
return;
}

При успешном завершении этого диалога, собственно, и начинается процесс печати. При неудаче мы уничтожаем все динамически созданные переменные и объекты, сохраняя тем самым ресурсы, отведённые системой нашему приложению.

Как мы уже упоминали, в VCL для подготовки и выполнения операций с печатью существует класс TPrinter. Методами и свойствами данного класса мы сейчас и воспользуемся.

Чтобы начать процесс печати, необходимо вызвать метод BeginDoc():

Printer()->BeginDoc();

Теперь нелишним будет проверить, поддерживает ли выбранный принтер аппаратную палитру, передав функции GetDeviceCaps() манипулятор контекста устройства, выбранного принтера Printer()->Canvas->Handle и индекс RASTERCAPS и затем выполнив над результатом, который вернёт данная функция, битовую операцию "AND" с константой RC_PALETTE:

bool bFlag =::GetDeviceCaps(Printer()->Canvas->Handle, RASTERCAPS) & RC_PALETTE;

Если, в итоге, булевая переменная bFlag будет равняться истине, то следует выбрать палитру объекта Bitmap в контекст устройства принтера и затем позволить системе адаптировать её к нему:

if (bFlag = = true)
{
HPALETTE hOldPal
=static_cast<HPALETTE>(SelectPalette(Printer()->Canvas->Handle,
Bitmap->Palette,
FALSE));
RealizePalette(Printer()->Canvas->Handle);
}

Наконец, рисуем (печатаем) на контексте принтера, вызывая одну из немногих функций (их всего две), позволяющую отобразить аппаратно-независимый растр на графический контекст устройства:

StretchDIBits(Printer()->Canvas->Handle, 0, 0,
Bitmap->Width, Bitmap->Height, 0,0, Bitmap->Width, Bitmap->Height,
(CONST VOID*)pBits, (BITMAPINFO*)&bmiHeader, DIB_RGB_COLORS, SRCCOPY);

Именно для этой функции мы получали экземпляр bmiHeader структуры BITMAPINFOHEADER и указатель на массив пикселей растра pBits.

Если использовалась палитра, вернём контексту устройства исходную.

if (bFlag = =
true)
{
SelectPalette(Printer()->Canvas->Handle, hOldPal,
TRUE);
}

Осталось завершить процесс печати и уничтожить динамические переменные и объекты:

Printer()->EndDoc();
delete[] pBits;
delete PrintDlg;

В принципе, код, обеспечивающий печать растрового изображения, мы написали. Можно попробовать запустить приложение на выполнение, так как кнопка BitBtn2 должна уже функционировать. Но если мы сейчас попробуем распечатать наше изображение, результат печати разочарует. Его размер на листе бумаги, как видно из рис.4, будет неприемлемо мал по сравнению с исходным, представленным на рис.3. К тому же, он будет зависеть от выбранного разрешения печати принтера и размера нашего растра (рис. 4).

Всё дело в том, что контекст устройства экрана монитора, как правило, определяет размеры растра в пикселах, контекст устройства принтера делает это в дюймах. Поэтому в функции StretchDIBits() параметры, которые задают геометрические размеры изображения для печати, должны предварительно быть умножены на определённые весовые коэффициенты, которые необходимо ещё вычислить.

Настройка положения и размера изображения на листе бумаги

Чтобы иметь возможность выбирать положение изображения на листе бумаги и масштабировать его, нам понадобится вычислить физические и печатные размеры листа бумаги, а также определить отступы. Все эти данные, для конкретного контекста устройства (у нас принтер), возвращаются функцией GetDeviceCaps() с соответствующим индексом. В свою очередь эта функция получает их от драйвера принтера, который, кстати, может их ей и не предоставить.

Размеры листа можно определить, передав функции GetDeviceCaps() индексы PHYSICALWIDTH и PHYSICALWIDTH:

int WidthPaper=GetDeviceCaps(Printer()->Canvas->Handle, PHYSICALWIDTH);
int HeightPaper=GetDeviceCaps(Printer()->Canvas->Handle, PHYSICALWIDTH);

Также просто получить и отступы, передавая индексы PHYSICALOFFSETX и PHYSICALOFFSETY:

int OffsetXPaper=GetDeviceCaps(Printer()->Canvas->Handle, PHYSICALOFFSETX);
int OffsetYPaper=GetDeviceCaps(Printer()->Canvas->Handle, PHYSICALOFFSETY);

Зная эти значения, легко вычислить размеры печатной области листа:

int WidthWork=WidthPaper-2*OffsetXPaper;
int HeightWork=HeightPaper-2*OffsetYPaper;

Теперь, чтобы распечатать изображение, например, на весь лист, надо вызвать функцию StretchDIBits() со следующими параметрами:

StretchDIBits(Printer()->Canvas->Handle, 0, 0, WidthWork,
HeightWork, 0,0, Bitmap->Width, Bitmap->Height, (CONST VOID*)pBits,
(BITMAPINFO*)&bmiHeader, DIB_RGB_COLORS, SRCCOPY);

Если необходимо распечатать изображение в определённом месте листа, используйте значения из интервала (0, WidthWork) по ширине листа и (0, HeightWork) по высоте, подставляя их вместо второго и третьего параметров функции StretchDIBits().

Важными характеристиками контекста устройства являются величины, определяющие количество пикселей на дюйм по его высоте и ширине. Найдём их для контекстов устройств экрана монитора и принтера соответственно:

float fScreenX=(float)::GetDeviceCaps(Canvas->Handle,
LOGPIXELSX);
float fScreenY=(float)::GetDeviceCaps(Canvas->Handle,
LOGPIXELSY);
float
fPrinterX=(float)::GetDeviceCaps(Printer()->Canvas->Handle,
LOGPIXELSX);
float
fPrinterY=(float)::GetDeviceCaps(Printer()->Canvas->Handle,
LOGPIXELSY);

С помощью этих величин мы можем вычислить ширину и высоту растрового изображения на листе бумаги принтера в пикселях и использовать их значения, когда требуется распечатать изображение в реальном масштабе:

int iWidthPrint=(int)((float) bmiHeader.biWidth * (fPrinterX /
fScreenX));
int iHeightPrint=(int)((float) bmiHeader.biHeight * (fPrinterY /
fScreenY));

В данном случае, вызывать функцию StretchDIBits() необходимо со следующими параметрами:

StretchDIBits(Printer()->Canvas->Handle, 0, 0, iWidthPrint,
iHeightPrint, 0,0, Bitmap->Width, Bitmap->Height, (CONST VOID*)pBits,
(BITMAPINFO*)&bmiHeader, DIB_RGB_COLORS, SRCCOPY);

Результат печати представлен на рис.6.

Прерывание печати

Всегда следует предоставлять пользователю программы возможность прервать процесс печати, тем более что класс TPrinter позволяет реализовать это очень компактно и эффективно. Достаточно поместить в тело обработчика кнопки BitBtn1 следующий код:

if
(Printer()->Printing)
{
Printer()->Abort();
MessageDlg("Процесс
печати прерван.", mtInformation, TMsgDlgButtons() << mbOK, 0);
}

То есть, сначала через свойство Printing проверяется - находится ли принтер в состоянии печати, а затем, в случае положительного результата, вызывается функция Abort(), которая и прекращает печать. И, наконец, не лишним будет информировать пользователя, о том, что произошло, показав окно с сообщением.

Тестовая печать

После написания программы, значительное время занимает её тестирование. Тестирование печати, кроме времени, ещё и довольно дорогостоящий процесс (принтер, бумага, картриджи), если не предпринять ряд дополнительных мер. Для этого нам понадобится сделать следующее:

  1. Обеспечить в программе возможность печати в файл - это мы уже сделали.

  2. Скачать из Интернета любой вьювер PostScript-файлов. Автор использовал программы GSview и Ghostscript (http://www.cs.wisc.edu/~ghost/).

  3. Найти на CD c Windows и установить драйвер какого-нибудь PostScript-принтера (например, Tektronix Phaser 540).

Вооружившись данными инструментами, мы получаем возможность достаточно точно оценивать результаты нашей печати: расположение рисунка на листе бумаги, его размер.

Дальнейшие действия несложны. Даём команду на печать, в появившемся диалоговом окне "Настройка печати" выбираем из списка принтер (если их несколько), ставим галочку в квадрате "Печать в файл" и нажимаем кнопку OK (рис.5).

Далее появится ещё одно окно. В нём следует указать полное имя файла, в который будет производиться печать.

Для просмотра полученного таким способом файла (имеющего, между прочим, расширение prn), запускаем программу GSview и открываем в ней наш файл.

Таким образом, мы завершили создание простейшего приложения, дающего возможность распечатывать растровые изображения. Хотя функциональные возможности его невелики, но в качестве стартовой площадки оно вполне пригодно для дальнейшего усовершенствования. Трудностей на этом пути, конечно, возникнет множество, но знания, которые возвращаются при их преодолении, окупят многократно все усилия.

Источник: http://www.comprice.ru/

***
Рекомендуем
Телекоммуникации и электроника
Соединительные технологии: кабели, оптоволокно, изоляция, монтаж и др.
 Электромонтаж, Технологии монтажа, Термоусаживаемые трубки, Муфты, манжеты, Соединительные модули, Одиночные соединители, Соединители для жил, Кроссовое оборудование, Арматура герметизации, Соед. компоненты, Материалы для монтажа


Полная защита

Сегодня практически каждый пользователь ПК старается заботиться о своей безопасности и сохранности конфиденциальной информации. Для этого используется множество разных программ. Например, для шифрования файлов нужна одна утилита, для защиты электронной почты - другая, для уничтожения следов, оставшихся от интернет-серфинга - третья, для надежного удаления данных - четвертая... Этот список можно продолжать. А не хотите ли вы, уважаемые читатели, вместо всех этих программ пользоваться только одной? Если да, то обратите свое внимание на комплект утилит Steganos Security Suite, состоящий из семи частей, способных надежно защитить вашу информацию.

Комплекс Steganos Security Suite работает с любой версией Windows, начиная с 98 и заканчивая XP. Загрузить его можно с сайта разработчика , правда, объем дистрибутива достаточно большой - около 14 Мб. Установка Steganos Security Suite не представляет собой никакой сложности. В принципе, этот процесс ничем не отличается от инсталляции любой другой программы. После установки Steganos Security Suite в системном трее появляется еще один значок в виде замочка. При нажатии на него вызывается Steganos Security Suite Center - специальная оболочка для быстрого доступа к утилитам, входящим в комплект. Также из трея можно запускать и каждую программу по отдельности. Ну, а теперь давайте подробнее рассмотрим утилиты, входящие в Steganos Security Suite.

Steganos Safe

Эта утилита предназначена для надежного хранения конфиденциальной информации. Steganos Safe позволяет создавать несколько логических дисков общим объемом до 128 Гб, закодированных с применением 128-битного алгоритма шифрования. Для пользователя это выглядит следующим образом. После загрузки операционной системы диски закрыты. Если пользователю нужна зашифрованная информация, он вводит свой пароль, после чего в системе появляются логические разделы с конфиденциальными данными. В принципе, работа с этими дисками ничем не отличается от обычной работы с винчестером. Можно создавать папки и файлы, копировать и удалять информацию, запускать программы и так далее. Все данные, сохраняемые на логических дисках Steganos Safe, шифруются, как говорится, "на лету", то есть в режиме реального времени, причем скорость этого процесса достаточно велика, чтобы не причинять пользователю серьезных неудобств.

Steganos Portable Safe

Эта утилита, в принципе, также предназначена для хранения секретных данных, но уже не на винчестере, а на дисках CD-R/RW, DVD и различных картах памяти. Принцип работы Steganos Portable Safe во многом похож на Steganos Safe. Пользователь указывает данные для шифрования и пароль доступа к ним. В результате работы программы на рабочем столе создается папка, в которой будет находиться файл с зашифрованной информацией, и специальный пакет, который может распаковать ее на компьютере без установленного комплекта ПО Steganos Security Suite. Таким образом, Steganos Portable Safe - очень удобное и надежное средство для переноса конфиденциальной информации с одного компьютера на другой без использования сетевых технологий.

E-mail Encryption

Сегодня электронная почта очень часто становится инструментом для ведения бизнеса, а поэтому ей частенько доверяют секретную информацию. Да и домашним пользователям вряд ли понравится, если их личную переписку будет читать кто-то другой. Свой вариант решения этой проблемы и предложили разработчики Steganos Security Suite. E-mail Encryption - это утилита для шифрования текста электронного письма и всех прикрепленных к нему файлов. Возможны два варианта работы программы.

В первом случае текст письма набирается в специальном окне E-mail Encryption (или копируется туда из другой программы). Затем указываются файлы, которые должны быть отправлены вместе с этим сообщением. После этого утилита зашифровывает все данные и создает самораспаковывающийся файл с расширением .exe. Естественно, для его запуска нужно ввести правильный пароль, который передан адресату заранее. Ну, а потом этот файл передается нужному человеку любым доступным способом, в том числе и по электронной почте. Второй вариант отличается от первого только тем, что E-mail Encryption автоматически создает в почтовом клиенте письмо, к которому файл в формате cab с зашифрованными данными. Тело сообщения в этом случае содержит инструкцию по распаковке файла.

Steganos File Manager

Эта утилита предназначена для быстрого запрета доступа к любым данным на жестком диске. Просто запускаем Steganos File Manager, указываем файлы и папки, которые нужно спрятать, и пароль для доступа к ним. После этого данные шифруются и помещаются в один файл, который можно сделать самораспаковывающимся. Кроме того, доступ к информации можно получить и из самой утилиты, причем в этом случае с ними можно производить различные операции - например, запускать приложения.

Password Manager

Сегодня менеджер паролей нужен многим интернетчикам. Ведь практически каждый сервис в глобальной сети, включая форумы и чаты, требует регистрации. Пользоваться везде и всюду одним логином и паролем очень опасно. Если злоумышленники каким-то образом получат эти данные, то смогут воспользоваться ими для всех сервисов. Вот и приходится каждому посетителю Интернета запоминать по несколько ключевых слов. Для решения этой проблемы и предназначен Password Manager.

Эта утилита позволяет надежно хранить неограниченное число паролей в зашифрованном виде. То есть вам нужно запомнить всего одно ключевое слово - для доступа к базе Password Manager. Каждый пароль сопровождается описанием и дополнительный информацией. Все ключевые слова можно разбить по собственным категориям. Кроме того, в Password Manager предусмотрен блок генерации безопасных паролей с максимальной длиной 100 символов. То есть все сделано с максимальным удобством. Сгенерировал пароль, указал при регистрации и сохранил в базе. В будущем для доступа к сервису достаточно выбрать ключевое слово из списка и скопировать его для авторизации на сервере. Получается, что пользователь может даже вообще не знать свой пароль, не говоря уже о необходимости его запоминания.

Internet Trace Destructor

Ни для кого не секрет, что после путешествия по Интернету на компьютере остается множество "следов", по которым можно проследить, какие сайты посещал человек. Во многих случаях эту информацию нужно скрыть. Именно для этого и нужна утилита Internet Trace Destructor. Программа быстро очищает сookies, кеш браузеров Internet Explorer, Netscape, Mozilla, Opera, список недавно открывавшихся документов, а заодно и временные файлы Microsoft Office, ICQ и других программ. Internet Trace Destructor может работать в двух режимах - автоматический запуск после окончания работы в Интернете и в режиме реального времени.

Steganos Shredder

Знаете ли вы, уважаемые читатели, что происходит, когда вы в Windows или DOS удаляете файл? Да просто удаляются все указатели на него в таблице размещения. При этом данные с жесткого диска никуда не исчезают. Они остаются до тех пор, пока поверх них не будет записана другая информация. Именно это и используют в своей работе многочисленные программы для восстановления удаленных файлов. Но что же делать, когда нужно уничтожить конфиденциальную информацию и быть уверенным, что уже никто не сможет ее получить? Ответ на этот вопрос прост - нужно использовать Steganos Shredder.

Работа этой утилиты основана на двух методах надежного удаления: полная перезапись и многократная перезаписи данных, основанная на технологии DoD 5220.22-M/NISPOM 8-306 "Департамента США по средствам защиты". И хотя применение Steganos Shredder серьезно замедляет удаление файлов и папок, зато вы можете быть уверены, что никто, даже с применением специальных средств, не сможет получить удаленную информацию.

Ну, а теперь нужно сказать несколько слов и о недостатках Steganos Security Suite. Во-первых, к ним можно отнести отсутствие русскоязычного интерфейса. Во-вторых, Steganos Security Suite - не бесплатная программа. Стоит она около 60 долларов, демонстрационный период - 7 дней. Есть еще и третий недостаток рассмотренного набора утилит. Все-таки некоторые программы Steganos Security Suite несколько менее надежны, чем специальные средства. Например, для шифрования электронной почты лучше использоваться все-таки PGP. Правда, если вашими письмами не будут интересоваться спецслужбы, то никакой разницы, в общем-то, и нет. Тем более что, установив Steganos Security Suite, вы получаете утилиты, способные защитить вашу информацию в различных ситуациях.

Ссылки по теме:

  • Steganos GmbH
  • Дистрибутив Steganos Security Suite
  • Программы для защиты данных в каталоге SoftKey.Ru

Автор статьи: Марат Давлетханов

Источник: http://www.softkey.info/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

Разные картинки

Одной из проблем, с которой сталкиваются владельцы цифровых камер - это забивание диска повторяющимися картинками. Некоторую помощь тут могут оказать разнообразные каталогизаторы и организаторы фотоархивов, но полностью проблему они не решают - все равно рано или поздно, но дубликаты появляются...

Помимо "полных дубликатов" возникает и еще одна сложность - это похожие фотографии. Скажем, вы несколько раз сфотографировали вид из своего окна. Фотографии, безусловно, разные - на одной машинка красная, на другой - она уже уехала, зато прилетела птичка и так далее, но в целом-то фотографии одинаковые... И порой очень хочется эти "похожие наборы" как-то выделить, и поудалять (или убрать подальше) не самые удачные снимки.

Задача только на первый взгляд кажется простой - листай себе какой-нибудь смотрелкой эти фотографии, да сортируй потихоньку... Но коллекция-то растет! И среди новых снимков может оказаться тот самый вид из окна, который вы уже рассортировали в прошлом месяце! Значит, надо регулярно пересматривать все снимки... Но это уже становится проблематичным, особенно если камерой вы пользуетесь не считанные дни, а хотя бы пару лет...

И вот тут на сцену выходит он - DupDetector. Эта бесплатная утилита возьмет заботы по поиску дубликатов на себя. Причем не только возьмет, но еще и весьма успешно с этими заботами справится...

Начать, разумеется, надо со скачивания программы и ее установки. Если вы работаете с WindowsXP, то после установки вам еще надо будет перетащить программу из Windows \ Profiles \ Ваше Имя \ Start Menu \ Programs, где, как она полагает, живут ссылки на программы, туда, где они действительно живут: Documents and Settings \ Ваше Имя \ Start Menu \ Programs. Если вы этого не сделаете, то с удивлением обнаружите, что свежеустановленная программа от вас спряталась...

После этого, запустив программу, вы увидите совершенно непрезентабельное окно выбора действий. Каковых всего три: сравнить все фотографии в наборе, сравнить два набора и сравнить отдельную картинку с набором. Чаще всего используется первый вариант, о котором мы и поговорим. Впрочем, другие действия выполняются аналогично...

На следующей вкладке - Get Data - вам надо определить тот набор фотографий, в котором будут искаться дубликаты. Программа работает с файлами собственного формата, которые сначала надо построить, а потом уже можно будет и просто открывать. Построение набора сложностей не вызывает - надо просто указать папку с фотографиями и сказать программе, надо ли включать в набор вложенные папки. В зависимости от количества фотографий, их размера и скорости вашего компьютера, сканирование может занять несколько минут. Когда набор отсканирован, вы можете сохранить полученный файл с "отпечатками" снимков, используя меню File.

Следующий этап (и следующая вкладка) - собственно, поиск дубликатов. Здесь вам надо определить, насколько точно должны совпадать снимки, чтобы считаться дублями. По умолчанию установлено, что совпадение должно быть от 98 до 100 процентов, но довольно интересные эффекты можно получить, если установить границу, скажем, от 90 до 98 процентов - при этом выберутся только похожие снимки, а вот "полные дубли", наоборот, в выборку не попадут. Этот метод может быть интересен для отбора наиболее удачных снимков из серии... Можно также открыть настройки поиска и детально определить, как именно должны искаться фотографии, но с настройками по умолчанию DupDetector работает очень неплохо, так что "в дебри" лезть совсем не обязательно. Теперь кульминация - вы нажимаете кнопочку "Find dupes", и программа начинает заниматься своей черной магией...

Но не успеете вы насладиться этим состоянием, как выяснится, что все уже закончилось - поиск происходит очень быстро. После этого вам остается только перейти на последнюю вкладку с результатами. В верхней ее части находится лог с указанием адреса каждой фотографии и процента похожести, а в нижней - пара фотографий из найденного списка. Каждую фотографию можно удалить (для этого есть специальная кнопка) или посмотреть в полноэкранном режиме (через контекстное меню). Ну, а если дубликатов найдено очень много, то в меню есть такой раздел - Options, - в котором можно выбрать метод удаления дубликатов: ручной, автоматический или полуавтоматический. В полуавтоматическом вам надо будет для удаления просто нажимать Del или Enter на клавиатуре, а в автоматическом - и это не потребуется...

Вот и весь рассказ про эту маленькую, бесплатную, но такую полезную утилитку...

Ссылки по теме:

  • DupDetector
  • DupDetector на ListSoft.ru

Автор статьи: Дмитрий Турецкий

Источник: http://www.softkey.info/

***
Рекомендуем
Хотите сыграть в пейнтбол?
По сути, пейнтбол - это экстремальный вид спорта, требующий от игроков умения принимать решения в экстремальных ситуациях и взаимодействовать с товарищами по команде, приносящий участникам ни с чем не сравнимый всплеск эмоций
Подробнее >>


Программа "Кадры"
Автоматизация работы кадровой службы для предприятий любых форм собственности.
Построение разветвленной структуры предприятия, ведение штатного расписания.
Ведение учета личных карточек с автоматическим формированием приказов.
Возможность стыковки с бухгалтерскими программами.
Формирование произвольных отчетов по любым параметрам личной карточки.
***

И в горшках растут деревья

Автор: Сергей А. ЯРЕМЧУК

Среди дистрибутивов Linux водятся эдакие киты, монстры, о которых знают все и, естественно, стараются установить в первую очередь. Но они, кроме достоинств, имеют и недостатки. Пожалуй, самый главный из них — они развиваются медленней из-за того, что их разработчикам приходится обременять себя заботами о совместимости, стабильности и т.д. Да и монстры не всегда и не всем симпатичны — особенно тем, кто привык общаться по душам и знает в этом толк.

Уже скопилось порядком Debian-основанных дистрибутивов — среди них и довольно известные Lindows, Xandros, Knoppix, Morphix, египетский MEPIS. Первых два являются коммерческими, остальные можно скачать бесплатно. Герой сегодняшнего повествования — дистрибутив Bonzai (http://www.gnulinux.de), его еще называют Debian on a Diet, был разработан с таким учетом, чтобы его можно было записать на маленький компакт-диск объемом 180 Мб. Bonzai представляет собой, фактически, несколько улучшенную версию Debian. Прежде известный как Mini-Woody, этот дистрибутив был создан немецким разработчиком Маркусом Моллером (Marcus Moeller). Главной задачей его было разработать маленький дистрибутив с самой современной версией ядра и KDE. Разработчики намеревались предоставить пользователю возможность быстро заполучить Debian и, имея уже готовую систему, затем самостоятельно доустановить любой из тысяч пакетов, которые доступны для Debian в Интернете.

К сожалению, сразу стоит отметить, что вся документация по Bonsai, которую можно найти на сайте, — на немецком языке, что, конечно, не лучшим образом сказывается на успехе данного дистрибутива. Но при установке используется принятый в Debian псевдографический инсталлятор, вдобавок, любой документ по использованию родительского дистрибутива вполне актуален и для нашего героя.

Системные требования и приложения

Для тестирования я использовал Bonsai версии 2.1 от 6 июля 2003 года. Минимальные требования — 386i-процессор, 12 Мб ОЗУ и 110 Мб на жестком диске. Хотя для работы в X-Window я бы рекомендовал процессор класса PI и хотя бы 64 Мб ОЗУ (пингвин больше любит мегабайты, а не мегагерцы :-)). Ядро 2.4.20-bf2.4 имеет поддержку файловых систем ext2/3fs, ReiserFS, FAT и ISO9660, имеются и утилиты для работы с ними. В дистрибутиве имеются: KDE 3.1.2 (фактически только база и библиотеки, без большинства приложений), XFree86 4.1.0 (староват, однако), GCC 3.0, Perl 5.6.1, Python 2.1.3, Lynx 2.8, Samba 2.99, Exim 3.35-1, Mutt 1.3, Wget 1.8.1 и Xpdf 1.0.

Установка

Заряжаем диск в CD-ROM, перезагружаемся и получаем приглашение для загрузки. Пройдясь по вспомогательным клавишам F1—F10, можно получить дополнительную информацию по тем или иным особенностям установки. Например, введя в строке приглашения:

мы загрузимся в спасательном режиме, и в качестве корневого раздела будет установлен /dev/hda1. bootkbd=qwerty/ru позволит использовать русскую раскладку клавиатуры. В обычном случае жмем Enter и попадаем в меню выбора языка, на котором программа установки будет общаться в дальнейшем. В списке присутствует более 20 языков, есть среди них и русский. После выбора переключателя клавиатуры попадаем в главное меню программы (полностью, в том числе и комментарии — на русском). Тут думать нечего, программа сама предлагает следующий для выполнения шаг, плюс два альтернативных. Если надо все повторить сначала, выбираем пункт Перезагрузка программы установки — все можно повторить сначала. В этом же меню можно, выбрав нужный пункт, в любой момент просмотреть таблицу дисковых разделов или выйти в shell (простой ash) для выполнения команды. Всего насчитал 23 пункта. А так для установки Bonsai на уже подготовленный диск с двумя разделами (swap и /), которые можно создать при помощи PM, программа предложит пройти десять шагов, а при отсутствии разделов добавится пункт Разбиение жесткого диска на разделы (для этой операции вам присоветуют программу cfdisk). Итак, шаги:

Настройка клавиатуры — программа сообщит, что клава еще как-то не очень настроена, и предложит исправить этот недостаток (можно и пропустить, а потом установить раскладку при помощи kbdconfig, выбрав из большего списка);

Инициализация и активация swap-раздела — программа сама находит раздел, помеченный как Linux swap, после чего, припугнув уничтожением всех данных, отформатирует, подключит и при желании проверит на сбойные сектора;

Инициализация разделов Linux — программа предлагает на выбор одну из трех файловых систем — ext2, ext3 и ReiserFS, после чего указанный раздел форматируется и предлагается указать для него точку монтирования;

Установка ядра операционной системы и модулей — указываем источник, с которого устанавливаем систему (в нашем случае это CD-ROM, но можно и по ftp, http или с раздела жесткого диска) и назначаем путь, по которому лежат необходимые файлы (в нашем случае жмем просто Enter);

Настройка модулей драйверов устройств — я думаю, что этот пункт со страшным названием можно смело пропускать и вернуться к нему, только если действительно что-то не заработает, а так программа установки сама обычно правильно подбирает необходимые модули;

Выбор имени компьютера — здесь понятно, вводим hostname;

Установка базовой системы — копирует базовые файлы на жесткий диск и спрашивает, хотим ли мы сохранить текущую локаль для работы;

Сделать систему загружаемой — конфигурируется загрузчик LILO, причем программа установки сама найдет загружаемые сигнатуры в разделах с другими системами и предложит занести их в список. После чего задается вопрос, куда ставить LILO (в корневой или в MBR). Если выбран корневой раздел, то программа предлагает создать MBR (Create Master Boot Record?) — чтобы иметь возможность добраться до LILO. У меня в MBR уже имелся загрузчик, и я ответил No, а затем откорректировал конфигурацию;

Создание загрузочной дискеты;

Перезагрузка системы.

Вот, в принципе, и все. В процессе установки выдаются вполне понятные объяснения, помогающие определиться с правильным выбором нужного варианта ответа. Пока не выбран последний пункт, всегда можно обратиться к пропущенным пунктам меню или повторить все сначала. Перезагружаемся. После перезагрузки нас встречает программа Debian System Configuration, которую можно вызвать в любое время, набрав /usr/sbin/base-config. Эта программа также пыталась пообщаться по-русски, но на экран выводился нечитаемый текст. Пришлось потыкать в пункты наугад, а затем после завершения установки запустить программу вручную. Последняя позволяет выбрать часовой пояс, установить пароль root, назначить использование паролей MD5 и файла /etc/shadow (странно, что это до сих пор еще спрашивают), добавить обычного пользователя. Попадаем в следующее окно — appselect, где предлагаются приложения для установки, выбираем необходимые. После чего они копируются, устанавливаются и далее автоматически настраивается оборудование, в том числе задаются вопросы по конфигурированию Samba и настройке системы X-Window; при необходимости графического входа в систему устанавливается автоматический старт KDM. На этом установка, собственно, и заканчивается.

Что дальше?

Набор приложений, устанавливаемых с системой, очень мал, даже музыку послушать нечем, хотя звуковая карта была настроена правильно, и при загрузке и работе в KDE были слышны звуки. Список установленных пакетов можно получить, введя dpkg --get-selections | more. Для настройки Ethernet-сети в файл /etc/network/interfaces я добавил информацию о параметрах интерфейса (подробнее в man interfaces):

После чего, добавив в /etc/hosts данные о хостах, перезапустил сервис:

И уже мог наблюдать, что творится в локалке. Если будут проблемы с настройкой карты в комплекте, есть программа, которая поможет в этом — netcardconfig-knoppix. Модемное соединение можно настроить при помощи kppp. А настроив, насладиться удобством работы с пакетом APT (Advanced Packaging Tool). Например, при помощи команды apt-get install имя_приложения можно доустановить все остальное, только перед этим отредактируйте файл /etc/apt/sources.list, в котором указываются источники, в которых данная утилита будет искать файлы для установки (по умолчанию туда занесен только CD-ROM). Чтобы не гадать, какой из трех сотен серверов туда заносить, используйте команду apt-setuр и выберите тот, что на вас смотрит.

***

Я не думаю, что пользователь, уже использующий Debian, перейдет на Bonsai. А вот желающие испробовать этот интересный и, главное, полностью свободный дистрибутив вполне могут заинтересоваться этим проектом и попробовать с ним поработать. Тем более что программа установки проще и понятней, чем у старшего брата (впрочем, Debian'цы свой вариант не считают особо сложным). Вообще, основная проблема новичков — установка и конфигурирование системы, а также X-Window и KDE с KDM — здесь решена. К тому же из множества вариантов поставки Debian не все достойны внимания. И поделом: мне Linux всегда нравился возможностью выбора — приятно ведь, когда есть из чего выбирать.

Linux forever!

Источник: http://www.mycomp.com.ua/

***
Рекомендуем
eBay - крупнейший в мире аукцион в Интернете eBay - крупнейший в мире аукцион в Интернете.
Имеет грандиозную посещаемость. Здесь можно все, что угодно купить или продать. Регистрация совершенно бесплатна. Кстати, многие люди очень плотно занимаются продажей чего-либо на этом аукционе (это для них, как работа) - и у них неплохо получается... в смысле материальных результатов...
А другая категория людей очень выгодно покупает по дешевке ноутбуки, компьютеры, принтеры, сканеры и многое другое!
См. подробнее: http://www.izcity.com/ebay/


Разгоняем окна - оптимизация Windows XP

Автор: Дмитрий Бардиян

Перед тем как вооружаться огромным кулером, подумывая о разгоне процессора, попробуйте для начала разогнать саму операционную систему. Как показывает опыт, скорость работы Windows XP можно ощутимо увеличить путём правильной настройки системы и удаления из неё лишнего мусора. Причём всё это можно сделать своими руками, не прибегая к помощи специализированных утилит. Ведь руками - оно всегда надёжнее, да и приятнее будет.

САМ, САМ, САМ - АВТОМАТИЧЕСКАЯ ОПТИМИЗАЦИЯ

Стараниями разработчиков Windows XP способна сама автоматически проводить оптимизацию. Происходит это таким образом: операционная система (ОС) наблюдает за тем, какие приложения запускает пользователь, и заносит эти сведения в файл layout.ini (windows\prefetch\layout.ini). Выбрав время, когда компьютер не используется, ОС изменяет расположение некоторых программ на жестком диске, в соответствии с информацией в layout.ini. Помимо этого Windows XP ускоряет запуск программ с помощью предсказаний. Система следит за тем, какие компоненты и файлы использует то или иное приложение, и при следующем его запуске предугадывает список файлов, которые потребуются для его работы.

КРАСИВО НЕ ЗНАЧИТ БЫСТРО - ВИЗУАЛЬНЫЕ ЭФФЕКТЫ

Как известно, красота требует жертв, в нашем случае - жертв со стороны производительности. Отключив ненужные визуальные эффекты, можно добиться значительного ускорения работы пользовательского интерфейса, что избавит нас от томительного ожидания выпадающих меню и разворачивающихся окон.

Для начала загляните в свойствах монитора на вкладку "Оформление". Щёлкните на кнопке "Эффекты" и в появившемся окне вы сможете отказаться от эффекта падающих теней и переходных эффектов.

Дальнейшая настройка производительности графического интерфейса выполняется в окне "Свойства системы". На вкладке "Дополнительно" находится раздел "Быстродействие", настройкой параметров которого и предлагаю заняться. После нажатия кнопки "Параметры", в появившемся окне на вкладке "Визуальные эффекты" можно отключить всё лишнее. Визуальные аскеты могут полностью отказаться от всех украшений интерфейса, выбрав пункт "Наилучшее быстродействие".

Отдельного упоминания заслуживает вопрос о выборе метода сглаживания экранных шрифтов. По умолчанию навязывается новая технология улучшения читаемости шрифта - ClearType. Однако существует мнение, что ClearType хорош для ноутбуков и ЖК-мониторов, но на ЭЛТ текст выглядит слишком жирно и смазано. Такого же мнения придерживаюсь я сам, читать действительно удобнее без ClearType. Так что попробуйте выбрать обычный метод сглаживания (вкладка "Оформление" в свойствах монитора) и, как говорится, почувствуйте разницу.

РАСПРЕДЕЛЕНИЕ ВРЕМЕНИ ПРОЦЕССОРА

В "Свойствах системы" на вкладке "Дополнительно" в разделе "Быстродействие" вы сможете управлять распределением времени процессора и использованием памяти (в том числе и виртуальной). Если ваш компьютер не является сервером, то процессор и память рекомендуется ориентировать на оптимизацию работы программ. Если же компьютер - сервер, нужно указать приоритет фоновых служб и кэша. Что касается файла подкачки, то его рекомендуется располагать на любом логическом диске, кроме того, на котором находится папка с самой Windows.

ВОССТАВШИЕ ИЗ АДА - ФУНКЦИЯ ВОССТАНОВЛЕНИЯ

Работает функция восстановления системных файлов следующим образом: ОС периодически создает копии важных системных файлов (файлов реестра, базы данных COM+, профилей пользователей и т.п.) и сохраняет их в качестве "точки возврата". Если какое-либо приложение испортит важные данные, вы сможете вернуться к состоянию, сохраненному в этой точке. "Точки возврата" создаются автоматически службой восстановления системы при установке новых приложений, обновлении Windows, установке неподписанного драйвера и при совершении других критических для системы операций.

По своей сути функция восстановления очень полезна, можно сказать, что она выступает гарантом надёжной работы компьютера. Поэтому отключать её вряд ли стоит, а вот поумерить аппетиты будет весьма кстати. Дело в том, что в основе функции восстановления лежит фоновая служба, которая сама по себе минимально сказывается на быстродействии, но сделанные копии системных файлов занимают драгоценное место на диске. В целях экономии можно вручную ограничить объем дискового пространства, используемого данной службой.

Для этого в окошке "Свойства системы" перейдите на закладку "Восстановление системы" и, выбрав какой-либо из дисков, жмите кнопку "Параметры". Здесь же можно и отключить функцию восстановления. На мой взгляд, функцию восстановления можно отключить на всех дисках кроме системного, дабы не загромождать винчестер лишней информацией.

ОПТИМИЗАЦИЯ С ПОМОЩЬЮ КЛЮЧЕЙ РЕЕСТРА

Вот мы и добрались до самого сокровенного места Windows - реестра. Вначале стандартное предупреждение: будьте осторожны при выполнении приведённых рекомендаций, иначе придётся проверять функцию восстановления в действии.

В реестре находится параметр, включающий анимацию при сворачивании и разворачивании окон. Его отключение увеличит скорость работы графического интерфейса. Адрес таков: HKEY_CURRENT_USER\ ControlPanel\ Desktop\ WindowsMetrics. Ищите MinAnimate и ставьте его значение в ноль (1 - анимация включена, 0 - выключена). Если же этого ключа в реестре нет, тогда создайте его (тип - String).

Чтобы убрать задержку при открытии меню "Пуск" (по умолчанию - 400 миллисекунд), в реестре по адресу HKEY_CURRENT_USER\ ControlPanel\ Desktop измените значение ключа MenuShowDelay на ноль. В этом случае меню будет появляться мгновенно.

Теперь рассмотрим несколько ключей реестра, которые позволяют оптимизировать работу операционной системы с памятью.

Счастливым обладателям более 256 Мб оперативной памяти можно рекомендовать эксперименты с ключом DisablePagingExecutive, что находится в ветви HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ ControlSessionManager\ MemoryManagement. Этот ключ запрещает записывать в файл подкачки коды (драйверы, exe-файлы), всегда оставляя их в физической памяти. Установка значения DisablePagingExecutive в 1 может существенно ускорить работу системы.

Если у вас возникают большие задержки при перезагрузке, тогда по адресу HKEY_LOCAL_ MACHINE\ SYSTEM\CurrentControlSet\ ControlSessionManager\ MemoryManagement найдите ключ ClearPageFileAtShutdown (он позволяет удалять файл подкачки при выходе из Windows). И проверьте, равно ли его значение нулю, поскольку ненулевое значение приводит к большим задержкам при перезагрузке.

Если в папке, которая находится в NTFS-разделе, много файлов, открываться она будет довольно медленно, поскольку каждый раз ОС тратит время на обновление метки последнего доступа к файлам.

Для отключения этой функции нужно по адресу HKEY_LOCAL_MACHINE\ SYSTEM\ CurrentControlSet\ Control\ FileSystem создать параметр NtfsDisableLastAccessUpdate типа DWord и присвоить ему значение 1.

ИЗ-ПОД ЗЕМЛИ ДО СТАНЕМ - УДАЛЕНИЕ СКРЫТЫХ КОМПОНЕНТОВ

В отличие от предыдущих версий, Windows XP при установке не интересуется у пользователя тем, какие компоненты ему необходимы, а какие и вовсе ни к чему. Но это ещё только полбеды. При дальнейшей попытке убрать неиспользуемые компоненты системы, полные праведного гнева, мы запускаем мастер "установки и удаления программ" и вдруг обнаруживаем, что удалять практически нечего - многие компоненты Windows XP просто-напросто скрыты.

Для решения этой проблемы в папке Windows открываем директорию Inf, в которой находим файл sysoc.inf. В файле удаляем во всех строках слово hide, но удалять при этом следует только hide, оставляя запятые до и после этого слова.

Например, если исходная строка выглядела так: iis=iis.dll,OcEntry,iis.inf,hide,7 то должно получиться следующее: iis=iis.dll,OcEntry,iis.inf,,7.

После сохранения файла sysoc.inf, мастер компонентов Windows покажет нам значительно более длинный список, чем прежде...

СКРИПАЧ НЕ НУЖЕН - ЛИШНИЕ СЛУЖБЫ

Важную роль в оптимизации производительности Windows XP может сыграть настройка системных служб. Для управления ими следует запустить в меню "Пуск" команду "Выполнить", после чего в появившемся окне набрать services.msc.

Перед тем как производить эксперименты со службами, сохраните раздел реестра HKEY_LOCAL_ MACHINESYSTEMCurrentControlSetServiсes (щелкните на указанном разделе правой кнопкой мыши и выберите пункт "Экспортировать").

Ниже приведён список служб, которые в общем случае можно безболезненно отключать.

Machine Debug Manager - управляет местной и удаленной отладкой с помощью компонентов Visual Studio.

NetMeeting Remote Desktop Sharing - разрешает проверенным пользователям получать доступ к рабочему столу, используя NetMeeting.

QoS RSVP - обеспечивает рассылку оповещений в сети и управление локальным трафиком.

Telnet - позволяет удаленному пользователю входить в систему и запускать программы.

"Автоматическое обновление" - включает автоматическую загрузку и установку критических обновлений Windows.

"Диспетчер очереди печати" - загружает в память файлы для последующей печати. Лучше отключить, если нет принтера.

"Диспетчер сеанса справки для удаленного рабочего стола" - управляет возможностями удаленного помощника.

"Журналы и оповещения производительности" - управляет сбором данных о производительности с локального или удаленных компьютеров.

"Источник бесперебойного питания" - управляет работой источников бесперебойного питания, подключенных к компьютеру. Если таковых нет, то службу отключаем.

"Клиент отслеживания изменившихся связей" - поддерживает связи NTFS-файлов, перемещаемых в пределах компьютера или между компьютерами в домене. При отсутствии NTFS отключаем.

"Модуль поддержки NetBIOS через TCP/IP" - включает поддержку службы NetBIOS через TCP/IP.

"Модуль поддержки смарт-карт" - обеспечивает поддержку для старых устройств чтения смарт-карт. Если такими устройствами не пользуетесь, то службу отключаем.

"Обозреватель компьютеров" - обслуживает список компьютеров в сети и выдает его программам по запросу.

"Оповещатель" - посылает выбранным пользователям и компьютерам административные оповещения.

"Планировщик заданий" - позволяет настраивать расписание автоматического выполнения задач на компьютере.

"Серийный номер переносного медиа-устройства" - получает серийные номера всех переносных медиа-устройств, подключенных к системе.

"Сетевой вход в систему" - поддерживает сквозную идентификацию событий входа учетной записи для компьютеров домена.

"Служба COM записи компакт-дисков IMAPI" - управление записью компакт-дисков встроенными средствами Windows. Если не отключить, могут возникнуть проблемы с записью дисков сторонними программами.

"Служба времени Windows" - управляет синхронизацией даты и времени на всех клиентах и серверах в сети.

"Служба загрузки изображений" - обеспечивает службы получения изображений со сканеров и цифровых камер. Можно отключить, если таковых нет.

"Служба индексирования" - индексирует содержимое и свойства файлов на локальном и удаленных компьютерах.

"Служба обнаружения SSDP" - включает обнаружение UPnP-устройств в домашней сети.

"Служба сообщений" - посылает и получает сообщения, переданные администраторами или службой оповещений.

"Службы терминалов" - позволяет подключаться к локальной машине по сети и удаленно работать на ней.

"Съемные ЗУ" - если не пользуетесь ZIP-дисководами и прочими, можно отключить.

"Удаленный реестр" - позволяет удаленным пользователям изменять параметры реестра на локальном компьютере.

Источник: http://www.comprice.ru/

***
Рекомендуем
Попробуйте бесплатно! Runbox mail - почтовый вэб-сервис нового поколения
 100MB дискового места под почту
Антиспам и антивирусные фильтры
Возможность отправки и получения больших сообщений - до 20 MB каждое
Полное отсутствие рекламных баннеров и другой рекламы на сервисе
Неограниченный трафик и многое другое
Почтовый сервис отвечающий всем современным требованиям и спецификациям:
Подробнее >>


Информация

Свежие номера здесь! Служебная информация
  • Реклама в журнале
  • Для авторов, желающих публиковаться
  • Условия использования материалов
  • Подписка на рассылку

Реклама в журнале

Версия от 07.12.2003г.

Информация о журнале:
От обычных рассылок, рассылаемых по почте, журнал отличается тем, что это не одинарный листок с информацией, а действительно полноценный электронный журнал (содержащий внутри себя массу страниц с информацией и графикой, систематизированными по рубрикам).
Большинство пользователей, скачивающих журналы - создают у себя на компьютере электронную библиотеку, т.е. хранят у себя на компьютере архивы журналов.
Соответственно, рекламная информация размещенная в журнале - имеет гораздо более длительный "срок жизни", чем реклама в обычных рассылках.

Количество загрузок каждого номера вы можете посмотреть здесь: http://www.izcity.com/down/doc0.html
В среднем порядка не менее 17-20 тыс. человек скачивают и читают каждый номер. Количество постоянных читателей (как минимум раз в месяц загружающих и просматривающих какой-либо выпуск журнала): не менее 50 тыс. человек
Периодичность выхода журнала: 8-10 выпусков в месяц.

Расценки:

Где размещено | Тип рекламы | 1 выпуск | 3 выпуска | 10 выпусков
Главная страница журнала | баннер 468х60 вверху | $5 | $12 | $30
 | Статья до 5000 знаков | $5 | $12 | $30
Внутри журнала баннер (сквозной по журналу, на всех страницах со статьями, кроме главной и нескольких служебных) | баннер 468х60 вверху | нет | нет | $30
 | баннер 468х60 внизу | нет | нет | $20
Статья рекламная внутри журнала | Статья до 7000 знаков | $3 | $7 | $20

Примечание:

  • Текст вместо баннера: вместо баннера вверху или внизу можно размещать текстовый блок до 300 знаков или текстово-графический блок (помимо текста может присутствовать небольшая картинка)
  • Бесплатно: в вашей статье или материале могут также присутствовать одно или несколько графических изображений общим "весом" не более 30 кб.
  • При подсчете знаков html-тэги не учитываются, а пробелы учитываются.
    Для того, чтобы правильно подсчитать знаки в вашем рекламном объявлении - используйте, например текстовый редактор Word. Скопируйте в него ваш текст, а затем в меню Word найдите пункт Статистика. Все сразу и увидите.
  • Форматы присылаемых текстовых блоков, материалов и статей:
    HTML, HTM, Word (doc) или RTF. Если статья с графикой, то можете все это дело упаковать в zip-архив и в таком виде прислать нам. Обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам.

Как платить?
Все расчеты производятся при помощи платежной системы WebMoney.
Наши кошельки:
Z906510760241
R211650054260
Если вы не знакомы с этой платежной системой, то зайдите к ним на сайт, почитайте. Все на русском языке, просто и понятно. Денежные переводы и расчеты производятся моментально, в режиме реального времени через Интернет.

Порядок оформления рекламного заказа:
- Переводите нужную сумму денег на наш кошелек в системе Webmoney
- В примечании к переводу оставьте какой-нибудь комментарий, в котором укажите ваш емейл или адрес сайта, или фамилию, или название организации. Чтоб мы могли понять, от кого пришли деньги...
- Затем присылаете письмо с сообщением о переводе денег и вашим рекламным текстом (статьей) или баннером.
- Ваша реклама выходит в ближайшем свободном выпуске журнала (в течении 2-4 дней).

По вопросам размещения рекламы обращаться: reklama@izcity.com
Дополнительно смотрите другие наши рекламные услуги

Вверх | На главную

Для авторов

Версия текста от 19.10.2003г.

Хотите публиковаться?
Стать нашим автором несложно... Если вы пишете статьи, если вы считаете, что они интересно, талантливо написаны, то у нас с вами есть повод для сотрудничества.
Нас интересуют статьи, описания, руководства... Тематика: компьютеры, Интернет, программы; описания утилит; обзоры железа, периферии, софта; примеры решения каких-либо компьютерных проблем и т.д. В общем интересно все, что относится к компьютерной тематике и Интернету.

Требования к материалам:

  • Статьи принимаются к публикации у нас только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Актуальность, ясность и простота изложения, последовательность и логичность, четкость формулировок и аккуратное использование терминов, точность в научных и технических сведениях. В статье могут быть указаны реквизиты автора: емейл, ссылка на сайт и т.д. Дополнительно: в двух-трех предложениях автор может написать о себе. Также может выразить благодарность компаниям или лицам, оказавшим помощь при подготовке материала. Соответственно могут быть указаны реквизиты организаций, предоставивших продукты или программы для тестирования или обзора.
  • Форматы присылаемых материалов: DOC (Microsoft Word), RTF, HTML (HTM).
    Если вы используете в статье графику (логотипы, скриншоты и т.д.), то сразу вставляйте графику в HTML. Графика не должна быть громоздкой и иметь большие размеры. Желательно не более 30 кб. графики (общий "вес") на одну статью... Кроме того, изображения (картинка, скриншот) в статье не должны превышать 370 пикселей в длину по горизонтали.
    Проверьте правильность ссылок. Статью и графику к ней будет логичным объединить в один каталог, упаковать архиватором и в таком виде переслать нам.
    Если ваша статья без графики и состоит из одной страницы, то этот документ можно просто прислать вместе с письмом.
  • Отсутствие ошибок: грамматических и орфографических (проверяйте тексты в Word, плюс сами читайте, перед тем как нам отправлять...)
    Обратите внимание: обязательно проверяйте тексты на наличие ошибок перед отправкой на публикацию к нам... Статьи, содержащие много ошибок - не публикуются!
  • Статьи о спонсорах и заработке - грамотные содержательные статьи общего плана публикуются бесплатно. Статьи рекламного характера, с реферральными ссылками публикуются на правах рекламы
  • Рекламные статьи любой тематики (явно рекламирующие компанию, платные продукты или услуги) публикуются на правах рекламы.

Взаимоотношения с авторами:
Денег мы не платим, однако мы предлагаем альтернативные варианты поощрений для авторов. Для начала скажем, что понятное дело - вы в статье можете указать свои авторские реквизиты: емейл, ссылку на свой сайт и т.д. Таким образом, вы получите дополнительный приток людей на свой сайт. Ведь, не секрет, что хорошая статья о каком-либо продукте или услуге, со ссылкой на сайт - неизбежно вызовет приток посетителей на этот сайт.
Если вы достаточно часто будете публиковать статьи, то за вами вполне может закрепиться имидж эксперта в той или иной области.

А теперь о поощрениях за опубликованные у нас статьи:
За каждую статью, опубликованную в нашем журнале вы получаете бесплатно рекламный блок в нашей рассылке IZone Web (это правило действует с 14.08.2002г.; о рассылке IZone Web: на 19.10.2003 г. более 150 тыс. подписчиков, статистику на сегодняшний день можно посмотреть с этой страницы: http://www.izcity.com/info/reklama2.htm).
Рекламные блоки предлагаются в следующем соотношении:

  • Статья до 5000 знаков - текстовый блок до 200 знаков

  • Статья до 7000 знаков - текстовый блок до 300 знаков

  • Статья до 10000 знаков - текстовый блок до 500 знаков

Рекламные блоки бесплатно размещаются в нижней части рассылки IZone Web. Можно присылать заявку на размещение вашего рекламного блока после каждой вашей статьи. Можно опубликовать несколько статей у нас, а потом спустя некоторое время прислать заявку на размещение группы ваших блоков.

Если вы подаете заявку на размещение у нас рекламного блока после каждой вашей статьи, то форма подачи заявки следующая:
Присылаете письмо, в котором должны обязательно присутствовать следующие моменты:
- Название вашей статьи, количество знаков без пробелов в статье и номер выпуска журнала, в котором ваша статья опубликована.
- Текст вашего рекламного блока (объявления)
Ваш рекламный блок выйдет в одной из ближайших рассылок (в течение 2-4 дней).

Если вы подаете заявку на размещение у нас сразу нескольких рекламных блоков после публикации нескольких ваших статей, то форма подачи заявки следующая:
- Названия ваших статей, количество знаков без пробелов в каждой статье и номера выпусков журнала, в котором ваши статьи опубликованы.
- Текст вашего рекламного блока (или блоков).
- Ваши комментарии по вашей рекламе у нас (количество раз публикаций которые вам причитаются; также в зависимости от этого текст и размеры у рекламных блоков могут быть одинаковыми, а могут быть и разными). Пожалуйста четко указывайте в ваших комментариях все нюансы, чтобы мы вас поняли с первого раза.
Ваша рекламная кампания начнется в одной из ближайших рассылок (в течение 2-4 дней) и будет продолжаться положенное вам количество времени (выпусков рассылки).

Обратите внимание:

  • Вы имеете право на получение бесплатного рекламного блока только в случае факта публикации вашей статьи.
  • Статьи принимаются нами только от непосредственных авторов статей или правообладателей материалов. Чужие, "содранные" откуда-то и ворованные статьи НЕ ПРИНИМАЮТСЯ к публикации.
  • Присланные нам статьи не резензируются, не комментируются, не возвращаются. В переписку с авторами, редакция не вступает.

P.S. Мы оставляем за собой право:

  • На распространение копий присланных нам материалов
  • Не публиковать материалы противоречащие нашей концепции.
Статьи для публикации присылать на адрес editor@izcity.com, тема: avtor

Рекламные блоки для размещения в нашей рассылке присылать на адрес reklama@izcity.com, тема: free

Вверх | На главную

Условия использования материалов

Использование материалов нашего журнала регламентируется настоящими правилами (с 15.09.2003г.).

Использование CHM-файлов
Если вы хотите использовать у себя полностью chm-файлы с номерами журналов (например, вы провайдер и хотите выложить журналы у себя на ftp-сервере, или у вас архив софта и вы хотите некоторые архивы журналов держать у себя на сайте), то нет никаких проблем... Можно использовать при соблюдении следующих факторов:
1. Нельзя ничего внутри изменять (ну это, как вы знаете - общее правило...).
2. При использовании обязательна ссылка на нас. Ссылка должна указывать на наш сайт http://www.izcity.com

Использование отдельных статей из выпуска
Наши собственные статьи, т.е. статьи наших авторов (отсутствует под статьей ссылка на источник) - можно использовать с указанием ссылки на наш сайт http://www.izcity.com
Использование статей с других источников (под статьей есть ссылка на источник информации) - запрещено.

О наших материалах
Информационную начинку нашего журнала составляют, как материалы собственных авторов, так и дайджест с наиболее популярных компьютерных ресурсов Рунета. Все публикуемые у нас материалы - юридически чисты. Каждый материал (или статья) в нашем журнале имеет своего автора или правообладателя (собственника прав на статью). Все материалы публикуются либо с разрешения авторов или владельцев авторских прав, либо присылаются ими непосредственно в редакцию IZone для публикации.

Вверх | На главную

Подпишитесь на нашу рассылку IZone WEB!
Своевременно полученная информация - залог успеха. Для того, чтобы всегда быть в курсе всех наших новинок - подпишитесь на нашу рассылку. Удобно и практично: наша информация будет доставляться в ваш почтовый ящик. Периодичность рассылки: 3 раза в неделю.
Наши подписчики получают краткую аннотированную информацию обо всех новинках нашего сайта. Это выход свежих номеров журнала "Internet Zone", бесплатные программы, различные утилиты, средства и сервисы для создания и "раскрутки" сайта, различная компьютерная документация и т.д.
Для подписки на рассылку - посетите нашу страницу подписки в Интернет по адресу: http://www.izcity.com/info/sub.htm либо воспользуйтесь формой справа (необходимо подключение к Интернет)
Подписка на рассылку
Рассылка MailList.Ru

Вверх | На главную


Работа с журналом

Помощь при работе с журналом

Свежие номера здесь! Версия текста от 28.11.2003 г.

Системные требования

Операционная система, начиная от Windows98 и выше.
В системе должен быть установлен браузер Internet Explorer версии начиная от 5.0 или выше.
!!! Обязательно в браузере должны быть включены: поддержка java-скрипт, показ рисунков и анимации.
Разрешение экрана монитора желательно должно быть не менее, чем 1024х768.

Для тех, кто в первый раз...

Что такое CHM?

Compiled HTML - специально разработанный Microsoft формат данных для поддержки гипертекстовых справочных систем. Не требует специальных средств для просмотра. Всё уже есть в Windows. В этом формате сделаны справки к браузерам IE, начиная с четвертой версии и выше, справка к Microsoft Office и т.д.

Как лучше начать просмотр выпуска журнала?

Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню слева и выбрать Открыть все. Данная операция одним махом открывает все вложенные в папки страницы. По окончанию просмотра журнала, аналогично можно выбрать Закрыть все.
Весьма удобно - пользуйтесь. Можно открывать рубрики и поодиночке - используйте крестик слева от папки/рубрики.

Навигация: кнопки вверху

Назад/Вперед
Данные кнопки аналогичны одноименным кнопкам в браузере. Служат для быстрого перемещения между просмотренными страницами

Домой
Нажав на эту кнопку, вы попадете на стартовую страницу

Шрифт
Весьма полезная кнопка. Регулирует размер шрифтов для просмотра. Нажимаете и все. Шрифты меняются по кругу. Обязательно найдется устраивающий вас размер шрифта. Если установки размера шрифтов по умолчанию вас устраивают, то можете вообще не пользоваться данной кнопкой.

Печать
Вывод на печать необходимой вам страницы. Если у вас установлен принтер, то можете пользоваться.

Параметры
Различные настройки и команды.

Навигационное меню слева

- В зависимости от размеров вашего монитора, вы можете зацепить мышкой и расширить/сузить границу-бордюр между навигационным меню и правой частью журнала со статьями.

- Одинарный щелчок мышкой по крестику слева от папки/рубрики (или двойной щелчок по названию) открывает содержимое папки. Обратная операция: щелчок мышкой по минусу (или двойной щелчок по названию) - закрывает папку/рубрику.

- Можно щелкнуть правой кнопкой мышки по любой из папок или по любому пустому месту меню и в зависимости от текущего состояния папок, вы можете выбрать Открыть все/Закрыть все. Данная операция одним махом открывает/закрывает все вложенные в папки страницы.

- Если вы усиленно используете принтер, то здесь же, щелчком правой кнопки мышки по папке можно выбрать варианты печати.

- В Навигационном меню также присутствует вверху закладка Избранное. При просмотре вы можете понравившиеся статьи заносить в Избранное для последующего быстрого доступа к этим статьям.

Разное

Просмотр страниц

При щелчке правой кнопкой мышки по просматриваемой странице - появляется меню с командами.

Используйте клавиатуру

При просмотре выпуска удобно использовать клавиши клавиатуры. Например, клавиши Page Up и Page Down служат для быстрой прокрутки. А вот клавиши справа внизу на клавиатуре со стрелками вверх и вниз - удобно использовать для плавной прокрутки читаемой страницы.

При просмотре CHM-выпуска журнала вместо рисунков вижу только рамки, а сами рисунки не видны.
Также не мигает, как бы застыл анимированный баннер внизу некоторых страниц.

Для корректной работы CHM-формата требуется установленный в системе браузер Internet Explorer и соответственно CHM-формат использует его настройки. В вашем браузере отключен показ рисунков и анимации. Включите их (Сервис > Свойства обозревателя... > вкладка Дополнительно)

Каким образом открыть отдельную страницу выпуска в отдельном окне браузера Internet Explorer?

Кликнуть правой кнопкой по любому месту на странице, в появившемся контекстном меню выбрать "Свойства", значение поля "Адрес (URL)" скопировать в буфер обмена, вставить в адресную строку IE и нажать Enter (или кнопку "Переход" в браузере). Нужная вам страница откроется в браузере
(правда, обратите внимание: при попытке сохранить такую страницу на диск в виде html - сохранится только текст, без картинок, хотя при просмотре картинки будут доступны).

Как сохранить на диск (в формате HTML) одну или несколько понравившихся мне статей (или даже целиком весь выпуск) полностью со всем оформлением, включая и графику?

Для этого придется распаковать/декомпилировать весь выпуск. См. здесь: http://www.izcity.com/info/chm.htm

Как осуществить поиск в пределах одной страницы?

Используйте сочетание клавиш Ctrl-F.

Как распечатать текущую страницу?

Используйте сочетание клавиш Ctrl-P.

В chm-выпуске вашего журнала нашел интересующую меня программу. Как ее скачать не браузером, а моей качалкой, т.е. download-менеджером?

Рассмотрим данный момент на примере популярной качалки FlashGet (http://www.amazesoft.com/). Итак, вот несколько способов для того чтобы скачать нужный вам файл, используя качалку.

1. Первый способ. Стандартный, не требующий от вас лишний телодвижений. Если ваша качалка интегрирована с браузером (производит слежение за кликами), то никаких проблем возникнуть не должно. При клике по ссылке, будет происходить запуск качалки. Если этого не происходит, то проверьте за какими типами файлов ваша качалка производит слежение. Например, во FlashGet по умолчанию не "заряжено" слежение за avi-файлами. Добавьте этот формат вручную в настройках FlashGet.

2. Второй способ: откройте у FlashGet Корзину (выберите в настройках ее показ). И теперь при просмотре chm-выпуска журнала - просто мышкой перетаскивайте нужные вам ссылки в Корзину FlashGet. Вуаля!
Помимо FlashGet, Корзинку имеют и все другие продвинутые качалки. Например, ReGet и т.д.

3. Если файлов, которые нужно скачать, на странице очень много, например 30-40 шт.:), то можно вообще открыть нужную вам страницу в отдельном окне браузера Internet Explorer (см. выше как это сделать), ну а далее выберите в контекстном меню браузера (щелчок правой кнопкой по странице) команду: Закачать все при помощи FlashGet. В появившемся окне FlashGet вручную или с помощью фильтров можно подкорректировать опции загрузки (если что-то ненужное попадет в список загрузки).


IZone

Свежие номера здесь!
IZONE
554
9.12.2003

Полезный совет:
Щелкните правой кнопкой мышки по любому месту в меню слева и выберите Открыть все.

Полезный совет-2:
Почитайте как работать с журналом в папке Your help

Полезный совет-3:
Скачайте другие
выпуски

IZONE
электронный
компьютерный журнал
о высоких технологиях
Читай лучшее!

9-ти язычный говорящий переводчик ASSISTANТ AT-2092

Впервые карманный переводчик выполнен в виде КПК с сенсорным экраном.
Впервые многоязычный переводчик имеет такой большой обьем слов - по 20 тысяч слов на каждый язык и большой разговорник на 2 тысячи фраз.
Впервые переводчик имеет синтезатор речи на всех языках
(английский, немецкий, китайский, японский, корейский,
русский, французский, испанский, итальянский).

ASSISTANT AT-2092

Технические характеристики AT-2092

Синтезатор речи | на 9-ти языках
Записная книжка | 32 кб
Калькулятор | 12 разрядный
Часы | да
Календарь | да
Будильник | да
Мировое время | да
Пересчет валют | да
Метрическое преобразования | 8 пар единиц измерения
Дисплей | сенсорный
Подсветка | да

Цифровые диктофоны
DAINET
Купить ASSISTANT AT-2092 Цена 110$

Более 20 видов карманных переводчиков на сайте http://www.slovary.ru/

г. Москва ул. Новопоселковая д.6 корп.7 тел. (095) 497-5361, 497-5570