Новые возможности

Программа установки Batch была полностью переработана для Windows 98.

Теперь она включает расширенную обработку ошибок и богатые возможности автоматизации установки, чем программа для Windows 95. В большинстве случаев можно воспользоваться командой Собрать сведения для создания файла .inf непосредственно из реестра данного компьютера, что ускоряет процесс создания файла сценария и устраняет необходимость его долгой настройки.

Программа Batch позволяет также настроить программу установки Internet Explorer 4.0, а также всех новых параметров оболочки и рабочего стола. Например, нетрудно задать параметры безопасности Интернета и прокси-сервера для всех компьютеров, на которые выполняется установка системы.


Справка по программе пакетной установки Batch

Общие сведения о программе Batch 98

Программа Batch 98 позволяет легко создавать сценарий (файл .inf) для автоматизации установки системы Windows 98. Затем программа установки Windows 98 обращается к этому файлу вместо запросов каждого типа сведений у пользователя, позволяя автоматически и быстро установить Windows 98. Выполнение программы установки с помощью сценариев Batch 98 делает установку Windows проще и быстрее, особенно для компьютеров в сети.

Программа Batch 98 имеет следующие возможности.

  • Параметр Собрать сведения позволяющий создать файл .inf из локального реестра для известных параметров.

  • Сценарий установки, созданный программой Batch, позволяет автоматически установить Windows 98, операционную систему и другие компоненты, не требуя ввода дополнительных сведений во время установки, например, вида установки, папки установки и т. п. Это основное применение пакетной установки, наиболее полезное при установке Windows 98 на несколько компьютеров. Программа установки Windows 98 запросит только пропущенные параметры.

  • Программа Batch позволяет настроить параметры Windows 98, которые обычно изменяются после установки. Они включают сетевые параметры (протоколы, службы и т. п.).

  • Параметры пакетной установки позволяют ограничить их выбор во время установки системы, обеспечивая то, что каждый новый компьютер будет иметь одинаковый набор установленных дополнительных программ.

  • Пакетная установка гарантирует, что каждая установка Windows 98 совпадает с предыдущей, что упрощает поддержку нескольких компьютеров.

Для получения дополнительных сведений о параметрах пакетной установки просмотрите раздел Создание файла сценария (.inf), либо приложение D, "Msbatch.inf Parameters", из Windows 98 Resource Kit.

Данная версия программы Batch.exe является 32-разрядным приложением, использующим общие элементы управления Windows 95. Оно работает только в системе Windows 98. Автоматический анализ реестра не поддерживается в системе Windows NT.


возможности пакетной установки

Использование возможностей пакетной установки

Пакетная установка позволяет задать и автоматизировать почти каждый параметр, доступный при установке системы Windows 98.

  • Сведения о компьютере и пользователе: Можно задать имя пользователя, название организации, имя компьютера, рабочую группу и описание компьютера. Эти параметры доступны в диалоговом окне Основные параметры установки на вкладке Пользователь.

  • Сетевые клиенты: Возможен выбор автоматической установки клиента для сетей Microsoft и клиента для сетей NetWare 3.x/4.x. Можно также задать параметры для каждого клиента, включая проверяемый вход в сеть, основной сервер, вход по умолчанию, имя первого сетевого диска и т. д. Допускается также включение поддержки многих других сетей. Данные параметры доступны в диалоговом окне Параметры сети.

  • Сетевые протоколы: Включается поддержка автоматической установки наборов протоколов защищенного режима для протоколов NetBEUI, IPX/SPX, TCP/IP и 32-разрядного протокола DLC. Можно также определить параметры протоколов IPX/SPX и TCP/IP. Данные параметры доступны в диалоговом окне Параметры сети на вкладке Протоколы.

  • Сетевые службы: Можно выбрать установку службу доступа к файлам и принтерам как для сетей Microsoft, так и для сетей NetWare 3.x/4.x. С помощью сведений из пакета Windows 98 Resource Kit включите поддержку для дополнительных сетевых служб, клиентов и протоколов.

  • Управление пользовательской установкой: Программа Batch упрощает администрирование интерфейса пользователя во время установки системы Windows 98. Администраторы могут задать параметры установки Windows 98, которые недоступны для изменения пользователем, а также значения параметров, используемые по умолчанию. Это позволяет администраторам в полной мере управлять пользовательской установкой.

  • Поддержка принтеров: Имеется возможность настроить принтеры с помощью пакетной установки. Выберите установку определенных принтеров (даже сетевых принтеров) или пропустите мастер установки принтеров. Для получения дополнительных сведений выберите ссылку Принтеры.

  • Дополнительные компоненты: Пакетная установка позволяет задать дополнительные компоненты, которые необходимо установить во время установки Windows 98. Более того, мощные средства раздела дополнительных компонентов позволяют администраторам ограничить выбор и включение новых компонентов, что как правило недоступно при обычной установке Windows 98. Для получения дополнительных сведений выберите ссылку Дополнительные компоненты.

  • Поддержка удаления установки: Пакетная установка позволяет автоматически собрать сведения для отмены установки, автоматически пропустить мастера отмены установки или выдать запрос об этом к пользователю во время установки.

  • Возможность установки на несколько компьютеров: Пакетная установка позволяет сохранить до 9999 отдельных файлов .inf одновременно. С помощью текстового файла с именами компьютеров (и, при необходимости, IP-адресов) нетрудно сохранить сразу несколько файлов .inf, созданных по одинаковому шаблону. Эти параметры предоставляются в диалоговом окне Список имен компьютеров.

  • Автоматическое создание файла .inf на основе текущих параметров реестра: Пакетная установка позволяет просканировать существующий реестр (на компьютере с системой Windows 98) и создать файл .inf на основе обнаруженных сведений. Для получения дополнительных сведений выберите ссылку Сканирование реестра.

  • Другие параметры: Программа пакетной установки Batch позволяет указать многие параметры, которые как правило недоступны во время обычной установки, например разрешение экрана и цветовая палитра, а также пропустить многие диалоговые окна программы установки и т. п.


Создание основного файла пакетного сценария (.inf)

  1. Откройте программу Batch 98 (Batch.exe).

  2. Нажмите кнопку Собрать сведения.

  3. Выберите Основные параметры установки, выберите вкладку Пользователь, заполните соответствующие поля и нажмите кнопку OK.

  4. Если этих параметров достаточно для вашей пакетной установки, выберите Сохранить параметры в INF-файл для создания файла .inf и выхода из программы Batch 98.

Определение дополнительных параметров:

  1. В диалоговом окне Основные параметры установки, выберите каждую вкладку, заполните соответствующие поля и нажмите кнопку OK.

  2. Нажмите кнопку Дополнительные компоненты, чтобы выбрать компоненты для включения в окончательную установку Windows 98. Параметры, используемые по умолчанию, отражают те, что используются в "обычной" установке. Чтобы включить компонент, установите его флажок в группе Компоненты. Чтобы исключить компонент, снимите его флажок. Чтобы сохранить параметры и вернуться в главное окно программы, нажмите кнопку OK.

  3. Чтобы определить сетевые параметры, нажмите кнопку Параметры сети. Введите требуемые значения в диалоговом окне Параметры сети. Чтобы сохранить параметры и вернуться в главное окно программы, нажмите кнопку OK.

  4. Если все параметры заданы правильно, нажмите кнопку Сохранить параметры в INF-файл. Программа создает файл .inf в формате Msbatch.inf и с именем msbatch.inf, а затем завершает сеанс работы программы Batch.

  5. Запустите установку Windows 98 с командной строки MS-DOS. Например:
    setup c:\msbatch.inf

Примечание

  • Необходимо указать полный путь к файлу .inf. В противном случае установка будет завершена с сообщением об ошибке.


Использование программы Batch 98

Для запуска программы установки Windows 98 с помощью сценария воспользуйтесь командой setup, за которой следует путь и имя файла .inf, созданного с помощью программы Batch. (Этот файл по умолчанию имеет имя Msbatch.inf). Например, наберите следующую командную строку:

setup c:\msbatch.inf

Начнется установка Windows 98, управляемая файлом .inf.

Имеется возможность загрузить сценарий установки (в формате Msbatch.inf) в программу Batch, включая имя файла в командную строку. Например:

batch c:\myfile.inf

Примечания

  • Если сохранить новые параметры в существующем файле .inf, файл будет уничтожен перед сохранением параметров. Если открыть существующий файл .inf, а затем изменить параметры, файл НЕ будет уничтожен при сохранении.

  • Программа Batch не может автоматизировать некоторые диалоговые окна установки Windows 98. Например, сообщения, которые не могут быть пропущены, включая поиск предыдущей версии Windows, и сообщения о размере места на диске и конфликтующих сетевых компонентах. Сообщения об ошибках приведут к остановке программы установки с запросов к пользователю.

  • При запуске установки Windows 98 с файлом .inf, созданным программой Batch, выдается предупреждение о необходимости удалить все дискеты из дисковода перед перезагрузкой компьютера. Убедитесь, что все дискеты извлечены перед запуском программы установки или после создания диска аварийной загрузки.

  • Дополнительные сведения см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.


Загрузка параметров из реестра

При работе на компьютере с системой Windows 98 программа Batch может найти в реестре известные параметры, чтобы автоматически создать пригодный для использования файл .inf. Нажмите кнопку Собрать сведения и программа пакетной установки выполнит поиск параметров в следующих областях:

  • Все известные 32-разрядные клиенты сетей Microsoft и их параметры

  • Все известные 32-разрядные сетевые службы Microsoft и их параметры

  • Все известные 32-разрядные сетевые протоколы Microsoft и их параметры

  • Текущие параметры разрешения экрана

  • Установленные принтеры

  • Текущий часовой пояс

  • Параметры безопасности уровня пользователя

  • Текущий каталог Windows

  • Сведения о текущем пользователе, имя и описание компьютера

  • MRU-размещения

  • Дополнительные компоненты

  • Параметры сетевой платы

Некоторые строки, которые не удается определить программе Batch.exe:

  • Параметры удаления установки

  • 16-разрядные сетевые клиенты, серверы и протоколы

  • Некоторые параметры установки, относящиеся только к пакетной установке (например, параметр 'Нет для всех')


Справка по основным параметрам программы Batch

Команды пакетной установки

Основные параметры установки

Установка

Пользователь

Диалоги установки

Регион и язык

Рабочий стол

Принтеры

MRU-размещения

Настройка экрана

Профили

Параметры сети

Протоколы

Службы

Клиенты

Управление доступом

Дополнительные клиенты

Дополнительные компоненты

Параметры Internet Explorer

Рабочий стол

Экран

Обозреватель

Безопасность

Прокси-сервер

Дополнительные параметры

Дополнительные файлы

Windows Update


Спецификация Optional.ini

 Использование спецификации Optional.ini

В данном разделе справки описывается спецификация создания и изменения файла Optional.ini, который пакетная установка использует для определения устанавливаемых компонентов.

Файл Optional.ini использует стандартные соглашения для файлов INI:

  • Имена разделов

    Имена разделов в файле не должны повторяться. Они должны заключаться в скобки, например, [Networks].

    • Основным разделом файла Optional.ini является раздел [AREAS]. В нем определяются доступные области дополнительных компонентов. В данном разделе создайте параметр в следующем формате:

    Entry#=Название области

    Каждый следующий номер области (#) должен на единицу превосходить номер предыдущей записи. Порядок записей не имеет значения. Не заключайте названия областей в кавычки, если не хотите, чтобы они отображались в кавычках.

    Файл Optional.ini может содержать до 20 уникальных областей. Далее показан пример раздела AREAS:

    [Areas]
Entry1=Accessories
Entry3=Screen Savers
Entry2=Communications

    Для каждой области из раздела AREAS должен существовать соответствующий раздел. Компоненты каждого раздела записываются в соответствии с теми же соглашениями, что и раздел AREAS. После имени компонента вставьте запятую, а затем число 0 (не устанавливать компонент по умолчанию) или число 1 (устанавливать компонент по умолчанию).

  • Параметры

    Параметры должны быть уникальными в пределах каждого раздела. Пробелы перед значениями игнорируются. Кроме того, значения не должны содержать точки с запятой (;).

    • Файл Optional.ini может содержать до 50 уникальных параметров в каждой области. Пакетная установка обрабатывает раздел, пока не обнаружит записи с номером, который не существует. Если обнаружится запись, не имеющая значения, используемого по умолчанию, предполагается, что это значение равно 0 (не устанавливать компонент). Например:

    [Accessories]
    Entry1=Cardfile,1
    Entry2=Clipboard Viewer
     (для Clipboard Viewer будет автоматически присвоено значение 0.)
    Entry3=Object Packager,1
    Entry4=Sound Recorder,0
    Entry6=Calculator,1
    (Запись Calculator не будет прочитана, поскольку чтения раздела будет окончено, после того как не будет найдена отсутствующая запись Entry5.)

Файл Optional.ini может содержать также три специальные категории:

  • Зависимости

    • Для дополнительных компонентов, имеющих зависимости (один компонент должен быть установлен для установки другого), создайте раздел с именем [Dependencies].

    Чтобы создать зависимость, создайте параметр с именем, соответствующим имени компонента, котолрому требуется второй компонент. Значением этого параметра является имя требуемого компонента. Любой одиночный компонент может иметь только одну зависимость; однако не существует предела вложенной зависимости компонентов. (Компоненту A может требоваться компонент B, которому требуется компонент C и т. д.) Старайтесь избегать создания рекурсивных зависимостей (A -> B -> C -> A).

    Не существует предела на число разных зависимостей, кроме предела в 1000 символов на весь раздел. Далее показан пример раздела Dependencies:

    [Dependencies]
    Direct Cable Connection=Dial-Up Networking
    (Для DCC требуется Dial-Up Networking.)

  • Defunct

    • Раздел DEFUNCT может использоваться для создания списка дополнительных компонентов, имена которых могли быть изменены. В данное время, если пользователь открывает существующий файл .inf, содержащий компоненты, отсутствующие в файле OPTIONAL.INI, такие записи отбрасываются. Однако перед их удалением программа установки проверяет по разделу DEFUNCT, не было ли дано компоненту новое имя.

    Имя раздела должны быть [Defunct]. Внутри раздела создайте параметр с именем, соответствующим старому имени компонента. Значением параметра должно быть новое имя компонента. Не существует предела на число записей раздела DEFUNCT, за исключением предела в 1000 символов на весь раздел. Далее показан пример раздела Defunct:

    [Defunct]
    Extra Cursors=Mouse Pointers
    (Новое имя для Extra Cursors - Mouse Pointers.)
    Nature Sound Scheme=Jungle Sound Scheme
    (имя Nature было заменено на Jungle.)

  • No Choice

    • Чтобы включить раздел NOCHOICE, добавьте в него запись, аналогично обычной записи для дополнительного компонента, как описано выше, плюс значение для выбора: 0 (не устанавливать) или 1 (устанавливать). Параметры указанные здесь не могут быть изменены пользователем с помощью окон программы установки, даже если эти параметры отображаются в интерфейсе.

    Параметр указанный в данном разделе не требуется указывать ни в каком другом разделе файла INI. Далее показан пример раздела NoChoice:

    [NoChoice]
    Entry2=Calculator,0
    (Calculator никогда не будет установлен.)
    Entry3=Custom Component,1
    (Будет установлен дополнительный компонент, известный программе установки Windows.)

Пример файла Optional.ini


Вкладка 'Управление доступом'

Диалоговое окно 'Параметры сети', вкладка 'Управление доступом'

Воспользуйтесь данной вкладкой для задания управления доступом на уровне пользователя или на уровне ресурсов.

  • Компьютеры с установленной службой Доступ к файлам и принтерам для сетей NetWare 3.x/4.x могут использовать только управление доступом на уровне пользователей.

  • Компьютеры с установленной службой Доступ к файлам и принтерам для сетей Microsoft могут использовать как управление доступом на уровне ресурсов, так и на уровне пользователей. Однако для управление доступом на уровне пользователей необходимо иметь домен или рабочую станцию Windows NT для проверки учетных записей пользователей.

Управление доступом на уровне ресурсов | Задает необходимость ввода пароля для доступа к каждому общему ресурсу.
Управление доступом на уровне пользователей | Указывает, какие пользователи и группы имеют доступ к каждому общему ресурсу. Если выбран данный параметр, введите \\сервер\общий_ресурс для списка пользователей и групп.


Диалоговое окно 'Параметры сети', вкладка 'Дополнительные клиенты'

Данная вкладка позволяет установить дополнительные драйверы во время установки.

Примечание

Microsoft не поставляет драйверы, перечисленные в списке Поддерживаемые клиенты; их необходимо поместить в каталог, из которого выполняется установка Windows 98.

Поддерживаемые клиенты | Клиент Banyan DOS/Windows 3.1 Novell NetWare (Workstation Shell 3.x [NETX]) Novell NetWare (Workstation Shell 4.x [VLM])
Другие клиенты | Протоколы — см. приложение D пакета Windows 98 Resource Kit для получения списка служб, для которых отсутствует встроенная поддержка. ЗАПРОС:Клиенты — Текст отсутствует. См. интерфейс. Службы — см. приложение D пакета Windows 98 Resource Kit для получения списка служб, для которых отсутствует встроенная поддержка.

Введите эти строки в формате, указанном в приложении D пакета Windows 98 Resource Kit.

Примечание

  • Microsoft не поставляет драйверы, перечисленные в списке Поддерживаемые клиенты; их необходимо поместить в каталог, из которого выполняется установка Windows.


Диалоговое окно 'Дополнительные параметры', вкладка 'Дополнительные файлы'

Файл, добавляемый в реестр | Ввод имени файла приводит к автоматическому импорту файла реестра во время установки.
Файл системных политик | автоматически - Указывает на то, что используется файл политики из каталога, используемого по умолчанию (каталог NETLOGON в сети Windows NT или каталог PUBLIC в сети NETWARE). вручную - Указывает на то, что путь к файлу политики задается вручную.


Диалоговое окно 'Дополнительные параметры'

Имеются две вкладки: 'Дополнительные файлы' и 'Windows Update'.

Вкладка Дополнительные файлы предназначена для добавления каталогов файлов реестра и, если нужно, файлов системной политики.

Вкладка Windows Update позволяет обновлять сведения о программах и драйверах через Интернет. С этой вкладки можно отключить ссылку 'Windows Update' на данном компьютере.


Вкладка 'Клиенты'

Диалоговое окно 'Параметры сети', вкладка 'Клиенты'

На компьютер могут быть установлено несколько сетевых клиентов, выполняемых в защищенном режиме.

Клиент для сетей Microsoft | Задает доступ к компьютерам, на которых установлена служба доступа к файлам и принтерам для сетей Microsoft, к системе Windows NT, а также к клиентам и серверам с системой LAN Manager. Это используемый по умолчанию сетевой клиент Microsoft.
Входить в домен NT | Задает вывод окна входа в домен Windows NT при запуске Windows 98. Этот параметр должен быть включен для сетей Microsoft.
Домен | Поле ввода имени домена Windows NT, используемого для проверки входа.
Клиент для сетей NetWare 3.x/4.x | Задает доступ клиента к серверам NetWare и компьютерам Windows 98, на которых запущена служба доступа к файлам и принтерам для сетей NetWare 3.x/4.x. Примечание Если уже выбран клиент NetWare для реального режима, то будет выдан запрос на подтверждение при выборе данного поля.
Включить обработку макроса подключения | Разрешает обработку макроса подключения Windows 98 для сетей NetWare 3.x/4.x.
Основной сервер | Поле ввода имени основного сервера NetWare (если такой имеется), используемого для проверки входа.
Имя первого диска | Нажмите кнопку со стрелкой для выбора крайней буквы, которую можно использовать для назначения имени сетевого диска (по умолчанию это F).
Служба каталогов NetWare | Задает доступ клиента к службе каталогов NetWare (NetWare Directory Services).
Предпочтительное дерево | Поле ввода основного дерева для службы каталогов NetWare.
Контекст имен | Поле ввода желательного контекста имен для службы каталогов NetWare.
Вход по умолчанию | Нажмите кнопку со стрелкой, чтобы выбрать, какого клиента использовать по умолчанию. Допускаются все включенные сетевые клиенты.

Переход к разделу 'Параметры сети'


Вкладка 'Доступные протоколы'

Диалоговое окно 'Параметры сети', вкладка 'Протоколы'

Имеется возможность выбрать любой и все следующие протоколы.

IPX/SPX-совместимый протокол | Задает использование протокола IPX/SPX.
Использовать NetBIOS поверх IPX/SPX | Указывает, требуется ли поддержка NetBIOS с протоколом IPX/SPX.
Тип пакета | Нажмите кнопку со стрелкой, чтобы выбрать тип пакета, отличного от того, который автоматически определяется системой Windows 98. Если выбрать тип пакета, не используемый в данной сети, взаимодействие с остальными сетевыми ресурсами будет невозможно.
NetBEUI | Задает использование протокола NetBEUI.
32-разрядный DLC-драйвер Microsoft | Задает использование протокола 32-разрядного протокола DLC.
TCP/IP | Задает использование протокола TCP/IP.
Настройка TCP/IP | Нажмите кнопку для изменения настройки TCP/IP.
Протокол по умолчанию | Нажмите кнопку со стрелкой, чтобы выбрать один из доступных 32-разрядных протоколов. Если оставить данное поле пустым, программа установки автоматически назначит протокол, используемый по умолчанию.

Переход к разделу 'Параметры сети'


Вкладка 'Службы'

Диалоговое окно 'Параметры сети', вкладка 'Службы'

На данной вкладке определяется доступ к файлам и принтерам. Компьютер Windows 98 может предоставить доступ к файлам и принтерам как для сетей Microsoft, так и для сетей NetWare 3.x/4.x, но не для обоих сетей одновременно.

Не использовать доступ к файлам и принтерам | Невозможно предоставление доступа к файлам и принтерам данного компьютера для других компьютеров. Это особенно важно для компьютеров с малым объемом памяти или ограниченной мощностью процессора.
Служба доступа к файлам и принтерам сетей Microsoft | Данный компьютер может предоставлять доступ к файлам, папкам, принтерам и компакт-дискам для других компьютеров в сети. Это используемая по умолчанию служба доступа к узлам в сети Microsoft. Для запуска данной службы на компьютере должен быть загружен клиент для сетей Microsoft.
Оповещение LM | Использование адресации в стиле LAN Manager. Установите этот флажок, если в сети имеются старые серверы, совместимые с системой LAN Manager.
Параметры основного обозревателя сети | Задает желательные параметры данного компьютера как основного координатора сети. В зависимости от обычной роли компьютера можно задать, что он никогда не является основным координатором (запретить), преимущественно является основным координатором (разрешить) или по умолчанию является основным координатором, если это необходимо (Автоматически).
Служба доступа к файлам и принтерам для сетей NetWare | Компьютер с системой Windows 98 будет выглядеть как сервер NetWare для других компьютеров с клиентами сетей NetWare. Для запуска данной службы на компьютере должен быть загружен клиент для сетей NetWare.
Сообщения SAP | Включение сообщений в стиле SAP (Server Advertising Protocol) для данного компьютера.
Сообщения рабочих групп | Задает желательное для данного компьютера состояние сообщений рабочих групп. В зависимости от обычной роли компьютера можно задать, что для него отключены сообщения (запретить), он никогда не является основным координатором (разрешить: не будет координатором), преимущественно является основным координатором (разрешить: основной координатор) или по умолчанию является основным координатором, если это необходимо (разрешить: может быть координатором).

Переход к разделу 'Параметры сети'


Сохранение пакета

Запуск программы установки на нескольких компьютерах с помощью списка имен компьютеров

Список имен компьютеров позволяет запускать файлы программы установки (файлы .inf) одновременно на нескольких компьютерах с помощью отдельного текстового файла со списком параметров (имя компьютера и адрес IP), которые должны быть уникальными.

  1. Из меню Файл в главном окне программы Batch выберите пункт Список имен компьютеров.

  2. Создание файла имен компьютеров.

    С помощью Блокнота откройте текстовый файл, введите по одному имени компьютера на каждой строке и завершите каждую строку символами перевода каретки и новой строки (нажмите клавишу ввода ENTER после набора каждого имени). В сетях Microsoft имена компьютеров могут содержать только алфавитно-цифровые, а также следующие символы:

    ! @ $ % ^ ( ) { } _ ~.

    Далее приводится пример текстового файла со списком имен компьютеров:

    Zarg!
    P133_Mega_Machine, 128.2.3.4
    KCF
    Print_Server_1
    Duke, 128.3.4.5
    Scarlett
    Rhett

    Следует отметить, что можно включить в имя адрес IP для любого компьютера (на той же строке, что и имя, и после запятой), но не обязательно это делать для всех компьютеров. В данном примере 'P133_Mega_Machine' и 'Duke' задаются с адресами IP.

  3. После выбора файла имен компьютеров, пакетная установка читает и сохраняет все имена и адреса. Выдается сообщение о том, сколько имен было прочитано.

  4. Затем необходимо выбрать каталог, в котором должны быть сохранены все файлы .inf. В диалоговом окне Папка назначения найдите каталог, который хотите использовать. Каталог должен быть создан заранее. Имя файла в соответствующем поле не имеет значения.

  5. После задания каталога нажмите кнопку Сохранить.

    Программа Batch создаст по одному файлу .inf для каждого имени, содержащему все определенные параметры, с именами от Bstp0001.inf до Bstp9999.inf, записанными в том же порядке, что и имена с списке имен компьютеров. Уникальными для каждого файла являются только заданные имя компьютера и адрес IP. В предыдущем примере файл Bstp0001.inf будет содержать сведения об установке для компьютера по имени 'Zarg!' а файл Bstp0007.inf будет содержать сведения об установке для компьютера по имени 'Rhett.'

  6. Чтобы закрыть диалоговое окно Список имен компьютеров, нажмите кнопку Закрыть.

Примечания

  • Не используйте точки в именах компьютеров. Другие сети могут иметь иные требования к именам компьютеров.

  • Если хотите включить адрес IP для данного компьютера, поместите одну запятую после имени компьютера и наберите IP-адрес.

  • Одна пустая строка означает конец файла имен компьютеров. Поверка наличия ошибок в этих значениях во время сохранения параметров не выполняется.

  • Если в файл имен компьютеров введены неверные сведения, программа установки Windows 98 может остановиться и запросить правильные сведения у пользователя.


Добро пожаловать в справочную систему

Познакомьтесь с Windows 98 с помощью встроенной справки.

  • Найдите ответы на возникающие вопросы.
  • Просмотрите электронную версию книги Приступая к работе.
  • Подключитесь к Web, чтобы получить обновленное программное обеспечение.
  • Устраните неполадки, возникающие при работе с системой.


Диалоговое окно 'Основные параметры установки'

Диалоговое окно 'Основные параметры установки', вкладка 'Настройка экрана'

Глубина цвета | Варианты: Текущие параметры, 16 цветов (4 бита), 256 цветов (8 бит), High Color (16 бит), True Color (24 бит) и True Color (32 бит)
Разрешение | Варианты: Текущие параметры, 640 на 480 точек; 800 на 600 точек; 1024 на 768 точек; 1152 на 864 точек; и 1280 на 1024 точек.


Вкладка 'Конфигурация DNS'

Диалоговое окно 'Параметры TCP/IP', вкладка 'Конфигурация DNS'

Вкл. DNS | Задает настройку протокола TCP/IP на поддержку DNS (Domain Name System). DNS используется в Интернете для поиска имен узлов. Необходимо также включить этот параметр для использования файла LMHOSTS для определения имен компьютеров через NetBIOS.
Узел br> | Поле ввода для DNS имени узла, предоставленного системным администратором. По умолчанию в качестве имени узла задается имя компьютера.
Домен | Поле ввода имени домена для службы DNS.
Сервера DNS | Поле ввода IP-адеса для каждого сервера DNS. Чтобы добавить в поле IP-адрес, нажмите кнопку Добавить. Чтобы удалить IP-адрес из поля, выберите адрес и нажмите кнопку Удалить. Порядок, в котором серверы отображаются в поле, соответствует порядку, в котором будет выполняться их поиск при работе по протоколу TCP/IP.
Доменные суффиксы | Поле ввода суффикса домена для каждого сервера DNS. Чтобы добавить в поле суффикс домена, нажмите кнопку Добавить. Чтобы удалить суффикс домена, выберите суффикс и нажмите кнопку Удалить. Порядок, в котором суффиксы отображаются в поле, соответствует порядку, в котором они будут использоваться при работе по протоколу TCP/IP.

Переход к разделу 'Параметры TCP/IP'


Вкладка 'Рабочий стол'

Диалоговое окно 'Основные параметры установки', вкладка 'Рабочий стол'

Установите эти параметры, что задать отображение или удаление определенных значков рабочего стола после установки Windows 98.

Внимание! Удаление этих значков может ограничить доступ к другим параметрам Windows и сети.

Не удаляйте значки без необходимости. Их нельзя будет восстановить без переустановки Windows.

Эти параметры будут сохранены в файле .inf, но не будут читаться. Необходимо вручную задавать или удалять эти параметры при каждом сохранении файла .inf.

Значки рабочего стола
Мои документы | Задает удаление значка с рабочего стола. При этом папка 'Мои документы' не удаляется с диска компьютера.
Internet Explorer | Задает удаление значка с рабочего стола. При этом программа Internet Explorer не удаляется с компьютера.
Сетевое окружение | Задает удаление значка с рабочего стола. При этом папка 'Сетевое окружение' не удаляется с диска компьютера.
Outlook Express | Задает удаление значка с рабочего стола. При этом почтовая программа не удаляется с компьютера. Примечание Этот параметр недоступен, если программа Outlook Express не выбрана в диалоговом окне Дополнительные компоненты .
Корзина | Задает удаление значка корзины с рабочего стола. При этом функции корзины не удаляются с компьютера.

Прочее
Удаляет информационные службы с рабочего стола после установки | Задает удаление папки Online Services (информационные службы) и ее содержимого с рабочего стола после завершения установки (только в английской версии).
Не выводить окно приветствия Windows 98 | Отключает вывода на экран окна приветствия Windows 98. Следующий параметр недоступен, если выбран данный.
Не запускать мастер регистрации | Отключает вывода на экран мастера регистрации Windows. Если имеется лицензия на узел и не требуется регистрация копии Windows 98 для каждого пользователя, установите данный флажок.


Диалоговое окно 'Параметры Internet Explorer', вкладка 'Обозреватель'

Сведения о приведенных ниже параметрах см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Домашняя страница | Введите адрес, который обычно должен открывать обозреватель.
Страница после установки | Введите адрес, который обозреватель должен открывать при его первом использовании.
Страница поиска | Введите адрес страницы поиска, которую хотите использовать.
Страница поддержки | Введите адрес страницы поддержки.
Примечание

Все эти параметры могут быть изменены пользователем после установки.


Диалоговое окно 'Параметры Internet Explorer', вкладка 'Рабочий стол'

Сведения о приведенных ниже параметрах см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Панель быстрого запуска: Internet Explorer Outlook Express Свернуть все окна Включить каналы | Проверьте, что значки каждой программы отображаются на панели быстрого запуска Windows 98.
Панель каналов | Включение панели каналов.
Панель каналов может быть легко настроена для каждого устанавливаемого компьютера. Настройте один компьютер и нажмите кнопку 'Собрать сведения'. Программа Batch 98 распространит настройку каналов на все компьютеры, на которые устанавливается система.


Диалоговое окно 'Параметры Internet Explorer', вкладка 'Экран'

Сведения о приведенных ниже параметрах см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Active Desktop | Включение отображания рабочего стола в стиле web.
Способ обзора папок | Выбор открытия всех папок в одном и том же окне.
Применение вида Web | Включение отображения в папках содержимого в стиле web (например фоновых рисунков HTML).
Применение щелчков мыши | Выберите использование однократного щелчка (как на web-странице) или двойного щелчка (клиссический стиль Windows) для открытия объектов.

Примечание

Все эти параметры могут быть изменены пользователем после установки.


Диалоговое окно 'Параметры Internet Explorer'

Окно содержит следующие вкладки:

Рабочий стол

Экран

Обозреватель

Безопасность

Прокси-сервер


Диалоговое окно 'Параметры Internet Explorer', вкладка 'Прокси-сервер'

Подключаться к Интернету через прокси-сервер | Снимите флажок для прямого подключения к Интернету.
Серверы | Введите адрес и номер порта прокси-сервера, используемого для получения доступа к Интернету с помощью протоколов HTTP, Secure, FTP, Gopher и Cocks. (Воспользуйтесь данным параметром только при подключении к Интернету через локальную сеть.)
Один прокси-сервер для всех протоколов | Снимите флажок, чтобы задать свой адрес и порт для каждого прокси-сервера
Не применять прокси-сервер для локальных адресов. | Снимите флажок, чтобы использовать прокси-сервер и для локальных адресов.

Примечание
Internet Explorer работает только с прокси-серверами, совместимыми со стандартом CERN.


Диалоговое окно 'Параметры Internet Explorer', вкладка 'Безопасность'

Выберите тип web-содержимого в поле Зона, а затем выберите уровень безопасности для каждой зоны в следующей группе.

Для каждой зоны: | Задайте уровень безопасности
Местная зона (интрасеть) Зона надежных узлов Зона Интернета Зона ограниченных узлов | Высокий -- будут выдаваться уведомления о возможных неполадках защиты; при этом активное содержимое может не загружаться. Средний -- выдаются уведомления о возможных неполадках защиты. Низкий -- все содержимое с проверенными сертификатами будет загружаться.
Добавление узлов | Добавьте адреса URL для определенных узлов.
Настройка | Настройте вид активного содержимого, которое может быть загружено и просмотрено на данном компьютере.


Диалоговое окно параметров установки

Диалоговое окно 'Основные параметры установки'

Для открытия диалогового окна выберите Основные параметры установки в главном окне программы Batch 98. Дополнительные сведения см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Окно содержит следующие вкладки:

Установка

Пользователь

Диалоги установки

Регион и язык

Рабочий стол

Принтеры

MRU-размещения

Настройка экрана

Профили


IP-адрес

Диалоговое окно 'Параметры сети', вкладка 'IP-адрес'

Получить IP-адрес автоматически | Задает, включена ли поддержка службы DHCP (Dynamic Host Control Protocol) для автоматической настройки протокола TCP/IP. Для использования службы DHCP в сети должен присутствовать сервер Windows NT, который работает в качестве сервера DHCP. Если не предполагается использование службы DHCP, необходимо указать IP-адрес.
Использовать IP-адрес | Указание IP-адреса, отличного от адреса, присваиваемого службой DHCP.
IP-адрес | Поле ввода нужного IP-адреса.
Маска подсети | Поле ввода маски подсети. Как правило, это поле оставляют пустым. Маска подсети назначается на основе IP-адреса во время установки Windows 98. Этот параметр недоступен, если включена поддержка протокола DHCP.
Отключить Autonet | Рекомендуется для больших сетей.

Переход к разделу 'Параметры TCP/IP'


Вкладка 'Шлюз'

Диалоговое окно 'Параметры TCP/IP', вкладка 'Шлюз'

Новый шлюз | Поле ввода IP-адреса шлюза. Чтобы добавить адрес в список, нажмите кнопку Добавить.
Установленные шлюзы | Список доступных IP-адресов. Порядок адресов в списке указывает порядок, в котором выполняется их поиск. Чтобы удалить адрес шлюза из списка, выберите адрес и нажмите кнопку Удалить.

Переход к разделу 'Параметры TCP/IP'


Уведомления

Microsoft Windows 98

В содержание данного документа могут быть внесены изменения без предварительного уведомления. Названия организаций, имена и даты, используемые в качестве примеров, являются вымышленными, если не оговорено обратное. На пользователе лежит ответственность за соблюдение всех применимых в данном случае законов об авторском праве. Никакая часть настоящего документа ни в каких целях не может быть воспроизведена или передана в какой бы то ни было форме и какими бы то ни было средствами, будь то электронные или механические, включая фотокопирование и запись на магнитный носитель, если на то нет письменного разрешения корпорации Microsoft.

Корпорация Microsoft может являться правообладателем патентов и заявок, поданных на получение патента, товарных знаков и объектов авторского права, которые имеют отношение к содержанию данного документа. Предоставление вам данного документа не означает передачи какой-либо лицензии на использование данных патентов, товарных знаков и объектов авторского права, за исключением использования, явно оговоренного в лицензионном соглашении корпорации Microsoft.

© Корпорация Microsoft, 1998. Все права защищены.

Microsoft, ActiveX, BackOffice, MS, MS-DOS, Windows и Windows NT являются охраняемыми товарными знаками корпорации Microsoft в США и других странах.

Названия других продуктов или предприятий, указанные здесь, могут быть товарными знаками соответствующих владельцев.


Вкладка MRU-размещения

Диалоговое окно 'Основные параметры установки', вкладка MRU-размещения

Программа Batch позволяет пользователю задать 21 адрес MRU (Most Recently Used) на каждом компьютере после установки Windows 98. Адреса MRU будут появляться во время установки в каждом раскрывающемся списке, с помощью которого пользователю предлагается выбрать место, откуда нужно брать файлы для установки.

С помощью специальных адресов MRU задается свой список таких адресов, предоставляемых на выбор пользователя.

Например, MRU 1 может задавать адрес "\\сервер\продукты", MRU 2 -- "\\название_отдела\общие_ресурсы" и MRU 3 -- "A:\"

Чтобы включить MRU-размещения, введите в поле вверху путь в формате UNC для каждого места и нажмите кнопку Добавить MRU.

Чтобы удалить MRU-размещение, выберите в большом поле путь и нажмите кнопку Удалить MRU.

Чтобы удалить сразу все MRU-размещения, нажмите кнопку Очистить MRU.


Параметры сети

Диалоговое окно 'Параметры сети'

Диалоговое окно Параметры сети имеет следующие вкладки:

Протоколы (включает кнопку Настройка TCP/IP)

Службы

Клиенты

Управление доступом

Дополнительные клиенты


Параметры сети для независимых поставщиков

Окно 'Параметры сети', вкладка 'Дополнительные клиенты'

Имеется возможность установить любой из перечисленных параметров, чтобы установить в Windows 98 поддержку соответствующей сети. Необходимо заранее установить на компьютер нужное программное обеспечение от поставщика сетевых услуг.

Поддерживаемые клиенты
 Можно выбрать любого 16-разраядного сетевого клиента. Невозможно выбрать других клиентов NetWare, если уже выбран клиент для сетей NetWare 3.x/4.x на основной странице сетевых параметров. Имейте ввиду, что включение одной из этих сетей не устанавливает необходимые сетевые драйверы; это только сообщение системе Windows 98 о наличии определенных 16-разрядных сетевых компонентов.
Другие клиенты Протоколы
Клиенты
Службы

 Введите разделенный запятыми список сетевых параметров в каждую область для дополнительных сетевых компонентов или сетевых клиентов от независимых поставщиков. Воспользуйтесь этими флажками, чтобы включить параметры поддержки сетевых протоколов независимых поставщиков, агентов инспектора сети Microsoft и т. п.

Проверка ошибок в этих параметрах не выполняется. Программа установки Windows 98 воспользуется этими параметрами, но может и остановиться при обнаружении неизвестных параметров в этой области.

См. приложение D пакета Windows 98 Resource Kit для получения списка служб, для которых отсутствует встроенная поддержка.

Для получения нужных строк, необходимых для параметров установки сетей от независимых разработчиков, см. приложение D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

К разделу 'Параметры сети'


Параметры TCP/IP

Диалоговое окно 'Параметры TCP/IP'

Чтобы открыть это диалоговое окно, выберите Параметры сети. На вкладке Протоколы установите флажок TCP/IP и нажмите кнопку Настройка TCP/IP.

Полные сведения о протоколе TCP/IP содержатся в главе 12, "Network Technical Discussion", Windows 98 Resource Kit. Неправильные параметры ограничат возможности использования TCP/IP.

Окно содержит следующие вкладки:

Конфигурация DNS

Шлюз

Конфигурация WINS

IP-адрес


Диалоговое окно 'Дополнительные компоненты'

При изменении параметров в окне Дополнительные компоненты необходимо помнить о следующих вопросах.

  • Установка флажка задает добавление компонента.

  • Снятие флажка задает исключение компонента.

Программа Batch читает список дополнительных компонентов из файла Optional.ini, который должен находится в том же каталоге, что и файл Batch.exe. Имеется возможность изменить этот файл, чтобы изменить список компонентов и ограничить возможности пользователей. Для получения дополнительных сведений выберите ссылку Спецификация Optional.ini.


Пример файла Optional.ini

В любое место файла можно также добавить раздел [NoChoice].

[Areas]

Area1=Accessibility Options
Area2=Accessories
Area3=Communications
Area4=Disk Tools
Area5=Microsoft Fax
Area6=Multimedia
Area7=Screen Savers
Area8=Windows Messaging

[Accessibility Options]

Entry1=Accessibility Options,0

[Accessories]

Entry1=Briefcase,0
Entry2=Calculator,1
Entry3=Character Map,0
Entry4=Clipboard Viewer,0
Entry5=Desktop Wallpaper,0
Entry6=DMI Mgmt Service Layer,0
Entry7=Document Templates,1
Entry8=Games,0
Entry9=Imaging,1
Entry10=Mouse Pointers,0
Entry11=Net Watcher,0
Entry12=Object Packager,1
Entry13=Online User's Guide,0
Entry14=Paint,1
Entry15=Quick View,0
Entry16=System Mgmt Infrastructure,0
Entry17=System Monitor,0
Entry18=System Resource Meter,0
Entry19=TWAIN 1.6,1
Entry20=Windows 98 Tour,0
Entry21=WordPad,1

[Communications]

Entry1=Dial-Up Networking,0
Entry2=Direct Cable Connection,0
Entry3=HyperTerminal,1
Entry4=Microsoft NetMeeting,1
Entry5=Phone Dialer,1

[Disk Tools]

Entry1=Backup,0
Entry2=Defrag,1
Entry3=Disk compression tools,1

[Microsoft Fax]

Entry1=Microsoft Fax Services,0
Entry2=Microsoft Fax Viewer,0

[Multimedia]

Entry1=Audio Compression,1
Entry2=CD Player,1
Entry3=Media Player,1
Entry4=Multimedia Sound Schemes,0
Entry5=Sample Sounds,0
Entry6=Sound Recorder,1
Entry7=Video Compression,1
Entry8=Volume Control,1

[Screen Savers]

Entry1=Additional Screen Savers,0
Entry2=Flying Windows,1
Entry3=OpenGL Screen Savers,1


Установка принтеров

Диалоговое окно 'Основные параметры установки', вкладка 'Принтеры'

Чтобы открыть это диалоговое окно, выберите вкладку принтеров в верхней части окна Основные параметры установки . Дополнительные сведения см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Это окно позволяет задать принтеры, устанавливаемые во время установки системы. Чтобы описание каждого принтера в сценарий установки, нажмите кнопку Добавить.

Устанавливать следующие принтеры | Задает установку принтеров во время установки системы. Примечание Установка сетевого принтера допускается только при установке через сеть.
Название принтера | Поле ввода названия для принтера, которое может включать любые знаки, кроме следующих: \ , ; =
Тип принтера | Поле ввода точного имени драйвера для модели принтера, поддерживаемой Windows 98, что определено в файле printer .inf.
Порт принтера | Поле ввода порта, к которому присоединен принтер (например, LPT1) или пути в формате UNC к очереди сетевого принтера.
Добавить | Добавление и настройка трех текстовых полей. Например, My Printer=Panasonic KX-P4420,FILE
Удалить | Перевод введенной строки обратно в текстовые поля для изменения.

Возврат к разделу 'Основные параметры установки'


Вкладка 'Диалоги установки'

Диалоговое окно 'Основные параметры установки', вкладка 'Диалоги установки'

Сведения о приведенных ниже параметрах см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Не выводить лицензионное соглашение | Снимите флажок, чтобы программа установки останавливалась и ожидала принятия лицензионного соглашения.
Не запрашивать создание загрузочного диска | Снимите флажок, что программа установки Windows 98 создавала диск аварийной загрузки. Пользователю будет предложено вставить в дисковод одну 3-х или 5-и дюймовую дискету.
Автоматически отвечать 'Нет для всех' в диалогах конфликтов версий | Снимите флажок, чтобы программа установки Windows 98 автоматически перезаписывала существующие файлы, даже если дата или версия локальной копии является более поздней, чем дата или версия устанавливаемого файла.
Автоматическая перезагрузка компьютеров PCI и PnP во время установки | Снимите флажок, чтобы программа установки останавливалась и ожидала, пока пользователь разрешит каждую перезагрузку таких компьютеров во время установки системы.
Не производить поиск папки драйверов устройств | Снимите флажок, чтобы Windows 98 продолжала искать в папке, из которой выполняется установка (обычно это сетевая папка), новые файлы .inf и новые поддерживаемые устройства. Этот параметр позволяет системному администратору централизованно распространять новые драйверы; все компьютеры, установленные из одного места, воспримут необходимые изменения.
Не запускать мастера плат PC Card (PCMCIA) | Снимите флажок, чтобы получить приглашение (если на компьютере имеется гнездо для платы PC Card) во время установки. Рекомендуется это сделать, если не используются драйверы платы PC Card реального режима.


Вкладка 'Регион и язык'

Диалоговое окно 'Основные параметры установки', вкладка 'Регион и язык'

Дополнительные сведения см. в приложении D, "Msbatch.inf Parameters", пакета Windows 98 Resource Kit.

Часовой пояс | Нажмите кнопку со стрелкой и выберите часовой пояс из списка. Выберите свой часовой пояс. Если оставить поле пустым, будет предложено ввести его во время установки.
Клавиатура | Нажмите кнопку со стрелкой и выберите страну и стиль раскладки клавиатуры.
Регион и язык | Нажмите кнопку со стрелкой и выберите язык и регион. Этот параметр влияет на параметры со вкладок Числа, Денежная единица, Время и Дата из окна свойств Язык и стандарты каждого устанавливаемого компьютера.

Возврат к разделу 'Основные параметры установки'


Параметры удаления установки

Диалоговое окно 'Основные параметры установки', вкладка 'Установка'

Код продукта | Поле для ввода серийного номера продукта (необязательный параметр).
Установочная папка | Поле ввода имени каталога, в который будет установлена система Windows 98. По умолчанию используется каталог, в котором система Windows установлена сейчас. При создании шаблона для другого компьютера можно изменить этот используемый по умолчанию каталог. Если оставить поле пустым и выполнить обновление Windows, система Windows 98 будет установлена поверх старой версии. Если поле пусто и выполняется новая установка, будет выдано приглашение ввести каталог установки.
Не выводить предупреждение о папке установки | Указывает, что предупреждение о каталоге установки не будет показано. Выберите этот параметр для обновления системы Windows.
Не хранить сведения отмены установки | Указывает, что программа установки Windows 98 не будет сохранять сведения для отмены установки.
Автоматически сохранять сведения | Указывает, что программа установки Windows 98 запишет все необходимые сведения в каталог архива. Если не задать каталог сейчас, будет выдано приглашение на ввод каталога во время установки.

К разделу 'Основные параметры установки'


Вкладка 'Пользователь'

Диалоговое окно 'Основные параметры установки', вкладка 'Пользователь'

Пользователь | Поле ввода имени пользователя, на которого будет зарегистрирована система Windows 98. Это имя появляется во многих диалоговых окнах 'О программе'.
Организация | Поле ввода названия организации, на которую будет зарегистрирована система Windows 98. Это имя появляется во многих диалоговых окнах 'О программе'.
Компьютер | Поле ввода уникального имени компьютера, на который будет установлена система Windows 98. Во многих сетях необходимо задавать отдельное имя для каждого компьютера. Выберите имя, которое не будет конфликтовать с именами, уже имеющимися в сети. Если конфликт имен возникает во время установки, не будет выполнен вход в сеть. Для имени можно использовать не более 15 алфавитно-цифровых знаков, а также следующие: ! @ $ % ^ ( ) { } _ ~ . Не используйте точки. Внимание! При использовании пакетного файла сразу для нескольких компьютеров имеются три варианта: вручную изменить каждый файл для добавления уникального имени для каждого компьютера; оставить поле имени компьютера пустым, и во время установки будет выдано приглашение на его ввод; либо воспользоваться списком имен компьютеров.
Рабочая группа | Строка, в которую следует ввести имя основной рабочей группы компьютера. Попросите у системного администратора или в информационном отделе имя рабочей группы, к которой принадлежит ваша учетная запись (например, "Marketing" или "3rdFloorNorth"). На имя рабочей группы накладываются те же ограничения, что и на имя компьютера.
Описание | Поле для ввода краткого описания компьютера. Во многих сетях допускается поиск определенных компьютеров по тексту из сроки описания. Обычно в описании указывается имя оператора, расположение или назначение компьютера ("Принт-сервер"). Описание не может содержать более 48 символов.

Если оставить одно или несколько полей пустыми, возможны следующие результаты.

  • Если установка Windows 98 выполняется в системе Windows 3.1, Windows для рабочих групп или Windows 95, программа установки берет сведения из существующей копии Windows и продолжает работу без остановки.

  • Если установка Windows 98 выполняется в системе MS-DOS (как с имеющейся копией Windows, так и без нее) или в системе Windows 3.0, программа установки выдается приглашение на ввод этих сведений.

Сведения об управлении остановкой программы установки Windows 98 содержатся в разделе Диалоги установки.

Имеется параметр главного окна, доступный только пользователям Windows 98 (или более поздней версии). Это кнопка Собрать сведения может быть использована для проведения автоматического сканирования реестра на компьютере клиента.


Вкладка 'Профили'

Диалоговое окно 'Основные параметры установки', вкладка 'Профили'

Если выбрать параметр Пользователи могут изменять настройки:
Все пользователи данного компьютера используют одинаковые параметры системы и рабочего стола. | Для компьютеров, обычно используемых большим числом пользователей
Пользователи могут задавать свои параметры системы и рабочего стола. Windows использует их при входе пользователя в систему. | Для большинства персональных компьютеров
Включите значки рабочего стола и содержимое сетевого окружения в параметры пользователя | Рекомендуется
Включите главное меню и группы программ в параметры пользователя. | Рекомендуется


Диалоговое окно 'Дополнительные параметры', вкладка 'Windows Update'

Средство Windows Update позволяет обновить программное обеспечение и драйверы непосредственно через Интернет. Оно обеспечивает доступ к мастеру обновлений, который проверяет драйверы устройств и системное программное обеспечение компьютера, сравнивая обнаруженные файлы с главной базой данных, имеющейся в Web, а затем рекомендует и устанавливает определенные файлы, подходящие для данного компьютера.

  • Чтобы отключить автоматическое выполнение обновлений, выберите параметр Запретить использование Windows Update.


Вкладка 'Конфигурация WINS'

Диалоговое окно 'Параметры TCP/IP', вкладка 'Конфигурация WINS'

Для службы WINS (Windows Internet Name Service) требуется сервер Windows NT WINS, выполняющий определение имен NetBIOS через TCP/IP. Это, в свою очередь, позволяет компьютерам, на которые установлен только протокол TCP/IP, узнать имя NetBIOS для компьютера в сети. Имеется возможность указать пару серверов WINS или, если была включена поддержка DHCP, указать, что серверы WINS назначаются через службу DHCP.

Отключить распознавание WINS | Задает отключение службы WINS.
Использовать DHCP для распознавания WINS | Задает включение службы WINS и указывает, что сервер WINS, назначает служба DHCP. Этот параметр недоступен, если не задана также поддержка DHCP для автоматического назначения IP-адреса.
Включить распознавание WINS | Задает включение службы WINS.
Порядок поиска серверов WINS | Поле ввода IP-адреса главного сервера WINS, если распознавание WINS включено. Чтобы добавить в поле IP-адрес, нажмите кнопку Добавить. Чтобы удалить IP-адрес из поля, выберите адрес и нажмите кнопку Удалить. Порядок, в котором серверы отображаются в поле, соответствует порядку, в котором будет выполняться их поиск при работе по протоколу TCP/IP.
Код области | Поле ввода кода области для определенной группы компьютеров. Оставьте поле пустым, если не знаете необходимого значения.
Файл LMHosts | Задает использование файла LMHOSTS. Введите имя и путь к файлу LMHOSTS, которые предоставляет те же сведения, что и сервер WINS, за исключением того, что он содержит статические сведения. Файл LMHOSTS по умолчанию находится в папке WINDOWS. Чтобы воспользоваться файлом LMHOSTS, необходимо также включить службу DNS.

Переход к разделу 'Параметры TCP/IP'