О программе XP Tweaker

XP Tweaker - О Программе
XP Tweaker Russian Edition

XP Tweaker - программа настройки, оптимизации и защиты Windows XP. Включает несколько опций предназначенных специально для русских версий Windows XP. Возможность сохранения настроек в файле для быстрой настройки системы или настройки системы на нескольких компьютерах. Программа имеет подробную справочную систему обо всех имеющихся опциях.

В большинстве случаев XP Tweaker сохраняет только измененные параметры, что повышает стабильность работы программы и системы в целом. Встроенная консоль XP Tweaker выводит все изменения, которые программа делает в реестре.

Программа тестировалась под следующими ОС:
(*) Windows XP Pro Rus
(*) Windows XP Corporate Edition Eng + MUI
(*) Windows Server 2003 Enterprise Edition Eng

Программа не совместима с другими версиями Windows. Вполне возможно большинство опций будут работать в Windows 2000 и Windows Longhorn, для этого запустите программу с ключом /nocheckver. Используйте данную возможность только в случае крайней необходимости, программа не тестировалась и не предназначена для этих операционных систем. С другими версиями Windows (95, 98, ME) программа не работает.

Для запуска программы необходимы привилегии Администратора. Есть возможность запустить программу под другими правами, при этом большинство опций не будут сохраняться.

Заходите на домашнюю страницу программы, чтобы скачать новые версии XP Tweaker http://xptweaker.narod.ru

http://xptweaker.by.ru (download page)
http://xptweaker.boom.ru (download page)

Все пожелания, предложения и сообщения об ошибках пишите на e-mail xptweaker@fromru.com
Авторские права

В программе используются FOOOD's Icons http://www.foood.net/icons/

Для создания программы использовалась информация со следующих веб-сайтов:

http://www.winguides.com (английский)

http://www.whatis.ru

http://www.softodrom.ru

http://www.microsoft.com

Справочник по реестру

а также другие сайты и источники.

Если Вы используете информацию из справочной системы или с сайта XP Tweaker (публикуете на других сайтах, CD и др.), Вы должны уведомить автора об этом xptweaker@fromru.com

© 2002-2003 dmc


XP Tweaker - Что нового?
XP Tweaker RE 1.40

Изменения в программе:

[+] Поддержка "мультиязычности" (90%)

[-] При отключении галочки "Оптимизировать кэш диска" значение в реестре не восстанавливалось (не удалялось)

[*] При удалении программ из автозагрузки не выдаются дополнительные предупреждения

[*] Ссылки в справке теперь открываются в новом окне

[-] Исправлена опция командной строки /shutdown

[+] Опция "Автоматически выполнять команды при запуске консоли"

[*] Создание точки восстановления только под XP

[+] Опция установки размера кэша второго уровня процессора

[-] Опция "Не использовать файл подкачки для хранения ядра системы" (DisablePagingExecutive 1<->0)

[*] Некоторые уточнения в справочной системе программы

[*] Новый стиль программы, используется новая серия иконок "iCandy Junior" от FOOOD'a

[+] Опция "Корректное удаление AVI фалов"

[*] Опция "Удалить встроенный Windows Messenger" становится недоступной под ОС отличными от Windows XP

[+] Опция "Не сканировать сеть на наличие сетевых принтеров"

[+] Опция "Не сканировать сеть на наличие назначенных заданий (Scheduled Tasks)"

[*] Опция "Задержка выпадения меню" в Windows Server 2003 (при установке значения "0")

[+] Параметры командной строки /opencd /closecd

[+] Линк "Учетные записи пользователей" на вкладке "Загрузка системы" (control userpasswords2)

[*] Убраны опции "Размер кэша для хранения иконок" и "Количество цветов для отображения иконок"

[+] Опция "Раскладка клавиатуры при входе в систему"

[+] Опция "Использовать Ctrl+Shift для переключения раскладки клавиатуры" (вкладка "Загрузка системы")

[*] Опция "Включать Num Lock при загрузке" перемещена на кладку "Загрузка системы"

[*] В "настройках соединения", убраны опции, настраивающие высокоскоростные соединения.

[*] В программе теперь используются только маленькие иконки в панели навигации, минус ~60Кб от размера дистрибутива.

[+] Опция "Изменить диалоговое окно в Microsoft Office 2000/XP"

[+] OEM информация + сведения о поддержке

[+] Возможность редактирования контекстных меню папок

[+] Опция "Восстановить пункт меню "Найти...""

[+]Другие обновления...
XP Tweaker RE 1.30

Изменения в программе:

[*] Более быстрое обновление и отмена настроек

[*] Теперь окно программы может перекрывать окно справки

[*] Сохранение положения окна (в т.ч. консоли), необходимо для работы при разрешении 800х600

[*] Выбор большие/маленькие иконки в панели навигации

[+] Совместимость с Windows Server 2003

[-] Не верная ссылка "?"

[+] Системные папки - двойной щелчок для открытия папки в проводнике

[+] Путь к папке временных файлов - линк "Установить значения %SYSTEMROOT%\Temp"

[*] Фокусировка списков в программе

[*] При выводе информации в консоль, убрана деактивация-активация главного окна (окно мигало при нажатии на кнопку Применить)

[*] Программа не закрывается, если не определит привилегии администратора или версию Windows

[*] Поиск в списке установленных программ теперь сразу отображает путь внизу

[+] Пароль для запуска программы

[+] Опция "Не выводить окно Подключение удаленного доступа при автономной работе"

[+] Опция "X-Mouse"

[-] При обновлении настроек (F5) в разделе Uninstall не считывались uninstall пути (программа не могла отобразить их и выдавала ошибку)

[+] Опция "Запретить кэширование изображений (thumbnails)"

[+] Раздел "Запрет запуска программ"

[+] Раздел "Создание виртуального диска"

[+] Раздел "Изменение регистрационных данных Windows"

[+] Опция "Открывать ярлыки в новом окне IE"

[+] Опция "Запретить фоновые звуки" (Internet Explorer)

[+] Опция "Запрет командной строки"

[+] Опция "Быстрое редактирование в командной строке"

[+] Опция "Выводить окно для ввода причины завершения работы"

[*] Программа установки теперь включает опции "Поддержка прокрутки Intelli mouse" и "Сворачивать программу в трей"

[*] Обновился редактор автозагрузки, появилась кнопка изменить

[+] Изменение OEM информации

[*] Опция sfc теперь при желании изменит sfc_os.dll (примените опцию заново)

[+] Опция "Перемещать указатель в диалоговых окнах к кнопке по умолчанию"

[-] Исправлены ошибки "Параметров работы с памятью", в справке даны ссылки на документацию Microsoft

[+] Программа установки позволяет установить некоторые параметры XP Tweaker до установки

[+] Программа установки создает ярлыки reboot, shutdown, logoff

[+] Также в программе появились новые параметры командной строки, /reboot (/r), /shutdown (/s), /logoff (/l), /force (/f), /u (/uninstall)

[+] Запуск с командной строки (например, Пуск - Выполнить - xptweaker /u)

[+]Другие обновления...
XP Tweaker RE 1.20

Изменения в программе:

[*] Вкладка "Система" разделена на две вкладки "Система" и "Загрузка системы"

[*] Удаление MSN Messenger перенесено в "Раздел Uninstall"

[*] Интервал синхронизации часов с Интернет сервером перенесен на раздел "Система - Система"

[*] Опция "Показывать выполняемые команды при запуске и выходе из системы" перенесена из "Система - Решение проблем" в "Система - Загрузка системы"

[-] Windows Messenger (Необходимо было перезапускать программу после удаления WM)

[-] Удалена опция отключения восстановления системы, для отключения данной функции пользуйтесь стандартными средствами WinXP

[-] В некоторых случаях не возможно было вызвать справку

[*] Исправлены некоторые неточности в справочной системе

[+] Если включена служба восстановления системы, программа при первом запуске предлагает создать точку отката

[+] Опция "Изменить интервал запуска программы проверки диска (Scandisk)"

[*] Автоматический вход в систему теперь изменяет ForceAutoLogon

[+] Опция "Не показывать сообщения при запуске и выходе из системы"

[+] Опция "Отключить встроенные средства WinXP для записи компакт-дисков"

[+] Опция "Принудительный вызов "стоп-ошибки" при нажатии Ctrl+Scroll Lock"

[*] Теперь при включении встроенного mp3 кодека используется максимальный битрейт 128Кбит (большие значения WinXP игнорирует, необходимо ставить дополнительные кодеки) Для записи музыки с CD доступны следующие битрейты 128Кбит/c, 112Кбит/c, 64Кбит/c, 56Кбит/c.

[-] Опция "Запись отладочной информации" Полный дамп памяти <-> Малый дамп памяти

[+] Опция "Запретить доступ к дискам"

[+] Опция "Скрыть диски в проводнике *"

[+] Новый параметр из командной строки /uninstall - При запуске программы перейти на вкладку Uninstall (удобно при создании ярлыка для удаления программ)

[+] Опция "Пункт "Удаление программ" в контекстном меню Корзины"

[+] Опция "Запретить анонимным пользователям просматривать ресурсы"

[+] Новый раздел "Утилиты Windows XP" (XP Pro)

[+] Новый раздел "Системные папки Windows"

[+]Другие обновления...
XP Tweaker RE 1.10

Основные обновления

[-] Исправлена опция "Отключить автозапись состояния окон проводника"

[-] Исправлены баги с прозрачностью окна.

[+] Поддержка скроллинга для всех мышек (раньше работали мышки, поддерживающие Enhanced scroll mode) см. Настройки

[+] Оптимизирована справочная система для лучшего просмотра

[+] Добавлена удобная навигация по справочной системе

Другие обновления

[-] Опция "Автоматически скрывать иконки в трее" при изменении не сохранялась

[-] Опцию "Использовать свою программу очистки системы" не возможно было отключить, при вызове CleanUp из свойств диска, проводник вылетал с ошибкой.

[-] Корректное сохранение "удаляемых" ключей в файле *.reg

[-] Опция "Автоматически перезапускать Проводник при ошибках" теперь читается из HKLM, а не HKCU.

[-] Сохранение опции "Мелкие значки в главном меню" (классическое меню)

[-] Опция Настройки - Запоминать размеры окна

[+] Программа добавляется в "Установка удаление программ"

[*] Опции в разделе "Пути к системным утилитам" и "Путь к папке временных файлов" теперь сохраняются как EXPAND STRING

[+] Теперь при удалении программы, удаляются все её настройки из реестра (ключ HKCU\Software\DMC Software\XP Tweaker)

[+] Теперь прозрачность окна можно менять в realtime, сразу после нажатия кнопки Применить.

[+] Корректное отображение программы при использовании крупных размеров системных шрифтов (120 точек/дюйм) Вероятно поддерживаются не все системы, пишите если программа отображается неправильно, не забудьте указать версию Windows

[+] Клавишу F5 теперь можно использовать для обновления настроек (обновление происходит за время < 1 сек)

Новые опции

[+] Опция "Поиск из панели адресов"

[+] Опция "Автоматические обновления Windows"

[+] Опция "Не показывать имя последнего пользователя"

[+] 4 опции запрета запуска программ из реестра

[+] Опция "Использовать страницу приветствия"

[+] Опция "Использовать быстрое переключение пользователей"

[+] Опция "Windows Prefetcher сервис"

Консоль XP Tweaker

Консоль реестра, предназначенная для тестирования программы, вызвала интерес среди пользователей, поэтому она не будет исключена в финальной версии, а даже наоборот, она немного обновилась. Теперь в ней пишется, какое значение записывается в реестр (раньше велась запись только измененного параметра). Теперь консоль можно закрывать, если произойдет какое либо событие, XP Tweaker вновь отобразит консоль на экране (если консоль включена).

[+]Другие обновления...


Система

XP Tweaker - Система
Содержание

Система

Очистка файла подкачки перед перезагрузкой системы

Отключить встроенный отладчик Dr. Watson

Не производить запись последнего доступа к файлам (только NTFS)

Отключить System Files Protection (SFC)

Включить поддержку UDMA-66 на чипсетах Intel *

Включать Num Lock при загрузке

Автоматически выгружать не используемые библиотеки

Отключить слежение Windows XP за пользователем

Запускать 16-битные программы в отдельных процессах

Не отсылать в Microsoft отчеты об ошибках

Запрашивать пароль после выхода из Ждущего режима

Оптимизировать системные файлы во время загрузки (boot defrag)

Принудительный вызов "стоп-ошибки" при нажатии Ctrl+Scroll Lock *

Быстрое редактирование в командной строке

Выводить окно для ввода причины завершения работы

Сообщения об ошибках

Путь к дистрибутиву Windows

Переписать консоль восстановления на жесткий диск

Автоматические обновления Windows

Windows Prefetcher сервис

Настройка кэша второго уровня

Синхронизация времени

Интервал синхронизации системных часов компьютера с time-сервером

Работа Windows с zip-архивами

Отключить поддержку Windows XP zip-архивов

Восстановление системы

Время жизни точек восстановления

Отказ системы

Автоматически перезагрузить компьютер

Записать событие в системный журнал

Отправить административное оповещение

Запись отладочной информации

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

Оптимизировать работу системного кэша

Оптимизировать кэш диска

X-Mouse

Делать окно активным при наведении указателя *

Делать окно поверх всех окон при наведении указателя *

Время задержки в миллисекундах *

Перемещать указатель в диалоговых окнах к кнопке по умолчанию

Консоль

Автоматически выполнять команды, при запуске консоли
Очистка файла подкачки перед перезагрузкой системы

Очищает файл pagefile.sys перед перезагрузкой системы. В данном файле может храниться конфиденциальная информация. Если данная опция включена, возможно значительное увеличение времени выключения компьютера.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DWORD ClearPageFileAtShutdown, значение 1 или 0

Наверх
Отключить встроенный отладчик Dr. Watson

Отключает встроенного отладчика Windows XP (программа обнаружения ошибок). Если текущим отладчиком не является Dr. Watson, он будет также отключен. Если опция выключена, то при ошибке в программе, будет выводиться соответствующее сообщение об ошибке с кнопками ОК и Отмена, при нажатии ОК - приложение завершается, а при нажатии на отмену запускается отладчик.

Примечание: можно отключить вывод окошка совсем см. опцию Сообщения об ошибках

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AeDebug

DWORD Auto, значение 1 или 0

Наверх
Не производить запись последнего доступа к файлам (только NTFS)

Ускоряет доступ к каталогам с большим количеством файлов. Данная опция работает только с дисками с файловой системой NTFS. На работу FAT32 никак не влияет. Чтобы узнать файловую систему диска, щелкните правой кнопкой на имени диска в Моем компьютере и выберите пункт меню свойства.

HKLM\SYSTEM\CurrentControlSet\Control\FileSystem

DWORD NtfsDisableLastAccessUpdate, значение 1 или 0

Наверх
Отключить System Files Protection (SFC)

Отключает блокировку системных файлов Windows XP, будьте осторожны с этой опцией, т.к. системные фалы могут быть заменены старыми версиями.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

DWORD SfcDisable, параметр может принимать различные значения, XP Tweaker для отключения SFC ставит значение hex:ffffff9d (4294967197) или 0 для включения

Начиная с версии 1.30, XP Tweaker предлагает внести изменения в системную библиотеку sfc_os.dll. Предварительно программа делает копию файла sfc_os.xpt, проверяет версию и только после этого изменяет файл. Это полностью отключит SFC. При отмене опции программа восстановит файл sfc_os.xpt, если он существует.

Примечание: Если после применения опции был установлен SP1, то необходимо удалить файл sfc_os.xpt из системной папки и после этого заново применить опцию.

Наверх
Включить поддержку UDMA-66 на чипсетах Intel *

Необходимо перезагрузить компьютер, чтобы изменения вступили в силу.

HKLM\System\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\0000

DWORD EnableUDMA66, значение 1 или 0

Примечание: прежде чем применить опцию, убедитесь, что ваше устройство поддерживает UDMA-66 и используется 80-pin кабель.
Данная возможность не должна использоваться для UDMA-100, необходимо установить драйвера контролера IDE.

Наверх
Включать Num Lock при загрузке

Определяет состояние кнопки Num Lock при вводе логина и пароля. Windows XP отключает Num Lock в любом случае, даже если в BIOS состояние Num Lock находится в положении включено.

HKEY_USERS\.DEFAULT\Control Panel\Keyboard

DWORD InitialKeyboardIndicators, значение 2 - Num Lock включен, значение 0 - выключен

Наверх
Автоматически выгружать не используемые библиотеки

Разрешает Windows XP выгружать не используемые библиотеки, тем самым, освобождая память. Если наблюдается нестабильная работа системы при включенной опции, отключите её.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer

DWORD AlwaysUnloadDLL, значение 1 - выгружать библиотеки, значение 0 - не выгружать

Примечание: включение данной опции может привести к невозможности запуска XP Tweaker, в этом случае исправить значение можно только при помощи редактора реестра!

Наверх
Отключить слежение Windows XP за пользователем

Windows XP постоянно записывает действия пользователя, какие программы он запускал, какие открывал документы и т.д. В целях безопасности данную опцию можно отключить.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoInstrumentation, значение 1 - отключить слежение, значение 0 - включить

Примечание: НЕ БУДЕТ СОХРАНЯТЬСЯ список часто вызываемых программ (в меню Пуск), недавние документы и пр.

Наверх
Запускать 16-битные программы в отдельных процессах

Запускает приложения для MS-DOS и Windows 3.1 в отдельных процессах. При крахе одного процесса, работа других не нарушится. Включение данной опции потребует больше памяти под 16-битные программы.

HKLM\SYSTEM\CurrentControlSet\Control\WOW

STRING DefaultSeparateVDM, значение "yes" - запускать программы в отдельных процессах, другие игнорируются

Ссылки по теме:

Windows 2000 Resourse Kits (DefaultSeparateVDM)

Наверх
Не отсылать в Microsoft отчеты об ошибках

С помощью данной опции можно отключить отсылку сообщений об ошибках в Microsoft. Данную опцию, при необходимости, можно более подробно настроить в Свойствах системы, вкладка Дополнительно, кнопка отчет об ошибках.

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting

DWORD DoReport, 0 - Отключить отчет об ошибках, 1 - включить
DWORD ShowUI, 0 - Отключить сообщения о критических ошибках, 1 - включить сообщения о критических ошибках, 2 - включить сообщения обо всех ошибках.

Если данная опция включена, XP Tweaker присваивает параметрам DoReport и ShowUI значение 0, иначе обоим присваивает значение 1. Вы также можете настроить некоторые другие опции (они будут работать, только если DoReport = 1 и ShowUI = 3)

DWORD IncludeKernelFaults - Отчет об ошибках Windows XP (ошибки ядра), может принимать значения 1 или 0
DWORD IncludeMicrosoftApps - Отчет об ошибках программ от Майкрософт, может принимать значения 1 или 0
DWORD IncludeWindowsApps - Отчет об ошибках компонентов Windows XP, может принимать значения 1 или 0

DWORD AllOrNone - Дает возможность запрета отсылки сообщений об ошибках определенных приложений, значение 1 - отсылаются все, значение 0 - только выбранные приложения. Для того чтобы выбрать приложение, его необходимо добавить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\InclusionList, а чтобы исключить в
HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList.

В данных разделах необходимо создать DWORD параметр с названием программы и значением 1, например:

HKLM\SOFTWARE\Microsoft\PCHealth\ErrorReporting\ExclusionList
"programm.exe"=dword:00000001

исключает отсылку сообщений об ошибках программы programm.exe

Наверх
Запрашивать пароль после выхода из Ждущего режима

HKCU\Software\Policies\Microsoft\Windows\System\Power

DWORD PromptPasswordOnResume, значение 1 - запрашивать пароль

Наверх
Оптимизировать системные файлы во время загрузки (boot defrag)

Дефрагментация файлов, необходимых для старта операционной системы. Выключение этой функции позволит на некоторое время уменьшить время загрузки, но со временем она будет становиться все медленнее.

HKLM\SOFTWARE\Microsoft\Dfrg\BootOptimizeFunction

STRING Enable, значение "Y" - оптимизация включена, "N" - выключена

Наверх
Принудительный вызов "стоп-ошибки" при нажатии Ctrl+Scroll Lock *

Принудительный вызов "синего экрана смерти" вручную. Данную возможность можно использовать при зависании компьютера вместо нажатия reset.

Необходимо перезагрузить компьютер, чтобы изменения вступили в силу. После этого для вызова стоп-ошибки нужно удерживая клавишу Ctrl два раза нажать на Scroll Lock.

HKLM\SYSTEM\CurrentControlSet\Services\i8042prt\Parameters

DWORD CrashOnCtrlScroll, значение 1 - принудительный вызов ошибки вручную включен

Наверх
Быстрое редактирование в командной строке

Позволяет быстро копировать/вставлять текст в консоли, используя кнопки мыши. Левая кнопка используется для выделения текста в консоли, правая для копирования (если в консоли имеется выделенный текст) или для вставки текста. Чтобы настройка вступила в силу, необходимо перезапустить консоль.

HKCU\Console

DWORD QuickEdit, значение 1 - быстрое редактирование включено, 0 - выключено.

Примечание: если опция включена, контекстное меню будет не доступно

Наверх
Выводить окно для ввода причины завершения работы

Windows Server 2003 не дает завершить работу компьютера без ввода причины завершения. С помощью данной опции можно отключить этот запрос. В Windows XP этот режим по умолчанию выключен.

HKLM\Software\Policies\Microsoft\Windows NT\Reliability

DWORD ShutdownReasonUI, значение 1 - запрос причины завершения включен, 0 - выключен.

Примечание: если параметр отсутствует, то Windows XP считает его равным 0, а Windows Server 2003 равным 1

Наверх
Сообщения об ошибках

Данный параметр задает, какие сообщения об ошибках будут выводиться на экран

HKLM\SYSTEM\CurrentControlSet\Control\Windows

DWORD ErrorMode, может принимать следующие значения

    • 0 - Показывать все ошибки (По умолчанию)
    • 1 - Только ошибки приложений, системные отключены
    • 2 - Отключить все сообщения об ошибках

Наверх
Путь к дистрибутиву Windows

Windows не дает стандартными способами изменить путь к дистрибутиву, но вы можете изменить его с помощью данной опции.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup

STRING SourcePath, полный путь к дистрибутиву, например F:\ или C:\DISTRIB\WINXP\

Наверх
Переписать консоль восстановления на жесткий диск

Консоль восстановления Windows находится на CD-ROM с Windows XP, но имеется возможность переписать её на жесткий диск так, что при загрузке вы сможете выбрать: загружать XP или консоль восстановления. Перед тем как щелкнуть по ссылке вставьте компакт-диск с дистрибутивом Windows XP.

XP Tweaker выполнить команду: %путь к дистрибутиву%\i386\winnt32.exe /cmdcons

После установки консоли, на системном диске появится папка cmdcons размером 7-8 Мб, а в boot.ini появиться новая строка

...\CMDCONS\BOOTSECT.DAT="Microsoft Windows XP Recovery Console" /cmdcons

Выполните Пуск->Выполнить->msconfig перейдите на вкладку boot.ini и убедитесь, что появился новый пункт меню.

Наверх
Автоматические обновления Windows

Управление автоматическим обновлением Windows XP. Также данную опцию можно настроить следующим способом: Панель управления - Система - Автоматическое обновление.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Auto Update

DWORD AUOptions
DWORD AUState

Windows XP использует следующие значения:

Отключить автоматические обновления:

AUOptions = 1
AUState = 7

Уведомлять о возможности загруки обновлений

AUOptions = 2
AUState = 2

Загружать обновления, затем уведомлять о готовности к установке

AUOptions = 3 и другие значения
AUState = 2

Наверх
Windows Prefetcher сервис

В Windows XP есть специальный Prefetcher Service, его задача уменьшить время запуска приложений и время загрузки системы. Файлы, используемые этим сервисом, находятся в папке %systemroot%\prefetch. C помощью данной опции Вы можете управлять данным сервисом.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\PrefetchParameters

DWORD EnablePrefetcher, параметр может принимать следующие значения:

0 - отключить сервис

1 - упреждающая выборка приложений

2 - упреждающая выборка приложений, запускаемых во время загрузки системы (используется Windows Server 2003 по умолчанию)

3 - включены обе упреждающие выборки (пп. 1 и 2) используется Windows XP по умолчанию

Перезагрузите компьютер, чтобы изменения вступили в силу.

Наверх
Настройка кэша второго уровня

Опция задает значение кэша процессора второго уровня (L2 cache). Это значение используется, в случае если Windows XP не сможет определить размер кэша и позволяет полностью использовать ресурсы процессора.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DWORD SecondLevelDataCache, значение - размер кэша второго уровня процессора в килобайтах, если значение параметра равно 0, используется кэш равный 256 килобайт

Примечание: размер кэша вашего процессора можно узнать из документации к нему.

Ссылки по теме:

Windows 2000 Resourse Kits (SecondLevelDataCache)

Наверх

Синхронизация времени

Интервал синхронизации системных часов компьютера с time-сервером

Синхронизация времени вашего компьютера с сервером в Интернете. По умолчанию Windows XP использует интервал в 7 дней. Чтобы настроить сервер, с которым Windows XP будет сверять время, выберите в Панели управления - Дата и время, затем перейдите на вкладку Время Интернета.

HKLM\SYSTEM\ControlSet001\Services\W32Time\TimeProviders\NtpClient

DWORD SpecialPollInterval, значение - интервал в секундах. XP Tweaker позволяет выставлять интервалы кратные 24 часам.

Примечание: Значение интервала вступит в силу только после синхронизации времени Windows или вручную.

Наверх

Работа Windows с zip-архивами

Отключить поддержку Windows XP zip-архивов

По умолчанию Windows XP считает zip-файлы папками - это удобно, если у вас быстрый компьютер. На медленных компьютерах можно отключить эту возможность. Также Windows не будет искать файлы в архивах, что значительно ускорит поиск.

Для отключения поддержки XP Tweaker исполняет команду:

regsvr32 /u /s zipfldr.dll, а для включения regsvr32 /s zipfldr.dll

Параметр /u отключает поддержку, /s не выдаются сообщения. Для определения включена поддержка или нет, XP Tweaker проверяет, существует ли параметр HKEY_CLASSES_ROOT\.zip\CompressedFolder\ShellNew BINARY Data. Если существует - поддержка включена, иначе выставляется галочка, что означает - поддержка zip-архивов отключена.

Примечание: опция не доступна для Windows Server 2003

Наверх

Восстановление системы

Время жизни точек восстановления

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SystemRestore

DWORD RPLifeInterval, время жизни точек восстановления в секундах. XP Tweaker позволяет выставить значения от одного до 365 дней

*Вы можете задать количество мегабайт, которые использует восстановление системы на каждом диске через Свойства системы->Восстановление системы.

Примечание: опция не доступна для Windows Server 2003.

Наверх

Отказ системы

Автоматически перезагрузить компьютер

Майкрософт всегда думает о пользователях, не прошёл мимо и факт зависания компьютера. Теперь вам не надо тянуться к кнопке Reset, компьютер перезагрузиться самостоятельно, если произойдет непоправимая ошибка. Данную опцию можно настроить в Свойствах системы, вкладка Дополнительно, раздел Загрузка и восстановление.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

DWORD AutoReboot, значение 1 - перезагружать компьютер, 0 - не перезагружать

Наверх
Записать событие в системный журнал

Производит запись в журнал об ошибке системы, если компьютером пользуется несколько человек и вам интересно, когда произошло зависание компьютера, включите данную опцию, иначе имеет смысл её отключить.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

DWORD LogEvent, значение 1 - вести запись журнала, 0 - не вести

Примечание: опция не используется для Windows Server 2003

Наверх
Отправить административное оповещение

Оповещение администраторов системы при возникновении ошибки.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

DWORD SendAlert, значение 1 - отправлять сообщение администраторам, 0 - не отправлять

Наверх
Запись отладочной информации

Данную опцию следует включать, если вы гений в двоичных кодах :) Для всех остальных рекомендуется отключить данную опцию, т.к. при непоправимой ошибке система может довольно долго записывать отладочную информацию и её размер может быть равен размеру оперативной памяти, в зависимости от выбранных деталей отчета.

HKLM\SYSTEM\CurrentControlSet\Control\CrashControl

DWORD CrashDumpEnabled, значение 0 - запись не ведется, 1 - Полный дамп памяти (создание файла, равного размеру оперативной памяти) , 2 - Дамп памяти ядра, 3 - Малый дамп памяти (64КБ)

Наверх

Параметры работы с памятью

Не использовать файл подкачки для хранения ядра системы

По умолчанию WinXP хранит ядро системы и системные драйвера всегда в памяти, можно отключить данную возможность, чтобы разрешить хранить данные на диске в файле подкачки. При большом объеме памяти (RAM) не рекомендуется отключать данную опцию.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DWORD DisablePagingExecutive, 1 - не использовать файл подкачки для хранения ядра системы (по умолчанию), 0 - использовать

Ссылки по теме:

Windows 2000 Resourse Kits (Memory Management, DisablePagingExecutive)

Наверх
Оптимизировать работу системного кэша *

Используйте данную опцию, если у вас 512 МБ памяти или больше. Данная опция увеличит производительность Windows XP. Рекомендуется использовать данную опция, если компьютер используется в качестве сервера или работа ведется в программах, для которых требуется кэш большого размера.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DWORD LargeSystemCache, значение 1 - использовать, 0 - не использовать

Примечание: в Windows Server 2003 по умолчанию опция включена.

Ссылки по теме:

Windows 2000 Resourse Kits (Memory Management, LargeSystemCache)

Наверх
Оптимизировать кэш диска

Данная опция увеличит число страниц, которые система будет читать или писать на жесткий диск за один раз. Исходя из этого, должна вырасти производительность.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

DWORD IOPageLockLimit, значение параметра задаётся в шестнадцатеричной системе от hex:1 до hex:FFFFFFFF байт. Если параметр не существует или равен 0 (по умолчанию), то используется кэш равный 512 Кб. Рекомендуются следующие значения:

Объём RAM компьютера | Рекомендуемое значение параметра IOPageLockLimit
128 МБ и более | 16384 КБ (16 МБ)
160 МБ и более | 32768 КБ (32 МБ)
256 МБ и более | 65536 КБ (64 МБ)
512 МБ и более | 131072 КБ (128 МБ)
Объём RAM компьютера | Максимальное значение параметра
Менее 64 МБ | Объём RAM минус 7 МБ
64 МБ - 500 МБ | Объём RAM минус 16 МБ
512 Мб и более | Объём RAM минус 64 МБ

Ссылки по теме:

Microsoft Knowledge Base Article - 121965 (HOWTO: Change Max Memory Allowed with MmProbeAndLockPages)

Microsoft Knowledge Base Article - 102985 (REG: CurrentControlSet Entries PART 2: SessionManager)

Windows 2000 Resourse Kits (Memory Management, IoPageLockLimit)

Наверх

X-Mouse

Делать окно активным при наведении указателя *

1. Делать окно активным при наведении указателя

2. Делать окно поверх всех окон при наведении указателя

HKCU\Control Panel\Desktop

BINARY UserPreferencesMask, может принимать следующие значения:

Включены обе опции hex:df,3e,07,80
Включена только первая опция hex:9f,3e,07,80
Включена только вторая опция (без включения первой, не имеет никакого эффекта) hex:de,3e,07,80
Обе опции отключены hex:9e,3e,07,80

Наверх
Делать окно поверх всех окон при наведении указателя *

HKCU\Control Panel\Desktop

BINARY UserPreferencesMask, значения cм. выше

Наверх
Время задержки в миллисекундах *

Время задержки перед установкой окна активным.

HKCU\Control Panel\Desktop

DWORD ActiveWndTrkTimeout, значение - интервал в миллисекундах.

Наверх
Перемещать указатель в диалоговых окнах к кнопке по умолчанию

Автоматическое перемещение курсора мыши на активную по умолчанию кнопку диалогового окна. При редактировании реестра вручную, параметр вступит в силу только после перезагрузки системы.

HKCU\Control Panel\Mouse

STRING SnapToDefaultButton, значение 1 - опция включена, 0 - отключена

Наверх

Консоль

Автоматически выполнять команды, при запуске консоли

Опция позволяет указать командный файл, который будет запускаться каждый раз при запуске консоли.

HKEY_CURRENT_USER\SOFTWARE\Microsoft\Command Processor

STRING AutoRun, значение - путь к командном файлу

Примечание: путь к файлу необходимо указывать по правилу 8.3 (например, "C:\DOCUME~1\dmc\РАБОЧИ~1\Autocm.cmd")

Наверх


Проводник

XP Tweaker - Проводник
Содержание

Проводник

Отключить сообщение о недостатке свободного места на диске

Анимация при сворачивании и разворачивании окон *

Запускать окна Проводника в отдельном процессе

Автоматически перезапускать Проводник при ошибках

Удалить стрелки у ярлыков

Не добавлять "Ярлык для..." для создаваемых ярлыков

Отключить автозапись состояния окон проводника *

Не показывать папки документов в "Моем компьютере"

Отображать содержимое окна при перетаскивании *

Запретить кэширование изображений (thumbnails)

Сглаживать неровности экранных шрифтов

Частота мерцания курсора

Использовать свой редактор для открытия файлов неизвестного типа

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

Добавить пункт меню "Переместить в папку..."

Пункт меню "Отправить"

Удалить пункт из контекстного меню папок

Добавить новый пункт в контекстное меню папок

Диалоговое окно открытия и сохранения файла

Изменить диалоговое окно

Изменить диалоговое окно в Microsoft Office 2000/XP
Отключить сообщение о недостатке свободного места на диске

Не выдавать сообщение о недостатке места на диске. Имеет смысл использовать данную опцию на дисках малого размера.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoLowDiskSpaceChecks, значение 1 - сообщение отключено, 0 - включено

Наверх
Анимация при сворачивании и разворачивании окон *

На медленном компьютере рекомендуется отключить данную опцию. Изменения вступят в силу только после перезагрузки.

HKCU\Control Panel\Desktop\WindowMetrics

STRING MinAnimate, "1" - анимация включена, "0" - выключена. Обратите внимание, параметр имеет строковое значение, а не DWORD.

Наверх
Запускать окна Проводника в отдельном процессе

Включение данной опции позволяет запускать окна Проводника в разных процессах, это увеличит стабильность системы, но требует больше памяти.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD SeparateProcess, 1 - окна проводника запускаются в различных процессах, 0 - используется один процесс

Наверх
Автоматически перезапускать Проводник при ошибках

Очень удобная опция. При крахе Проводник будет сам перезапускаться и не надо вызывать диспетчер задач, чтобы его запустить.

HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon

DWORD AutoRestartShell, 1 - Проводник автоматически перезапускается, 0 - не перезапускается

Наверх
Удалить стрелки у ярлыков

Удаляет стрелки в левом нижнем углу у ярлыков.

HKLM\SOFTWARE\Classes\lnkfile - ярлыки Windows XP
HKLM\SOFTWARE\Classes\piffile - ярлыки DOS программ

STRING IsShortcut, значение "1" - На ярлыке присутствуют стрелки, удаление этого параметра - отключает стрелки на ярлыках

Примечание: XP Tweaker читает только одно значение HKLM\SOFTWARE\Classes\lnkfile\IsShortcut, и если оно существует, делает вывод, что опция отключена. Запись производится в оба параметра.

Наверх
Не добавлять "Ярлык для..." для создаваемых ярлыков

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

BINARY link, значение hex:00,00, 00,00 - не добавлять

Примечание: после включения опции не следует создавать ярлыки до перезагрузки компьютера, т.к. Windows изменит значение параметра.

Примечание: в Windows Server 2003 этот параметр по умолчанию включен.

Наверх
Отключить автозапись состояния окон проводника *

Отключает запись положения и размеров окон проводника. Чтобы изменения вступили в силу необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

BINARY NoSaveSettings, значение hex: 01,00,00,00 - отключить автозапись, удаление значения - включает автозапись

Наверх
Не показывать папки документов в "Моем компьютере"

Не показывать папки "Мои документы", "Общие документы" и т.д. Для удаления папок из "Моего компьютера" необходимо удалить ключ:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\MyComputer\ NameSpace\DelegateFolders\{59031a47-3f72-44a7-89c5-5595fe6b30ee}

Чтобы вернуть папки на место, создайте этот ключ заново.

Наверх
Отображать содержимое окна при перетаскивании *

Если данная опция отключена, то вместо самого окна передвигается только его контур. Отключите эту опцию, если это очень загружает систему. Чтобы изменения вступили в силу необходимо перезагрузиться.

HKCU\Control Panel\Desktop

STRING DragFullWindows, значение "1" - отображать содержимое, "0" - отображать только контур. Обратите внимание, параметр имеет строковое значение, а не DWORD.

Наверх
Запретить кэширование изображений (thumbnails)

Windows XP создает скрытые файлы Thumbs.db, для последующего быстрого вывода изображений, с помощью данной опции можно отключить эту возможность.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD DisableThumbnailCache, значение 1 - отключить кэширование, 0 - включить

Наверх
Сглаживать неровности экранных шрифтов

Улучшает отображение шрифтов на мониторе компьютера. Сглаживание Clear Type в основном используется для ЖК-дисплеев, т.к. на обыкновенных мониторах он будет смотреться размыто.

HKCU\Control Panel\Desktop

STRING FontSmoothing, "2" - использовать сглаживание шрифтов, "0" - не использовать
DWORD FontSmoothingType, может принимать следующие значения:

    • 0 - Не использовать сглаживание
    • 1 - Стандартное сглаживание
    • 2 - Сглаживание Clear Type

Наверх
Частота мерцания курсора

Частота мерцания курсора при вводе текста. Также эту возможность можно настроить в Панели управления->Клавиатура

HKCU\Control Panel\Desktop

STRING CursorBlinkRate, чем больше число, тем больше промежуток между мерцанием курсора, значение "-1" - курсор не мерцает. XP Tweaker разрешает выставить значения в диапазоне от 200 до 1200, если значение больше, то выставляется значение "-1". Обратите внимание, параметр имеет строковое значение, а не DWORD. По умолчанию Windows XP использует значение 530.

Наверх
Использовать свой редактор для открытия файлов неизвестного типа

Открытие не зарегистрированных типов файлов с помощью своей программы. Используйте префикс "%1" для подстановки имени файла. (XP Tweaker автоматически подставляет префикс, если его не находит)

HKLM\SOFTWARE\Classes\Unknown\shell\%open%\command

значение по умолчанию - путь к файлу, например, D:\Мои документы\CBuilder\Notepad\Notepad.exe %1

SOFTWARE\Classes\Unknown\shell

значение по умолчанию - %open%

%open% - любое имя, XP Tweaker использует значение "open"

Наверх

Контекстное меню проводника

Добавить пункт меню "Копировать в папку..."

С помощью данного меню можно быстро скопировать папку или файл в любое место.

HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Copy To

Для появления пункта меню, необходимо указать параметр по умолчанию {C2FBB630-2971-11D1-A18C-00C04FD75D13}, чтобы удалить пункт меню, удалите ключ.

Наверх
Добавить пункт меню "Переместить в папку..."

С помощью данного меню можно быстро переместить папку или файл в любое место.

HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Move To

Для появления пункта меню, необходимо указать параметр по умолчанию {C2FBB631-2971-11D1-A18C-00C04FD75D13}, чтобы удалить пункт меню, удалите ключ.

Наверх
Пункт меню "Отправить"

Позволяет быстро отправлять объекты проводника различным приложениям, например, почтовому клиенту или редактору текстовых файлов.

HKEY_CLASSES_ROOT\AllFilesystemObjects\shellex\ContextMenuHandlers\Send To

Для появления пункта меню, необходимо указать параметр по умолчанию {7BA4C740-9E81-11CF-99D3-00AA004AE837}, чтобы удалить пункт меню, удалите ключ.

Наверх
Удалить пункт из контекстного меню папок

Некоторые приложения без вашего желания добавляют свои пункты в контекстное меню папок, что делает меню большим и не удобными. С помощью XP Tweaker вы можете удалить некоторые из пунктов.

HKLM\SOFTWARE\Classes\Directory\shell - в данном разделе храниться информация о контекстном меню папок.

Наверх
Добавить новый пункт в контекстное меню папок

Добавляет новый пункт в контекстное меню папок.

HKLM\SOFTWARE\Classes\Directory\shell

В этом разделе необходимо создать новый ключ, например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager

В значении по умолчанию укажите название программы, например "Far manager", далее необходимо создать подключ с названием "command", например:

HKLM\SOFTWARE\Classes\Directory\shell\Far Manager\command

В значении по умолчанию укажите путь к файлу с параметрами при необходимости, например:

c:\program files\far\far.exe %1

Наверх

Диалоговое окно открытия и сохранения файла

Изменить диалоговое окно

Изменение кнопок быстрого доступа к файлам. Максимум кнопок может быть 5.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32\PlacesBar

DWORD или STRING Place0
DWORD или STRING Place1
DWORD или STRING Place2
DWORD или STRING Place3
DWORD или STRING Place4

Если параметр имеет значение типа STRING, то в нем хранится путь к папке, а если DWORD, то Windows XP сама выбирает папку в зависимости от значения параметра. XP Tweaker поддерживает следующие значения:

0 - Рабочий стол
5 - Мои документы
6 - Избранное
8 - Недавние документы
13 - Моя музыка
14 - Мои видеозаписи
17 - Мой компьютер
18 - Сетевое окружение
36 - Windows
37 - System32
38 - Program files
39 - Мои рисунки
40 - Documents & Settings\UserName
46 - Общие документы

также есть возможность задавать любую папку, в этом случае XP Tweaker использует значение типа STRING.

Наверх
Изменить диалоговое окно в Microsoft Office 2000/XP

Изменение кнопок быстрого доступа к файлам в офисных приложениях.

HKCU\Software\Microsoft\Office\10.0\Common\Open Find\Places\UserDefinedPlaces

Для добавления новой кнопки, необходимо в данном ключе, создать подключ, например:
HKCU\Software\Microsoft\Office\10.0\Common\Open Find\Places\UserDefinedPlaces\1

STRING Name, задает имя создаваемой кнопки
STRING Path, задает путь, например:

Name = Мои документы
Path = C:\Documents and Settings\dmc\Мои документы

После создания своих кнопок, необходимо запретить вывод на экран стандартных кнопок, для этого необходимо в каждом подключе HKCU\Software\Microsoft\Office\10.0\Common\Open Find\Places\StandardPlaces создать значение:

DWORD Show равное 0

Наверх


Панель задач

XP Tweaker - Панель задач
Содержание

Панель задач

Показывать всплывающие подсказки *

Автоматически скрывать иконки в трее

Cкрыть все значки в трее

Группировать сходные кнопки на панели задач

Мигание кнопок на панели задач

Мигание кнопок на панели задач

Число миганий кнопки на панели задач
Показывать всплывающие подсказки *

В Windows XP на панели задач существует два типа всплывающих подсказок - краткие и с дополнительными сведениями. В краткой показывается только название программы, а в "полной версии" некоторые дополнительные сведенья, их содержимое зависит от программы. Пример: при включенной опции монитор DrWeb'a (SpIDer Guard) показывает статистику проверок фалов, а при выключенной опции только название программы. Иногда "полные версии" всплывающих подсказок выводятся самостоятельно, без наведения мыши, чтобы сообщить пользователю, о каком либо событии. Значение отсутствует при установке Windows.

Примечание: Данная опция никак не влияет на всплывающую подсказку к кнопке Пуск.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD EnableBalloonTips, значение 1 (или удаление параметра) - показывать дополнительные сведенья, 0 - не показывать

Наверх
Автоматически скрывать иконки в трее

Очень удобная опция, если у вас постоянно находится много иконок программ в системном трее. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. При установке Windows, параметр отсутствует.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer

DWORD EnableAutoTray, значение 1 (или удаление параметра) - скрывать иконки, 0 - все иконки отображаются

Наверх
Cкрыть все значки в трее

Убирает значки всех приложений в системном трее. Если опция включена, то в свойствах "Панели задач и меню Пуск" раздел "Область уведомлений" будет недоступен.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoTrayItemsDisplay, значение 1 - скрыть все значки

Наверх
Группировать сходные кнопки на панели задач

Признак группировки окон одинакового типа в одну кнопку. В дальнейшем при щелчке на эту кнопку появится меню, в котором можно выбрать программу. Также эту опцию можно настроить, щелкнув правой кнопкой мыши на панели задач и выбрав в контекстном меню пункт Свойства. Значение отсутствует при установке Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD TaskbarGlomming, значение 1 (или удаление значения) - группировать окна, 0 - не группировать

Следующий параметр влияет на порядок группировки приложений:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD TaskbarGroupSize, может принимать следующие значения:

    • 0 - группировать окна, начиная со "старых" окон, когда на панели задач мало места
    • 1 - группировать окна, начиная с "новых" окон, когда на панели задач мало места
    • 2 - группировать в любом случае, если есть не менее двух подобных окон
    • 3 - группировать в любом случае, если есть не менее трех подобных окон и т.д.

Примечание: значение 0 используется по умолчанию.

Наверх

Мигание кнопок на панели задач

В этом разделе XP Tweaker позволяет изменить следующие параметры:

Когда программа требует ввода данных, она может либо "выскочить" наверх, либо начать мигать иконкой в панели задач. Данный параметр регулирует время задержки до "перехвата" фокуса в миллисекундах.

HKCU\Control Panel\Desktop

DWORD ForegroundLockTimeout, значение 0 - немедленно, по умолчанию Windows XP использует 200 секунд (200000 миллисекунд)

Наверх
Число миганий кнопки на панели задач

HKCU\Control Panel\Desktop

DWORD ForegroundFlashCount, значение 0 - заставит мигать кнопку бесконечно, по умолчанию Windows XP использует значение 3

Наверх


Меню Пуск

XP Tweaker - Меню Пуск
Содержание

Меню Пуск

Убрать имя пользователя из меню Пуск *

Удалить пункт меню Выход из системы (Logoff) *

Удалить список часто используемых программ *

Не вести историю открытия документов

Очистка списка недавно использовавшихся документов

Раскрывать меню при наведении и задержки указателя

Выделять недавно установленные программы *

Не показывать общие ярлыки (All Users)

Количество ярлыков в меню "Пуск - Документы"

Элементы меню Пуск

Меню в стиле Windows XP

Администрирование

Использовать прокрутку для меню Программы

Команда "Выполнить"

Меню "Избранное"

Мои документы

Мой компьютер

Мои рисунки

Моя музыка

Панель управления

Поиск

Разрешить перетаскивание объектов

Сетевое окружение

Сетевые подключения

Справка и поддержка

Отображать пункт меню Недавние документы

Большие значки в главном меню

Классический вид меню

Классический вид меню

Использовать прокрутку для меню "Программы"

Использовать сокращенные меню

Мелкие значки в главном меню

Отображать команду "Выполнить"

Отображать команду "Завершение сеанса"

Отображать меню "Администрирование"

Отображать папку "Избранное"

Разрешить перетаскивание объектов

Раскрывать "Панель управления"

Раскрывать папку "Мои документы"

Раскрывать папку "Мои рисунки"

Раскрывать папку "Принтеры"

Раскрывать "Сетевые подключения"

Задержка выпадения меню *

Задержка выпадения меню *
Убрать имя пользователя из меню Пуск *

Убирает имя пользователя из меню Пуск (только если меню в стиле XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoUserNameInStartMenu, значение 1 - убирает имя пользователя, 0 - показывать имя пользователя

Наверх
Удалить пункт меню Выход из системы (Logoff) *

Запретить выход из системы из меню Пуск. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD StartMenuLogoff, значение 1 - удаляет кнопку из меню

Наверх
Удалить список часто используемых программ *

Не путайте данный параметр с "Недавно использовавшимися документами". Данный параметр убирает часто использующиеся программы, которые появляются в меню пуск, в левом столбце (только в стиле Windows XP). Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoStartMenuMFUprogramsList, значение 1 - удаляет список

Наверх
Не вести историю открытия документов

Не вести историю "Недавно использовавшихся документов". Windows XP создает в папке Documents and Settings\%USERNAME%\Recent ярлыки к запускаемым программам. Вы можете отключить данную возможность, если не пользуетесь ими.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoRecentDocsHistory, значение 1 - история открытия документов не ведется

Наверх
Очистка списка недавно использовавшихся документов

Очитка списка происходит во время выхода из системы (logout) или перезагрузки компьютера.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD ClearRecentDocsOnExit, значение 1 - список очищается

Наверх
Раскрывать меню при наведении и задержки указателя

Если опция включена, меню автоматически раскрывается наведении и задержки указателя, иначе необходимо щелкнуть левой кнопкой мыши для его открытия.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_AutoCascade, значение 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Выделять недавно установленные программы *

Подсвечивать недавно установленные программы. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_NotifyNewApps, значение 1 - раскрывать меню автоматически, 0 - только после щелчка мыши.

Наверх
Не показывать общие ярлыки (All Users)

Не добавлять в меню Пуск общие ярлыки. Папка с общими ярлыками находится Documents and Settings\All Users\Главное меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoCommonGroups, значение 1 - ярлыки из общего меню не добавляются

Наверх
Количество ярлыков в меню "Пуск - Документы"

Количество ярлыков, которое будет отображаться в папке "Недавно использовавшиеся документы". По умолчанию Windows XP использует 15 ярлыков.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD MaxRecentDocs, значение - количество ярлыков

Наверх

Элементы меню Пуск

Меню в стиле Windows XP

Примечание: переключатель "Меню в стиле XP" и "Классический вид меню" типа никак не влияет на меню. В зависимости от выбранного параметра вам будет предложено настроить опции для соответствующих меню. Оба меню используют различные параметры в реестре (см. ниже), исключением составляет параметр StartMenuAdminTools, он используется обоими типами меню, но меню в стиле XP использует тип DWORD, а классическое меню строковый тип. В зависимости от выбранного положения переключателя, параметр будет сохраняться, соответственно, с типом DWORD для меню в стиле XP и строковым типом для классического стиля.

Существует две возможности скрывать/показывать меню, а именно два ключа
HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced и
HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer или такой же ключ в HKEY_LOCAL_MACHINE
первый ключ просто скрывает/показывает пункты меню и их легко исправить стандартными средствами Windows XP, второй же ключ запрещает/разрешает показ меню, изменение параметров в этом ключе имеет больший приоритет и не изменяется стандартными средствами Windows XP. (см. раздел Защита - Меню Пуск)

Наверх
Администрирование

Отображать в меню "Пуск"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_AdminToolsRoot, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Отображать в меню "Все программы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuAdminTools, значение 0 - не отображать пункт меню, 1 - отображать

Примечание: Windows XP не позволяет выбрать значение так, чтобы пункт меню Администрирование отображался в главном меню и не отображался в меню "Все программы", но вы можете это сделать с помощью XP Tweaker.

Наверх
Использовать прокрутку для меню Программы

Если прокрутка включена, то меню все программы будет в один столбец и для навигации по нему необходимо подвести курсор мыши к краю экрана. Иначе при большом количестве установленных программ может появиться два и более столбцов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ScrollPrograms, значение 0 - не использовать прокрутку меню, 1 - использовать

Наверх
Команда "Выполнить"

Отображать/скрыть пункт меню выполнить

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowRun, значение 0 -скрыть пункт меню, 1 - показывать

Наверх
Меню "Избранное"

Показывать/скрыть пункт меню избранного Internet Explorer. Его удобно использовать, если вы работаете с Internet Explorer, если вы работаете с другим браузером, который использует свою папку избранного, этот пункт меню зачастую теряет смысл. Пункт меню "Избранное" по умолчанию ссылается на папку Documents and Settings\%USERNAME%\Избранное.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuFavorites, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowMyDocs, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мой компьютер

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowMyComputer, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Мои рисунки

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Мои документы\Мои рисунки

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowMyPics, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Моя музыка

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Моя музыка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowMyMusic, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Панель управления

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowControlPanel, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Поиск

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowSearch, значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Разрешить перетаскивание объектов

Разрешить перетаскивание объектов с помощью мышки.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_EnableDragDrop, значение 1 - разрешить перетаскивание объектов, 0 - запретить

Наверх
Сетевое окружение

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowNetPlaces, значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Сетевые подключения

Ссылка на данную папку находится в Панели управления.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowNetConn, значение 0 - не отображать пункт меню, 1 - ссылка на папку сетевых подключений, 2 - отображать как меню "Подключение"

Наверх
Справка и поддержка

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowHelp, значение 0 - не отображать пункт меню, 1 - отображать

Наверх
Отображать пункт меню Недавние документы

Эта папка по умолчанию находится в Documents and Settings\%USERNAME%\Recent

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_ShowRecentDocs, значение 0 - не отображать пункт меню, 1 - отображать как ссылку, 2 - отображать как меню

Наверх
Большие значки в главном меню

Вид отображения значков в главном меню. Этот параметр влияет только на левый столбец меню в стиле XP.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_LargeMFUIcons, значение 0 - в меню отображаются маленькие значки, 1 - большие

Наверх

Классический вид меню

Классический вид меню

Параметры меню классического типа сохраняются в строковом виде. Значение "YES" означает, что опция включена. Другие значения игнорируются (т.е. считается, что опция выключена). Для выключения опции рекомендуется ставить параметр "NO".

Примечание: в данном случае значения параметров "YES", "Yes" и "yes" - разные, используйте только "YES" чтобы опция вступила в силу.

Наверх
Использовать прокрутку для меню "Программы"

Если прокрутка включена, то меню все программы будет в один столбец и для навигации по нему необходимо подвести курсор мыши к краю экрана. Иначе при большом количестве установленных программ может появиться два и более столбцов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuScrollPrograms, значение "YES" - прокрутка меню используется

Наверх
Использовать сокращенные меню

Если опция включена, то сначала появляется меню, содержащее часто используемые пункты меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD IntelliMenus, значение 1 - использовать сокращенные меню, 0 - не использовать

Наверх
Мелкие значки в главном меню

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD Start_LargeIcons, если параметр существует - используются большие иконки (Windows XP в качестве значения параметра использует 1), удалите параметр, чтобы использовать маленькие значки

Наверх
Отображать команду "Выполнить"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuRun, значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать команду "Завершение сеанса"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuLogoff, значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Отображать меню "Администрирование"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING StartMenuAdminTools, значение "YES" - отображать пункт меню

Наверх
Отображать папку "Избранное"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuFavorites, значение 1 - отображать пункт меню, 0 - не отображать

Наверх
Разрешить перетаскивание объектов

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

DWORD StartMenuChange, значение 1 - разрешить перетаскивание

Наверх
Раскрывать "Панель управления"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeControlPanel, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои документы"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyDocuments, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Мои рисунки"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeMyPictures, значение "YES" - раскрывать меню

Наверх
Раскрывать папку "Принтеры"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadePrinters, значение "YES" - раскрывать меню

Наверх
Раскрывать "Сетевые подключения"

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced

STRING CascadeNetworkConnections, значение "YES" - раскрывать меню

Наверх

Задержка выпадения меню *

Задержка выпадения меню *

Влияет на скорость показа меню Пуск и скорость выделения объектов в проводнике, если используется одинарный щелчок. По умолчанию задержка равна 400 миллисекунд. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Control Panel\Desktop

STRING MenuShowDelay, значение в миллисекундах, например "400". Обратите внимание, параметр имеет строковое значение, а не DWORD.

Примечание: в Windows 2003 Server значение "0" приводит к высокой нагрузке процессора при обращении к меню. XP Tweaker использует значение "1" вместо "0".

Наверх


Решение проблем

XP Tweaker - Решение проблем
Содержание

Шрифты

Использовать кодовую страницу 1251 вместо 1252

Переключение на русскую раскладку в DOS-приложениях *

Зависшие приложения

Интервал, по истечении которого не отвечающее приложение считается зависшим

Завершать зависшее приложение

Завершать зависший сервис

Автоматически завершать зависшие приложения

Проверка файлов

Проверка файлов

Путь к папке временных файлов

Путь к папке временных файлов

AVI файлы

Корректное удаление avi файлов

Шрифты

Использовать кодовую страницу 1251 вместо 1252

Данная опция решает проблемы с отображением русских шрифтов в некоторых программах. XP Tweaker меняет два параметра "1250" и "1252". В некоторых редких случаях можно исправить другие параметры.

HKLM\SYSTEM\CurrentControlSet\Control\Nls\CodePage

STRING 1250, значение "c_1251.nls" - опция включена, "c_1250.nls" - выключена
STRING 1252, значение "c_1251.nls" - опция включена, "c_1252.nls" - выключена

Наверх
Переключение на русскую раскладку в DOS-приложениях *

В некоторых DOS-программах невозможно переключить раскладку на русский язык, данная опция поможет вам решить эту проблему. Переключение на русскую раскладку происходит по нажатию Ctrl+Right Shift, на английскую - Ctrl+Left Shift. Чтобы изменения вступили в силу необходимо перезагрузиться.

HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\DosKeybCodes

STRING 00000409, "ru" - опция включена, "us" - выключена

Если опция включена, то XP Tweaker также добавляет строку

"lh %SystemRoot%\system32\kb16.com ru" в %SYSTEMROOT%\SYSTEM32\autoexec.nt, если выключена, удаляет её.

Примечание: при загрузке XP Tweaker для проверки включена опция или нет, использует только параметр STRING 00000409 (т.е. не ищет строку в autoexec.nt). При записи в autoexec.nt XP Tweaker сначала проверит, существует ли там строка "lh %SystemRoot%\system32\kb16.com ru" и если она уже существует, то запись в файл не производится.

Наверх

Зависшие приложения

Интервал, по истечении которого не отвечающее приложение считается зависшим:

По истечении этого времени Windows XP считает, что приложение зависло. По умолчанию значение равно 5 000 миллисекунд.

HKCU\Control Panel\Desktop

STRING HungAppTimeout, значение - время интервала в миллисекундах. XP Tweaker позволяет выставить значение в диапазоне от 1 до 20 секунд.

Ссылки по теме:

Windows 2000 Resourse Kits (HungAppTimeout)

Наверх
Завершать зависшее приложение

Интервал, в течение которого Windows XP ожидает, перед закрытием приложения. Меньшее значение ускоряет процесс завершения работы, но это может привести к тому, что будут закрываться не зависшие приложения. По умолчанию интервал равен 20 000.

HKCU\Control Panel\Desktop

STRING WaitToKillAppTimeout, значение - время интервала в миллисекундах. XP Tweaker позволяет выставить значения от 1 до 30 секунд

Ссылки по теме:

Windows 2000 Resourse Kits (WaitToKillAppTimeout)

Наверх
Завершать зависший сервис

Интервал, в течение которого Windows XP ожидает, перед закрытием зависшего сервиса. Меньшее значение ускоряет процесс завершения работы, но это может привести к тому, что будут закрываться не зависшие приложения. По умолчанию интервал равен 20 000.

HKCU\Control Panel\Desktop

STRING WaitToKillServiceTimeout, значение - время интервала в миллисекундах. XP Tweaker позволяет выставить значения от 1 до 60 секунд

Ссылки по теме:

Windows 2000 Resourse Kits (WaitToKillServiceTimeout)

Наверх
Автоматически завершать зависшие приложения

Эта опция используется для автоматического закрытия без всякого предупреждения всех зависших программ. Удобно при завершении работы компьютера, если приложение не отвечает, то не надо нажимать на кнопку, чтобы его завершить.

HKCU\Control Panel\Desktop

STRING AutoEndTasks, значение 1 - автоматически завершать зависшие приложения, 0 - ждать ввода пользователя

Наверх

Проверка файлов

Проверка файлов

Выполняет проверку и восстановление поврежденных системных файлов, возможно при этом потребуется компакт-диск с дистрибутивом Windows XP. XP Tweaker выполняет команду sfc.exe /scannow. Параметр /scannow - немедленная проверка без выдачи запроса, вы также можете использовать другие параметры, например, /scanonce - разовая проверка при следующей загрузке системы, для более подробной информации запустите в командной строке sfc без параметров. Если программа sfc находит, что защищенный файл был переопределен, подходящая версия файла восстанавливается из папки %SYSTEMROOT%\system32\dllcache или если таковой нет, с компакт-диска. Более подробную информацию о защите файлов Windows XP вы можете найти в справочной системе.

Наверх

Путь к папке временных файлов

Путь к папке временных файлов

Некоторые старые программы не поддерживают длинные пути с пробелами. Рекомендуется использовать путь в стиле DOS 8.3, например, с:\windows\temp. Также этот параметр можно настроить в Свойствах системы - Дополнительно, кнопка Переменные среды.

HKCU\Environment

EXPAND STRING TMP, значение - путь к папке временных файлов
EXPAND STRING TEMP, значение - путь к папке временных файлов

Наверх

AVI файлы

Корректное удаление avi файлов

В Windows XP часто возникают проблемы с удалением AVI файлов, система сообщает, что файл занят программой. С помощью данной опции можно устранить эту проблему.

Включение опции - XP Tweaker выполняет следующую команду:

regsvr32 /u %SystemRoot%\system32\shmedia.dll

Выключение опции (галочка снята)

regsvr32 %SystemRoot%\system32\shmedia.dll

Состояние опции программа проверяет с помощью содержимого ключа

HKLM\SOFTWARE\Classes\CLSID\{87D62D94-71B3-4b9a-9489-5FE6850DC73E}\InProcServer32

Примечание: При включении опции, вкладка "Сводка" в свойствах AVI файла будет отсутствовать. Не будет работать предварительный просмотр в Проводнике.

Наверх


Другое

XP Tweaker - Загрузка системы
Содержание

Вход в систему

Автоматический вход в систему без ввода пароля

Показывать сообщение при входе в систему

Не показывать имя последнего пользователя

Использовать страницу приветствия

Использовать быстрое переключение пользователей

Не показывать сообщения при запуске и выходе из системы

Показывать выполняемые команды при запуске и выходе из системы

Раскладка клавиатуры при входе в систему

Использовать Ctrl+Shift для переключения раскладки клавиатуры

Автозагрузка

Автозагрузка программ через реестр

Запретить автозапуск программ Local Machine Run

Запретить автозапуск программ Local Machine Run Once

Запретить автозапуск программ Current User Run

Запретить автозапуск программ Current User Run Once

Проверка диска

Изменить интервал запуска программы проверки диска (Scandisk)

Вход в систему

Автоматический вход в систему без ввода пароля

Позволяет автоматически входить в систему без выбора имени и ввода пароля. Также автоматический вход в систему можно включить следующим способом: Пуск - Выполнить - набрать "control userpasswords2", в появившемся окне снять галочку с "Требовать ввод имени и пароля", после нажатия на ОК появится окно, где нужно указать пользователя и пароль. Если автоматический вход включен, то его можно обойти, удерживая клавишу SHIFT при загрузке компьютера.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING AutoAdminLogon, принимает значение "1" - Автоматический вход включен, "0" - выключен. Обратите внимание, параметр имеет строковое значение, а не DWORD.

STRING DefaultUserName, имя пользователя, которое используется при автоматическом входе в систему
STRING DefaultUserPassword, пароль пользователя
STRING DefaultDomainName, домен по умолчанию, используется для компьютеров в сети
STRING ForceAutoLogon, включение принудительного автологина

Примечание: пароль храниться в реестре в незашифрованном виде.

При отключении автоматического входа в систему, XP Tweaker удаляет пароль из реестра.

Если опция сбрасывается после перезагрузки, создайте пароль для своей учетной записи (Панель управления - Учетные записи пользователей) или используйте апплет control userpasswords2 (см. выше)

Наверх
Показывать сообщение при входе в систему

Показывает сообщение перед вводом пароля для входа в систему. Чтобы войти в систему необходимо нажать на кнопку OK.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

STRING LegalNoticeCaption, заголовок окна
STRING LegalNoticeText, текст сообщения

Наверх
Не показывать имя последнего пользователя

Windows XP по умолчанию подставляет имя последнего пользователя использующего компьютер. Чтобы это отменить, используйте данную опцию.

HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD DontDisplayLastUserName, значение 1 - убрать имя пользователя

Наверх
Использовать страницу приветствия

Экран приветствия обеспечивает наиболее быстрый и простой вход в систему. Если опция выключена, используется классический вход в систему (более безопасно).

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

DWORD LogonType, значение 1 - используется страница приветствия, 0 - используется классический вход в систему

Примечание: опция не доступна для Windows Server 2003 (страница приветствия не используется)

Наверх
Использовать быстрое переключение пользователей

Если опция включена, то при переключении на другого пользователя, программы текущего пользователя будут продолжать работать. Иначе, программы будут автоматически выключатся, когда пользователь выходит из системы, и со следующим пользователем компьютер будет работать быстрее.

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

DWORD AllowMultipleTSSessions, значение 1 - использовать быстрое переключение пользователей

Наверх
Не показывать сообщения при запуске и выходе из системы

Убирает сообщения при запуске и выходе из системы (сохранение параметров, загрузка личных параметров, запуск Windows и т.д.)

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

DWORD DisableStatusMessages, значение 1 - Убрать сообщения

Наверх
Показывать выполняемые команды при запуске и выходе из системы

Показывает информацию о выполняемых процессах во время загрузки системы. Поможет быстро выяснить, на запуск чего система тратит много времени и если возможно, отключить не нужные сервисы.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System

DWORD verbosestatus, значение 1 - показывать, 0 - стандартная загрузка

Наверх
Раскладка клавиатуры при входе в систему

Windows XP дает возможность задать раскладку клавиатуры "по умолчанию" только при установке системы. С помощью данной опции можно изменить раскладку клавиатуры. XP Tweaker поддерживает до трех раскладок клавиатуры.

HKU\.DEFAULT\Keyboard Layout\Preload

STRING "1" - первая раскладка, "2" - вторая раскладка и т.д.

например:

STRING "1" = "00000409" - английская раскладка клавиатуры (она будет использоваться по умолчанию)

STRING "2" = "00000419" - русская раскладка клавиатуры

STRING "3" = "00000422" - украинская раскладка клавиатуры

Примечание: чтобы запретить переключение на другие раскладки, удалите все значения кроме "1". При удалении всех значений используется английский язык (тестировалось на Win XP Pro rus)

P.S. Опция применяет раскладку пользователю при входе в систему (т.н. default user). После входа в систему раскладкой по умолчанию стает раскладка, заданная пользователем в Панели управления.

Наверх
Использовать Ctrl+Shift для переключения раскладки клавиатуры

Windows XP дает возможность задать клавиши для переключения раскладки клавиатуры "по умолчанию" только при установке системы. С помощью данной опции можно изменить клавиши переключения раскладки.

HKU\.DEFAULT\Keyboard Layout\Toggle

STRING Hotkey - значение "1" - используется комбинация клавиш Alt+Shift (по умолчанию), "2" - используются клавиши Ctrl+Shift

P.S. Опция задает клавиши переключения раскладки пользователю при входе в систему (т.н. default user). После входа в систему клавиши переключения задаются пользователем в Панели управления.

Наверх

Автозагрузка

Автозагрузка программ через реестр

В этом разделе, вы можете удалить из реестра информацию об автоматически загружаемых программах при старте системы.

Список автоматически загружаемых программ разделен на два раздела:
программы, запускаемые только для текущего пользователя

HKCU\Software\Microsoft\Windows\CurrentVersion\Run

и программы, запускаемые для всех пользователей

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

Примечание: внизу списка автозагружаемых программ есть ссылка, в которой указан полный путь к программе. Щелкнув по ней, вы откроете папку, в которой находится эта программа.

Наверх
Запретить автозапуск программ Local Machine Run

Программы, запускаемые для всех пользователей компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DWORD DisableLocalMachineRun, значение 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Local Machine Run Once

Программы, запускаемые для всех пользователей компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DWORD DisableLocalMachineRunOnce, значение 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run

Программы, запускаемые для текущего пользователя компьютера.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DWORD DisableCurrentUserRun, значение 1 отключает автозапуск программ

Наверх
Запретить автозапуск программ Current User Run Once

Программы, запускаемые для текущего пользователя компьютера один раз.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer

DWORD DisableCurrentUserRunOnce, значение 1 отключает автозапуск программ

Наверх

Проверка диска

Изменить интервал запуска программы проверки диска (Scandisk)

С помощью данной опции можно изменить интервал перед запуском программы проверки диска при неправильном завершении работы системы. По умолчанию значение в реестре отсутствует и WinXP в этом случае использует интервал равный 10 секундам. Значение равное 0, не дает пользователю отменить запуск Scandisk'a при неправильном завершении работы.

Также данное значение можно изменить, используя программу chkntfs (не смотря на название, она также годиться и для FAT32)

chkntfs /t:n, где n - интервал в секундах.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager

DWORD AutoChkTimeOut, значение - интервал задержки в секундах

Чтобы отключить Scandisk, необходимо изменить следующий параметр:

MULTI STRING BootExecute, присвоив ему значение "", чтобы восстановить Scandisk установите значение "autocheck autochk *"

Примечание: Scandisk запускаемый под Windows исправляет не все ошибки на загрузочном томе (а точнее на томах которые не может заблокировать), поэтому не стоит его отключать. Если Scandisk отключен, но требуется полная проверка диска (с отключением тома), то наберите в командной строке следующее: "chkdsk c: /x" программа не может заблокировать текущий диск, и спросит, нужно ли его проверить при следующей загрузке компьютера (вместо с: подставьте необходимый диск).

Наверх


Windows Media Player

XP Tweaker - Windows Media Player
Включить MP3 кодирование

Включение встроенного кодека для копирования музыки с компакт диска в формате *.mp3 (MPEG-1 Layer 3)

HKLM\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding

Максимальный битрейт:
DWORD HighRate, XP Tweaker выставляет значение 192000, что равно 192 Кбит, хотя, скорее всего вам удастся кодировать с максимальным битрейтом 128 Кбит.

Минимальный битрейт:
DWORD LowRate, XP Tweaker выставляет значение 56000, что равно 56 Кбит

Средний-высокий битрейт
DWORD MediumHighRate, XP Tweaker выставляет значение 128000, что равно 128 Кбит - оптимальное значение

Средний битрейт
DWORD MediumRate, XP Tweaker выставляет значение 64000, что равно 64 Кбит

Если опция выключена, XPTweaker удаляет ключ HKLM\SOFTWARE\Microsoft\MediaPlayer\Settings\MP3Encoding полностью, при загрузке проверяется, существует ли данный ключ, если да, то опция включена.
Автоматически загружать кодеки из Интернета

Если на компьютере нет необходимого видео или аудио кодека, то Windows Media Player попытается найти его в Интернете и затем загрузить его. Если опция выключена, Media Player сначала спросит, загрузить кодек или нет, а если включена, кодек будет загружен и установлен без выдачи сообщения.

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

DWORD UpgradeCodecPrompt, значение 1 - выдавать сообщение перед загрузкой кодека, 0 - загружать автоматически

Примечание: WMP8 использует однобайтовый двоичный тип данных (hex:00 или hex:01), но вполне корректно работает с dword.

Автоматические обновления

HKCU\SOFTWARE\Microsoft\MediaPlayer\Preferences

DWORD UpgradeCheckFrequency, может принимать следующие значения:

    • 0 - Один раз день
    • 1 - Один раз в неделю
    • 2 - Один раз в месяц

Примечание: WMP8 использует двоичный тип данных, но вполне корректно работает с dword. (соответственно hex:00,00,00,00, hex:01,00,00,00, hex:02,00,00,00)


Компакт-диски

XP Tweaker - Компакт-диски
Отключить автозапуск компакт дисков

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom

DWORD AutoRun, значение 0 - автозапуск отключен, 1 - включен
Отключить встроенные средства WinXP для записи компакт-дисков

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoCDBurning, значение 1 - отключить


Система

XP Tweaker - Защита системы
Запретить вызов диспетчера задач

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD DisableTaskMgr, значение 1 - запрещает вызов диспетчера задач
Запретить редактирование реестра

Данная опция не запрещает полностью редактирование реестра, а только не дает запустить regedit.exe, другие программы редактирующие реестр игнорируют этот параметр. Вы можете запретить редактирование реестра, выставив права определенным пользователю или группам пользователей.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD DisableRegistryTools, значение 1 - запрещает вызов редактора реестра
Запретить завершения сеанса *

Запрещает завершение сеанса (logout). Необходимо перезагрузить компьютер, чтобы изменения вступили в силу.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoLogOff, значение 1 - запрещает завершение сеанса
Запретить завершение работы и убрать кнопку из меню Пуск *

Запрещает завершение работы компьютера(logoff) стандартными методами, специальные программы при этом могут завершать работу системы. Кнопка из меню пуск уберется/появится только после перезагрузки.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoClose, значение 1 - запрещает завершение работы компьютера
Запретить запуск апплетов в Панели управления

Запрещает запуск всех апплетов в Панели управления. Также запрещает вызов апплетов из Windows и запуск *.cpl файлов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoControlPanel, значение 1 - запрещает запуск апплетов в Панели управления
Запретить изменение свойств Экрана

Запрещает запуск апплета настройки экрана (настройка тем, обоев, разрешения экрана и др.)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD NoDispCPL, значение 1 - запрещает изменение свойств экрана
Командная строка

HKCU\Software\Policies\Microsoft\Windows\System

DWORD DisableCMD, значения:

0 - Разрешить использование командной строки
1 - Запретить использование командной строки
2 - Разрешить только запуск командных файлов

Сетевая безопасность

Полностью отключить общие ресурсы (ADMIN$, C$ и т.д.) *

Эти ресурсы доступны Администратору, для отключения/включения требуется перезагрузка. Windows XP позволяет отключить эти ресурсы, но только до перезагрузки.

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

DWORD AutoShareWks, значение 0 - общие ресурсы отключены, 1 - включены

Примечание: данное изменение реестра не отключит IPC$, чтобы его отключить наберите в командной строке:

net share ipc$ /delete

(работает только до перезагрузки)

Примечание: вWindows Server 2003 используется другой параметр:

DWORD AutoShareServer, значение 0 - общие ресурсы отключены, 1 - включены
Запретить анонимным пользователям просматривать ресурсы

Запрещает анонимным пользователям просматривать учетные записи и расшаренные ресурсы.

HKLM\System\CurrentControlSet\Control\Lsa

DWORD RestrictAnonymous, значение 1 - запретить, 0 - разрешить


Принтеры

XP Tweaker - Принтеры
Запретить установку новых принтеров

Запрещает добавление в системы новых принтеров, факсов.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoAddPrinter, значение 1 - запретить установку новых принтеров
Запретить удаление принтеров

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoDeletePrinter, значение 1 - запретить удаление принтеров и факсов


Проводник

XP Tweaker - Защита проводника
Содержание

Защита проводника

Сделать недоступным контекстное меню Проводника *

Запретить настройку панели инструментов (включая Internet Explorer) *

Удалить меню Файл *

Удалить кнопку Поиск с панели инструментов *

Использовать классический вид Проводника *

Запретить доступ к дискам

Запретить доступ к дискам *

Скрыть диски в проводнике

Скрыть диски в проводнике *
Сделать недоступным контекстное меню Проводника *

При щелчке правой кнопкой мыши, а также при нажатии Shift + F10 контекстное меню проводника не будет появляться. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoViewContextMenu, значение 1 - запрещает появление меню

Наверх
Запретить настройку панели инструментов (включая Internet Explorer) *

Запрет на изменение панели инструментов проводника. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoToolbarCustomize, значение 1 - запрещает изменение панели инструментов

Наверх
Удалить меню Файл *

Удаляет меню Файл из проводника. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoFileMenu, значение 1 - удаляет меню

Наверх
Удалить кнопку Поиск с панели инструментов *

Удаляет кнопку Поиск с панели инструментов, но F3 продолжает действовать. Чтобы изменения вступили в силу, необходимо перезагрузиться.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoShellSearchButton, значение 1 - удаляет кнопку Поиск

Наверх
Использовать классический вид Проводника *

Запрещает использовать веб вид папок, отображающий список типичных задач.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD ClassicShell, значение 1 - использовать классический вид

Наверх

Запретить доступ к дискам

Запретить доступ к дискам *

Запрещает доступ к просмотру содержимого дисков через Проводник (запуск программ разрешен)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoViewOnDrive, значение сумма "значений дисков". Значение 0 - разрешен доступ ко всем дискам, значение 67108863 (hex:3ffffff) - запретить доступ ко всем дискам (A: - Z:)

Значения дисков:

A: - 1 (2^0)
B: - 2 (2^1)
C: - 4 (2^2)
D: - 8 (2^3)
...
Z:- 33554432 (2^25)

Чтобы запретить доступ к дискам A и D необходимо сложить 1 + 8 = 9.

Наверх

Скрыть диски в проводнике

Скрыть диски в проводнике *

Скрывают диски в Проводнике. (В других файл-менеджерах диски будут отображаться)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoDrives, значение рассчитывается точно также как и для запрета доступа к дискам (см. выше)

Наверх


XP Tweaker - Защита меню Пуск и Панели задач
Содержание

Меню Пуск

Сделать недоступными свойства Панели задач и меню Пуск *

Запретить модификацию меню Пуск

Запретить переключать меню в стиль XP *

Запретить пункт меню Поиск *

Запретить пункт меню Выполнить *

Запретить пункт меню Справка и поддержка *

Запретить пункт меню Все программы (Стиль ХР) *

Запретить пункт меню Недавние документы *

Настройка меню классического типа

Запретить пункты меню Настройка

Панель задач

Запретить контекстное меню Панели задач

Меню Пуск

Сделать недоступными свойства Панели задач и меню Пуск *

Запрещает изменение и настройку Панели задач. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoSetTaskbar, значение 1 - свойства Панели задачи меню Пуск не доступны

Наверх
Запретить модификацию меню Пуск

Запрещает добавление и удаление новых пунктов в меню Пуск.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoChangeStartMenu, значение 1 - запрещает модификацию меню Пуск

Наверх
Запретить переключать меню в стиль XP *

Прежде чем применить опцию, необходимо переключиться на классический вид меню. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoSimpleStartMenu, значение 1 - запрещает переключать меню Пуск в стиль XP

Наверх
Запретить пункт меню Поиск *

Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoFind, значение 1 - убирает пункт меню Поиск

Наверх
Запретить пункт меню Выполнить *

Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoRun, значение 1 - убирает пункт меню Выполнить

Наверх
Запретить пункт меню Справка и поддержка *

Запретить доступ к справочной информации, обновлении, восстановлению системы и т.д. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoSMHelp, значение 1 - убирает пункт меню Справка и поддержка

Наверх
Запретить пункт меню Все программы (Стиль ХР) *

Убирает подменю Все программы из меню Пуск. Требуется перезагрузка.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoStartMenuMorePrograms, значение 1 - убирает подменю Все программы

Наверх
Запретить пункт меню Недавние документы *

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoRecentDocsMenu, значение 1 - убирает пункт меню Недавние документы

Наверх

Настройка меню классического типа

Запретить пункты меню Настройка

Данная настройка относится к меню классического вида и не влияет на вид меню в стиле XP . Данная опция убирает пункты "Панель управления", "Сетевые подключения", "Принтеры и факсы" из меню Настройка. Возможность настроить меню Пуск остается.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoSetFolders, значение 1 - запрещает пункты меню настройка.

Наверх

Панель задач

Запретить контекстное меню Панели задач

Запрещает контекстное меню Панели задач (контекстное меню программ, значки которых находятся в системном трее - доступно)

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoTrayContextMenu, значение 1 - запрещает контекстное меню.

Наверх


Internet Explorer

XP Tweaker - Защита Internet Explorer
Запретить доступ к свойствам Internet Explorer

Полностью запрещает доступ к настройкам Internet Explorer. Если данная опция включена, опции ниже игнорируются.

HKCU\Software\Policies\Microsoft\Internet Explorer\Restrictions

DWORD NoBrowserOptions, значение 1 - доступ к настройкам запрещен
Скрыть вкладку "Общие" в свойствах обозревателя

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD GeneralTab, значение 1 - скрыть вкладку
Скрыть вкладку "Безопасность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD SecurityTab, значение 1 - скрыть вкладку
Скрыть вкладку "Конфиденциальность"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD PrivacyTab, значение 1 - скрыть вкладку
Скрыть вкладку "Содержание"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD ContentTab, значение 1 - скрыть вкладку
Скрыть вкладку "Подключения"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD ConnectionsTab, значение 1 - скрыть вкладку
Скрыть вкладку "Программы"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD ProgramsTab, значение 1 - скрыть вкладку
Скрыть вкладку "Дополнительно"

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD AdvancedTab, значение 1 - скрыть вкладку
Запретить изменения на вкладке "Дополнительно"

Вкладка "Дополнительно" доступна, но изменить на ней ничего нельзя.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD Advanced, значение 1 - запретить изменения
Запретить доступ к настройке параметров временных файлов

Свойства обозревателя - вкладка Общие - раздел Временные файлы Интернета, становится недоступным.

HKCU\Software\Policies\Microsoft\Internet Explorer\Control Panel

DWORD Settings, значение 1 - запретить доступ к настройке параметров


Настройка Рабочего стола

XP Tweaker - Настройка Рабочего стола
Версия Windows на Рабочем столе *

Выводит версию Windows в правом нижнем углу Рабочего стола

HKCU\Control Panel\Desktop

DWORD PaintDesktopVersion, значение 1 - выводить версию Windows на Рабочий стол, 0 - не выводить.

Запретить рабочий стол *

Скрывает иконки с рабочего стола и делает не доступным контекстное меню.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoDesktop, значение 1 - запрещает рабочий стол
Запретить Active Desktop

Запрещает установку рабочего стола в виде веб-страницы.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

DWORD NoActiveDesktop, значение 1 - запрещает Active Desktop
Скрыть вкладки "Тема" и "Оформление" в свойствах экрана

Запретить изменение тем и оформления окон Windows XP

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD NoDispAppearancePage, значение 1 - скрыть вкладки
Скрыть вкладку "Рабочий стол"

Скрывает вкладку Рабочий стол в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD NoDispBackgroundPage, значение 1 - скрыть вкладку
Скрыть вкладку "Заставка"

Скрывает вкладку Заставка в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD NoDispScrSavPage, значение 1 - скрыть вкладку
Скрыть вкладку "Параметры"

Скрывает вкладку Параметры в свойствах экрана

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System

DWORD NoDispSettingsPage, значение 1 - скрыть вкладку


Корзина

XP Tweaker - Корзина
Название корзины

Изменяет имя корзины. Обновите рабочий стол, чтобы изменения вступили в силу.

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}

STRING по умолчанию, значение - имя корзины
STRING LocalizedString, значение - имя корзины
Добавить значок корзины в Мой компьютер

Добавляет значок корзины в Мой компьютер. Обновите Проводник (нажмите F5), чтобы изменения вступили в силу.

В разделе
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\NameSpace, необходимо создать ключ {645FF040-5081-101B-9F08-00AA002F954E}, чтобы удалить значок корзины - удалите ключ

Контекстное меню корзины

Удаление и добавление новых пунктов в контекстное меню корзины.

Для удаления пункта меню, удалите соответствующий ключ в разделе:

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell

Чтобы добавить новое меню, создайте новый ключ. Значение STRING по умолчанию - название пункта меню. Далее создайте подключ Command, значение STRING по умолчанию которого - исполняемая строка.

Пример добавления блокнота в контекстное меню программы:

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell\MyNotepad

STRING по умолчанию = "Блокнот"

HKEY_CLASSES_ROOT\CLSID\{645FF040-5081-101B-9F08-00AA002F954E}\Shell\MyNotepad

STRING по умолчанию = "notepad.exe" (или полный путь "c:\windows\notepad.exe", измените его, если каталог Windows отличается от приведенного)


Иконки

XP Tweaker - Выбор иконок на Рабочем столе
Скрытие/Добавление иконок на Рабочем столе

Для скрытия/добавления иконок на рабочем столе, используется следующий раздел реестра:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ ClassicStartMenu

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\HideDesktopIcons\ NewStartPanel

DWORD {208D2C60-3AEA-1069-A2D7-08002B30309D}, значение 1 - скрыть значок Сетевое окружение, 0 - показывать на рабочем столе

DWORD {871C5380-42A0-1069-A2EA-08002B30309D}, значение 1 - скрыть значок Internet Explorer, 0 - показывать на рабочем столе

DWORD {20D04FE0-3AEA-1069-A2D8-08002B30309D}, значение 1 - скрыть значок Мой компьютер, 0 - показывать на рабочем столе

DWORD {645FF040-5081-101B-9F08-00AA002F954E}, значение 1 - скрыть значок Корзины, 0 - показывать на рабочем столе

Примечание: если параметр не существует, значок Корзины показывается

DWORD {450D8FBA-AD25-11D0-98A8-0800361B1103}, значение 1 - скрыть значок Мои документы, 0 - показывать на рабочем столе


Настройка соединения

XP Tweaker - Настройка соединения
Максимальный размер передаваемого блока данных (Maximum Transmission Unit)

Определяет самое большое количество данных, которые могут быть переданы по сети в одном физическом фрейме. Если пакет IP большего размера чем MTU, то произойдет фрагментация, что может увеличить время, которое требуется, чтобы послать единственный пакет.

По-умолчанию Windows XP использует значение 1500.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD MTU, значение - размер блока в байтах

Рекомендуемые значения:

Для модема: 576

Для DSL, кабельных модемов, T1 и выше: 1500

Полную информацию по настройке протокола TCP/IP для Win2k3 можно получить на сайте Майкрософт

http://www.microsoft.com/technet/prodtechnol/windowsserver2003/plan/TCPIP03.asp?frame=true (english)

Максимальный размер окна для приёма TCP пакетов (RWIN)

Рекомендуется изменять опцию только опытным пользователям. Под NT-системами значение RWIN является динамическим.

Количество байт, которые отправитель может передать, не получая подтверждения.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD TCPWindowSize, значение - размер в байтах

XP Tweaker расчитывает значение следующим образом:

(Размер MTU - 40 байт заголовка TCP/IP) * множитель

Множитель может принимать значения от 2 - 10.

Автоматически определять MTU

Автоматически определять максимальный размер передаваемого блока данных.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD EnablePMTUDiscovery, значение 1 - определять MTU автоматически
Включить поддержку TCP окон больше 64Кб

Рекомендуется для сетей с большой пропускной способностью.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD Tcp1323Opts, значение 1 - поддержка включена
Максимальное время жизни пакета IP (Time to Live)

TTL определяет максимальное время, которое пакет IP может прожить в сети, не достигая адресата. Другими словами: использование этой опции определяет, как долго компьютер будет ждать, прежде чем решит, что запрашиваемый вебсайт не найден. Для плохих соединений имеет смысл увеличить данное значение.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD DefaultTTL, значение - время жизни пакета.
Выборочная передача поврежденных данных

Данная опция включает поддержку Selective Acknowledgement (SACK). Если пакет или ряд пакетов TCP потеряны, то получатель может сообщить отправителю, какие данные были получены, а какие нет.

HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

DWORD SackOpts, значение 1 - поддержка выборочной передачи включена


Internet Explorer

XP Tweaker - Internet Explorer
Автоматически подгонять размеры рисунка

Internet Explorer автоматически подгоняет рисунки так, чтобы они полностью умещались на экране и полосы прокрутки не появлялись. При необходимости можно отключить данную возможность.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Enable AutoImageResize, значение "yes" - автоматическое изменение размера изображений включено
Запретить автоматические обновления IE

HKCU\Software\Microsoft\Internet Explorer\Main

DWORD NoUpdateCheck, значение 1 - запрещает автоматические обновления
Скрывать редко используемые пункты в Избранном

В меню показываются только часто вызываемые пункты меню, для доступа к редко вызываемым пунктам, необходимо нажать на специальную стрелочку. Чтобы изменения вступили в силу, необходимо перезапустить Internet Explorer

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FavIntelliMenus, значение "yes" - скрывать редко используемые пункты
Удалить пароль на ограничение доступа к сайтам

Удаляет пароль на ограничение доступа к сайтам по содержанию. Данный пароль можно установить в Свойствах обозревателя, вкладка Содержание, раздел Ограничение доступа.

HKLM\Software\Microsoft\Windows\CurrentVersion\policies\Ratings

BINARY Key, значение - зашифрованный пароль и параметры ограничения. Удалите параметр, если хотите удалить пароль
Не выводить окно "Подключение удаленного доступа" при автономной работе

Internet Explorer при автономной работе выводит окно "Подключение удаленного доступа" если информация не доступна локально. В большинстве случаев это не важная информация (рекламные баннеры) и подключаться к Интернету нет необходимости. На больших страницах Internet Explorer может выдать окно несколько раз, прежде чем полностью отобразит информацию. С помощью данной опции можно запретить IE выводить окно подключения.

HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings

DWORD EnableAutodial, значение 1 - разрешить вывод окна, 0 - запретить
Открывать ярлыки в новом окне IE

Internet Explorer при открытии ссылки заменяет содержимое последнего открытого окна, с помощью данной опции можно настроить IE так, чтобы ярлыки открывались в новом окне. (Требуется перезапуск Internet Explorer).

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

DWORD AllowWindowReuse, значение 1 - открывать в последнем открытом окне, 0 - открывать в новом окне
Запретить фоновые звуки

Опция запрещает Internet Explorer проигрывать фоновые звуки на web-страницах.

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main

STRING Play_Background_Sounds, значение "yes" - разрешить проигрывать фоновые звуки, "no" - запретить
Путь к папке закачек по умолчанию

Данная папка будет всегда появляться первой для сохранения загружаемых файлов.

HKCU\Software\Microsoft\Internet Explorer

STRING Download Directory, значение путь к папке закачек
Редактор для просмотра исходного кода HTML страниц

Редактор, вызываемый через пункт меню Вид -> Просмотр HTML- кода.

HKLM\SOFTWARE\Microsoft\Internet Explorer\View Source Editor\Editor Name

STRING по умолчанию путь к редактору.
Поиск из панели адресов

Параметр влияет на поведение Internet Explorer, если он не находит страницу.

HKCU\Software\Microsoft\Internet Explorer\Main

DWORD AutoSearch, Internet Explorer 6.0 использует следующие значения:

0 - Не выполнять поиск из адресной строки
6 - Показать результаты и перейти на самый похожий узел
5 - Только перейти на самый похожий узел
4 - Только показать результаты в главном окне

Использовать автозаполнение для

Веб-адресов

Включить/выключить автозаполнение в строке адреса.

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete

STRING AutoSuggest, значение "yes" - автозаполнение веб-адресов используется
Автозаполнение форм

Включить/отключить автозаполнение форм. Internet Explorer выводит подсказки, в которых можно выбрать ранее введенные данные.

HKCU\Software\Microsoft\Internet Explorer\Main

STRING Use FormSuggest, значение "yes" - автозаполнение форм используется
Автозаполнение имен пользователей и паролей в формах

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest Passwords, значение "yes" - автозаполнение имен пользователей и паролей в формах используется
Запрос на сохранение пароля

HKCU\Software\Microsoft\Internet Explorer\Main

STRING FormSuggest PW Ask, значение "yes" - Internet Explorer выводит окно с сообщением сохранять пароль или нет


Локальные сети

XP Tweaker - Локальные сети
Не сканировать сеть на наличие сетевых принтеров

Windows XP по умолчанию каждый раз сканирует сеть на наличие сетевых принтеров и назначенных заданий. С помощью данной опции можно отключить данную возможность, тем самым, повысив доступ к компьютерам в сети.

При включении опции XP Tweaker удаляет ключ:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\ NameSpace\{2227A280-3AEA-1069-A2DE-08002B30309D}

при отключении опции восстанавливает его.
Не сканировать сеть на наличие назначенных заданий (Scheduled Tasks)

Описание см. выше. Используется следующий ключ:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\RemoteComputer\ NameSpace\{D6277990-4C6A-11CF-8D87-00AA0060F5BF}


Раздел Uninstall

XP Tweaker - Информация об установленных программах
Список установленных программ

Вся информация для удаления программы храниться в следующем разделе реестра:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

Информация о каждой программе храниться в отдельном разделе. В каждом разделе обязательно должны присутствовать два параметра:

STRING DisplayName, значение - имя, которое отображается в списке удаляемых программ

STRING UninstallString, значение - путь к программе удаления

также могут присутствовать другие пункты, их обычно добавляют современные инсталляторы:

STRING DisplayIcon - иконка, соответствующая приложению в диалоге "Установка и удаление программ"
STRING ModifyPath - Путь инсталлятора для изменения установочных параметров программы. Еcли этот ключ установлен, то Кнопка "Заменить/Удалить" распадается на две - "Заменить" (выполняется ModifyPath) и "Удалить" (выполняется UninstallString)

Следующие параметры относятся к диалоговому окну Поддержка

STRING Publisher - Издатель продукта
STRING Readme - Путь к файлу Readme для данного продукта
STRING Comments - Комментарии к продукту
STRING Contact - Контактное лицо (e-mail и т.п.)
STRING DisplayVersion - Номер версии
STRING ProductID - Код продукта
STRING RegCompany - Зарегистрированная компания
STRING RegOwner - Зарегистрированный владелец
STRING URLInfoAbout - Домашняя страничка производителя (параметр Publisher становится ссылкой)
STRING URLUpdateInfo - URL обновления продукта
STRING HelpLink - URL сведений о поддержке

Кнопка Изменить позволяет изменить строку, которая используется для удаления программы.

Кнопка Удалить из реестра, удаляет информацию о программе из раздела Uninstall. Это может понадобиться, если Вы удалили программу, не используя специальную программу для удаления. Windows XP иногда сама может удалить эту информацию (предварительно спросив Вас об этом), но далеко не всегда.

Кнопка Uninstall удаляет выделенную в списке программу.

Кнопка Обновить, обновляет список установленных программ, она может понадобиться после удаления программы, используя кнопку Uninstall


Параметры защиты

XP Tweaker - Параметры защиты
Запретить установку и удаление программ

Запрет запуска апплета "Установка и удаление программ".

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoAddRemovePrograms, значение 1 - запрещает запуск апплета Установка и удаление программ
Cкрыть вкладку Изменение или удаление программ

Данный параметр скрывает вкладку "Изменение или удаление программ" в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoRemovePage, значение 1 - скрыть вкладку
Скрыть вкладку Установка программ

Скрывает вкладку Установка программ в апплете Установка и удаление программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoAddPage, значение 1 - скрыть вкладку
Скрыть вкладку Установка компонентов Windows

Скрывает вкладку Установка компонентов Windows.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoWindowsSetupPage, значение 1 - скрыть вкладку
Скрыть раздел Установка программы с CD-ROM или дискеты

Скрывает раздел Установка программы с CD-ROM или дискеты и кнопку CD или дискета на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoAddFromCDorFloppy, значение 1 - скрыть вкладку
Скрыть раздел Установка программ от Майкрософт

Скрывает раздел Установка программы от Майкрософт и кнопку Windows Update на вкладке Установка программ.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoAddFromInternet, значение 1 - скрыть вкладку
Скрыть раздел Установка программ из сети

Скрывает раздел Установка программ из сети.

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoAddFromNetwork, значение 1 - скрыть вкладку
Скрыть сведения о поддержке

Скрывает ссылку Сведенья о поддержке

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Uninstall

DWORD NoSupportInfo, значение 1 - скрыть сведенья о поддержке


XP Tweaker - MSN Messenger

MSN Messenger

Удалить встроенный Windows Messenger

Данная опция относится только к встроенному Windows Messenger, если вы ставили более новую версию, то для ее удаления используйте "Установку и удаление программ" в Панели управления. При открытии Outlook запускает встроенную версию Windows Messenger, даже если установлена более новая версия, используйте данную опцию чтобы удалить встроенный Windows Messenger из системы.

Если опция включена, XP Tweaker изменяет следующие параметры в реестре:

HKLM\SOFTWARE\Policies\Microsoft\Messenger\Client

DWORD PreventAutoRun, значение 1 - запрет автоматического запуска
DWORD PreventAutoUpdate, значение 1 - запрет обновлений
DWORD PreventBackgroundDownload, значение 1 - запрет загрузки файлов
DWORD PreventRun, значение 1 - запрет запуска

Данные значения никак не влияют на удаление, а само удаление происходит так:

XP Tweaker выполняет команду rundll32 advpack.dll,LaunchINFSection %SYSTEMROOT%\inf\msmsgs.inf,BLC.Remove

Примечание: При запуске, XP Tweaker читает значение DWORD PreventRun, если оно равно 1, то считается, что Windows Messenger уже удален и опция становиться не доступной.

Опция не доступна для Windows Server 2003 (нет Windows Messenger)


XP Tweaker - Утилиты Windows XP
Содержание

Утилиты Windows XP

Примечание

Локальные параметры безопасности

Групповая политика (администрирование системы)

Производительность системы

Локальные пользователи и группы

Управление компьютером

Диспетчер устройств

Управление дисками

Журнал событий

Служба индексирования

Общие папки (расшаренные ресурсы)

Съемные ЗУ

Службы Windows XP

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Использовать свою программу очистки системы

Использовать свою программу для архивации данных

Утилиты Windows XP

Примечание

Чтобы запустить оснастку консоли наберите в окне Запуск программы (Пуск - Выполнить) название оснастки и нажмите ОК. Файлы оснастки консоли представляет собой текстовый файл, использующий язык XML. Для создания своих собственных оснасток используйте программу Консоль управления (Пуск - Выполнить - mmc.exe)

Наверх
Локальные параметры безопасности

Политика паролей, учетных записей пользователей, назначение прав пользователей, параметры безопасности и другое.

Оснастка консоли secpol.msc

Наверх
Групповая политика (администрирование системы)

Огромное количество параметров для настройки системы. С помощью данной консоли можно запретить доступ пользователя к отдельно взятым оснасткам консоли см. Конфигурация пользователя - Административные шаблоны - Компоненты Windows - Консоль управления Microsoft - Запрещенные или разрешенные оснастки, справа необходимо выбрать название оснастки и задать значение, запрещающее или разрешающее доступ. Если доступ запрещен, система выдаст сообщение:

Приведенная ниже оснастка, указанная в данном документе, ограничена политикой. Обратитесь к своему администратору за разъяснением.

Оснастка консоли gpedit.msc

Наверх
Производительность системы

Огромное количество счетчиков производительности компьютера (в т.ч. компьютера в сети) Загруженность процессора, памяти, кэша, логических дисков. Большое количество настроек и возможностей. Можно, например, узнать активность жесткого диска, его загруженность или отследить сколько байт занимает отдельно взятая программа в файле подкачки и т.д.

Оснастка консоли perfmon.msc

Наверх
Локальные пользователи и группы

Добавление новых пользователей в систему, создание новых групп пользователей, задание членства в группах для пользователей и настройка некоторых параметров.

Оснастка консоли lusrmgr.msc

Наверх
Управление компьютером

Оснастка включает в себя множество из описанных оснасток.

Оснастка консоли compmgmt.msc

Наверх
Диспетчер устройств

Управление всеми устройствами на компьютере.

Оснастка консоли devmgmt.msc

Наверх
Управление дисками

Управление разделами диска, форматирование, удаление, изменение буквы раздела.

Оснастка консоли diskmgmt.msc

Наверх
Журнал событий

Windows XP ведет журнал ошибок, предупреждений и уведомлений системы. С помощью данной оснастки можно просмотреть события, задать параметры журнала (например, размер файла) и очистить его.

Оснастка консоли eventvwr.msc

Наверх
Служба индексирования

Позволяет индексировать документы на компьютере для последующего быстрого их нахождения по содержанию. Более подробную справку вы можете получить, запустив оснастку консоли и выбрав пункт меню "Вызов справки".

Оснастка консоли ciadv.msc

Наверх
Общие папки (расшаренные ресурсы)

Создание и управление ресурсами доступными пользователям сети.

Оснастка консоли fsmgmt.msc

Наверх
Съемные ЗУ

Управление съемными носителями.

Оснастка консоли ntmsmgr.msc

Наверх
Службы Windows XP

Служба это приложение, автоматически запускаемое при старте системы или при необходимости. Для уменьшения времени загрузки системы и освобождения некоторого количества памяти можно отключить не нужные службы. Если Вы случайно изменили настройку службы и забыли параметры установленные по умолчанию, воспользуйтесь разделом справки Службы - Основные понятия - Стандартная настройка служб, здесь приведены настройки наиболее важных служб Windows XP.

Оснастка консоли services.msc

Наверх

Пути к системным утилитам

Использовать свою программу дефрагментации диска

Вы можете задать свою программу дефрагментации диска, она будет вызываться, если вы в свойствах диска, на вкладке Сервис нажмёте на кнопку "Выполнить дефрагментацию..."

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\DefragPath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%systemroot%\system32\dfrg.msc %c:"
С помощью параметра %с передается имя диска.

Наверх
Использовать свою программу очистки системы

По умолчанию Windows XP использует утилиту для очистки системы - CleanUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\cleanuppath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%SystemRoot%\system32\cleanmgr.exe /D %c"
С помощью параметра %с передается имя диска. Для CleanUp если не задан параметр /D, то параметр %с игнорируется и система предлагает пользователю выбрать диск самостоятельно.

Наверх
Использовать свою программу для архивации данных

По умолчанию Windows XP использует утилиту для архивации данных - BackUP, вы можете заменить её на свою.

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\ MyComputer\BackupPath

EXPAND STRING (По умолчанию), система использует следующую командную строку "%SystemRoot%\system32\ntbackup.exe"

Наверх


Системные папки

XP Tweaker - Системные папки
Системные папки

Информация о путях к системным папкам для активного пользователя хранится в следующих разделах:

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
здесь все значения имеют тип STRING

HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
здесь все значения имеют тип EXPAND STRING

STRING Cookies - Папка Cookies
STRING SendTo - Папка SendTo (Отправить)
STRING Start Menu - Главное меню
STRING History - Журнал
STRING Favorites - Избранное
STRING Cache - Папка Интернет кэша (Temporary Internet Files)
STRING Programs -Меню "Программы"
STRING Startup - Меню автозагрузка
STRING Personal - Мои документы
STRING My Pictures - Мои рисунки
STRING My Music - Моя музыка
STRING My Video - Мои видеозаписи
STRING Recent - Недавние документы
STRING Desktop - Рабочий стол
STRING Templates -Шаблоны

Временные файлы:

HKCU\Environment

EXPAND STRING TEMP
EXPAND STRING TMP

Пути к общим папкам хранятся в следующих разделах:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders
здесь все значения имеют тип STRING

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
здесь все значения имеют тип EXPAND STRING

STRING Common Desktop
STRING Common Favorites
STRING Common Start Menu
STRING Common Programs
STRING Common Startup


Регистрационные данные

XP Tweaker - Регистрационные данные
Изменение регистрационных данных

HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion

STRING RegisteredOwner, значение - имя зарегистрированного пользователя

STRING RegisteredOrganization, значение - название компании
OEM информация

Все данные хранятся в двух файлах: %SYSTEMROOT%\System32\oeminfo.ini и %SYSTEMROOT%\System32\oemlogo.bmp

В резделе [General] oeminfo.ini

STRING Manufacturer, значение - имя компании изготовителя (ОЕМ компания)

STRING Model, значение - ОЕМ модель

oemlogo.bmp содержит логотип компании в формате bmp 180х110


Приложения

XP Tweaker - Запрет запуска программ
Разрешить запуск приложений, кроме указанных в списке *

HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer

DWORD DisallowRun, значение 1 - запрещает запуск приложений указанных в списке:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisallowRun

Параметры типа STRING - список запрещенных приложений.

"1" - "program.exe"
"2" - "thebat.exe"
"3" - "icq.exe"
Запретить запуск приложений, кроме указанных в списке *

HKEY_CURRENT_USER\SOFTWARE\Microsoft\ Windows\CurrentVerson\Policies\Explorer

DWORD RestrictRun, значение 1 - запрещает запуск всех приложений, кроме системных и приложений указанных в списке:

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\RestrictRun

Параметры типа STRING - список разрешенных приложений.


Виртуальный диск

XP Tweaker - Виртуальный диск
Создание и удаление виртуального диска

Данная утилита предназначена для создания новых виртуальных дисков на компьютере. С помощью виртуального диска можно быстро осуществить доступ к любой папке на компьютере или в сети.

Создание дисков происходит с помощью программы subst.exe:
subst [имя диска] [путь к папке]

Удаление виртуального диска:
subst [имя диска] /D
Создавать виртуальный диск при загрузке компьютера

Создавать виртуальный диск при загрузке компьютера

HKCU\Software\Microsoft\Windows\CurrentVersion\Run

STRING VirtualDrive-<Drive:> - значение subst <Drive:> <Path>

Например: VirtualDrive-B: - "subst B: D:\Мои документы\XP Tweaker\XPTweaker\hlp"
Создавать виртуальный диск для всех пользователей компьютера

Создавать виртуальный диск для всех пользователей компьютера

HKLM\Software\Microsoft\Windows\CurrentVersion\Run

STRING VirtualDrive-<Drive:> - значение subst <Drive:> <Path>

Например: VirtualDrive-B: - "subst B: D:\Мои документы\XP Tweaker\XPTweaker\hlp"


Настройки

XP Tweaker - Настройки программы
Настройки программы

Все настройки программы хранятся в разделе реестра

HKEY_CURRENT_USER\Software\DMC Software\XP Tweaker\Options

После отключения опции Сделать главное окно прозрачным, перезапустите программу, чтобы изменения вступили в силу.

Консоль XP Tweaker выводит все изменения реестра в т.ч. и лог чтения значений реестра при необходимости.

Сохранение настроек

Сохранить настройки в файле реестра (*.reg)

Сохраняет настройки в файле *.reg для последующей настройки системы без участия самой программы. Чтобы применить настройки, содержащиеся в файле достаточно открыть его. Возможно, при этом Windows XP спросит подтверждение импортирования.

XP Tweaker сохраняет не все настройки, например, не сохраняются:

    • поддержка/отключение поддержки zip-архивов
    • программы из автозагрузки
    • добавленные контекстные меню Проводника
    • и некоторые другие...